# Elastic Stack

**URL:** https://discuss.elastic.co/c/elastic-stack/81.md?page=299

[Latest](https://discuss.elastic.co/latest.md) · [Categories](https://discuss.elastic.co/categories.md) · [Tags](https://discuss.elastic.co/tags.md)

**Page:** 300

---

## [Filebeat Docker Autodiscovery stopped working when I upgraded to 8.12.0](https://discuss.elastic.co/t/filebeat-docker-autodiscovery-stopped-working-when-i-upgraded-to-8-12-0/353103)

<div class="topic-metadata">

**Author:** [@jerrac](https://discuss.elastic.co/u/jerrac)\
**Replies:** 19\
**Last updated:** [February 23, 2024, 9:00am UTC](https://discuss.elastic.co/t/filebeat-docker-autodiscovery-stopped-working-when-i-upgraded-to-8-12-0/353103 "2024-02-23T09:00:20Z")

</div>

Hey, Last week I was trying to use the logs from my Docker Swarm containers that were supposed to be in my test elasticsearch stack, when I found that said logs were not present. A bit of digging later and I can see tha…

---

## [Cannot create new data stream from auto-create](https://discuss.elastic.co/t/cannot-create-new-data-stream-from-auto-create/353958)

<div class="topic-metadata">

**Author:** [@hti](https://discuss.elastic.co/u/hti)\
**Replies:** 0\
**Last updated:** [February 23, 2024, 8:59am UTC](https://discuss.elastic.co/t/cannot-create-new-data-stream-from-auto-create/353958 "2024-02-23T08:59:28Z")

</div>

Hello, since the last update from 8.10.3 to 8.12.1 we have issues creating new data streams. We do see error messages such as "no such index \[composable template \[logs-cape.\*\] forbids index auto creation\]" The cluster…

---

## [Create a rule / alert using dashboard formula](https://discuss.elastic.co/t/create-a-rule-alert-using-dashboard-formula/353952)

<div class="topic-metadata">

**Author:** [@Samuele\_Lolli](https://discuss.elastic.co/u/Samuele_Lolli)\
**Replies:** 0\
**Last updated:** [February 23, 2024, 8:25am UTC](https://discuss.elastic.co/t/create-a-rule-alert-using-dashboard-formula/353952 "2024-02-23T08:25:58Z")

</div>

Hi, i need to create an alert using the rule page but im not able to replicate the formula that im using on the dashboard. Someone can help me? unique\_count(event.metadata.correlationId, kql=' event.metadata.tracePoint…

---

## [Auto Discovery not Working on Azure kubernetes service](https://discuss.elastic.co/t/auto-discovery-not-working-on-azure-kubernetes-service/353947)

<div class="topic-metadata">

**Author:** [@srinikar87](https://discuss.elastic.co/u/srinikar87)\
**Replies:** 0\
**Last updated:** [February 23, 2024, 6:39am UTC](https://discuss.elastic.co/t/auto-discovery-not-working-on-azure-kubernetes-service/353947 "2024-02-23T06:39:36Z")

</div>

Filebeat autodiscovery not working on AKS cluster failing with below error as soon i include auto discovery \< ax\_events":4096}}},"registrar":{"states":{"cleanup":0,"current":0,"update":51},"writes":{"fail":0,"success":…

---

## [Which connector to use to establish connection via logstash 8.11?](https://discuss.elastic.co/t/which-connector-to-use-to-establish-connection-via-logstash-8-11/352333)

<div class="topic-metadata">

**Author:** [@ALTAMASH80](https://discuss.elastic.co/u/ALTAMASH80)\
**Replies:** 1\
**Last updated:** [February 23, 2024, 6:38am UTC](https://discuss.elastic.co/t/which-connector-to-use-to-establish-connection-via-logstash-8-11/352333 "2024-02-23T06:38:14Z")

</div>

Hi, I've installed Kibana and Elasticsearch and I wanted to insert data in an index via logstash from MySQL. But, the documentation uses JDBC connectors. You guys have an official connector repository which has Mysql an…

---

## [Filebeat fingerprint excessive logs](https://discuss.elastic.co/t/filebeat-fingerprint-excessive-logs/352440)

<div class="topic-metadata">

**Author:** [@kbujold\_wr](https://discuss.elastic.co/u/kbujold_wr)\
**Replies:** 14\
**Last updated:** [February 23, 2024, 6:14am UTC](https://discuss.elastic.co/t/filebeat-fingerprint-excessive-logs/352440 "2024-02-23T06:14:11Z")

</div>

Hi We have turned on fingerprinting in our lab. We see a lot of these logs. Is there a way to disabled those 0 bytes logs? Or make fingerprint ignore those files? {"log.level":"warn","@timestamp":"2024-02-02T18:16:22.…

---

## [Unknown error occurred sending a bulk request to Elasticsearch](https://discuss.elastic.co/t/unknown-error-occurred-sending-a-bulk-request-to-elasticsearch/353920)

<div class="topic-metadata">

**Author:** [@JRicha](https://discuss.elastic.co/u/JRicha)\
**Replies:** 1\
**Last updated:** [February 22, 2024, 10:41pm UTC](https://discuss.elastic.co/t/unknown-error-occurred-sending-a-bulk-request-to-elasticsearch/353920 "2024-02-22T22:41:19Z")

</div>

Hello community, I have found other posts here to be helpful in solving my previous issues so I am hoping that someone can help me resolve this issue. I researched my problem in the community pages and have not found an…

---

## [Transforms - Latest and Pivot](https://discuss.elastic.co/t/transforms-latest-and-pivot/353925)

<div class="topic-metadata">

**Author:** [@erikg](https://discuss.elastic.co/u/erikg)\
**Replies:** 1\
**Last updated:** [February 23, 2024, 3:28am UTC](https://discuss.elastic.co/t/transforms-latest-and-pivot/353925 "2024-02-23T03:28:47Z")

</div>

Hello, I was wondering if its possible to do something like a combination of latest and pivot or maybe more understanding of what I can do with each. So use case: I have status field(keyword) reported for object field…

---

## [Data race condition in automaton queries](https://discuss.elastic.co/t/data-race-condition-in-automaton-queries/353937)

<div class="topic-metadata">

**Author:** [@yfful](https://discuss.elastic.co/u/yfful)\
**Replies:** 0\
**Last updated:** [February 22, 2024, 11:46pm UTC](https://discuss.elastic.co/t/data-race-condition-in-automaton-queries/353937 "2024-02-22T23:46:48Z")

</div>

Hello, In a local unit test involving a runtime field and a regexp query with ES 8.12.1, I have experienced search inconsistencies with the result count. The query shown below uses the script parity which returns even o…

---

## [Do terms queries behave differently with runtime mappings?](https://discuss.elastic.co/t/do-terms-queries-behave-differently-with-runtime-mappings/353931)

<div class="topic-metadata">

**Author:** [@nicole.oresme](https://discuss.elastic.co/u/nicole.oresme)\
**Replies:** 0\
**Last updated:** [February 22, 2024, 9:42pm UTC](https://discuss.elastic.co/t/do-terms-queries-behave-differently-with-runtime-mappings/353931 "2024-02-22T21:42:56Z")

</div>

I have a query: { "query": { "bool": { "filter": \[ { "terms": { "foo": ... (1000 terms) } }, { "terms": { "bar": ... (1000 terms) } } \] } } } which works just fine as is. But if I run those term…

---

## [Passing credentials for S3 snapshot repository in Terraform](https://discuss.elastic.co/t/passing-credentials-for-s3-snapshot-repository-in-terraform/353924)

<div class="topic-metadata">

**Author:** [@acormier-spectrumai](https://discuss.elastic.co/u/acormier-spectrumai)\
**Replies:** 0\
**Last updated:** [February 22, 2024, 8:45pm UTC](https://discuss.elastic.co/t/passing-credentials-for-s3-snapshot-repository-in-terraform/353924 "2024-02-22T20:45:12Z")

</div>

Hello, I am trying to setup a new ELK stack in Terraform, that also includes our configurations/settings/etc. One of the settings I would like to configure is snapshot lifecycle management, and a snapshot repository. I…

---

## [Logstash input with Ruby filter to Opensearch output](https://discuss.elastic.co/t/logstash-input-with-ruby-filter-to-opensearch-output/353635)

<div class="topic-metadata">

**Author:** [@samuelstephens](https://discuss.elastic.co/u/samuelstephens)\
**Replies:** 1\
**Last updated:** [February 20, 2024, 12:15am UTC](https://discuss.elastic.co/t/logstash-input-with-ruby-filter-to-opensearch-output/353635 "2024-02-20T00:15:52Z")

</div>

I have rewritten the Ruby filter mentioned here: The filter now reads as such and I am able to at minimum pass the event to OpenSearch: input: |- http { port =\> 8080 codec =\> "json" filter: |- json { source …

---

## [Kabana pdf reporting error](https://discuss.elastic.co/t/kabana-pdf-reporting-error/353820)

<div class="topic-metadata">

**Author:** [@mst3r25](https://discuss.elastic.co/u/mst3r25)\
**Replies:** 1\
**Last updated:** [February 22, 2024, 7:20pm UTC](https://discuss.elastic.co/t/kabana-pdf-reporting-error/353820 "2024-02-22T19:20:27Z")

</div>

When I try to export a dashboard to pdf I get a "err\_bad\_ssl\_client\_auth\_cert https://{ip}:5601/s/....." This only happens when running pdf reports. All my users and transport connection work fine using SSL. I have a 5 …

---

## [Search for exact value is not having a good score](https://discuss.elastic.co/t/search-for-exact-value-is-not-having-a-good-score/353914)

<div class="topic-metadata">

**Author:** [@tonnyfrancis](https://discuss.elastic.co/u/tonnyfrancis)\
**Replies:** 0\
**Last updated:** [February 22, 2024, 7:05pm UTC](https://discuss.elastic.co/t/search-for-exact-value-is-not-having-a-good-score/353914 "2024-02-22T19:05:12Z")

</div>

When I try to search for a document using an exact value, I notice that the desired document is not being properly classified, even when the search value is identical to that contained in the document. This has a negativ…

---

## [Snapshot doesn't complete with "failed to finalize snapshot"](https://discuss.elastic.co/t/snapshot-doesnt-complete-with-failed-to-finalize-snapshot/352418)

<div class="topic-metadata">

**Author:** [@luana](https://discuss.elastic.co/u/luana)\
**Replies:** 2\
**Last updated:** [February 22, 2024, 5:45pm UTC](https://discuss.elastic.co/t/snapshot-doesnt-complete-with-failed-to-finalize-snapshot/352418 "2024-02-22T17:45:01Z")

</div>

Hi, I'm facing issues to have a snapshot of my cluster completed. For context, this cluster used to have nightly snapshots working as expected until late November 2023, however due to an incorrect setting on beats there…

---

## [Logstash automatic config reload and config.reload.interval (high CPU usage)](https://discuss.elastic.co/t/logstash-automatic-config-reload-and-config-reload-interval-high-cpu-usage/353805)

<div class="topic-metadata">

**Author:** [@Daniel314](https://discuss.elastic.co/u/Daniel314)\
**Replies:** 2\
**Last updated:** [February 22, 2024, 5:35pm UTC](https://discuss.elastic.co/t/logstash-automatic-config-reload-and-config-reload-interval-high-cpu-usage/353805 "2024-02-22T17:35:24Z")

</div>

Hi, I've upgraded my logstash deployments multiple times over the years (starting way back in the 1.x days), and I had set Logstash to check once a minute for config changes (auto-reload) in the logstash.yml file. I re…

---

## [Salesforce Plugin](https://discuss.elastic.co/t/salesforce-plugin/353804)

<div class="topic-metadata">

**Author:** [@kkalwaysok](https://discuss.elastic.co/u/kkalwaysok)\
**Replies:** 3\
**Last updated:** [February 22, 2024, 5:26pm UTC](https://discuss.elastic.co/t/salesforce-plugin/353804 "2024-02-22T17:26:54Z")

</div>

Hi, I'm using salesforce plugin to pull the logs, and it is downloading 6months worth data that is available in Salesforce. Is there a setting that I can use to download logs from specific date? Thanks in advance.

---

## [Gateway timeout while getting the snapshots from Azure storage account](https://discuss.elastic.co/t/gateway-timeout-while-getting-the-snapshots-from-azure-storage-account/352175)

<div class="topic-metadata">

**Author:** [@Milos\_Podunavac](https://discuss.elastic.co/u/Milos_Podunavac)\
**Replies:** 6\
**Last updated:** [February 22, 2024, 3:57pm UTC](https://discuss.elastic.co/t/gateway-timeout-while-getting-the-snapshots-from-azure-storage-account/352175 "2024-02-22T15:57:13Z")

</div>

Hi all, we are using Elastic Stack with Kibana, and we have created restore and backup option in Elastic UI, so we are connected to Azure storage account and we are doing hourly backup every day. Everything was fine unti…

---

## [Scatter Plot in Kibana Dashboard](https://discuss.elastic.co/t/scatter-plot-in-kibana-dashboard/353897)

<div class="topic-metadata">

**Author:** [@robertomzc](https://discuss.elastic.co/u/robertomzc)\
**Replies:** 1\
**Last updated:** [February 22, 2024, 3:42pm UTC](https://discuss.elastic.co/t/scatter-plot-in-kibana-dashboard/353897 "2024-02-22T15:42:32Z")

</div>

Hi all, We have created a dashboard with several plots regarding the status and parameters of a bunch of batteries during their use, charge and discharge. Among other we have the classic lenses line and pie plots, for …

---

## [Keycloak authentifaction failure](https://discuss.elastic.co/t/keycloak-authentifaction-failure/353895)

<div class="topic-metadata">

**Author:** [@bouzir22](https://discuss.elastic.co/u/bouzir22)\
**Replies:** 6\
**Last updated:** [February 22, 2024, 3:07pm UTC](https://discuss.elastic.co/t/keycloak-authentifaction-failure/353895 "2024-02-22T15:07:41Z")

</div>

kibana : elasticsearch exception:\[Authentication to realm oidc1 failed - Failed to authenticate user with OpenID Connect (Caused by org.elasticsearch.ElasticsearchSecurityException: Failed to parse or validate the ID…

---

## [ElasticSearch 8.12.1 with HighLevelRestClient/JavaClient not working](https://discuss.elastic.co/t/elasticsearch-8-12-1-with-highlevelrestclient-javaclient-not-working/353888)

<div class="topic-metadata">

**Author:** [@frank-montyne](https://discuss.elastic.co/u/frank-montyne)\
**Replies:** 2\
**Last updated:** [February 22, 2024, 3:05pm UTC](https://discuss.elastic.co/t/elasticsearch-8-12-1-with-highlevelrestclient-javaclient-not-working/353888 "2024-02-22T15:05:36Z")

</div>

I'm trying to use Elasticsearch 8.12.1 with the 7.17.18 HighLevelRestClient and the new 8.12.1 JavaClient. I saw that for all the org.elasticsearch and org.elasticsearch.client artifacts there are now 8.12.1 versions ex…

---

## [Add an existing index as a backing index for a data stream](https://discuss.elastic.co/t/add-an-existing-index-as-a-backing-index-for-a-data-stream/353892)

<div class="topic-metadata">

**Author:** [@christian.k](https://discuss.elastic.co/u/christian.k)\
**Replies:** 0\
**Last updated:** [February 22, 2024, 2:25pm UTC](https://discuss.elastic.co/t/add-an-existing-index-as-a-backing-index-for-a-data-stream/353892 "2024-02-22T14:25:00Z")

</div>

The documentation for adding an existing index as a backing index for a data stream warns that this is an expert-level API and "can potentially result in improper data stream behavior" (see Modify data streams API | Elas…

---

## [Async Search - How to get list of IDs?](https://discuss.elastic.co/t/async-search-how-to-get-list-of-ids/353660)

<div class="topic-metadata">

**Author:** [@BBQigniter](https://discuss.elastic.co/u/BBQigniter)\
**Replies:** 2\
**Last updated:** [February 22, 2024, 2:10pm UTC](https://discuss.elastic.co/t/async-search-how-to-get-list-of-ids/353660 "2024-02-22T14:10:23Z")

</div>

Do I see that correctly that there is currently NO chance to retrieve an async-search ID if someone missed to save it?

---

## [Logstash http poller input not able to dynamically update the current date](https://discuss.elastic.co/t/logstash-http-poller-input-not-able-to-dynamically-update-the-current-date/353890)

<div class="topic-metadata">

**Author:** [@rajatbhardwaj1393](https://discuss.elastic.co/u/rajatbhardwaj1393)\
**Replies:** 2\
**Last updated:** [February 22, 2024, 1:56pm UTC](https://discuss.elastic.co/t/logstash-http-poller-input-not-able-to-dynamically-update-the-current-date/353890 "2024-02-22T13:56:02Z")

</div>

trying to update dynamically date in post request in http\_poller. Its not updating. Using below code "range": { "ProjectHistories.ProjectHistoryModified": { "gte": "%{+yyyy-MM-dd'T'00:00:00}", "lte": "%{+yyyy-MM-dd'…

---

## [Changing Time Zone for Elastic](https://discuss.elastic.co/t/changing-time-zone-for-elastic/352761)

<div class="topic-metadata">

**Author:** [@ruslan.yeraliyev](https://discuss.elastic.co/u/ruslan.yeraliyev)\
**Replies:** 8\
**Last updated:** [February 22, 2024, 12:49pm UTC](https://discuss.elastic.co/t/changing-time-zone-for-elastic/352761 "2024-02-22T12:49:47Z")

</div>

Hi, All. Who knows how Kafka will behave when changing time zones? We are soon switching from UTC +6 to UTC +5. Will simply changing the settings in NTP or Chrony resolve this issue? Perhaps someone has practical experie…

---

## [Around 1500 indexes to snapshot and restore in another cluster. How would you do it?](https://discuss.elastic.co/t/around-1500-indexes-to-snapshot-and-restore-in-another-cluster-how-would-you-do-it/353711)

<div class="topic-metadata">

**Author:** [@Joao\_Barreto](https://discuss.elastic.co/u/Joao_Barreto)\
**Replies:** 8\
**Last updated:** [February 22, 2024, 12:28pm UTC](https://discuss.elastic.co/t/around-1500-indexes-to-snapshot-and-restore-in-another-cluster-how-would-you-do-it/353711 "2024-02-22T12:28:44Z")

</div>

Dear community members, I recently encountered a challenge involving the migration of an entire cluster to a different version of Elasticsearch, specifically one that includes archive indexes. A few days ago, I posted …

---

## [Getting 400 Error for the Elastic Search](https://discuss.elastic.co/t/getting-400-error-for-the-elastic-search/353883)

<div class="topic-metadata">

**Author:** [@syedimran7861](https://discuss.elastic.co/u/syedimran7861)\
**Replies:** 0\
**Last updated:** [February 22, 2024, 12:21pm UTC](https://discuss.elastic.co/t/getting-400-error-for-the-elastic-search/353883 "2024-02-22T12:21:32Z")

</div>

failed to install template message= got response code '400' contacting elasticsearch Configuration { "order": 1, "index\_patterns": \[ "log-default-\*", "log-http-\*" \], "settings": { "number\_of\_shards"…

---

## [How do i output kubernetes Logs to logstash](https://discuss.elastic.co/t/how-do-i-output-kubernetes-logs-to-logstash/353880)

<div class="topic-metadata">

**Author:** [@ataylor](https://discuss.elastic.co/u/ataylor)\
**Replies:** 0\
**Last updated:** [February 22, 2024, 11:36am UTC](https://discuss.elastic.co/t/how-do-i-output-kubernetes-logs-to-logstash/353880 "2024-02-22T11:36:22Z")

</div>

Ok So for Context, we have a on prem ELK stack, where we ship via filebeats installed locally, to Logstash, then onto our elasticsearch cluster. I have now been asked by a stakeholder to help them do the same but from a…

---

## [I cannot transport data between two elasticsearch nodes](https://discuss.elastic.co/t/i-cannot-transport-data-between-two-elasticsearch-nodes/353670)

<div class="topic-metadata">

**Author:** [@quanganhhnv](https://discuss.elastic.co/u/quanganhhnv)\
**Replies:** 13\
**Last updated:** [February 22, 2024, 10:41am UTC](https://discuss.elastic.co/t/i-cannot-transport-data-between-two-elasticsearch-nodes/353670 "2024-02-22T10:41:24Z")

</div>

I have two machines using elasticSearch, each machine I have the following configuration set Machine 1 cluster.name: NDC node.name: node-1 node.roles: \[ master, data \] network.host: 30.30.30.65 http.port: 9200 discover…

---

## [Elasticsearch snapshot and recovery](https://discuss.elastic.co/t/elasticsearch-snapshot-and-recovery/353668)

<div class="topic-metadata">

**Author:** [@tykarthick](https://discuss.elastic.co/u/tykarthick)\
**Replies:** 5\
**Last updated:** [February 22, 2024, 10:20am UTC](https://discuss.elastic.co/t/elasticsearch-snapshot-and-recovery/353668 "2024-02-22T10:20:12Z")

</div>

Hi Team, Am using Elasticsearch three node cluster with version 8.6.2 and hosted on a Linux environment. Doing a POC in Snapshot and Recovery and external NFS storage is configured to store the snapshots. The NFS repo i…

[Previous page](https://discuss.elastic.co/c/elastic-stack/81.md?page=298)

[Next page](https://discuss.elastic.co/c/elastic-stack/81.md?page=300)
