# Elastic Stack

**URL:** https://discuss.elastic.co/c/elastic-stack/81.md?page=322

[Latest](https://discuss.elastic.co/latest.md) · [Categories](https://discuss.elastic.co/categories.md) · [Tags](https://discuss.elastic.co/tags.md)

**Page:** 323

---

## [My Agent not send Logs, Kibana Healthy Green](https://discuss.elastic.co/t/my-agent-not-send-logs-kibana-healthy-green/351600)

<div class="topic-metadata">

**Author:** [@aguskhohar](https://discuss.elastic.co/u/aguskhohar)\
**Replies:** 3\
**Last updated:** [January 26, 2024, 1:10pm UTC](https://discuss.elastic.co/t/my-agent-not-send-logs-kibana-healthy-green/351600 "2024-01-26T13:10:40Z")

</div>

Hi Guys, Could you please to help me, my kibana is green but my agent not send log. fyi, my elastic : http://localhost:9200 my kibana : http://10.xxx.xxx.xxx:5601 my fleet server : http://10.xxx.xxx.xxx:8220

---

## [How to create an API Key with current user credentials?](https://discuss.elastic.co/t/how-to-create-an-api-key-with-current-user-credentials/351876)

<div class="topic-metadata">

**Author:** [@cyrildaniel](https://discuss.elastic.co/u/cyrildaniel)\
**Replies:** 0\
**Last updated:** [January 26, 2024, 12:47pm UTC](https://discuss.elastic.co/t/how-to-create-an-api-key-with-current-user-credentials/351876 "2024-01-26T12:47:00Z")

</div>

Hey, I would like to create an API Key on the ui/server side of my plugin without having to pass any credentials/authorization. I would like to create an API Key based on the credentials that user has input while loadin…

---

## [Why \_grokparsefailure?](https://discuss.elastic.co/t/why-grokparsefailure/351859)

<div class="topic-metadata">

**Author:** [@emoxam](https://discuss.elastic.co/u/emoxam)\
**Replies:** 5\
**Last updated:** [January 26, 2024, 12:38pm UTC](https://discuss.elastic.co/t/why-grokparsefailure/351859 "2024-01-26T12:38:14Z")

</div>

Part of a config filter { if \[message\] =~ /actions/ or \[message\] =~ /172\\.16\\.10\\.78/ or \[message\] =~ /172\\.16\\.10\\.77/ { grok { match =\> \[ "message", "%{GREEDYDATA:timestamp}%{LOGLEVEL:level}%{GR…

---

## [Bucket script aggregation, do not return parameter values](https://discuss.elastic.co/t/bucket-script-aggregation-do-not-return-parameter-values/351872)

<div class="topic-metadata">

**Author:** [@Mert\_Uygur](https://discuss.elastic.co/u/Mert_Uygur)\
**Replies:** 0\
**Last updated:** [January 26, 2024, 11:26am UTC](https://discuss.elastic.co/t/bucket-script-aggregation-do-not-return-parameter-values/351872 "2024-01-26T11:26:23Z")

</div>

Hi, I am running Elasticsearch version 7.10, and I use Elasticsearch Java Client version 8. I basically run some aggregations to calculate a bucket script. I have defined scripts on elasticsearch, and use them in my requ…

---

## [Shrink operation in ILM is unusable when same\_shard is set in multinode cluster](https://discuss.elastic.co/t/shrink-operation-in-ilm-is-unusable-when-same-shard-is-set-in-multinode-cluster/351869)

<div class="topic-metadata">

**Author:** [@john90](https://discuss.elastic.co/u/john90)\
**Replies:** 3\
**Last updated:** [January 26, 2024, 11:45am UTC](https://discuss.elastic.co/t/shrink-operation-in-ilm-is-unusable-when-same-shard-is-set-in-multinode-cluster/351869 "2024-01-26T11:45:41Z")

</div>

Hi, I am trying to find out if this is really the case: shrink operation via API or ILM is unusable or at least unreliable when when both these conditions apply: cluster.routing.allocation.same\_shard.host is set to tru…

---

## [FSCrawler - Folder index is not getting created in the latest version](https://discuss.elastic.co/t/fscrawler-folder-index-is-not-getting-created-in-the-latest-version/351544)

<div class="topic-metadata">

**Author:** [@kamalsharma](https://discuss.elastic.co/u/kamalsharma)\
**Replies:** 8\
**Last updated:** [January 26, 2024, 9:46am UTC](https://discuss.elastic.co/t/fscrawler-folder-index-is-not-getting-created-in-the-latest-version/351544 "2024-01-26T09:46:28Z")

</div>

The index name is fs-test-001 (Example) in the \_settings.json file. After running the FsCrawler, Template is automatically added in the Elastic. I am able to see the Templates for the index as well as for the folders alo…

---

## [How to invoke custom rescorer plugin using elasticsearch-java 8 client](https://discuss.elastic.co/t/how-to-invoke-custom-rescorer-plugin-using-elasticsearch-java-8-client/351868)

<div class="topic-metadata">

**Author:** [@baji](https://discuss.elastic.co/u/baji)\
**Replies:** 0\
**Last updated:** [January 26, 2024, 9:27am UTC](https://discuss.elastic.co/t/how-to-invoke-custom-rescorer-plugin-using-elasticsearch-java-8-client/351868 "2024-01-26T09:27:49Z")

</div>

Hi, I have migrated a custom rescorer plugin from Elasticsearch version 7 to 8. I can invoke the plugin using the following request. However, I am unable to generate a similar request using elasticsearch-java 8.10.4. I …

---

## [Failed to install template {:message=\>"Got response code '400' contacting Elasticsearch at URL 'http://x.x.x.x:9200/\_template/ecs-logstash'",](https://discuss.elastic.co/t/failed-to-install-template-message-got-response-code-400-contacting-elasticsearch-at-url-http-x-x-x-x-9200-template-ecs-logstash/351578)

<div class="topic-metadata">

**Author:** [@sunnysigara](https://discuss.elastic.co/u/sunnysigara)\
**Replies:** 5\
**Last updated:** [January 26, 2024, 7:13am UTC](https://discuss.elastic.co/t/failed-to-install-template-message-got-response-code-400-contacting-elasticsearch-at-url-http-x-x-x-x-9200-template-ecs-logstash/351578 "2024-01-26T07:13:27Z")

</div>

Using a default mapping template {:es\_version=\>7, :ecs\_compatibility=\>:v8} gives me this error, \[2024-01-23T02:24:07,381\]\[INFO \]\[logstash.outputs.elasticsearch\]\[main\] Elasticsearch version determined (7.13.3) {:es\_versi…

---

## [When kafka broker timeout ,my filebeat always retrying](https://discuss.elastic.co/t/when-kafka-broker-timeout-my-filebeat-always-retrying/351814)

<div class="topic-metadata">

**Author:** [@zhaoting1667](https://discuss.elastic.co/u/zhaoting1667)\
**Replies:** 2\
**Last updated:** [January 26, 2024, 7:03am UTC](https://discuss.elastic.co/t/when-kafka-broker-timeout-my-filebeat-always-retrying/351814 "2024-01-26T07:03:07Z")

</div>

my filebeat version 6.4.0 (amd64), libbeat 6.4.0 when kafka broker timeout ,my filebeat always retrying, don't put log,util restart filebeat,Please help me take a look。 filebeat log is this.....2024-01-23T20:38:21.439…

---

## [I have installed Elasticsearch 7.17.17 version. i am doing semantic search, but at final search it give me the error which is give below:BadRequestError(400, 'illegal\_argument\_exception', 'Invalid type: expecting \[\_doc\] but got \[\_knn\_search\]')](https://discuss.elastic.co/t/i-have-installed-elasticsearch-7-17-17-version-i-am-doing-semantic-search-but-at-final-search-it-give-me-the-error-which-is-give-below-badrequesterror-400-illegal-argument-exception-invalid-type-expecting-doc-but-got-knn-search/351853)

<div class="topic-metadata">

**Author:** [@Muhammad\_Adnan1](https://discuss.elastic.co/u/Muhammad_Adnan1)\
**Replies:** 2\
**Last updated:** [January 26, 2024, 6:46am UTC](https://discuss.elastic.co/t/i-have-installed-elasticsearch-7-17-17-version-i-am-doing-semantic-search-but-at-final-search-it-give-me-the-error-which-is-give-below-badrequesterror-400-illegal-argument-exception-invalid-type-expecting-doc-but-got-knn-search/351853 "2024-01-26T06:46:07Z")

</div>

BadRequestError(400, 'illegal\_argument\_exception', 'Invalid type: expecting \[\_doc\] but got \[\_knn\_search\]')

---

## [Looking for advice on a use case for NetFlow](https://discuss.elastic.co/t/looking-for-advice-on-a-use-case-for-netflow/351422)

<div class="topic-metadata">

**Author:** [@tonitones](https://discuss.elastic.co/u/tonitones)\
**Replies:** 3\
**Last updated:** [January 26, 2024, 2:47am UTC](https://discuss.elastic.co/t/looking-for-advice-on-a-use-case-for-netflow/351422 "2024-01-26T02:47:10Z")

</div>

Hello everyone from the elastic community! This will be my first topic here. Hoping to get some insights from everyone. I am very new to elastic. I was able to install and run elk stack on docker, thanks to the official…

---

## [Unable to Set UP TLS for Kibana](https://discuss.elastic.co/t/unable-to-set-up-tls-for-kibana/351380)

<div class="topic-metadata">

**Author:** [@audric\_w](https://discuss.elastic.co/u/audric_w)\
**Replies:** 2\
**Last updated:** [January 26, 2024, 2:19am UTC](https://discuss.elastic.co/t/unable-to-set-up-tls-for-kibana/351380 "2024-01-26T02:19:27Z")

</div>

Hi, I've encountered a problem when trying to disable TLSv1.1 for Kibana using the command below: server.ssl.supportedProtocols: "TLSv1.2" However, after adding that command, the Kibana cannot be started: Jan 19 03:3…

---

## [Maintaining @timestamp order of docs when using the reindex api](https://discuss.elastic.co/t/maintaining-timestamp-order-of-docs-when-using-the-reindex-api/351318)

<div class="topic-metadata">

**Author:** [@petlit2049](https://discuss.elastic.co/u/petlit2049)\
**Replies:** 1\
**Last updated:** [January 26, 2024, 1:36am UTC](https://discuss.elastic.co/t/maintaining-timestamp-order-of-docs-when-using-the-reindex-api/351318 "2024-01-26T01:36:06Z")

</div>

There's a deprecated feature in the reindex api which makes (made?) it possible to maintain the timestamp order between docs being reindexed using the reindex api. However, the documentation states that this is a depreca…

---

## [Configuring Input file on Windows to get Output in 2024](https://discuss.elastic.co/t/configuring-input-file-on-windows-to-get-output-in-2024/351839)

<div class="topic-metadata">

**Author:** [@Will\_J](https://discuss.elastic.co/u/Will_J)\
**Replies:** 2\
**Last updated:** [January 25, 2024, 11:10pm UTC](https://discuss.elastic.co/t/configuring-input-file-on-windows-to-get-output-in-2024/351839 "2024-01-25T23:10:18Z")

</div>

I am trying a simple file input / output example. Using following conf file at the C:/logstash-8.11.3-windows-x86\_64/logstash-8.11.3/config/file-pipeline.conf input { file { path =\> \["C:/logstash-8.11.3-wind…

---

## [Basic Setup failures joining an existing cluster](https://discuss.elastic.co/t/basic-setup-failures-joining-an-existing-cluster/351830)

<div class="topic-metadata">

**Author:** [@bryanrood](https://discuss.elastic.co/u/bryanrood)\
**Replies:** 0\
**Last updated:** [January 25, 2024, 7:53pm UTC](https://discuss.elastic.co/t/basic-setup-failures-joining-an-existing-cluster/351830 "2024-01-25T19:53:41Z")

</div>

Hi there, I have been beating my head against a tree trying to get nodes added to my new ES cluster. I'm trying to build a 6 node ES cluster. I got the first node working and I'm trying to add the second node. I can ge…

---

## [How to loop the jdbc streaming filter by pass the index of array of object?](https://discuss.elastic.co/t/how-to-loop-the-jdbc-streaming-filter-by-pass-the-index-of-array-of-object/351784)

<div class="topic-metadata">

**Author:** [@kishorkumar](https://discuss.elastic.co/u/kishorkumar)\
**Replies:** 1\
**Last updated:** [January 25, 2024, 5:59pm UTC](https://discuss.elastic.co/t/how-to-loop-the-jdbc-streaming-filter-by-pass-the-index-of-array-of-object/351784 "2024-01-25T17:59:31Z")

</div>

So here is the usecase i have the "mainSKU": \[ { "id": 102, }, { "id": 101, }, { "id": 100, } \] like this and i am using jdb\_streaming and every mainSKU has 3 to 4 SKU in order to that i need to loop get …

---

## [Sql escape character in logstash](https://discuss.elastic.co/t/sql-escape-character-in-logstash/351800)

<div class="topic-metadata">

**Author:** [@Rakesh\_Verma](https://discuss.elastic.co/u/Rakesh_Verma)\
**Replies:** 2\
**Last updated:** [January 25, 2024, 5:51pm UTC](https://discuss.elastic.co/t/sql-escape-character-in-logstash/351800 "2024-01-25T17:51:31Z")

</div>

I am getting below error in following sql . SELECT HA.HotelID AS HotelCode,'\[' + STUFF((SELECT ',' + '{"AmenityId": ' + CAST(HA\_inner.AmenityId AS VARCHAR(10)) + ', "AmenityName": ' + QUOTENAME(HAT\_inner.AmenityName, '"…

---

## [How to test or check Connection of my Java application to Elasticsearch?](https://discuss.elastic.co/t/how-to-test-or-check-connection-of-my-java-application-to-elasticsearch/351821)

<div class="topic-metadata">

**Author:** [@unknownuser](https://discuss.elastic.co/u/unknownuser)\
**Replies:** 1\
**Last updated:** [January 25, 2024, 5:43pm UTC](https://discuss.elastic.co/t/how-to-test-or-check-connection-of-my-java-application-to-elasticsearch/351821 "2024-01-25T17:43:45Z")

</div>

Hi Everyone! :slight\_smile: Can you help me to know how to check the connection between my java application to Elasticsearch? Btw, I am using the Elasticsearch version 8.11. I see the documentation Connecting | Elastics…

---

## [Anonymous Viewer unable to see links panel](https://discuss.elastic.co/t/anonymous-viewer-unable-to-see-links-panel/351650)

<div class="topic-metadata">

**Author:** [@A\_Sto](https://discuss.elastic.co/u/A_Sto)\
**Replies:** 3\
**Last updated:** [January 25, 2024, 5:18pm UTC](https://discuss.elastic.co/t/anonymous-viewer-unable-to-see-links-panel/351650 "2024-01-25T17:18:16Z")

</div>

I recently updated my dashboards with a links panel. I have anonymous viewing set up with read permissions on a subset of dashboards to enable users without explicit logins to view some basic dashboards. The links panels…

---

## [Elastic artifacts repository missing last release](https://discuss.elastic.co/t/elastic-artifacts-repository-missing-last-release/350367)

<div class="topic-metadata">

**Author:** [@nisow95612](https://discuss.elastic.co/u/nisow95612)\
**Replies:** 3\
**Last updated:** [January 25, 2024, 4:05pm UTC](https://discuss.elastic.co/t/elastic-artifacts-repository-missing-last-release/350367 "2024-01-25T16:05:49Z")

</div>

Hello, I again notice new elastic version is released - Release notes | Elasticsearch Guide \[7.17\] | Elastic, now also with security fixes (Elasticsearch 8.11.2, 7.17.16 Security Update (ESA-2023-29)), but it is not ava…

---

## [How often a shard is actually refreshing](https://discuss.elastic.co/t/how-often-a-shard-is-actually-refreshing/351801)

<div class="topic-metadata">

**Author:** [@ktech007](https://discuss.elastic.co/u/ktech007)\
**Replies:** 3\
**Last updated:** [January 25, 2024, 2:31pm UTC](https://discuss.elastic.co/t/how-often-a-shard-is-actually-refreshing/351801 "2024-01-25T14:31:31Z")

</div>

Hi, I am trying to better understand how often a shard is refreshed in comparison to the refresh interval. For some context: We are trying to calculate the indexing lag in our indexing pipeline and refresh interval is …

---

## [Terms aggregation is slow, setting eager\_global\_ordinals to True did not work](https://discuss.elastic.co/t/terms-aggregation-is-slow-setting-eager-global-ordinals-to-true-did-not-work/350550)

<div class="topic-metadata">

**Author:** [@rupesh.yadav](https://discuss.elastic.co/u/rupesh.yadav)\
**Replies:** 1\
**Last updated:** [January 25, 2024, 2:10pm UTC](https://discuss.elastic.co/t/terms-aggregation-is-slow-setting-eager-global-ordinals-to-true-did-not-work/350550 "2024-01-25T14:10:56Z")

</div>

I am quite new to ES so I might not know a few things. I have an Elasticsearch query\_string query and with that I have an aggregate query, I am trying to get the results as fast as I can. Currently, it is taking 20s to 2…

---

## [Can ELSER be used with languages other than English](https://discuss.elastic.co/t/can-elser-be-used-with-languages-other-than-english/351186)

<div class="topic-metadata">

**Author:** [@Chenko](https://discuss.elastic.co/u/Chenko)\
**Replies:** 11\
**Last updated:** [January 25, 2024, 1:02pm UTC](https://discuss.elastic.co/t/can-elser-be-used-with-languages-other-than-english/351186 "2024-01-25T13:02:19Z")

</div>

Hello, I'm posting to gather insights about ELSER's language capabilities, particularly its support for languages other than English. My interest lies in understanding how well ELSER handles the following languages: D…

---

## [Import Emails into Elasticsearch using Logstash IMAP Input](https://discuss.elastic.co/t/import-emails-into-elasticsearch-using-logstash-imap-input/351798)

<div class="topic-metadata">

**Author:** [@frank\_esg](https://discuss.elastic.co/u/frank_esg)\
**Replies:** 0\
**Last updated:** [January 25, 2024, 12:38pm UTC](https://discuss.elastic.co/t/import-emails-into-elasticsearch-using-logstash-imap-input/351798 "2024-01-25T12:38:01Z")

</div>

Hi, we would like to import Emails into Elasticsearch to have a kind of Email Archive. We started with Logstash and the IMAP Input plugin. But it turned out that this plugin was not updated in the last years and has se…

---

## [Failing to match "53...\\n" with "\[0-9\]\[0-9\]\\\\.\\\\.\\\\.\\n?" in Discover filter. Help?](https://discuss.elastic.co/t/failing-to-match-53-n-with-0-9-0-9-n-in-discover-filter-help/351104)

<div class="topic-metadata">

**Author:** [@timbav](https://discuss.elastic.co/u/timbav)\
**Replies:** 7\
**Last updated:** [January 25, 2024, 12:02pm UTC](https://discuss.elastic.co/t/failing-to-match-53-n-with-0-9-0-9-n-in-discover-filter-help/351104 "2024-01-25T12:02:35Z")

</div>

I'm on v 7.10.0 of Kibana. My logs are line-based Json, and the JSON looks like this: {"dlog":{ ..., "line":"53...\\n", ...}, ...} Those dots are three . characters, not a unicode ellipsis: 0000000 , " l i…

---

## [Ingest pipeline ELSER embedding fails with more than 1 ML node](https://discuss.elastic.co/t/ingest-pipeline-elser-embedding-fails-with-more-than-1-ml-node/351673)

<div class="topic-metadata">

**Author:** [@Rakesh\_Nayak](https://discuss.elastic.co/u/Rakesh_Nayak)\
**Replies:** 1\
**Last updated:** [January 25, 2024, 11:25am UTC](https://discuss.elastic.co/t/ingest-pipeline-elser-embedding-fails-with-more-than-1-ml-node/351673 "2024-01-25T11:25:01Z")

</div>

Hello Team, We can create embeddings using a pipeline with 1 ML node. But, when we add another node, it seems like none of the documents gets ingested through the pipeline. Attached is the reference. note: using simula…

---

## [Elk 7.5 How to show all indexes having storage\_term as cold](https://discuss.elastic.co/t/elk-7-5-how-to-show-all-indexes-having-storage-term-as-cold/351377)

<div class="topic-metadata">

**Author:** [@mpniel](https://discuss.elastic.co/u/mpniel)\
**Replies:** 5\
**Last updated:** [January 25, 2024, 11:16am UTC](https://discuss.elastic.co/t/elk-7-5-how-to-show-all-indexes-having-storage-term-as-cold/351377 "2024-01-25T11:16:38Z")

</div>

How to show all indexes having storage\_term as cold? Why are there indexes with this cold parameter?

---

## [Delete index after 1 day if empty and after n days if not empty](https://discuss.elastic.co/t/delete-index-after-1-day-if-empty-and-after-n-days-if-not-empty/351741)

<div class="topic-metadata">

**Author:** [@elastico23](https://discuss.elastic.co/u/elastico23)\
**Replies:** 2\
**Last updated:** [January 25, 2024, 9:44am UTC](https://discuss.elastic.co/t/delete-index-after-1-day-if-empty-and-after-n-days-if-not-empty/351741 "2024-01-25T09:44:55Z")

</div>

Hi, we use daily indices and currently use an ILM policy to delete indices after n days. However, we have some indices each day that don't end up having documents and would like to delete those after 1 day instead of kee…

---

## [How to convert HEXA field into ASCII field through logstash pipeline](https://discuss.elastic.co/t/how-to-convert-hexa-field-into-ascii-field-through-logstash-pipeline/351771)

<div class="topic-metadata">

**Author:** [@upreddy](https://discuss.elastic.co/u/upreddy)\
**Replies:** 1\
**Last updated:** [January 25, 2024, 9:44am UTC](https://discuss.elastic.co/t/how-to-convert-hexa-field-into-ascii-field-through-logstash-pipeline/351771 "2024-01-25T09:44:11Z")

</div>

Hi All, we are getting one filed in the form of hexa i need to convert that filed into ASCII through logstash pipeline. Could you please guide me on this? eg:- "abc": "8a64756c656173654368616e" I need to convert "abc"…

---

## [Filebeat CEL Input: how to pass headers in request?](https://discuss.elastic.co/t/filebeat-cel-input-how-to-pass-headers-in-request/351746)

<div class="topic-metadata">

**Author:** [@kelk](https://discuss.elastic.co/u/kelk)\
**Replies:** 2\
**Last updated:** [January 25, 2024, 7:56am UTC](https://discuss.elastic.co/t/filebeat-cel-input-how-to-pass-headers-in-request/351746 "2024-01-25T07:56:27Z")

</div>

I'm trying to pull from an API which has got Digest authentication ONLY enabled. Hence cannot use httpjson But in input.type of cel, how do I pass request headers like 'Content-Type: application/json' etc? Below is my …

[Previous page](https://discuss.elastic.co/c/elastic-stack/81.md?page=321)

[Next page](https://discuss.elastic.co/c/elastic-stack/81.md?page=323)
