# Elastic Stack

**URL:** https://discuss.elastic.co/c/elastic-stack/81.md?page=586

[Latest](https://discuss.elastic.co/latest.md) · [Categories](https://discuss.elastic.co/categories.md) · [Tags](https://discuss.elastic.co/tags.md)

**Page:** 587

---

## [Connect elastic search to external react plugin](https://discuss.elastic.co/t/connect-elastic-search-to-external-react-plugin/328929)

<div class="topic-metadata">

**Author:** [@anik-27](https://discuss.elastic.co/u/anik-27)\
**Replies:** 2\
**Last updated:** [March 30, 2023, 11:56am UTC](https://discuss.elastic.co/t/connect-elastic-search-to-external-react-plugin/328929 "2023-03-30T11:56:29Z")

</div>

Hello there ! Is it possible to connect Elasticsearch to the external plugin created in react and use the data stored in indices without using node.js ?

---

## [External plugin connectivity with Elastic search](https://discuss.elastic.co/t/external-plugin-connectivity-with-elastic-search/328552)

<div class="topic-metadata">

**Author:** [@anik-27](https://discuss.elastic.co/u/anik-27)\
**Replies:** 4\
**Last updated:** [March 30, 2023, 11:41am UTC](https://discuss.elastic.co/t/external-plugin-connectivity-with-elastic-search/328552 "2023-03-30T11:41:38Z")

</div>

Hello there ! I have created an external plugin using React in Kibana Now I want to connect that to the Elastic search and use the data stored in one of the index. What are the possible options to achieve this ?

---

## [Elasticsearch Python Client's LicenseClient.post fails](https://discuss.elastic.co/t/elasticsearch-python-clients-licenseclient-post-fails/328850)

<div class="topic-metadata">

**Author:** [@kbujold\_wr](https://discuss.elastic.co/u/kbujold_wr)\
**Replies:** 1\
**Last updated:** [March 30, 2023, 11:33am UTC](https://discuss.elastic.co/t/elasticsearch-python-clients-licenseclient-post-fails/328850 "2023-03-30T11:33:32Z")

</div>

Hi, We have upgrade from 7.17.1 to 8.6.2. We are using the Elasticsearch Python Client. We are using LicenseClient.post which was working in 7.17.1 but now is failing with 8.6.2. I get this error from the client ApiEr…

---

## [Facing issue while inserting data into the index](https://discuss.elastic.co/t/facing-issue-while-inserting-data-into-the-index/328917)

<div class="topic-metadata">

**Author:** [@Balraj\_Periasamy](https://discuss.elastic.co/u/Balraj_Periasamy)\
**Replies:** 7\
**Last updated:** [March 30, 2023, 11:04am UTC](https://discuss.elastic.co/t/facing-issue-while-inserting-data-into-the-index/328917 "2023-03-30T11:04:08Z")

</div>

Hi, I am facing issue while inserting the data into Elasticsearch. All data is going to Elastic queue and its taking time to insert the data into index. I am using Elasticsearch docker image

---

## [Metricbeat configuration for custom application](https://discuss.elastic.co/t/metricbeat-configuration-for-custom-application/328925)

<div class="topic-metadata">

**Author:** [@Abdul\_Ahad](https://discuss.elastic.co/u/Abdul_Ahad)\
**Replies:** 0\
**Last updated:** [March 30, 2023, 10:48am UTC](https://discuss.elastic.co/t/metricbeat-configuration-for-custom-application/328925 "2023-03-30T10:48:08Z")

</div>

Hi Team, We got an application deployed in Openshift which got a /metrics end point. Could you please help on how to configure metricbeat to push the metrics from this application to elasticsearch. Currently I am able t…

---

## [Required Elastic Query with having Clause in Aggregation](https://discuss.elastic.co/t/required-elastic-query-with-having-clause-in-aggregation/328920)

<div class="topic-metadata">

**Author:** [@Sunny\_Gupta](https://discuss.elastic.co/u/Sunny_Gupta)\
**Replies:** 1\
**Last updated:** [March 30, 2023, 9:57am UTC](https://discuss.elastic.co/t/required-elastic-query-with-having-clause-in-aggregation/328920 "2023-03-30T09:57:46Z")

</div>

If Have One index having records with Properties Email and Event We have different Events like Submitted, Delivered,Bounce etc. I want to Get those record that available in Submitted only. Means If any Email has to de…

---

## [Negative cluster hash](https://discuss.elastic.co/t/negative-cluster-hash/328912)

<div class="topic-metadata">

**Author:** [@SteelDi](https://discuss.elastic.co/u/SteelDi)\
**Replies:** 0\
**Last updated:** [March 30, 2023, 9:23am UTC](https://discuss.elastic.co/t/negative-cluster-hash/328912 "2023-03-30T09:23:05Z")

</div>

Hello. After i moved elasticsearch from docker to k8s helm chart, i getiing many emails from watcher with node was changed alerts. Is it normal then i see negative sluster hash? "\_score": null, …

---

## [Trying to configure the Watcher within the ELK](https://discuss.elastic.co/t/trying-to-configure-the-watcher-within-the-elk/328801)

<div class="topic-metadata">

**Author:** [@ashwin2610](https://discuss.elastic.co/u/ashwin2610)\
**Replies:** 3\
**Last updated:** [March 30, 2023, 9:09am UTC](https://discuss.elastic.co/t/trying-to-configure-the-watcher-within-the-elk/328801 "2023-03-30T09:09:50Z")

</div>

Version: 8.6.2 Trying to configure the o365 password within keystore using the below command as defined in the doc: bin/elasticsearch-keystore add xpack.notification.email.account.exchange\_account.smtp.secure\_password …

---

## [Kibana Dashboards giving 403 error in dashboards when more visualizations added in 8.6.2 version](https://discuss.elastic.co/t/kibana-dashboards-giving-403-error-in-dashboards-when-more-visualizations-added-in-8-6-2-version/328883)

<div class="topic-metadata">

**Author:** [@Sandeep\_Raju](https://discuss.elastic.co/u/Sandeep_Raju)\
**Replies:** 2\
**Last updated:** [March 30, 2023, 7:30am UTC](https://discuss.elastic.co/t/kibana-dashboards-giving-403-error-in-dashboards-when-more-visualizations-added-in-8-6-2-version/328883 "2023-03-30T07:30:28Z")

</div>

Hi all, I recently migrated my kibana dashboards from 7.9 to 7.17 and then to 8.6.2 However i'm getting an error in my dashboards as shown below. Apparently this error appears when there are approximately 20 visualiza…

---

## [Kibana not running as a service](https://discuss.elastic.co/t/kibana-not-running-as-a-service/328829)

<div class="topic-metadata">

**Author:** [@LilBaloche](https://discuss.elastic.co/u/LilBaloche)\
**Replies:** 12\
**Last updated:** [March 30, 2023, 8:35am UTC](https://discuss.elastic.co/t/kibana-not-running-as-a-service/328829 "2023-03-30T08:35:51Z")

</div>

Hello everyone, I've installed ELK stack on an Ubuntu Server 22.04. My problem is that I've start elasticsearch with "systemctl start elasticsearch.service" because bin/elasticsearch does not work, I always have an err…

---

## [Newbie question regarding maps](https://discuss.elastic.co/t/newbie-question-regarding-maps/328744)

<div class="topic-metadata">

**Author:** [@GKre](https://discuss.elastic.co/u/GKre)\
**Replies:** 3\
**Last updated:** [March 30, 2023, 8:11am UTC](https://discuss.elastic.co/t/newbie-question-regarding-maps/328744 "2023-03-30T08:11:24Z")

</div>

Hello community, i checked to find the answer searching but maybe the question is to easy :wink: how do i configure an overlay in a map so that every "point" where a network communication ended has a tooltip with the "…

---

## [Unresolved reference 'Aggregation, Size, TrackTotalHits, Pretty, Sort, and Do'](https://discuss.elastic.co/t/unresolved-reference-aggregation-size-tracktotalhits-pretty-sort-and-do/328884)

<div class="topic-metadata">

**Author:** [@golofetuk](https://discuss.elastic.co/u/golofetuk)\
**Replies:** 3\
**Last updated:** [March 30, 2023, 7:34am UTC](https://discuss.elastic.co/t/unresolved-reference-aggregation-size-tracktotalhits-pretty-sort-and-do/328884 "2023-03-30T07:34:24Z")

</div>

I am trying to execute a search on the Elasticsearch client in Go olivere/elastic, using the appropriate client library for Elasticsearch version 7.x. The expected behavior is to compile the code without errors and retur…

---

## [ERROR: Invalid Host Header Requests](https://discuss.elastic.co/t/error-invalid-host-header-requests/328885)

<div class="topic-metadata">

**Author:** [@irfancankaleli](https://discuss.elastic.co/u/irfancankaleli)\
**Replies:** 7\
**Last updated:** [March 30, 2023, 7:31am UTC](https://discuss.elastic.co/t/error-invalid-host-header-requests/328885 "2023-03-30T07:31:22Z")

</div>

We are running Elasticsearch v6.8.0 on AWS OpenSearch Service, through VPN, and we use following elasticsearch client in our NodeJS server: elasticsearch - npm Our client version is v16.7.2. When I check the metrics on…

---

## [Elastic-agent does not restart automatically after machine reboot](https://discuss.elastic.co/t/elastic-agent-does-not-restart-automatically-after-machine-reboot/328894)

<div class="topic-metadata">

**Author:** [@irivas95](https://discuss.elastic.co/u/irivas95)\
**Replies:** 0\
**Last updated:** [March 30, 2023, 7:19am UTC](https://discuss.elastic.co/t/elastic-agent-does-not-restart-automatically-after-machine-reboot/328894 "2023-03-30T07:19:20Z")

</div>

Hi, I have an elastic-agent with a prometheus integration with and another elastic-agent acting as fleet with the service enabled and when the machines (both with Red Hat SO) are restarted neither the fleet nor the elas…

---

## [Elasticstack in k8s](https://discuss.elastic.co/t/elasticstack-in-k8s/328865)

<div class="topic-metadata">

**Author:** [@Ross\_Phillips](https://discuss.elastic.co/u/Ross_Phillips)\
**Replies:** 3\
**Last updated:** [March 30, 2023, 7:19am UTC](https://discuss.elastic.co/t/elasticstack-in-k8s/328865 "2023-03-30T07:19:14Z")

</div>

Hi all, I'm having an issue deploying ELK on k8s. The error is shown below, any assistance is v. appreciated. java.lang.IllegalStateException: Unable to access 'path.logs' (/data/log) Likely root cause: java.nio.file…

---

## [How does rescore query affect aggregation results?](https://discuss.elastic.co/t/how-does-rescore-query-affect-aggregation-results/328892)

<div class="topic-metadata">

**Author:** [@Abhishek3](https://discuss.elastic.co/u/Abhishek3)\
**Replies:** 0\
**Last updated:** [March 30, 2023, 7:00am UTC](https://discuss.elastic.co/t/how-does-rescore-query-affect-aggregation-results/328892 "2023-03-30T07:00:33Z")

</div>

I am running rescore\_query with ltr model with window\_size=5, I am seeing the recore\_query is being applied to top 5 docs in hits and top 5 docs of every aggregated bucket. Is the how rescore\_query designed to work? f…

---

## [Way for implementing proxy server goint to elastic cluster](https://discuss.elastic.co/t/way-for-implementing-proxy-server-goint-to-elastic-cluster/328889)

<div class="topic-metadata">

**Author:** [@minkiyo](https://discuss.elastic.co/u/minkiyo)\
**Replies:** 0\
**Last updated:** [March 30, 2023, 6:46am UTC](https://discuss.elastic.co/t/way-for-implementing-proxy-server-goint-to-elastic-cluster/328889 "2023-03-30T06:46:09Z")

</div>

Hello I am suffuring now. I am implementing Proxy Server going to Elastic Cluster . Broswer --\> Elastic Proxy Server (Nginx(prot:8081) --\> Express(port:7081)) --\> Elastic Cluster(http://10.150.25.119:5601) When I t…

---

## [Writing nest query with multi match and filter and return data](https://discuss.elastic.co/t/writing-nest-query-with-multi-match-and-filter-and-return-data/328803)

<div class="topic-metadata">

**Author:** [@reza\_setareh](https://discuss.elastic.co/u/reza_setareh)\
**Replies:** 4\
**Last updated:** [March 30, 2023, 6:35am UTC](https://discuss.elastic.co/t/writing-nest-query-with-multi-match-and-filter-and-return-data/328803 "2023-03-30T06:35:30Z")

</div>

hi everybody i have three fields title,description and cityId i want to multi match title and description and filter cities for example cityId==1 how should i do that with nest? thank you

---

## [Transport response handler not found of id](https://discuss.elastic.co/t/transport-response-handler-not-found-of-id/328879)

<div class="topic-metadata">

**Author:** [@KeithTt](https://discuss.elastic.co/u/KeithTt)\
**Replies:** 3\
**Last updated:** [March 30, 2023, 6:31am UTC](https://discuss.elastic.co/t/transport-response-handler-not-found-of-id/328879 "2023-03-30T06:31:21Z")

</div>

\[2023-03-30T09:20:19,277\]\[WARN \]\[o.e.t.TransportService \] \[m-21-63\] Transport response handler not found of id \[197374379\] \[2023-03-30T09:20:19,280\]\[WARN \]\[o.e.t.TransportService \] \[m-21-63\] Transport response handle…

---

## [Space privilege](https://discuss.elastic.co/t/space-privilege/328796)

<div class="topic-metadata">

**Author:** [@\_Thomas](https://discuss.elastic.co/u/_Thomas)\
**Replies:** 5\
**Last updated:** [March 30, 2023, 6:23am UTC](https://discuss.elastic.co/t/space-privilege/328796 "2023-03-30T06:23:43Z")

</div>

Hi Guys, I'm trying to limit the Space to particular Users - this however, doesn't seem to work the way I'd expect. The Problem is as following: I did create a new Space called "SoC", created a new Role called "TestUs…

---

## [Canvas with background image and Map zoom click not working](https://discuss.elastic.co/t/canvas-with-background-image-and-map-zoom-click-not-working/328543)

<div class="topic-metadata">

**Author:** [@syed786](https://discuss.elastic.co/u/syed786)\
**Replies:** 3\
**Last updated:** [March 30, 2023, 4:53am UTC](https://discuss.elastic.co/t/canvas-with-background-image-and-map-zoom-click-not-working/328543 "2023-03-30T04:53:59Z")

</div>

Hello, I am using Kibana Canvas and I have added an image as a background. On top of the image, I have added a map element. However, when I try to click on the zoom button in the map, it does not work. Additionally, whe…

---

## [Why the "exec" input in logstash does not work?](https://discuss.elastic.co/t/why-the-exec-input-in-logstash-does-not-work/328808)

<div class="topic-metadata">

**Author:** [@JohnnyLee](https://discuss.elastic.co/u/JohnnyLee)\
**Replies:** 0\
**Last updated:** [March 29, 2023, 10:02am UTC](https://discuss.elastic.co/t/why-the-exec-input-in-logstash-does-not-work/328808 "2023-03-29T10:02:24Z")

</div>

Hi, I failed to load shell script output to ELK with "exec" input plugin in logstash. Is there anything misconfigured in my configure file? Below is my logstash configuraitons. input { exec { command =\> "bash /r…

---

## [Logstash autorelaod even the config file not changed](https://discuss.elastic.co/t/logstash-autorelaod-even-the-config-file-not-changed/328881)

<div class="topic-metadata">

**Author:** [@kannan\_raj](https://discuss.elastic.co/u/kannan_raj)\
**Replies:** 0\
**Last updated:** [March 30, 2023, 4:35am UTC](https://discuss.elastic.co/t/logstash-autorelaod-even-the-config-file-not-changed/328881 "2023-03-30T04:35:16Z")

</div>

Hello Team, We use the logstash to consume the messages from Kafka and indexing into Elasticsearch and we use the vault to drop the cert and keys to connect to Kafka and Elasticsearch. vault rotates the cert and key dep…

---

## [ES cloud - Reduce index size with rollover failing](https://discuss.elastic.co/t/es-cloud-reduce-index-size-with-rollover-failing/327480)

<div class="topic-metadata">

**Author:** [@twilight](https://discuss.elastic.co/u/twilight)\
**Replies:** 12\
**Last updated:** [March 30, 2023, 4:33am UTC](https://discuss.elastic.co/t/es-cloud-reduce-index-size-with-rollover-failing/327480 "2023-03-30T04:33:44Z")

</div>

Hello, We have an ES cloud deployment having version 7.17. The storage is being consumed fast. One of our index has grown too big hence utilizing lot of the instance storage, I tried to setup a rollover policy on that …

---

## [Aggregate by sum and avg in visualization](https://discuss.elastic.co/t/aggregate-by-sum-and-avg-in-visualization/328534)

<div class="topic-metadata">

**Author:** [@Toaster2-0](https://discuss.elastic.co/u/Toaster2-0)\
**Replies:** 8\
**Last updated:** [March 30, 2023, 12:28am UTC](https://discuss.elastic.co/t/aggregate-by-sum-and-avg-in-visualization/328534 "2023-03-30T00:28:14Z")

</div>

Hello, I am having multiple Docker compose projects of which I collect metrics. I want to see the CPU of the Projects over Time. That means I need to add the amount of cpu ticks of every document with the same docker.c…

---

## [How to set a filter to a map embedded in canvas](https://discuss.elastic.co/t/how-to-set-a-filter-to-a-map-embedded-in-canvas/328820)

<div class="topic-metadata">

**Author:** [@obelaisk](https://discuss.elastic.co/u/obelaisk)\
**Replies:** 1\
**Last updated:** [March 29, 2023, 9:45pm UTC](https://discuss.elastic.co/t/how-to-set-a-filter-to-a-map-embedded-in-canvas/328820 "2023-03-29T21:45:32Z")

</div>

Hi, Im new to canvas and i was trying to know if it's possible to set a filter values of a map based in a value that i get from the urlparam function, like this: var\_set name="var" value={urlparam param="parameter" defa…

---

## [Elatic-agent not sending any data](https://discuss.elastic.co/t/elatic-agent-not-sending-any-data/328868)

<div class="topic-metadata">

**Author:** [@ermilan2309](https://discuss.elastic.co/u/ermilan2309)\
**Replies:** 0\
**Last updated:** [March 29, 2023, 9:34pm UTC](https://discuss.elastic.co/t/elatic-agent-not-sending-any-data/328868 "2023-03-29T21:34:35Z")

</div>

I have installed elastic agent with the same certificates that used for elasticsearch and kibana to communicate with each other. I have all in one deployment. I used the same certs for agents to communicate but not sure…

---

## [Elastic-hadoop access failing due to SSL check](https://discuss.elastic.co/t/elastic-hadoop-access-failing-due-to-ssl-check/328857)

<div class="topic-metadata">

**Author:** [@NN1](https://discuss.elastic.co/u/NN1)\
**Replies:** 1\
**Last updated:** [March 29, 2023, 9:27pm UTC](https://discuss.elastic.co/t/elastic-hadoop-access-failing-due-to-ssl-check/328857 "2023-03-29T21:27:18Z")

</div>

I am trying to connect to a https ES node through my external table created in hdfs cluster. I connect to this hdfs cluster from my linux server using beeline and created the external table setting the property 'es.net.s…

---

## [Logstash License](https://discuss.elastic.co/t/logstash-license/327869)

<div class="topic-metadata">

**Author:** [@Milad\_Heydariaan](https://discuss.elastic.co/u/Milad_Heydariaan)\
**Replies:** 3\
**Last updated:** [March 29, 2023, 9:26pm UTC](https://discuss.elastic.co/t/logstash-license/327869 "2023-03-29T21:26:54Z")

</div>

Hi, Logstash is still covered by Elastic License v1 (ELv1) which has more restrictions than Elastic License v2 (ELv2): But Elasticsearch and Kibana are already migrated to ELv2. Is there any plan for migrating Logst…

---

## [Custom UDP Logs](https://discuss.elastic.co/t/custom-udp-logs/328867)

<div class="topic-metadata">

**Author:** [@Thomas\_Baumann](https://discuss.elastic.co/u/Thomas_Baumann)\
**Replies:** 0\
**Last updated:** [March 29, 2023, 9:10pm UTC](https://discuss.elastic.co/t/custom-udp-logs/328867 "2023-03-29T21:10:47Z")

</div>

Hello, we are using an Fleet Server, including Custom UDP logs integration. We observed an issue with data are not ingested with a load about 500 EPS. About 30% to 50 % messages are not ingested. Also netstat -ulpn …

[Previous page](https://discuss.elastic.co/c/elastic-stack/81.md?page=585)

[Next page](https://discuss.elastic.co/c/elastic-stack/81.md?page=587)
