# Beats

**URL:** https://discuss.elastic.co/c/elastic-stack/beats/28.md?page=137

[Latest](https://discuss.elastic.co/latest.md) · [Categories](https://discuss.elastic.co/categories.md) · [Tags](https://discuss.elastic.co/tags.md)

**Page:** 138

---

## [Metricbeat Azure Modules metricset for VirtualNetworkGateway](https://discuss.elastic.co/t/metricbeat-azure-modules-metricset-for-virtualnetworkgateway/282732)

<div class="topic-metadata">

**Author:** [@adhiraj-g](https://discuss.elastic.co/u/adhiraj-g)\
**Replies:** 0\
**Last updated:** [August 28, 2021, 8:23pm UTC](https://discuss.elastic.co/t/metricbeat-azure-modules-metricset-for-virtualnetworkgateway/282732 "2021-08-28T20:23:23Z")

</div>

Hi, Is it possible to get Data from azure Virtual Network Gateway shown on Kibana? I have added the namespace to azure module yaml file. Connection is there but not sure on how to display its metrics on Kibana. I trie…

---

## [\-system.hostfs doesn't seem to work](https://discuss.elastic.co/t/system-hostfs-doesnt-seem-to-work/282745)

<div class="topic-metadata">

**Author:** [@MikSFG](https://discuss.elastic.co/u/MikSFG)\
**Replies:** 0\
**Last updated:** [August 29, 2021, 7:15am UTC](https://discuss.elastic.co/t/system-hostfs-doesnt-seem-to-work/282745 "2021-08-29T07:15:53Z")

</div>

Hi, I'm currently trying to audit my host from my container, but when I mount my var,sys,proc to the container's /hostfs it doesn't affect anything, audit doesn't do anything with them. For example, I can check my host…

---

## [Other deployment options for functionbeat](https://discuss.elastic.co/t/other-deployment-options-for-functionbeat/282696)

<div class="topic-metadata">

**Author:** [@mohsen0](https://discuss.elastic.co/u/mohsen0)\
**Replies:** 0\
**Last updated:** [August 27, 2021, 5:16pm UTC](https://discuss.elastic.co/t/other-deployment-options-for-functionbeat/282696 "2021-08-27T17:16:28Z")

</div>

Hi The current deployment method of functionbeat, doesn't support adding AWS resource tags for different deployments. I saw Pass AWS tags to resources created by Functionbeat which went unanswered. Currently, deploym…

---

## [Filebeat fingerprint doesn't understand columns from csv files](https://discuss.elastic.co/t/filebeat-fingerprint-doesnt-understand-columns-from-csv-files/282427)

<div class="topic-metadata">

**Author:** [@Baygon](https://discuss.elastic.co/u/Baygon)\
**Replies:** 4\
**Last updated:** [August 27, 2021, 2:44pm UTC](https://discuss.elastic.co/t/filebeat-fingerprint-doesnt-understand-columns-from-csv-files/282427 "2021-08-27T14:44:35Z")

</div>

Hi, I have a filebeat instance that sends event from CSV files to an ES cluster. The ingest pipeline has the relevant mappings and everything works fine. I'm trying to improve the pipeline for deduplication of event b…

---

## [How to run beats/machinebeat as a service](https://discuss.elastic.co/t/how-to-run-beats-machinebeat-as-a-service/282678)

<div class="topic-metadata">

**Author:** [@Valdos116](https://discuss.elastic.co/u/Valdos116)\
**Replies:** 0\
**Last updated:** [August 27, 2021, 2:30pm UTC](https://discuss.elastic.co/t/how-to-run-beats-machinebeat-as-a-service/282678 "2021-08-27T14:30:14Z")

</div>

I've machinebeat set up and running and I'm looking for a way to run it as a service. Any helps will be appreciated. Thanks,

---

## [Filebeat unable to output logs to kafka](https://discuss.elastic.co/t/filebeat-unable-to-output-logs-to-kafka/278359)

<div class="topic-metadata">

**Author:** [@itsec](https://discuss.elastic.co/u/itsec)\
**Replies:** 5\
**Last updated:** [August 27, 2021, 2:00pm UTC](https://discuss.elastic.co/t/filebeat-unable-to-output-logs-to-kafka/278359 "2021-08-27T14:00:24Z")

</div>

I had setup a 3 node clusters and my kafka / zookeeper are running i can create a topic and insert msg to the topic and read its output filebeat version 7.12.0 (amd64), libbeat 7.12.0 kafka 2.13-2.7.0 zookeeper 3.5.8 …

---

## [FileBeat loses 10 seconds of logs on rotation](https://discuss.elastic.co/t/filebeat-loses-10-seconds-of-logs-on-rotation/282227)

<div class="topic-metadata">

**Author:** [@jj12341](https://discuss.elastic.co/u/jj12341)\
**Replies:** 9\
**Last updated:** [August 27, 2021, 1:56pm UTC](https://discuss.elastic.co/t/filebeat-loses-10-seconds-of-logs-on-rotation/282227 "2021-08-27T13:56:52Z")

</div>

Hi! My FileBeat is losing 10 seconds of approximately logs. Obviously the problem is in the rotation of the files, but I can not find the correct option so that these logs are not lost. The Rotation of Logs performs Lo…

---

## [Mtericbeat - error - Failed to connect to elasticsearch](https://discuss.elastic.co/t/mtericbeat-error-failed-to-connect-to-elasticsearch/282323)

<div class="topic-metadata">

**Author:** [@nehasinha1807](https://discuss.elastic.co/u/nehasinha1807)\
**Replies:** 2\
**Last updated:** [August 26, 2021, 4:09pm UTC](https://discuss.elastic.co/t/mtericbeat-error-failed-to-connect-to-elasticsearch/282323 "2021-08-26T16:09:09Z")

</div>

I'm new to ELK. here is my doubt - we had installed ELK lite on a linux server(A) and trying to install metricbeat on a different server(B) but my metricbeat is failed to connect to elasticsearch(A). metricbeat i insta…

---

## [Module elasticsearch issue with filed limit](https://discuss.elastic.co/t/module-elasticsearch-issue-with-filed-limit/282592)

<div class="topic-metadata">

**Author:** [@Messias\_2](https://discuss.elastic.co/u/Messias_2)\
**Replies:** 0\
**Last updated:** [August 26, 2021, 2:55pm UTC](https://discuss.elastic.co/t/module-elasticsearch-issue-with-filed-limit/282592 "2021-08-26T14:55:49Z")

</div>

Hi, I use metric beat to monitor elasticsearch per docker. metricbeat.config: modules: path: ${path.config}/modules.d/\*.yml # Reload module configs as they change: reload.enabled: false processors: - a…

---

## [Unable to install fleet server](https://discuss.elastic.co/t/unable-to-install-fleet-server/282525)

<div class="topic-metadata">

**Author:** [@geetika\_gopi](https://discuss.elastic.co/u/geetika_gopi)\
**Replies:** 5\
**Last updated:** [August 26, 2021, 1:41pm UTC](https://discuss.elastic.co/t/unable-to-install-fleet-server/282525 "2021-08-26T13:41:43Z")

</div>

Hi @scottdfedorov, Since this is a production environment, I tried installing fleet by providing my own certificates and this is the error I see: sudo ./elastic-agent install --url=https://abc:8220 \\ -f \\ --fleet-serve…

---

## [Transport data to remote networks via fleet / Beats](https://discuss.elastic.co/t/transport-data-to-remote-networks-via-fleet-beats/282507)

<div class="topic-metadata">

**Author:** [@widhalmt](https://discuss.elastic.co/u/widhalmt)\
**Replies:** 2\
**Last updated:** [August 26, 2021, 12:13pm UTC](https://discuss.elastic.co/t/transport-data-to-remote-networks-via-fleet-beats/282507 "2021-08-26T12:13:00Z")

</div>

Hi, This is not a question about a specific setup, it's more or less me trying to understand the intended use of Beats / Fleet in distributed setup. In the past I built several setups where I used Logstash to transport…

---

## [Configuring MSSQL transaction on ELK stack hosting on windows machine](https://discuss.elastic.co/t/configuring-mssql-transaction-on-elk-stack-hosting-on-windows-machine/282543)

<div class="topic-metadata">

**Author:** [@AbdulVaseem](https://discuss.elastic.co/u/AbdulVaseem)\
**Replies:** 1\
**Last updated:** [August 26, 2021, 11:37am UTC](https://discuss.elastic.co/t/configuring-mssql-transaction-on-elk-stack-hosting-on-windows-machine/282543 "2021-08-26T11:37:53Z")

</div>

Hi All, I need some help in configuring MSSQL hosting on Windows 2012R2. I have ELK running on Windows 10 Pro (standalone) and need to understand how I would need to configure MSSQL transaction logs.

---

## [Unable to install fleet server](https://discuss.elastic.co/t/unable-to-install-fleet-server/282481)

<div class="topic-metadata">

**Author:** [@geetika\_gopi](https://discuss.elastic.co/u/geetika_gopi)\
**Replies:** 1\
**Last updated:** [August 25, 2021, 1:17pm UTC](https://discuss.elastic.co/t/unable-to-install-fleet-server/282481 "2021-08-25T13:17:08Z")

</div>

Hi Everyone, I am trying to install fleet server on one of my elastic data nodes. However im facing this error. Could someone help me out please? ./elastic-agent install -f --fleet-server-es=https://xyz:9200 --fleet-se…

---

## [My Kibana dashboard shows " No Results found" for my system module of metricbeat](https://discuss.elastic.co/t/my-kibana-dashboard-shows-no-results-found-for-my-system-module-of-metricbeat/282205)

<div class="topic-metadata">

**Author:** [@Shubh\_Garg](https://discuss.elastic.co/u/Shubh_Garg)\
**Replies:** 2\
**Last updated:** [August 25, 2021, 12:37pm UTC](https://discuss.elastic.co/t/my-kibana-dashboard-shows-no-results-found-for-my-system-module-of-metricbeat/282205 "2021-08-25T12:37:08Z")

</div>

The kibana dashboard for system shows "No Result found" for all the fields that i have configured. Here is my system module config : # Module: system # Docs: https://www.elastic.co/guide/en/beats/metricbeat/7.x/metric…

---

## [Cannot deploy functionbeat 7.14.0](https://discuss.elastic.co/t/cannot-deploy-functionbeat-7-14-0/282217)

<div class="topic-metadata">

**Author:** [@sproctor](https://discuss.elastic.co/u/sproctor)\
**Replies:** 4\
**Last updated:** [August 25, 2021, 10:52pm UTC](https://discuss.elastic.co/t/cannot-deploy-functionbeat-7-14-0/282217 "2021-08-25T22:52:16Z")

</div>

Did something change in the process needed to deploy functionbeat 7.14.0? I can deploy 7.13.4 fine. If I try to deploy 7.14.0, I get the following error: Function: st-cw-logs, could not deploy, error: bucket 'st-fb-dep…

---

## [Filebeat sidecar with Sonarqube in Kubernetes](https://discuss.elastic.co/t/filebeat-sidecar-with-sonarqube-in-kubernetes/282315)

<div class="topic-metadata">

**Author:** [@Vincent3](https://discuss.elastic.co/u/Vincent3)\
**Replies:** 3\
**Last updated:** [August 25, 2021, 2:14pm UTC](https://discuss.elastic.co/t/filebeat-sidecar-with-sonarqube-in-kubernetes/282315 "2021-08-25T14:14:09Z")

</div>

Hello, I have a configMap : apiVersion: v1 kind: ConfigMap metadata: name: filebeat-configmap namespace: k8s-mxt-sonarqube data: filebeat.yml: |- filebeat.inputs: - type: container enabled: …

---

## [Metricbeat 401 error after enabling TLS](https://discuss.elastic.co/t/metricbeat-401-error-after-enabling-tls/281986)

<div class="topic-metadata">

**Author:** [@Greg\_R](https://discuss.elastic.co/u/Greg_R)\
**Replies:** 1\
**Last updated:** [August 25, 2021, 11:14am UTC](https://discuss.elastic.co/t/metricbeat-401-error-after-enabling-tls/281986 "2021-08-25T11:14:44Z")

</div>

Greetings I've setup ElasticSearch, Kibana and Metricbeat on http and it's working. Now I want to enable API keys, so I have to enable TLS (although I don't understand why). So I got ES and Kibana working together, bu…

---

## [Metricbeat Timeout Errors while scraping state metricset from kube-state-mertics](https://discuss.elastic.co/t/metricbeat-timeout-errors-while-scraping-state-metricset-from-kube-state-mertics/281931)

<div class="topic-metadata">

**Author:** [@Kosodrom](https://discuss.elastic.co/u/Kosodrom)\
**Replies:** 3\
**Last updated:** [August 25, 2021, 9:37am UTC](https://discuss.elastic.co/t/metricbeat-timeout-errors-while-scraping-state-metricset-from-kube-state-mertics/281931 "2021-08-25T09:37:13Z")

</div>

I am running metricbeat deployment and daemonset using elasticsearch helm chart. In my metricbeat deployment I am collecting state metrics from the kube-state-metrics API from an openshift cluster and experience followin…

---

## [Filebeat high CPU usage during reading a huge file](https://discuss.elastic.co/t/filebeat-high-cpu-usage-during-reading-a-huge-file/282363)

<div class="topic-metadata">

**Author:** [@arberg](https://discuss.elastic.co/u/arberg)\
**Replies:** 0\
**Last updated:** [August 24, 2021, 2:35pm UTC](https://discuss.elastic.co/t/filebeat-high-cpu-usage-during-reading-a-huge-file/282363 "2021-08-24T14:35:01Z")

</div>

Hello fellow ELKstackers, Filebeat (6.3.1 on x64 old RedHat) runs with very high CPU when has been behind and needs to read some large log-files. It used 100% of 1/8 cpus (top said around 100%). After it was done proces…

---

## [On the division of labor between packetbeat and filebeat](https://discuss.elastic.co/t/on-the-division-of-labor-between-packetbeat-and-filebeat/282379)

<div class="topic-metadata">

**Author:** [@chinaxushi](https://discuss.elastic.co/u/chinaxushi)\
**Replies:** 2\
**Last updated:** [August 25, 2021, 1:19am UTC](https://discuss.elastic.co/t/on-the-division-of-labor-between-packetbeat-and-filebeat/282379 "2021-08-25T01:19:14Z")

</div>

Today, I just noticed that filebeat can also listen to TCP or UPD traffic data, even NetFlow traffic data. Shouldn't these be the working scope of packetbeat. I feel beat's planning is a little messy!

---

## [Filebeat: initial ingestion of 2M files](https://discuss.elastic.co/t/filebeat-initial-ingestion-of-2m-files/282362)

<div class="topic-metadata">

**Author:** [@Baygon](https://discuss.elastic.co/u/Baygon)\
**Replies:** 2\
**Last updated:** [August 25, 2021, 1:03am UTC](https://discuss.elastic.co/t/filebeat-initial-ingestion-of-2m-files/282362 "2021-08-25T01:03:35Z")

</div>

I have about 2M log files to process for initial ingestion. These csv files are spread on 4 folders. I have set up a filebeat pipeline and set harvester\_limit: 0 I have also tried to set up 4 filebeat instances, modif…

---

## [Filebeat Multiline Pattern not working on Production servers](https://discuss.elastic.co/t/filebeat-multiline-pattern-not-working-on-production-servers/282398)

<div class="topic-metadata">

**Author:** [@Pavani\_Reddy](https://discuss.elastic.co/u/Pavani_Reddy)\
**Replies:** 0\
**Last updated:** [August 24, 2021, 6:41pm UTC](https://discuss.elastic.co/t/filebeat-multiline-pattern-not-working-on-production-servers/282398 "2021-08-24T18:41:33Z")

</div>

Hi Team, I am using multiline.pattern in filebeat for parsing logs. I am able parse the logs correctly on local lab servers, but when implemented the same on prod servers , multiple logs gets indexed as one event to el…

---

## [Getting metricbeat error on 7.14 v](https://discuss.elastic.co/t/getting-metricbeat-error-on-7-14-v/282272)

<div class="topic-metadata">

**Author:** [@cool999](https://discuss.elastic.co/u/cool999)\
**Replies:** 4\
**Last updated:** [August 24, 2021, 4:50pm UTC](https://discuss.elastic.co/t/getting-metricbeat-error-on-7-14-v/282272 "2021-08-24T16:50:42Z")

</div>

Hi, I have ansible config files which was installing all elasticsearch components of 7.4 version. I have changed it to download and use 7.14 version. I am getting below error, elasticsearch service is not getting sta…

---

## [Ingesting PCAP dataset into ELK via Zeek and Zeek scripting](https://discuss.elastic.co/t/ingesting-pcap-dataset-into-elk-via-zeek-and-zeek-scripting/282280)

<div class="topic-metadata">

**Author:** [@momo1104](https://discuss.elastic.co/u/momo1104)\
**Replies:** 3\
**Last updated:** [August 24, 2021, 3:59pm UTC](https://discuss.elastic.co/t/ingesting-pcap-dataset-into-elk-via-zeek-and-zeek-scripting/282280 "2021-08-24T15:59:10Z")

</div>

Hello, I am having trouble with filebeat and logstash configurations I think. What I am trying to do is send a DDoS pcap dataset (saved on my ubuntu machine) to ELK, using Zeek while applying Zeek scripts to it. I hav…

---

## [Have a problem with my Suricata + ELK stack](https://discuss.elastic.co/t/have-a-problem-with-my-suricata-elk-stack/281364)

<div class="topic-metadata">

**Author:** [@Yves\_Silvere\_Randria](https://discuss.elastic.co/u/Yves_Silvere_Randria)\
**Replies:** 12\
**Last updated:** [August 24, 2021, 1:50pm UTC](https://discuss.elastic.co/t/have-a-problem-with-my-suricata-elk-stack/281364 "2021-08-24T13:50:11Z")

</div>

Hello, I have this error when I am setting up ELK servers + Suricata .

---

## [How many workers on filebeat?](https://discuss.elastic.co/t/how-many-workers-on-filebeat/282354)

<div class="topic-metadata">

**Author:** [@Arethusa](https://discuss.elastic.co/u/Arethusa)\
**Replies:** 0\
**Last updated:** [August 24, 2021, 1:30pm UTC](https://discuss.elastic.co/t/how-many-workers-on-filebeat/282354 "2021-08-24T13:30:57Z")

</div>

Hello, I am not sure to understand how many work do I need. On this configuration I see that : # nano /etc/filebeat/filebeat.yml output.logstash: hosts: \["logstash1:5044","logstash2:5044","logstash3:5044"\] loadb…

---

## [Metricbeat: Dashboard desired pods shown as 0 (zero)](https://discuss.elastic.co/t/metricbeat-dashboard-desired-pods-shown-as-0-zero/282340)

<div class="topic-metadata">

**Author:** [@mgo1](https://discuss.elastic.co/u/mgo1)\
**Replies:** 0\
**Last updated:** [August 24, 2021, 11:16am UTC](https://discuss.elastic.co/t/metricbeat-dashboard-desired-pods-shown-as-0-zero/282340 "2021-08-24T11:16:34Z")

</div>

Hi, As the title suggests I'm getting some metrics in the \[Metricbeat Kubernetes\] ECS Overview but I have a couple of issues. The desired pods and available pods is always zero (even though there are around 70 pods ru…

---

## [Include multiline and non-multiline events](https://discuss.elastic.co/t/include-multiline-and-non-multiline-events/282249)

<div class="topic-metadata">

**Author:** [@tecbox41](https://discuss.elastic.co/u/tecbox41)\
**Replies:** 0\
**Last updated:** [August 23, 2021, 2:56pm UTC](https://discuss.elastic.co/t/include-multiline-and-non-multiline-events/282249 "2021-08-23T14:56:22Z")

</div>

{"sub-4.0": { "level":"WARN","timestamp":"2021-02-12 13:01:25,047","thread":"Mapper","file":"filemapper.java","line":"732","message":"no data found"}} {"sub-4.0": { "level":"WARN","timestamp":"2021-02-12 13:01:26,047",…

---

## [In which order are config loaded?](https://discuss.elastic.co/t/in-which-order-are-config-loaded/281014)

<div class="topic-metadata">

**Author:** [@colttt](https://discuss.elastic.co/u/colttt)\
**Replies:** 2\
**Last updated:** [August 23, 2021, 9:51am UTC](https://discuss.elastic.co/t/in-which-order-are-config-loaded/281014 "2021-08-23T09:51:38Z")

</div>

Hi, so far as I can see, there is a path.config which pont to /etc/filebeat (on debian systems). when I put a config file in this dir, lets say custom\_conf.yml. will it be load after the filebeat.yml and overwrite the se…

---

## [Filebeat shows unexpected error while setup](https://discuss.elastic.co/t/filebeat-shows-unexpected-error-while-setup/282203)

<div class="topic-metadata">

**Author:** [@Shubh\_Garg](https://discuss.elastic.co/u/Shubh_Garg)\
**Replies:** 0\
**Last updated:** [August 23, 2021, 8:58am UTC](https://discuss.elastic.co/t/filebeat-shows-unexpected-error-while-setup/282203 "2021-08-23T08:58:50Z")

</div>

I get the following error while running the command sudo filebeat setup on my centos7 linux ec2 instance. I have two modules nginx and System enabled. The error above only comes when i enable the system module. The …

[Previous page](https://discuss.elastic.co/c/elastic-stack/beats/28.md?page=136)

[Next page](https://discuss.elastic.co/c/elastic-stack/beats/28.md?page=138)
