# Elasticsearch

**URL:** https://discuss.elastic.co/c/elastic-stack/elasticsearch/6.md?page=100

[Latest](https://discuss.elastic.co/latest.md) · [Categories](https://discuss.elastic.co/categories.md) · [Tags](https://discuss.elastic.co/tags.md)

**Page:** 101

---

## [Facing jar hell issue when trying to embed some code in server src using external libraries](https://discuss.elastic.co/t/facing-jar-hell-issue-when-trying-to-embed-some-code-in-server-src-using-external-libraries/361821)

<div class="topic-metadata">

**Author:** [@anshulvika360](https://discuss.elastic.co/u/anshulvika360)\
**Replies:** 1\
**Last updated:** [June 21, 2024, 6:31am UTC](https://discuss.elastic.co/t/facing-jar-hell-issue-when-trying-to-embed-some-code-in-server-src-using-external-libraries/361821 "2024-06-21T06:31:12Z")

</div>

I am trying to enrich logs with some additional information when using bulk api. For this i have added my custom code in server src. My code depends on few external libraries namely: hhtpclient,httpcore,comons codec,comm…

---

## [\[HELP\] Transform not accounting for documents with same timestamp](https://discuss.elastic.co/t/help-transform-not-accounting-for-documents-with-same-timestamp/361804)

<div class="topic-metadata">

**Author:** [@Liam\_Young](https://discuss.elastic.co/u/Liam_Young)\
**Replies:** 2\
**Last updated:** [June 21, 2024, 12:32am UTC](https://discuss.elastic.co/t/help-transform-not-accounting-for-documents-with-same-timestamp/361804 "2024-06-21T00:32:09Z")

</div>

Hi, I am new to elasticsearch. I have a datastream that uses a custom timestamp field that is made by envoy, and fed thru filebeat to logstash (with grok) then to elasticsearch. The use case is that there are thousands o…

---

## [Notion elasticsearch integration](https://discuss.elastic.co/t/notion-elasticsearch-integration/361667)

<div class="topic-metadata">

**Author:** [@anuj99](https://discuss.elastic.co/u/anuj99)\
**Replies:** 1\
**Last updated:** [June 20, 2024, 5:21pm UTC](https://discuss.elastic.co/t/notion-elasticsearch-integration/361667 "2024-06-20T17:21:24Z")

</div>

I am trying to use workplace search using elasticsearch. My organisation needs to integrate notion data in ES. I can see that notion is provided as a integration. However, when using my integrations keys, it does not ha…

---

## [502 bad gateway error](https://discuss.elastic.co/t/502-bad-gateway-error/361686)

<div class="topic-metadata">

**Author:** [@Niru8](https://discuss.elastic.co/u/Niru8)\
**Replies:** 1\
**Last updated:** [June 20, 2024, 5:02pm UTC](https://discuss.elastic.co/t/502-bad-gateway-error/361686 "2024-06-20T17:02:07Z")

</div>

in client server i am facing this issue

---

## [Migration of data from Elasticsearch to Databases (MongoDB, MySQL)](https://discuss.elastic.co/t/migration-of-data-from-elasticsearch-to-databases-mongodb-mysql/361669)

<div class="topic-metadata">

**Author:** [@Andy\_Cong](https://discuss.elastic.co/u/Andy_Cong)\
**Replies:** 7\
**Last updated:** [June 20, 2024, 4:18pm UTC](https://discuss.elastic.co/t/migration-of-data-from-elasticsearch-to-databases-mongodb-mysql/361669 "2024-06-20T16:18:54Z")

</div>

Brief Principle: The real-time incremental data is written to both the old and new storage engines (ES and DB). Then data from the old storage engine (ES) is migrated to the new storage engine (DB). After that finish, da…

---

## [Elasticsearch - Migrating from Java High Level Rest Client to New Java API Client of Version 8.x](https://discuss.elastic.co/t/elasticsearch-migrating-from-java-high-level-rest-client-to-new-java-api-client-of-version-8-x/358709)

<div class="topic-metadata">

**Author:** [@Aswini\_Kumar\_Rout](https://discuss.elastic.co/u/Aswini_Kumar_Rout)\
**Replies:** 2\
**Last updated:** [June 16, 2024, 1:51pm UTC](https://discuss.elastic.co/t/elasticsearch-migrating-from-java-high-level-rest-client-to-new-java-api-client-of-version-8-x/358709 "2024-06-16T13:51:22Z")

</div>

I am using the new version 8.13 of Elasticsearch for a new search app and trying to imitate the below kind of logic using the new Java API client instead of using Java High Level Rest client which was deprecated now. I h…

---

## [Snapshot not registering on remote cluster](https://discuss.elastic.co/t/snapshot-not-registering-on-remote-cluster/361549)

<div class="topic-metadata">

**Author:** [@Rokni](https://discuss.elastic.co/u/Rokni)\
**Replies:** 11\
**Last updated:** [June 20, 2024, 10:10am UTC](https://discuss.elastic.co/t/snapshot-not-registering-on-remote-cluster/361549 "2024-06-20T10:10:47Z")

</div>

Hey, We are trying to restore a snapshot on a remote cluster of ours. We have created an S3 snapshot repo in the source cluster, took the snapshot and then we restore this snapshot on a remote es cluster. We are witne…

---

## [Error: using Java API calling ElasticsearchClient method healthReport()](https://discuss.elastic.co/t/error-using-java-api-calling-elasticsearchclient-method-healthreport/361478)

<div class="topic-metadata">

**Author:** [@p4paul](https://discuss.elastic.co/u/p4paul)\
**Replies:** 2\
**Last updated:** [June 20, 2024, 8:34am UTC](https://discuss.elastic.co/t/error-using-java-api-calling-elasticsearchclient-method-healthreport/361478 "2024-06-20T08:34:14Z")

</div>

I'm using co.elastic.clients:elasticsearch-java:8.13.4 and get a deserilizing error calling the healthReport() method: HealthReportResponse health = myEsClient.healthReport(); Error: co.elastic.clients.json.JsonpMappi…

---

## [Can not loading adding integrations page. ELK v8.14.0 on Ubuntu](https://discuss.elastic.co/t/can-not-loading-adding-integrations-page-elk-v8-14-0-on-ubuntu/361474)

<div class="topic-metadata">

**Author:** [@ahn](https://discuss.elastic.co/u/ahn)\
**Replies:** 8\
**Last updated:** [June 20, 2024, 7:50am UTC](https://discuss.elastic.co/t/can-not-loading-adding-integrations-page-elk-v8-14-0-on-ubuntu/361474 "2024-06-20T07:50:45Z")

</div>

Hi hero, Please help a beginner. Test environment OS - Ubuntu 22.04.3 LTS ELK version - elasticsearch-8.14.0-linux-x86\_64.tar kibana-8.14.0-linux-x86\_64.tar I went through two situations. When I installed ELK at …

---

## [After enabling xpack security readinessprobe fails](https://discuss.elastic.co/t/after-enabling-xpack-security-readinessprobe-fails/361625)

<div class="topic-metadata">

**Author:** [@laurijssen](https://discuss.elastic.co/u/laurijssen)\
**Replies:** 3\
**Last updated:** [June 20, 2024, 6:14am UTC](https://discuss.elastic.co/t/after-enabling-xpack-security-readinessprobe-fails/361625 "2024-06-20T06:14:30Z")

</div>

I've got elk stack running through helm without security but now I was aked to turn it on. So I generated certificates with elastic-certutil and put them in a secret and changed the config into esConfig: elasticsearc…

---

## [How to generate a metric index from a Nginx log(or similar) index?](https://discuss.elastic.co/t/how-to-generate-a-metric-index-from-a-nginx-log-or-similar-index/361769)

<div class="topic-metadata">

**Author:** [@gzOne2Free](https://discuss.elastic.co/u/gzOne2Free)\
**Replies:** 0\
**Last updated:** [June 20, 2024, 5:27am UTC](https://discuss.elastic.co/t/how-to-generate-a-metric-index-from-a-nginx-log-or-similar-index/361769 "2024-06-20T05:27:11Z")

</div>

Hi there, I have an index which store Nginx access log. I am able to create a Kibana dashboard to visualize the response time, 4XX, 5XX and other KPIs for a website. A dashboard visualization can do the aggregation like…

---

## [Failed to determine the health of the cluster when creating enrollment token](https://discuss.elastic.co/t/failed-to-determine-the-health-of-the-cluster-when-creating-enrollment-token/361679)

<div class="topic-metadata">

**Author:** [@HallMonitor](https://discuss.elastic.co/u/HallMonitor)\
**Replies:** 5\
**Last updated:** [June 19, 2024, 11:48pm UTC](https://discuss.elastic.co/t/failed-to-determine-the-health-of-the-cluster-when-creating-enrollment-token/361679 "2024-06-19T23:48:42Z")

</div>

sudo /usr/share/elasticsearch/bin/elasticsearch-create-enrollment-token -s node ERROR: Failed to determine the health of the cluster. , with exit code 69 Only configuration change so far is the setup of ReadOnlyRest. …

---

## [Transport ssl cannot read configured](https://discuss.elastic.co/t/transport-ssl-cannot-read-configured/361705)

<div class="topic-metadata">

**Author:** [@VijayIQA](https://discuss.elastic.co/u/VijayIQA)\
**Replies:** 1\
**Last updated:** [June 19, 2024, 11:42pm UTC](https://discuss.elastic.co/t/transport-ssl-cannot-read-configured/361705 "2024-06-19T23:42:28Z")

</div>

Hi Team, Created pk12 certification for http and transport as like below steps: openssl genrsa -out elastic\_private\_key.pem 2048 openssl req -new -key elastic\_private\_key.pem -out elastic\_csr.pem openssl x509 -req -day…

---

## [Get a list of all available language analyzers?](https://discuss.elastic.co/t/get-a-list-of-all-available-language-analyzers/361752)

<div class="topic-metadata">

**Author:** [@mrodent](https://discuss.elastic.co/u/mrodent)\
**Replies:** 1\
**Last updated:** [June 19, 2024, 5:30pm UTC](https://discuss.elastic.co/t/get-a-list-of-all-available-language-analyzers/361752 "2024-06-19T17:30:06Z")

</div>

Asked 10 years ago. The "command" or "index" or whatever it was, "sgen", either appears no longer to exist, or no longer to work that way. I'm doing a project where users should be able to stipulate "set of such and suc…

---

## [Component template](https://discuss.elastic.co/t/component-template/361677)

<div class="topic-metadata">

**Author:** [@Kishore\_Pothireddy1](https://discuss.elastic.co/u/Kishore_Pothireddy1)\
**Replies:** 2\
**Last updated:** [June 19, 2024, 1:41pm UTC](https://discuss.elastic.co/t/component-template/361677 "2024-06-19T13:41:10Z")

</div>

How to reference the custom analyzer present in settings component template in mappings component template? I have created a component template for settings as shown below but creating a mappings component template that…

---

## [Deploy Elasticsearch free for PoC Testing/Development](https://discuss.elastic.co/t/deploy-elasticsearch-free-for-poc-testing-development/361727)

<div class="topic-metadata">

**Author:** [@b-m-s-west](https://discuss.elastic.co/u/b-m-s-west)\
**Replies:** 6\
**Last updated:** [June 19, 2024, 3:24pm UTC](https://discuss.elastic.co/t/deploy-elasticsearch-free-for-poc-testing-development/361727 "2024-06-19T15:24:55Z")

</div>

Using Elasticsearch for development of a PoC between three people. Are there any ways or suggestions to be able to deploy it for free beyond the free trail? Currently have tried the free VM on Azure and AWS, but the comp…

---

## [Issue with creating backup to s3](https://discuss.elastic.co/t/issue-with-creating-backup-to-s3/361701)

<div class="topic-metadata">

**Author:** [@Vakh](https://discuss.elastic.co/u/Vakh)\
**Replies:** 10\
**Last updated:** [June 19, 2024, 3:03pm UTC](https://discuss.elastic.co/t/issue-with-creating-backup-to-s3/361701 "2024-06-19T15:03:55Z")

</div>

Hello there! I will start by providing as many details as possible. First of all, I want to state that it is my first time working with Elastic and I do not know a lot. Now, in a company we have 3 EC2 instances, on wh…

---

## [Readiness probe failed when I apply SSL and saml on the data notes on the ECK cluster in AWS EKS cluster](https://discuss.elastic.co/t/readiness-probe-failed-when-i-apply-ssl-and-saml-on-the-data-notes-on-the-eck-cluster-in-aws-eks-cluster/360643)

<div class="topic-metadata">

**Author:** [@sunilyadav0201](https://discuss.elastic.co/u/sunilyadav0201)\
**Replies:** 0\
**Last updated:** [May 31, 2024, 5:56pm UTC](https://discuss.elastic.co/t/readiness-probe-failed-when-i-apply-ssl-and-saml-on-the-data-notes-on-the-eck-cluster-in-aws-eks-cluster/360643 "2024-05-31T17:56:44Z")

</div>

Hi, I am trying to apply the SSL and SAML configuration on my elastic cluster which is in aws EKS and created using ECK. I am running the cluster and have applied the SSL and SAML working but sometimes I am facing failu…

---

## [What's the recomendation when dealing with a index widely used?](https://discuss.elastic.co/t/whats-the-recomendation-when-dealing-with-a-index-widely-used/361741)

<div class="topic-metadata">

**Author:** [@SamuelSMendes](https://discuss.elastic.co/u/SamuelSMendes)\
**Replies:** 0\
**Last updated:** [June 19, 2024, 2:17pm UTC](https://discuss.elastic.co/t/whats-the-recomendation-when-dealing-with-a-index-widely-used/361741 "2024-06-19T14:17:26Z")

</div>

I have plans to centralize the indexes I use for a few reports. The plan is to have an index with little more than 2million documents; Short in size but still growing and is also highly searched within multiple Kibana sp…

---

## [Broken documentation link](https://discuss.elastic.co/t/broken-documentation-link/361735)

<div class="topic-metadata">

**Author:** [@Chenko](https://discuss.elastic.co/u/Chenko)\
**Replies:** 4\
**Last updated:** [June 19, 2024, 2:02pm UTC](https://discuss.elastic.co/t/broken-documentation-link/361735 "2024-06-19T14:02:54Z")

</div>

Hello, I have found a broken link in the documentation, here. Tested on Chrome & Firefox, both showed a broken page. Kr, Chenko

---

## [Trouble with errors when creating a snapshot](https://discuss.elastic.co/t/trouble-with-errors-when-creating-a-snapshot/361462)

<div class="topic-metadata">

**Author:** [@YUUTA.INOUE-JPN](https://discuss.elastic.co/u/YUUTA.INOUE-JPN)\
**Replies:** 13\
**Last updated:** [June 19, 2024, 9:40am UTC](https://discuss.elastic.co/t/trouble-with-errors-when-creating-a-snapshot/361462 "2024-06-19T09:40:26Z")

</div>

Hello from Japan I have a question for all the dear Elastic engineers I want to use the snapshot function to save a snapshot on one node in a cluster. \*I have configured a cluster of three Elasticsearch machines. I h…

---

## [Watcher showing security\_exception error](https://discuss.elastic.co/t/watcher-showing-security-exception-error/361393)

<div class="topic-metadata">

**Author:** [@Sayali](https://discuss.elastic.co/u/Sayali)\
**Replies:** 4\
**Last updated:** [June 19, 2024, 6:47am UTC](https://discuss.elastic.co/t/watcher-showing-security-exception-error/361393 "2024-06-19T06:47:28Z")

</div>

Hello, I have been facing an issue with some watchers regarding role privileges due to which the watchers don't trigger and show error. But I have superuser privileges. "result": { "execution\_time": "2024-06-13T07:…

---

## [Which index is exceeding the total\_fields limit?](https://discuss.elastic.co/t/which-index-is-exceeding-the-total-fields-limit/361697)

<div class="topic-metadata">

**Author:** [@Nithesh\_Balaji\_D](https://discuss.elastic.co/u/Nithesh_Balaji_D)\
**Replies:** 2\
**Last updated:** [June 19, 2024, 6:38am UTC](https://discuss.elastic.co/t/which-index-is-exceeding-the-total-fields-limit/361697 "2024-06-19T06:38:27Z")

</div>

We're encountering an issue with our Elasticsearch pods: The error message we're seeing is: \[Limit of total fields \[1000\] has been exceeded while adding new fields \[644\]\], which is causing Fluentd to partially upload lo…

---

## [Cannot load PEM certificate\_authorities](https://discuss.elastic.co/t/cannot-load-pem-certificate-authorities/361623)

<div class="topic-metadata">

**Author:** [@INS](https://discuss.elastic.co/u/INS)\
**Replies:** 2\
**Last updated:** [June 19, 2024, 4:06am UTC](https://discuss.elastic.co/t/cannot-load-pem-certificate-authorities/361623 "2024-06-19T04:06:02Z")

</div>

Hi I have generated a couple of cert under my instance list followed by so at least my config looks like below container\_name: es\_master\_1\_1 environment: - node.name=es\_master\_1\_1 - xpack.ml.enab…

---

## [No one responded to the post about this issue](https://discuss.elastic.co/t/no-one-responded-to-the-post-about-this-issue/361612)

<div class="topic-metadata">

**Author:** [@ahn](https://discuss.elastic.co/u/ahn)\
**Replies:** 2\
**Last updated:** [June 19, 2024, 1:15am UTC](https://discuss.elastic.co/t/no-one-responded-to-the-post-about-this-issue/361612 "2024-06-19T01:15:13Z")

</div>

Are there no heroes here? Thanks in advance. Regards -Ahn

---

## [Applied a new template to my indices, but new indices are created with the wrong shard/replica count](https://discuss.elastic.co/t/applied-a-new-template-to-my-indices-but-new-indices-are-created-with-the-wrong-shard-replica-count/361651)

<div class="topic-metadata">

**Author:** [@Bogdan\_Laban](https://discuss.elastic.co/u/Bogdan_Laban)\
**Replies:** 2\
**Last updated:** [June 18, 2024, 4:55pm UTC](https://discuss.elastic.co/t/applied-a-new-template-to-my-indices-but-new-indices-are-created-with-the-wrong-shard-replica-count/361651 "2024-06-18T16:55:18Z")

</div>

AWS OpenSearch, running 7.10 Elasticsearch version. I have my current template as this: { "ism\_rollover" : { "order" : 100, "index\_patterns" : \[ "default-logs-\*" \], "settings" : { "index" …

---

## [Aggregations sorting (between them, not in their results) changes from ES7 to ES8?](https://discuss.elastic.co/t/aggregations-sorting-between-them-not-in-their-results-changes-from-es7-to-es8/361659)

<div class="topic-metadata">

**Author:** [@samyrabih](https://discuss.elastic.co/u/samyrabih)\
**Replies:** 0\
**Last updated:** [June 18, 2024, 3:01pm UTC](https://discuss.elastic.co/t/aggregations-sorting-between-them-not-in-their-results-changes-from-es7-to-es8/361659 "2024-06-18T15:01:52Z")

</div>

Hi ! In our application, we use aggregations using this kind of syntax: "aggs": { "question\_1.answer.id": { "terms": { "field": "question\_1.answer.id", "size": 20000 }, "aggs": { …

---

## [Failed to retrieve shards stuck Elastic node and performance](https://discuss.elastic.co/t/failed-to-retrieve-shards-stuck-elastic-node-and-performance/361658)

<div class="topic-metadata">

**Author:** [@todorvgit](https://discuss.elastic.co/u/todorvgit)\
**Replies:** 0\
**Last updated:** [June 18, 2024, 2:52pm UTC](https://discuss.elastic.co/t/failed-to-retrieve-shards-stuck-elastic-node-and-performance/361658 "2024-06-18T14:52:38Z")

</div>

Hello, We are having issue with Hot tier in our elasticsearch version 7.16.2 Time to time in last few weeks we are experience issue that Metrics beat stop getting any data of the cluster. What we are seeing in master …

---

## [Elasticsearch 7.17.1 - shards skipped even if they contain data](https://discuss.elastic.co/t/elasticsearch-7-17-1-shards-skipped-even-if-they-contain-data/361649)

<div class="topic-metadata">

**Author:** [@mihail-ca](https://discuss.elastic.co/u/mihail-ca)\
**Replies:** 0\
**Last updated:** [June 18, 2024, 1:48pm UTC](https://discuss.elastic.co/t/elasticsearch-7-17-1-shards-skipped-even-if-they-contain-data/361649 "2024-06-18T13:48:15Z")

</div>

Hello, We have the following document in Elasticsearch 7.17.1: { "\_index": "operate-list-view-8.1.0\_2024-06-13", "\_type": "\_doc", "\_id": "2251800712733897", "\_score": 1.0, "\_source": { "id": "225180071273…

---

## [Scalability of Nested Objects & Good Practice](https://discuss.elastic.co/t/scalability-of-nested-objects-good-practice/361609)

<div class="topic-metadata">

**Author:** [@mvkfg](https://discuss.elastic.co/u/mvkfg)\
**Replies:** 2\
**Last updated:** [June 18, 2024, 1:13pm UTC](https://discuss.elastic.co/t/scalability-of-nested-objects-good-practice/361609 "2024-06-18T13:13:03Z")

</div>

Hello, I am working in an Elasticsearch environment in which I can monitor and search logs within a game server. This includes a reputation/punishment system, or voting, for example to kick a cheater from the game. Exa…

[Previous page](https://discuss.elastic.co/c/elastic-stack/elasticsearch/6.md?page=99)

[Next page](https://discuss.elastic.co/c/elastic-stack/elasticsearch/6.md?page=101)
