# Elasticsearch

**URL:** https://discuss.elastic.co/c/elastic-stack/elasticsearch/6.md?page=143

[Latest](https://discuss.elastic.co/latest.md) · [Categories](https://discuss.elastic.co/categories.md) · [Tags](https://discuss.elastic.co/tags.md)

**Page:** 144

---

## [Need to delete the data from Indices A based on Indices B](https://discuss.elastic.co/t/need-to-delete-the-data-from-indices-a-based-on-indices-b/353744)

<div class="topic-metadata">

**Author:** [@Tqvenkata](https://discuss.elastic.co/u/Tqvenkata)\
**Replies:** 2\
**Last updated:** [February 22, 2024, 6:15am UTC](https://discuss.elastic.co/t/need-to-delete-the-data-from-indices-a-based-on-indices-b/353744 "2024-02-22T06:15:10Z")

</div>

HI, Is there any solution to delete the data from Indices A which are not exists(based on key) in Indices B in elasticsearch.

---

## [Unable to read elasticsearch.6.0.1 index data into dataframe using pyspark](https://discuss.elastic.co/t/unable-to-read-elasticsearch-6-0-1-index-data-into-dataframe-using-pyspark/353844)

<div class="topic-metadata">

**Author:** [@vincentnaveen](https://discuss.elastic.co/u/vincentnaveen)\
**Replies:** 0\
**Last updated:** [February 22, 2024, 5:39am UTC](https://discuss.elastic.co/t/unable-to-read-elasticsearch-6-0-1-index-data-into-dataframe-using-pyspark/353844 "2024-02-22T05:39:54Z")

</div>

Hello everyone, I am using elastcisearch version 6.0.1 from AWS service. I am trying to read Es index data into spark dataframe using pyspark. I can read all fields except the fields contain nested arrays. The nested a…

---

## [Getting invalid IPv6 address error while connecting Springboot with elasticsearch over ipv4](https://discuss.elastic.co/t/getting-invalid-ipv6-address-error-while-connecting-springboot-with-elasticsearch-over-ipv4/353840)

<div class="topic-metadata">

**Author:** [@JeyakumarKarunanithi](https://discuss.elastic.co/u/JeyakumarKarunanithi)\
**Replies:** 0\
**Last updated:** [February 22, 2024, 5:25am UTC](https://discuss.elastic.co/t/getting-invalid-ipv6-address-error-while-connecting-springboot-with-elasticsearch-over-ipv4/353840 "2024-02-22T05:25:58Z")

</div>

Hello Team , We are using Elasticsearch 7.17.5 docker image and connecting our own java springboot application using IPv4 in docker swarm & Kubernetes. While deploying the same stack in Openshift, We are getting the fo…

---

## [Questions about trace logs on RestClient RequestLogger.java](https://discuss.elastic.co/t/questions-about-trace-logs-on-restclient-requestlogger-java/353590)

<div class="topic-metadata">

**Author:** [@HongJian-Yang](https://discuss.elastic.co/u/HongJian-Yang)\
**Replies:** 1\
**Last updated:** [February 22, 2024, 2:40am UTC](https://discuss.elastic.co/t/questions-about-trace-logs-on-restclient-requestlogger-java/353590 "2024-02-22T02:40:52Z")

</div>

Why use LogFactory. getLog ("tracer") instead of the logger passed in by the method when determining whether to print trace logs in the logResponse method of RequestLogger.java? Does this cause logging. level. org. lasti…

---

## [Question for local SSD usage for hot nodes on Elastic Cloud](https://discuss.elastic.co/t/question-for-local-ssd-usage-for-hot-nodes-on-elastic-cloud/353725)

<div class="topic-metadata">

**Author:** [@lzz118](https://discuss.elastic.co/u/lzz118)\
**Replies:** 1\
**Last updated:** [February 21, 2024, 10:37pm UTC](https://discuss.elastic.co/t/question-for-local-ssd-usage-for-hot-nodes-on-elastic-cloud/353725 "2024-02-21T22:37:15Z")

</div>

I heard Local / NVME SSD were used on Elastic Cloud on GCP, I wonder if the local SSDs configured for Elastic Cloud on GCP utilize the LVM to merge individual disks into single logical partition or RAID? I don't seems …

---

## [Not opting out of the query cache; authorization is not allowed](https://discuss.elastic.co/t/not-opting-out-of-the-query-cache-authorization-is-not-allowed/353819)

<div class="topic-metadata">

**Author:** [@SQIGGLES](https://discuss.elastic.co/u/SQIGGLES)\
**Replies:** 0\
**Last updated:** [February 21, 2024, 7:43pm UTC](https://discuss.elastic.co/t/not-opting-out-of-the-query-cache-authorization-is-not-allowed/353819 "2024-02-21T19:43:24Z")

</div>

I'm on a 3-node basic ES cluster and receiving lots of these in the logs: \[Name of our main db\] not opting out of the query cache; authorization is not allowed I'm perusing the logs as we are troubleshooting anything t…

---

## [More Index replicas = faster sync of data?](https://discuss.elastic.co/t/more-index-replicas-faster-sync-of-data/353314)

<div class="topic-metadata">

**Author:** [@SQIGGLES](https://discuss.elastic.co/u/SQIGGLES)\
**Replies:** 3\
**Last updated:** [February 21, 2024, 7:29pm UTC](https://discuss.elastic.co/t/more-index-replicas-faster-sync-of-data/353314 "2024-02-21T19:29:46Z")

</div>

Hello! I have a scenario that seems to function opposite documentation / logic. I hope someone can help me. environment: ES 6.8 3 node cluster on ALMA9 w/basic configuration (We should upgrade but can't at this time) …

---

## [\_reindex has suddenly stopped working inexplicably](https://discuss.elastic.co/t/reindex-has-suddenly-stopped-working-inexplicably/352375)

<div class="topic-metadata">

**Author:** [@mrodent](https://discuss.elastic.co/u/mrodent)\
**Replies:** 3\
**Last updated:** [February 21, 2024, 7:20pm UTC](https://discuss.elastic.co/t/reindex-has-suddenly-stopped-working-inexplicably/352375 "2024-02-21T19:20:16Z")

</div>

I've been using the \_reindex endpoint for some time now, about 2 months, without any problems. I'm running ES 8.6.2 on port 9500. The OS is W10. For some reason, as of this morning, any attempts to reindex are just not…

---

## [Adding multiple synonyms sets to a filter](https://discuss.elastic.co/t/adding-multiple-synonyms-sets-to-a-filter/353814)

<div class="topic-metadata">

**Author:** [@dat\_boi](https://discuss.elastic.co/u/dat_boi)\
**Replies:** 0\
**Last updated:** [February 21, 2024, 5:13pm UTC](https://discuss.elastic.co/t/adding-multiple-synonyms-sets-to-a-filter/353814 "2024-02-21T17:13:06Z")

</div>

i successfully created an index which uses a filter that has one synonyms\_set , but right when i try to use multiple synonyms Sets it fails with no error message, it creates an empty index with no status , here are my s…

---

## [Invalidated / Expired API Keys not being cleaned up](https://discuss.elastic.co/t/invalidated-expired-api-keys-not-being-cleaned-up/353806)

<div class="topic-metadata">

**Author:** [@Masok](https://discuss.elastic.co/u/Masok)\
**Replies:** 0\
**Last updated:** [February 21, 2024, 3:56pm UTC](https://discuss.elastic.co/t/invalidated-expired-api-keys-not-being-cleaned-up/353806 "2024-02-21T15:56:57Z")

</div>

Hi Our use case requires us to utilise short(ish) lived API Keys. After reading the documentation I was under the impression that expired / invalidated API Keys would be automatically deleted after a period of time (I t…

---

## [Conditions for external refreshes](https://discuss.elastic.co/t/conditions-for-external-refreshes/353803)

<div class="topic-metadata">

**Author:** [@spinscale](https://discuss.elastic.co/u/spinscale)\
**Replies:** 0\
**Last updated:** [February 21, 2024, 3:41pm UTC](https://discuss.elastic.co/t/conditions-for-external-refreshes/353803 "2024-02-21T15:41:44Z")

</div>

Hey, Elasticsearch has a metric for external refreshes in its RefreshStats, added in #38643, since 7.2. I am wondering what can trigger such an external refresh, if all requests have refresh=false set. Can a refresh b…

---

## [Elasticsearch cluster pricing calculation for on premise deployment](https://discuss.elastic.co/t/elasticsearch-cluster-pricing-calculation-for-on-premise-deployment/353760)

<div class="topic-metadata">

**Author:** [@RajuParipelly](https://discuss.elastic.co/u/RajuParipelly)\
**Replies:** 2\
**Last updated:** [February 21, 2024, 3:27pm UTC](https://discuss.elastic.co/t/elasticsearch-cluster-pricing-calculation-for-on-premise-deployment/353760 "2024-02-21T15:27:22Z")

</div>

Hi, How do we calculate elastic cluster license pricing for a on premise deployment?

---

## [Implementing Function Score in Elasticsearch with BM25, Views, and Matching Categories](https://discuss.elastic.co/t/implementing-function-score-in-elasticsearch-with-bm25-views-and-matching-categories/353787)

<div class="topic-metadata">

**Author:** [@dan\_kim](https://discuss.elastic.co/u/dan_kim)\
**Replies:** 3\
**Last updated:** [February 21, 2024, 2:59pm UTC](https://discuss.elastic.co/t/implementing-function-score-in-elasticsearch-with-bm25-views-and-matching-categories/353787 "2024-02-21T14:59:31Z")

</div>

\--in short ----- i want to reflect category mathcing every time it matches document's category field and it is list Hello! I'm in the process of implementing a search functionality using Elasticsearch's function scor…

---

## [How to make a match query with aggregations?](https://discuss.elastic.co/t/how-to-make-a-match-query-with-aggregations/353692)

<div class="topic-metadata">

**Author:** [@Oerlikon](https://discuss.elastic.co/u/Oerlikon)\
**Replies:** 4\
**Last updated:** [February 21, 2024, 2:30pm UTC](https://discuss.elastic.co/t/how-to-make-a-match-query-with-aggregations/353692 "2024-02-21T14:30:58Z")

</div>

Hi to all. I'm working on my university project, where I use Elasticsearch to find similar texts using a "match" query. Here is an example of one document from my dataset: ""\_ident": "5/425/2020", "versions": \[ { …

---

## [Connection is closed after setting CompatibilityMode(true) of RHLC](https://discuss.elastic.co/t/connection-is-closed-after-setting-compatibilitymode-true-of-rhlc/353708)

<div class="topic-metadata">

**Author:** [@Andreas\_Pichler](https://discuss.elastic.co/u/Andreas_Pichler)\
**Replies:** 1\
**Last updated:** [February 21, 2024, 12:39pm UTC](https://discuss.elastic.co/t/connection-is-closed-after-setting-compatibilitymode-true-of-rhlc/353708 "2024-02-21T12:39:28Z")

</div>

Hello dear community, I am currently working on making my ES7 client compatible with the ES8 cluster, but since the migration from Spring-Boot 2.3.x to 2.7.18 I am encountering the error below. To make the RestHighLevel…

---

## [Filter date histogram buckets](https://discuss.elastic.co/t/filter-date-histogram-buckets/353623)

<div class="topic-metadata">

**Author:** [@mwitsas](https://discuss.elastic.co/u/mwitsas)\
**Replies:** 3\
**Last updated:** [February 21, 2024, 12:32pm UTC](https://discuss.elastic.co/t/filter-date-histogram-buckets/353623 "2024-02-21T12:32:38Z")

</div>

Could anyone help me to understand how to filter the following query just to return minute buckets containing zero documents? Equivalent of a GROUP BY with a HAVING statement in SQL. My aim is to return a list of minutes…

---

## [Crea index with new fields](https://discuss.elastic.co/t/crea-index-with-new-fields/353157)

<div class="topic-metadata">

**Author:** [@goncalobsantos](https://discuss.elastic.co/u/goncalobsantos)\
**Replies:** 1\
**Last updated:** [February 21, 2024, 12:17pm UTC](https://discuss.elastic.co/t/crea-index-with-new-fields/353157 "2024-02-21T12:17:09Z")

</div>

I have an index that contains 1 document. This document has a field1 with value "B" and a field2 with value "C, D, E" (that is, the value in field2 is comma separated and can have variable lenght). I want to create a …

---

## [Issue with elasticsearch shards: \[search\_phase\_execution\_exception\] all shards failed](https://discuss.elastic.co/t/issue-with-elasticsearch-shards-search-phase-execution-exception-all-shards-failed/353783)

<div class="topic-metadata">

**Author:** [@Javier\_Sotoca](https://discuss.elastic.co/u/Javier_Sotoca)\
**Replies:** 0\
**Last updated:** [February 21, 2024, 11:09am UTC](https://discuss.elastic.co/t/issue-with-elasticsearch-shards-search-phase-execution-exception-all-shards-failed/353783 "2024-02-21T11:09:18Z")

</div>

Hello everyone. Since last week, we've ben having an issue with our elasticsearch in our project. We are using ES 7.2.0 and the error that appears when we run the starting scipt is the following: FATAL \[search\_phase\_e…

---

## [Elasticsearch keeps restarting](https://discuss.elastic.co/t/elasticsearch-keeps-restarting/351963)

<div class="topic-metadata">

**Author:** [@Moe\_Hmaidan](https://discuss.elastic.co/u/Moe_Hmaidan)\
**Replies:** 7\
**Last updated:** [February 21, 2024, 10:35am UTC](https://discuss.elastic.co/t/elasticsearch-keeps-restarting/351963 "2024-02-21T10:35:19Z")

</div>

Morning, We have an elasticsearch cluster consist of (3 master, 12 data) one of our data nodes keeps restarting due to the following error in logs. \[2024-01-29T10:52:57,011\]\[ERROR\]\[o.e.b.ElasticsearchUncaughtException…

---

## [Elasticsearch Policy](https://discuss.elastic.co/t/elasticsearch-policy/353741)

<div class="topic-metadata">

**Author:** [@Myungji\_Kim](https://discuss.elastic.co/u/Myungji_Kim)\
**Replies:** 1\
**Last updated:** [February 21, 2024, 10:34am UTC](https://discuss.elastic.co/t/elasticsearch-policy/353741 "2024-02-21T10:34:13Z")

</div>

Hello, I am currently using Elasticsearch v 7.10.2. For the indexes that are created, the policy is applied by creating a policy in the state management policies and applying policy to the indices. Is there a way to app…

---

## [Index.mapping.dimension\_fields.limit ignored - Limit of total dimension fields \[21\] has been exceeded](https://discuss.elastic.co/t/index-mapping-dimension-fields-limit-ignored-limit-of-total-dimension-fields-21-has-been-exceeded/353774)

<div class="topic-metadata">

**Author:** [@matled](https://discuss.elastic.co/u/matled)\
**Replies:** 0\
**Last updated:** [February 21, 2024, 10:23am UTC](https://discuss.elastic.co/t/index-mapping-dimension-fields-limit-ignored-limit-of-total-dimension-fields-21-has-been-exceeded/353774 "2024-02-21T10:23:34Z")

</div>

Elastic-Stack 8.12.1 We are currently trying to use a downsample ILM on Netflow Data using the elastiflow integration. It seems as the setting for the dimension fields is ignored from the index settings as there is the …

---

## [Can I apply index template to two index](https://discuss.elastic.co/t/can-i-apply-index-template-to-two-index/353747)

<div class="topic-metadata">

**Author:** [@Frances\_Chu](https://discuss.elastic.co/u/Frances_Chu)\
**Replies:** 0\
**Last updated:** [February 21, 2024, 6:26am UTC](https://discuss.elastic.co/t/can-i-apply-index-template-to-two-index/353747 "2024-02-21T06:26:14Z")

</div>

I create a ilm policy, then index template\_A Can I apply the index template\_A to two different index. e.g index\_A\* and index\_B\*. If yes how to set the rollover\_alias in the template's setting? ========================…

---

## [ElasticSearch with FsCrawler Eror](https://discuss.elastic.co/t/elasticsearch-with-fscrawler-eror/353712)

<div class="topic-metadata">

**Author:** [@DAVID\_MARIN\_ALVAREZ](https://discuss.elastic.co/u/DAVID_MARIN_ALVAREZ)\
**Replies:** 3\
**Last updated:** [February 20, 2024, 9:42pm UTC](https://discuss.elastic.co/t/elasticsearch-with-fscrawler-eror/353712 "2024-02-20T21:42:37Z")

</div>

I need help please ! I'm using Fscrawler for process diferent documents with diferents formats (pdf, wxcel, word, RTF, etc) but i'm have a stranger error: \` 10:03:29,868 INFO \[f.p.e.c.f.c.BootstrapChecks\] Memory \[Free/…

---

## [Elasticsearch Query: using match query with AND operator, fetching all the data](https://discuss.elastic.co/t/elasticsearch-query-using-match-query-with-and-operator-fetching-all-the-data/353724)

<div class="topic-metadata">

**Author:** [@Mohan\_T](https://discuss.elastic.co/u/Mohan_T)\
**Replies:** 2\
**Last updated:** [February 20, 2024, 8:32pm UTC](https://discuss.elastic.co/t/elasticsearch-query-using-match-query-with-and-operator-fetching-all-the-data/353724 "2024-02-20T20:32:03Z")

</div>

Query { "query": { "bool": { "should": \[ { "match": { "keywords.keyword\_values": { "query"…

---

## [How can i do a manual rollover for all indices to the newest index policy?](https://discuss.elastic.co/t/how-can-i-do-a-manual-rollover-for-all-indices-to-the-newest-index-policy/353416)

<div class="topic-metadata">

**Author:** [@idan\_amar](https://discuss.elastic.co/u/idan_amar)\
**Replies:** 3\
**Last updated:** [February 20, 2024, 7:20pm UTC](https://discuss.elastic.co/t/how-can-i-do-a-manual-rollover-for-all-indices-to-the-newest-index-policy/353416 "2024-02-20T19:20:32Z")

</div>

Is it possible to force a rollover for my indices to the latest updated policy? So they would be in the correct phase? GET \_ilm/policy/netlogstash\_policy { "netlogstash\_policy": { "version": 1, "modified\_date…

---

## [Terms aggregation on a nested field using Java SDK?](https://discuss.elastic.co/t/terms-aggregation-on-a-nested-field-using-java-sdk/353634)

<div class="topic-metadata">

**Author:** [@ndtreviv](https://discuss.elastic.co/u/ndtreviv)\
**Replies:** 6\
**Last updated:** [February 20, 2024, 2:28pm UTC](https://discuss.elastic.co/t/terms-aggregation-on-a-nested-field-using-java-sdk/353634 "2024-02-20T14:28:23Z")

</div>

I have a document mapping that looks like this: "domain": { "type": "nested", "properties": { "name": { "type": "keyword", "store": true }, "tl…

---

## [Failed to parse date field \[-386391600\] with format \[epoch\_millis\]](https://discuss.elastic.co/t/failed-to-parse-date-field-386391600-with-format-epoch-millis/353444)

<div class="topic-metadata">

**Author:** [@persik665](https://discuss.elastic.co/u/persik665)\
**Replies:** 6\
**Last updated:** [February 20, 2024, 2:23pm UTC](https://discuss.elastic.co/t/failed-to-parse-date-field-386391600-with-format-epoch-millis/353444 "2024-02-20T14:23:35Z")

</div>

Hi all, we have a problem with bulk requests: \[ElasticsearchException\[Elasticsearch exception \[type=mapper\_parsing\_exception, reason=failed to parse field \[clientBirthday\] of type \[date\] in document with id 'lBWSpo0B8q…

---

## [ElasticSearch failed to apply default image tag in OpenShift deployment](https://discuss.elastic.co/t/elasticsearch-failed-to-apply-default-image-tag-in-openshift-deployment/353630)

<div class="topic-metadata">

**Author:** [@Mike\_Kirby](https://discuss.elastic.co/u/Mike_Kirby)\
**Replies:** 2\
**Last updated:** [February 20, 2024, 12:54pm UTC](https://discuss.elastic.co/t/elasticsearch-failed-to-apply-default-image-tag-in-openshift-deployment/353630 "2024-02-20T12:54:20Z")

</div>

Good Afternoon my Elastic Guru's. I am in the process of using the Docker image of 8.11.4 to deploy Elasticsearch in an OpenShift envirorment. I am using the OpenShift User interface and it should be a simple enough ta…

---

## [ECK on GKE with local SSDs](https://discuss.elastic.co/t/eck-on-gke-with-local-ssds/353689)

<div class="topic-metadata">

**Author:** [@rh\_at](https://discuss.elastic.co/u/rh_at)\
**Replies:** 0\
**Last updated:** [February 20, 2024, 12:39pm UTC](https://discuss.elastic.co/t/eck-on-gke-with-local-ssds/353689 "2024-02-20T12:39:00Z")

</div>

Hi all, We've set a new elasticsearch cluster to store skywalking data. Settings are as following: 6 data nodes, each 16GB RAM (around 50% heap size), 16 cores, 4\*375G local SSDs disks (thats about 1.5TB each) 3 maste…

---

## [Block results for search terms](https://discuss.elastic.co/t/block-results-for-search-terms/353615)

<div class="topic-metadata">

**Author:** [@syrupman](https://discuss.elastic.co/u/syrupman)\
**Replies:** 1\
**Last updated:** [February 20, 2024, 12:37pm UTC](https://discuss.elastic.co/t/block-results-for-search-terms/353615 "2024-02-20T12:37:50Z")

</div>

We are using elastic.co to search images in our ecommerce with ELSER. Knowing that AI/ML will eventually commit a faux-paus, we need to be able to add negative words to each item so they won't show up on searches with t…

[Previous page](https://discuss.elastic.co/c/elastic-stack/elasticsearch/6.md?page=142)

[Next page](https://discuss.elastic.co/c/elastic-stack/elasticsearch/6.md?page=144)
