# Elasticsearch

**URL:** https://discuss.elastic.co/c/elastic-stack/elasticsearch/6.md?page=147

[Latest](https://discuss.elastic.co/latest.md) · [Categories](https://discuss.elastic.co/categories.md) · [Tags](https://discuss.elastic.co/tags.md)

**Page:** 148

---

## [Elasticsearch http.host default value](https://discuss.elastic.co/t/elasticsearch-http-host-default-value/351384)

<div class="topic-metadata">

**Author:** [@ilya-popkov](https://discuss.elastic.co/u/ilya-popkov)\
**Replies:** 4\
**Last updated:** [February 12, 2024, 9:19am UTC](https://discuss.elastic.co/t/elasticsearch-http-host-default-value/351384 "2024-02-12T09:19:35Z")

</div>

In the elasticsearch version 8.12 docs says "network.host default value is localhost and http.host value defaults is address given by network.host". But for default in fresh new elasticsearch http.host is equal 0.0.0.0 w…

---

## [Elasticsearch-setup-passwords auto -url "http://localhost:9200" i want to run this command but getting error](https://discuss.elastic.co/t/elasticsearch-setup-passwords-auto-url-http-localhost-9200-i-want-to-run-this-command-but-getting-error/352920)

<div class="topic-metadata">

**Author:** [@Karan37](https://discuss.elastic.co/u/Karan37)\
**Replies:** 2\
**Last updated:** [February 12, 2024, 9:07am UTC](https://discuss.elastic.co/t/elasticsearch-setup-passwords-auto-url-http-localhost-9200-i-want-to-run-this-command-but-getting-error/352920 "2024-02-12T09:07:51Z")

</div>

while running this command in the elasticsearch bin folder cli elasticsearch-setup-passwords auto -url "http://localhost:9200" it is giving this error Failed to authenticate user 'elastic' against http://localhost:920…

---

## [Boost results that starts with exact query](https://discuss.elastic.co/t/boost-results-that-starts-with-exact-query/352959)

<div class="topic-metadata">

**Author:** [@MMkMkMk](https://discuss.elastic.co/u/MMkMkMk)\
**Replies:** 2\
**Last updated:** [February 12, 2024, 8:57am UTC](https://discuss.elastic.co/t/boost-results-that-starts-with-exact-query/352959 "2024-02-12T08:57:17Z")

</div>

Hello, I'm trying to have a full-text query that boost results that starts with the entered query. For instance i have 2 book titles: "Viva Harry Potter" and "Harry Potter and the whatever stone". If the user search fo…

---

## [How to use minimum\_should\_match for prefix search?](https://discuss.elastic.co/t/how-to-use-minimum-should-match-for-prefix-search/352363)

<div class="topic-metadata">

**Author:** [@Leonid\_P](https://discuss.elastic.co/u/Leonid_P)\
**Replies:** 1\
**Last updated:** [February 12, 2024, 7:38am UTC](https://discuss.elastic.co/t/how-to-use-minimum-should-match-for-prefix-search/352363 "2024-02-12T07:38:10Z")

</div>

I want to make a search-as-you-type search service (with tokenization, analyzer etc.) and to use minimum\_should\_match in it, i.e. to show pages with three of four typed tokens but not with two of four. What is the best …

---

## [What is the best way to search one index with keyword and another index with vector and combine the search results?](https://discuss.elastic.co/t/what-is-the-best-way-to-search-one-index-with-keyword-and-another-index-with-vector-and-combine-the-search-results/352628)

<div class="topic-metadata">

**Author:** [@zli](https://discuss.elastic.co/u/zli)\
**Replies:** 1\
**Last updated:** [February 12, 2024, 7:33am UTC](https://discuss.elastic.co/t/what-is-the-best-way-to-search-one-index-with-keyword-and-another-index-with-vector-and-combine-the-search-results/352628 "2024-02-12T07:33:17Z")

</div>

Hi there, I'm currently working on a project where I need to perform searches across multiple indices in Elasticsearch and combine the results into a single ranked list. I have one index where keyword search is performe…

---

## [Best practices for managing lifecycles of small units of data](https://discuss.elastic.co/t/best-practices-for-managing-lifecycles-of-small-units-of-data/352670)

<div class="topic-metadata">

**Author:** [@japem](https://discuss.elastic.co/u/japem)\
**Replies:** 2\
**Last updated:** [February 12, 2024, 7:28am UTC](https://discuss.elastic.co/t/best-practices-for-managing-lifecycles-of-small-units-of-data/352670 "2024-02-12T07:28:48Z")

</div>

I have a use case where I have small-ish units of data (generally \<1GB) that I want to be able to manage the lifecycles of separately. Essentially, each user has information that we want to store in a hot data tier durin…

---

## [Elasticsearch Java Api Client (7.17.16) - GetIndexResponse](https://discuss.elastic.co/t/elasticsearch-java-api-client-7-17-16-getindexresponse/353035)

<div class="topic-metadata">

**Author:** [@SElasticsearch](https://discuss.elastic.co/u/SElasticsearch)\
**Replies:** 0\
**Last updated:** [February 12, 2024, 5:41am UTC](https://discuss.elastic.co/t/elasticsearch-java-api-client-7-17-16-getindexresponse/353035 "2024-02-12T05:41:55Z")

</div>

I am trying to fetch the list of index names matching an index prefix (for example: abc-2024-02\*) GetIndexRequest request = new GetIndexRequest.Builder().index("abc-2024-02\*").allowNoIndices(false).expandWildcards(Expan…

---

## [Ingest Pipeline Creating Grok Pattern with string as dependency](https://discuss.elastic.co/t/ingest-pipeline-creating-grok-pattern-with-string-as-dependency/353014)

<div class="topic-metadata">

**Author:** [@pupit](https://discuss.elastic.co/u/pupit)\
**Replies:** 1\
**Last updated:** [February 11, 2024, 10:57pm UTC](https://discuss.elastic.co/t/ingest-pipeline-creating-grok-pattern-with-string-as-dependency/353014 "2024-02-11T22:57:36Z")

</div>

Hi, I am exploring ingest pipeline. The grok is working as expected. But, I am looking into just executing/running the grok pattern if the field have a certain string. How can I add a if condition where "if message =~…

---

## [Elasticsearch High CPU usage](https://discuss.elastic.co/t/elasticsearch-high-cpu-usage/352998)

<div class="topic-metadata">

**Author:** [@kkkk7](https://discuss.elastic.co/u/kkkk7)\
**Replies:** 2\
**Last updated:** [February 11, 2024, 2:54am UTC](https://discuss.elastic.co/t/elasticsearch-high-cpu-usage/352998 "2024-02-11T02:54:59Z")

</div>

Hello I'm using version 7.3.2 (this is a project since 2019 so a bit old version) After a years pass by my elastic stack CPU usage very high so we decide extends the CPU core but seem like the usage will growth bigger …

---

## [Getting the "Can't apply \[synonyms\_set\]! Loading synonyms from index is supported only for search time synonyms!" error when creating index](https://discuss.elastic.co/t/getting-the-cant-apply-synonyms-set-loading-synonyms-from-index-is-supported-only-for-search-time-synonyms-error-when-creating-index/352990)

<div class="topic-metadata">

**Author:** [@Hatef\_Alipour](https://discuss.elastic.co/u/Hatef_Alipour)\
**Replies:** 2\
**Last updated:** [February 10, 2024, 12:11pm UTC](https://discuss.elastic.co/t/getting-the-cant-apply-synonyms-set-loading-synonyms-from-index-is-supported-only-for-search-time-synonyms-error-when-creating-index/352990 "2024-02-10T12:11:58Z")

</div>

We have an index in Elasticsearch 7.17, It uses synonym files you can see the full structure below: { "my-index" : { "settings" : { "index" : { "routing" : { "allocation" : { "i…

---

## [Super user elastic can't run as regular user](https://discuss.elastic.co/t/super-user-elastic-cant-run-as-regular-user/352974)

<div class="topic-metadata">

**Author:** [@data\_smith](https://discuss.elastic.co/u/data_smith)\
**Replies:** 1\
**Last updated:** [February 9, 2024, 10:02pm UTC](https://discuss.elastic.co/t/super-user-elastic-cant-run-as-regular-user/352974 "2024-02-09T22:02:15Z")

</div>

Shouldn't elastic user be able to run\_as anyone? I have a proxy in front of Kibana and in the past I could set it to run as a user I would use the elastic user to authenticate and then run as someone else. Now it's sa…

---

## [How to automate query from trained ML model](https://discuss.elastic.co/t/how-to-automate-query-from-trained-ml-model/352956)

<div class="topic-metadata">

**Author:** [@federica.forti](https://discuss.elastic.co/u/federica.forti)\
**Replies:** 1\
**Last updated:** [February 9, 2024, 8:49pm UTC](https://discuss.elastic.co/t/how-to-automate-query-from-trained-ml-model/352956 "2024-02-09T20:49:56Z")

</div>

Hi, we have added a custom model among the machine learning models. During testing, we obtain, as a result, a vector that we use in the following query: GET indexname/\_search { "query": { "script\_score": { …

---

## [Search and Pagination in .Net](https://discuss.elastic.co/t/search-and-pagination-in-net/352973)

<div class="topic-metadata">

**Author:** [@eric.paul](https://discuss.elastic.co/u/eric.paul)\
**Replies:** 0\
**Last updated:** [February 9, 2024, 7:42pm UTC](https://discuss.elastic.co/t/search-and-pagination-in-net/352973 "2024-02-09T19:42:26Z")

</div>

I am looking for an example of how to use search\_after for pagination using the elastic.client in c#. I can see where the method is and that it takes a type of ICollection\<FieldValue\>? but I do not know how to get this f…

---

## [Filebeat -\> Elasticsearch ingestion: Document loss](https://discuss.elastic.co/t/filebeat-elasticsearch-ingestion-document-loss/352952)

<div class="topic-metadata">

**Author:** [@tmslara.a](https://discuss.elastic.co/u/tmslara.a)\
**Replies:** 7\
**Last updated:** [February 9, 2024, 7:24pm UTC](https://discuss.elastic.co/t/filebeat-elasticsearch-ingestion-document-loss/352952 "2024-02-09T19:24:34Z")

</div>

Hello, We are having some problems with document loss when ingesting data into Elasticsearch using Filebeat. I'll describe our approach to data ingest. We are running a process. This process generates some data that we…

---

## [Gettting error migrating data stream](https://discuss.elastic.co/t/gettting-error-migrating-data-stream/352947)

<div class="topic-metadata">

**Author:** [@James83](https://discuss.elastic.co/u/James83)\
**Replies:** 0\
**Last updated:** [February 9, 2024, 2:31pm UTC](https://discuss.elastic.co/t/gettting-error-migrating-data-stream/352947 "2024-02-09T14:31:43Z")

</div>

Hello, I'm in the process of migrating ELK (both servers on same version 7.17). I'm trying to restore an index wich has the ilm-history datastream. The index is restored but I'm getting this error in log : java.lang.Il…

---

## [Update ELK version](https://discuss.elastic.co/t/update-elk-version/352573)

<div class="topic-metadata">

**Author:** [@hiruni.insyncit.net](https://discuss.elastic.co/u/hiruni.insyncit.net)\
**Replies:** 7\
**Last updated:** [February 9, 2024, 2:04pm UTC](https://discuss.elastic.co/t/update-elk-version/352573 "2024-02-09T14:04:16Z")

</div>

Hi, I'm planning to update ELK version 8.2 to 8.12 version. Does ELK version 8.12 require additional CPU, RAM to deploy the new version of ELK or it's not required additional resources to upgrade the ELK version. Than…

---

## [How to improve ELSERv2 ingest throughput?](https://discuss.elastic.co/t/how-to-improve-elserv2-ingest-throughput/352636)

<div class="topic-metadata">

**Author:** [@Rakesh\_Nayak](https://discuss.elastic.co/u/Rakesh_Nayak)\
**Replies:** 3\
**Last updated:** [February 9, 2024, 1:16pm UTC](https://discuss.elastic.co/t/how-to-improve-elserv2-ingest-throughput/352636 "2024-02-09T13:16:06Z")

</div>

Hello Team, We need your guidance on "Improving ELSERv2 optimized model ingest throughput". As per the link we can't ingest more than 26docs per sec no matter what the allocations are. A little background on our inges…

---

## [How to remove text from variable. Alerts](https://discuss.elastic.co/t/how-to-remove-text-from-variable-alerts/352937)

<div class="topic-metadata">

**Author:** [@Nidro96](https://discuss.elastic.co/u/Nidro96)\
**Replies:** 0\
**Last updated:** [February 9, 2024, 1:13pm UTC](https://discuss.elastic.co/t/how-to-remove-text-from-variable-alerts/352937 "2024-02-09T13:13:31Z")

</div>

Hi. First post, so I am sorry if this is in the wrong categorie. I am trying to set up an alert for my system. I got everything working but having problems with formating the message sent to the users. I have the follow…

---

## [Identifying Duplicate Records Based on Multiple Fields in Elasticsearch](https://discuss.elastic.co/t/identifying-duplicate-records-based-on-multiple-fields-in-elasticsearch/352115)

<div class="topic-metadata">

**Author:** [@Bikash\_Hutait](https://discuss.elastic.co/u/Bikash_Hutait)\
**Replies:** 7\
**Last updated:** [February 9, 2024, 12:13pm UTC](https://discuss.elastic.co/t/identifying-duplicate-records-based-on-multiple-fields-in-elasticsearch/352115 "2024-02-09T12:13:36Z")

</div>

I have a dataset in Elasticsearch containing records related to users and their assistants. I need to identify duplicate records for a specific file\_id. A record should be considered a duplicate if the fields FirstName, L…

---

## [Correct way to have different databases connected to different elasticsearches](https://discuss.elastic.co/t/correct-way-to-have-different-databases-connected-to-different-elasticsearches/352856)

<div class="topic-metadata">

**Author:** [@mike\_mike](https://discuss.elastic.co/u/mike_mike)\
**Replies:** 2\
**Last updated:** [February 9, 2024, 9:57am UTC](https://discuss.elastic.co/t/correct-way-to-have-different-databases-connected-to-different-elasticsearches/352856 "2024-02-09T09:57:12Z")

</div>

Hello all, I am new here and kinda new to the way Elasticsearch should work (cause I am already working with it, but I miss lots of documentation principles). We mainly use ES as a faster way to retrieve important data…

---

## [StackConfigPolicy ECK Index template fails to create](https://discuss.elastic.co/t/stackconfigpolicy-eck-index-template-fails-to-create/352909)

<div class="topic-metadata">

**Author:** [@PLR-KMD](https://discuss.elastic.co/u/PLR-KMD)\
**Replies:** 0\
**Last updated:** [February 9, 2024, 7:20am UTC](https://discuss.elastic.co/t/stackconfigpolicy-eck-index-template-fails-to-create/352909 "2024-02-09T07:20:45Z")

</div>

Hi, According to docs on Elastic Stack configuration policies | Elastic Cloud on Kubernetes \[2.11\] | Elastic I'm trying to deploy simple ILM and index template. Everything works fine when I deploy ILM only but I can't g…

---

## [AccessDeniedException for path.repo while starting Elasticsearch](https://discuss.elastic.co/t/accessdeniedexception-for-path-repo-while-starting-elasticsearch/322428)

<div class="topic-metadata">

**Author:** [@cr\_168328](https://discuss.elastic.co/u/cr_168328)\
**Replies:** 3\
**Last updated:** [February 9, 2024, 5:49am UTC](https://discuss.elastic.co/t/accessdeniedexception-for-path-repo-while-starting-elasticsearch/322428 "2024-02-09T05:49:19Z")

</div>

I have installed elasticsearch Debian package. In /etc/elasticsearch/elasticsearch.yml file, I have this added: path.repo: \["/home/admin/backup\_extracted/var/lib/elasticsearch/es\_bkp"\]. The ownership of backup\_exctracted …

---

## [Simple\_query\_string and query\_string not working as expected](https://discuss.elastic.co/t/simple-query-string-and-query-string-not-working-as-expected/352905)

<div class="topic-metadata">

**Author:** [@Sankar\_S](https://discuss.elastic.co/u/Sankar_S)\
**Replies:** 0\
**Last updated:** [February 9, 2024, 5:05am UTC](https://discuss.elastic.co/t/simple-query-string-and-query-string-not-working-as-expected/352905 "2024-02-09T05:05:27Z")

</div>

I have a title field in document 1 document has $kitkat as value and another has "title" : "Testing Special\_character Elastic Search in $reference entry search" { "query": { "bool": { "must": \[ …

---

## [Failed to load SSL configuration \[xpack.security.transport.ssl\] - cannot specify both \[keystore.secure\_password\] and \[keystore.password\]](https://discuss.elastic.co/t/failed-to-load-ssl-configuration-xpack-security-transport-ssl-cannot-specify-both-keystore-secure-password-and-keystore-password/352748)

<div class="topic-metadata">

**Author:** [@Karan37](https://discuss.elastic.co/u/Karan37)\
**Replies:** 2\
**Last updated:** [February 9, 2024, 4:55am UTC](https://discuss.elastic.co/t/failed-to-load-ssl-configuration-xpack-security-transport-ssl-cannot-specify-both-keystore-secure-password-and-keystore-password/352748 "2024-02-09T04:55:24Z")

</div>

when running the elasticsearch.bat command after generating the certificates with the password it is showing only this error "fatal exception while booting Elasticsearchorg.elasticsearch.ElasticsearchSecurityException: f…

---

## [Can't write to logstash (ELK)](https://discuss.elastic.co/t/cant-write-to-logstash-elk/352887)

<div class="topic-metadata">

**Author:** [@Rotem\_Orbach](https://discuss.elastic.co/u/Rotem_Orbach)\
**Replies:** 0\
**Last updated:** [February 8, 2024, 6:13pm UTC](https://discuss.elastic.co/t/cant-write-to-logstash-elk/352887 "2024-02-08T18:13:15Z")

</div>

Hi, I'm trying to write to ELK. (using Docker) Elastic is already installed and working properly. I've installed Logstash on docker as well. Problem is I can't see any logs being generated on kibana, I thought tha…

---

## [Load Null values to Index Key column](https://discuss.elastic.co/t/load-null-values-to-index-key-column/352879)

<div class="topic-metadata">

**Author:** [@Debasis\_Mallick](https://discuss.elastic.co/u/Debasis_Mallick)\
**Replies:** 0\
**Last updated:** [February 8, 2024, 4:38pm UTC](https://discuss.elastic.co/t/load-null-values-to-index-key-column/352879 "2024-02-08T16:38:29Z")

</div>

Hi Team, we had created index with location\_timestamp as key of type date and format "epoch\_millis" as below. "location\_timestamp":{ "type": "date", "format": "epoch\_millis" }, But while loading data from…

---

## [Terms aggregation split by coma](https://discuss.elastic.co/t/terms-aggregation-split-by-coma/352798)

<div class="topic-metadata">

**Author:** [@Imad\_Ourak](https://discuss.elastic.co/u/Imad_Ourak)\
**Replies:** 5\
**Last updated:** [February 8, 2024, 4:32pm UTC](https://discuss.elastic.co/t/terms-aggregation-split-by-coma/352798 "2024-02-08T16:32:51Z")

</div>

I have a bunch of Elasticsearch documents that contain information about study fields. I'm trying to aggregate the studyfields field to extract the number of "study fields" instances from the job posting. e.g. data scien…

---

## [\[ERROR\]\[discovery.ec2 \] \[host\] unexpected error while joining cluster, trying again org.elasticsearch.ElasticsearchException: Ping execution failed](https://discuss.elastic.co/t/error-discovery-ec2-host-unexpected-error-while-joining-cluster-trying-again-org-elasticsearch-elasticsearchexception-ping-execution-failed/352690)

<div class="topic-metadata">

**Author:** [@jnunez87](https://discuss.elastic.co/u/jnunez87)\
**Replies:** 7\
**Last updated:** [February 8, 2024, 4:22pm UTC](https://discuss.elastic.co/t/error-discovery-ec2-host-unexpected-error-while-joining-cluster-trying-again-org-elasticsearch-elasticsearchexception-ping-execution-failed/352690 "2024-02-08T16:22:45Z")

</div>

Hello all Today we had a very strange error appear today in our cluster that is preventing the node from connecting. Below is our errors \[2024-02-06 23:18:11,590\]\[ERROR\]\[discovery.ec2 \] \[Windeagle\] unexpect…

---

## [Migrating from RestClient to ElasticsearchClient](https://discuss.elastic.co/t/migrating-from-restclient-to-elasticsearchclient/352575)

<div class="topic-metadata">

**Author:** [@Tony\_Clarke](https://discuss.elastic.co/u/Tony_Clarke)\
**Replies:** 6\
**Last updated:** [February 8, 2024, 3:54pm UTC](https://discuss.elastic.co/t/migrating-from-restclient-to-elasticsearchclient/352575 "2024-02-08T15:54:36Z")

</div>

Hi, I'm trying to migrate from using the org.elasticsearch.client.RestClient to co.elastic.clients.elasticsearch.ElasticsearchClient. However, I'm noticing one difference in behavior. The ElasticsearchClient has bespoke…

---

## [API calls taking more than 10s](https://discuss.elastic.co/t/api-calls-taking-more-than-10s/352769)

<div class="topic-metadata">

**Author:** [@kvmuralidhar](https://discuss.elastic.co/u/kvmuralidhar)\
**Replies:** 1\
**Last updated:** [February 8, 2024, 3:28pm UTC](https://discuss.elastic.co/t/api-calls-taking-more-than-10s/352769 "2024-02-08T15:28:35Z")

</div>

Hi There, We are running Elasticsearch version 8.8.1 (on prem) and have the following configuration. 3 coordinator nodes 3 dedicated master nodes 17 hot nodes 20 cold nodes 6 frozen nodes (Each frozen node has abou…

[Previous page](https://discuss.elastic.co/c/elastic-stack/elasticsearch/6.md?page=146)

[Next page](https://discuss.elastic.co/c/elastic-stack/elasticsearch/6.md?page=148)
