# Elasticsearch

**URL:** https://discuss.elastic.co/c/elastic-stack/elasticsearch/6.md?page=149

[Latest](https://discuss.elastic.co/latest.md) · [Categories](https://discuss.elastic.co/categories.md) · [Tags](https://discuss.elastic.co/tags.md)

**Page:** 150

---

## [CONNECT to remote clusters](https://discuss.elastic.co/t/connect-to-remote-clusters/352647)

<div class="topic-metadata">

**Author:** [@Nathan\_Nieselpriem](https://discuss.elastic.co/u/Nathan_Nieselpriem)\
**Replies:** 0\
**Last updated:** [February 6, 2024, 3:20pm UTC](https://discuss.elastic.co/t/connect-to-remote-clusters/352647 "2024-02-06T15:20:39Z")

</div>

Hi fellows, I need your help so bad. I am running 2 elasticsearch cluster as docker container http port 9200 transport port 9300 But when I try to configure the remote cluster like that: name docker-cluster seed no…

---

## [Is there a limit on disk size for single ES node?](https://discuss.elastic.co/t/is-there-a-limit-on-disk-size-for-single-es-node/352635)

<div class="topic-metadata">

**Author:** [@umuteyilmaz](https://discuss.elastic.co/u/umuteyilmaz)\
**Replies:** 1\
**Last updated:** [February 6, 2024, 2:04pm UTC](https://discuss.elastic.co/t/is-there-a-limit-on-disk-size-for-single-es-node/352635 "2024-02-06T14:04:29Z")

</div>

Is there a limit on disk size for single ES node? We have 900 GB storage size on ES node, we want to extend to 2 TB, Will I encounter any problems?

---

## [Example usage of GetSourceRequest](https://discuss.elastic.co/t/example-usage-of-getsourcerequest/351923)

<div class="topic-metadata">

**Author:** [@Tony\_Clarke](https://discuss.elastic.co/u/Tony_Clarke)\
**Replies:** 4\
**Last updated:** [February 6, 2024, 12:39pm UTC](https://discuss.elastic.co/t/example-usage-of-getsourcerequest/351923 "2024-02-06T12:39:37Z")

</div>

Trying to use ElasticsearchClient to get the source of a document. No problem getting the document but when I use GetSourceRequest as below it results in an error during deserialization. I couldn't find any unit tests or…

---

## [Where i can i get the implementation examples of java api client with elasticsearch for all type of query request and responses](https://discuss.elastic.co/t/where-i-can-i-get-the-implementation-examples-of-java-api-client-with-elasticsearch-for-all-type-of-query-request-and-responses/352625)

<div class="topic-metadata">

**Author:** [@Krishna\_Sailesh](https://discuss.elastic.co/u/Krishna_Sailesh)\
**Replies:** 1\
**Last updated:** [February 6, 2024, 12:23pm UTC](https://discuss.elastic.co/t/where-i-can-i-get-the-implementation-examples-of-java-api-client-with-elasticsearch-for-all-type-of-query-request-and-responses/352625 "2024-02-06T12:23:54Z")

</div>

Hi Team I am revamping the HLRC code with a Java Api Client package. there is a lot of syntax changes in the Java Api Client package. where can I get the all package docs and examples for connecting to elasticsearch in …

---

## [Is the nodes load a criteria for shard allocation?](https://discuss.elastic.co/t/is-the-nodes-load-a-criteria-for-shard-allocation/352170)

<div class="topic-metadata">

**Author:** [@voharunado](https://discuss.elastic.co/u/voharunado)\
**Replies:** 17\
**Last updated:** [February 6, 2024, 12:06pm UTC](https://discuss.elastic.co/t/is-the-nodes-load-a-criteria-for-shard-allocation/352170 "2024-02-06T12:06:38Z")

</div>

Hi, I would like to know if Elasticsearch is taking the load of the nodes to decide how to reballance shards? I have seen cluster.routing.allocation.balance.write\_load in the documentation, but I'm not sure how that wor…

---

## [UpdateRequest with JSON in JavaAPIClient getting parsing error](https://discuss.elastic.co/t/updaterequest-with-json-in-javaapiclient-getting-parsing-error/352533)

<div class="topic-metadata">

**Author:** [@Krishna\_Sailesh](https://discuss.elastic.co/u/Krishna_Sailesh)\
**Replies:** 4\
**Last updated:** [February 6, 2024, 12:02pm UTC](https://discuss.elastic.co/t/updaterequest-with-json-in-javaapiclient-getting-parsing-error/352533 "2024-02-06T12:02:04Z")

</div>

I am trying to update the existing record with Java API client but getting the below issue. index record json { "docId": "1", "id": 1, "name": "aegon", "details": { "id":1234 } } // update json Str…

---

## [Problems setting up documents using geo\_point](https://discuss.elastic.co/t/problems-setting-up-documents-using-geo-point/352618)

<div class="topic-metadata">

**Author:** [@Dennis\_Christensen](https://discuss.elastic.co/u/Dennis_Christensen)\
**Replies:** 4\
**Last updated:** [February 6, 2024, 11:54am UTC](https://discuss.elastic.co/t/problems-setting-up-documents-using-geo-point/352618 "2024-02-06T11:54:58Z")

</div>

I am using C# Nest version 8, and have an Index of hotels with GeoLocation. My document have the following property: public GeoCoordinate geoCoordinate { get; set; } When I try to do a geo search I end up with an empt…

---

## [Exact match Query: ex: When I am trying to search for marble flooring the following matches should be fetched](https://discuss.elastic.co/t/exact-match-query-ex-when-i-am-trying-to-search-for-marble-flooring-the-following-matches-should-be-fetched/352589)

<div class="topic-metadata">

**Author:** [@Mohan\_T](https://discuss.elastic.co/u/Mohan_T)\
**Replies:** 9\
**Last updated:** [February 6, 2024, 11:54am UTC](https://discuss.elastic.co/t/exact-match-query-ex-when-i-am-trying-to-search-for-marble-flooring-the-following-matches-should-be-fetched/352589 "2024-02-06T11:54:39Z")

</div>

When I am trying to search for marble flooring the following matches should be fetched marble flooring marbles flooring flooring marble flooring marbles marble floor marbles floor marble marbles flooring floor { "si…

---

## [Keyword Array Field Removes Duplicates in Queries](https://discuss.elastic.co/t/keyword-array-field-removes-duplicates-in-queries/352582)

<div class="topic-metadata">

**Author:** [@aeroplane380](https://discuss.elastic.co/u/aeroplane380)\
**Replies:** 2\
**Last updated:** [February 6, 2024, 9:52am UTC](https://discuss.elastic.co/t/keyword-array-field-removes-duplicates-in-queries/352582 "2024-02-06T09:52:24Z")

</div>

This post relates to a problem I have encountered in my business production database, but will be described with a minimal reproducible example. I have an index with the following mapping: { "properties": { "test…

---

## [Indexing rate became very low in elastic cluster](https://discuss.elastic.co/t/indexing-rate-became-very-low-in-elastic-cluster/352377)

<div class="topic-metadata">

**Author:** [@Subrahmanyam\_Veerank](https://discuss.elastic.co/u/Subrahmanyam_Veerank)\
**Replies:** 14\
**Last updated:** [February 6, 2024, 9:38am UTC](https://discuss.elastic.co/t/indexing-rate-became-very-low-in-elastic-cluster/352377 "2024-02-06T09:38:42Z")

</div>

Hi sir. @stephenb The indexing rate of our cluster become very low and even search results are getting delayed. cluster details: 3 Master nodes - cpu 4 cores -RAM 16GB 4 Data nodes (out of 4 one node is given both ing…

---

## [Unable connect to Elasticsearch from another machine](https://discuss.elastic.co/t/unable-connect-to-elasticsearch-from-another-machine/352204)

<div class="topic-metadata">

**Author:** [@MinaYousry](https://discuss.elastic.co/u/MinaYousry)\
**Replies:** 1\
**Last updated:** [February 6, 2024, 9:30am UTC](https://discuss.elastic.co/t/unable-connect-to-elasticsearch-from-another-machine/352204 "2024-02-06T09:30:02Z")

</div>

I installed Elasticsearch on one machine and my application, developed with Spring Boot, on another machine. When I try to connect, I face a connection refused error. However, when I run the command : curl http://server…

---

## [How to pass specific characters password to ElasticSearch through Sulu/ArticleBundle](https://discuss.elastic.co/t/how-to-pass-specific-characters-password-to-elasticsearch-through-sulu-articlebundle/352544)

<div class="topic-metadata">

**Author:** [@Agdi](https://discuss.elastic.co/u/Agdi)\
**Replies:** 6\
**Last updated:** [February 6, 2024, 9:24am UTC](https://discuss.elastic.co/t/how-to-pass-specific-characters-password-to-elasticsearch-through-sulu-articlebundle/352544 "2024-02-06T09:24:18Z")

</div>

Elasticsearch Version 6.8.0 Installed Plugins Sulu - SuluArticle/Bundle Java Version bundled OS Version Ubuntu 20.04 Problem Description I'm working on a project using Sulu 2.4.15 - php 8.2 - Symfony 5.5 - Sulu/Artic…

---

## [Upgrading cluster and its monitoring cluster](https://discuss.elastic.co/t/upgrading-cluster-and-its-monitoring-cluster/352608)

<div class="topic-metadata">

**Author:** [@Gerardo\_Zenobi](https://discuss.elastic.co/u/Gerardo_Zenobi)\
**Replies:** 2\
**Last updated:** [February 6, 2024, 8:48am UTC](https://discuss.elastic.co/t/upgrading-cluster-and-its-monitoring-cluster/352608 "2024-02-06T08:48:59Z")

</div>

Hi there, When I set up my separate monitoring cluster for my production cluster, I did it in the same version 8.8.2 as the production one. Now I want to upgrade the production cluster version to 8.12. How should I pr…

---

## [After ES7.5 why "WHERE isn't (yet) compatible with scalar functions on nested fields"](https://discuss.elastic.co/t/after-es7-5-why-where-isnt-yet-compatible-with-scalar-functions-on-nested-fields/352611)

<div class="topic-metadata">

**Author:** [@muhao1020](https://discuss.elastic.co/u/muhao1020)\
**Replies:** 0\
**Last updated:** [February 6, 2024, 8:48am UTC](https://discuss.elastic.co/t/after-es7-5-why-where-isnt-yet-compatible-with-scalar-functions-on-nested-fields/352611 "2024-02-06T08:48:12Z")

</div>

ref : SQL Limitations | Elasticsearch Guide \[7.10\] | Elastic why above limit occurded?

---

## [Cannot add node to ELK cluster 8. ( redhat - rpm package)](https://discuss.elastic.co/t/cannot-add-node-to-elk-cluster-8-redhat-rpm-package/352609)

<div class="topic-metadata">

**Author:** [@duong\_pham](https://discuss.elastic.co/u/duong_pham)\
**Replies:** 0\
**Last updated:** [February 6, 2024, 8:34am UTC](https://discuss.elastic.co/t/cannot-add-node-to-elk-cluster-8-redhat-rpm-package/352609 "2024-02-06T08:34:24Z")

</div>

Hi all, I am new with ELK I follow the guide on internet to install ELK cluster 8. on redhat 7 by rpm package ( 3 nodes) But i met this error \[root@elk02 elasticsearch\]# /usr/share/elasticsearch/bin/elasticsearch-rec…

---

## [How to run curl and hide the username's password from command?](https://discuss.elastic.co/t/how-to-run-curl-and-hide-the-usernames-password-from-command/352567)

<div class="topic-metadata">

**Author:** [@mpniel](https://discuss.elastic.co/u/mpniel)\
**Replies:** 3\
**Last updated:** [February 5, 2024, 11:57pm UTC](https://discuss.elastic.co/t/how-to-run-curl-and-hide-the-usernames-password-from-command/352567 "2024-02-05T23:57:34Z")

</div>

How to run curl and hide the username's password from command?

---

## [How to get count of specific value in elasticsearch java clinet](https://discuss.elastic.co/t/how-to-get-count-of-specific-value-in-elasticsearch-java-clinet/352465)

<div class="topic-metadata">

**Author:** [@Abdalrazag\_Al-Shrufa](https://discuss.elastic.co/u/Abdalrazag_Al-Shrufa)\
**Replies:** 1\
**Last updated:** [February 5, 2024, 9:43pm UTC](https://discuss.elastic.co/t/how-to-get-count-of-specific-value-in-elasticsearch-java-clinet/352465 "2024-02-05T21:43:49Z")

</div>

I am using elasticsearch-java 8.12, and I want to get the count of specific value, in my example I have log index, and there is a field called result, I want to get the number of documents that the result field is "corr…

---

## [Formal grammar for DSL?](https://discuss.elastic.co/t/formal-grammar-for-dsl/352564)

<div class="topic-metadata">

**Author:** [@Steph\_van\_Schalkwyk](https://discuss.elastic.co/u/Steph_van_Schalkwyk)\
**Replies:** 0\
**Last updated:** [February 5, 2024, 7:02pm UTC](https://discuss.elastic.co/t/formal-grammar-for-dsl/352564 "2024-02-05T19:02:21Z")

</div>

Continuing the discussion from Formal Grammar of Query DSL?: Still looking. I can find SQL and Painless grammars, but not DSL.

---

## [Corrupt primary shard, how to recover from replica shard?](https://discuss.elastic.co/t/corrupt-primary-shard-how-to-recover-from-replica-shard/352561)

<div class="topic-metadata">

**Author:** [@ncluff](https://discuss.elastic.co/u/ncluff)\
**Replies:** 2\
**Last updated:** [February 5, 2024, 6:34pm UTC](https://discuss.elastic.co/t/corrupt-primary-shard-how-to-recover-from-replica-shard/352561 "2024-02-05T18:34:49Z")

</div>

I have an index with 3 primary shards and 1 replica. Primary shard 1 for some reason goes corrupt. The error mentions merge failed, org.apache.lucene.index.CorruptIndexException which I'm looking into. Am I right thinkin…

---

## [Was CRC32 in version 7.x of Elasticsearch?](https://discuss.elastic.co/t/was-crc32-in-version-7-x-of-elasticsearch/352558)

<div class="topic-metadata">

**Author:** [@ncluff](https://discuss.elastic.co/u/ncluff)\
**Replies:** 1\
**Last updated:** [February 5, 2024, 5:58pm UTC](https://discuss.elastic.co/t/was-crc32-in-version-7-x-of-elasticsearch/352558 "2024-02-05T17:58:33Z")

</div>

I noticed this post where David Turner mentions the troubleshooting guide for corruption. The documentation started in 8.3, but I'm curious if this is the same for version 7.17.4? Backstory, I have a deployment on VMWar…

---

## [Error while trying to new node to existing cluster. Bootstrap settings failed](https://discuss.elastic.co/t/error-while-trying-to-new-node-to-existing-cluster-bootstrap-settings-failed/352404)

<div class="topic-metadata">

**Author:** [@charvi23](https://discuss.elastic.co/u/charvi23)\
**Replies:** 2\
**Last updated:** [February 5, 2024, 3:43pm UTC](https://discuss.elastic.co/t/error-while-trying-to-new-node-to-existing-cluster-bootstrap-settings-failed/352404 "2024-02-05T15:43:28Z")

</div>

Getting error while adding new node to cluster. \[1\] bootstrap checks failed. You must address the points described in the following \[1\] lines before starting Elasticsearch. For more information see \[ https://www.elastic…

---

## [How to parse Mime x-wine-extension-ini files](https://discuss.elastic.co/t/how-to-parse-mime-x-wine-extension-ini-files/352541)

<div class="topic-metadata">

**Author:** [@Admin\_Zee9](https://discuss.elastic.co/u/Admin_Zee9)\
**Replies:** 0\
**Last updated:** [February 5, 2024, 2:06pm UTC](https://discuss.elastic.co/t/how-to-parse-mime-x-wine-extension-ini-files/352541 "2024-02-05T14:06:14Z")

</div>

Hello, Has anyone had to deal with parsing a MIME type x-wine-extension-ini file? I need to convert many of them to CSV or XML using AWS Athena. I found that a Grok pattern could be helpful, but this is the first time…

---

## [About the ILM policy implented and on the post observations](https://discuss.elastic.co/t/about-the-ilm-policy-implented-and-on-the-post-observations/351851)

<div class="topic-metadata">

**Author:** [@Ravi\_Pattar](https://discuss.elastic.co/u/Ravi_Pattar)\
**Replies:** 6\
**Last updated:** [February 5, 2024, 1:16pm UTC](https://discuss.elastic.co/t/about-the-ilm-policy-implented-and-on-the-post-observations/351851 "2024-02-05T13:16:52Z")

</div>

Hello, Recently I have implemented ILM policy on of the production setup. However, the rollover for the existing ILM policy seems to be working fine. But I am seeing indices for other version e.g. 8.x are utilizing the…

---

## [Unable to access 'path.data' (/data/db/elasticsearch)](https://discuss.elastic.co/t/unable-to-access-path-data-data-db-elasticsearch/352302)

<div class="topic-metadata">

**Author:** [@daniela09](https://discuss.elastic.co/u/daniela09)\
**Replies:** 4\
**Last updated:** [February 5, 2024, 1:36pm UTC](https://discuss.elastic.co/t/unable-to-access-path-data-data-db-elasticsearch/352302 "2024-02-05T13:36:32Z")

</div>

This is my Statefulset for Elasticsearch spec: podManagementPolicy: OrderedReady replicas: 3 revisionHistoryLimit: 10 selector: matchLabels: app: elasticsearch serviceName: elasticsearch-data templ…

---

## [Monitor database metrics using elastic](https://discuss.elastic.co/t/monitor-database-metrics-using-elastic/352530)

<div class="topic-metadata">

**Author:** [@searchwithme](https://discuss.elastic.co/u/searchwithme)\
**Replies:** 1\
**Last updated:** [February 5, 2024, 1:19pm UTC](https://discuss.elastic.co/t/monitor-database-metrics-using-elastic/352530 "2024-02-05T13:19:06Z")

</div>

Is it possible to monitor database metrics like connection time, page reads, open connections, uptime, long running queries, etc using elastic?

---

## [Registering S3 repository from private subnet fails with "Unauthorized"](https://discuss.elastic.co/t/registering-s3-repository-from-private-subnet-fails-with-unauthorized/352527)

<div class="topic-metadata">

**Author:** [@strophy](https://discuss.elastic.co/u/strophy)\
**Replies:** 4\
**Last updated:** [February 5, 2024, 12:56pm UTC](https://discuss.elastic.co/t/registering-s3-repository-from-private-subnet-fails-with-unauthorized/352527 "2024-02-05T12:56:05Z")

</div>

I'm trying to register an S3 repository for a test cluster of two instances running Elasticsearch 8.12.0 in a private AWS subnet using IAM instance profiles instead of access keys. The subnet security group has outgoing …

---

## [What is the risk of running Rally on production?](https://discuss.elastic.co/t/what-is-the-risk-of-running-rally-on-production/352433)

<div class="topic-metadata">

**Author:** [@userR](https://discuss.elastic.co/u/userR)\
**Replies:** 1\
**Last updated:** [February 5, 2024, 11:48am UTC](https://discuss.elastic.co/t/what-is-the-risk-of-running-rally-on-production/352433 "2024-02-05T11:48:20Z")

</div>

I have ran Rally on a staging instance and wanted to compare the performance to our existing production cluster. From the documentation: First of all: Please (please, please) do NOT run Rally against your production clu…

---

## [Java api client 7.x with Elasticsearch server 8.x](https://discuss.elastic.co/t/java-api-client-7-x-with-elasticsearch-server-8-x/352369)

<div class="topic-metadata">

**Author:** [@SElasticsearch](https://discuss.elastic.co/u/SElasticsearch)\
**Replies:** 3\
**Last updated:** [February 5, 2024, 11:35am UTC](https://discuss.elastic.co/t/java-api-client-7-x-with-elasticsearch-server-8-x/352369 "2024-02-05T11:35:37Z")

</div>

We have a scenario where our application needs to connect with both 7.x and 8.x Elasticsearch server. Using Java API client 7.17.16 and it works with Elasticsearch server 7.x. Used (HttpHeaders.CONTENT\_TYPE, "applicatio…

---

## [Are Conditional Aggregations Possible?](https://discuss.elastic.co/t/are-conditional-aggregations-possible/352518)

<div class="topic-metadata">

**Author:** [@ndtreviv](https://discuss.elastic.co/u/ndtreviv)\
**Replies:** 0\
**Last updated:** [February 5, 2024, 10:21am UTC](https://discuss.elastic.co/t/are-conditional-aggregations-possible/352518 "2024-02-05T10:21:06Z")

</div>

I want to run a count query with an associated aggregation, but only run the aggregation if the count for the query is below a certain number. Is this possible?

---

## [How can I generate root-ca.pem file for Elasticsearch](https://discuss.elastic.co/t/how-can-i-generate-root-ca-pem-file-for-elasticsearch/352511)

<div class="topic-metadata">

**Author:** [@fahim2024](https://discuss.elastic.co/u/fahim2024)\
**Replies:** 2\
**Last updated:** [February 5, 2024, 9:16am UTC](https://discuss.elastic.co/t/how-can-i-generate-root-ca-pem-file-for-elasticsearch/352511 "2024-02-05T09:16:19Z")

</div>

How can I generate root-ca.pem file for Elasticsearch ,Would be great if some help me

[Previous page](https://discuss.elastic.co/c/elastic-stack/elasticsearch/6.md?page=148)

[Next page](https://discuss.elastic.co/c/elastic-stack/elasticsearch/6.md?page=150)
