# Elasticsearch

**URL:** https://discuss.elastic.co/c/elastic-stack/elasticsearch/6.md?page=166

[Latest](https://discuss.elastic.co/latest.md) · [Categories](https://discuss.elastic.co/categories.md) · [Tags](https://discuss.elastic.co/tags.md)

**Page:** 167

---

## [Fatal exception while booting Elasticsearchorg.elasticsearch.ElasticsearchSecurityException: failed to load SSL configuration \[xpack.security.transport.ssl\] - cannot read configured \[PKCS12\] keystore](https://discuss.elastic.co/t/fatal-exception-while-booting-elasticsearchorg-elasticsearch-elasticsearchsecurityexception-failed-to-load-ssl-configuration-xpack-security-transport-ssl-cannot-read-configured-pkcs12-keystore/349427)

<div class="topic-metadata">

**Author:** [@9631](https://discuss.elastic.co/u/9631)\
**Replies:** 7\
**Last updated:** [December 15, 2023, 10:58am UTC](https://discuss.elastic.co/t/fatal-exception-while-booting-elasticsearchorg-elasticsearch-elasticsearchsecurityexception-failed-to-load-ssl-configuration-xpack-security-transport-ssl-cannot-read-configured-pkcs12-keystore/349427 "2023-12-15T10:58:50Z")

</div>

\[2023-12-15T12:36:37,084\]\[ERROR\]\[o.e.b.Elasticsearch \] \[LAPTOP-ECGDD83N\] fatal exception while booting Elasticsearchorg.elasticsearch.ElasticsearchSecurityException: failed to load SSL configuration \[xpack.security.…

---

## [Searchable Snapshot - S3 - Object Lock](https://discuss.elastic.co/t/searchable-snapshot-s3-object-lock/349418)

<div class="topic-metadata">

**Author:** [@digital-thought](https://discuss.elastic.co/u/digital-thought)\
**Replies:** 3\
**Last updated:** [December 15, 2023, 10:45am UTC](https://discuss.elastic.co/t/searchable-snapshot-s3-object-lock/349418 "2023-12-15T10:45:22Z")

</div>

I have implemented a Frozen Tier with Searchable Snapshots within AWS S3. To further protect the data and prevent deletion, I am looking to setup "Object Lock". Will the use of "Object Lock" interfere in anyway with El…

---

## [How bad is it for Elasticsearch peformance to use external disk storage?](https://discuss.elastic.co/t/how-bad-is-it-for-elasticsearch-peformance-to-use-external-disk-storage/349442)

<div class="topic-metadata">

**Author:** [@mtovmassian](https://discuss.elastic.co/u/mtovmassian)\
**Replies:** 0\
**Last updated:** [December 15, 2023, 9:36am UTC](https://discuss.elastic.co/t/how-bad-is-it-for-elasticsearch-peformance-to-use-external-disk-storage/349442 "2023-12-15T09:36:45Z")

</div>

I am currently running a small cluster of 3 nodes with a size (shards considered) of =~ 200GB. But disk usage keeps increasing and hard drives are about to reach saturation. I know that Elasticsearch need to be as clo…

---

## [Problems with simple python Elastic connection. Documentation Wrong?](https://discuss.elastic.co/t/problems-with-simple-python-elastic-connection-documentation-wrong/349400)

<div class="topic-metadata">

**Author:** [@allan.silverstein](https://discuss.elastic.co/u/allan.silverstein)\
**Replies:** 2\
**Last updated:** [December 15, 2023, 6:49am UTC](https://discuss.elastic.co/t/problems-with-simple-python-elastic-connection-documentation-wrong/349400 "2023-12-15T06:49:00Z")

</div>

I spent about an hour on what seems like a simple getting started exercise. Just connecting to the elastic stack with the python client. Leaving out all of the trial and error detail. The documentation shows that the …

---

## [How to specify a default value for my field in grok pattern match](https://discuss.elastic.co/t/how-to-specify-a-default-value-for-my-field-in-grok-pattern-match/349310)

<div class="topic-metadata">

**Author:** [@ameeto17](https://discuss.elastic.co/u/ameeto17)\
**Replies:** 9\
**Last updated:** [December 15, 2023, 5:53am UTC](https://discuss.elastic.co/t/how-to-specify-a-default-value-for-my-field-in-grok-pattern-match/349310 "2023-12-15T05:53:26Z")

</div>

I have a pattern to match using GROK Dec 14 03:13:01 ppddc1kfep302 my-checker: Context SHA of VSP Logger Software da39a3ee5e6b4b0d3255bfef95601890afd80709 I have the format below for the match %{SYSLOGTIMESTAMP}%{SPAC…

---

## [Behaviour of match\_phrase\_prefix in ES ES 8.9.0 is different from that in 7.17.7](https://discuss.elastic.co/t/behaviour-of-match-phrase-prefix-in-es-es-8-9-0-is-different-from-that-in-7-17-7/348283)

<div class="topic-metadata">

**Author:** [@elastic-a](https://discuss.elastic.co/u/elastic-a)\
**Replies:** 1\
**Last updated:** [December 14, 2023, 10:06pm UTC](https://discuss.elastic.co/t/behaviour-of-match-phrase-prefix-in-es-es-8-9-0-is-different-from-that-in-7-17-7/348283 "2023-12-14T22:06:45Z")

</div>

ES 8.9.0 With a query having match\_phrase\_prefix of just one term, the search returns expected match; with the same query, percolate by id does not return expected match. The same (both search and percolate) work as ex…

---

## [Please point me to a good article on how to "Optimally size Elasticsearch Thread Pools"](https://discuss.elastic.co/t/please-point-me-to-a-good-article-on-how-to-optimally-size-elasticsearch-thread-pools/349397)

<div class="topic-metadata">

**Author:** [@andrew3](https://discuss.elastic.co/u/andrew3)\
**Replies:** 2\
**Last updated:** [December 14, 2023, 9:38pm UTC](https://discuss.elastic.co/t/please-point-me-to-a-good-article-on-how-to-optimally-size-elasticsearch-thread-pools/349397 "2023-12-14T21:38:33Z")

</div>

We're pushing a lot of data in the form of bulk indexing requests and saturating the available thread pools. Can you point me to a good article on optimally sizing ES thread pools? Thanks.

---

## [Running ANN with num\_candidates \> 10000](https://discuss.elastic.co/t/running-ann-with-num-candidates-10000/349387)

<div class="topic-metadata">

**Author:** [@rajivhs](https://discuss.elastic.co/u/rajivhs)\
**Replies:** 1\
**Last updated:** [December 14, 2023, 5:02pm UTC](https://discuss.elastic.co/t/running-ann-with-num-candidates-10000/349387 "2023-12-14T17:02:36Z")

</div>

Hi. Given millions of documents in our index, we would like to run ANN in order to get the top-X documents, where X is greater than 10,000. However, we're running into the num\_candidates cannot exceed 10000 error. We do…

---

## [Help for configuring index and query for autocomplete full\_text\_search on addresses](https://discuss.elastic.co/t/help-for-configuring-index-and-query-for-autocomplete-full-text-search-on-addresses/349386)

<div class="topic-metadata">

**Author:** [@Queepyl](https://discuss.elastic.co/u/Queepyl)\
**Replies:** 1\
**Last updated:** [December 14, 2023, 4:30pm UTC](https://discuss.elastic.co/t/help-for-configuring-index-and-query-for-autocomplete-full-text-search-on-addresses/349386 "2023-12-14T16:30:15Z")

</div>

Hello, I am creating an index to search existing addresses. Unfortunately I don't have some good results at all and I would like to ask for advices on how to improove these results. So the aim is to let a user enter i…

---

## [How to story a JSON Array in an index via the Java client?](https://discuss.elastic.co/t/how-to-story-a-json-array-in-an-index-via-the-java-client/349390)

<div class="topic-metadata">

**Author:** [@Itsman-AT](https://discuss.elastic.co/u/Itsman-AT)\
**Replies:** 0\
**Last updated:** [December 14, 2023, 4:25pm UTC](https://discuss.elastic.co/t/how-to-story-a-json-array-in-an-index-via-the-java-client/349390 "2023-12-14T16:25:45Z")

</div>

I am trying to store a JSON array (coming from an SQL Table field) within an Elasticsearch index. The JSON Array coming from the DB looks like this: \["Texas", "Texas", "Sidebet City"\] I get this array as a String from …

---

## [ElasticSearch in WordPress headless setup](https://discuss.elastic.co/t/elasticsearch-in-wordpress-headless-setup/349237)

<div class="topic-metadata">

**Author:** [@andreasdiehl](https://discuss.elastic.co/u/andreasdiehl)\
**Replies:** 2\
**Last updated:** [December 14, 2023, 3:34pm UTC](https://discuss.elastic.co/t/elasticsearch-in-wordpress-headless-setup/349237 "2023-12-14T15:34:24Z")

</div>

We are setting up a headless frontend (Nuxt, Vue) for our WordPress site. We pull data via GraphQL. Now we explore if / hot to make use of Elasticsearch. Any experiences / recommendations how to do the setup? So far we…

---

## [Correct way of mapping some structure to Elasticsearch document](https://discuss.elastic.co/t/correct-way-of-mapping-some-structure-to-elasticsearch-document/349379)

<div class="topic-metadata">

**Author:** [@Vadym\_Romanenko](https://discuss.elastic.co/u/Vadym_Romanenko)\
**Replies:** 0\
**Last updated:** [December 14, 2023, 2:54pm UTC](https://discuss.elastic.co/t/correct-way-of-mapping-some-structure-to-elasticsearch-document/349379 "2023-12-14T14:54:18Z")

</div>

Good day, community! At this moment we're posting some items from our solution to the ES index. Everything works fine. But we want to enlarge our decision. Our project gives ability to categorize items. We want to have …

---

## ["Multiple mapping types and custom mapping types in index templates" issue when upgrading to v8](https://discuss.elastic.co/t/multiple-mapping-types-and-custom-mapping-types-in-index-templates-issue-when-upgrading-to-v8/349185)

<div class="topic-metadata">

**Author:** [@preetish\_P](https://discuss.elastic.co/u/preetish_P)\
**Replies:** 1\
**Last updated:** [December 14, 2023, 2:46pm UTC](https://discuss.elastic.co/t/multiple-mapping-types-and-custom-mapping-types-in-index-templates-issue-when-upgrading-to-v8/349185 "2023-12-14T14:46:36Z")

</div>

Hi folks, We are in the process of upgrading ELK stack from version 7.17.2 to 8.9.2. When going through the list of Elasticsearch deprecation issues I spotted the below in Prod: (not seen in non-prod) Multiple mapping …

---

## [njava.lang.NoClassDefFoundError: Could not initialize class org.elasticsearch.xcontent.json.JsonXContent](https://discuss.elastic.co/t/njava-lang-noclassdeffounderror-could-not-initialize-class-org-elasticsearch-xcontent-json-jsonxcontent/349373)

<div class="topic-metadata">

**Author:** [@Jhalak43](https://discuss.elastic.co/u/Jhalak43)\
**Replies:** 0\
**Last updated:** [December 14, 2023, 2:08pm UTC](https://discuss.elastic.co/t/njava-lang-noclassdeffounderror-could-not-initialize-class-org-elasticsearch-xcontent-json-jsonxcontent/349373 "2023-12-14T14:08:18Z")

</div>

Previously we were using 7.17.12 version of below dependency org.elasticsearch elasticsearch But now when i update version from 7.17.12 to 8.6.1 or 8.8.2 i get below exception Could not initialize class org.elast…

---

## [Access Elasticsearch Data as a Remote Oracle Database](https://discuss.elastic.co/t/access-elasticsearch-data-as-a-remote-oracle-database/349350)

<div class="topic-metadata">

**Author:** [@onr1onr1](https://discuss.elastic.co/u/onr1onr1)\
**Replies:** 11\
**Last updated:** [December 14, 2023, 2:38pm UTC](https://discuss.elastic.co/t/access-elasticsearch-data-as-a-remote-oracle-database/349350 "2023-12-14T14:38:03Z")

</div>

We want to set up a dblink from the Oracle database to eleastic search and pull information, but we get the following error in the dblink. We could not find a source on this site, so we did it by following the steps in …

---

## [Is there any recommended ratio between the number of master, data, coordinator and ingestion nodes?](https://discuss.elastic.co/t/is-there-any-recommended-ratio-between-the-number-of-master-data-coordinator-and-ingestion-nodes/349270)

<div class="topic-metadata">

**Author:** [@calin](https://discuss.elastic.co/u/calin)\
**Replies:** 13\
**Last updated:** [December 14, 2023, 1:05pm UTC](https://discuss.elastic.co/t/is-there-any-recommended-ratio-between-the-number-of-master-data-coordinator-and-ingestion-nodes/349270 "2023-12-14T13:05:23Z")

</div>

Currently working with equal number of master, data and coordinator nodes (10). Need to add some ingestion nodes. They all have 2 CPU/node, master and coordinator have 4 GB each, data has 16 GB. I haven't done the sizi…

---

## [How can we ingest fields dynamically in integation package](https://discuss.elastic.co/t/how-can-we-ingest-fields-dynamically-in-integation-package/349338)

<div class="topic-metadata">

**Author:** [@Niraj\_Rathod](https://discuss.elastic.co/u/Niraj_Rathod)\
**Replies:** 0\
**Last updated:** [December 14, 2023, 9:05am UTC](https://discuss.elastic.co/t/how-can-we-ingest-fields-dynamically-in-integation-package/349338 "2023-12-14T09:05:13Z")

</div>

We are trying to fetch MongoDB Atlas logs. In MongoDB Atlas Activity Logs there is an object named “attr” under which there are many dynamic fields that change depending on logs, these fields can't be mentioned in “field…

---

## [Elasticsearch Upgrade issue](https://discuss.elastic.co/t/elasticsearch-upgrade-issue/349159)

<div class="topic-metadata">

**Author:** [@Ifteakhar\_ali](https://discuss.elastic.co/u/Ifteakhar_ali)\
**Replies:** 1\
**Last updated:** [December 12, 2023, 2:23pm UTC](https://discuss.elastic.co/t/elasticsearch-upgrade-issue/349159 "2023-12-12T14:23:43Z")

</div>

Hello Team, I am facing issue while upgrading elasticsearch from elasticsearch-6.8.11-1.noarch to elasticsearch-7.10.2-aarch64.rpm. Kindly advise Current ES Version : elasticsearch-6.8.11-1.noarch Current OS Version :…

---

## [Ingest error with logstash](https://discuss.elastic.co/t/ingest-error-with-logstash/349195)

<div class="topic-metadata">

**Author:** [@hollo](https://discuss.elastic.co/u/hollo)\
**Replies:** 2\
**Last updated:** [December 14, 2023, 11:39am UTC](https://discuss.elastic.co/t/ingest-error-with-logstash/349195 "2023-12-14T11:39:19Z")

</div>

Hi. I've created a filebeat -\> logstash -\> elastic flow for iptables logs. Filebeat uses the default iptables module. Logstash has minimal config (beat input, elastic output, no filter). The Logstash pipeline comes f…

---

## [Unavailable\_shards\_exception](https://discuss.elastic.co/t/unavailable-shards-exception/349343)

<div class="topic-metadata">

**Author:** [@Vittorio\_Morellini](https://discuss.elastic.co/u/Vittorio_Morellini)\
**Replies:** 0\
**Last updated:** [December 14, 2023, 9:34am UTC](https://discuss.elastic.co/t/unavailable-shards-exception/349343 "2023-12-14T09:34:06Z")

</div>

I have a problem since 2 days on my production inde4x on Elasticsearch. Every night I re-create the index by deleteing it and re-creating with a reindex command from a source index. Now it is happening this error and t…

---

## [Create custom plugin to route](https://discuss.elastic.co/t/create-custom-plugin-to-route/349342)

<div class="topic-metadata">

**Author:** [@tung\_duong](https://discuss.elastic.co/u/tung_duong)\
**Replies:** 0\
**Last updated:** [December 14, 2023, 9:33am UTC](https://discuss.elastic.co/t/create-custom-plugin-to-route/349342 "2023-12-14T09:33:14Z")

</div>

\-1 I am new to Elasticsearch. I currently need to design a plugin with the task of navigating my use of Elasticsearch. Specifically: I already have semantic search models, which can be used as an API, with output be…

---

## [Composite aggregation pagination](https://discuss.elastic.co/t/composite-aggregation-pagination/349340)

<div class="topic-metadata">

**Author:** [@Thishon](https://discuss.elastic.co/u/Thishon)\
**Replies:** 0\
**Last updated:** [December 14, 2023, 9:28am UTC](https://discuss.elastic.co/t/composite-aggregation-pagination/349340 "2023-12-14T09:28:36Z")

</div>

I am using Elasticsearch and i want to show results by pagination so i choosed composite method. but i couldnt sort the result by outer source buckets.

---

## [When 2 of 3 masters die, how to restore the cluster?](https://discuss.elastic.co/t/when-2-of-3-masters-die-how-to-restore-the-cluster/349324)

<div class="topic-metadata">

**Author:** [@ycice](https://discuss.elastic.co/u/ycice)\
**Replies:** 1\
**Last updated:** [December 14, 2023, 8:58am UTC](https://discuss.elastic.co/t/when-2-of-3-masters-die-how-to-restore-the-cluster/349324 "2023-12-14T08:58:24Z")

</div>

Hi, i am using ES version 7.17.0 My cluster consists of 3 master-eligible 2 data + ingest 2 Coordinating 1 kibana and they are running on AWS EC2 as docker container. 1 EC2 has 1 container And i am testing availab…

---

## [Continuous transformation is not update](https://discuss.elastic.co/t/continuous-transformation-is-not-update/349212)

<div class="topic-metadata">

**Author:** [@Zosmex](https://discuss.elastic.co/u/Zosmex)\
**Replies:** 3\
**Last updated:** [December 14, 2023, 8:34am UTC](https://discuss.elastic.co/t/continuous-transformation-is-not-update/349212 "2023-12-14T08:34:29Z")

</div>

I created a pivot continuous transformation to automatically count the data in each location. Each document has an 'updated\_at' field which is a timestamp in epoch second format when each document was last modified. Aft…

---

## [Tenable Vulnerability Integration not producing Data Stream](https://discuss.elastic.co/t/tenable-vulnerability-integration-not-producing-data-stream/349332)

<div class="topic-metadata">

**Author:** [@longansoju](https://discuss.elastic.co/u/longansoju)\
**Replies:** 1\
**Last updated:** [December 14, 2023, 7:54am UTC](https://discuss.elastic.co/t/tenable-vulnerability-integration-not-producing-data-stream/349332 "2023-12-14T07:54:38Z")

</div>

I have a elastic fleet cluster set up and I've configured one of my agents to use the Tenable Vulnerability Management Integration. However, under Fleet \> Data Streams, there is no Tenable Data Stream being generated. M…

---

## [Unable to login using elastic](https://discuss.elastic.co/t/unable-to-login-using-elastic/349304)

<div class="topic-metadata">

**Author:** [@Harper\_S1](https://discuss.elastic.co/u/Harper_S1)\
**Replies:** 3\
**Last updated:** [December 14, 2023, 5:17am UTC](https://discuss.elastic.co/t/unable-to-login-using-elastic/349304 "2023-12-14T05:17:40Z")

</div>

Hi, I have upgraded elastic 6.8 to 7.17. and i have taken the .security-6 file backup as .security-6-reindexed. but. while performing upgrade to 8.x.x version. nodes are showing the following error java.lang.IllegalS…

---

## [There is a way to set the time of the day when the index rollover will happen?](https://discuss.elastic.co/t/there-is-a-way-to-set-the-time-of-the-day-when-the-index-rollover-will-happen/348915)

<div class="topic-metadata">

**Author:** [@abiliocastro](https://discuss.elastic.co/u/abiliocastro)\
**Replies:** 8\
**Last updated:** [December 13, 2023, 9:50pm UTC](https://discuss.elastic.co/t/there-is-a-way-to-set-the-time-of-the-day-when-the-index-rollover-will-happen/348915 "2023-12-13T21:50:32Z")

</div>

I have an index template like the following: { "index": { "lifecycle": { "name": "indexname\_ilm\_policy", "rollover\_alias": "indexname" }, "number\_of\_replicas": "2", "refresh\_interval": "60s…

---

## [Elasticsearch server crashing with new version release](https://discuss.elastic.co/t/elasticsearch-server-crashing-with-new-version-release/349274)

<div class="topic-metadata">

**Author:** [@R7ST](https://discuss.elastic.co/u/R7ST)\
**Replies:** 1\
**Last updated:** [December 13, 2023, 6:22pm UTC](https://discuss.elastic.co/t/elasticsearch-server-crashing-with-new-version-release/349274 "2023-12-13T18:22:49Z")

</div>

I have two ubuntu 22.04 servers with elasticsearch (two separate installations) and this is the second time both servers goes down at the same time. The same error message appears in both logs (below) The error occurs …

---

## [Unspecific Machine Learning Job Validation Errors - can't troubleshoot](https://discuss.elastic.co/t/unspecific-machine-learning-job-validation-errors-cant-troubleshoot/349286)

<div class="topic-metadata">

**Author:** [@LogsandParsers](https://discuss.elastic.co/u/LogsandParsers)\
**Replies:** 1\
**Last updated:** [December 13, 2023, 5:43pm UTC](https://discuss.elastic.co/t/unspecific-machine-learning-job-validation-errors-cant-troubleshoot/349286 "2023-12-13T17:43:10Z")

</div>

Hi all, I'm trying to create Machine Learning jobs on Kibana, but in the vast majority of time, they fail with the following error at the 'Validation' stage on Kibana, before the job is run: So, is this a capacity p…

---

## [Would dividing the same resources over more nodes improve performance?](https://discuss.elastic.co/t/would-dividing-the-same-resources-over-more-nodes-improve-performance/349264)

<div class="topic-metadata">

**Author:** [@calin](https://discuss.elastic.co/u/calin)\
**Replies:** 5\
**Last updated:** [December 13, 2023, 4:40pm UTC](https://discuss.elastic.co/t/would-dividing-the-same-resources-over-more-nodes-improve-performance/349264 "2023-12-13T16:40:46Z")

</div>

A load test seems to show that resources (CPU, RAM) on the data nodes aren't fully used. Would spreading the same resources over more data nodes help performance ?

[Previous page](https://discuss.elastic.co/c/elastic-stack/elasticsearch/6.md?page=165)

[Next page](https://discuss.elastic.co/c/elastic-stack/elasticsearch/6.md?page=167)
