# Elasticsearch

**URL:** https://discuss.elastic.co/c/elastic-stack/elasticsearch/6.md?page=185

[Latest](https://discuss.elastic.co/latest.md) · [Categories](https://discuss.elastic.co/categories.md) · [Tags](https://discuss.elastic.co/tags.md)

**Page:** 186

---

## [Runtime field component mapping with IF in script fails to parse due to compile error](https://discuss.elastic.co/t/runtime-field-component-mapping-with-if-in-script-fails-to-parse-due-to-compile-error/345816)

<div class="topic-metadata">

**Author:** [@dmgeurts](https://discuss.elastic.co/u/dmgeurts)\
**Replies:** 1\
**Last updated:** [October 26, 2023, 12:51pm UTC](https://discuss.elastic.co/t/runtime-field-component-mapping-with-if-in-script-fails-to-parse-due-to-compile-error/345816 "2023-10-26T12:51:54Z")

</div>

I'm trying to create a mapping based on a value. However, whatever I try to save the component template, I'm shown the following error: :warning: Unable to create component template Failed to parse mapping: compile er…

---

## [Securityadmin.sh unable to find valid certification path to requested target error](https://discuss.elastic.co/t/securityadmin-sh-unable-to-find-valid-certification-path-to-requested-target-error/345809)

<div class="topic-metadata">

**Author:** [@Xhar](https://discuss.elastic.co/u/Xhar)\
**Replies:** 2\
**Last updated:** [October 26, 2023, 12:49pm UTC](https://discuss.elastic.co/t/securityadmin-sh-unable-to-find-valid-certification-path-to-requested-target-error/345809 "2023-10-26T12:49:58Z")

</div>

Hello,when i'm trying to execute securityadmin.sh with command ./securityadmin.sh -f /home/user/Documents/opensearch-2.8.0/config/opensearch-security/config.yml -icl -nhnv -cert /home/user/Documents/opensearch-2.8.0/con…

---

## [\[Kibana\] Visualize number of documents having a field inferior to the 99th percentile of this field](https://discuss.elastic.co/t/kibana-visualize-number-of-documents-having-a-field-inferior-to-the-99th-percentile-of-this-field/344485)

<div class="topic-metadata">

**Author:** [@JeromeLavadou](https://discuss.elastic.co/u/JeromeLavadou)\
**Replies:** 4\
**Last updated:** [October 26, 2023, 12:40pm UTC](https://discuss.elastic.co/t/kibana-visualize-number-of-documents-having-a-field-inferior-to-the-99th-percentile-of-this-field/344485 "2023-10-26T12:40:17Z")

</div>

Hello, Is there a way, in a Kibana visualization (Lens, TSVB...), to display on a chart (line, bar, etc.), for each time bucket, the number of documents having a field, let's says "response\_time", inferior to the 99th p…

---

## [Map azureAD roles or groups with elasticsearch roles](https://discuss.elastic.co/t/map-azuread-roles-or-groups-with-elasticsearch-roles/345763)

<div class="topic-metadata">

**Author:** [@ebuildy](https://discuss.elastic.co/u/ebuildy)\
**Replies:** 2\
**Last updated:** [October 26, 2023, 12:30pm UTC](https://discuss.elastic.co/t/map-azuread-roles-or-groups-with-elasticsearch-roles/345763 "2023-10-26T12:30:14Z")

</div>

We deploy ES 8.8.1 with ECK on kubernetes. We connect it to azureAD, login works fine. I would like to map azureAD roles or groups with elasticsearch roles, I have no idea how to start. Our config is: xpack.security.…

---

## [Total number of shards](https://discuss.elastic.co/t/total-number-of-shards/345749)

<div class="topic-metadata">

**Author:** [@lemospt](https://discuss.elastic.co/u/lemospt)\
**Replies:** 2\
**Last updated:** [October 26, 2023, 9:25am UTC](https://discuss.elastic.co/t/total-number-of-shards/345749 "2023-10-26T09:25:27Z")

</div>

Hi Guys, i have an elastic cluster with 5 nodes. This cluster is configured 1290 indices, all indices is configured to have 2 primary shards and 1 replica shard. For me the cluster should have 3\*1290=3870 shards but ac…

---

## [I need to use the Suggester when I enable the DLS](https://discuss.elastic.co/t/i-need-to-use-the-suggester-when-i-enable-the-dls/345263)

<div class="topic-metadata">

**Author:** [@sjp.jamalian](https://discuss.elastic.co/u/sjp.jamalian)\
**Replies:** 4\
**Last updated:** [October 26, 2023, 6:34am UTC](https://discuss.elastic.co/t/i-need-to-use-the-suggester-when-i-enable-the-dls/345263 "2023-10-26T06:34:42Z")

</div>

Hello, When I enable the security and want to use the Suggester, I get this error: org.elasticsearch.ElasticsearchException: Elasticsearch exception \[type=security\_exception, reason=Suggest isn't supported if document …

---

## [How to compare value exactly from array of document with params in script plainess?](https://discuss.elastic.co/t/how-to-compare-value-exactly-from-array-of-document-with-params-in-script-plainess/345691)

<div class="topic-metadata">

**Author:** [@duyhunter1001](https://discuss.elastic.co/u/duyhunter1001)\
**Replies:** 2\
**Last updated:** [October 26, 2023, 6:19am UTC](https://discuss.elastic.co/t/how-to-compare-value-exactly-from-array-of-document-with-params-in-script-plainess/345691 "2023-10-26T06:19:16Z")

</div>

Hi everyone, I have a index example above: PUT target\_index { "mappings": { "properties": { "targetoperator": { "type": "keyword" }, "targetvalue": { "type": "float" } } } } PUT t…

---

## [Get repository folder name for an index](https://discuss.elastic.co/t/get-repository-folder-name-for-an-index/345737)

<div class="topic-metadata">

**Author:** [@karan\_c](https://discuss.elastic.co/u/karan_c)\
**Replies:** 2\
**Last updated:** [October 26, 2023, 6:15am UTC](https://discuss.elastic.co/t/get-repository-folder-name-for-an-index/345737 "2023-10-26T06:15:18Z")

</div>

Hi All, I'm creating day wise snapshots which contains multiple indices for different services (also day wise). I'm planning to move older snapshots from S3 Intelligent-Tiering to S3 Glacier Deep Archive storage class. …

---

## [Configuration Elastic Cluster 8.10.3 Certificates in roles master, coordinator anda data](https://discuss.elastic.co/t/configuration-elastic-cluster-8-10-3-certificates-in-roles-master-coordinator-anda-data/345750)

<div class="topic-metadata">

**Author:** [@efrainMZ](https://discuss.elastic.co/u/efrainMZ)\
**Replies:** 1\
**Last updated:** [October 26, 2023, 4:05am UTC](https://discuss.elastic.co/t/configuration-elastic-cluster-8-10-3-certificates-in-roles-master-coordinator-anda-data/345750 "2023-10-26T04:05:04Z")

</div>

I have a question, how can I configure the certificates for an elastic cluster in version 8.10.3, it will contain master roles, coordinators, data and machine learning. Is it intended to have several roles on the nodes,…

---

## ["could not read the current timestamp"](https://discuss.elastic.co/t/could-not-read-the-current-timestamp/344608)

<div class="topic-metadata">

**Author:** [@arunv707](https://discuss.elastic.co/u/arunv707)\
**Replies:** 1\
**Last updated:** [October 26, 2023, 3:59am UTC](https://discuss.elastic.co/t/could-not-read-the-current-timestamp/344608 "2023-10-26T03:59:25Z")

</div>

I get the following in application logs. Could someone please help? \[2023-09-19T17:07:52,876\]\[DEBUG\]\[o.e.a.s.TransportSearchAction\] \[O1onMaP\] \[xxxxxx\]\[0\], node\[a24qYwKTTUO6yFcWf8QRKg\], \[P\], s\[STARTED\], a\[id=50vjfxaPSuqA…

---

## [Fscrawler, error 415 when using REST API for upload PDF file](https://discuss.elastic.co/t/fscrawler-error-415-when-using-rest-api-for-upload-pdf-file/345760)

<div class="topic-metadata">

**Author:** [@Erik\_Bors](https://discuss.elastic.co/u/Erik_Bors)\
**Replies:** 4\
**Last updated:** [October 25, 2023, 9:25pm UTC](https://discuss.elastic.co/t/fscrawler-error-415-when-using-rest-api-for-upload-pdf-file/345760 "2023-10-25T21:25:59Z")

</div>

Trying to use the REST API service of the fscrawler. When using the POST MAN with PDF file, the app is answering with the 415 code - unsupported media type Content-Type header is correct with application/pdf. Using POS…

---

## [Deprecation info missing in the docs?](https://discuss.elastic.co/t/deprecation-info-missing-in-the-docs/345744)

<div class="topic-metadata">

**Author:** [@bunste](https://discuss.elastic.co/u/bunste)\
**Replies:** 2\
**Last updated:** [October 25, 2023, 8:59pm UTC](https://discuss.elastic.co/t/deprecation-info-missing-in-the-docs/345744 "2023-10-25T20:59:16Z")

</div>

I saw the following deprecation warning today: \[ignore\_throttled\] parameter is deprecated because frozen indices have been deprecated. Consider cold or frozen tiers in place of frozen indices. So far so good, finding a…

---

## [Fleet integrations page failing to load](https://discuss.elastic.co/t/fleet-integrations-page-failing-to-load/345473)

<div class="topic-metadata">

**Author:** [@tdanno](https://discuss.elastic.co/u/tdanno)\
**Replies:** 4\
**Last updated:** [October 25, 2023, 7:19pm UTC](https://discuss.elastic.co/t/fleet-integrations-page-failing-to-load/345473 "2023-10-25T19:19:32Z")

</div>

On three separate clusters in three different parts of the world everything is functioning fine except the ability to fully load the integrations page- it seems like whatever it needs to do to reach out to the central re…

---

## [Certificate configuration for an Elastic 8.10.3 cluster](https://discuss.elastic.co/t/certificate-configuration-for-an-elastic-8-10-3-cluster/345745)

<div class="topic-metadata">

**Author:** [@efrainMZ](https://discuss.elastic.co/u/efrainMZ)\
**Replies:** 2\
**Last updated:** [October 25, 2023, 4:40pm UTC](https://discuss.elastic.co/t/certificate-configuration-for-an-elastic-8-10-3-cluster/345745 "2023-10-25T16:40:23Z")

</div>

I have a question, how can I configure the certificates for an elastic cluster in version 8.10.3, it will contain master roles, coordinators, data and machine learning. Is it intended to have several roles on the nodes,…

---

## [Wtacher or Ingest pipeline avoiding duplicates](https://discuss.elastic.co/t/wtacher-or-ingest-pipeline-avoiding-duplicates/345747)

<div class="topic-metadata">

**Author:** [@elk-user-0001](https://discuss.elastic.co/u/elk-user-0001)\
**Replies:** 0\
**Last updated:** [October 25, 2023, 3:36pm UTC](https://discuss.elastic.co/t/wtacher-or-ingest-pipeline-avoiding-duplicates/345747 "2023-10-25T15:36:35Z")

</div>

Hello colleagues! I have a question. Is there a way to put in watcher or ingest pipelines an update based on a document\_id ( field, fields, fingerprint... ) to avoid duplicates as in the logstash output ? I have a wat…

---

## [Unassigned shards](https://discuss.elastic.co/t/unassigned-shards/344125)

<div class="topic-metadata">

**Author:** [@abisinio](https://discuss.elastic.co/u/abisinio)\
**Replies:** 0\
**Last updated:** [September 29, 2023, 10:21am UTC](https://discuss.elastic.co/t/unassigned-shards/344125 "2023-09-29T10:21:41Z")

</div>

Hi mates, I've made a mistake in my ELK deployment. I was trying to install a new elastic agent and I put the wrong token and used the one used to configure a new server. Now I've got a lot of unassigned shards and I d…

---

## [Query retrieving documents when only one of two conditions are found under same aggregation](https://discuss.elastic.co/t/query-retrieving-documents-when-only-one-of-two-conditions-are-found-under-same-aggregation/345746)

<div class="topic-metadata">

**Author:** [@roblopes](https://discuss.elastic.co/u/roblopes)\
**Replies:** 0\
**Last updated:** [October 25, 2023, 2:52pm UTC](https://discuss.elastic.co/t/query-retrieving-documents-when-only-one-of-two-conditions-are-found-under-same-aggregation/345746 "2023-10-25T14:52:50Z")

</div>

There is a process that logs every step of the way. I am looking for processes that have the log informing the process start but don't have the end process log. Log example: { "app": "myapp", "content": "End Pro…

---

## [Invalid major version 2.5.0](https://discuss.elastic.co/t/invalid-major-version-2-5-0/345684)

<div class="topic-metadata">

**Author:** [@spearsear](https://discuss.elastic.co/u/spearsear)\
**Replies:** 4\
**Last updated:** [October 25, 2023, 2:25pm UTC](https://discuss.elastic.co/t/invalid-major-version-2-5-0/345684 "2023-10-25T14:25:10Z")

</div>

I have two OpenSearch 2.5 clusters running in 2 AWS accounts (environments), dev and stg. I use elasticsearch-spark-30\_2.12-7.15.2.jar to write data to an index in OpenSearch. dev works fine, but stg throws error below…

---

## [Dependant nodes in dockerized Elasticsearch 3-node cluster](https://discuss.elastic.co/t/dependant-nodes-in-dockerized-elasticsearch-3-node-cluster/345713)

<div class="topic-metadata">

**Author:** [@thibaut\_a](https://discuss.elastic.co/u/thibaut_a)\
**Replies:** 2\
**Last updated:** [October 25, 2023, 2:15pm UTC](https://discuss.elastic.co/t/dependant-nodes-in-dockerized-elasticsearch-3-node-cluster/345713 "2023-10-25T14:15:31Z")

</div>

Hi, I try to install an Elasticsearch (v8.10.2) cluster (with one Kibana and one Logstash container) on Docker for a production environment. My 3 nodes are running correctly on the same server (it will be different in pr…

---

## [Approximate KNN search with filtering vs. exact search after the filtering](https://discuss.elastic.co/t/approximate-knn-search-with-filtering-vs-exact-search-after-the-filtering/345736)

<div class="topic-metadata">

**Author:** [@AlwaysLearning](https://discuss.elastic.co/u/AlwaysLearning)\
**Replies:** 0\
**Last updated:** [October 25, 2023, 1:51pm UTC](https://discuss.elastic.co/t/approximate-knn-search-with-filtering-vs-exact-search-after-the-filtering/345736 "2023-10-25T13:51:55Z")

</div>

Suppose I want to use KNN search to search for best matching documents (represented by their high-dimensional vector embeddings) belonging to a particular user. As explained here, the approximate search (i.e. using HNSW…

---

## [ANN Search is super slow](https://discuss.elastic.co/t/ann-search-is-super-slow/344863)

<div class="topic-metadata">

**Author:** [@spliter2157](https://discuss.elastic.co/u/spliter2157)\
**Replies:** 14\
**Last updated:** [October 25, 2023, 1:38pm UTC](https://discuss.elastic.co/t/ann-search-is-super-slow/344863 "2023-10-25T13:38:02Z")

</div>

Hello There, Hello, I have a question regarding Elasticsearch vector search. Our vector index has 768 dimensions, and it contains 25,000,000 documents split into two indices. Here are the results from /\_cat/indices: he…

---

## [Adding support for multi-language partial matching querying](https://discuss.elastic.co/t/adding-support-for-multi-language-partial-matching-querying/344828)

<div class="topic-metadata">

**Author:** [@Shachar0n](https://discuss.elastic.co/u/Shachar0n)\
**Replies:** 1\
**Last updated:** [October 25, 2023, 1:21pm UTC](https://discuss.elastic.co/t/adding-support-for-multi-language-partial-matching-querying/344828 "2023-10-25T13:21:36Z")

</div>

Hi all, I'm trying to add support for partial-matching search on certain fields that may contain text in multiple languages. Specifically I currently lack support for Japanese, but IIUC - same applies for Cyrillic and C…

---

## [Unable to restore snapshot on elasticsearch 8.x](https://discuss.elastic.co/t/unable-to-restore-snapshot-on-elasticsearch-8-x/345731)

<div class="topic-metadata">

**Author:** [@Kiran\_K](https://discuss.elastic.co/u/Kiran_K)\
**Replies:** 0\
**Last updated:** [October 25, 2023, 12:58pm UTC](https://discuss.elastic.co/t/unable-to-restore-snapshot-on-elasticsearch-8-x/345731 "2023-10-25T12:58:53Z")

</div>

We have copy the snapshot backup over the restoration path but we unable to restore snapshot backup. As per attached snapshot please guide.

---

## [Not able to send logs to elastic search via Nlog.config](https://discuss.elastic.co/t/not-able-to-send-logs-to-elastic-search-via-nlog-config/345702)

<div class="topic-metadata">

**Author:** [@prakshi91](https://discuss.elastic.co/u/prakshi91)\
**Replies:** 1\
**Last updated:** [October 25, 2023, 12:11pm UTC](https://discuss.elastic.co/t/not-able-to-send-logs-to-elastic-search-via-nlog-config/345702 "2023-10-25T12:11:24Z")

</div>

Hi Everyone, Our aim is to send logs to Elasticsearch and we have made changes to the NLog.config file as per the documentation - Home · markmcdowell/NLog.Targets.ElasticSearch Wiki · GitHub NLog File However, we a…

---

## [Add a new Elasticsearch to TLS/SSL cluster](https://discuss.elastic.co/t/add-a-new-elasticsearch-to-tls-ssl-cluster/345500)

<div class="topic-metadata">

**Author:** [@Farid\_Niasti](https://discuss.elastic.co/u/Farid_Niasti)\
**Replies:** 3\
**Last updated:** [October 25, 2023, 5:56am UTC](https://discuss.elastic.co/t/add-a-new-elasticsearch-to-tls-ssl-cluster/345500 "2023-10-25T05:56:41Z")

</div>

Hi I have a cluster with 2 nodes of Elasticsearch. TLS/SSL is enables according to the bellow blog: Everything is OK and monitor-node-01 with IP 192.168.11.142 and monitor-node-02 with IP 192.168.11.143 works correct…

---

## [Is possible to create multiple Stored Scripts in 1 single operation using the API?](https://discuss.elastic.co/t/is-possible-to-create-multiple-stored-scripts-in-1-single-operation-using-the-api/345680)

<div class="topic-metadata">

**Author:** [@iTiago](https://discuss.elastic.co/u/iTiago)\
**Replies:** 1\
**Last updated:** [October 25, 2023, 5:31am UTC](https://discuss.elastic.co/t/is-possible-to-create-multiple-stored-scripts-in-1-single-operation-using-the-api/345680 "2023-10-25T05:31:16Z")

</div>

I have more than 2.5K lines in StoredScripts in my old Cloud 5.6 cluster. I want to transfer them to my new Cloud 8.10.4 Cluster. For this, is there a way to automate the creation of these a little using the API? I crea…

---

## [Deleting data while indexing](https://discuss.elastic.co/t/deleting-data-while-indexing/345565)

<div class="topic-metadata">

**Author:** [@Lilia](https://discuss.elastic.co/u/Lilia)\
**Replies:** 4\
**Last updated:** [October 25, 2023, 4:21am UTC](https://discuss.elastic.co/t/deleting-data-while-indexing/345565 "2023-10-25T04:21:16Z")

</div>

Hi all, I have a case where i need to delete data while it is indexing, to stop the process. Is this possible and if yes, can you explain me how to do it? The case is as follow i want to delete a report while it is uplo…

---

## [ES superuser cannot Create & Delete Kibana index patterns](https://discuss.elastic.co/t/es-superuser-cannot-create-delete-kibana-index-patterns/345665)

<div class="topic-metadata">

**Author:** [@fuwei1234](https://discuss.elastic.co/u/fuwei1234)\
**Replies:** 2\
**Last updated:** [October 24, 2023, 8:37pm UTC](https://discuss.elastic.co/t/es-superuser-cannot-create-delete-kibana-index-patterns/345665 "2023-10-24T20:37:34Z")

</div>

I have an ES770, I am superuser and just found that I cannot create Kibana index pattern. When I create an index pattern, the page shows that successfully find ES index, but Next button does not go to the next page, no r…

---

## [Elasticsearch using lots of CPU and disk, flipping to read-only during heavy use](https://discuss.elastic.co/t/elasticsearch-using-lots-of-cpu-and-disk-flipping-to-read-only-during-heavy-use/345660)

<div class="topic-metadata">

**Author:** [@dpitchford](https://discuss.elastic.co/u/dpitchford)\
**Replies:** 1\
**Last updated:** [October 24, 2023, 8:37pm UTC](https://discuss.elastic.co/t/elasticsearch-using-lots-of-cpu-and-disk-flipping-to-read-only-during-heavy-use/345660 "2023-10-24T20:37:28Z")

</div>

I am trying to understand behavior I am seeing from Elasticsearch 6.8 on a production site. During a period of heavy use (indexing large numbers of documents), Prometheus metrics are showing me that ES is using large amo…

---

## [Clean Install 8.10 Security Configuration](https://discuss.elastic.co/t/clean-install-8-10-security-configuration/345510)

<div class="topic-metadata">

**Author:** [@mgriffith](https://discuss.elastic.co/u/mgriffith)\
**Replies:** 16\
**Last updated:** [October 24, 2023, 6:29pm UTC](https://discuss.elastic.co/t/clean-install-8-10-security-configuration/345510 "2023-10-24T18:29:16Z")

</div>

I've been testing Elastic 7.17 in single-node configuration and have successfully configured minimal and basic security. Now I'd like to setup a new 3-node cluster on the latest version (8.10), but can't for the life of…

[Previous page](https://discuss.elastic.co/c/elastic-stack/elasticsearch/6.md?page=184)

[Next page](https://discuss.elastic.co/c/elastic-stack/elasticsearch/6.md?page=186)
