# Elasticsearch

**URL:** https://discuss.elastic.co/c/elastic-stack/elasticsearch/6.md?page=195

[Latest](https://discuss.elastic.co/latest.md) · [Categories](https://discuss.elastic.co/categories.md) · [Tags](https://discuss.elastic.co/tags.md)

**Page:** 196

---

## [How to get licence expiration date](https://discuss.elastic.co/t/how-to-get-licence-expiration-date/342565)

<div class="topic-metadata">

**Author:** [@pratik\_jain163](https://discuss.elastic.co/u/pratik_jain163)\
**Replies:** 10\
**Last updated:** [October 1, 2023, 4:52am UTC](https://discuss.elastic.co/t/how-to-get-licence-expiration-date/342565 "2023-10-01T04:52:26Z")

</div>

This category relates to the Enterprise Search set of products - App Search, Site Search and Workplace Search. If your question relates to core Elasticsearch functionality, please head over to the Elasticsearch category…

---

## [Any reason not to use ALL data nodes as coordinator nodes for queries/indexing?](https://discuss.elastic.co/t/any-reason-not-to-use-all-data-nodes-as-coordinator-nodes-for-queries-indexing/344077)

<div class="topic-metadata">

**Author:** [@Mike\_Snare](https://discuss.elastic.co/u/Mike_Snare)\
**Replies:** 6\
**Last updated:** [October 1, 2023, 12:35am UTC](https://discuss.elastic.co/t/any-reason-not-to-use-all-data-nodes-as-coordinator-nodes-for-queries-indexing/344077 "2023-10-01T00:35:40Z")

</div>

We have 37 data nodes but our clients only use 6 of them to send requests to. Is there any reason why the entire set of nodes couldn't be used by the clients? I know that some clusters use dedicated coordinator nodes, …

---

## [Python Authentication Problem](https://discuss.elastic.co/t/python-authentication-problem/343775)

<div class="topic-metadata">

**Author:** [@Somdev\_Das](https://discuss.elastic.co/u/Somdev_Das)\
**Replies:** 16\
**Last updated:** [September 30, 2023, 4:48pm UTC](https://discuss.elastic.co/t/python-authentication-problem/343775 "2023-09-30T16:48:02Z")

</div>

Facing this issue, all my path and passwords are ok but not able to authenticate. Please some one help me.

---

## [Elasticsearch and Kibana update from 6.8.18 to latest version](https://discuss.elastic.co/t/elasticsearch-and-kibana-update-from-6-8-18-to-latest-version/343248)

<div class="topic-metadata">

**Author:** [@francisco.palacios](https://discuss.elastic.co/u/francisco.palacios)\
**Replies:** 3\
**Last updated:** [September 30, 2023, 1:44pm UTC](https://discuss.elastic.co/t/elasticsearch-and-kibana-update-from-6-8-18-to-latest-version/343248 "2023-09-30T13:44:24Z")

</div>

We are considering the option of migrating our current Elasticsearch service from a local self-managed server to the Elastic Cloud. In the case of having an Elastic Cloud deployment, when an update is released, is Elasti…

---

## [In filebeat processing json log files that does not need processing](https://discuss.elastic.co/t/in-filebeat-processing-json-log-files-that-does-not-need-processing/344146)

<div class="topic-metadata">

**Author:** [@gred7](https://discuss.elastic.co/u/gred7)\
**Replies:** 10\
**Last updated:** [September 30, 2023, 1:28pm UTC](https://discuss.elastic.co/t/in-filebeat-processing-json-log-files-that-does-not-need-processing/344146 "2023-09-30T13:28:49Z")

</div>

Hello Everybody, Hope somebody could answer my question. I have an app, that writes logs in json format, that are ALREADY prepared as message for elastic. one example of what I have in logs: {"@timestamp":"2023-09-2…

---

## [I see this error in logstash-plain.log](https://discuss.elastic.co/t/i-see-this-error-in-logstash-plain-log/344082)

<div class="topic-metadata">

**Author:** [@Mostafa\_Faridi](https://discuss.elastic.co/u/Mostafa_Faridi)\
**Replies:** 23\
**Last updated:** [September 30, 2023, 10:35am UTC](https://discuss.elastic.co/t/i-see-this-error-in-logstash-plain-log/344082 "2023-09-30T10:35:33Z")

</div>

I installed elastcisearch 8.10.20 and kibana 810.2 and logstash 8.10.2 and filebeat 10.8.2 RPM on my oracle Linux, everything is running and I can login to kibana dashboard after adding token and username and password, b…

---

## [Remote Ubuntu installation: no automatic security configuration](https://discuss.elastic.co/t/remote-ubuntu-installation-no-automatic-security-configuration/344162)

<div class="topic-metadata">

**Author:** [@sandbender](https://discuss.elastic.co/u/sandbender)\
**Replies:** 0\
**Last updated:** [September 29, 2023, 10:28pm UTC](https://discuss.elastic.co/t/remote-ubuntu-installation-no-automatic-security-configuration/344162 "2023-09-29T22:28:17Z")

</div>

Hello, I'm trying to remotely install Elasticsearch and Kibana on an Ubuntu 22.04.3 LTS server as described in the Elasticsearch Guide. Unfortunately the automatic security configuration during install does simply not h…

---

## [Ingest pipeline not finding field](https://discuss.elastic.co/t/ingest-pipeline-not-finding-field/344144)

<div class="topic-metadata">

**Author:** [@emi\_rose](https://discuss.elastic.co/u/emi_rose)\
**Replies:** 7\
**Last updated:** [September 29, 2023, 10:08pm UTC](https://discuss.elastic.co/t/ingest-pipeline-not-finding-field/344144 "2023-09-29T22:08:26Z")

</div>

Hi there, When I test my ingest pipeline, which replaces a delimiter with a whitespace, with a document that has the exact field I'm trying to transform, I keep getting this error: \[Field \[field\] not present as part of …

---

## [Request/timeline for updating Iron Bank UBI Base Image from 8.6 to 8.8](https://discuss.elastic.co/t/request-timeline-for-updating-iron-bank-ubi-base-image-from-8-6-to-8-8/344150)

<div class="topic-metadata">

**Author:** [@Lemongarbage](https://discuss.elastic.co/u/Lemongarbage)\
**Replies:** 0\
**Last updated:** [September 29, 2023, 3:59pm UTC](https://discuss.elastic.co/t/request-timeline-for-updating-iron-bank-ubi-base-image-from-8-6-to-8-8/344150 "2023-09-29T15:59:58Z")

</div>

Hello, I am wondering if there is an effort to upgrade the base image used for the Iron Bank Elasticsearch image from UBI 8.6 to UBI 8.8. Thank you

---

## [Connector for Elastic Search 8.6.2 and databricks spark 3.4.0](https://discuss.elastic.co/t/connector-for-elastic-search-8-6-2-and-databricks-spark-3-4-0/342746)

<div class="topic-metadata">

**Author:** [@luckymishra](https://discuss.elastic.co/u/luckymishra)\
**Replies:** 8\
**Last updated:** [September 29, 2023, 3:53pm UTC](https://discuss.elastic.co/t/connector-for-elastic-search-8-6-2-and-databricks-spark-3-4-0/342746 "2023-09-29T15:53:14Z")

</div>

I am trying to connect Elastic Search using spark in data bricks but keep getting this error org.elasticsearch.hadoop.EsHadoopIllegalArgumentException: Cannot detect ES version - typically this happens if the network/Ela…

---

## [Action \[indices:admin/create\] is unauthorized for user](https://discuss.elastic.co/t/action-indices-admin-create-is-unauthorized-for-user/343990)

<div class="topic-metadata">

**Author:** [@brunoflament](https://discuss.elastic.co/u/brunoflament)\
**Replies:** 5\
**Last updated:** [September 29, 2023, 12:59pm UTC](https://discuss.elastic.co/t/action-indices-admin-create-is-unauthorized-for-user/343990 "2023-09-29T12:59:06Z")

</div>

Hi, I try to create a index but i have this error : PUT toto-1 ( curl -k -u "logstash:password" -X PUT "https://localhost:9200/toto-1) {"error":{"root\_cause":\[{"type":"security\_exception","reason":"action \[indices:adm…

---

## [Filtering elastic search results based on score](https://discuss.elastic.co/t/filtering-elastic-search-results-based-on-score/344136)

<div class="topic-metadata">

**Author:** [@mreddy9](https://discuss.elastic.co/u/mreddy9)\
**Replies:** 0\
**Last updated:** [September 29, 2023, 12:30pm UTC](https://discuss.elastic.co/t/filtering-elastic-search-results-based-on-score/344136 "2023-09-29T12:30:16Z")

</div>

Hi All, I'm using the following c# code to query the elastic and trying to filter the results which has less than 50% score but it still returning all results which has score more than 50%. Please help to resolve this i…

---

## [Elastic deleted documents](https://discuss.elastic.co/t/elastic-deleted-documents/344097)

<div class="topic-metadata">

**Author:** [@ranjini](https://discuss.elastic.co/u/ranjini)\
**Replies:** 6\
**Last updated:** [September 29, 2023, 12:10pm UTC](https://discuss.elastic.co/t/elastic-deleted-documents/344097 "2023-09-29T12:10:21Z")

</div>

All the documents which are ingested by logstash are deleted automatically. Please find the screen shot. I do not have any ISM policy to delete document. Any help!

---

## [Unable to verify the first certificate on postman](https://discuss.elastic.co/t/unable-to-verify-the-first-certificate-on-postman/344071)

<div class="topic-metadata">

**Author:** [@stramzik](https://discuss.elastic.co/u/stramzik)\
**Replies:** 3\
**Last updated:** [September 29, 2023, 9:22am UTC](https://discuss.elastic.co/t/unable-to-verify-the-first-certificate-on-postman/344071 "2023-09-29T09:22:52Z")

</div>

Hi I've setup a Elastic and Kibana instance on Windows server Both instances are secured with LetsEncrypt certificate. When I try to use the elasticsearch API on POSTMAN i get the "Unable to verify the first certificate…

---

## [Usecase product list filter in E-commerce web app](https://discuss.elastic.co/t/usecase-product-list-filter-in-e-commerce-web-app/344116)

<div class="topic-metadata">

**Author:** [@hieuneo](https://discuss.elastic.co/u/hieuneo)\
**Replies:** 0\
**Last updated:** [September 29, 2023, 8:14am UTC](https://discuss.elastic.co/t/usecase-product-list-filter-in-e-commerce-web-app/344116 "2023-09-29T08:14:03Z")

</div>

Hello everyone, I have a usecase and hope you can help me find a solution I have a Product index, with fields brandId and categoryId,..., I need to filter by many brandId and many categoryId and aggregate by brandId and…

---

## [Version conflict issue while updating data continously](https://discuss.elastic.co/t/version-conflict-issue-while-updating-data-continously/344065)

<div class="topic-metadata">

**Author:** [@bhumika](https://discuss.elastic.co/u/bhumika)\
**Replies:** 8\
**Last updated:** [September 29, 2023, 7:50am UTC](https://discuss.elastic.co/t/version-conflict-issue-while-updating-data-continously/344065 "2023-09-29T07:50:19Z")

</div>

Describe the bug/error/problem I am getting this error sometimes while updating the index of user. "error": "\[409\] {"error":{"root\_cause":\[{"type":"version\_conflict\_engine\_exception","reason":"\[2568\]: version conflict,…

---

## [Getting wrong method GET for \_ssl/certificates ES 7.17](https://discuss.elastic.co/t/getting-wrong-method-get-for-ssl-certificates-es-7-17/343811)

<div class="topic-metadata">

**Author:** [@Doc\_Kaos](https://discuss.elastic.co/u/Doc_Kaos)\
**Replies:** 7\
**Last updated:** [September 29, 2023, 6:54am UTC](https://discuss.elastic.co/t/getting-wrong-method-get-for-ssl-certificates-es-7-17/343811 "2023-09-29T06:54:17Z")

</div>

Has anyone seen this? It works fine on my 8.x clusters ... # curl -X GET "localhost:9200/\_ssl/certificates?pretty" { "error" : "Incorrect HTTP method for uri \[/\_ssl/certificates?pretty\] and method \[GET\], allowed: \[PO…

---

## [What Node to I point to](https://discuss.elastic.co/t/what-node-to-i-point-to/344096)

<div class="topic-metadata">

**Author:** [@digital-thought](https://discuss.elastic.co/u/digital-thought)\
**Replies:** 4\
**Last updated:** [September 29, 2023, 3:41am UTC](https://discuss.elastic.co/t/what-node-to-i-point-to/344096 "2023-09-29T03:41:14Z")

</div>

I have a cluster with 3 x Master, 4 x Hot, 4 x Warm and 2 x Ingest. With Kibana and when I want to send data to the cluster, what is the recommended set of nodes to point to? Is it just the Masters, Hot or Warm nodes o…

---

## [Change node hostname](https://discuss.elastic.co/t/change-node-hostname/338312)

<div class="topic-metadata">

**Author:** [@cesar.hernandez.a3se](https://discuss.elastic.co/u/cesar.hernandez.a3se)\
**Replies:** 7\
**Last updated:** [September 29, 2023, 3:19am UTC](https://discuss.elastic.co/t/change-node-hostname/338312 "2023-09-29T03:19:50Z")

</div>

Hi We have a 7 node ES cluster (v7.17.5) and we need to change the hostnames of all nodes. I know how to do it on Linux, but, is there anything I need to change on Elasticsearch? My elasticsearch.yml uses ip address (n…

---

## [How to boost scoring for whole word hits over substring hits](https://discuss.elastic.co/t/how-to-boost-scoring-for-whole-word-hits-over-substring-hits/344095)

<div class="topic-metadata">

**Author:** [@cookersjs](https://discuss.elastic.co/u/cookersjs)\
**Replies:** 0\
**Last updated:** [September 29, 2023, 12:38am UTC](https://discuss.elastic.co/t/how-to-boost-scoring-for-whole-word-hits-over-substring-hits/344095 "2023-09-29T00:38:30Z")

</div>

Hi there, I'd like to make it so that single-word query results that contain the entire query word by itself get higher scoring over results that contain the query word within another word. For example in the case I am…

---

## [What is the correct way to insert document in elastic search using multiple documents using multiple threads in c#](https://discuss.elastic.co/t/what-is-the-correct-way-to-insert-document-in-elastic-search-using-multiple-documents-using-multiple-threads-in-c/343711)

<div class="topic-metadata">

**Author:** [@mreddy9](https://discuss.elastic.co/u/mreddy9)\
**Replies:** 5\
**Last updated:** [September 28, 2023, 9:41pm UTC](https://discuss.elastic.co/t/what-is-the-correct-way-to-insert-document-in-elastic-search-using-multiple-documents-using-multiple-threads-in-c/343711 "2023-09-28T21:41:14Z")

</div>

Hi All, I'm using multiple threads in c# to isert documents in c# as below but some times document is not inserted into elstic search search. var indexResponse = elasticClient.IndexDocument(testReport); But if I try t…

---

## [Duplicates after index rollover](https://discuss.elastic.co/t/duplicates-after-index-rollover/344084)

<div class="topic-metadata">

**Author:** [@elk-user-0001](https://discuss.elastic.co/u/elk-user-0001)\
**Replies:** 16\
**Last updated:** [September 28, 2023, 6:49pm UTC](https://discuss.elastic.co/t/duplicates-after-index-rollover/344084 "2023-09-28T18:49:49Z")

</div>

Good afternoon. The problem that I am going to comment is a common problem but I do not know if elastic has already given a solution. We have an api ingest via logstash that we have to attack it 7 days ago because thro…

---

## [Able to access Elastic and Kibana in localhost but not outside](https://discuss.elastic.co/t/able-to-access-elastic-and-kibana-in-localhost-but-not-outside/344083)

<div class="topic-metadata">

**Author:** [@Yue\_CHEN](https://discuss.elastic.co/u/Yue_CHEN)\
**Replies:** 3\
**Last updated:** [September 28, 2023, 6:42pm UTC](https://discuss.elastic.co/t/able-to-access-elastic-and-kibana-in-localhost-but-not-outside/344083 "2023-09-28T18:42:49Z")

</div>

New to Elastic search, set up new instance in azure windows vm. Able to access Elastic and Kibana in localhost but not outside for some reason. Here are settings from Elastic.yml network.host: 10.x.x.x is private IP a…

---

## [How to change specialized data node role to generic data node role](https://discuss.elastic.co/t/how-to-change-specialized-data-node-role-to-generic-data-node-role/344089)

<div class="topic-metadata">

**Author:** [@Hemanth\_Gowda](https://discuss.elastic.co/u/Hemanth_Gowda)\
**Replies:** 0\
**Last updated:** [September 28, 2023, 5:57pm UTC](https://discuss.elastic.co/t/how-to-change-specialized-data-node-role-to-generic-data-node-role/344089 "2023-09-28T17:57:04Z")

</div>

Hi, We have 5 data nodes with below node roles as shown below. All data nodes are allocated with 2 TB of storage. We are seeing high storage usage on node1 and node2 due to specific specialized data roles defined to nod…

---

## [BucketSelectorPipelineAggregationBuilder missing from elasticsearch 8.9.2](https://discuss.elastic.co/t/bucketselectorpipelineaggregationbuilder-missing-from-elasticsearch-8-9-2/344067)

<div class="topic-metadata">

**Author:** [@rishavgu](https://discuss.elastic.co/u/rishavgu)\
**Replies:** 3\
**Last updated:** [September 28, 2023, 4:30pm UTC](https://discuss.elastic.co/t/bucketselectorpipelineaggregationbuilder-missing-from-elasticsearch-8-9-2/344067 "2023-09-28T16:30:16Z")

</div>

We are upgrading our Elasticsearch from 8.5.3 to 8.9.2 and our migration is failing with following error: Cannot resolve symbol 'BucketSelectorPipelineAggregationBuilder' Seems like in 8.9.2 this class file has been rem…

---

## [Error when creating a index template for a Time Serie](https://discuss.elastic.co/t/error-when-creating-a-index-template-for-a-time-serie/344002)

<div class="topic-metadata">

**Author:** [@Mubolio](https://discuss.elastic.co/u/Mubolio)\
**Replies:** 8\
**Last updated:** [September 28, 2023, 4:06pm UTC](https://discuss.elastic.co/t/error-when-creating-a-index-template-for-a-time-serie/344002 "2023-09-28T16:06:33Z")

</div>

Hello, I'm trying to use a timeserie datastream, for that I try to create an index template, note that the bellow example it is almost the same as the one in the documentation: PUT \_index\_template/my-weather-sensor-i…

---

## [How do I have to migrate the usage of org.elasticsearch.\* multiSearchResponse to co.elastic.\* MsearchResponse?](https://discuss.elastic.co/t/how-do-i-have-to-migrate-the-usage-of-org-elasticsearch-multisearchresponse-to-co-elastic-msearchresponse/344081)

<div class="topic-metadata">

**Author:** [@du-it](https://discuss.elastic.co/u/du-it)\
**Replies:** 0\
**Last updated:** [September 28, 2023, 3:52pm UTC](https://discuss.elastic.co/t/how-do-i-have-to-migrate-the-usage-of-org-elasticsearch-multisearchresponse-to-co-elastic-msearchresponse/344081 "2023-09-28T15:52:16Z")

</div>

I am migrating from org.elasticsearch.\* to co.elastic.\* classes using elasticsearch-java dependency 8.10.2. It's really not obvious which co.elastic.\* classes are the org.elasticsearvh.\* equivalent when replacing the R…

---

## [Received response for a request that has timed out and "failed to retrieve stats for node"](https://discuss.elastic.co/t/received-response-for-a-request-that-has-timed-out-and-failed-to-retrieve-stats-for-node/343963)

<div class="topic-metadata">

**Author:** [@sanju1323](https://discuss.elastic.co/u/sanju1323)\
**Replies:** 7\
**Last updated:** [September 28, 2023, 3:01pm UTC](https://discuss.elastic.co/t/received-response-for-a-request-that-has-timed-out-and-failed-to-retrieve-stats-for-node/343963 "2023-09-28T15:01:22Z")

</div>

Hi.. I have a 5 node cluster where we are receiving data around 400 GB per day. Disk in the cluster is at 70% mark on all the nodes. We have observed slowness in running simple queries like \_cat/indices also. When we c…

---

## [PutIndexTemplateRequest](https://discuss.elastic.co/t/putindextemplaterequest/343994)

<div class="topic-metadata">

**Author:** [@toddcarv](https://discuss.elastic.co/u/toddcarv)\
**Replies:** 2\
**Last updated:** [September 28, 2023, 11:42am UTC](https://discuss.elastic.co/t/putindextemplaterequest/343994 "2023-09-28T11:42:40Z")

</div>

Is there a replacement for the create method below in the new Java API? Thanks. PutIndexTemplateRequest request = new PutIndexTemplateRequest(TEMPLATE\_NAME); request.create(false); // Required to allow…

---

## [Total\_shards\_per\_node on an index pattern instead of an simple index](https://discuss.elastic.co/t/total-shards-per-node-on-an-index-pattern-instead-of-an-simple-index/343869)

<div class="topic-metadata">

**Author:** [@Guillaume\_Soustrade](https://discuss.elastic.co/u/Guillaume_Soustrade)\
**Replies:** 2\
**Last updated:** [September 28, 2023, 11:05am UTC](https://discuss.elastic.co/t/total-shards-per-node-on-an-index-pattern-instead-of-an-simple-index/343869 "2023-09-28T11:05:38Z")

</div>

Hello, I'm looking for a way to limit the number of shards per nodes on a group of index. Is it possible, may be by using index patterns ? My situation is : I have a set of 14 indexes with 12 shards for each We have …

[Previous page](https://discuss.elastic.co/c/elastic-stack/elasticsearch/6.md?page=194)

[Next page](https://discuss.elastic.co/c/elastic-stack/elasticsearch/6.md?page=196)
