# Elasticsearch

**URL:** https://discuss.elastic.co/c/elastic-stack/elasticsearch/6.md?page=21

[Latest](https://discuss.elastic.co/latest.md) · [Categories](https://discuss.elastic.co/categories.md) · [Tags](https://discuss.elastic.co/tags.md)

**Page:** 22

---

## [PUT mapping doesn't actually replace the mapping but only "updates" it with new fields](https://discuss.elastic.co/t/put-mapping-doesnt-actually-replace-the-mapping-but-only-updates-it-with-new-fields/381203)

<div class="topic-metadata">

**Author:** [@albertino87](https://discuss.elastic.co/u/albertino87)\
**Replies:** 1\
**Last updated:** [August 21, 2025, 11:04am UTC](https://discuss.elastic.co/t/put-mapping-doesnt-actually-replace-the-mapping-but-only-updates-it-with-new-fields/381203 "2025-08-21T11:04:27Z")

</div>

good morning, I have elasticsearch 7.17. I noticed that if I have a mapping in an existing index and then i use PUT mapping, it doesn’t replace the mapping with the new one as I would expect, but simply updates it with …

---

## [❗️ Issue: NotEntitledException after upgrading to Elasticsearch 8.18.1](https://discuss.elastic.co/t/issue-notentitledexception-after-upgrading-to-elasticsearch-8-18-1/381148)

<div class="topic-metadata">

**Author:** [@Shubham.Kumar](https://discuss.elastic.co/u/Shubham.Kumar)\
**Replies:** 13\
**Last updated:** [August 21, 2025, 10:09am UTC](https://discuss.elastic.co/t/issue-notentitledexception-after-upgrading-to-elasticsearch-8-18-1/381148 "2025-08-21T10:09:00Z")

</div>

Hi everyone, After upgrading to Elasticsearch 8.18.1, I'm encountering the following warning during startup: \[2025-08-20T05:39:57,789\]\[WARN \]\[o.e.e.r.p.P.r.o.e.r.root \] \[node-1\] Not entitled: component \[rest-root\], mod…

---

## [Failed to start elasticsearch|| ssl error](https://discuss.elastic.co/t/failed-to-start-elasticsearch-ssl-error/381173)

<div class="topic-metadata">

**Author:** [@sreya\_14](https://discuss.elastic.co/u/sreya_14)\
**Replies:** 5\
**Last updated:** [August 21, 2025, 7:46am UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch-ssl-error/381173 "2025-08-21T07:46:47Z")

</div>

Unable to start elasticsearch \[2025-08-20T17:16:58,661\]\[ERROR\]\[o.e.b.Elasticsearch \] \[vfralapelkprd01.canoninf.net\] fatal exception while booting Elasticsearchorg.elasticsearch.ElasticsearchSecurityException: faile…

---

## [Is it possible to skip some watcher inputs if an earlier input returns hits in Elasticsearch?](https://discuss.elastic.co/t/is-it-possible-to-skip-some-watcher-inputs-if-an-earlier-input-returns-hits-in-elasticsearch/381155)

<div class="topic-metadata">

**Author:** [@Simriti\_Bundhoo](https://discuss.elastic.co/u/Simriti_Bundhoo)\
**Replies:** 2\
**Last updated:** [August 21, 2025, 2:41am UTC](https://discuss.elastic.co/t/is-it-possible-to-skip-some-watcher-inputs-if-an-earlier-input-returns-hits-in-elasticsearch/381155 "2025-08-21T02:41:54Z")

</div>

Hi all, I’m working on an Elasticsearch Watcher that has multiple search inputs. What I want to do is: Run the first input query. If this query returns more than 0 hits, I want to skip running the other inputs ent…

---

## [Elasticsearch-java api for Slices doesn't have a way to specify 'auto' for reindexing?](https://discuss.elastic.co/t/elasticsearch-java-api-for-slices-doesnt-have-a-way-to-specify-auto-for-reindexing/380004)

<div class="topic-metadata">

**Author:** [@buitcj](https://discuss.elastic.co/u/buitcj)\
**Replies:** 3\
**Last updated:** [August 20, 2025, 4:01pm UTC](https://discuss.elastic.co/t/elasticsearch-java-api-for-slices-doesnt-have-a-way-to-specify-auto-for-reindexing/380004 "2025-08-20T16:01:56Z")

</div>

It seems that Slices.java in v8 and v9 of the elasticsearch-java, there is no way to specify slices = 'auto'? The REST API seems to to say 'auto' can be used (Reindex documents | Elasticsearch API documentation) But th…

---

## [Shared File System - Repository Issues](https://discuss.elastic.co/t/shared-file-system-repository-issues/381136)

<div class="topic-metadata">

**Author:** [@Armindo77](https://discuss.elastic.co/u/Armindo77)\
**Replies:** 7\
**Last updated:** [August 20, 2025, 2:28pm UTC](https://discuss.elastic.co/t/shared-file-system-repository-issues/381136 "2025-08-20T14:28:31Z")

</div>

Hello, Hope you guys are doing well! During the last few years, we have been using the Snapshot & Restore feature, over a Shared File System via SMB, and everything seemed to work well. We did some restores earlier thi…

---

## [Truncated Chunk](https://discuss.elastic.co/t/truncated-chunk/381057)

<div class="topic-metadata">

**Author:** [@cannon707](https://discuss.elastic.co/u/cannon707)\
**Replies:** 3\
**Last updated:** [August 20, 2025, 1:01pm UTC](https://discuss.elastic.co/t/truncated-chunk/381057 "2025-08-20T13:01:19Z")

</div>

We are currently upgrading our elastic stack from using the elasticsearch-rest-high-level-client 6.2.4 to elasticsearch-java client 8.19.0 and upgrading the server to match. While upgrading we have run into a problem tha…

---

## [Result from ES|QL differs from result of regular search](https://discuss.elastic.co/t/result-from-es-ql-differs-from-result-of-regular-search/381123)

<div class="topic-metadata">

**Author:** [@peter9](https://discuss.elastic.co/u/peter9)\
**Replies:** 8\
**Last updated:** [August 19, 2025, 6:27pm UTC](https://discuss.elastic.co/t/result-from-es-ql-differs-from-result-of-regular-search/381123 "2025-08-19T18:27:53Z")

</div>

This regular query: GET /twitter20230601-times/\_search { "\_source": \["counts"\] } results: { "took": 0, "timed\_out": false, "\_shards": { "total": 1, "successful": 1, "skipped": 0, "failed": 0 …

---

## [Index fields became unmapped](https://discuss.elastic.co/t/index-fields-became-unmapped/381120)

<div class="topic-metadata">

**Author:** [@zaeemmasood](https://discuss.elastic.co/u/zaeemmasood)\
**Replies:** 4\
**Last updated:** [August 19, 2025, 2:43pm UTC](https://discuss.elastic.co/t/index-fields-became-unmapped/381120 "2025-08-19T14:43:15Z")

</div>

Hi All, All fields except @timestamp became “Unmapped” (unavailable for Analysis). Please see below and help: This was working fine earlier. Please help

---

## [Interaction Between discovery.zen.ping.unicast.hosts and discovery-gce in Elasticsearch 6.5.3](https://discuss.elastic.co/t/interaction-between-discovery-zen-ping-unicast-hosts-and-discovery-gce-in-elasticsearch-6-5-3/381021)

<div class="topic-metadata">

**Author:** [@sisindri](https://discuss.elastic.co/u/sisindri)\
**Replies:** 3\
**Last updated:** [August 19, 2025, 10:58am UTC](https://discuss.elastic.co/t/interaction-between-discovery-zen-ping-unicast-hosts-and-discovery-gce-in-elasticsearch-6-5-3/381021 "2025-08-19T10:58:27Z")

</div>

We are running Elasticsearch 6.5.3 on GCP with the discovery-gce plugin enabled. All master nodes have both: discovery.zen.ping.unicast.hosts: \["ip1:9300", "ip2:9300", "ip3:9300"\] discovery.gce.project: "my-project" d…

---

## [High memory usage](https://discuss.elastic.co/t/high-memory-usage/381101)

<div class="topic-metadata">

**Author:** [@Dev\_AI](https://discuss.elastic.co/u/Dev_AI)\
**Replies:** 5\
**Last updated:** [August 18, 2025, 9:26am UTC](https://discuss.elastic.co/t/high-memory-usage/381101 "2025-08-18T09:26:04Z")

</div>

Hello, I'm new to the ElasticStacks universe and would like to ask a question. Below is a screenshot of the resources being used by my nodes. You can see that memory usage is high. Is this normal? Should I be conc…

---

## [Elasticsearch on BareMetal, not Virtual Server](https://discuss.elastic.co/t/elasticsearch-on-baremetal-not-virtual-server/381065)

<div class="topic-metadata">

**Author:** [@api\_developer](https://discuss.elastic.co/u/api_developer)\
**Replies:** 3\
**Last updated:** [August 17, 2025, 8:27pm UTC](https://discuss.elastic.co/t/elasticsearch-on-baremetal-not-virtual-server/381065 "2025-08-17T20:27:03Z")

</div>

Hi everyone, Does anyone have experience building Elastic Stack on BareMetal? Its depends on the price of SAN, which is expensive. If anyone has done it, could you share with me how you did it and the pros & cons? Tha…

---

## [Opster availability](https://discuss.elastic.co/t/opster-availability/368511)

<div class="topic-metadata">

**Author:** [@agonzalez](https://discuss.elastic.co/u/agonzalez)\
**Replies:** 9\
**Last updated:** [August 17, 2025, 8:21pm UTC](https://discuss.elastic.co/t/opster-availability/368511 "2025-08-17T20:21:44Z")

</div>

Elastic acquired opster 1 year ago, why is not available to new users yet or integrated? we need a solution like that to optimize clusters, now is very hard. I am testing Pulse that is an alternative but we would like t…

---

## [What is the best way to distribute nodes and shards in Elasticsearch to achieve fast search while storing recent data on SSD and older data on HDD?](https://discuss.elastic.co/t/what-is-the-best-way-to-distribute-nodes-and-shards-in-elasticsearch-to-achieve-fast-search-while-storing-recent-data-on-ssd-and-older-data-on-hdd/380988)

<div class="topic-metadata">

**Author:** [@Ella\_conan](https://discuss.elastic.co/u/Ella_conan)\
**Replies:** 27\
**Last updated:** [August 17, 2025, 7:52pm UTC](https://discuss.elastic.co/t/what-is-the-best-way-to-distribute-nodes-and-shards-in-elasticsearch-to-achieve-fast-search-while-storing-recent-data-on-ssd-and-older-data-on-hdd/380988 "2025-08-17T19:52:12Z")

</div>

Hello, I am storing events from different sources, and the data is continuous and reaches huge sizes. I want to implement an effective strategy for data retention. I want to keep the last 14 days of data on SSD storage…

---

## [ESQL beginner grouping question](https://discuss.elastic.co/t/esql-beginner-grouping-question/381054)

<div class="topic-metadata">

**Author:** [@spinscale](https://discuss.elastic.co/u/spinscale)\
**Replies:** 4\
**Last updated:** [August 15, 2025, 4:40pm UTC](https://discuss.elastic.co/t/esql-beginner-grouping-question/381054 "2025-08-15T16:40:11Z")

</div>

Hey, I am currently trying to convert a lengthy query DSL query with terms, top hits and max aggregations into a ESQL query, but I am failing at a basic requirement. Imagine the following three documents: PUT alr-test/…

---

## [NodeClosedException error](https://discuss.elastic.co/t/nodeclosedexception-error/381015)

<div class="topic-metadata">

**Author:** [@mahesh.hemke24](https://discuss.elastic.co/u/mahesh.hemke24)\
**Replies:** 2\
**Last updated:** [August 15, 2025, 3:33pm UTC](https://discuss.elastic.co/t/nodeclosedexception-error/381015 "2025-08-15T15:33:29Z")

</div>

{"@timestamp":"2025-08-13T08:41:40.021Z", "log.level": "INFO", "message":"stopping ...", "ecs.version": "1.2.0","service.name":"ES\_ECS","event.dataset":"elasticsearch.server","process.thread.name":"elasticsearch-shutdow…

---

## [Missing repodata/filelists.xml in yum repo causes repo sync to fail](https://discuss.elastic.co/t/missing-repodata-filelists-xml-in-yum-repo-causes-repo-sync-to-fail/374168)

<div class="topic-metadata">

**Author:** [@sobjerke](https://discuss.elastic.co/u/sobjerke)\
**Replies:** 35\
**Last updated:** [August 15, 2025, 7:47am UTC](https://discuss.elastic.co/t/missing-repodata-filelists-xml-in-yum-repo-causes-repo-sync-to-fail/374168 "2025-08-15T07:47:56Z")

</div>

We are using Red Hat Satellite server to distribute rpm packages to our servers. It synchronizes the Elasticsearch 8.x yum repository (https://artifacts.elastic.co/packages/8.x/yum) only downloading repository metadata a…

---

## [Copy ES snapshot to another ES](https://discuss.elastic.co/t/copy-es-snapshot-to-another-es/381045)

<div class="topic-metadata">

**Author:** [@Shahram](https://discuss.elastic.co/u/Shahram)\
**Replies:** 0\
**Last updated:** [August 14, 2025, 1:12pm UTC](https://discuss.elastic.co/t/copy-es-snapshot-to-another-es/381045 "2025-08-14T13:12:13Z")

</div>

Hello, I have 2 ES9.0.4 with exactily the same configuration and setup. In ES1: I created one index and put some dummy data as: get test/\_search { "took": 0, "timed\_out": false, "\_shards": { "total": 1, "successful"…

---

## [Getting error in elasticsearch while adding the policies](https://discuss.elastic.co/t/getting-error-in-elasticsearch-while-adding-the-policies/381013)

<div class="topic-metadata">

**Author:** [@mahesh.hemke24](https://discuss.elastic.co/u/mahesh.hemke24)\
**Replies:** 0\
**Last updated:** [August 13, 2025, 4:04pm UTC](https://discuss.elastic.co/t/getting-error-in-elasticsearch-while-adding-the-policies/381013 "2025-08-13T16:04:47Z")

</div>

Getting below errors {"@timestamp":"2025-08-13T08:41:40.028Z", "log.level": "INFO", "message":"\\\[controller/5551\\\] \\\[Main.cc@176\\\] ML controller exiting", "ecs.version": "1.2.0","service.name":"ES\_ECS","event.dataset":"…

---

## [Connection error (check network and/or proxy settings)- all nodes failed](https://discuss.elastic.co/t/connection-error-check-network-and-or-proxy-settings-all-nodes-failed/380965)

<div class="topic-metadata">

**Author:** [@shifen\_luo](https://discuss.elastic.co/u/shifen_luo)\
**Replies:** 4\
**Last updated:** [August 13, 2025, 1:39pm UTC](https://discuss.elastic.co/t/connection-error-check-network-and-or-proxy-settings-all-nodes-failed/380965 "2025-08-13T13:39:22Z")

</div>

Subject:​​ Connection error "all nodes failed" writing Hive to ES 7.7.1 via Spark UPSERT ​​Body:​​ Hi Elastic community, We're encountering persistent Connection error (check network and/or proxy settings) - all nodes…

---

## [Count existing files pattern](https://discuss.elastic.co/t/count-existing-files-pattern/380990)

<div class="topic-metadata">

**Author:** [@HarimbolaSantatra](https://discuss.elastic.co/u/HarimbolaSantatra)\
**Replies:** 2\
**Last updated:** [August 13, 2025, 12:29pm UTC](https://discuss.elastic.co/t/count-existing-files-pattern/380990 "2025-08-13T12:29:37Z")

</div>

We are monitoring a Wildfly deployments using Elasticsearch. Deployment status are done using Marker files on Wildfly. So if a war named example.war is successfully deployed, it will create a file named example.war.dep…

---

## [Renew http.p12 and http\_ca.p12](https://discuss.elastic.co/t/renew-http-p12-and-http-ca-p12/380983)

<div class="topic-metadata">

**Author:** [@Frances\_Chu](https://discuss.elastic.co/u/Frances_Chu)\
**Replies:** 1\
**Last updated:** [August 13, 2025, 8:26am UTC](https://discuss.elastic.co/t/renew-http-p12-and-http-ca-p12/380983 "2025-08-13T08:26:18Z")

</div>

In my system http.p12 expired in 2025 http\_ca.p12 expired in 2026 I renew the http.p12 to 2030 using the http\_ca.p12. May I know whehter http.p12 can work in 2027 (as http\_ca.p12 expired in 2026) If not. Is there a…

---

## [Large time variance between tests on the same system running the same track](https://discuss.elastic.co/t/large-time-variance-between-tests-on-the-same-system-running-the-same-track/380977)

<div class="topic-metadata">

**Author:** [@e.undaunted407](https://discuss.elastic.co/u/e.undaunted407)\
**Replies:** 1\
**Last updated:** [August 13, 2025, 8:13am UTC](https://discuss.elastic.co/t/large-time-variance-between-tests-on-the-same-system-running-the-same-track/380977 "2025-08-13T08:13:33Z")

</div>

I’ve been running rally multiple times on the same system as part of a benchmarking project, but I keep seeing huge variances between how long each run takes. How can I debug this further to understand what’s causing suc…

---

## [JRE 24 vulnerability](https://discuss.elastic.co/t/jre-24-vulnerability/380981)

<div class="topic-metadata">

**Author:** [@BS1](https://discuss.elastic.co/u/BS1)\
**Replies:** 2\
**Last updated:** [August 13, 2025, 8:01am UTC](https://discuss.elastic.co/t/jre-24-vulnerability/380981 "2025-08-13T08:01:36Z")

</div>

The Java 24 version bundled with all recent versions of Elasticsearch has three vulnerabilities, all published on April 15th CVE-2025-21587 Score 7.4 High CVE-2025-30691 Score 4.8 Medium CVE-2025-30698 Score 5.6 Mediu…

---

## [Double Multi-field Loses Precision](https://discuss.elastic.co/t/double-multi-field-loses-precision/380561)

<div class="topic-metadata">

**Author:** [@dna01](https://discuss.elastic.co/u/dna01)\
**Replies:** 7\
**Last updated:** [August 13, 2025, 7:10am UTC](https://discuss.elastic.co/t/double-multi-field-loses-precision/380561 "2025-08-13T07:10:50Z")

</div>

It seems double field under a float property loses precision in ES8. What changed on ES8? Is there a way to configure it (mapping/index/cluster) so it doesn't lose precision? I tested with the following index PUT test.…

---

## [How to add a synonym set at indexing](https://discuss.elastic.co/t/how-to-add-a-synonym-set-at-indexing/380973)

<div class="topic-metadata">

**Author:** [@VeniVidiVici](https://discuss.elastic.co/u/VeniVidiVici)\
**Replies:** 0\
**Last updated:** [August 12, 2025, 6:22pm UTC](https://discuss.elastic.co/t/how-to-add-a-synonym-set-at-indexing/380973 "2025-08-12T18:22:19Z")

</div>

Hello, I’m struggling to add a synonym at indexing using the EalsticSearch C# API, does anyone here has an example by any chance? My understanding is that I have to run the synonym association after I create my index. I…

---

## [The RRF retriever could use a weighting option](https://discuss.elastic.co/t/the-rrf-retriever-could-use-a-weighting-option/378182)

<div class="topic-metadata">

**Author:** [@jan.stap](https://discuss.elastic.co/u/jan.stap)\
**Replies:** 2\
**Last updated:** [August 12, 2025, 2:19pm UTC](https://discuss.elastic.co/t/the-rrf-retriever-could-use-a-weighting-option/378182 "2025-08-12T14:19:06Z")

</div>

Hi! I would like to combine a multi\_match query with two kNN queries. For that I use the RRF retriever, which itself uses a Standard retriever and two kNN retrievers. This works fine, but I have no option to add weighti…

---

## [\[v8.17.6\] Azure Managed Identity Not Working – CredentialUnavailableException](https://discuss.elastic.co/t/v8-17-6-azure-managed-identity-not-working-credentialunavailableexception/380335)

<div class="topic-metadata">

**Author:** [@kshanuy](https://discuss.elastic.co/u/kshanuy)\
**Replies:** 3\
**Last updated:** [August 12, 2025, 2:05pm UTC](https://discuss.elastic.co/t/v8-17-6-azure-managed-identity-not-working-credentialunavailableexception/380335 "2025-08-12T14:05:49Z")

</div>

We are trying to use User Assigned Managed Identity (UAMI) for snapshot repository authentication on Elasticsearch v8.17.6 running on Azure Virtual Machines Scale Set (Windows VM). We followed the official docs: https…

---

## [Snapshot Recovery Results in Empty Index for Dense Vector Embeddings (v8.18.2)](https://discuss.elastic.co/t/snapshot-recovery-results-in-empty-index-for-dense-vector-embeddings-v8-18-2/380168)

<div class="topic-metadata">

**Author:** [@Khanh\_Chuong\_Le](https://discuss.elastic.co/u/Khanh_Chuong_Le)\
**Replies:** 1\
**Last updated:** [August 12, 2025, 1:33pm UTC](https://discuss.elastic.co/t/snapshot-recovery-results-in-empty-index-for-dense-vector-embeddings-v8-18-2/380168 "2025-08-12T13:33:02Z")

</div>

I am experiencing an issue with Elasticsearch version 8.18.2 on a self-managed setup. I've set up an index with vector embeddings, templated as dense vectors. The index contains thousands of documents and search operatio…

---

## [Can't set JVM Cheap memory setting](https://discuss.elastic.co/t/cant-set-jvm-cheap-memory-setting/380957)

<div class="topic-metadata">

**Author:** [@TheJ](https://discuss.elastic.co/u/TheJ)\
**Replies:** 1\
**Last updated:** [August 12, 2025, 8:53am UTC](https://discuss.elastic.co/t/cant-set-jvm-cheap-memory-setting/380957 "2025-08-12T08:53:14Z")

</div>

Hi, I have a circuit\_breaking\_exception error in my cluster. When I look into logs I see that nodes need 32gb JVM memory to load indices. \[parent\] Data too large, data for \[indices:data/read/search\[phase/query\]\] would …

[Previous page](https://discuss.elastic.co/c/elastic-stack/elasticsearch/6.md?page=20)

[Next page](https://discuss.elastic.co/c/elastic-stack/elasticsearch/6.md?page=22)
