# Elasticsearch

**URL:** https://discuss.elastic.co/c/elastic-stack/elasticsearch/6.md?page=222

[Latest](https://discuss.elastic.co/latest.md) · [Categories](https://discuss.elastic.co/categories.md) · [Tags](https://discuss.elastic.co/tags.md)

**Page:** 223

---

## [Can I reindex using a search template?](https://discuss.elastic.co/t/can-i-reindex-using-a-search-template/339556)

<div class="topic-metadata">

**Author:** [@A\_Mightiev](https://discuss.elastic.co/u/A_Mightiev)\
**Replies:** 1\
**Last updated:** [July 28, 2023, 2:03pm UTC](https://discuss.elastic.co/t/can-i-reindex-using-a-search-template/339556 "2023-07-28T14:03:14Z")

</div>

Would it be possible to use the \_reindex but instead of specifying the query, call a search template stored?

---

## [Could not push logs to Elasticsearch cluster](https://discuss.elastic.co/t/could-not-push-logs-to-elasticsearch-cluster/339488)

<div class="topic-metadata">

**Author:** [@Vikas1633](https://discuss.elastic.co/u/Vikas1633)\
**Replies:** 1\
**Last updated:** [July 28, 2023, 1:16pm UTC](https://discuss.elastic.co/t/could-not-push-logs-to-elasticsearch-cluster/339488 "2023-07-28T13:16:04Z")

</div>

I am facing issue could not push logs to Elasticsearch cluster but when i change the buffer path and restart elastic it gets solved and every odd day I have to do this, looking for some permanent solution over this. :El…

---

## [\_mget vs \_search for large amount of documents](https://discuss.elastic.co/t/mget-vs-search-for-large-amount-of-documents/339521)

<div class="topic-metadata">

**Author:** [@hattorihanzo](https://discuss.elastic.co/u/hattorihanzo)\
**Replies:** 4\
**Last updated:** [July 28, 2023, 12:40pm UTC](https://discuss.elastic.co/t/mget-vs-search-for-large-amount-of-documents/339521 "2023-07-28T12:40:39Z")

</div>

Hi there! I'm looking for some guidance around what's the most fit way to retrieve a large amount of documents (\>=1000) when you know their ID. I'd like it to be fast, yet efficient and not put unnecessary strain on ES s…

---

## [Bulk indexing failed and after retrying 2 times. at Nest.BulkAllObservable\`1.\<BulkAsync\>d\_\_20.MoveNext()](https://discuss.elastic.co/t/bulk-indexing-failed-and-after-retrying-2-times-at-nest-bulkallobservable-1-bulkasync-d-20-movenext/339546)

<div class="topic-metadata">

**Author:** [@stkollamp](https://discuss.elastic.co/u/stkollamp)\
**Replies:** 0\
**Last updated:** [July 28, 2023, 12:26pm UTC](https://discuss.elastic.co/t/bulk-indexing-failed-and-after-retrying-2-times-at-nest-bulkallobservable-1-bulkasync-d-20-movenext/339546 "2023-07-28T12:26:08Z")

</div>

ElastiSearch 7.x is working completely fine with 7.15.x Nest Client and then I have migrated to Elasticsearch 8.8.1 and its response has shown that "minimum\_wire\_compatibility\_version" : "7.17.0". As suggested upgrade…

---

## [Alerting on watermark threshold - Available API or field inside elasticsearch?](https://discuss.elastic.co/t/alerting-on-watermark-threshold-available-api-or-field-inside-elasticsearch/339451)

<div class="topic-metadata">

**Author:** [@chouben](https://discuss.elastic.co/u/chouben)\
**Replies:** 1\
**Last updated:** [July 28, 2023, 12:05pm UTC](https://discuss.elastic.co/t/alerting-on-watermark-threshold-available-api-or-field-inside-elasticsearch/339451 "2023-07-28T12:05:41Z")

</div>

Hi I'm looking into a way on how to achieve monitoring of the watermark thresholds. We would like to add alerting once the first threshold passes. I do not want to use fixed sizes inside the alerts, but would like to u…

---

## [Ingest sharepoint on premises files to elk](https://discuss.elastic.co/t/ingest-sharepoint-on-premises-files-to-elk/339522)

<div class="topic-metadata">

**Author:** [@sunny2502](https://discuss.elastic.co/u/sunny2502)\
**Replies:** 1\
**Last updated:** [July 28, 2023, 9:54am UTC](https://discuss.elastic.co/t/ingest-sharepoint-on-premises-files-to-elk/339522 "2023-07-28T09:54:22Z")

</div>

Hi I want to ingest data from local sharepoint to elastic using python, can anyone please help me in same.

---

## [Limit on number of Clusters supported by Cross cluster search (CCS)](https://discuss.elastic.co/t/limit-on-number-of-clusters-supported-by-cross-cluster-search-ccs/339525)

<div class="topic-metadata">

**Author:** [@siddhartha\_c](https://discuss.elastic.co/u/siddhartha_c)\
**Replies:** 0\
**Last updated:** [July 28, 2023, 9:52am UTC](https://discuss.elastic.co/t/limit-on-number-of-clusters-supported-by-cross-cluster-search-ccs/339525 "2023-07-28T09:52:55Z")

</div>

Can I have a Architectural design where in we have around 100 clusters of Elastic. Where in each cluster is basically a small set of Master Node and Data Nodes . Using Cross Cluster Search if we send the search queries…

---

## [Rolling vs. Cluster Upgrades](https://discuss.elastic.co/t/rolling-vs-cluster-upgrades/339424)

<div class="topic-metadata">

**Author:** [@Tim\_Mobley](https://discuss.elastic.co/u/Tim_Mobley)\
**Replies:** 1\
**Last updated:** [July 28, 2023, 8:06am UTC](https://discuss.elastic.co/t/rolling-vs-cluster-upgrades/339424 "2023-07-28T08:06:30Z")

</div>

I'm wanting to better understand when to perform a full-cluster restart upgrade vs. a rolling upgrade of ES. I understand that a rolling upgrade has the benefit of minimizing impact to services during the upgrade (with t…

---

## [Memory consumption in io.netty.buffer.PoolThreadCache](https://discuss.elastic.co/t/memory-consumption-in-io-netty-buffer-poolthreadcache/339412)

<div class="topic-metadata">

**Author:** [@liguifa](https://discuss.elastic.co/u/liguifa)\
**Replies:** 10\
**Last updated:** [July 28, 2023, 8:02am UTC](https://discuss.elastic.co/t/memory-consumption-in-io-netty-buffer-poolthreadcache/339412 "2023-07-28T08:02:13Z")

</div>

Hi guys, I'm facing a large memory consumption in io.netty.buffer.PoolThreadCache. This portion of memory can reach up to 5GB. I think this is abnormal /usr/share/elasticsearch/jdk/bin/java -Xshare:auto -Des.networ…

---

## ["stacktrace": \["org.apache.lucene.index.CorruptIndexException: compound sub-files must have a valid codec header and footer: file is too small (0 bytes) (resource=BufferedChecksumIndexInput)](https://discuss.elastic.co/t/stacktrace-org-apache-lucene-index-corruptindexexception-compound-sub-files-must-have-a-valid-codec-header-and-footer-file-is-too-small-0-bytes-resource-bufferedchecksumindexinput/338323)

<div class="topic-metadata">

**Author:** [@Aravindh\_M](https://discuss.elastic.co/u/Aravindh_M)\
**Replies:** 21\
**Last updated:** [July 28, 2023, 8:00am UTC](https://discuss.elastic.co/t/stacktrace-org-apache-lucene-index-corruptindexexception-compound-sub-files-must-have-a-valid-codec-header-and-footer-file-is-too-small-0-bytes-resource-bufferedchecksumindexinput/338323 "2023-07-28T08:00:43Z")

</div>

Recently, we have been encountering the "CorruptIndexException" frequently, accompanied by the following stacktrace: "org.apache.lucene.index.CorruptIndexException: compound sub-files must have a valid codec header and f…

---

## [Total count of a field](https://discuss.elastic.co/t/total-count-of-a-field/339289)

<div class="topic-metadata">

**Author:** [@Dana\_Pavaday](https://discuss.elastic.co/u/Dana_Pavaday)\
**Replies:** 6\
**Last updated:** [July 28, 2023, 7:04am UTC](https://discuss.elastic.co/t/total-count-of-a-field/339289 "2023-07-28T07:04:43Z")

</div>

Hello everyone, I need to get the total count of a field in Elasticsearch (in my case, the number of clients in client field). How do I write the query in Dev tools?

---

## [Metrics don't send after some time to Elasticsearch - Temp. bulk send fail](https://discuss.elastic.co/t/metrics-dont-send-after-some-time-to-elasticsearch-temp-bulk-send-fail/339500)

<div class="topic-metadata">

**Author:** [@Swathi12](https://discuss.elastic.co/u/Swathi12)\
**Replies:** 0\
**Last updated:** [July 28, 2023, 6:41am UTC](https://discuss.elastic.co/t/metrics-dont-send-after-some-time-to-elasticsearch-temp-bulk-send-fail/339500 "2023-07-28T06:41:58Z")

</div>

Hi, Few months ago I installed metricbeat in K8S cluster and everything was working fine. All of a sudden after 1-2 months I get error: Temporary bulk send failure - Drop batch INFO \[publisher\] pipeline/retry.go:223 …

---

## [I would like to know about the limit on the maximum number of documents per index](https://discuss.elastic.co/t/i-would-like-to-know-about-the-limit-on-the-maximum-number-of-documents-per-index/339497)

<div class="topic-metadata">

**Author:** [@bbasosuho](https://discuss.elastic.co/u/bbasosuho)\
**Replies:** 3\
**Last updated:** [July 28, 2023, 6:50am UTC](https://discuss.elastic.co/t/i-would-like-to-know-about-the-limit-on-the-maximum-number-of-documents-per-index/339497 "2023-07-28T06:50:17Z")

</div>

Hi We are going to use elasticsearch 8.7. I would like to know if there is a limit on the number of documents to be stored in one index. Is there a limit on the number of documents per index? Or is there a limit on th…

---

## [Can't see metricbeat logs](https://discuss.elastic.co/t/cant-see-metricbeat-logs/339407)

<div class="topic-metadata">

**Author:** [@Swathi12](https://discuss.elastic.co/u/Swathi12)\
**Replies:** 2\
**Last updated:** [July 28, 2023, 6:35am UTC](https://discuss.elastic.co/t/cant-see-metricbeat-logs/339407 "2023-07-28T06:35:02Z")

</div>

Hi together Do you know why i can't see since creating of metricbeat any logfiles here ?

---

## [Elastic search not working](https://discuss.elastic.co/t/elastic-search-not-working/339423)

<div class="topic-metadata">

**Author:** [@gopikrish](https://discuss.elastic.co/u/gopikrish)\
**Replies:** 2\
**Last updated:** [July 28, 2023, 6:06am UTC](https://discuss.elastic.co/t/elastic-search-not-working/339423 "2023-07-28T06:06:52Z")

</div>

Hi Team, Suddenly, my Elasticsearch went down, and I'm not able to access it on remote systems or other systems with the same network band. I'm able to access it on my system only using my IP Address. For reference, I'…

---

## [Performance impact of upsert vs index with custom id](https://discuss.elastic.co/t/performance-impact-of-upsert-vs-index-with-custom-id/339492)

<div class="topic-metadata">

**Author:** [@sriapr98](https://discuss.elastic.co/u/sriapr98)\
**Replies:** 0\
**Last updated:** [July 28, 2023, 4:49am UTC](https://discuss.elastic.co/t/performance-impact-of-upsert-vs-index-with-custom-id/339492 "2023-07-28T04:49:47Z")

</div>

We have a huge traffic coming out of kafka which we are continuously ingesting to es using Index api(with custom doc id). Due to some edge cases we are thinking of moving to update api(upsert with doc\_as\_upsert with upd…

---

## [Failed to flush the buffer ||Data too large, data for|| could not push logs to Elasticsearch cluster](https://discuss.elastic.co/t/failed-to-flush-the-buffer-data-too-large-data-for-could-not-push-logs-to-elasticsearch-cluster/339489)

<div class="topic-metadata">

**Author:** [@Vikas1633](https://discuss.elastic.co/u/Vikas1633)\
**Replies:** 0\
**Last updated:** [July 28, 2023, 4:08am UTC](https://discuss.elastic.co/t/failed-to-flush-the-buffer-data-too-large-data-for-could-not-push-logs-to-elasticsearch-cluster/339489 "2023-07-28T04:08:46Z")

</div>

Hi all i am facing this issue since long and not able to control the buffer file whenever large amount of data is ingested its get chocked any help would be apprecitated. 2023-05-24 17:34:11 +0300 \[warn\]: #0 failed to f…

---

## [If index does not exists does not show error, return empty](https://discuss.elastic.co/t/if-index-does-not-exists-does-not-show-error-return-empty/339343)

<div class="topic-metadata">

**Author:** [@Murilo\_Livorato](https://discuss.elastic.co/u/Murilo_Livorato)\
**Replies:** 2\
**Last updated:** [July 27, 2023, 6:54pm UTC](https://discuss.elastic.co/t/if-index-does-not-exists-does-not-show-error-return-empty/339343 "2023-07-27T18:54:22Z")

</div>

hello , I have a search with many indexes here - GET index-0001, index-0002, index-0003/\_search { "size": 30, "query": { "match\_all": {} } } index-0001 exists index-0002 , does not exists . index-0003 exist…

---

## [How to use pagination with new Java Client](https://discuss.elastic.co/t/how-to-use-pagination-with-new-java-client/339460)

<div class="topic-metadata">

**Author:** [@Andre\_Schmer](https://discuss.elastic.co/u/Andre_Schmer)\
**Replies:** 0\
**Last updated:** [July 27, 2023, 4:42pm UTC](https://discuss.elastic.co/t/how-to-use-pagination-with-new-java-client/339460 "2023-07-27T16:42:24Z")

</div>

Trying to use a search\_after with the new Java API. That s what i did so far: SearchResponse\<PeriodInventory\> sr = newClient.search(searchRequest, PeriodInventory.class); List\<Hit\<PeriodInventory\>\> searchHits = sr.h…

---

## [Upgrading from 7.11.1 to 7.17 with only one node in the Cluster](https://discuss.elastic.co/t/upgrading-from-7-11-1-to-7-17-with-only-one-node-in-the-cluster/339455)

<div class="topic-metadata">

**Author:** [@getmoin](https://discuss.elastic.co/u/getmoin)\
**Replies:** 0\
**Last updated:** [July 27, 2023, 2:51pm UTC](https://discuss.elastic.co/t/upgrading-from-7-11-1-to-7-17-with-only-one-node-in-the-cluster/339455 "2023-07-27T14:51:55Z")

</div>

Hi everyone, I have an Elastic search in prod, hosting on GCP. The present version of the Elastic search is 7.11.1 and its in yellow (EOL) in the dashboard.I want to upgrade it to the 7.17.12. And then to the 8.x I hav…

---

## [Elastic memmory size](https://discuss.elastic.co/t/elastic-memmory-size/339450)

<div class="topic-metadata">

**Author:** [@hlcxpl](https://discuss.elastic.co/u/hlcxpl)\
**Replies:** 2\
**Last updated:** [July 27, 2023, 2:45pm UTC](https://discuss.elastic.co/t/elastic-memmory-size/339450 "2023-07-27T14:45:40Z")

</div>

Hi i have this error when i ingest my nodes with logstsh data the thing is that the nodes were block because the memory what to small for the size of data but i change the path data to another that has 5 Teras o f memor…

---

## [Customize security exception error message](https://discuss.elastic.co/t/customize-security-exception-error-message/339191)

<div class="topic-metadata">

**Author:** [@Juan\_Heredia\_Heredia](https://discuss.elastic.co/u/Juan_Heredia_Heredia)\
**Replies:** 0\
**Last updated:** [July 25, 2023, 12:15pm UTC](https://discuss.elastic.co/t/customize-security-exception-error-message/339191 "2023-07-25T12:15:27Z")

</div>

Hello everyone! I am novice in Kibana and this is my first topic in the group. Thanks in advance. It is possible to customize the error messages in Dev Tools Console? I need not shows the user and backend\_roles sec…

---

## [Does adding a custom endpoint alias retain the original random URL?](https://discuss.elastic.co/t/does-adding-a-custom-endpoint-alias-retain-the-original-random-url/339449)

<div class="topic-metadata">

**Author:** [@sparrowt](https://discuss.elastic.co/u/sparrowt)\
**Replies:** 0\
**Last updated:** [July 27, 2023, 2:21pm UTC](https://discuss.elastic.co/t/does-adding-a-custom-endpoint-alias-retain-the-original-random-url/339449 "2023-07-27T14:21:31Z")

</div>

If you create a 'custom endpoint alias' as described here, how long will the existing, original, random URL endpoints keep working for? For example with an existing Elastic Cloud deployment with Deployment ID Stringwith…

---

## [What's the number of Elser parameter?](https://discuss.elastic.co/t/whats-the-number-of-elser-parameter/339446)

<div class="topic-metadata">

**Author:** [@Ernest\_Dong](https://discuss.elastic.co/u/Ernest_Dong)\
**Replies:** 0\
**Last updated:** [July 27, 2023, 1:40pm UTC](https://discuss.elastic.co/t/whats-the-number-of-elser-parameter/339446 "2023-07-27T13:40:58Z")

</div>

The model binary is 400M in size. Looks like BERT. But I believe Elser must be quantized or distilled, since it took much more time to run in my laptop

---

## [Is it always necessary to use size attribute in DSL query?](https://discuss.elastic.co/t/is-it-always-necessary-to-use-size-attribute-in-dsl-query/339377)

<div class="topic-metadata">

**Author:** [@Sheereen](https://discuss.elastic.co/u/Sheereen)\
**Replies:** 3\
**Last updated:** [July 27, 2023, 1:23pm UTC](https://discuss.elastic.co/t/is-it-always-necessary-to-use-size-attribute-in-dsl-query/339377 "2023-07-27T13:23:26Z")

</div>

Hi, Is it always necessary to use the size attribute in Elasticsearch DSL query? What if there are many documents and I do not know the exact no of documents that I would need? I am trying to get the last poll data fr…

---

## [Elastic Enterprise Pricing](https://discuss.elastic.co/t/elastic-enterprise-pricing/339439)

<div class="topic-metadata">

**Author:** [@mahan\_masih](https://discuss.elastic.co/u/mahan_masih)\
**Replies:** 1\
**Last updated:** [July 27, 2023, 1:06pm UTC](https://discuss.elastic.co/t/elastic-enterprise-pricing/339439 "2023-07-27T13:06:24Z")

</div>

Hi, How is Elastic licensing priced? Is it per node, per eps, which parameter affects the price? This is for an on-prem cluster. Does anybody have an idea of the Enterprise license price? This is for an 8 nodes clust…

---

## [Does Elasticsearch capture audit logs for Query DSL, EQL and SQL or Not?](https://discuss.elastic.co/t/does-elasticsearch-capture-audit-logs-for-query-dsl-eql-and-sql-or-not/339398)

<div class="topic-metadata">

**Author:** [@Subrato1](https://discuss.elastic.co/u/Subrato1)\
**Replies:** 12\
**Last updated:** [July 27, 2023, 12:43pm UTC](https://discuss.elastic.co/t/does-elasticsearch-capture-audit-logs-for-query-dsl-eql-and-sql-or-not/339398 "2023-07-27T12:43:41Z")

</div>

Does Elasticsearch capture audit logs for Query DSL, EQL and SQL or Not???

---

## [I have install elasticsearch 8.5.3 in K8s, the pods are not getting up, shows error\[failed to bind service\]](https://discuss.elastic.co/t/i-have-install-elasticsearch-8-5-3-in-k8s-the-pods-are-not-getting-up-shows-error-failed-to-bind-service/339421)

<div class="topic-metadata">

**Author:** [@Rahul\_madugula](https://discuss.elastic.co/u/Rahul_madugula)\
**Replies:** 0\
**Last updated:** [July 27, 2023, 10:37am UTC](https://discuss.elastic.co/t/i-have-install-elasticsearch-8-5-3-in-k8s-the-pods-are-not-getting-up-shows-error-failed-to-bind-service/339421 "2023-07-27T10:37:13Z")

</div>

---

## [How to download platinum and enterprise version of elasticsearch for free trail](https://discuss.elastic.co/t/how-to-download-platinum-and-enterprise-version-of-elasticsearch-for-free-trail/339256)

<div class="topic-metadata">

**Author:** [@ashishshukla](https://discuss.elastic.co/u/ashishshukla)\
**Replies:** 19\
**Last updated:** [July 27, 2023, 10:23am UTC](https://discuss.elastic.co/t/how-to-download-platinum-and-enterprise-version-of-elasticsearch-for-free-trail/339256 "2023-07-27T10:23:59Z")

</div>

Please provide the link for download platinum or enterprise version of elasticsearch for free trail in Linux and rpm system.

---

## [Elasticsearch not capturing audit logs while I am executing index creation queries, SQL queries mention in ELASTICSEARCH documentation](https://discuss.elastic.co/t/elasticsearch-not-capturing-audit-logs-while-i-am-executing-index-creation-queries-sql-queries-mention-in-elasticsearch-documentation/339381)

<div class="topic-metadata">

**Author:** [@Subrato1](https://discuss.elastic.co/u/Subrato1)\
**Replies:** 1\
**Last updated:** [July 27, 2023, 10:22am UTC](https://discuss.elastic.co/t/elasticsearch-not-capturing-audit-logs-while-i-am-executing-index-creation-queries-sql-queries-mention-in-elasticsearch-documentation/339381 "2023-07-27T10:22:00Z")

</div>

I am executing index creation queries and SQL queries mention in ELASTICSEARCH documentation, but I am not getting audit logs regarding these queries. Can anyone tell me which kind audit logs only we can get while execu…

[Previous page](https://discuss.elastic.co/c/elastic-stack/elasticsearch/6.md?page=221)

[Next page](https://discuss.elastic.co/c/elastic-stack/elasticsearch/6.md?page=223)
