# Elasticsearch

**URL:** https://discuss.elastic.co/c/elastic-stack/elasticsearch/6.md?page=232

[Latest](https://discuss.elastic.co/latest.md) · [Categories](https://discuss.elastic.co/categories.md) · [Tags](https://discuss.elastic.co/tags.md)

**Page:** 233

---

## [Java heap space](https://discuss.elastic.co/t/java-heap-space/337902)

<div class="topic-metadata">

**Author:** [@UP\_NEWS](https://discuss.elastic.co/u/UP_NEWS)\
**Replies:** 2\
**Last updated:** [July 7, 2023, 3:44pm UTC](https://discuss.elastic.co/t/java-heap-space/337902 "2023-07-07T15:44:25Z")

</div>

Hello, how to resolve this problem my jvm is 16g Thanks

---

## [SPLIT Pipeline is not working correctly](https://discuss.elastic.co/t/split-pipeline-is-not-working-correctly/337880)

<div class="topic-metadata">

**Author:** [@anupvtr](https://discuss.elastic.co/u/anupvtr)\
**Replies:** 16\
**Last updated:** [July 7, 2023, 2:55pm UTC](https://discuss.elastic.co/t/split-pipeline-is-not-working-correctly/337880 "2023-07-07T14:55:56Z")

</div>

Hello All, Thanks in advance. We have configured the logstash on ServerA and pipeline is configured. All the filebeat agents are sending data successfully to ServerA. PipelinePrimary.conf To avoid delay and better l…

---

## [Move index to data warm manually](https://discuss.elastic.co/t/move-index-to-data-warm-manually/337885)

<div class="topic-metadata">

**Author:** [@UP\_NEWS](https://discuss.elastic.co/u/UP_NEWS)\
**Replies:** 7\
**Last updated:** [July 7, 2023, 2:53pm UTC](https://discuss.elastic.co/t/move-index-to-data-warm-manually/337885 "2023-07-07T14:53:06Z")

</div>

Hi, i can move a index from data hot to datawarm manullay with command rsync in linux from /var/lib/elasticsearch/nodes/uid(index) if the api ilm/\_move cant' work ? Thanks

---

## [Is it possible to parse NLP query on specific field?](https://discuss.elastic.co/t/is-it-possible-to-parse-nlp-query-on-specific-field/337900)

<div class="topic-metadata">

**Author:** [@learntech004](https://discuss.elastic.co/u/learntech004)\
**Replies:** 0\
**Last updated:** [July 7, 2023, 2:34pm UTC](https://discuss.elastic.co/t/is-it-possible-to-parse-nlp-query-on-specific-field/337900 "2023-07-07T14:34:57Z")

</div>

Hi I am trying to use ELSR model. One of my requirement is - I have a view column and if user searches using a NLP query like " Give me all documents viewed more than 10 times", will the model return only those documen…

---

## [Force merge optimise in background process](https://discuss.elastic.co/t/force-merge-optimise-in-background-process/337768)

<div class="topic-metadata">

**Author:** [@INS](https://discuss.elastic.co/u/INS)\
**Replies:** 8\
**Last updated:** [July 7, 2023, 2:33pm UTC](https://discuss.elastic.co/t/force-merge-optimise-in-background-process/337768 "2023-07-07T14:33:19Z")

</div>

Hi I need to change the force merge process in the background for count of segments. Also how I can steering/manipulating force merge. In my case I have the index which is really updating by data. So If this index is s…

---

## [Unable to send data from Otel Collector to Elasticsearch using Elastic APM](https://discuss.elastic.co/t/unable-to-send-data-from-otel-collector-to-elasticsearch-using-elastic-apm/337871)

<div class="topic-metadata">

**Author:** [@Prateek\_Kumar](https://discuss.elastic.co/u/Prateek_Kumar)\
**Replies:** 3\
**Last updated:** [July 7, 2023, 12:30pm UTC](https://discuss.elastic.co/t/unable-to-send-data-from-otel-collector-to-elasticsearch-using-elastic-apm/337871 "2023-07-07T12:30:01Z")

</div>

Hi Team, I am new to OpenTelemetry. I am trying to do setup using yaml files appraoch but facing 'connection refused' issue while connecting apm to elasticsearch. What I have achieved so far: Able to receive data in …

---

## [Java JDBC : http client did not trust this server's certificate, closing connection](https://discuss.elastic.co/t/java-jdbc-http-client-did-not-trust-this-servers-certificate-closing-connection/337421)

<div class="topic-metadata">

**Author:** [@dprutean](https://discuss.elastic.co/u/dprutean)\
**Replies:** 3\
**Last updated:** [July 7, 2023, 12:22pm UTC](https://discuss.elastic.co/t/java-jdbc-http-client-did-not-trust-this-servers-certificate-closing-connection/337421 "2023-07-07T12:22:57Z")

</div>

I created a docker container using: docker run --name elasticsearch -p 9200:9200 -p 9300:9300 -e "discovery.type=single-node" -it docker.elastic.co/elasticsearch/elasticsearch:8.8.2 This prints out the password and the…

---

## [Index routing and deletion](https://discuss.elastic.co/t/index-routing-and-deletion/337809)

<div class="topic-metadata">

**Author:** [@parthmaniar](https://discuss.elastic.co/u/parthmaniar)\
**Replies:** 1\
**Last updated:** [July 7, 2023, 12:16pm UTC](https://discuss.elastic.co/t/index-routing-and-deletion/337809 "2023-07-07T12:16:31Z")

</div>

Hello, I hope my message finds community members and their loved ones safe and healthy. I have a three-node cluster with two nodes storing data and one being a voting-only node. The current status of the cluster is ye…

---

## [Increase size of JVM Heap in Elastic cloud](https://discuss.elastic.co/t/increase-size-of-jvm-heap-in-elastic-cloud/337754)

<div class="topic-metadata">

**Author:** [@JasonREC](https://discuss.elastic.co/u/JasonREC)\
**Replies:** 3\
**Last updated:** [July 7, 2023, 8:58am UTC](https://discuss.elastic.co/t/increase-size-of-jvm-heap-in-elastic-cloud/337754 "2023-07-07T08:58:15Z")

</div>

Hi, I wonder if there is a way to increase the JVM Heap size of a node. I am curretly using cloud hosted Elasticsearch, and just want to increase 200mb of the heap Max size for one of my instance

---

## [ECK Stack - no persistent volumes available for this claim and no storage class is set](https://discuss.elastic.co/t/eck-stack-no-persistent-volumes-available-for-this-claim-and-no-storage-class-is-set/337875)

<div class="topic-metadata">

**Author:** [@simonebenati](https://discuss.elastic.co/u/simonebenati)\
**Replies:** 0\
**Last updated:** [July 7, 2023, 8:53am UTC](https://discuss.elastic.co/t/eck-stack-no-persistent-volumes-available-for-this-claim-and-no-storage-class-is-set/337875 "2023-07-07T08:53:59Z")

</div>

As the title says I am not able to provision a pvc, the error is: "no persistent volumes available for this claim and no storage class is set" And therefore the describe of the elasticsearch pod says: pod has unbou…

---

## [Reindexing failed with TAG Mismatch Exception](https://discuss.elastic.co/t/reindexing-failed-with-tag-mismatch-exception/335839)

<div class="topic-metadata">

**Author:** [@awenest](https://discuss.elastic.co/u/awenest)\
**Replies:** 2\
**Last updated:** [July 7, 2023, 5:23am UTC](https://discuss.elastic.co/t/reindexing-failed-with-tag-mismatch-exception/335839 "2023-07-07T05:23:55Z")

</div>

I have increased the socket timeout to 15 minutes since I am trying to reindex ~ 40k records. But within 6 minutes I get below exception : Caused by: org.springframework.dao.DataAccessResourceFailureException: Tag mism…

---

## [Regarding the ranking of the inspection results of elasticsearch](https://discuss.elastic.co/t/regarding-the-ranking-of-the-inspection-results-of-elasticsearch/337424)

<div class="topic-metadata">

**Author:** [@kimjinyoung](https://discuss.elastic.co/u/kimjinyoung)\
**Replies:** 4\
**Last updated:** [July 6, 2023, 11:52pm UTC](https://discuss.elastic.co/t/regarding-the-ranking-of-the-inspection-results-of-elasticsearch/337424 "2023-07-06T23:52:02Z")

</div>

hi! I would like to ask you about Elasticsearch's test result ranking. "If there is ""kimchy"" in the data below." user.id kimchy\_00 kimchy\_01 kimchy\_02 .. kimchy\_50 example of elasticsearch below GET /\_search { "…

---

## [Why \`/\_cat/indices\` shows system indices?](https://discuss.elastic.co/t/why-cat-indices-shows-system-indices/337837)

<div class="topic-metadata">

**Author:** [@Mike\_Z](https://discuss.elastic.co/u/Mike_Z)\
**Replies:** 1\
**Last updated:** [July 6, 2023, 10:00pm UTC](https://discuss.elastic.co/t/why-cat-indices-shows-system-indices/337837 "2023-07-06T22:00:44Z")

</div>

The system indices have names starting with a dot, like .xxxxxx. And usually, the command GET \_cat/indices/\_all does not show the system indices, so they are hidden by default. For learning purposes, we recently went th…

---

## [Help understanding boolean query and boosting?](https://discuss.elastic.co/t/help-understanding-boolean-query-and-boosting/337842)

<div class="topic-metadata">

**Author:** [@reswob](https://discuss.elastic.co/u/reswob)\
**Replies:** 2\
**Last updated:** [July 6, 2023, 9:22pm UTC](https://discuss.elastic.co/t/help-understanding-boolean-query-and-boosting/337842 "2023-07-06T21:22:52Z")

</div>

So I'm doing some self training in my lab. I wanted to create a query looking for value A in field A OR value B in field B and return all records that met that either criteria. Value A is type long and value B is text …

---

## [Reverse word order search (with shingles)](https://discuss.elastic.co/t/reverse-word-order-search-with-shingles/336792)

<div class="topic-metadata">

**Author:** [@RS232](https://discuss.elastic.co/u/RS232)\
**Replies:** 4\
**Last updated:** [July 6, 2023, 7:19pm UTC](https://discuss.elastic.co/t/reverse-word-order-search-with-shingles/336792 "2023-07-06T19:19:00Z")

</div>

Hello dear Elasticsearch users, Wanted to ask if anyone has a suggestion how to handle this situation. We have source data with phrases like "mazda 3" And two search scenarios: Customer should be able to find it via…

---

## [Problems with aggregations: Data too large](https://discuss.elastic.co/t/problems-with-aggregations-data-too-large/337591)

<div class="topic-metadata">

**Author:** [@tmslara.a](https://discuss.elastic.co/u/tmslara.a)\
**Replies:** 6\
**Last updated:** [July 6, 2023, 7:13pm UTC](https://discuss.elastic.co/t/problems-with-aggregations-data-too-large/337591 "2023-07-06T19:13:42Z")

</div>

Hi, I have problems when trying to get aggregations. I have a cluster with one node, and I'm trying to interact with an index that contains 534,737,088 documents (around 32 GB). Some aggregations work, and Elasticsearch…

---

## [Elastic multy match query with order of words given shoul follow in resulted records](https://discuss.elastic.co/t/elastic-multy-match-query-with-order-of-words-given-shoul-follow-in-resulted-records/337827)

<div class="topic-metadata">

**Author:** [@Lakshmikiran](https://discuss.elastic.co/u/Lakshmikiran)\
**Replies:** 1\
**Last updated:** [July 6, 2023, 6:49pm UTC](https://discuss.elastic.co/t/elastic-multy-match-query-with-order-of-words-given-shoul-follow-in-resulted-records/337827 "2023-07-06T18:49:53Z")

</div>

Using multi match queries in each query different words line word1 word2 word3 respectively. After search results also I'm expecting the words in same order, but in between of the words it could be present or not also. B…

---

## [S3 moving the data from 1 AWS S3 repo to new AWS repo](https://discuss.elastic.co/t/s3-moving-the-data-from-1-aws-s3-repo-to-new-aws-repo/337821)

<div class="topic-metadata">

**Author:** [@shani\_angarkadu](https://discuss.elastic.co/u/shani_angarkadu)\
**Replies:** 0\
**Last updated:** [July 6, 2023, 4:04pm UTC](https://discuss.elastic.co/t/s3-moving-the-data-from-1-aws-s3-repo-to-new-aws-repo/337821 "2023-07-06T16:04:34Z")

</div>

We have AWS S3 repo1 and we have cold phase data but we are planning to move that data to new AWS S3 repo. What is the best way to do it?

---

## [Bulk insert with Spark causes org.elasticsearch.hadoop.rest.EsHadoopNoNodesLeftException: Connection error (check network and/or proxy settings)- all nodes failed](https://discuss.elastic.co/t/bulk-insert-with-spark-causes-org-elasticsearch-hadoop-rest-eshadoopnonodesleftexception-connection-error-check-network-and-or-proxy-settings-all-nodes-failed/337631)

<div class="topic-metadata">

**Author:** [@Thijsvdp](https://discuss.elastic.co/u/Thijsvdp)\
**Replies:** 6\
**Last updated:** [July 6, 2023, 3:17pm UTC](https://discuss.elastic.co/t/bulk-insert-with-spark-causes-org-elasticsearch-hadoop-rest-eshadoopnonodesleftexception-connection-error-check-network-and-or-proxy-settings-all-nodes-failed/337631 "2023-07-06T15:17:06Z")

</div>

Hi all, I am having trouble with writing to a 5-node Elasticsearch cluster with Spark. Some basic details about the cluster: 5 nodes 6TB of disk 5x28 GB of RAM (half is Heap) 5x6 CPU Allocated 140 shards for the relev…

---

## [Logging from painless script in ingest pipeline](https://discuss.elastic.co/t/logging-from-painless-script-in-ingest-pipeline/337716)

<div class="topic-metadata">

**Author:** [@akhil\_reddy](https://discuss.elastic.co/u/akhil_reddy)\
**Replies:** 1\
**Last updated:** [July 6, 2023, 2:00pm UTC](https://discuss.elastic.co/t/logging-from-painless-script-in-ingest-pipeline/337716 "2023-07-06T14:00:12Z")

</div>

Hi, I have a requirement where I am indexing my raw docs to an index (original\_index). I am creating a rollup job for this index which runs every hour. My rollup index goes through an ingest pipeline which has a script. …

---

## [Migration from OpenSearch2.5 to Elasticsearch8.8.1](https://discuss.elastic.co/t/migration-from-opensearch2-5-to-elasticsearch8-8-1/336491)

<div class="topic-metadata">

**Author:** [@tatsuya](https://discuss.elastic.co/u/tatsuya)\
**Replies:** 8\
**Last updated:** [July 6, 2023, 12:57pm UTC](https://discuss.elastic.co/t/migration-from-opensearch2-5-to-elasticsearch8-8-1/336491 "2023-07-06T12:57:41Z")

</div>

Hello. I'm thinking of migrating from AWS OpenSearch to Elastic Cloud. First, I launched Elasticsearch 8.8.1 locally with docker and checked if the data could be migrated. Data migration experimented with Snapshot & R…

---

## [Combine multiple index and nested in search elasticsearch](https://discuss.elastic.co/t/combine-multiple-index-and-nested-in-search-elasticsearch/337753)

<div class="topic-metadata">

**Author:** [@stephane\_chan](https://discuss.elastic.co/u/stephane_chan)\
**Replies:** 1\
**Last updated:** [July 6, 2023, 11:43am UTC](https://discuss.elastic.co/t/combine-multiple-index-and-nested-in-search-elasticsearch/337753 "2023-07-06T11:43:03Z")

</div>

How to search multiple indexes with nested and non-nested fields ? I have an audio index with the results like this : { "\_index" : "audios", "\_type" : "\_doc", "\_id" : "145", "\_score" : 9…

---

## ["ClusterFormationFailureHelper" master not discovered error while master node is run an stable elected](https://discuss.elastic.co/t/clusterformationfailurehelper-master-not-discovered-error-while-master-node-is-run-an-stable-elected/337789)

<div class="topic-metadata">

**Author:** [@Mohammad\_Hossein\_Ela](https://discuss.elastic.co/u/Mohammad_Hossein_Ela)\
**Replies:** 0\
**Last updated:** [July 6, 2023, 11:22am UTC](https://discuss.elastic.co/t/clusterformationfailurehelper-master-not-discovered-error-while-master-node-is-run-an-stable-elected/337789 "2023-07-06T11:22:01Z")

</div>

I have two two nodes. the first node is master. this node is running without any error. but another node cannot discover this node. The full log of second node as below: \[2023-07-06T09:39:30,479\]\[INFO \]\[o.e.n.Node …

---

## [Elastic Curl search index refine](https://discuss.elastic.co/t/elastic-curl-search-index-refine/337776)

<div class="topic-metadata">

**Author:** [@kuthputheen](https://discuss.elastic.co/u/kuthputheen)\
**Replies:** 0\
**Last updated:** [July 6, 2023, 10:21am UTC](https://discuss.elastic.co/t/elastic-curl-search-index-refine/337776 "2023-07-06T10:21:43Z")

</div>

Team, I am using Elastic aggregation to fetch the certain values from the Logstash-database ( Index Name) search and the JSON results generating huge output (currently fetches 30,000 lines output) and bit time consuming…

---

## [Using own SSL certificate doesn't work on stack Elasticsearch + Kibana](https://discuss.elastic.co/t/using-own-ssl-certificate-doesnt-work-on-stack-elasticsearch-kibana/337772)

<div class="topic-metadata">

**Author:** [@vojtech-cerveny](https://discuss.elastic.co/u/vojtech-cerveny)\
**Replies:** 0\
**Last updated:** [July 6, 2023, 9:31am UTC](https://discuss.elastic.co/t/using-own-ssl-certificate-doesnt-work-on-stack-elasticsearch-kibana/337772 "2023-07-06T09:31:34Z")

</div>

Hello! I tried to create production stack kibana + elasticsearch and I am kinda stuck on certificates. Can you help me find the problem in my setting? Situation: We have SSL certificate for \*.example.com and I need …

---

## [Can't enroll new node in current cluster](https://discuss.elastic.co/t/cant-enroll-new-node-in-current-cluster/337764)

<div class="topic-metadata">

**Author:** [@Hi\_u\_Thu\_n](https://discuss.elastic.co/u/Hi_u_Thu_n)\
**Replies:** 0\
**Last updated:** [July 6, 2023, 8:28am UTC](https://discuss.elastic.co/t/cant-enroll-new-node-in-current-cluster/337764 "2023-07-06T08:28:12Z")

</div>

When i try bin\\elasticsearch --enrollment-token MyErrollMent It show an error ERROR: Skipping security auto configuration because it appears that the node is not starting up for the first time. The node might already …

---

## [Elastic Stack Upgradation](https://discuss.elastic.co/t/elastic-stack-upgradation/337760)

<div class="topic-metadata">

**Author:** [@Akulainelastic](https://discuss.elastic.co/u/Akulainelastic)\
**Replies:** 1\
**Last updated:** [July 6, 2023, 7:57am UTC](https://discuss.elastic.co/t/elastic-stack-upgradation/337760 "2023-07-06T07:57:59Z")

</div>

Hi All, so I want to upgrade the entire elk stack version from 7.2 to 8.4 , could anyone shed some light here upon what all backup and prerequisites I need to take care of. Thanks in advance.

---

## [Issue running elastics/security track in esrally offline mode](https://discuss.elastic.co/t/issue-running-elastics-security-track-in-esrally-offline-mode/336609)

<div class="topic-metadata">

**Author:** [@Swathi\_Kakumanu](https://discuss.elastic.co/u/Swathi_Kakumanu)\
**Replies:** 3\
**Last updated:** [July 6, 2023, 4:49am UTC](https://discuss.elastic.co/t/issue-running-elastics-security-track-in-esrally-offline-mode/336609 "2023-07-06T04:49:50Z")

</div>

Hi, I am trying to run esrally in offline mode. I am successful in running the http\_logs or geonames tracks in offline mode. However, I am facing issue when running the elastic/security or elastic/logs tracks in offline…

---

## [Elasticsearch restoring got conflicts with the internal system indices](https://discuss.elastic.co/t/elasticsearch-restoring-got-conflicts-with-the-internal-system-indices/337586)

<div class="topic-metadata">

**Author:** [@Mike\_Z](https://discuss.elastic.co/u/Mike_Z)\
**Replies:** 2\
**Last updated:** [July 5, 2023, 11:25pm UTC](https://discuss.elastic.co/t/elasticsearch-restoring-got-conflicts-with-the-internal-system-indices/337586 "2023-07-05T23:25:50Z")

</div>

We are trying to restore a snapshot made previously, using the following command: POST /\_snapshot/my\_backup/my\_snapshot\_2023.06.30/\_restore However, the command keeps getting errors saying ... index \[.xxxxxx\] because a…

---

## [Search UI - custom checkbox styling issue](https://discuss.elastic.co/t/search-ui-custom-checkbox-styling-issue/337725)

<div class="topic-metadata">

**Author:** [@JeroenAdam](https://discuss.elastic.co/u/JeroenAdam)\
**Replies:** 0\
**Last updated:** [July 5, 2023, 10:28pm UTC](https://discuss.elastic.co/t/search-ui-custom-checkbox-styling-issue/337725 "2023-07-05T22:28:05Z")

</div>

Hi there, I'm developing an app using search UI and Elasticsearch, great experience so far. I 'm lacking in advanced React skills, I have no idea why my custom styled checkboxes won't reflect the correct state in the UI…

[Previous page](https://discuss.elastic.co/c/elastic-stack/elasticsearch/6.md?page=231)

[Next page](https://discuss.elastic.co/c/elastic-stack/elasticsearch/6.md?page=233)
