# Elasticsearch

**URL:** https://discuss.elastic.co/c/elastic-stack/elasticsearch/6.md?page=245

[Latest](https://discuss.elastic.co/latest.md) · [Categories](https://discuss.elastic.co/categories.md) · [Tags](https://discuss.elastic.co/tags.md)

**Page:** 246

---

## [How to find the number of affected results from Collapse?](https://discuss.elastic.co/t/how-to-find-the-number-of-affected-results-from-collapse/335896)

<div class="topic-metadata">

**Author:** [@\_zogaj](https://discuss.elastic.co/u/_zogaj)\
**Replies:** 0\
**Last updated:** [June 13, 2023, 4:53pm UTC](https://discuss.elastic.co/t/how-to-find-the-number-of-affected-results-from-collapse/335896 "2023-06-13T16:53:57Z")

</div>

I am using collapse to remove duplicated docs. How to find affected results from Collapse ?

---

## [Adding a negative boost in a multi\_match query](https://discuss.elastic.co/t/adding-a-negative-boost-in-a-multi-match-query/335534)

<div class="topic-metadata">

**Author:** [@daansk44](https://discuss.elastic.co/u/daansk44)\
**Replies:** 3\
**Last updated:** [June 13, 2023, 2:52pm UTC](https://discuss.elastic.co/t/adding-a-negative-boost-in-a-multi-match-query/335534 "2023-06-13T14:52:49Z")

</div>

Hi everyone, I just started with Elastic Search I wanted to make some items in the query less relevant, so I am trying to give them a negative boost (make the two items in the must\_not sub-query less relevant). And exa…

---

## [Cluster fails to elect master after using new data store](https://discuss.elastic.co/t/cluster-fails-to-elect-master-after-using-new-data-store/335450)

<div class="topic-metadata">

**Author:** [@Xand](https://discuss.elastic.co/u/Xand)\
**Replies:** 6\
**Last updated:** [June 13, 2023, 2:36pm UTC](https://discuss.elastic.co/t/cluster-fails-to-elect-master-after-using-new-data-store/335450 "2023-06-13T14:36:41Z")

</div>

We have a 2-node cluster running on an Openshift platform. Recently, we installed new NFS volume shares to be used as data stores for the cluster, and we want to make a new cluster using those volumes. After deleting the…

---

## [Is there any jar to support elasticsearch integrated to tez on hadoop?](https://discuss.elastic.co/t/is-there-any-jar-to-support-elasticsearch-integrated-to-tez-on-hadoop/335857)

<div class="topic-metadata">

**Author:** [@Suna.Y](https://discuss.elastic.co/u/Suna.Y)\
**Replies:** 1\
**Last updated:** [June 13, 2023, 1:24pm UTC](https://discuss.elastic.co/t/is-there-any-jar-to-support-elasticsearch-integrated-to-tez-on-hadoop/335857 "2023-06-13T13:24:05Z")

</div>

Is there any jar to support elasticsearch integrated to tez on hadoop? I didn't see any jar like elasticsearch-hadoop-tez.jar

---

## [Sending custom documents from AWS Kinesis Firehose to Elastic Cloud](https://discuss.elastic.co/t/sending-custom-documents-from-aws-kinesis-firehose-to-elastic-cloud/335619)

<div class="topic-metadata">

**Author:** [@Andy0708](https://discuss.elastic.co/u/Andy0708)\
**Replies:** 5\
**Last updated:** [June 13, 2023, 11:57am UTC](https://discuss.elastic.co/t/sending-custom-documents-from-aws-kinesis-firehose-to-elastic-cloud/335619 "2023-06-13T11:57:50Z")

</div>

Hi, As part of a migration away from OpenSearch, we have been wanting to send data from AWS Kinesis Firehose to Elastic Cloud. This has historically required workarounds using either a transformation Lambda or a custom …

---

## [Elasticsearch Unit test using Test-containers](https://discuss.elastic.co/t/elasticsearch-unit-test-using-test-containers/335831)

<div class="topic-metadata">

**Author:** [@tcpeiris](https://discuss.elastic.co/u/tcpeiris)\
**Replies:** 4\
**Last updated:** [June 13, 2023, 9:44am UTC](https://discuss.elastic.co/t/elasticsearch-unit-test-using-test-containers/335831 "2023-06-13T09:44:07Z")

</div>

@TestConfiguration public class ESRestClientTestConfig { private static final String ELASTICSEARCH\_VERSION = "8.7.0"; private static final DockerImageName ELASTICSEARCH\_IMAGE = DockerImageName .parse(…

---

## [Migration from mysql to elasticsearch](https://discuss.elastic.co/t/migration-from-mysql-to-elasticsearch/335577)

<div class="topic-metadata">

**Author:** [@Omarbek\_Dinassil](https://discuss.elastic.co/u/Omarbek_Dinassil)\
**Replies:** 3\
**Last updated:** [June 13, 2023, 9:24am UTC](https://discuss.elastic.co/t/migration-from-mysql-to-elasticsearch/335577 "2023-06-13T09:24:46Z")

</div>

Hello! Right now I have three tables A, B and C in mysql database: Table A Table B Table C id id id FK\_A FK\_C I should write a service which…

---

## [Elasticsearch synonym mappings - illegal\_argument\_exception](https://discuss.elastic.co/t/elasticsearch-synonym-mappings-illegal-argument-exception/335746)

<div class="topic-metadata">

**Author:** [@Jacques\_du\_Plessis](https://discuss.elastic.co/u/Jacques_du_Plessis)\
**Replies:** 1\
**Last updated:** [June 13, 2023, 8:25am UTC](https://discuss.elastic.co/t/elasticsearch-synonym-mappings-illegal-argument-exception/335746 "2023-06-13T08:25:35Z")

</div>

is there a way to tell the mappings to ignore the synonym file if it does not exist? currently i always have to make sure that the synonym file exist, but just wondering of there is a way to ignore it if its not there, …

---

## [Removing redundancy in query](https://discuss.elastic.co/t/removing-redundancy-in-query/335778)

<div class="topic-metadata">

**Author:** [@searchwithme](https://discuss.elastic.co/u/searchwithme)\
**Replies:** 2\
**Last updated:** [June 13, 2023, 7:38am UTC](https://discuss.elastic.co/t/removing-redundancy-in-query/335778 "2023-06-13T07:38:56Z")

</div>

Can this query: { "query": { "bool": { "must": \[ { "match": { "title": "elasticsearch" } }, { "match": { "author": "jondoe" } }, { "range": { "price": { "gte": 10, "lte": 100 } } } \], "must\_not": \[ { "match": {…

---

## [How to describe multiple users in ECS](https://discuss.elastic.co/t/how-to-describe-multiple-users-in-ecs/335448)

<div class="topic-metadata">

**Author:** [@srilumpa](https://discuss.elastic.co/u/srilumpa)\
**Replies:** 4\
**Last updated:** [June 13, 2023, 7:29am UTC](https://discuss.elastic.co/t/how-to-describe-multiple-users-in-ecs/335448 "2023-06-13T07:29:52Z")

</div>

Hello, I have a use case that is not described in the Elastic ECS documentation and I am looking for best practices on how to handle this. So, basically, I have an application where an app admin can change multiple use…

---

## [Unable to install ESRally](https://discuss.elastic.co/t/unable-to-install-esrally/335523)

<div class="topic-metadata">

**Author:** [@Darshan\_J](https://discuss.elastic.co/u/Darshan_J)\
**Replies:** 4\
**Last updated:** [June 13, 2023, 6:14am UTC](https://discuss.elastic.co/t/unable-to-install-esrally/335523 "2023-06-13T06:14:50Z")

</div>

Using cached zipp-3.15.0-py3-none-any.whl (6.8 kB) Building wheels for collected packages: yappi Building wheel for yappi (setup.py) ... error error: subprocess-exited-with-error × python setup.py bdist\_wheel …

---

## [How to set other time zone in rally's log?](https://discuss.elastic.co/t/how-to-set-other-time-zone-in-rallys-log/328683)

<div class="topic-metadata">

**Author:** [@vsop\_479](https://discuss.elastic.co/u/vsop_479)\
**Replies:** 7\
**Last updated:** [June 13, 2023, 6:13am UTC](https://discuss.elastic.co/t/how-to-set-other-time-zone-in-rallys-log/328683 "2023-06-13T06:13:49Z")

</div>

Is there any way to set other time zone in rally's log? I tried modify the format or datefmt in logging.json, but can't figure it out. "normal": { "format": "%(asctime)s,%(msecs)d %(actorAddress)s/PID:%(process)d…

---

## [Get list of documents from a specific segment](https://discuss.elastic.co/t/get-list-of-documents-from-a-specific-segment/335663)

<div class="topic-metadata">

**Author:** [@cvarano](https://discuss.elastic.co/u/cvarano)\
**Replies:** 3\
**Last updated:** [June 13, 2023, 1:45am UTC](https://discuss.elastic.co/t/get-list-of-documents-from-a-specific-segment/335663 "2023-06-13T01:45:36Z")

</div>

Is there a way to inspect which documents are stored in a specific segment? I can get the segments from the cat segments api, but it only tells me the total # of docs. I want to perform two functions: Given a segment …

---

## [Authentication of \[elastic\] was terminated by realm \[reserved\] - failed to authenticate user \[elastic\]](https://discuss.elastic.co/t/authentication-of-elastic-was-terminated-by-realm-reserved-failed-to-authenticate-user-elastic/335744)

<div class="topic-metadata">

**Author:** [@Shreyansh\_Narang](https://discuss.elastic.co/u/Shreyansh_Narang)\
**Replies:** 1\
**Last updated:** [June 13, 2023, 1:27am UTC](https://discuss.elastic.co/t/authentication-of-elastic-was-terminated-by-realm-reserved-failed-to-authenticate-user-elastic/335744 "2023-06-13T01:27:38Z")

</div>

Getting the authentication error for elastic user. Authentication of \[elastic\] was terminated by realm \[reserved\] - failed to authenticate user \[elastic\] I tried resetting the password using bootstrap but no luck. Ca…

---

## [Can we apply new platinum license be applied before the start date](https://discuss.elastic.co/t/can-we-apply-new-platinum-license-be-applied-before-the-start-date/335593)

<div class="topic-metadata">

**Author:** [@forabraham1](https://discuss.elastic.co/u/forabraham1)\
**Replies:** 1\
**Last updated:** [June 13, 2023, 1:08am UTC](https://discuss.elastic.co/t/can-we-apply-new-platinum-license-be-applied-before-the-start-date/335593 "2023-06-13T01:08:03Z")

</div>

Currently we're using platinum license (in-house) and it is going expire on July 1st 2023 12:59 AM. We have procured new platinum license for this year and its start date is "start\_date\_in\_millis":1656633600000 which is …

---

## [Watcher webhook gives error 401 Authorization after certificate update](https://discuss.elastic.co/t/watcher-webhook-gives-error-401-authorization-after-certificate-update/335457)

<div class="topic-metadata">

**Author:** [@ynassipov](https://discuss.elastic.co/u/ynassipov)\
**Replies:** 1\
**Last updated:** [June 13, 2023, 12:57am UTC](https://discuss.elastic.co/t/watcher-webhook-gives-error-401-authorization-after-certificate-update/335457 "2023-06-13T00:57:33Z")

</div>

Recently upgraded Elasticsearch from 8.3.2 to 8.6.2 we have watcher with webhook posting information to 3rd party application for one of the instances of that 3rd party application we had to update SSL certificate aft…

---

## [Estimate resource usage in ES 6](https://discuss.elastic.co/t/estimate-resource-usage-in-es-6/335803)

<div class="topic-metadata">

**Author:** [@louisdeveloper](https://discuss.elastic.co/u/louisdeveloper)\
**Replies:** 1\
**Last updated:** [June 13, 2023, 12:39am UTC](https://discuss.elastic.co/t/estimate-resource-usage-in-es-6/335803 "2023-06-13T00:39:08Z")

</div>

However I have a self-hosted server with Elasticsearch 6. Does it allow me to get an estimate of how many GB were read during a period and how many API calls were made in a period?

---

## [How to configure Elastic.Serilog.Sinks librari with appsettings.json?](https://discuss.elastic.co/t/how-to-configure-elastic-serilog-sinks-librari-with-appsettings-json/335635)

<div class="topic-metadata">

**Author:** [@mchudinov](https://discuss.elastic.co/u/mchudinov)\
**Replies:** 1\
**Last updated:** [June 12, 2023, 11:30pm UTC](https://discuss.elastic.co/t/how-to-configure-elastic-serilog-sinks-librari-with-appsettings-json/335635 "2023-06-12T23:30:01Z")

</div>

I want to use Elastic.Serilog.Sinks library (created by Elastic co) to submit logs to an Elastic instance inside the Elastic cloud. How to configure logging using appsettings.json for a .NET 7 application? How to confi…

---

## [An issue , in implmenting the scroll function](https://discuss.elastic.co/t/an-issue-in-implmenting-the-scroll-function/335813)

<div class="topic-metadata">

**Author:** [@Bettaieb\_Walid](https://discuss.elastic.co/u/Bettaieb_Walid)\
**Replies:** 0\
**Last updated:** [June 12, 2023, 9:48pm UTC](https://discuss.elastic.co/t/an-issue-in-implmenting-the-scroll-function/335813 "2023-06-12T21:48:43Z")

</div>

hello , i am developing a scroll api , in order to be able to fetch a large amount of data , i am able to console log the scroll id , but i am having an empty response , here is my code snippet \`\`\`const { Client } = req…

---

## [Cost of ElasticSearch on Google Cloud Platform](https://discuss.elastic.co/t/cost-of-elasticsearch-on-google-cloud-platform/335799)

<div class="topic-metadata">

**Author:** [@louisdeveloper](https://discuss.elastic.co/u/louisdeveloper)\
**Replies:** 5\
**Last updated:** [June 12, 2023, 6:16pm UTC](https://discuss.elastic.co/t/cost-of-elasticsearch-on-google-cloud-platform/335799 "2023-06-12T18:16:18Z")

</div>

In our company, we chose to use Elasticsearch Cloud on Google Cloud Platform (GCP) due to the ease of updating and scaling our application. However, GCP has a charge for every HTTP access on our VM. Since our other VMs…

---

## [This really helped me on Elastic with Logstash 8.x](https://discuss.elastic.co/t/this-really-helped-me-on-elastic-with-logstash-8-x/335781)

<div class="topic-metadata">

**Author:** [@dpresbit](https://discuss.elastic.co/u/dpresbit)\
**Replies:** 0\
**Last updated:** [June 12, 2023, 2:27pm UTC](https://discuss.elastic.co/t/this-really-helped-me-on-elastic-with-logstash-8-x/335781 "2023-06-12T14:27:36Z")

</div>

Continuing the discussion from Where is the object mapping for \[host\] defined?:

---

## [\[es/search\] failed: \[search\_phase\_execution\_exception\] all shards failed](https://discuss.elastic.co/t/es-search-failed-search-phase-execution-exception-all-shards-failed/335428)

<div class="topic-metadata">

**Author:** [@FTOR](https://discuss.elastic.co/u/FTOR)\
**Replies:** 6\
**Last updated:** [June 12, 2023, 1:31pm UTC](https://discuss.elastic.co/t/es-search-failed-search-phase-execution-exception-all-shards-failed/335428 "2023-06-12T13:31:52Z")

</div>

Hello, I would like to get documents from an index that contains a huge number of data ~ (1 million). I am using ElasticSearchClient to connect and get information from Elasticsearch. I tested the solution with a small…

---

## [Difficulty creating role](https://discuss.elastic.co/t/difficulty-creating-role/335764)

<div class="topic-metadata">

**Author:** [@Jck\_H\_ui](https://discuss.elastic.co/u/Jck_H_ui)\
**Replies:** 6\
**Last updated:** [June 12, 2023, 1:04pm UTC](https://discuss.elastic.co/t/difficulty-creating-role/335764 "2023-06-12T13:04:18Z")

</div>

I'm trying to create a role using the command as described in the doc's ( I'm using elastic 8.7) curl -X POST "localhost:9200/\_security/role/myprofile?pretty" -H 'Content-Type: application/json' -d' { "indices": \[ …

---

## [Error message: the node is expected to continue to exceed the high disk watermark when these relocations are complete](https://discuss.elastic.co/t/error-message-the-node-is-expected-to-continue-to-exceed-the-high-disk-watermark-when-these-relocations-are-complete/335660)

<div class="topic-metadata">

**Author:** [@Mhvrke](https://discuss.elastic.co/u/Mhvrke)\
**Replies:** 2\
**Last updated:** [June 12, 2023, 1:00pm UTC](https://discuss.elastic.co/t/error-message-the-node-is-expected-to-continue-to-exceed-the-high-disk-watermark-when-these-relocations-are-complete/335660 "2023-06-12T13:00:02Z")

</div>

Hi! There’s this scenario where my cluster elasticsearch in rke logs is showing the following message: the node is expected to continue to exceed the high disk watermark when these relocations are complete. It keeps lo…

---

## [Anyone please help me for How to make flyaway for elastic search with node js?](https://discuss.elastic.co/t/anyone-please-help-me-for-how-to-make-flyaway-for-elastic-search-with-node-js/335707)

<div class="topic-metadata">

**Author:** [@faiyaz\_18](https://discuss.elastic.co/u/faiyaz_18)\
**Replies:** 4\
**Last updated:** [June 12, 2023, 12:33pm UTC](https://discuss.elastic.co/t/anyone-please-help-me-for-how-to-make-flyaway-for-elastic-search-with-node-js/335707 "2023-06-12T12:33:33Z")

</div>

Elastic search

---

## [Cannot post document to TimeSeries DataStream after upgrade from 8.6.2 to 8.7.1](https://discuss.elastic.co/t/cannot-post-document-to-timeseries-datastream-after-upgrade-from-8-6-2-to-8-7-1/335313)

<div class="topic-metadata">

**Author:** [@VietDuc](https://discuss.elastic.co/u/VietDuc)\
**Replies:** 14\
**Last updated:** [June 12, 2023, 11:39am UTC](https://discuss.elastic.co/t/cannot-post-document-to-timeseries-datastream-after-upgrade-from-8-6-2-to-8-7-1/335313 "2023-06-12T11:39:57Z")

</div>

Hi everyone, We had some Timeseries DataStream in version 8.6.2 and we have just upgraded our cluster to version 8.7.1. However, after the upgrade, new documents cannot be posted to those TSDS and we got the following e…

---

## [Which storage type should I use for Elasticsearch?](https://discuss.elastic.co/t/which-storage-type-should-i-use-for-elasticsearch/335511)

<div class="topic-metadata">

**Author:** [@Yasser\_Alsawy](https://discuss.elastic.co/u/Yasser_Alsawy)\
**Replies:** 1\
**Last updated:** [June 12, 2023, 11:33am UTC](https://discuss.elastic.co/t/which-storage-type-should-i-use-for-elasticsearch/335511 "2023-06-12T11:33:59Z")

</div>

I'm installing elasticsearch and needs 2 TB storage for shipping from filesystem log files using beats and logstash. What is the proper storage type as per our required design (frequent writes, many nodes and less read) …

---

## [ConnectionRefusedError: \[Errno 111\] Connection refused error while running rally for an existing elastic cluster](https://discuss.elastic.co/t/connectionrefusederror-errno-111-connection-refused-error-while-running-rally-for-an-existing-elastic-cluster/335333)

<div class="topic-metadata">

**Author:** [@Swathi\_Kakumanu](https://discuss.elastic.co/u/Swathi_Kakumanu)\
**Replies:** 3\
**Last updated:** [June 12, 2023, 6:37am UTC](https://discuss.elastic.co/t/connectionrefusederror-errno-111-connection-refused-error-while-running-rally-for-an-existing-elastic-cluster/335333 "2023-06-12T06:37:12Z")

</div>

Hi, I am new to rally and trying to run the benchmark for the existing cluster. I have 3 K8's nodes (1 master,2 worker) 192.168.105.116 192.168.105.117 192.168.105.118 I have created an Elasticsearch cluster on top…

---

## [Add unique value for each fields](https://discuss.elastic.co/t/add-unique-value-for-each-fields/335695)

<div class="topic-metadata">

**Author:** [@sevbans](https://discuss.elastic.co/u/sevbans)\
**Replies:** 6\
**Last updated:** [June 11, 2023, 9:26pm UTC](https://discuss.elastic.co/t/add-unique-value-for-each-fields/335695 "2023-06-11T21:26:30Z")

</div>

I have a index something like this: All countries' names, along with their populations, exist in my index. Since Kibana does not allow us to use the countries' normal names, I have to add unique country codes such as…

---

## [Too many open files](https://discuss.elastic.co/t/too-many-open-files/335677)

<div class="topic-metadata">

**Author:** [@lchqlchq](https://discuss.elastic.co/u/lchqlchq)\
**Replies:** 4\
**Last updated:** [June 11, 2023, 7:36am UTC](https://discuss.elastic.co/t/too-many-open-files/335677 "2023-06-11T07:36:32Z")

</div>

i have a three node es7.4 cluster without data. choose one node,ifdown the network，and es filehandler increasing quickly until the ulimit filehandler fills up。the new added filehandler point the same socket id as:ll /pro…

[Previous page](https://discuss.elastic.co/c/elastic-stack/elasticsearch/6.md?page=244)

[Next page](https://discuss.elastic.co/c/elastic-stack/elasticsearch/6.md?page=246)
