# Elasticsearch

**URL:** https://discuss.elastic.co/c/elastic-stack/elasticsearch/6.md?page=247

[Latest](https://discuss.elastic.co/latest.md) · [Categories](https://discuss.elastic.co/categories.md) · [Tags](https://discuss.elastic.co/tags.md)

**Page:** 248

---

## [How to change elasticsearch.slowlog.id?](https://discuss.elastic.co/t/how-to-change-elasticsearch-slowlog-id/335184)

<div class="topic-metadata">

**Author:** [@Ghouneim](https://discuss.elastic.co/u/Ghouneim)\
**Replies:** 3\
**Last updated:** [June 8, 2023, 3:25pm UTC](https://discuss.elastic.co/t/how-to-change-elasticsearch-slowlog-id/335184 "2023-06-08T15:25:07Z")

</div>

Hello, I want to be able to track the user who send the \_bulk request for indexing some data so I am trying to use X-Opaque-Id in bulk requests to be displayed in \*\_index\_indexing\_slowlog.json but I always get a differe…

---

## [/etc/elasticsearch/certs/ - 3 files](https://discuss.elastic.co/t/etc-elasticsearch-certs-3-files/335459)

<div class="topic-metadata">

**Author:** [@Timberwolve77](https://discuss.elastic.co/u/Timberwolve77)\
**Replies:** 5\
**Last updated:** [June 8, 2023, 2:52pm UTC](https://discuss.elastic.co/t/etc-elasticsearch-certs-3-files/335459 "2023-06-08T14:52:57Z")

</div>

I saw there is a directory /etc/elasticsearch/certs/ and inside there are three files: http\_ca.crt, http.p12 and transport.p12. What if these files were deleted? Is there a way to generate new ones?

---

## [Increased memory requirements for geo search queries in Elasticsearch 8](https://discuss.elastic.co/t/increased-memory-requirements-for-geo-search-queries-in-elasticsearch-8/334594)

<div class="topic-metadata">

**Author:** [@Tomas\_Bartek](https://discuss.elastic.co/u/Tomas_Bartek)\
**Replies:** 15\
**Last updated:** [June 8, 2023, 2:33pm UTC](https://discuss.elastic.co/t/increased-memory-requirements-for-geo-search-queries-in-elasticsearch-8/334594 "2023-06-08T14:33:30Z")

</div>

After upgrading from Elasticsearch 7.17.10 to Elasticsearch 8.7.1, our geosearch workloads started to hit memory circuitbreaker leading to the unstable cluster (cluster rejecting requests which leads to degradation of …

---

## [ElasticSearch rest-high-level client compatibility and licensing](https://discuss.elastic.co/t/elasticsearch-rest-high-level-client-compatibility-and-licensing/335471)

<div class="topic-metadata">

**Author:** [@Nikita\_Bratukhin](https://discuss.elastic.co/u/Nikita_Bratukhin)\
**Replies:** 1\
**Last updated:** [June 8, 2023, 1:35pm UTC](https://discuss.elastic.co/t/elasticsearch-rest-high-level-client-compatibility-and-licensing/335471 "2023-06-08T13:35:24Z")

</div>

Hello! I faced the problem the same as in this issue : stackoverflow/a/74102828 We would like to use newer ES client with old ES cluster( in order to gracefully migrate everything). But es client validates X-Elastic-P…

---

## [Reverse word search in Elastic](https://discuss.elastic.co/t/reverse-word-search-in-elastic/334173)

<div class="topic-metadata">

**Author:** [@Rakhshunda\_Noorein\_J](https://discuss.elastic.co/u/Rakhshunda_Noorein_J)\
**Replies:** 7\
**Last updated:** [May 31, 2023, 10:09am UTC](https://discuss.elastic.co/t/reverse-word-search-in-elastic/334173 "2023-05-31T10:09:32Z")

</div>

Hello, I want to search words in reverse also in Elasticsearch. for Example - "Tpp Info" and "Info Tpp" should give the same result. while in my db the document present is "Tpp Infotech" in the field title. My query is…

---

## [Cannot login to Elastic Cloud, UI keep saying wrong password](https://discuss.elastic.co/t/cannot-login-to-elastic-cloud-ui-keep-saying-wrong-password/335512)

<div class="topic-metadata">

**Author:** [@mecer80](https://discuss.elastic.co/u/mecer80)\
**Replies:** 4\
**Last updated:** [June 8, 2023, 10:55am UTC](https://discuss.elastic.co/t/cannot-login-to-elastic-cloud-ui-keep-saying-wrong-password/335512 "2023-06-08T10:55:00Z")

</div>

Hi, I can't seem to login using the client UI: https://cloud.elastic.co/ It keeps saying my password is wrong even thought I've tried to changed it like 10 times using the "forgot your password". I received the emails…

---

## [Reindexing using Java Client - What happens when one or both of the index do not exist](https://discuss.elastic.co/t/reindexing-using-java-client-what-happens-when-one-or-both-of-the-index-do-not-exist/335505)

<div class="topic-metadata">

**Author:** [@sanskarfc](https://discuss.elastic.co/u/sanskarfc)\
**Replies:** 5\
**Last updated:** [June 8, 2023, 10:06am UTC](https://discuss.elastic.co/t/reindexing-using-java-client-what-happens-when-one-or-both-of-the-index-do-not-exist/335505 "2023-06-08T10:06:24Z")

</div>

What happens when one or both of the index do not exist if we do reindexing using Java Client? When I tested on local, it completes successfully without throwing exception. How does one test if an index already exists o…

---

## [Compatible s3 plugin for my ES](https://discuss.elastic.co/t/compatible-s3-plugin-for-my-es/335510)

<div class="topic-metadata">

**Author:** [@EshaSingh32000](https://discuss.elastic.co/u/EshaSingh32000)\
**Replies:** 1\
**Last updated:** [June 8, 2023, 7:34am UTC](https://discuss.elastic.co/t/compatible-s3-plugin-for-my-es/335510 "2023-06-08T07:34:49Z")

</div>

Hello, My elasticsearch version is elasticsearch -6.4.2-1, what would be suitable s3 plugin for my es, as 6.4.3 version is not compatible with my es, please suggest.

---

## [Elasticsearch 8 Client is giving error The following method did not exist: ‘org.elasticsearch.client.RequestOptions$Builder org.elasticsearch.client.RequestOptions$Builder.removeHeader(java.lang.String)’](https://discuss.elastic.co/t/elasticsearch-8-client-is-giving-error-the-following-method-did-not-exist-org-elasticsearch-client-requestoptions-builder-org-elasticsearch-client-requestoptions-builder-removeheader-java-lang-string/335467)

<div class="topic-metadata">

**Author:** [@Skander\_Mansouri](https://discuss.elastic.co/u/Skander_Mansouri)\
**Replies:** 9\
**Last updated:** [June 8, 2023, 7:32am UTC](https://discuss.elastic.co/t/elasticsearch-8-client-is-giving-error-the-following-method-did-not-exist-org-elasticsearch-client-requestoptions-builder-org-elasticsearch-client-requestoptions-builder-removeheader-java-lang-string/335467 "2023-06-08T07:32:58Z")

</div>

I have copied exactly the same steps as the documentation elastic8 docs @Bean public ElasticsearchClient getElasticSearchClient(){ RestClient restClient = RestClient.builder( new HttpHost("", 9200)).build();…

---

## [Need Help with ProductCheckOnStartup](https://discuss.elastic.co/t/need-help-with-productcheckonstartup/335478)

<div class="topic-metadata">

**Author:** [@Priyam\_Mozumder](https://discuss.elastic.co/u/Priyam_Mozumder)\
**Replies:** 3\
**Last updated:** [June 8, 2023, 7:15am UTC](https://discuss.elastic.co/t/need-help-with-productcheckonstartup/335478 "2023-06-08T07:15:19Z")

</div>

19:38:24 INF\] Job Initialized \[19:38:25 FTL\] Error: Unsuccessful () low level call on GET: /\_cluster/health?pretty=true&error\_trace=true Audit trail of this API call: - \[1\] ProductCheckOnStartup: Took: 00:00:00.1116282…

---

## [Elasticsearch cannot restore existing snapshot. Blob not found](https://discuss.elastic.co/t/elasticsearch-cannot-restore-existing-snapshot-blob-not-found/335506)

<div class="topic-metadata">

**Author:** [@Naresh1919](https://discuss.elastic.co/u/Naresh1919)\
**Replies:** 0\
**Last updated:** [June 8, 2023, 6:18am UTC](https://discuss.elastic.co/t/elasticsearch-cannot-restore-existing-snapshot-blob-not-found/335506 "2023-06-08T06:18:15Z")

</div>

Elasticsearch version: 6.3.2 I was trying to restore an old snapshot (taken in January 2018) of a read only S3 repository. The necessary permissions in the IAM role for the instance are setup. Here is the repository de…

---

## [Failed to start Elasticsearch 7.11.2](https://discuss.elastic.co/t/failed-to-start-elasticsearch-7-11-2/334680)

<div class="topic-metadata">

**Author:** [@Nik1](https://discuss.elastic.co/u/Nik1)\
**Replies:** 35\
**Last updated:** [June 8, 2023, 5:43am UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch-7-11-2/334680 "2023-06-08T05:43:28Z")

</div>

Elasticsearch service is not starting on the ubuntu machine. Getting the below error. Anybody having idea? ~# systemctl start elasticsearch Job for elasticsearch.service failed because the control process exited with e…

---

## [Disable \_source field](https://discuss.elastic.co/t/disable-source-field/335434)

<div class="topic-metadata">

**Author:** [@Mhag](https://discuss.elastic.co/u/Mhag)\
**Replies:** 4\
**Last updated:** [June 8, 2023, 5:39am UTC](https://discuss.elastic.co/t/disable-source-field/335434 "2023-06-08T05:39:53Z")

</div>

Hello, I'm currently working on optimizing the size of an index. After reviewing the documentation and analyzing the field sizes, I found that a significant portion of the document size is attributed to the \_source fiel…

---

## [ILM policy for custom index](https://discuss.elastic.co/t/ilm-policy-for-custom-index/335271)

<div class="topic-metadata">

**Author:** [@lalchand\_rajak](https://discuss.elastic.co/u/lalchand_rajak)\
**Replies:** 6\
**Last updated:** [June 8, 2023, 5:06am UTC](https://discuss.elastic.co/t/ilm-policy-for-custom-index/335271 "2023-06-08T05:06:56Z")

</div>

Hello, I am unable to apply ILM policy to custom index coming from Openshift cluster log forwarding. As It create index with app-write and does not have any aliases. GET app-write/\_ilm/explain output { "indices": { …

---

## [Elasticsearch Circuit breaking exception](https://discuss.elastic.co/t/elasticsearch-circuit-breaking-exception/335305)

<div class="topic-metadata">

**Author:** [@RAM\_NATHAN](https://discuss.elastic.co/u/RAM_NATHAN)\
**Replies:** 2\
**Last updated:** [June 7, 2023, 10:57pm UTC](https://discuss.elastic.co/t/elasticsearch-circuit-breaking-exception/335305 "2023-06-07T22:57:00Z")

</div>

Hi Im using elasticsearch 7.10.2 single node. Im getting this Data too large, data for \[\<http\_request\>\] would be \[3985754120/3.7gb\], which is larger than the limit of \[3910375833/3.6gb\], real usage: \[3985754120/3.7gb\],…

---

## [Opensearch mappings](https://discuss.elastic.co/t/opensearch-mappings/335476)

<div class="topic-metadata">

**Author:** [@Kylychbek](https://discuss.elastic.co/u/Kylychbek)\
**Replies:** 2\
**Last updated:** [June 7, 2023, 8:46pm UTC](https://discuss.elastic.co/t/opensearch-mappings/335476 "2023-06-07T20:46:22Z")

</div>

why it is showing differend available fields eventhough there is same environment. From what depends my available fields

---

## [DSL Query does date math differently than KQL?](https://discuss.elastic.co/t/dsl-query-does-date-math-differently-than-kql/335468)

<div class="topic-metadata">

**Author:** [@pocketcolin](https://discuss.elastic.co/u/pocketcolin)\
**Replies:** 1\
**Last updated:** [June 7, 2023, 8:37pm UTC](https://discuss.elastic.co/t/dsl-query-does-date-math-differently-than-kql/335468 "2023-06-07T20:37:10Z")

</div>

I have a Kibana graph showing a number of records where a value is \>= the current date (specifically now/d). I just happened to be testing a similar query in dev tools when I discovered that the number shown in Kibana or…

---

## [Adding a field, view painless script error](https://discuss.elastic.co/t/adding-a-field-view-painless-script-error/333505)

<div class="topic-metadata">

**Author:** [@marscar](https://discuss.elastic.co/u/marscar)\
**Replies:** 1\
**Last updated:** [June 7, 2023, 7:45pm UTC](https://discuss.elastic.co/t/adding-a-field-view-painless-script-error/333505 "2023-06-07T19:45:47Z")

</div>

Hello and thanks for advance for the help. I am trying to create a new variable in elastic, but no matter what I put in the painless script editor, I get painless script invalid. I would try to debug, but I can't seem t…

---

## [I cannot search by telephone (part)](https://discuss.elastic.co/t/i-cannot-search-by-telephone-part/333353)

<div class="topic-metadata">

**Author:** [@mg85](https://discuss.elastic.co/u/mg85)\
**Replies:** 1\
**Last updated:** [June 7, 2023, 7:21pm UTC](https://discuss.elastic.co/t/i-cannot-search-by-telephone-part/333353 "2023-06-07T19:21:37Z")

</div>

Im trying to create an autocomplete, this is my index creation: curl -X PUT "localhost:9200/backoffice\_clients-com" -H 'Content-Type: application/json' -d' { "settings": { "analysis": { "analyzer": { …

---

## [QueryString vs multiple wildcards](https://discuss.elastic.co/t/querystring-vs-multiple-wildcards/335382)

<div class="topic-metadata">

**Author:** [@Ortiga\_Abdo](https://discuss.elastic.co/u/Ortiga_Abdo)\
**Replies:** 5\
**Last updated:** [June 7, 2023, 6:23pm UTC](https://discuss.elastic.co/t/querystring-vs-multiple-wildcards/335382 "2023-06-07T18:23:01Z")

</div>

I can't find any documentations that talks about queries and their performance/comparison I'm wondering which is better performance/faster multiple wildcard filter or a string\_query? "query": { "bool" : { "mu…

---

## [Failed to start elastic search service after upgrade from version 8.2 to 8.8](https://discuss.elastic.co/t/failed-to-start-elastic-search-service-after-upgrade-from-version-8-2-to-8-8/335081)

<div class="topic-metadata">

**Author:** [@JonathanDSSOUZA](https://discuss.elastic.co/u/JonathanDSSOUZA)\
**Replies:** 5\
**Last updated:** [June 7, 2023, 4:17pm UTC](https://discuss.elastic.co/t/failed-to-start-elastic-search-service-after-upgrade-from-version-8-2-to-8-8/335081 "2023-06-07T16:17:49Z")

</div>

Hello community, after updating a cluster that contains 3 master nodes and 3 data nodes (ingest), the master nodes work normally, but the ingest nodes do not start the elasticsearch service, activating the DEBUG mode, re…

---

## [Https://discuss.elastic.co/t/possible-to-highlight-inner-hits-in-percolate-query/91926](https://discuss.elastic.co/t/https-discuss-elastic-co-t-possible-to-highlight-inner-hits-in-percolate-query-91926/335261)

<div class="topic-metadata">

**Author:** [@marufrahman](https://discuss.elastic.co/u/marufrahman)\
**Replies:** 4\
**Last updated:** [June 7, 2023, 3:35pm UTC](https://discuss.elastic.co/t/https-discuss-elastic-co-t-possible-to-highlight-inner-hits-in-percolate-query-91926/335261 "2023-06-07T15:35:48Z")

</div>

Is this currently supported?

---

## [How to set \`index.codec: best\_compression\` as the default for all future indices?](https://discuss.elastic.co/t/how-to-set-index-codec-best-compression-as-the-default-for-all-future-indices/335383)

<div class="topic-metadata">

**Author:** [@jerrac](https://discuss.elastic.co/u/jerrac)\
**Replies:** 2\
**Last updated:** [June 7, 2023, 3:22pm UTC](https://discuss.elastic.co/t/how-to-set-index-codec-best-compression-as-the-default-for-all-future-indices/335383 "2023-06-07T15:22:32Z")

</div>

Pretty much what the subject says. How to I turn on best\_compression as the default for all new indices? The docs explain how to do it per index. But I haven't found anything on setting it as the default. Nor has googl…

---

## [Problems creating a ILM correctly](https://discuss.elastic.co/t/problems-creating-a-ilm-correctly/335365)

<div class="topic-metadata">

**Author:** [@blacar](https://discuss.elastic.co/u/blacar)\
**Replies:** 1\
**Last updated:** [June 7, 2023, 2:50pm UTC](https://discuss.elastic.co/t/problems-creating-a-ilm-correctly/335365 "2023-06-07T14:50:39Z")

</div>

I am having problems creating an ILM that fits my needs. I have it done in another cluster but even trying to replicate it piece by piece ends in errors. Context: This is on Elastic Cloud using latest ES version I wi…

---

## [Special characters handling](https://discuss.elastic.co/t/special-characters-handling/335294)

<div class="topic-metadata">

**Author:** [@aetius](https://discuss.elastic.co/u/aetius)\
**Replies:** 1\
**Last updated:** [June 7, 2023, 12:01pm UTC](https://discuss.elastic.co/t/special-characters-handling/335294 "2023-06-07T12:01:53Z")

</div>

Hi Folks I was fixing a bug which came through the upgrade from Spring 2.5 to Spring 3.0. Now before in Spring 2.5 we had custom method from a repo that extended the ElasticsearchRepository interface, and in the method…

---

## [Multiple filter for query not working as expected](https://discuss.elastic.co/t/multiple-filter-for-query-not-working-as-expected/335388)

<div class="topic-metadata">

**Author:** [@Atul\_Chadha](https://discuss.elastic.co/u/Atul_Chadha)\
**Replies:** 3\
**Last updated:** [June 7, 2023, 9:11am UTC](https://discuss.elastic.co/t/multiple-filter-for-query-not-working-as-expected/335388 "2023-06-07T09:11:41Z")

</div>

We are using elasticsearch as backend for our Wazuh cluster, i am trying to filter our results which contain values from "filter 01" and exclude results from "filter 02" however it looks its not working and showing resu…

---

## [How to run multiple geo\_distance filter to get result for each filter separately?](https://discuss.elastic.co/t/how-to-run-multiple-geo-distance-filter-to-get-result-for-each-filter-separately/335286)

<div class="topic-metadata">

**Author:** [@maulik\_trapasiya](https://discuss.elastic.co/u/maulik_trapasiya)\
**Replies:** 3\
**Last updated:** [June 7, 2023, 7:20am UTC](https://discuss.elastic.co/t/how-to-run-multiple-geo-distance-filter-to-get-result-for-each-filter-separately/335286 "2023-06-07T07:20:13Z")

</div>

I need result documents based on geo\_distance query for points A(lat=3,long=101) and B(lat=5,long=102) separately. one result docs I need corresponding to filter A(lat=3,long=101) and other result set I need correspondin…

---

## [How to stop index from getting throttled?](https://discuss.elastic.co/t/how-to-stop-index-from-getting-throttled/334923)

<div class="topic-metadata">

**Author:** [@hjazz6](https://discuss.elastic.co/u/hjazz6)\
**Replies:** 18\
**Last updated:** [June 7, 2023, 3:26am UTC](https://discuss.elastic.co/t/how-to-stop-index-from-getting-throttled/334923 "2023-06-07T03:26:32Z")

</div>

Hi, I am ingesting netflow data into my ES 8.3.3 node at a very high rate. As I increase the ingest to ES where the index rate is about 30+K/s, I started to get the messages below: \[INFO\] \[o.e.i.e.I.EngineMergeSchedule…

---

## [Not able to to overwrite elasticsearch.keystore in elasticsearch 8.8.0](https://discuss.elastic.co/t/not-able-to-to-overwrite-elasticsearch-keystore-in-elasticsearch-8-8-0/335289)

<div class="topic-metadata">

**Author:** [@prathibha](https://discuss.elastic.co/u/prathibha)\
**Replies:** 0\
**Last updated:** [June 6, 2023, 7:12am UTC](https://discuss.elastic.co/t/not-able-to-to-overwrite-elasticsearch-keystore-in-elasticsearch-8-8-0/335289 "2023-06-06T07:12:23Z")

</div>

Hello Everyone, I have a single node elastic running on a centos vm . This elastic is running as a docker container and I am trying to upgrade from 7.16-\> 7.17-\> 8.8.0. I have multile configuration files mounted on to c…

---

## [Buffer Options does not contain a definition for ConcurrentConsumers](https://discuss.elastic.co/t/buffer-options-does-not-contain-a-definition-for-concurrentconsumers/335371)

<div class="topic-metadata">

**Author:** [@Marcos\_Ivan\_Robles\_H](https://discuss.elastic.co/u/Marcos_Ivan_Robles_H)\
**Replies:** 0\
**Last updated:** [June 6, 2023, 5:11pm UTC](https://discuss.elastic.co/t/buffer-options-does-not-contain-a-definition-for-concurrentconsumers/335371 "2023-06-06T17:11:23Z")

</div>

Hello I am trying to follow the example in the following nuget package: Elastic.Serilog.Sinks I got the following error: Buffer Options does not contain a definition for ConcurrentConsumers this is the code in progra…

[Previous page](https://discuss.elastic.co/c/elastic-stack/elasticsearch/6.md?page=246)

[Next page](https://discuss.elastic.co/c/elastic-stack/elasticsearch/6.md?page=248)
