# Elasticsearch

**URL:** https://discuss.elastic.co/c/elastic-stack/elasticsearch/6.md?page=354

[Latest](https://discuss.elastic.co/latest.md) · [Categories](https://discuss.elastic.co/categories.md) · [Tags](https://discuss.elastic.co/tags.md)

**Page:** 355

---

## [Elastic score decay if field tokens are in another field](https://discuss.elastic.co/t/elastic-score-decay-if-field-tokens-are-in-another-field/316037)

<div class="topic-metadata">

**Author:** [@Sergey\_V](https://discuss.elastic.co/u/Sergey_V)\
**Replies:** 4\
**Last updated:** [October 25, 2022, 7:38am UTC](https://discuss.elastic.co/t/elastic-score-decay-if-field-tokens-are-in-another-field/316037 "2022-10-25T07:38:12Z")

</div>

Hi! Me need decrease score of document if in "field1" has tokens of "field2". Tell me how can this be done?

---

## [Visio stencils](https://discuss.elastic.co/t/visio-stencils/317368)

<div class="topic-metadata">

**Author:** [@bering](https://discuss.elastic.co/u/bering)\
**Replies:** 0\
**Last updated:** [October 25, 2022, 6:20am UTC](https://discuss.elastic.co/t/visio-stencils/317368 "2022-10-25T06:20:09Z")

</div>

Some time ago I was able to download logos and other Elasic figures that could be imported into Visio from this link Trademarks found on Elastic.co | Elastic but that now links to some trademark page. Does anyone know w…

---

## [How to get nested field value equal to keyword field value](https://discuss.elastic.co/t/how-to-get-nested-field-value-equal-to-keyword-field-value/317360)

<div class="topic-metadata">

**Author:** [@casterQ](https://discuss.elastic.co/u/casterQ)\
**Replies:** 0\
**Last updated:** [October 25, 2022, 2:58am UTC](https://discuss.elastic.co/t/how-to-get-nested-field-value-equal-to-keyword-field-value/317360 "2022-10-25T02:58:31Z")

</div>

can i get b value in nested script query? PUT test { "mappings": { "properties": { "b": { "type": "keyword" }, "nested": { "type": "nested", "properties": { "a":…

---

## [Using Prometheus remote\_write to send metrics to Elastic cloud](https://discuss.elastic.co/t/using-prometheus-remote-write-to-send-metrics-to-elastic-cloud/317014)

<div class="topic-metadata">

**Author:** [@Maduranga](https://discuss.elastic.co/u/Maduranga)\
**Replies:** 6\
**Last updated:** [October 25, 2022, 1:48am UTC](https://discuss.elastic.co/t/using-prometheus-remote-write-to-send-metrics-to-elastic-cloud/317014 "2022-10-25T01:48:41Z")

</div>

Hello, I have a Prometheus server which is sending currently sending metrics to Grafana using remote\_write. I would like to use our Elastic cloud Kibana to get the Prometheus metrics. Would like advice on how to authe…

---

## [Solving version\_conflict\_engine\_exception on update](https://discuss.elastic.co/t/solving-version-conflict-engine-exception-on-update/317337)

<div class="topic-metadata">

**Author:** [@OranShuster](https://discuss.elastic.co/u/OranShuster)\
**Replies:** 9\
**Last updated:** [October 24, 2022, 8:31pm UTC](https://discuss.elastic.co/t/solving-version-conflict-engine-exception-on-update/317337 "2022-10-24T20:31:46Z")

</div>

Preface - Cluster is running version 6.8 and we are doing a mix of search/create/update using the NodeJS Operations can access the same document in quick succession/concurrently since its based off events coming from k…

---

## [Can I use discovery-ec2 plugin for finding data node?](https://discuss.elastic.co/t/can-i-use-discovery-ec2-plugin-for-finding-data-node/317331)

<div class="topic-metadata">

**Author:** [@qksjdhi1212](https://discuss.elastic.co/u/qksjdhi1212)\
**Replies:** 1\
**Last updated:** [October 24, 2022, 8:24pm UTC](https://discuss.elastic.co/t/can-i-use-discovery-ec2-plugin-for-finding-data-node/317331 "2022-10-24T20:24:15Z")

</div>

First I wanted to use discovery-ec2 plugin to find nodes(including non-master-eligible nodes) easily in cluster but I've just noticed that discovery-ec2 plugin is only for finding master-eligible nodes on ES docs The d…

---

## [Failed to start Elasticsearch](https://discuss.elastic.co/t/failed-to-start-elasticsearch/317304)

<div class="topic-metadata">

**Author:** [@nicolas2603](https://discuss.elastic.co/u/nicolas2603)\
**Replies:** 9\
**Last updated:** [October 24, 2022, 3:12pm UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch/317304 "2022-10-24T15:12:52Z")

</div>

Hello. I'm having a problem with Elasticsearch, and I don't know much about Linux. It doesn't help! To run a mapping application (GeoNetwork), I need an instance of Elasticsearch. So I downloaded version 8.4.3 in tar.g…

---

## [EQL correlation rule is timing out...sometimes](https://discuss.elastic.co/t/eql-correlation-rule-is-timing-out-sometimes/316641)

<div class="topic-metadata">

**Author:** [@gweiss76](https://discuss.elastic.co/u/gweiss76)\
**Replies:** 0\
**Last updated:** [October 14, 2022, 1:21pm UTC](https://discuss.elastic.co/t/eql-correlation-rule-is-timing-out-sometimes/316641 "2022-10-14T13:21:54Z")

</div>

Hi fellow log analysts We have a simple EQL correlation rule which we use to identify password changes on critical accounts (eventlog based). It looks like this: \[ any where event.code == "4624" \] by winlog.event\_data.…

---

## [Will PCRE regular expressions be supported in the future?](https://discuss.elastic.co/t/will-pcre-regular-expressions-be-supported-in-the-future/317322)

<div class="topic-metadata">

**Author:** [@shengwei.xu](https://discuss.elastic.co/u/shengwei.xu)\
**Replies:** 0\
**Last updated:** [October 24, 2022, 2:06pm UTC](https://discuss.elastic.co/t/will-pcre-regular-expressions-be-supported-in-the-future/317322 "2022-10-24T14:06:50Z")

</div>

Will PCRE regular expressions be supported in the future? I ran into a scenario that non-tech users only use PCRE regular expressions that most languages use, it's time-consuming for non-tech users to learn how to use el…

---

## [How to find the percentage for any query success?](https://discuss.elastic.co/t/how-to-find-the-percentage-for-any-query-success/317194)

<div class="topic-metadata">

**Author:** [@HemabhRavee](https://discuss.elastic.co/u/HemabhRavee)\
**Replies:** 1\
**Last updated:** [October 24, 2022, 12:38pm UTC](https://discuss.elastic.co/t/how-to-find-the-percentage-for-any-query-success/317194 "2022-10-24T12:38:21Z")

</div>

I want to write an aggregation which returns the percentage of hits for any query Let say I have a query Q which returns me 20 docs out of the 100 present in the target index. Then that aggregation should return me 20%…

---

## [Filter vs query](https://discuss.elastic.co/t/filter-vs-query/317297)

<div class="topic-metadata">

**Author:** [@Ismet](https://discuss.elastic.co/u/Ismet)\
**Replies:** 1\
**Last updated:** [October 24, 2022, 12:20pm UTC](https://discuss.elastic.co/t/filter-vs-query/317297 "2022-10-24T12:20:52Z")

</div>

Hi, can we use only filter without query and can we use query string with wildcard in filter. What are benefits of using only filter and using query string + filter? There is example of using only filter. Is this code o…

---

## [Add index\_options option to all text fields with dynamic templates](https://discuss.elastic.co/t/add-index-options-option-to-all-text-fields-with-dynamic-templates/317303)

<div class="topic-metadata">

**Author:** [@frank\_esg](https://discuss.elastic.co/u/frank_esg)\
**Replies:** 0\
**Last updated:** [October 24, 2022, 9:21am UTC](https://discuss.elastic.co/t/add-index-options-option-to-all-text-fields-with-dynamic-templates/317303 "2022-10-24T09:21:55Z")

</div>

Hello, we´re using component templates to define field mappings based on ECS for all of our indices. In the past we had some issues with search highlighting in Kibana , when text fields are very big. Now i would like t…

---

## [Indexes created automatically by the system](https://discuss.elastic.co/t/indexes-created-automatically-by-the-system/317125)

<div class="topic-metadata">

**Author:** [@dpelaezb](https://discuss.elastic.co/u/dpelaezb)\
**Replies:** 4\
**Last updated:** [October 24, 2022, 7:47am UTC](https://discuss.elastic.co/t/indexes-created-automatically-by-the-system/317125 "2022-10-24T07:47:40Z")

</div>

Hello everyone, We have an infrastructure that consists of several Filebeats that send the traces to a Logstash located on another machine where there is also a Metricbeat to plot Logstash. We have detected that a seri…

---

## [Impact of CVE-2022-42889 on Elastic stack](https://discuss.elastic.co/t/impact-of-cve-2022-42889-on-elastic-stack/316858)

<div class="topic-metadata">

**Author:** [@jgimenez](https://discuss.elastic.co/u/jgimenez)\
**Replies:** 4\
**Last updated:** [October 24, 2022, 7:28am UTC](https://discuss.elastic.co/t/impact-of-cve-2022-42889-on-elastic-stack/316858 "2022-10-24T07:28:56Z")

</div>

Hi there, is the Elastic software affected by CVE-2022-42889, and if so, what are the actions recommended? Thanks.

---

## [.ds-logstash shards remain](https://discuss.elastic.co/t/ds-logstash-shards-remain/316734)

<div class="topic-metadata">

**Author:** [@waleedkh](https://discuss.elastic.co/u/waleedkh)\
**Replies:** 3\
**Last updated:** [October 24, 2022, 6:56am UTC](https://discuss.elastic.co/t/ds-logstash-shards-remain/316734 "2022-10-24T06:56:11Z")

</div>

I have an issue in that I have 2200 of these .ds-logstash-DATE indices that are not being cleaned out as part of the ILM policy. They are from a data stream. Below is the linked ILM policy PUT \_ilm/policy/logstash-lif…

---

## [How to push json into elasticsearch](https://discuss.elastic.co/t/how-to-push-json-into-elasticsearch/317275)

<div class="topic-metadata">

**Author:** [@ZahraZare](https://discuss.elastic.co/u/ZahraZare)\
**Replies:** 11\
**Last updated:** [October 24, 2022, 5:41am UTC](https://discuss.elastic.co/t/how-to-push-json-into-elasticsearch/317275 "2022-10-24T05:41:12Z")

</div>

I want to push the following Json data using Python in elasticsearch, I used the following code but there is no data in the index. json data : \[ "break", false, -1314177328.9280925, \[ -107585784.0005331, 11732320…

---

## [I can't get Elastic and Kibana to work with real certificates](https://discuss.elastic.co/t/i-cant-get-elastic-and-kibana-to-work-with-real-certificates/317282)

<div class="topic-metadata">

**Author:** [@abkrim](https://discuss.elastic.co/u/abkrim)\
**Replies:** 5\
**Last updated:** [October 24, 2022, 5:23am UTC](https://discuss.elastic.co/t/i-cant-get-elastic-and-kibana-to-work-with-real-certificates/317282 "2022-10-24T05:23:35Z")

</div>

I can't get Elastic and Kibana to work with real certificates from either Let's encrypt or Comodo. I've thought about it a thousand times, but no matter how much I read and reread, I can't find the error of something as…

---

## [Can I know the basic specifications for master, ingest, coordinate node?](https://discuss.elastic.co/t/can-i-know-the-basic-specifications-for-master-ingest-coordinate-node/317289)

<div class="topic-metadata">

**Author:** [@dms6978](https://discuss.elastic.co/u/dms6978)\
**Replies:** 2\
**Last updated:** [October 24, 2022, 2:00am UTC](https://discuss.elastic.co/t/can-i-know-the-basic-specifications-for-master-ingest-coordinate-node/317289 "2022-10-24T02:00:36Z")

</div>

Can I know the basic specifications for master, ingest, coordinate node? CPU, memory, heapsize.....

---

## [Can't Automatically Start Elasticsearch Service After Upgrade to 8.4.3](https://discuss.elastic.co/t/cant-automatically-start-elasticsearch-service-after-upgrade-to-8-4-3/317262)

<div class="topic-metadata">

**Author:** [@krmathieu](https://discuss.elastic.co/u/krmathieu)\
**Replies:** 1\
**Last updated:** [October 24, 2022, 1:25am UTC](https://discuss.elastic.co/t/cant-automatically-start-elasticsearch-service-after-upgrade-to-8-4-3/317262 "2022-10-24T01:25:40Z")

</div>

I can't get the Elasticsearch service to start using the Windows service on a Windows 10 machine after upgrading to 8.4.3.. I successfully used elasticsearch-service.bat to install the service and see it listed as an ava…

---

## [Can hacker use search api endpoint to update document or delete index?](https://discuss.elastic.co/t/can-hacker-use-search-api-endpoint-to-update-document-or-delete-index/317027)

<div class="topic-metadata">

**Author:** [@jbond](https://discuss.elastic.co/u/jbond)\
**Replies:** 6\
**Last updated:** [October 23, 2022, 11:52pm UTC](https://discuss.elastic.co/t/can-hacker-use-search-api-endpoint-to-update-document-or-delete-index/317027 "2022-10-23T23:52:58Z")

</div>

My company use free version of Elasticsearch software so no security on it. Our Elasticsearch server is running on internal network and internet user cannot access to it. We have a public app need to call Elasticsearch A…

---

## [Delete Duplicate id documents in Search Result](https://discuss.elastic.co/t/delete-duplicate-id-documents-in-search-result/317190)

<div class="topic-metadata">

**Author:** [@manupoti](https://discuss.elastic.co/u/manupoti)\
**Replies:** 1\
**Last updated:** [October 23, 2022, 11:14pm UTC](https://discuss.elastic.co/t/delete-duplicate-id-documents-in-search-result/317190 "2022-10-23T23:14:11Z")

</div>

1.Created two indexes and with same alias name 2.Inseart document with \_id in "doc1" index with alias 3.Insert same document with same \_id in "doc2" with alias 4.Search with \_id and Search result should return only on…

---

## [Throw error when doc id already exists in index with NEST](https://discuss.elastic.co/t/throw-error-when-doc-id-already-exists-in-index-with-nest/317283)

<div class="topic-metadata">

**Author:** [@johanwallenborg](https://discuss.elastic.co/u/johanwallenborg)\
**Replies:** 2\
**Last updated:** [October 23, 2022, 7:29pm UTC](https://discuss.elastic.co/t/throw-error-when-doc-id-already-exists-in-index-with-nest/317283 "2022-10-23T19:29:37Z")

</div>

Hello, I'm using BulkAll-method when indexing documents. Everything works fine but I wonder if there's a way too report back if an document with same document id already exists in index. Is there any?

---

## [Data replication across data centers](https://discuss.elastic.co/t/data-replication-across-data-centers/316740)

<div class="topic-metadata">

**Author:** [@harijld](https://discuss.elastic.co/u/harijld)\
**Replies:** 2\
**Last updated:** [October 23, 2022, 6:14pm UTC](https://discuss.elastic.co/t/data-replication-across-data-centers/316740 "2022-10-23T18:14:21Z")

</div>

Dear Team, Regarding data replication between data centers, I have a quick question. To replicate the data between data centers, we have several options. cross cluster replication taking snapshot from prod and moving…

---

## [ERROR: Failed to determine the health of the cluster when initial password setting](https://discuss.elastic.co/t/error-failed-to-determine-the-health-of-the-cluster-when-initial-password-setting/317252)

<div class="topic-metadata">

**Author:** [@tmdgk490255](https://discuss.elastic.co/u/tmdgk490255)\
**Replies:** 5\
**Last updated:** [October 23, 2022, 3:31pm UTC](https://discuss.elastic.co/t/error-failed-to-determine-the-health-of-the-cluster-when-initial-password-setting/317252 "2022-10-23T15:31:45Z")

</div>

I tried to set up initial password with following command and got this error message $ ./elasticsearch-reset-password -u elasticsearch ERROR: Failed to determine the health of the cluster. Here is my elasticsearch.ym…

---

## [Search.max\_async\_search\_response\_size](https://discuss.elastic.co/t/search-max-async-search-response-size/317202)

<div class="topic-metadata">

**Author:** [@Roger\_Huang](https://discuss.elastic.co/u/Roger_Huang)\
**Replies:** 7\
**Last updated:** [October 23, 2022, 5:17am UTC](https://discuss.elastic.co/t/search-max-async-search-response-size/317202 "2022-10-23T05:17:45Z")

</div>

Hi all, I am new to Elasticsearch stack. Any suggestions or help is greatly appreciated please. I encountered this error after doing a http\_poller in Logstash. {"@timestamp":"2022-10-21T13:17:56.029Z", "log.level":"ERR…

---

## [Module system syslog logs of Filebeat and auditbeat](https://discuss.elastic.co/t/module-system-syslog-logs-of-filebeat-and-auditbeat/317250)

<div class="topic-metadata">

**Author:** [@morad\_della3](https://discuss.elastic.co/u/morad_della3)\
**Replies:** 1\
**Last updated:** [October 22, 2022, 4:29pm UTC](https://discuss.elastic.co/t/module-system-syslog-logs-of-filebeat-and-auditbeat/317250 "2022-10-22T16:29:56Z")

</div>

Difference btween module system syslog logs of Filebeat and auditbeat the two collect the linux logs ?

---

## [Finding a geo point inside a geoshape rectangle](https://discuss.elastic.co/t/finding-a-geo-point-inside-a-geoshape-rectangle/317160)

<div class="topic-metadata">

**Author:** [@antonpious](https://discuss.elastic.co/u/antonpious)\
**Replies:** 12\
**Last updated:** [October 22, 2022, 2:40pm UTC](https://discuss.elastic.co/t/finding-a-geo-point-inside-a-geoshape-rectangle/317160 "2022-10-22T14:40:39Z")

</div>

All the documentation seems to point to either having geo points and then having a bounding box to select these geo points. Is the reverse feature possible in Elastic Search? The only closest I could find in this form …

---

## [Proposed way to use Elasticsearch Java API Client to generate requests](https://discuss.elastic.co/t/proposed-way-to-use-elasticsearch-java-api-client-to-generate-requests/317239)

<div class="topic-metadata">

**Author:** [@Michael\_Gattinger](https://discuss.elastic.co/u/Michael_Gattinger)\
**Replies:** 0\
**Last updated:** [October 22, 2022, 5:37am UTC](https://discuss.elastic.co/t/proposed-way-to-use-elasticsearch-java-api-client-to-generate-requests/317239 "2022-10-22T05:37:00Z")

</div>

Hello, as i found for my self there are a bunch of ways how to use Elasticsearch Java API Client to generate requests. write JSON (in file or programm code) and push it over the low level Rest Client instead of the ES…

---

## [Creation/error of a x.509 certificate](https://discuss.elastic.co/t/creation-error-of-a-x-509-certificate/317201)

<div class="topic-metadata">

**Author:** [@EExisT](https://discuss.elastic.co/u/EExisT)\
**Replies:** 11\
**Last updated:** [October 22, 2022, 1:35pm UTC](https://discuss.elastic.co/t/creation-error-of-a-x-509-certificate/317201 "2022-10-22T13:35:43Z")

</div>

Hello, I'm trying to produce x.509 crt and key for 4 instances that I have saved in a .yml file(Elastic, Kibana, Winlogbeat and Metricbeat) I was trying to ro run the command /usr/share/elasticsearch/bin/elasticsearch-…

---

## [Best practice for large indexes on docker](https://discuss.elastic.co/t/best-practice-for-large-indexes-on-docker/317235)

<div class="topic-metadata">

**Author:** [@Ostr1969](https://discuss.elastic.co/u/Ostr1969)\
**Replies:** 1\
**Last updated:** [October 21, 2022, 8:40pm UTC](https://discuss.elastic.co/t/best-practice-for-large-indexes-on-docker/317235 "2022-10-21T20:40:00Z")

</div>

how can I specify the storage location for an index?. The docker is saves all the container at the /var/lib/docker, but I don't have enough space there.

[Previous page](https://discuss.elastic.co/c/elastic-stack/elasticsearch/6.md?page=353)

[Next page](https://discuss.elastic.co/c/elastic-stack/elasticsearch/6.md?page=355)
