# Elasticsearch

**URL:** https://discuss.elastic.co/c/elastic-stack/elasticsearch/6.md?page=357

[Latest](https://discuss.elastic.co/latest.md) · [Categories](https://discuss.elastic.co/categories.md) · [Tags](https://discuss.elastic.co/tags.md)

**Page:** 358

---

## [Convert java query output in json format](https://discuss.elastic.co/t/convert-java-query-output-in-json-format/316893)

<div class="topic-metadata">

**Author:** [@Shubh](https://discuss.elastic.co/u/Shubh)\
**Replies:** 0\
**Last updated:** [October 18, 2022, 1:06pm UTC](https://discuss.elastic.co/t/convert-java-query-output-in-json-format/316893 "2022-10-18T13:06:31Z")

</div>

Hi all, can someone help get my java query output in json format im just printing it in line and now i want to upgrade my code output tried multiple ways but no luck. Below is my code elasticsearch java api code. try…

---

## [Standard Memory recommendation for each POD having 3 node cluster running on Elasticsearch 7.17.1](https://discuss.elastic.co/t/standard-memory-recommendation-for-each-pod-having-3-node-cluster-running-on-elasticsearch-7-17-1/316854)

<div class="topic-metadata">

**Author:** [@bikas](https://discuss.elastic.co/u/bikas)\
**Replies:** 2\
**Last updated:** [October 18, 2022, 10:24am UTC](https://discuss.elastic.co/t/standard-memory-recommendation-for-each-pod-having-3-node-cluster-running-on-elasticsearch-7-17-1/316854 "2022-10-18T10:24:08Z")

</div>

Hello, I would like to know the recommended Memory needs to be allocated to Elasticsearch 7.17.1 POD. Currently we have 3 node cluster deployed in GKE. Each POD is being allocated to 4GB RAM and 50% of its memory to Hea…

---

## [High cpu usage during search](https://discuss.elastic.co/t/high-cpu-usage-during-search/316795)

<div class="topic-metadata">

**Author:** [@faisal.k](https://discuss.elastic.co/u/faisal.k)\
**Replies:** 9\
**Last updated:** [October 18, 2022, 9:52am UTC](https://discuss.elastic.co/t/high-cpu-usage-during-search/316795 "2022-10-18T09:52:18Z")

</div>

Hello, I have tried to read through most of the topics and tried with the suggestions, nothing has helped so far. We are running an elasticsearch cluster (v7.16.1) with 2 nodes (4 CPUs, heap assigned as 16GB - physical…

---

## [Unhide System Indices](https://discuss.elastic.co/t/unhide-system-indices/316736)

<div class="topic-metadata">

**Author:** [@Ankita\_Pachauri](https://discuss.elastic.co/u/Ankita_Pachauri)\
**Replies:** 7\
**Last updated:** [October 18, 2022, 8:04am UTC](https://discuss.elastic.co/t/unhide-system-indices/316736 "2022-10-18T08:04:32Z")

</div>

Hi Team, I am using searchguard for alerting purpose. The indices of searchguard are stored in elasticsearch with .signals naming convention. I need to get the alert ID for the alerts. However, i cannot write a search q…

---

## [Domain redirection is not happening for workplace search endpoint](https://discuss.elastic.co/t/domain-redirection-is-not-happening-for-workplace-search-endpoint/316852)

<div class="topic-metadata">

**Author:** [@Elastic\_User3](https://discuss.elastic.co/u/Elastic_User3)\
**Replies:** 0\
**Last updated:** [October 18, 2022, 7:51am UTC](https://discuss.elastic.co/t/domain-redirection-is-not-happening-for-workplace-search-endpoint/316852 "2022-10-18T07:51:37Z")

</div>

we tried to change the domain and redirect to searchcapillary.com but its not happening. https://searchabc.in we are trying to point below mentioned endpoint to above mentioned end point, but once we done with that. we…

---

## [Add a new field to the .ml-anomalies-shared index](https://discuss.elastic.co/t/add-a-new-field-to-the-ml-anomalies-shared-index/316847)

<div class="topic-metadata">

**Author:** [@irivas95](https://discuss.elastic.co/u/irivas95)\
**Replies:** 0\
**Last updated:** [October 18, 2022, 6:58am UTC](https://discuss.elastic.co/t/add-a-new-field-to-the-ml-anomalies-shared-index/316847 "2022-10-18T06:58:26Z")

</div>

Hi, I need to add a new field, "anomaly level" to the .ml-anomalies-shared index to new data and already indexed data. The field would have a different value based on the value of the record score field, for example: i…

---

## [Time Zone issue with Range Query](https://discuss.elastic.co/t/time-zone-issue-with-range-query/316764)

<div class="topic-metadata">

**Author:** [@vipin.meshram13098](https://discuss.elastic.co/u/vipin.meshram13098)\
**Replies:** 0\
**Last updated:** [October 17, 2022, 10:53am UTC](https://discuss.elastic.co/t/time-zone-issue-with-range-query/316764 "2022-10-17T10:53:12Z")

</div>

Hello, I am facing one strange issue with range query "time\_zone" parameter. I have the Elasticsearch documents stored in the server of America/Chicago timezone. Basically, I am trying to fetch records from "12:00 AM …

---

## [When starting up a ELK Cluster, one Node fails with Java lang out of memory error](https://discuss.elastic.co/t/when-starting-up-a-elk-cluster-one-node-fails-with-java-lang-out-of-memory-error/316693)

<div class="topic-metadata">

**Author:** [@AKAM14](https://discuss.elastic.co/u/AKAM14)\
**Replies:** 8\
**Last updated:** [October 18, 2022, 2:46am UTC](https://discuss.elastic.co/t/when-starting-up-a-elk-cluster-one-node-fails-with-java-lang-out-of-memory-error/316693 "2022-10-18T02:46:34Z")

</div>

I have a 3 node ELK Cluster - with two logstash and 1 kibana server . When i start my Elk cluster it is giving an error in two nodes and fails. it is all realted to Jvm memory error. I have attached the error screenshot. …

---

## [WebNMS security vulnerability](https://discuss.elastic.co/t/webnms-security-vulnerability/316766)

<div class="topic-metadata">

**Author:** [@aligege123](https://discuss.elastic.co/u/aligege123)\
**Replies:** 3\
**Last updated:** [October 18, 2022, 1:19am UTC](https://discuss.elastic.co/t/webnms-security-vulnerability/316766 "2022-10-18T01:19:18Z")

</div>

Is elasticsearch related with ZOHO webNMS ? I recently meet a vulnerability report from es http server port 9200 about webNMS. The vulnerability detail: CVE - CVE-2016-6600 (mitre.org) My elasticsearch version is 7.6.1.…

---

## [Combine value for a common field from search results and remove one of the result](https://discuss.elastic.co/t/combine-value-for-a-common-field-from-search-results-and-remove-one-of-the-result/316831)

<div class="topic-metadata">

**Author:** [@Calvin\_Feng](https://discuss.elastic.co/u/Calvin_Feng)\
**Replies:** 2\
**Last updated:** [October 18, 2022, 12:46am UTC](https://discuss.elastic.co/t/combine-value-for-a-common-field-from-search-results-and-remove-one-of-the-result/316831 "2022-10-18T00:46:49Z")

</div>

Hi dear, We have a some documents saved in Elasticsearch with a common value, like group\_id. When we do the search, we'd like to combine the value of specific field if the documents are having the same group\_id. Then we…

---

## [Eland - exactly which of the pandas are supported?](https://discuss.elastic.co/t/eland-exactly-which-of-the-pandas-are-supported/316829)

<div class="topic-metadata">

**Author:** [@sachinsdesai](https://discuss.elastic.co/u/sachinsdesai)\
**Replies:** 0\
**Last updated:** [October 17, 2022, 10:10pm UTC](https://discuss.elastic.co/t/eland-exactly-which-of-the-pandas-are-supported/316829 "2022-10-17T22:10:38Z")

</div>

I am looking at Supported Pandas APIs — eland 8.3.0 documentation and several of the APIs are not supported. An an example, sort\_values is not supported, but the documentation says it is. Where can I get info about exact…

---

## [Docker Image not uploading to ecr from jenkins](https://discuss.elastic.co/t/docker-image-not-uploading-to-ecr-from-jenkins/316616)

<div class="topic-metadata">

**Author:** [@veera\_ravala](https://discuss.elastic.co/u/veera_ravala)\
**Replies:** 1\
**Last updated:** [October 17, 2022, 11:54pm UTC](https://discuss.elastic.co/t/docker-image-not-uploading-to-ecr-from-jenkins/316616 "2022-10-17T23:54:40Z")

</div>

=I created a CI/CD pipline which builds a docker image and pushes to docker image to amazon ecr. The docker image build perfectly but does not upload to ecr After building the image it keeps retrying to upload the imag…

---

## [Elasticsearch cross cluster data migration approach](https://discuss.elastic.co/t/elasticsearch-cross-cluster-data-migration-approach/316692)

<div class="topic-metadata">

**Author:** [@Sarthak\_Agarwal](https://discuss.elastic.co/u/Sarthak_Agarwal)\
**Replies:** 1\
**Last updated:** [October 17, 2022, 11:50pm UTC](https://discuss.elastic.co/t/elasticsearch-cross-cluster-data-migration-approach/316692 "2022-10-17T23:50:19Z")

</div>

Hi, We have an existing cluster running ES 5.6.7 version. We want to create a new cluster running ES 7.17.5 version and migrate all data to this cluster. We have close to 300 Million documents present on the existing c…

---

## [LDAP Group members can't login in elasticsearch](https://discuss.elastic.co/t/ldap-group-members-cant-login-in-elasticsearch/316446)

<div class="topic-metadata">

**Author:** [@Tarah](https://discuss.elastic.co/u/Tarah)\
**Replies:** 7\
**Last updated:** [October 17, 2022, 11:39pm UTC](https://discuss.elastic.co/t/ldap-group-members-cant-login-in-elasticsearch/316446 "2022-10-17T23:39:41Z")

</div>

Hi Elastic Team, I think I'm missing something here. E456 uid can't login to elasticsearch even if it is a member of ou=people,ou=ec,o=world. But when using E123 uid, it is successful. E456 and E123 belongs to the same …

---

## [EQL with time filter](https://discuss.elastic.co/t/eql-with-time-filter/316781)

<div class="topic-metadata">

**Author:** [@kmz161](https://discuss.elastic.co/u/kmz161)\
**Replies:** 0\
**Last updated:** [October 17, 2022, 12:24pm UTC](https://discuss.elastic.co/t/eql-with-time-filter/316781 "2022-10-17T12:24:31Z")

</div>

Hello! I use rule for checking Sysmon logs '''any where event.code == 1 and process.executable: "C:\\Windows\\System32\\sc.exe" ''' The rule is working, but it checks all existing indexes. And my ELK is very loaded. How…

---

## [Disk Usage - Something isnt adding up](https://discuss.elastic.co/t/disk-usage-something-isnt-adding-up/316822)

<div class="topic-metadata">

**Author:** [@Kurtis\_Schlienger](https://discuss.elastic.co/u/Kurtis_Schlienger)\
**Replies:** 1\
**Last updated:** [October 17, 2022, 7:17pm UTC](https://discuss.elastic.co/t/disk-usage-something-isnt-adding-up/316822 "2022-10-17T19:17:43Z")

</div>

I recently was looking into the shard distribution in my Elasticsearch cluster, and I noticed a heavy weighting on half of my cluster (some nodes have barely any shards on them). When looking into the distribution what I…

---

## [Data node left cluster. /media/Data/elasticsearch missing](https://discuss.elastic.co/t/data-node-left-cluster-media-data-elasticsearch-missing/316800)

<div class="topic-metadata">

**Author:** [@mhoward](https://discuss.elastic.co/u/mhoward)\
**Replies:** 2\
**Last updated:** [October 17, 2022, 7:01pm UTC](https://discuss.elastic.co/t/data-node-left-cluster-media-data-elasticsearch-missing/316800 "2022-10-17T19:01:41Z")

</div>

Hello. Yesterday one of our data nodes left our cluster and we've been unable to get it to rejoin. I'm still able to SSH into the physical server and noticed an error in the elasticsearch logs that led me to discover t…

---

## [RestHighLevelClient 7.17 not able to parse extended\_stats response](https://discuss.elastic.co/t/resthighlevelclient-7-17-not-able-to-parse-extended-stats-response/316368)

<div class="topic-metadata">

**Author:** [@swamy\_sandeep\_kommur](https://discuss.elastic.co/u/swamy_sandeep_kommur)\
**Replies:** 3\
**Last updated:** [October 17, 2022, 6:59pm UTC](https://discuss.elastic.co/t/resthighlevelclient-7-17-not-able-to-parse-extended-stats-response/316368 "2022-10-17T18:59:56Z")

</div>

Below is the query I am trying to make on Elasticsearch 8.3, using RestHighLevelClient 7.17 Query --------- { "size": 0, "timeout": "600000ms", "query": { "bool": { "filter": \[ { "range…

---

## [Dynamic mapping](https://discuss.elastic.co/t/dynamic-mapping/316475)

<div class="topic-metadata">

**Author:** [@cool999](https://discuss.elastic.co/u/cool999)\
**Replies:** 8\
**Last updated:** [October 17, 2022, 2:48pm UTC](https://discuss.elastic.co/t/dynamic-mapping/316475 "2022-10-17T14:48:04Z")

</div>

Hi Team, I am trying to understand if we can partially customize elasticsearch's dynamic mapping i.e for some of the fields we will set the data type explicitely and all the remaining fields (which are not mentioned exp…

---

## [Update\_by\_query fails to update all documents in ElasticSearch, getting true in between](https://discuss.elastic.co/t/update-by-query-fails-to-update-all-documents-in-elasticsearch-getting-true-in-between/316744)

<div class="topic-metadata">

**Author:** [@PriyaSmartShore](https://discuss.elastic.co/u/PriyaSmartShore)\
**Replies:** 1\
**Last updated:** [October 17, 2022, 1:55pm UTC](https://discuss.elastic.co/t/update-by-query-fails-to-update-all-documents-in-elasticsearch-getting-true-in-between/316744 "2022-10-17T13:55:27Z")

</div>

I have over 25 million documents in Elasticsearch (version - 7.6.2), those are having duplicates among them. So I have written a script in painless to delete one instance of duplicated document. I have tried running the …

---

## [Unbalanced distribution of index (shards) between HOT servers ES](https://discuss.elastic.co/t/unbalanced-distribution-of-index-shards-between-hot-servers-es/315603)

<div class="topic-metadata">

**Author:** [@Aleksei](https://discuss.elastic.co/u/Aleksei)\
**Replies:** 6\
**Last updated:** [October 17, 2022, 1:44pm UTC](https://discuss.elastic.co/t/unbalanced-distribution-of-index-shards-between-hot-servers-es/315603 "2022-10-17T13:44:03Z")

</div>

Hi community ! I apologize if this topic has been covered for a long time. But I never found it in the open Elastic Сommunity. :face\_with\_peeking\_eye: We have 11 cluster servers in the infrastructure ES: Servers HOT …

---

## [What's the cause and the solution of this error](https://discuss.elastic.co/t/whats-the-cause-and-the-solution-of-this-error/315055)

<div class="topic-metadata">

**Author:** [@morad\_della3](https://discuss.elastic.co/u/morad_della3)\
**Replies:** 9\
**Last updated:** [October 17, 2022, 9:51am UTC](https://discuss.elastic.co/t/whats-the-cause-and-the-solution-of-this-error/315055 "2022-10-17T09:51:03Z")

</div>

ubuntu 22.04 VM elasticsearch,kibana,filebeat8.4.1 ,elastalert,suricata i have this error in the log of elasticsearch when i try to start elasticsearch it failed to start Failed to get the temporary directory; falling…

---

## [Elastic Aggregate](https://discuss.elastic.co/t/elastic-aggregate/316485)

<div class="topic-metadata">

**Author:** [@edhbs31](https://discuss.elastic.co/u/edhbs31)\
**Replies:** 5\
**Last updated:** [October 17, 2022, 9:40am UTC](https://discuss.elastic.co/t/elastic-aggregate/316485 "2022-10-17T09:40:26Z")

</div>

Hi Guys, I am very new at elastic.. and i need some help or advice.. i have elastic's json result like this: "results": \[ { "discount": "", }, And Aggregate like this.. "data": \[ { "count": 17081, "value": "" …

---

## [Why "conf.dfs.replication" : "1" is not SUCCESS?](https://discuss.elastic.co/t/why-conf-dfs-replication-1-is-not-success/316405)

<div class="topic-metadata">

**Author:** [@bo8888](https://discuss.elastic.co/u/bo8888)\
**Replies:** 12\
**Last updated:** [October 17, 2022, 9:38am UTC](https://discuss.elastic.co/t/why-conf-dfs-replication-1-is-not-success/316405 "2022-10-17T09:38:23Z")

</div>

I set snapshot use hdfs with conf conf.dfs.replication = 1 ,but I found the replication of data is also 3，i need to hdfs dfs -setrep -R -w 1 /es\_snapshots GET \_snapshot/es\_snapshots { "es\_snapshots" : { "type" : …

---

## [Completion suggester issue](https://discuss.elastic.co/t/completion-suggester-issue/316657)

<div class="topic-metadata">

**Author:** [@Mahesh\_Hegde](https://discuss.elastic.co/u/Mahesh_Hegde)\
**Replies:** 3\
**Last updated:** [October 17, 2022, 7:50am UTC](https://discuss.elastic.co/t/completion-suggester-issue/316657 "2022-10-17T07:50:11Z")

</div>

Issue - completion suggester with custom keyword lowercase analyzer not working as expected. We can reproduce the issue with following steps. Not able to understand whats causing issue here. However, if we search for "P…

---

## [Upgrade OpenJDK](https://discuss.elastic.co/t/upgrade-openjdk/315659)

<div class="topic-metadata">

**Author:** [@hugo.barbosa](https://discuss.elastic.co/u/hugo.barbosa)\
**Replies:** 2\
**Last updated:** [October 17, 2022, 6:23am UTC](https://discuss.elastic.co/t/upgrade-openjdk/315659 "2022-10-17T06:23:27Z")

</div>

Dear all I would like to upgrade or check the current OpenJDK Java version on my three ubuntu nodes. Asking the dev tools about my version, it says 18 But asking on the ubuntu servers commandline, I got version 11. …

---

## [Fatal exception while booting Elasticsearchjava.nio.file.NoSuchFileException:](https://discuss.elastic.co/t/fatal-exception-while-booting-elasticsearchjava-nio-file-nosuchfileexception/316603)

<div class="topic-metadata">

**Author:** [@Arun\_Singh2](https://discuss.elastic.co/u/Arun_Singh2)\
**Replies:** 2\
**Last updated:** [October 17, 2022, 5:50am UTC](https://discuss.elastic.co/t/fatal-exception-while-booting-elasticsearchjava-nio-file-nosuchfileexception/316603 "2022-10-17T05:50:31Z")

</div>

i cant find any way to solve this error java version on my laptop is 19 nad i have added ES dir to path also these are logs --\> \[2022-10-14T12:45:26,597\]\[ERROR\]\[o.e.b.Elasticsearch \] \[LT0148506\] fatal exception w…

---

## [Debugging role-based access control to documents](https://discuss.elastic.co/t/debugging-role-based-access-control-to-documents/316628)

<div class="topic-metadata">

**Author:** [@foxy](https://discuss.elastic.co/u/foxy)\
**Replies:** 3\
**Last updated:** [October 17, 2022, 4:47am UTC](https://discuss.elastic.co/t/debugging-role-based-access-control-to-documents/316628 "2022-10-17T04:47:52Z")

</div>

Is there a way to see how access to a particular document set has been granted (i.e: where the permission has come from)? context We have several indices that employ document level security to restrict access, by role,…

---

## [Random sample of non-null values using Eland](https://discuss.elastic.co/t/random-sample-of-non-null-values-using-eland/316720)

<div class="topic-metadata">

**Author:** [@wpm](https://discuss.elastic.co/u/wpm)\
**Replies:** 0\
**Last updated:** [October 17, 2022, 3:25am UTC](https://discuss.elastic.co/t/random-sample-of-non-null-values-using-eland/316720 "2022-10-17T03:25:55Z")

</div>

I have indexed a bunch of documents containing an optional field called value. How do I use Eland to take a random sample of n non-null instances of value with replacement? If I had a pandas data frame I would do the fo…

---

## [Slow queries (fuzzy) - how to disable score calculation](https://discuss.elastic.co/t/slow-queries-fuzzy-how-to-disable-score-calculation/316711)

<div class="topic-metadata">

**Author:** [@Giorgos\_Katiforis](https://discuss.elastic.co/u/Giorgos_Katiforis)\
**Replies:** 0\
**Last updated:** [October 16, 2022, 6:52pm UTC](https://discuss.elastic.co/t/slow-queries-fuzzy-how-to-disable-score-calculation/316711 "2022-10-16T18:52:01Z")

</div>

The query has several match conditions with fuzziness 2, which makes it quite expensive. I don't want to search for document relevance or any kind of scoring, just identify the list of document IDs that match the query c…

[Previous page](https://discuss.elastic.co/c/elastic-stack/elasticsearch/6.md?page=356)

[Next page](https://discuss.elastic.co/c/elastic-stack/elasticsearch/6.md?page=358)
