# Elasticsearch

**URL:** https://discuss.elastic.co/c/elastic-stack/elasticsearch/6.md?page=43

[Latest](https://discuss.elastic.co/latest.md) · [Categories](https://discuss.elastic.co/categories.md) · [Tags](https://discuss.elastic.co/tags.md)

**Page:** 44

---

## [Elasticsearch fails to register the repository but succeeds after retry](https://discuss.elastic.co/t/elasticsearch-fails-to-register-the-repository-but-succeeds-after-retry/375271)

<div class="topic-metadata">

**Author:** [@wei.guo](https://discuss.elastic.co/u/wei.guo)\
**Replies:** 1\
**Last updated:** [March 1, 2025, 4:23pm UTC](https://discuss.elastic.co/t/elasticsearch-fails-to-register-the-repository-but-succeeds-after-retry/375271 "2025-03-01T16:23:23Z")

</div>

The issue is only on repository on Zadara. Error: "type": "repository\_verification\_exception", "reason": "\[index\_test\_1634127279\] \[\[wZIWLWCURDCiCRy6B6tClw, 'RepositoryVerificationException\[\[index\_test\_1634127279\] Failed…

---

## [Search-as-you-type Optimization: How to boost the First N-Gram for More Accurate Results](https://discuss.elastic.co/t/search-as-you-type-optimization-how-to-boost-the-first-n-gram-for-more-accurate-results/375264)

<div class="topic-metadata">

**Author:** [@Crout](https://discuss.elastic.co/u/Crout)\
**Replies:** 0\
**Last updated:** [March 1, 2025, 11:39am UTC](https://discuss.elastic.co/t/search-as-you-type-optimization-how-to-boost-the-first-n-gram-for-more-accurate-results/375264 "2025-03-01T11:39:27Z")

</div>

Hello everyone, I have been trying to improve my search for a while now I am searching for names with the help of search\_as\_you\_type and a mixture of match\_phrase and the math\_phrase\_prefix. the search itself works wond…

---

## [Elastic-agent-complete-\>x509: certificate signed by unknown authority](https://discuss.elastic.co/t/elastic-agent-complete-x509-certificate-signed-by-unknown-authority/375081)

<div class="topic-metadata">

**Author:** [@Amol\_Nagotkar](https://discuss.elastic.co/u/Amol_Nagotkar)\
**Replies:** 10\
**Last updated:** [March 1, 2025, 3:25am UTC](https://discuss.elastic.co/t/elastic-agent-complete-x509-certificate-signed-by-unknown-authority/375081 "2025-03-01T03:25:47Z")

</div>

Hi all, i am following this -\> Monitor resources on private networks | Elastic Observability \[8.16\] | Elastic sudo docker run \\ --env FLEET\_ENROLL=1 \\ --env FLEET\_URL=https://elastic:8220 \\ --env FLEET\_ENROLLMENT…

---

## [Curator - Failed to complete action: allocation. \<class 'KeyError'\>: 'store'](https://discuss.elastic.co/t/curator-failed-to-complete-action-allocation-class-keyerror-store/375037)

<div class="topic-metadata">

**Author:** [@mikewillis](https://discuss.elastic.co/u/mikewillis)\
**Replies:** 4\
**Last updated:** [February 28, 2025, 7:45pm UTC](https://discuss.elastic.co/t/curator-failed-to-complete-action-allocation-class-keyerror-store/375037 "2025-02-28T19:45:04Z")

</div>

Elasticsearch version: 7.17.1 (yes, I know.) Curator version: 7.0.1 I'm seeing an occasional error where a Curator task about allocation fails with Failed to complete action: allocation. \<class 'KeyError'\>: 'store' …

---

## [Unable to set username password for Elastic in azure container app](https://discuss.elastic.co/t/unable-to-set-username-password-for-elastic-in-azure-container-app/374962)

<div class="topic-metadata">

**Author:** [@chand\_techie](https://discuss.elastic.co/u/chand_techie)\
**Replies:** 7\
**Last updated:** [February 28, 2025, 7:27pm UTC](https://discuss.elastic.co/t/unable-to-set-username-password-for-elastic-in-azure-container-app/374962 "2025-02-28T19:27:39Z")

</div>

Unable to set username password for Elastic in conatiner app. As to launch the container app, I am passing below environment varibles. xpack.security.enabled = false discovery.type = single-node If I make xpack.securi…

---

## [How do I decide if i need co-ordinator nodes for my cluster?](https://discuss.elastic.co/t/how-do-i-decide-if-i-need-co-ordinator-nodes-for-my-cluster/374747)

<div class="topic-metadata">

**Author:** [@masif2002](https://discuss.elastic.co/u/masif2002)\
**Replies:** 20\
**Last updated:** [February 28, 2025, 11:06am UTC](https://discuss.elastic.co/t/how-do-i-decide-if-i-need-co-ordinator-nodes-for-my-cluster/374747 "2025-02-28T11:06:39Z")

</div>

I have an ELK setup in my org. We're working on improving the reliability of the system. We have 22 data nodes running in the cluster Having co-ordinator nodes is something that was suggested to us. We want to make sure…

---

## [Minor code cleanup (unused imports & static/final order) — OK to submit PR?](https://discuss.elastic.co/t/minor-code-cleanup-unused-imports-static-final-order-ok-to-submit-pr/375167)

<div class="topic-metadata">

**Author:** [@LTS2](https://discuss.elastic.co/u/LTS2)\
**Replies:** 3\
**Last updated:** [February 28, 2025, 6:55am UTC](https://discuss.elastic.co/t/minor-code-cleanup-unused-imports-static-final-order-ok-to-submit-pr/375167 "2025-02-28T06:55:31Z")

</div>

Dear developers, I found a few places in the code where there are unused imports and static final modifiers out of the recommended order. I'd like to open a PR to clean these up to align with the code style and remove …

---

## [Search UI: Remove "" from Facet component options](https://discuss.elastic.co/t/search-ui-remove-from-facet-component-options/375178)

<div class="topic-metadata">

**Author:** [@tanza-s](https://discuss.elastic.co/u/tanza-s)\
**Replies:** 0\
**Last updated:** [February 27, 2025, 10:16pm UTC](https://discuss.elastic.co/t/search-ui-remove-from-facet-component-options/375178 "2025-02-27T22:16:57Z")

</div>

Hello, I am building out the Facet components for a search index where some of the indexed items will have a blank field. I want to exclude the "" option from the facet display. Ideally something like: \<Facet field…

---

## [Locked out after closing indexes to enable compression. :-(](https://discuss.elastic.co/t/locked-out-after-closing-indexes-to-enable-compression/375173)

<div class="topic-metadata">

**Author:** [@JimKeating](https://discuss.elastic.co/u/JimKeating)\
**Replies:** 6\
**Last updated:** [February 27, 2025, 8:14pm UTC](https://discuss.elastic.co/t/locked-out-after-closing-indexes-to-enable-compression/375173 "2025-02-27T20:14:29Z")

</div>

We have an Elasticsearch 7.17 4 node cluster and we were running low on space so I found an article on how to enable high compression on the indexes. The first step was to close the indexes. Big mistake because as soon…

---

## [What is the latest and most stable version recommended for migration, which has been on the market long enough, for a cluster with dozens of nodes?](https://discuss.elastic.co/t/what-is-the-latest-and-most-stable-version-recommended-for-migration-which-has-been-on-the-market-long-enough-for-a-cluster-with-dozens-of-nodes/375038)

<div class="topic-metadata">

**Author:** [@mpniel](https://discuss.elastic.co/u/mpniel)\
**Replies:** 8\
**Last updated:** [February 27, 2025, 12:08pm UTC](https://discuss.elastic.co/t/what-is-the-latest-and-most-stable-version-recommended-for-migration-which-has-been-on-the-market-long-enough-for-a-cluster-with-dozens-of-nodes/375038 "2025-02-27T12:08:07Z")

</div>

Hello, What is the latest and most stable ELK version recommended for migration, which has been on the market long enough, for a cluster with dozens of nodes?

---

## [Connection error caused by: ConnectionError(Connection error caused by: NameResolutionError(\<elastic\_transport.\_node.\_urllib3\_chain\_certs.HTTPSConnection object at 0x0000026D04448ED0\>: Failed to resolve \<url\> (\[Errno 11002\] getaddrinfo failed)))](https://discuss.elastic.co/t/connection-error-caused-by-connectionerror-connection-error-caused-by-nameresolutionerror-elastic-transport-node-urllib3-chain-certs-httpsconnection-object-at-0x0000026d04448ed0-failed-to-resolve-url-errno-11002-getaddrinfo-failed/375052)

<div class="topic-metadata">

**Author:** [@Prateek\_Agrawal](https://discuss.elastic.co/u/Prateek_Agrawal)\
**Replies:** 2\
**Last updated:** [February 27, 2025, 4:08am UTC](https://discuss.elastic.co/t/connection-error-caused-by-connectionerror-connection-error-caused-by-nameresolutionerror-elastic-transport-node-urllib3-chain-certs-httpsconnection-object-at-0x0000026d04448ed0-failed-to-resolve-url-errno-11002-getaddrinfo-failed/375052 "2025-02-27T04:08:22Z")

</div>

I am getting the above error intermittently. Below is how I am connecting with Elasticsearch. can anyone help in this es = Elasticsearch(cloud\_id=\<ELASTIC\_CLOUD\_ID\>), api\_key=\<ELASTIC\_API\_KEY\>)…

---

## [How to setup security/SSL on ElasticSearch?](https://discuss.elastic.co/t/how-to-setup-security-ssl-on-elasticsearch/375049)

<div class="topic-metadata">

**Author:** [@chung](https://discuss.elastic.co/u/chung)\
**Replies:** 1\
**Last updated:** [February 27, 2025, 3:45am UTC](https://discuss.elastic.co/t/how-to-setup-security-ssl-on-elasticsearch/375049 "2025-02-27T03:45:16Z")

</div>

I am in the middle part upgrading Elastic 7 to 8 and ran into an SSL issue. Currently SSL is disabled curl -k https://10.152.0.5:9200 -u elastic:somepassword curl: (35) error:1408F10B:SSL routines:ssl3\_get\_record:wrong…

---

## [Unable to login, forced in to onboarding](https://discuss.elastic.co/t/unable-to-login-forced-in-to-onboarding/375006)

<div class="topic-metadata">

**Author:** [@Tom\_Maxwell](https://discuss.elastic.co/u/Tom_Maxwell)\
**Replies:** 1\
**Last updated:** [February 27, 2025, 3:34am UTC](https://discuss.elastic.co/t/unable-to-login-forced-in-to-onboarding/375006 "2025-02-27T03:34:13Z")

</div>

Our IT have added me to our account but I can't login with my google gmail account I'm being forced down onboarding with no way to cancel out. Same as this, but with google \> Login Issues

---

## [Documents not updating in Elasticsearch despite successful API requests](https://discuss.elastic.co/t/documents-not-updating-in-elasticsearch-despite-successful-api-requests/374976)

<div class="topic-metadata">

**Author:** [@chaq3l](https://discuss.elastic.co/u/chaq3l)\
**Replies:** 3\
**Last updated:** [February 26, 2025, 6:00pm UTC](https://discuss.elastic.co/t/documents-not-updating-in-elasticsearch-despite-successful-api-requests/374976 "2025-02-26T18:00:33Z")

</div>

I am trying to update elasticsearch documents with additional fields.I don't get any errors, but there is no change in documents. I use Elasticsearch 7.10.0 and NEST 7.17.5 using System; using System.Collections.Generic…

---

## [Map index to a new ILM](https://discuss.elastic.co/t/map-index-to-a-new-ilm/375056)

<div class="topic-metadata">

**Author:** [@Chaviru](https://discuss.elastic.co/u/Chaviru)\
**Replies:** 3\
**Last updated:** [February 26, 2025, 10:28am UTC](https://discuss.elastic.co/t/map-index-to-a-new-ilm/375056 "2025-02-26T10:28:37Z")

</div>

Hello guys, I have a usecase where I need to map my current index to a new ILM policy. So I created a new ILM polciy with my requirement and then deleted the existing ILM for the index and then added the new ILM for thi…

---

## [How do i edit my elasticsearch.yml and kibana.yml in conf folder to be to install on my pc](https://discuss.elastic.co/t/how-do-i-edit-my-elasticsearch-yml-and-kibana-yml-in-conf-folder-to-be-to-install-on-my-pc/375063)

<div class="topic-metadata">

**Author:** [@nabireeba](https://discuss.elastic.co/u/nabireeba)\
**Replies:** 0\
**Last updated:** [February 26, 2025, 9:18am UTC](https://discuss.elastic.co/t/how-do-i-edit-my-elasticsearch-yml-and-kibana-yml-in-conf-folder-to-be-to-install-on-my-pc/375063 "2025-02-26T09:18:10Z")

</div>

ERROR: Failed to determine the health of the cluster. , with exit code 69 when creating enrollment token

---

## [Not able to connect to elastic from pyspark application](https://discuss.elastic.co/t/not-able-to-connect-to-elastic-from-pyspark-application/375005)

<div class="topic-metadata">

**Author:** [@meghananagaraja](https://discuss.elastic.co/u/meghananagaraja)\
**Replies:** 3\
**Last updated:** [February 26, 2025, 9:06am UTC](https://discuss.elastic.co/t/not-able-to-connect-to-elastic-from-pyspark-application/375005 "2025-02-26T09:06:06Z")

</div>

Hi All, I am running Kafka, spark and elastic separately on docker containers. I use a python pyspark application to connect with elastic. But i am getting an error spark-job-2 | INFO:elastic\_transport.transport:HEAD …

---

## [Installed Docker onb redhat](https://discuss.elastic.co/t/installed-docker-onb-redhat/375002)

<div class="topic-metadata">

**Author:** [@felixwong](https://discuss.elastic.co/u/felixwong)\
**Replies:** 2\
**Last updated:** [February 26, 2025, 8:48am UTC](https://discuss.elastic.co/t/installed-docker-onb-redhat/375002 "2025-02-26T08:48:16Z")

</div>

HI , Thank you all for your help ! I installed elasticsearch:8.17.2 in red hat Docker . Is it possible to export docker configuration es01/es02/kib01 before stop? so I can retain configuration and keys ( password) w…

---

## [Issue with CompletionSuggester query using DotNet Elastic.Clients.Elasticsearch](https://discuss.elastic.co/t/issue-with-completionsuggester-query-using-dotnet-elastic-clients-elasticsearch/374959)

<div class="topic-metadata">

**Author:** [@Reed\_M](https://discuss.elastic.co/u/Reed_M)\
**Replies:** 3\
**Last updated:** [February 25, 2025, 8:03pm UTC](https://discuss.elastic.co/t/issue-with-completionsuggester-query-using-dotnet-elastic-clients-elasticsearch/374959 "2025-02-25T20:03:40Z")

</div>

I am trying to query the CompletionSuggester using Elastic.Clients.Elasticsearch. I am able to query with the following (use either prefix OR regex gets the right result): POST customer-catalog-test-0001/\_search { "\_s…

---

## [Why analyser dont work with suggester?](https://discuss.elastic.co/t/why-analyser-dont-work-with-suggester/374827)

<div class="topic-metadata">

**Author:** [@Adrien\_L](https://discuss.elastic.co/u/Adrien_L)\
**Replies:** 2\
**Last updated:** [February 25, 2025, 5:01pm UTC](https://discuss.elastic.co/t/why-analyser-dont-work-with-suggester/374827 "2025-02-25T17:01:33Z")

</div>

I'm trying to work on a basic suggester that if someone write "bl" the suggester would propose "blue corola" and "toyota blue". But at the moment its only return "blue corola". It's like the analyser dont work. Can you…

---

## [Error message": "getting node from external cluster \[RC\_Test\] failed" between nodes on 2 docker hosts](https://discuss.elastic.co/t/error-message-getting-node-from-external-cluster-rc-test-failed-between-nodes-on-2-docker-hosts/374980)

<div class="topic-metadata">

**Author:** [@poke1710](https://discuss.elastic.co/u/poke1710)\
**Replies:** 10\
**Last updated:** [February 25, 2025, 4:21pm UTC](https://discuss.elastic.co/t/error-message-getting-node-from-external-cluster-rc-test-failed-between-nodes-on-2-docker-hosts/374980 "2025-02-25T16:21:15Z")

</div>

Hi, We are facing problem while connecting remote cluster. I am using docker compose to build elasticsearch with local ip 10.1.1.2 on docker host 1 and same on docker host 2, when trying to connect remote cluster it is …

---

## [I get an error when connecting 2 remote clusters](https://discuss.elastic.co/t/i-get-an-error-when-connecting-2-remote-clusters/375029)

<div class="topic-metadata">

**Author:** [@shin12](https://discuss.elastic.co/u/shin12)\
**Replies:** 2\
**Last updated:** [February 25, 2025, 3:23pm UTC](https://discuss.elastic.co/t/i-get-an-error-when-connecting-2-remote-clusters/375029 "2025-02-25T15:23:14Z")

</div>

However, I am encountering an issue when trying to connect Cluster 1 to Cluster 2 as a remote cluster. The nodes on both clusters are trying to communicate using their internal IP addresses (the IPs assigned to each cont…

---

## [I get an error when connecting 2 remote clusters](https://discuss.elastic.co/t/i-get-an-error-when-connecting-2-remote-clusters/375031)

<div class="topic-metadata">

**Author:** [@anhle](https://discuss.elastic.co/u/anhle)\
**Replies:** 0\
**Last updated:** [February 25, 2025, 3:00pm UTC](https://discuss.elastic.co/t/i-get-an-error-when-connecting-2-remote-clusters/375031 "2025-02-25T15:00:02Z")

</div>

However, I am encountering an issue when trying to connect Cluster 1 to Cluster 2 as a remote cluster. The nodes on both clusters are trying to communicate using their internal IP addresses (the IPs assigned to each cont…

---

## [Memory usage in elasticsearch](https://discuss.elastic.co/t/memory-usage-in-elasticsearch/374973)

<div class="topic-metadata">

**Author:** [@Carlos\_Cardoso](https://discuss.elastic.co/u/Carlos_Cardoso)\
**Replies:** 3\
**Last updated:** [February 25, 2025, 1:19pm UTC](https://discuss.elastic.co/t/memory-usage-in-elasticsearch/374973 "2025-02-25T13:19:46Z")

</div>

Hello everyone, good evening. I'm experiencing seemingly high memory consumption from Elasticsearch and would like to know if anyone else has experienced this and how they optimized. :small\_blue\_diamond: Scenario: Elas…

---

## [Understanding Point-in-Time Recovery (PITR) & Backup Strategies in Elastic Cloud](https://discuss.elastic.co/t/understanding-point-in-time-recovery-pitr-backup-strategies-in-elastic-cloud/374996)

<div class="topic-metadata">

**Author:** [@Tharun\_Chimata](https://discuss.elastic.co/u/Tharun_Chimata)\
**Replies:** 1\
**Last updated:** [February 25, 2025, 10:04am UTC](https://discuss.elastic.co/t/understanding-point-in-time-recovery-pitr-backup-strategies-in-elastic-cloud/374996 "2025-02-25T10:04:53Z")

</div>

I have an Elastic Cloud account and I'm trying to understand if Point-in-Time Recovery (PITR) is possible using Elasticsearch snapshots. From what I’ve read, snapshots in Elasticsearch seem to be full backups (similar t…

---

## [A romved rule keeps firing alerts in ELK SIEM version: 7.12.0](https://discuss.elastic.co/t/a-romved-rule-keeps-firing-alerts-in-elk-siem-version-7-12-0/374995)

<div class="topic-metadata">

**Author:** [@JasemMHZ](https://discuss.elastic.co/u/JasemMHZ)\
**Replies:** 0\
**Last updated:** [February 25, 2025, 9:18am UTC](https://discuss.elastic.co/t/a-romved-rule-keeps-firing-alerts-in-elk-siem-version-7-12-0/374995 "2025-02-25T09:18:23Z")

</div>

I removed a rule from \<kibana\_IP\>:5601/app/alerting/rules about two weeks ago and it keeps generating alerts, but when I click on edit event and then edit rule link in the event page, it says the rule has been deleted, b…

---

## [Index replica shard relocation taking too long](https://discuss.elastic.co/t/index-replica-shard-relocation-taking-too-long/374950)

<div class="topic-metadata">

**Author:** [@Samuel\_Ruiz\_Garcia](https://discuss.elastic.co/u/Samuel_Ruiz_Garcia)\
**Replies:** 1\
**Last updated:** [February 25, 2025, 7:21am UTC](https://discuss.elastic.co/t/index-replica-shard-relocation-taking-too-long/374950 "2025-02-25T07:21:11Z")

</div>

A week ago, we had to recreate one out of 3 nodes of our ELK cluster due to and exception trying to stop the service (docker container). To solve it i had to kill the container process and then recreate the node. To let …

---

## [Azure Blob Storage Keeps Disconnecting when verify it gives "502 Bad Gateway"](https://discuss.elastic.co/t/azure-blob-storage-keeps-disconnecting-when-verify-it-gives-502-bad-gateway/374987)

<div class="topic-metadata">

**Author:** [@kishorkumar](https://discuss.elastic.co/u/kishorkumar)\
**Replies:** 0\
**Last updated:** [February 25, 2025, 7:00am UTC](https://discuss.elastic.co/t/azure-blob-storage-keeps-disconnecting-when-verify-it-gives-502-bad-gateway/374987 "2025-02-25T07:00:14Z")

</div>

Basic Information: I'm experiencing an issue with my on-prem Elasticsearch cluster's (8.17) Azure Blob Storage repository. The repository is configured using a container and initially shows as connected when verified vi…

---

## [What is the usecasae of --ca-dn when using elasticsearch-certutil utility](https://discuss.elastic.co/t/what-is-the-usecasae-of-ca-dn-when-using-elasticsearch-certutil-utility/374961)

<div class="topic-metadata">

**Author:** [@jack\_a](https://discuss.elastic.co/u/jack_a)\
**Replies:** 2\
**Last updated:** [February 25, 2025, 5:31am UTC](https://discuss.elastic.co/t/what-is-the-usecasae-of-ca-dn-when-using-elasticsearch-certutil-utility/374961 "2025-02-25T05:31:50Z")

</div>

the --ca-dn option while using cert seems to only be applicable with --self-signed option, for example ./elasticsearch-certutil cert --self-signed --ca-dn xyz --pem --out /usr/share/elasticsearch/bin/test/out5.zip Bu…

---

## [Reindex request failure causes error parsing exception](https://discuss.elastic.co/t/reindex-request-failure-causes-error-parsing-exception/374944)

<div class="topic-metadata">

**Author:** [@svtd](https://discuss.elastic.co/u/svtd)\
**Replies:** 4\
**Last updated:** [February 24, 2025, 3:50pm UTC](https://discuss.elastic.co/t/reindex-request-failure-causes-error-parsing-exception/374944 "2025-02-24T15:50:49Z")

</div>

Elasticsearch version and Elasticsearch Java client version: 8.13.4 Hi! When destination index is read only, reindex request expectedly fail, but Elastic Java client is not able to parse the failure response with the f…

[Previous page](https://discuss.elastic.co/c/elastic-stack/elasticsearch/6.md?page=42)

[Next page](https://discuss.elastic.co/c/elastic-stack/elasticsearch/6.md?page=44)
