# Elasticsearch

**URL:** https://discuss.elastic.co/c/elastic-stack/elasticsearch/6.md?page=49

[Latest](https://discuss.elastic.co/latest.md) · [Categories](https://discuss.elastic.co/categories.md) · [Tags](https://discuss.elastic.co/tags.md)

**Page:** 50

---

## [Storage differentiation. Multiple nodes on single host?](https://discuss.elastic.co/t/storage-differentiation-multiple-nodes-on-single-host/373719)

<div class="topic-metadata">

**Author:** [@catn0b0t](https://discuss.elastic.co/u/catn0b0t)\
**Replies:** 7\
**Last updated:** [January 28, 2025, 12:15pm UTC](https://discuss.elastic.co/t/storage-differentiation-multiple-nodes-on-single-host/373719 "2025-01-28T12:15:27Z")

</div>

We have hosts with both nvme storage and sata storage. Currently we run a single elasticsearch instance on each host and to keep performance up we only use the nvme storage. Now, we would like to start using the sata-dis…

---

## [Move default elastic data/index storage to a newly created volume](https://discuss.elastic.co/t/move-default-elastic-data-index-storage-to-a-newly-created-volume/373658)

<div class="topic-metadata">

**Author:** [@ermisma](https://discuss.elastic.co/u/ermisma)\
**Replies:** 7\
**Last updated:** [January 27, 2025, 10:50pm UTC](https://discuss.elastic.co/t/move-default-elastic-data-index-storage-to-a-newly-created-volume/373658 "2025-01-27T22:50:33Z")

</div>

We have successfully deployed ELK and it's up and running. We've created a new volume and attached it to the VM hosting the ELK stack. Our goal is to store all data, including indices, on this newly mounted volume. To d…

---

## [Cross Cluster Replication: To find overall time taken for data replication](https://discuss.elastic.co/t/cross-cluster-replication-to-find-overall-time-taken-for-data-replication/373750)

<div class="topic-metadata">

**Author:** [@lochinvar](https://discuss.elastic.co/u/lochinvar)\
**Replies:** 0\
**Last updated:** [January 27, 2025, 10:50pm UTC](https://discuss.elastic.co/t/cross-cluster-replication-to-find-overall-time-taken-for-data-replication/373750 "2025-01-27T22:50:28Z")

</div>

Hi All, I have done CCR setup and was able to get the existing data replicated from leader to follower. Working on to know the overall time taken to replicate the data from leader to follower. I ran "\_ccr/stats" to gat…

---

## [Elastic Data at Rest Encryption](https://discuss.elastic.co/t/elastic-data-at-rest-encryption/373746)

<div class="topic-metadata">

**Author:** [@Elk\_huh](https://discuss.elastic.co/u/Elk_huh)\
**Replies:** 1\
**Last updated:** [January 27, 2025, 8:39pm UTC](https://discuss.elastic.co/t/elastic-data-at-rest-encryption/373746 "2025-01-27T20:39:48Z")

</div>

Is there Data at rest Encryption on self-hosted Elasticsearch ? If so how can i achieve this

---

## [Cant run elasticsearch on mastodon](https://discuss.elastic.co/t/cant-run-elasticsearch-on-mastodon/373717)

<div class="topic-metadata">

**Author:** [@rasitha](https://discuss.elastic.co/u/rasitha)\
**Replies:** 1\
**Last updated:** [January 27, 2025, 5:08pm UTC](https://discuss.elastic.co/t/cant-run-elasticsearch-on-mastodon/373717 "2025-01-27T17:08:21Z")

</div>

hi im having trouble connecting elasticsearch to mastodon i can connect with curl without problem when i run RAILS\_ENV=production bin/tootctl search deploy i get this error INFO -- : \[dotenv\] Loaded .env.production Th…

---

## [Proxy to Elastic Cloud](https://discuss.elastic.co/t/proxy-to-elastic-cloud/373734)

<div class="topic-metadata">

**Author:** [@rugenl](https://discuss.elastic.co/u/rugenl)\
**Replies:** 0\
**Last updated:** [January 27, 2025, 4:05pm UTC](https://discuss.elastic.co/t/proxy-to-elastic-cloud/373734 "2025-01-27T16:05:58Z")

</div>

We have some private network servers where we may want to send data to our Elastic cloud service. Our desire is to use Fleet managed agents on these servers. Of course, that means "special handling". :slight\_smile: I…

---

## [Moving from source to synthetic\_source](https://discuss.elastic.co/t/moving-from-source-to-synthetic-source/358107)

<div class="topic-metadata">

**Author:** [@Aditya\_Teltia](https://discuss.elastic.co/u/Aditya_Teltia)\
**Replies:** 4\
**Last updated:** [January 27, 2025, 11:16am UTC](https://discuss.elastic.co/t/moving-from-source-to-synthetic-source/358107 "2025-01-27T11:16:26Z")

</div>

Hi everyone, I am moving set of indices from ES7 to ES8 with synthetic source. I added "mappings": { "\_source": { "mode": "synthetic" } } this in the mappings. But now I am getting following error - o…

---

## [How Can Elasticsearch Be Optimized for AI Workloads on Laptops?](https://discuss.elastic.co/t/how-can-elasticsearch-be-optimized-for-ai-workloads-on-laptops/373695)

<div class="topic-metadata">

**Author:** [@leoarthur](https://discuss.elastic.co/u/leoarthur)\
**Replies:** 1\
**Last updated:** [January 27, 2025, 7:58am UTC](https://discuss.elastic.co/t/how-can-elasticsearch-be-optimized-for-ai-workloads-on-laptops/373695 "2025-01-27T07:58:05Z")

</div>

Hi everyone, I’ve recently started using Elasticsearch on my AI-enabled laptop (with a decent GPU and an AI accelerator), primarily for small-scale machine learning experiments and AI data processing. However, I’ve noti…

---

## [Elasticsearch with trino not working for a specific field present in an index](https://discuss.elastic.co/t/elasticsearch-with-trino-not-working-for-a-specific-field-present-in-an-index/373684)

<div class="topic-metadata">

**Author:** [@Karan\_Rawat](https://discuss.elastic.co/u/Karan_Rawat)\
**Replies:** 0\
**Last updated:** [January 26, 2025, 3:41pm UTC](https://discuss.elastic.co/t/elasticsearch-with-trino-not-working-for-a-specific-field-present-in-an-index/373684 "2025-01-26T15:41:59Z")

</div>

just using trino on my elasticsearch ,ran a query on my accounts index SELECT \* FROM elasticsearch."default".accounts WHERE id = 24862540; which resulted in an error SQL Error \[58\]: Query failed (#20250126\_153854\_0014…

---

## ['Unable to process GET request to elasticsearch URL' in Zammad](https://discuss.elastic.co/t/unable-to-process-get-request-to-elasticsearch-url-in-zammad/373650)

<div class="topic-metadata">

**Author:** [@Laszlo\_Horvath](https://discuss.elastic.co/u/Laszlo_Horvath)\
**Replies:** 8\
**Last updated:** [January 25, 2025, 8:57pm UTC](https://discuss.elastic.co/t/unable-to-process-get-request-to-elasticsearch-url-in-zammad/373650 "2025-01-25T20:57:08Z")

</div>

Hello all, I am new to Elastic products, so forgive my ignorance. I've installed Zammad on a Debian server today, everything went well but the search indexing, even though Elasticsearch service is up and running. When…

---

## [Elasticsearch node http certificate expiration error](https://discuss.elastic.co/t/elasticsearch-node-http-certificate-expiration-error/373228)

<div class="topic-metadata">

**Author:** [@jack\_a](https://discuss.elastic.co/u/jack_a)\
**Replies:** 5\
**Last updated:** [January 25, 2025, 12:50pm UTC](https://discuss.elastic.co/t/elasticsearch-node-http-certificate-expiration-error/373228 "2025-01-25T12:50:37Z")

</div>

While i try to connects the kibana to elasticsearch i get the following error in the kibana's logs and when i try to load the kibana i get the Kibana server is not ready yet. : \[ERROR\]\[elasticsearch-service\] Unable to …

---

## [Exact match in query](https://discuss.elastic.co/t/exact-match-in-query/373538)

<div class="topic-metadata">

**Author:** [@mariana.upcodes](https://discuss.elastic.co/u/mariana.upcodes)\
**Replies:** 12\
**Last updated:** [January 25, 2025, 8:29am UTC](https://discuss.elastic.co/t/exact-match-in-query/373538 "2025-01-25T08:29:42Z")

</div>

We currently use the following query: "query": { "bool": { "should": \[\], "must": \[ { "multi\_match": { "query": "but not both", "type": "phrase", "…

---

## [Question about Elasticsearch ILM Index Lifecycle Policies](https://discuss.elastic.co/t/question-about-elasticsearch-ilm-index-lifecycle-policies/373620)

<div class="topic-metadata">

**Author:** [@ibollman](https://discuss.elastic.co/u/ibollman)\
**Replies:** 2\
**Last updated:** [January 24, 2025, 3:50pm UTC](https://discuss.elastic.co/t/question-about-elasticsearch-ilm-index-lifecycle-policies/373620 "2025-01-24T15:50:24Z")

</div>

Good Day! We have the following question about the ILMs: In our Elasticsearch Instance we are using the predefined default logs-ILM to manage our data streams. It is configured to delete the logs-\* data streams after 9…

---

## [Different behavior in multi\_match after replacing NEST with Elastic.Clients.Elasticsearch](https://discuss.elastic.co/t/different-behavior-in-multi-match-after-replacing-nest-with-elastic-clients-elasticsearch/373495)

<div class="topic-metadata">

**Author:** [@mbooh](https://discuss.elastic.co/u/mbooh)\
**Replies:** 2\
**Last updated:** [January 24, 2025, 3:33pm UTC](https://discuss.elastic.co/t/different-behavior-in-multi-match-after-replacing-nest-with-elastic-clients-elasticsearch/373495 "2025-01-24T15:33:37Z")

</div>

Hi! I just removed NEST and started to use Elastic.Clients.Elasticsearch I get a really strange behavior. The mulit\_match looks like this: "multi\_match": { "operator": "and", "query": "…

---

## [How to avoid duplicate fields?](https://discuss.elastic.co/t/how-to-avoid-duplicate-fields/373457)

<div class="topic-metadata">

**Author:** [@gorano79](https://discuss.elastic.co/u/gorano79)\
**Replies:** 8\
**Last updated:** [January 24, 2025, 1:22pm UTC](https://discuss.elastic.co/t/how-to-avoid-duplicate-fields/373457 "2025-01-24T13:22:24Z")

</div>

I am new to elasticsearch so forgive me if this question is stupid. We have millions of json documents in Azure blob storage that we would like to index in Elastic. After importing just a thousand we've reached the defau…

---

## [New datanode join ES cluster cpu high](https://discuss.elastic.co/t/new-datanode-join-es-cluster-cpu-high/373505)

<div class="topic-metadata">

**Author:** [@anders\_larsson](https://discuss.elastic.co/u/anders_larsson)\
**Replies:** 4\
**Last updated:** [January 24, 2025, 1:02pm UTC](https://discuss.elastic.co/t/new-datanode-join-es-cluster-cpu-high/373505 "2025-01-24T13:02:01Z")

</div>

Im adding a new data node in ES running version 6.8.21 and i cant update due to other realated dependencies. when join the new datanode the reroute start of shards works fine for around 30-50 min then the server starts …

---

## [Elasticsearch 8.17 on windows server start problem when es7.16 starts fine](https://discuss.elastic.co/t/elasticsearch-8-17-on-windows-server-start-problem-when-es7-16-starts-fine/373324)

<div class="topic-metadata">

**Author:** [@Maki\_Pa](https://discuss.elastic.co/u/Maki_Pa)\
**Replies:** 3\
**Last updated:** [January 24, 2025, 12:47pm UTC](https://discuss.elastic.co/t/elasticsearch-8-17-on-windows-server-start-problem-when-es7-16-starts-fine/373324 "2025-01-24T12:47:59Z")

</div>

Could you please, help me overcome this problem. I cannot start ES8.17 on this windows server from folder via elsticsearch.bat, when es7.17 works fine locally, from the his folder via elsticsearch.bat. Another es7.14 is …

---

## [Elasticsearch-reset-password returns error code 69](https://discuss.elastic.co/t/elasticsearch-reset-password-returns-error-code-69/373477)

<div class="topic-metadata">

**Author:** [@jimou](https://discuss.elastic.co/u/jimou)\
**Replies:** 14\
**Last updated:** [January 24, 2025, 12:44pm UTC](https://discuss.elastic.co/t/elasticsearch-reset-password-returns-error-code-69/373477 "2025-01-24T12:44:38Z")

</div>

I have installed elasticsearch-8.15.3-1.x86\_64 by following Install Elasticsearch with RPM | Elasticsearch Guide \[8.17\] | Elastic and I verified it is installed properly by $ sudo curl --cacert /etc/elasticsearch/certs…

---

## [Frequent GetObject Requests to S3 in Elasticsearch Snapshot Repository](https://discuss.elastic.co/t/frequent-getobject-requests-to-s3-in-elasticsearch-snapshot-repository/373602)

<div class="topic-metadata">

**Author:** [@Abasha](https://discuss.elastic.co/u/Abasha)\
**Replies:** 1\
**Last updated:** [January 24, 2025, 9:42am UTC](https://discuss.elastic.co/t/frequent-getobject-requests-to-s3-in-elasticsearch-snapshot-repository/373602 "2025-01-24T09:42:36Z")

</div>

Hello, I’m encountering an issue with GET Object operations while using Elasticsearch snapshots, in aws s3 bucker repository and I’d appreciate some guidance. Currently, I’m trying to snapshot an index that has a size…

---

## [Sentinelone integration api expires](https://discuss.elastic.co/t/sentinelone-integration-api-expires/373615)

<div class="topic-metadata">

**Author:** [@amarasinghe.kaluarac](https://discuss.elastic.co/u/amarasinghe.kaluarac)\
**Replies:** 0\
**Last updated:** [January 24, 2025, 5:52am UTC](https://discuss.elastic.co/t/sentinelone-integration-api-expires/373615 "2025-01-24T05:52:28Z")

</div>

Hi all, I have notice that the when the API token expires integration stop ingesting data to the siem, doesnt the integration automaticaly renew the token if it expires ? for a example lets say I created a token for a o…

---

## [Elastic Security use cases and Logsdb](https://discuss.elastic.co/t/elastic-security-use-cases-and-logsdb/373608)

<div class="topic-metadata">

**Author:** [@leandrojmp](https://discuss.elastic.co/u/leandrojmp)\
**Replies:** 0\
**Last updated:** [January 23, 2025, 11:46pm UTC](https://discuss.elastic.co/t/elastic-security-use-cases-and-logsdb/373608 "2025-01-23T23:46:16Z")

</div>

Hello, I'm just starting a new deployment on Elastic Cloud with the goal of going Enterprise to save space with by using both logsdb mode and searchable snapshots. I was reading the blog announcement about logsdb going…

---

## [How to search for last document per composite aggregation](https://discuss.elastic.co/t/how-to-search-for-last-document-per-composite-aggregation/373517)

<div class="topic-metadata">

**Author:** [@bzyku11](https://discuss.elastic.co/u/bzyku11)\
**Replies:** 3\
**Last updated:** [January 23, 2025, 9:23pm UTC](https://discuss.elastic.co/t/how-to-search-for-last-document-per-composite-aggregation/373517 "2025-01-23T21:23:52Z")

</div>

Hi, can someone help me with query: get last version of document per composite of fields(author, type, name) {"author" : "Mike", "type" : "expense\_report", "name": "trip to europe 2023", "updated" : "1727544249"} \<-re…

---

## [How can i use elasticsearch as a graphdb?](https://discuss.elastic.co/t/how-can-i-use-elasticsearch-as-a-graphdb/373552)

<div class="topic-metadata">

**Author:** [@Ali\_Zeiynali](https://discuss.elastic.co/u/Ali_Zeiynali)\
**Replies:** 1\
**Last updated:** [January 23, 2025, 6:53pm UTC](https://discuss.elastic.co/t/how-can-i-use-elasticsearch-as-a-graphdb/373552 "2025-01-23T18:53:57Z")

</div>

want to use Elasticsearch as a graph database, but I'm not sure how this is possible. I'm working on a text analysis project for coding and other analytics, similar to Maxqda. I want to implement some graph algorithms li…

---

## [How can I put mapping on a remote cluster index](https://discuss.elastic.co/t/how-can-i-put-mapping-on-a-remote-cluster-index/373596)

<div class="topic-metadata">

**Author:** [@rachelyang](https://discuss.elastic.co/u/rachelyang)\
**Replies:** 0\
**Last updated:** [January 23, 2025, 6:44pm UTC](https://discuss.elastic.co/t/how-can-i-put-mapping-on-a-remote-cluster-index/373596 "2025-01-23T18:44:54Z")

</div>

I have connected to a remote cluster. I want to parse a field and extract a value from this field by mapping script. I refer to this article: https://www.elastic.co/guide/en/elasticsearch/reference/7.14/scripting-field-e…

---

## [How to calculate Elasticsearch Cloud in Azure TCO](https://discuss.elastic.co/t/how-to-calculate-elasticsearch-cloud-in-azure-tco/373501)

<div class="topic-metadata">

**Author:** [@kdwolf](https://discuss.elastic.co/u/kdwolf)\
**Replies:** 6\
**Last updated:** [January 23, 2025, 4:36pm UTC](https://discuss.elastic.co/t/how-to-calculate-elasticsearch-cloud-in-azure-tco/373501 "2025-01-23T16:36:13Z")

</div>

Apologies I couldn't find a better category to raise this question. I want to consider moving diagnostics indices to Elasticsearch Cloud and I can use their following link to calculate the costs of subscription. But I c…

---

## [Destination.port field missing](https://discuss.elastic.co/t/destination-port-field-missing/373221)

<div class="topic-metadata">

**Author:** [@Hendrawns](https://discuss.elastic.co/u/Hendrawns)\
**Replies:** 6\
**Last updated:** [January 23, 2025, 1:59pm UTC](https://discuss.elastic.co/t/destination-port-field-missing/373221 "2025-01-23T13:59:08Z")

</div>

Hello everyone, after I tried to install elastic on a new vm, I realized that there were several fields that did not appear when I used the discovery feature, the field that did not appear was “destination.port”, has any…

---

## [Import error](https://discuss.elastic.co/t/import-error/373472)

<div class="topic-metadata">

**Author:** [@searchwithme](https://discuss.elastic.co/u/searchwithme)\
**Replies:** 1\
**Last updated:** [January 23, 2025, 1:19pm UTC](https://discuss.elastic.co/t/import-error/373472 "2025-01-23T13:19:16Z")

</div>

Hi! I am trying out implementing this piece of code from search labs. git page says prerequisite is docker but I am trying to run using jupyter notebook. here is the error I am encountering: ImportError: /home/ec2-user…

---

## [Azure Native ISV Service](https://discuss.elastic.co/t/azure-native-isv-service/373580)

<div class="topic-metadata">

**Author:** [@fabry\_00](https://discuss.elastic.co/u/fabry_00)\
**Replies:** 0\
**Last updated:** [January 23, 2025, 12:15pm UTC](https://discuss.elastic.co/t/azure-native-isv-service/373580 "2025-01-23T12:15:49Z")

</div>

We are evaluating to deploy ELK on Azure using "Azure Native ISV Service" Here some linkgs: Azure Native ISV Service | Elasticsearch Service Documentation | Elastic Elastic integration overview - Azure Native ISV Serv…

---

## [Connection Pool Shutdown happening very frequently for s3 snapshot repository](https://discuss.elastic.co/t/connection-pool-shutdown-happening-very-frequently-for-s3-snapshot-repository/373570)

<div class="topic-metadata">

**Author:** [@Dharani\_Vattamwar](https://discuss.elastic.co/u/Dharani_Vattamwar)\
**Replies:** 0\
**Last updated:** [January 23, 2025, 9:53am UTC](https://discuss.elastic.co/t/connection-pool-shutdown-happening-very-frequently-for-s3-snapshot-repository/373570 "2025-01-23T09:53:50Z")

</div>

We have a need to perform automated restore testing for the snapshots stored . Whenever we connect the s3 to another ES cluster (readOnly mode) we will need to restart new ES cluster inorder to connect successfully. Late…

---

## [Is time series forecasting included in open source elasticsearch / kibana?](https://discuss.elastic.co/t/is-time-series-forecasting-included-in-open-source-elasticsearch-kibana/373564)

<div class="topic-metadata">

**Author:** [@vchalmel](https://discuss.elastic.co/u/vchalmel)\
**Replies:** 0\
**Last updated:** [January 23, 2025, 9:21am UTC](https://discuss.elastic.co/t/is-time-series-forecasting-included-in-open-source-elasticsearch-kibana/373564 "2025-01-23T09:21:28Z")

</div>

I am a long term user of elasticsearch for text data but have never really used the times series analytics capabilites. Being currently working towards a new project including a heavy workload on time series I was natur…

[Previous page](https://discuss.elastic.co/c/elastic-stack/elasticsearch/6.md?page=48)

[Next page](https://discuss.elastic.co/c/elastic-stack/elasticsearch/6.md?page=50)
