# Elasticsearch

**URL:** https://discuss.elastic.co/c/elastic-stack/elasticsearch/6.md?page=509

[Latest](https://discuss.elastic.co/latest.md) · [Categories](https://discuss.elastic.co/categories.md) · [Tags](https://discuss.elastic.co/tags.md)

**Page:** 510

---

## [Duplicate error logs](https://discuss.elastic.co/t/duplicate-error-logs/294696)

<div class="topic-metadata">

**Author:** [@Petersson](https://discuss.elastic.co/u/Petersson)\
**Replies:** 0\
**Last updated:** [January 18, 2022, 1:24pm UTC](https://discuss.elastic.co/t/duplicate-error-logs/294696 "2022-01-18T13:24:28Z")

</div>

Hello, I have recently started using Elasticsearch in combination with the Kibana presentation layer. My problem now is that in the log analysis all logs are shown to me individually, so there are many identical error …

---

## [Elasticsearch x-paxk error](https://discuss.elastic.co/t/elasticsearch-x-paxk-error/294661)

<div class="topic-metadata">

**Author:** [@harsh19](https://discuss.elastic.co/u/harsh19)\
**Replies:** 1\
**Last updated:** [January 18, 2022, 1:19pm UTC](https://discuss.elastic.co/t/elasticsearch-x-paxk-error/294661 "2022-01-18T13:19:37Z")

</div>

When i run ./Elasticsearch it's gives an error how do i reconfiugure keystore or else ? uncaught exception in thread \[main\] java.lang.IllegalArgumentException: unknown secure setting \[xpack.security.transport.ssl.keysto…

---

## [Curator failing with 'curator.exceptions.FailedExecution'\>: Unable to get snapshot information from repository: elkbackup. Error: NotFoundError(404, 'snapshot\_missing\_exception',](https://discuss.elastic.co/t/curator-failing-with-curator-exceptions-failedexecution-unable-to-get-snapshot-information-from-repository-elkbackup-error-notfounderror-404-snapshot-missing-exception/294660)

<div class="topic-metadata">

**Author:** [@jashwanth](https://discuss.elastic.co/u/jashwanth)\
**Replies:** 0\
**Last updated:** [January 18, 2022, 7:50am UTC](https://discuss.elastic.co/t/curator-failing-with-curator-exceptions-failedexecution-unable-to-get-snapshot-information-from-repository-elkbackup-error-notfounderror-404-snapshot-missing-exception/294660 "2022-01-18T07:50:40Z")

</div>

Hi Team, We're facing an issue with Curator and it is failing with below error. The Curator is searching a snapshot which is not present in S3. How can we fix this error for delete\_snapshots to work properly. One of th…

---

## [Would the search performance be very slow if a data stream consists of too many or too large cold backing indices?](https://discuss.elastic.co/t/would-the-search-performance-be-very-slow-if-a-data-stream-consists-of-too-many-or-too-large-cold-backing-indices/294376)

<div class="topic-metadata">

**Author:** [@Morriaty](https://discuss.elastic.co/u/Morriaty)\
**Replies:** 6\
**Last updated:** [January 18, 2022, 8:16am UTC](https://discuss.elastic.co/t/would-the-search-performance-be-very-slow-if-a-data-stream-consists-of-too-many-or-too-large-cold-backing-indices/294376 "2022-01-18T08:16:45Z")

</div>

Hi, I'm moving from es 6.x to 7.x, find the new feature data stream and would like to have a try. But I'm a bit worried of the search performace for the docs explains When you submit a read request to a data stream, the…

---

## [What is the point of using EQL to correlate log?](https://discuss.elastic.co/t/what-is-the-point-of-using-eql-to-correlate-log/294542)

<div class="topic-metadata">

**Author:** [@lusynda](https://discuss.elastic.co/u/lusynda)\
**Replies:** 1\
**Last updated:** [January 18, 2022, 6:57am UTC](https://discuss.elastic.co/t/what-is-the-point-of-using-eql-to-correlate-log/294542 "2022-01-18T06:57:48Z")

</div>

Hi all I am trying to understand how the eql is difference from the normal search api that we are already using in elastic. For example GET /winlogbeat-\*/\_eql/search { "query": """ process where event.type == "s…

---

## [After ES Cluster docker container restart on 7.5.0 could not elect master node with same configuration as old](https://discuss.elastic.co/t/after-es-cluster-docker-container-restart-on-7-5-0-could-not-elect-master-node-with-same-configuration-as-old/294615)

<div class="topic-metadata">

**Author:** [@shubham1121](https://discuss.elastic.co/u/shubham1121)\
**Replies:** 1\
**Last updated:** [January 18, 2022, 4:48am UTC](https://discuss.elastic.co/t/after-es-cluster-docker-container-restart-on-7-5-0-could-not-elect-master-node-with-same-configuration-as-old/294615 "2022-01-18T04:48:18Z")

</div>

On physical server container restarts and then could not elect master anymore from 3 node ES cluster

---

## [Questions about the use of maxSeqNoOfUpdatesOrDeletes in planIndexingAsNonPrimary](https://discuss.elastic.co/t/questions-about-the-use-of-maxseqnoofupdatesordeletes-in-planindexingasnonprimary/294650)

<div class="topic-metadata">

**Author:** [@liurui](https://discuss.elastic.co/u/liurui)\
**Replies:** 0\
**Last updated:** [January 18, 2022, 3:48am UTC](https://discuss.elastic.co/t/questions-about-the-use-of-maxseqnoofupdatesordeletes-in-planindexingasnonprimary/294650 "2022-01-18T03:48:14Z")

</div>

Hello. :grinning: I recently encountered read IOPS high due to translog operation replay during index recovery on a 710 cluster. I want to know more about the logic of this place and have a question about the method pla…

---

## [What's the detail about enterprise license 30$ per month?](https://discuss.elastic.co/t/whats-the-detail-about-enterprise-license-30-per-month/294643)

<div class="topic-metadata">

**Author:** [@chaishiqi](https://discuss.elastic.co/u/chaishiqi)\
**Replies:** 2\
**Last updated:** [January 18, 2022, 3:29am UTC](https://discuss.elastic.co/t/whats-the-detail-about-enterprise-license-30-per-month/294643 "2022-01-18T03:29:00Z")

</div>

As it ,In order to search snapshot on frozen tie of my private Elasticsearch cluster ,the license price on website is 30$ per month, this is all the cluster fee or single node agent?

---

## [Join the two index in the ElasticSearch to query the data with sorting](https://discuss.elastic.co/t/join-the-two-index-in-the-elasticsearch-to-query-the-data-with-sorting/294519)

<div class="topic-metadata">

**Author:** [@jamesweb1](https://discuss.elastic.co/u/jamesweb1)\
**Replies:** 3\
**Last updated:** [January 18, 2022, 3:23am UTC](https://discuss.elastic.co/t/join-the-two-index-in-the-elasticsearch-to-query-the-data-with-sorting/294519 "2022-01-18T03:23:18Z")

</div>

In my application, I have two indices like: Elasticsearch (index: 'identify\_results') deviceId value time 00245765 100 2021-11-22T08:20:01.004Z 10245888 200 2021-11-23T10:20:01.004Z 00245765 300 2021-11-24T11:20:01.004Z…

---

## [Cannot run forecast, memory usage is predicted to exceed 20MB. v7.8](https://discuss.elastic.co/t/cannot-run-forecast-memory-usage-is-predicted-to-exceed-20mb-v7-8/294623)

<div class="topic-metadata">

**Author:** [@ElasticLiver](https://discuss.elastic.co/u/ElasticLiver)\
**Replies:** 2\
**Last updated:** [January 18, 2022, 2:13am UTC](https://discuss.elastic.co/t/cannot-run-forecast-memory-usage-is-predicted-to-exceed-20mb-v7-8/294623 "2022-01-18T02:13:22Z")

</div>

Hi Im having problems runing a forecast, when I use the kibana GUI it throws me a Bad Request error and when I use devtools I get this error. Cannot run forecast: Forecast cannot be executed as forecast memory usage is …

---

## [Every Night- Elasticsearch. (code=killed, signal=KILL)](https://discuss.elastic.co/t/every-night-elasticsearch-code-killed-signal-kill/294397)

<div class="topic-metadata">

**Author:** [@beohna](https://discuss.elastic.co/u/beohna)\
**Replies:** 8\
**Last updated:** [January 17, 2022, 10:58pm UTC](https://discuss.elastic.co/t/every-night-elasticsearch-code-killed-signal-kill/294397 "2022-01-17T22:58:41Z")

</div>

Hey, on my Rasperry Pi with Nextcloud and full text search (powered by Elasticsearch) every night Elasticsearch is killed (code=killed, signal=KILL). ● elasticsearch.service - Elasticsearch Loaded: loaded (/lib/s…

---

## [Force\_source seems not working](https://discuss.elastic.co/t/force-source-seems-not-working/294622)

<div class="topic-metadata">

**Author:** [@ympark](https://discuss.elastic.co/u/ympark)\
**Replies:** 0\
**Last updated:** [January 17, 2022, 7:41pm UTC](https://discuss.elastic.co/t/force-source-seems-not-working/294622 "2022-01-17T19:41:17Z")

</div>

Hi all, I am testing the latest Elasticsearch 7.16.3 and encountered an issue. I have a keyword type field with the lowercase normaliser. When I get highlight on the keyword field, Highlighting seems not to be applied …

---

## [Setting up minimal security for Elasticsearch 7.16.2](https://discuss.elastic.co/t/setting-up-minimal-security-for-elasticsearch-7-16-2/294316)

<div class="topic-metadata">

**Author:** [@Akhil2](https://discuss.elastic.co/u/Akhil2)\
**Replies:** 1\
**Last updated:** [January 17, 2022, 7:39pm UTC](https://discuss.elastic.co/t/setting-up-minimal-security-for-elasticsearch-7-16-2/294316 "2022-01-17T19:39:13Z")

</div>

Hello all, I am using Elastic stack version 7.16.2 with a three node cluster implementation. I am using a basic license. I understand I can set up three different levels of security for my elastic stack. Minimal secu…

---

## [Error in per bucket doc\_count\_error\_upper\_bound for Term Aggregation?](https://discuss.elastic.co/t/error-in-per-bucket-doc-count-error-upper-bound-for-term-aggregation/294249)

<div class="topic-metadata">

**Author:** [@Nishikant\_Tayade](https://discuss.elastic.co/u/Nishikant_Tayade)\
**Replies:** 7\
**Last updated:** [January 17, 2022, 7:07pm UTC](https://discuss.elastic.co/t/error-in-per-bucket-doc-count-error-upper-bound-for-term-aggregation/294249 "2022-01-17T19:07:47Z")

</div>

Below configuration for Elasticsearch: 1 Cluster 1 Node 1 Index 3 Shards (1 Replica shard for each primary, but in UNASSIGNED state as there is only 1 node). I have indexed document and those are spread across 3 Shards…

---

## [Snapshot indices to S3 repository\_exception](https://discuss.elastic.co/t/snapshot-indices-to-s3-repository-exception/294611)

<div class="topic-metadata">

**Author:** [@rymr](https://discuss.elastic.co/u/rymr)\
**Replies:** 0\
**Last updated:** [January 17, 2022, 5:16pm UTC](https://discuss.elastic.co/t/snapshot-indices-to-s3-repository-exception/294611 "2022-01-17T17:16:44Z")

</div>

Hi, I backup my indices with a script on s3 bucket following those steps: create repository if it doesn't exist cleanup the repository remove old snapshots snapshot in 4 repositories depending of indices types The fi…

---

## [Error "Look-behind group does not have an obvious maximum length near index" in pattern\_capture](https://discuss.elastic.co/t/error-look-behind-group-does-not-have-an-obvious-maximum-length-near-index-in-pattern-capture/294594)

<div class="topic-metadata">

**Author:** [@Amir\_Faramarzi](https://discuss.elastic.co/u/Amir_Faramarzi)\
**Replies:** 1\
**Last updated:** [January 17, 2022, 4:08pm UTC](https://discuss.elastic.co/t/error-look-behind-group-does-not-have-an-obvious-maximum-length-near-index-in-pattern-capture/294594 "2022-01-17T16:08:08Z")

</div>

Hello I just want to index the word "Samsung" in the text below Text: Samsung a30 mobile phone I mean I want to separate the text above by space and just index the word I want (the word may change by location, for exa…

---

## [ES issue with bulk items](https://discuss.elastic.co/t/es-issue-with-bulk-items/294598)

<div class="topic-metadata">

**Author:** [@dominbdg](https://discuss.elastic.co/u/dominbdg)\
**Replies:** 1\
**Last updated:** [January 17, 2022, 3:35pm UTC](https://discuss.elastic.co/t/es-issue-with-bulk-items/294598 "2022-01-17T15:35:36Z")

</div>

Hello, I'm receiving below issues with bulk items, "stacktrace": \["org.elasticsearch.index.mapper.MapperParsingException: object mapping for \[rule\] tried to parse field \[rule\] as object, but found a concrete value", "a…

---

## [Elastic Ingest Node Geoip Expired](https://discuss.elastic.co/t/elastic-ingest-node-geoip-expired/294591)

<div class="topic-metadata">

**Author:** [@Mohammad\_Etemad](https://discuss.elastic.co/u/Mohammad_Etemad)\
**Replies:** 1\
**Last updated:** [January 17, 2022, 3:09pm UTC](https://discuss.elastic.co/t/elastic-ingest-node-geoip-expired/294591 "2022-01-17T15:09:30Z")

</div>

I have been using Elasticsearch ingest nodes for a while. For the first time I noticed that I am getting an error on geoip mapping of data. Error is: \_geoip\_expired\_database Looking into this, looks like if libraries ar…

---

## [How do I protect indexes](https://discuss.elastic.co/t/how-do-i-protect-indexes/294585)

<div class="topic-metadata">

**Author:** [@kzltp](https://discuss.elastic.co/u/kzltp)\
**Replies:** 3\
**Last updated:** [January 17, 2022, 2:09pm UTC](https://discuss.elastic.co/t/how-do-i-protect-indexes/294585 "2022-01-17T14:09:41Z")

</div>

I use elasticsarch 7.16. I wanna any indexes not delete. Any user(included in superuser) can't delete any indexes. How do i do that.

---

## [Log4j on Elasticsearch 7.9.2](https://discuss.elastic.co/t/log4j-on-elasticsearch-7-9-2/292093)

<div class="topic-metadata">

**Author:** [@h4h3hj](https://discuss.elastic.co/u/h4h3hj)\
**Replies:** 8\
**Last updated:** [January 17, 2022, 12:33pm UTC](https://discuss.elastic.co/t/log4j-on-elasticsearch-7-9-2/292093 "2022-01-17T12:33:12Z")

</div>

Hi Everyone, As we know the vulnerability (CVE-2021-44228) impacts multiple versions of the Apache Log4j2 I can see Elastic has updated about this Supported versions of Elasticsearch (6.8.9+, 7.8+) used with recent ve…

---

## [Kibana page goes unresponsive everytime i select sum buckets in Kibana 7.6.3](https://discuss.elastic.co/t/kibana-page-goes-unresponsive-everytime-i-select-sum-buckets-in-kibana-7-6-3/294573)

<div class="topic-metadata">

**Author:** [@emohan](https://discuss.elastic.co/u/emohan)\
**Replies:** 0\
**Last updated:** [January 17, 2022, 11:45am UTC](https://discuss.elastic.co/t/kibana-page-goes-unresponsive-everytime-i-select-sum-buckets-in-kibana-7-6-3/294573 "2022-01-17T11:45:06Z")

</div>

I want to sum count based on common bucket and so i try sum bucket aggregation which results in page going unresponsive. I am on Kibana 7.6.3 version. This is similar to previous post: Is this bug still existing?

---

## [Mean aggregation over cadinality aggregation, over previous composite aggregation](https://discuss.elastic.co/t/mean-aggregation-over-cadinality-aggregation-over-previous-composite-aggregation/294374)

<div class="topic-metadata">

**Author:** [@Silver137](https://discuss.elastic.co/u/Silver137)\
**Replies:** 3\
**Last updated:** [January 17, 2022, 10:52am UTC](https://discuss.elastic.co/t/mean-aggregation-over-cadinality-aggregation-over-previous-composite-aggregation/294374 "2022-01-17T10:52:21Z")

</div>

My use case require to obtain an average over previous cardinality aggregation, this aggregations works over the buckets generated by a composite aggregation "calendar histogram" that breaks the timeline in calendar days…

---

## [Snapshot & Restore Policies](https://discuss.elastic.co/t/snapshot-restore-policies/294567)

<div class="topic-metadata">

**Author:** [@FALEN](https://discuss.elastic.co/u/FALEN)\
**Replies:** 0\
**Last updated:** [January 17, 2022, 10:49am UTC](https://discuss.elastic.co/t/snapshot-restore-policies/294567 "2022-01-17T10:49:58Z")

</div>

Hi all, Im using s3 repository to snapshot & restore indices. Clusters configured to have 10+ different snapshot policies that mainly based on index names. I leave a certain amount of time between each policy to preven…

---

## [Ingest strategy](https://discuss.elastic.co/t/ingest-strategy/294561)

<div class="topic-metadata">

**Author:** [@mark8](https://discuss.elastic.co/u/mark8)\
**Replies:** 0\
**Last updated:** [January 17, 2022, 9:56am UTC](https://discuss.elastic.co/t/ingest-strategy/294561 "2022-01-17T09:56:56Z")

</div>

Hi there, as a (broader) follow up on this topic, I am creating this new one about ingest strategy, as I am utterly running out of ideas. My use case has many client machines, each logging various metrics (pretty common…

---

## [How to index a certain number of words from each text?](https://discuss.elastic.co/t/how-to-index-a-certain-number-of-words-from-each-text/294506)

<div class="topic-metadata">

**Author:** [@Amir\_Faramarzi](https://discuss.elastic.co/u/Amir_Faramarzi)\
**Replies:** 6\
**Last updated:** [January 17, 2022, 9:54am UTC](https://discuss.elastic.co/t/how-to-index-a-certain-number-of-words-from-each-text/294506 "2022-01-17T09:54:13Z")

</div>

How can only the first two words of each text be indexed ??

---

## [I deleted index like files into OS when I had a diskspace problem and now have to fix it](https://discuss.elastic.co/t/i-deleted-index-like-files-into-os-when-i-had-a-diskspace-problem-and-now-have-to-fix-it/294558)

<div class="topic-metadata">

**Author:** [@marlybyliganget](https://discuss.elastic.co/u/marlybyliganget)\
**Replies:** 1\
**Last updated:** [January 17, 2022, 9:31am UTC](https://discuss.elastic.co/t/i-deleted-index-like-files-into-os-when-i-had-a-diskspace-problem-and-now-have-to-fix-it/294558 "2022-01-17T09:31:10Z")

</div>

Hi guys I have a problem with Elasticsearch cluster I deleted index like files into OS, when I had a diskspace problem I deleted index through this command find ./data/nodes/0/indices -type d -mtime +30 -exec rm -rf …

---

## [Create TermAggregation with the wildcard field in Java code](https://discuss.elastic.co/t/create-termaggregation-with-the-wildcard-field-in-java-code/294424)

<div class="topic-metadata">

**Author:** [@Tiffany](https://discuss.elastic.co/u/Tiffany)\
**Replies:** 4\
**Last updated:** [January 17, 2022, 7:50am UTC](https://discuss.elastic.co/t/create-termaggregation-with-the-wildcard-field-in-java-code/294424 "2022-01-17T07:50:39Z")

</div>

Hi, I want to create a termAggregation query with wildcard in Java API. It works in Elasticsearch console, but not in Java code. Would you mind shedding some lights? Thank you! Below query works in console { "aggrega…

---

## [Authentication Options for Scroll API Call](https://discuss.elastic.co/t/authentication-options-for-scroll-api-call/294543)

<div class="topic-metadata">

**Author:** [@Matt.Wash](https://discuss.elastic.co/u/Matt.Wash)\
**Replies:** 0\
**Last updated:** [January 17, 2022, 7:58am UTC](https://discuss.elastic.co/t/authentication-options-for-scroll-api-call/294543 "2022-01-17T07:58:22Z")

</div>

Hi Elastic Experts, I am hoping you can help me. I am building Power BI templates for my clients using the Scroll API method where they want to retrieve results in excess of 10,000 records. I have built the templates u…

---

## [How to keep an ES cluster happy during a K8s(!) node update](https://discuss.elastic.co/t/how-to-keep-an-es-cluster-happy-during-a-k8s-node-update/293736)

<div class="topic-metadata">

**Author:** [@jugosag](https://discuss.elastic.co/u/jugosag)\
**Replies:** 1\
**Last updated:** [January 17, 2022, 5:17am UTC](https://discuss.elastic.co/t/how-to-keep-an-es-cluster-happy-during-a-k8s-node-update/293736 "2022-01-17T05:17:43Z")

</div>

Hi all, I am looking for general guidance on how to keep an Elasticsearch cluster on K8s happy while doing a K8s node update. Motivation We are running an HA microservice-based SaaS application on Kubernetes, we have i…

---

## [Elasticsearch password set error in both auto and interactive](https://discuss.elastic.co/t/elasticsearch-password-set-error-in-both-auto-and-interactive/294524)

<div class="topic-metadata">

**Author:** [@harsh19](https://discuss.elastic.co/u/harsh19)\
**Replies:** 2\
**Last updated:** [January 17, 2022, 5:13am UTC](https://discuss.elastic.co/t/elasticsearch-password-set-error-in-both-auto-and-interactive/294524 "2022-01-17T05:13:53Z")

</div>

when i execute ./bin/Elasticsearch-setup-passwords auto or interactive then it's shows me an error Exception in thread "main" SettingsException\[Failed to load settings from \[elasticsearch.yml\]\]; nested: MarkedYAMLExcept…

[Previous page](https://discuss.elastic.co/c/elastic-stack/elasticsearch/6.md?page=508)

[Next page](https://discuss.elastic.co/c/elastic-stack/elasticsearch/6.md?page=510)
