# Elasticsearch

**URL:** https://discuss.elastic.co/c/elastic-stack/elasticsearch/6.md?page=65

[Latest](https://discuss.elastic.co/latest.md) · [Categories](https://discuss.elastic.co/categories.md) · [Tags](https://discuss.elastic.co/tags.md)

**Page:** 66

---

## [\_cat/indices returns hidden indices](https://discuss.elastic.co/t/cat-indices-returns-hidden-indices/365020)

<div class="topic-metadata">

**Author:** [@Andy0708](https://discuss.elastic.co/u/Andy0708)\
**Replies:** 4\
**Last updated:** [November 4, 2024, 7:03pm UTC](https://discuss.elastic.co/t/cat-indices-returns-hidden-indices/365020 "2024-11-04T19:03:50Z")

</div>

Hi, On a fresh setup of version 8.15.0, I run the following query: GET /\_cat/indices?v It returns a bunch of internal indices: health status index uuid …

---

## [HTTPS and HTTP](https://discuss.elastic.co/t/https-and-http/370012)

<div class="topic-metadata">

**Author:** [@chenchen40](https://discuss.elastic.co/u/chenchen40)\
**Replies:** 1\
**Last updated:** [November 4, 2024, 2:03pm UTC](https://discuss.elastic.co/t/https-and-http/370012 "2024-11-04T14:03:54Z")

</div>

Is it possible to run Elasticsearch with both HTTP on port 9200 and HTTPS on port 9201 simultaneously?

---

## [Help optimizing slow knn query](https://discuss.elastic.co/t/help-optimizing-slow-knn-query/369910)

<div class="topic-metadata">

**Author:** [@Iliyan\_Tanev](https://discuss.elastic.co/u/Iliyan_Tanev)\
**Replies:** 7\
**Last updated:** [November 4, 2024, 1:19pm UTC](https://discuss.elastic.co/t/help-optimizing-slow-knn-query/369910 "2024-11-04T13:19:36Z")

</div>

Hi, I'm running into a problem with the hybrid search ( keyword + vector ). As far as I can tell the performance bottleneck comes from the vector part for which I use the knn query. Bellow, I'll share: The query I'm …

---

## [Read elastic rate limit headers from response](https://discuss.elastic.co/t/read-elastic-rate-limit-headers-from-response/369411)

<div class="topic-metadata">

**Author:** [@CTO\_Servefast](https://discuss.elastic.co/u/CTO_Servefast)\
**Replies:** 4\
**Last updated:** [November 4, 2024, 12:43pm UTC](https://discuss.elastic.co/t/read-elastic-rate-limit-headers-from-response/369411 "2024-11-04T12:43:17Z")

</div>

Hi,, we are using provided code const response = await client.app.indexDocuments({ engine\_name: engineName, documents: snakeCaseDocuments, }); We are hitting API requests limits and we would like to …

---

## [High JVM heap during upsert](https://discuss.elastic.co/t/high-jvm-heap-during-upsert/369999)

<div class="topic-metadata">

**Author:** [@Farhaan](https://discuss.elastic.co/u/Farhaan)\
**Replies:** 0\
**Last updated:** [November 4, 2024, 11:35am UTC](https://discuss.elastic.co/t/high-jvm-heap-during-upsert/369999 "2024-11-04T11:35:38Z")

</div>

We are using 4Gb memory Storage optimized (dense) instance in elastic cloud for storing millions of token with embeddings. We do an upsert operation to index embeddings. We follow two set process 1- Index tokens in El…

---

## [How do used asp.net mvc core](https://discuss.elastic.co/t/how-do-used-asp-net-mvc-core/369909)

<div class="topic-metadata">

**Author:** [@MohMehrnia](https://discuss.elastic.co/u/MohMehrnia)\
**Replies:** 1\
**Last updated:** [November 4, 2024, 10:02am UTC](https://discuss.elastic.co/t/how-do-used-asp-net-mvc-core/369909 "2024-11-04T10:02:14Z")

</div>

I used Nest in my app and I can not any sample for migrating from Nest to the new package

---

## [Incorrect Aggregation count vs Search Query results](https://discuss.elastic.co/t/incorrect-aggregation-count-vs-search-query-results/369977)

<div class="topic-metadata">

**Author:** [@suma](https://discuss.elastic.co/u/suma)\
**Replies:** 1\
**Last updated:** [November 4, 2024, 6:37am UTC](https://discuss.elastic.co/t/incorrect-aggregation-count-vs-search-query-results/369977 "2024-11-04T06:37:12Z")

</div>

When performing Aggregation on a query the count is mismatching with results coming from a simple search query. The query used in Aggregation is same as the Search query.

---

## [What are the potential drawbacks of changing ( "ignore\_above": 4000) and is there a better way to recommend it?](https://discuss.elastic.co/t/what-are-the-potential-drawbacks-of-changing-ignore-above-4000-and-is-there-a-better-way-to-recommend-it/369951)

<div class="topic-metadata">

**Author:** [@monther](https://discuss.elastic.co/u/monther)\
**Replies:** 4\
**Last updated:** [November 4, 2024, 4:30am UTC](https://discuss.elastic.co/t/what-are-the-potential-drawbacks-of-changing-ignore-above-4000-and-is-there-a-better-way-to-recommend-it/369951 "2024-11-04T04:30:16Z")

</div>

I have a field in which I store very textual data that may reach 4000 characters, which are symbols, numbers, and (/,\*,-,\_,.). When I store this data in the default state, it is normal and receives the data, but when I s…

---

## [Unsigned\_long value is not precise](https://discuss.elastic.co/t/unsigned-long-value-is-not-precise/369967)

<div class="topic-metadata">

**Author:** [@avnere](https://discuss.elastic.co/u/avnere)\
**Replies:** 1\
**Last updated:** [November 3, 2024, 4:07pm UTC](https://discuss.elastic.co/t/unsigned-long-value-is-not-precise/369967 "2024-11-03T16:07:57Z")

</div>

We are using elasticsearch v.8.12.2. We defined in some of our fields with type of unsigned\_long. In large numbers we see that the number we want to store is not the number actually stored in elastic. For example: We …

---

## [Elastic index option doesn't accept int4\_hnsw](https://discuss.elastic.co/t/elastic-index-option-doesnt-accept-int4-hnsw/369961)

<div class="topic-metadata">

**Author:** [@sandra\_a](https://discuss.elastic.co/u/sandra_a)\
**Replies:** 4\
**Last updated:** [November 3, 2024, 1:41pm UTC](https://discuss.elastic.co/t/elastic-index-option-doesnt-accept-int4-hnsw/369961 "2024-11-03T13:41:03Z")

</div>

Hi I want to create a dense vector index with int4\_hnsw option as said in document (Automatically quantize vectors for kNN search) but after running the same example i got this error: { "error": { "root\_cause": \[…

---

## [Ingest Pipeline processing issue in for loop](https://discuss.elastic.co/t/ingest-pipeline-processing-issue-in-for-loop/369954)

<div class="topic-metadata">

**Author:** [@Jay\_Timbadia](https://discuss.elastic.co/u/Jay_Timbadia)\
**Replies:** 6\
**Last updated:** [November 3, 2024, 7:38am UTC](https://discuss.elastic.co/t/ingest-pipeline-processing-issue-in-for-loop/369954 "2024-11-03T07:38:13Z")

</div>

I am running ingest pipeline in loop for an array of PDF files. I am creating new index for each file. But sometimes the pipeline gives 201 and sometimes it gives 200. In 201, it just creates the index but does not pro…

---

## [Could not communicate with the node on any of the addresses from the enrollment token](https://discuss.elastic.co/t/could-not-communicate-with-the-node-on-any-of-the-addresses-from-the-enrollment-token/369927)

<div class="topic-metadata">

**Author:** [@germebl](https://discuss.elastic.co/u/germebl)\
**Replies:** 0\
**Last updated:** [November 2, 2024, 1:09am UTC](https://discuss.elastic.co/t/could-not-communicate-with-the-node-on-any-of-the-addresses-from-the-enrollment-token/369927 "2024-11-02T01:09:39Z")

</div>

Hey everyone, actually doing my very first steps with elastic and want to use it with the full ELK Stack. I decided for a testing cluster of 3 elastic nodes and one kibana nodes. The node-1 is running fine with this el…

---

## [Documents failing to index with helpers.bulk](https://discuss.elastic.co/t/documents-failing-to-index-with-helpers-bulk/369834)

<div class="topic-metadata">

**Author:** [@tommycahir](https://discuss.elastic.co/u/tommycahir)\
**Replies:** 3\
**Last updated:** [November 1, 2024, 1:21pm UTC](https://discuss.elastic.co/t/documents-failing-to-index-with-helpers-bulk/369834 "2024-11-01T13:21:28Z")

</div>

Hey Everyone During some development work over the last few weeks release we noticed an issue with the Elasticsearch helper.bulk method we were using in the python scripts. Issue: When any docs fail to get uploaded to …

---

## [Not showing 8.15 version](https://discuss.elastic.co/t/not-showing-8-15-version/369901)

<div class="topic-metadata">

**Author:** [@Duong\_Quoc\_Khanh](https://discuss.elastic.co/u/Duong_Quoc_Khanh)\
**Replies:** 2\
**Last updated:** [November 1, 2024, 10:00am UTC](https://discuss.elastic.co/t/not-showing-8-15-version/369901 "2024-11-01T10:00:37Z")

</div>

I'm currently at the version of 8.10.4. When I click upgrade, I only see v8.14.3 the latest but not 8.15. Any idea guys?

---

## [ElasticSearch(8.15.0) Docker setup, ENV not able to reset built in user-elastic's password](https://discuss.elastic.co/t/elasticsearch-8-15-0-docker-setup-env-not-able-to-reset-built-in-user-elastics-password/369891)

<div class="topic-metadata">

**Author:** [@pranchalm](https://discuss.elastic.co/u/pranchalm)\
**Replies:** 5\
**Last updated:** [November 1, 2024, 6:00am UTC](https://discuss.elastic.co/t/elasticsearch-8-15-0-docker-setup-env-not-able-to-reset-built-in-user-elastics-password/369891 "2024-11-01T06:00:48Z")

</div>

Hi team, trying to create a custom elasticsearch docker image base image is set as 8.15.0, following is my Dockerfile which is getting built-: # Use the official Elasticsearch 8.15 base image FROM docker.elastic.co/ela…

---

## [Create two Elasticsearch hosts in Docker](https://discuss.elastic.co/t/create-two-elasticsearch-hosts-in-docker/369694)

<div class="topic-metadata">

**Author:** [@louisdeveloper](https://discuss.elastic.co/u/louisdeveloper)\
**Replies:** 3\
**Last updated:** [October 31, 2024, 9:39pm UTC](https://discuss.elastic.co/t/create-two-elasticsearch-hosts-in-docker/369694 "2024-10-31T21:39:44Z")

</div>

I tried creating two elasticsearch 8 virtual machines in Docker, but I end up having two problems: One of the machines always stops The server always has a high CPU consumption I did it this way: docker pull docker.e…

---

## [Getting bounds for the expected values from ML](https://discuss.elastic.co/t/getting-bounds-for-the-expected-values-from-ml/369292)

<div class="topic-metadata">

**Author:** [@gueri](https://discuss.elastic.co/u/gueri)\
**Replies:** 2\
**Last updated:** [October 31, 2024, 6:48pm UTC](https://discuss.elastic.co/t/getting-bounds-for-the-expected-values-from-ml/369292 "2024-10-31T18:48:16Z")

</div>

Hello See this ML example from Elastic documentation : I'm creating my own custom viz mixing data with ml results from .ml-anomalies-\* index. I would like to retireve the bounds for all the expected values (the sha…

---

## [Nested Query](https://discuss.elastic.co/t/nested-query/369752)

<div class="topic-metadata">

**Author:** [@palkema](https://discuss.elastic.co/u/palkema)\
**Replies:** 1\
**Last updated:** [October 31, 2024, 6:45pm UTC](https://discuss.elastic.co/t/nested-query/369752 "2024-10-31T18:45:40Z")

</div>

Hi, I have an elastic query where I would like to filter on the property userData where the windowsId = 'palkema', so I can retrieve those through the inner\_hits response, however this is impacting my overall result. F…

---

## [\[Resolved\] Question: Using AppSearch/ Search UI to query an EXACT text string with special character '/'](https://discuss.elastic.co/t/resolved-question-using-appsearch-search-ui-to-query-an-exact-text-string-with-special-character/369882)

<div class="topic-metadata">

**Author:** [@wh0lesome](https://discuss.elastic.co/u/wh0lesome)\
**Replies:** 3\
**Last updated:** [October 31, 2024, 3:54pm UTC](https://discuss.elastic.co/t/resolved-question-using-appsearch-search-ui-to-query-an-exact-text-string-with-special-character/369882 "2024-10-31T15:54:03Z")

</div>

Hi, I can not find my solution anywhere, so I am writing my own topic. I am using Search UI that has its data from an engine that is based on an index created by my own logstash pipeline. Now, everything works fine, j…

---

## [Migrate existing elasticsearch cluster running as a java process in linux vms to Kubernetes cluster](https://discuss.elastic.co/t/migrate-existing-elasticsearch-cluster-running-as-a-java-process-in-linux-vms-to-kubernetes-cluster/369875)

<div class="topic-metadata">

**Author:** [@Jeet\_Patel1](https://discuss.elastic.co/u/Jeet_Patel1)\
**Replies:** 1\
**Last updated:** [October 31, 2024, 1:14pm UTC](https://discuss.elastic.co/t/migrate-existing-elasticsearch-cluster-running-as-a-java-process-in-linux-vms-to-kubernetes-cluster/369875 "2024-10-31T13:14:40Z")

</div>

Hello, I am trying to migrate an existing Elasticsearch cluster, which is currently running as a process on Linux VMs, to a Kubernetes cluster. What I did: I created a new Elasticsearch data node pod in the Kubernetes …

---

## [X Index lifecycle error illegal\_argument\_exception: index name \[X\] does not match pattern "^\*-\\d+$"](https://discuss.elastic.co/t/x-index-lifecycle-error-illegal-argument-exception-index-name-x-does-not-match-pattern-d/369873)

<div class="topic-metadata">

**Author:** [@kishorkumar](https://discuss.elastic.co/u/kishorkumar)\
**Replies:** 0\
**Last updated:** [October 31, 2024, 11:26am UTC](https://discuss.elastic.co/t/x-index-lifecycle-error-illegal-argument-exception-index-name-x-does-not-match-pattern-d/369873 "2024-10-31T11:26:27Z")

</div>

I have a rollup job set up to send logs from system metrics to a standard index called rolled-metrics-system-rollup. I encountered an error during the lifecycle rollover process and, upon investigation, found the followi…

---

## [Elastic Agent/Fleet Server Error: "Access is denied" on Named Pipe](https://discuss.elastic.co/t/elastic-agent-fleet-server-error-access-is-denied-on-named-pipe/369703)

<div class="topic-metadata">

**Author:** [@YTS](https://discuss.elastic.co/u/YTS)\
**Replies:** 2\
**Last updated:** [October 31, 2024, 10:39am UTC](https://discuss.elastic.co/t/elastic-agent-fleet-server-error-access-is-denied-on-named-pipe/369703 "2024-10-31T10:39:15Z")

</div>

Hi, I set up Elasticsearch and Kibana via Docker. I am reaching out regarding an issue I encountered with the Elastic Agent on my setup. The agent fails to start the HTTP server for the API, resulting in an error that re…

---

## [The same search statement multiple times gets different total results](https://discuss.elastic.co/t/the-same-search-statement-multiple-times-gets-different-total-results/368688)

<div class="topic-metadata">

**Author:** [@deserts](https://discuss.elastic.co/u/deserts)\
**Replies:** 9\
**Last updated:** [October 31, 2024, 9:41am UTC](https://discuss.elastic.co/t/the-same-search-statement-multiple-times-gets-different-total-results/368688 "2024-10-31T09:41:46Z")

</div>

I am not sure if there is a teacher who is familiar with the elasticsearch source code to help me look at this issue I raised on github. At present, I cannot get stable query results using the same conditions. The reason…

---

## [Unexpected floating-point precision issue with scaled\_float field](https://discuss.elastic.co/t/unexpected-floating-point-precision-issue-with-scaled-float-field/369865)

<div class="topic-metadata">

**Author:** [@kangquanzhou](https://discuss.elastic.co/u/kangquanzhou)\
**Replies:** 0\
**Last updated:** [October 31, 2024, 7:17am UTC](https://discuss.elastic.co/t/unexpected-floating-point-precision-issue-with-scaled-float-field/369865 "2024-10-31T07:17:04Z")

</div>

Description: I'm experiencing an unexpected floating-point precision issue when performing aggregations on a scaled\_float field in Elasticsearch. I have defined a field with scaled\_float type and a scaling\_factor of 100…

---

## [Aggregation contains old values](https://discuss.elastic.co/t/aggregation-contains-old-values/369805)

<div class="topic-metadata">

**Author:** [@Bhavyagc](https://discuss.elastic.co/u/Bhavyagc)\
**Replies:** 1\
**Last updated:** [October 31, 2024, 6:30am UTC](https://discuss.elastic.co/t/aggregation-contains-old-values/369805 "2024-10-31T06:30:26Z")

</div>

Can someone please help on the below request? Please find the below example and the exact issue I am facing.... I'm having some problems with aggregations returning old data. When I query directly using bool/must/term …

---

## [Found an invalid configuration for xpack.ml.model\_repository. Illegal character in authority at index 9:](https://discuss.elastic.co/t/found-an-invalid-configuration-for-xpack-ml-model-repository-illegal-character-in-authority-at-index-9/369858)

<div class="topic-metadata">

**Author:** [@vin2008](https://discuss.elastic.co/u/vin2008)\
**Replies:** 0\
**Last updated:** [October 31, 2024, 3:40am UTC](https://discuss.elastic.co/t/found-an-invalid-configuration-for-xpack-ml-model-repository-illegal-character-in-authority-at-index-9/369858 "2024-10-31T03:40:48Z")

</div>

Found an invalid configuration for xpack.ml.model\_repository. Illegal character in authority at index 9: file://G:\\elasticsearch-8.15.3-windows-x86\_64\\elasticsearch-8.15.3/config/models/ See ELSER – Elastic Learned Sp…

---

## [Elasticsearch 7.17 and logstash7.17 have security issues with snakeyaml low versions and need to be upgraded to 2.0 or higher](https://discuss.elastic.co/t/elasticsearch-7-17-and-logstash7-17-have-security-issues-with-snakeyaml-low-versions-and-need-to-be-upgraded-to-2-0-or-higher/369855)

<div class="topic-metadata">

**Author:** [@wb\_he](https://discuss.elastic.co/u/wb_he)\
**Replies:** 1\
**Last updated:** [October 31, 2024, 3:22am UTC](https://discuss.elastic.co/t/elasticsearch-7-17-and-logstash7-17-have-security-issues-with-snakeyaml-low-versions-and-need-to-be-upgraded-to-2-0-or-higher/369855 "2024-10-31T03:22:21Z")

</div>

I am currently using Elasticsearch 7.17.14 and Logstash7.17.14. Scanning shows that both of these applications are using the snakeyaml 1.0 version jar package, and there are security issues with snakeyaml versions smalle…

---

## [Removing occurrences of repeated text Characters from title in Elastic cloud](https://discuss.elastic.co/t/removing-occurrences-of-repeated-text-characters-from-title-in-elastic-cloud/369775)

<div class="topic-metadata">

**Author:** [@DavidT\_Spark](https://discuss.elastic.co/u/DavidT_Spark)\
**Replies:** 4\
**Last updated:** [October 31, 2024, 12:17am UTC](https://discuss.elastic.co/t/removing-occurrences-of-repeated-text-characters-from-title-in-elastic-cloud/369775 "2024-10-31T00:17:56Z")

</div>

I would like to remove any "| Brand" occurrences in the title field in such results. What script should I use? I tried painless scripts String title = doc\['title'\].value; if (title != null) { // Use replaceAll to re…

---

## [ExceptionInInitializer and NoClassDefFound could not initialize class org.elasticsearch.client.RestClientBuilder](https://discuss.elastic.co/t/exceptionininitializer-and-noclassdeffound-could-not-initialize-class-org-elasticsearch-client-restclientbuilder/369813)

<div class="topic-metadata">

**Author:** [@Radha\_G](https://discuss.elastic.co/u/Radha_G)\
**Replies:** 4\
**Last updated:** [October 30, 2024, 6:39pm UTC](https://discuss.elastic.co/t/exceptionininitializer-and-noclassdeffound-could-not-initialize-class-org-elasticsearch-client-restclientbuilder/369813 "2024-10-30T18:39:25Z")

</div>

Hi All, I have replaced org.elasticsearch.client.RestHighLevelClient to co.elastic.clients.elasticsearch.ElasticsearchClient . But, when mvn clean verify command is executed, the following exception is being thrown : \[…

---

## [Connectors deprecated?](https://discuss.elastic.co/t/connectors-deprecated/369746)

<div class="topic-metadata">

**Author:** [@6igwig](https://discuss.elastic.co/u/6igwig)\
**Replies:** 4\
**Last updated:** [October 30, 2024, 5:56pm UTC](https://discuss.elastic.co/t/connectors-deprecated/369746 "2024-10-30T17:56:29Z")

</div>

Are connectors deprecated? I am trying to configure a PostgreSQL connector but the configuration instructions link to a GitHub page that no longer exists: https://github.com/elastic/connectors

[Previous page](https://discuss.elastic.co/c/elastic-stack/elasticsearch/6.md?page=64)

[Next page](https://discuss.elastic.co/c/elastic-stack/elasticsearch/6.md?page=66)
