# Elasticsearch

**URL:** https://discuss.elastic.co/c/elastic-stack/elasticsearch/6.md?page=67

[Latest](https://discuss.elastic.co/latest.md) · [Categories](https://discuss.elastic.co/categories.md) · [Tags](https://discuss.elastic.co/tags.md)

**Page:** 68

---

## [Elastic Search can't been started without execute rights on /tmp](https://discuss.elastic.co/t/elastic-search-cant-been-started-without-execute-rights-on-tmp/369149)

<div class="topic-metadata">

**Author:** [@mscheepers](https://discuss.elastic.co/u/mscheepers)\
**Replies:** 11\
**Last updated:** [October 27, 2024, 6:43pm UTC](https://discuss.elastic.co/t/elastic-search-cant-been-started-without-execute-rights-on-tmp/369149 "2024-10-27T18:43:41Z")

</div>

Hi All, I noticed when starting the Elasticsearch services on our RHEL 9 machine is failing when it's been installed with RPM's. The startup is failing as its trying to execute files on the /tmp path. This is by defaul…

---

## [Trouble following the "Getting started" blog guide](https://discuss.elastic.co/t/trouble-following-the-getting-started-blog-guide/369480)

<div class="topic-metadata">

**Author:** [@jackal713](https://discuss.elastic.co/u/jackal713)\
**Replies:** 4\
**Last updated:** [October 27, 2024, 6:41pm UTC](https://discuss.elastic.co/t/trouble-following-the-getting-started-blog-guide/369480 "2024-10-27T18:41:33Z")

</div>

Hello Everyone, I'm trying to follow the "Getting started with the Elastic Stack and Docker Compose" blog guide. (I'm not allowed to post the actual URL.) I'm running into an issue following the directions and I'm hopin…

---

## [Filter documents based on their Guid\[\] array property to only retrieve those containing all the values from an incoming Guid\[\] array or more](https://discuss.elastic.co/t/filter-documents-based-on-their-guid-array-property-to-only-retrieve-those-containing-all-the-values-from-an-incoming-guid-array-or-more/369484)

<div class="topic-metadata">

**Author:** [@ali101](https://discuss.elastic.co/u/ali101)\
**Replies:** 2\
**Last updated:** [October 27, 2024, 11:18am UTC](https://discuss.elastic.co/t/filter-documents-based-on-their-guid-array-property-to-only-retrieve-those-containing-all-the-values-from-an-incoming-guid-array-or-more/369484 "2024-10-27T11:18:06Z")

</div>

Hello, I'm using .NET 6.0 and Elastic.Clients.Elasticsearch V8.15.10. I have a title index with a property Guid\[\] Genres that is an array of Guids. In my incoming query I expect the same, an array of Guids (query.Genr…

---

## [What about the Scroll API makes it a bad choice for paging large result sets?](https://discuss.elastic.co/t/what-about-the-scroll-api-makes-it-a-bad-choice-for-paging-large-result-sets/368704)

<div class="topic-metadata">

**Author:** [@sweller](https://discuss.elastic.co/u/sweller)\
**Replies:** 1\
**Last updated:** [October 25, 2024, 7:04pm UTC](https://discuss.elastic.co/t/what-about-the-scroll-api-makes-it-a-bad-choice-for-paging-large-result-sets/368704 "2024-10-25T19:04:15Z")

</div>

The fact that the Scroll API is not recommended for deep pagination in ES 8 is well-documented. I'm currently updating some legacy code which uses it to page through a result set much larger than 10k hits, and from what …

---

## [Large data node memory issues on write](https://discuss.elastic.co/t/large-data-node-memory-issues-on-write/369454)

<div class="topic-metadata">

**Author:** [@gpremo](https://discuss.elastic.co/u/gpremo)\
**Replies:** 0\
**Last updated:** [October 25, 2024, 7:00pm UTC](https://discuss.elastic.co/t/large-data-node-memory-issues-on-write/369454 "2024-10-25T19:00:19Z")

</div>

Hello, we are seeing some memory issues in our cluster, and data nodes will sometimes crash when running out of memory. Some quick background of our elasticsearch cluster running in GKE with the following nodes: 3x Ma…

---

## [How does Elasticsearch propagate index mappings to all primary and replica shards?](https://discuss.elastic.co/t/how-does-elasticsearch-propagate-index-mappings-to-all-primary-and-replica-shards/369432)

<div class="topic-metadata">

**Author:** [@Hamza\_Belmellouki](https://discuss.elastic.co/u/Hamza_Belmellouki)\
**Replies:** 1\
**Last updated:** [October 25, 2024, 5:27pm UTC](https://discuss.elastic.co/t/how-does-elasticsearch-propagate-index-mappings-to-all-primary-and-replica-shards/369432 "2024-10-25T17:27:25Z")

</div>

Hello, I'm trying to understand how Elasticsearch ensures consistency of index mappings across all primary and replica shards. Specifically: When an index is created with mappings, does the master node propagate these…

---

## [Graph API Query with multiple hops](https://discuss.elastic.co/t/graph-api-query-with-multiple-hops/369309)

<div class="topic-metadata">

**Author:** [@Jennifer\_Klemisch](https://discuss.elastic.co/u/Jennifer_Klemisch)\
**Replies:** 6\
**Last updated:** [October 25, 2024, 5:10pm UTC](https://discuss.elastic.co/t/graph-api-query-with-multiple-hops/369309 "2024-10-25T17:10:38Z")

</div>

Hi I have data that looks like this: PUT g\_explore/\_doc/0 { "lot\_num":"A1", "out\_batch": "BATCH940","input\_batch": "BATCH770","produce\_consume": "BATCH770 BATCH940"} PUT g\_explore/\_doc/1 { "lot\_num":"A2-0", "out\_batch…

---

## [Elasticsearch multi cluster set up](https://discuss.elastic.co/t/elasticsearch-multi-cluster-set-up/369410)

<div class="topic-metadata">

**Author:** [@vinodmb](https://discuss.elastic.co/u/vinodmb)\
**Replies:** 2\
**Last updated:** [October 25, 2024, 10:47am UTC](https://discuss.elastic.co/t/elasticsearch-multi-cluster-set-up/369410 "2024-10-25T10:47:50Z")

</div>

We want to use multiple Elasticsearch cluster in our service, is there any way to automatically data is injected to specific cluster based on some parameter in bulk api without manually calling bulk api separately for ea…

---

## [Do very large segments lead to a significant increase in slow logs?](https://discuss.elastic.co/t/do-very-large-segments-lead-to-a-significant-increase-in-slow-logs/369409)

<div class="topic-metadata">

**Author:** [@wangxr1985](https://discuss.elastic.co/u/wangxr1985)\
**Replies:** 0\
**Last updated:** [October 25, 2024, 9:35am UTC](https://discuss.elastic.co/t/do-very-large-segments-lead-to-a-significant-increase-in-slow-logs/369409 "2024-10-25T09:35:44Z")

</div>

I have an Elasticsearch index that continuously receives new data, along with a certain proportion of update and delete operations. As a result, the docs.deleted count for this index is gradually increasing, and after a …

---

## [GraphQL Connector Object to ID mapping rookie question](https://discuss.elastic.co/t/graphql-connector-object-to-id-mapping-rookie-question/369406)

<div class="topic-metadata">

**Author:** [@hairyJerry](https://discuss.elastic.co/u/hairyJerry)\
**Replies:** 0\
**Last updated:** [October 25, 2024, 9:28am UTC](https://discuss.elastic.co/t/graphql-connector-object-to-id-mapping-rookie-question/369406 "2024-10-25T09:28:10Z")

</div>

Hello, I am trying to index a small test GraphQL data as a proof of concept. Having no better Ideas, I decided to map over the edges, i.e. the response I am trying to map looks like this: { "data": { "getIt…

---

## [Regenerate certificates](https://discuss.elastic.co/t/regenerate-certificates/368238)

<div class="topic-metadata">

**Author:** [@cyberzlo](https://discuss.elastic.co/u/cyberzlo)\
**Replies:** 1\
**Last updated:** [October 25, 2024, 7:17am UTC](https://discuss.elastic.co/t/regenerate-certificates/368238 "2024-10-25T07:17:41Z")

</div>

How can I regenerate certificates same as Ubuntu package is doing it after install? How this installation script looks like / where can I found it? I need extend certificate (regenerate) after 2 years. Looks like there i…

---

## [Elasticsearch Overview metrics visualizations (search/indexing rate)](https://discuss.elastic.co/t/elasticsearch-overview-metrics-visualizations-search-indexing-rate/369387)

<div class="topic-metadata">

**Author:** [@s.buksa](https://discuss.elastic.co/u/s.buksa)\
**Replies:** 0\
**Last updated:** [October 24, 2024, 10:32pm UTC](https://discuss.elastic.co/t/elasticsearch-overview-metrics-visualizations-search-indexing-rate/369387 "2024-10-24T22:32:41Z")

</div>

Hello, Could someone, please, explain how metrics in Elasticsearch Overview dashboard visualizations are calculated? I am trying to understand what are functions behind the following visualizations: Search Rate (/s) S…

---

## [A way to reduce mapping fields](https://discuss.elastic.co/t/a-way-to-reduce-mapping-fields/369363)

<div class="topic-metadata">

**Author:** [@913043599](https://discuss.elastic.co/u/913043599)\
**Replies:** 3\
**Last updated:** [October 25, 2024, 2:17am UTC](https://discuss.elastic.co/t/a-way-to-reduce-mapping-fields/369363 "2024-10-25T02:17:50Z")

</div>

Hi all: I have discovered a method for reducing the elasticsearch fields. For instance, if there are three keyword fields in an index and they are solely utilized for term queries, then I directly employ a single keywor…

---

## [ILM Downsample Failed with logs containing a lot of "Duplicate field 'min'" messages](https://discuss.elastic.co/t/ilm-downsample-failed-with-logs-containing-a-lot-of-duplicate-field-min-messages/360395)

<div class="topic-metadata">

**Author:** [@jerrac](https://discuss.elastic.co/u/jerrac)\
**Replies:** 2\
**Last updated:** [October 24, 2024, 10:44pm UTC](https://discuss.elastic.co/t/ilm-downsample-failed-with-logs-containing-a-lot-of-duplicate-field-min-messages/360395 "2024-10-24T22:44:56Z")

</div>

Hey all, I have a bunch of indices stuck when they try to downsample. They're all elasticsearch monitor related indices coming from the Elastic Agent Elasticsearch integration. When I manually tell ILM to try again, I …

---

## [Just now downloaded Elasticsearch 8.15.3, Getting the following error](https://discuss.elastic.co/t/just-now-downloaded-elasticsearch-8-15-3-getting-the-following-error/369351)

<div class="topic-metadata">

**Author:** [@ajaytavva](https://discuss.elastic.co/u/ajaytavva)\
**Replies:** 1\
**Last updated:** [October 24, 2024, 10:25pm UTC](https://discuss.elastic.co/t/just-now-downloaded-elasticsearch-8-15-3-getting-the-following-error/369351 "2024-10-24T22:25:47Z")

</div>

So, I was getting this error. After the first time I tried running the elasticsearch.bat file Any help is appreciated warning: ignoring JAVA\_HOME=C:\\Program Files\\Java\\jdk-17; using bundled JDK Oct 24, 2024 3:52:55 AM …

---

## [SSO not working on ECK with Oracle cloud IDP](https://discuss.elastic.co/t/sso-not-working-on-eck-with-oracle-cloud-idp/369239)

<div class="topic-metadata">

**Author:** [@hsinha09](https://discuss.elastic.co/u/hsinha09)\
**Replies:** 2\
**Last updated:** [October 24, 2024, 7:48pm UTC](https://discuss.elastic.co/t/sso-not-working-on-eck-with-oracle-cloud-idp/369239 "2024-10-24T19:48:15Z")

</div>

Hi, I am trying to configure SSO on elasticsearch. While login, it is redirecting to the SSO auth page and asks for username and password, followed by auth code. Once the auth code is entered, I am getting 404 - not fo…

---

## [Return date fields as long numbers when using synthetic \_source and having format of date as epoch\_millis](https://discuss.elastic.co/t/return-date-fields-as-long-numbers-when-using-synthetic-source-and-having-format-of-date-as-epoch-millis/369383)

<div class="topic-metadata">

**Author:** [@dbenesj](https://discuss.elastic.co/u/dbenesj)\
**Replies:** 0\
**Last updated:** [October 24, 2024, 6:57pm UTC](https://discuss.elastic.co/t/return-date-fields-as-long-numbers-when-using-synthetic-source-and-having-format-of-date-as-epoch-millis/369383 "2024-10-24T18:57:11Z")

</div>

We are using synthetic \_source and date fields with format defined as epoch\_millis. Our expectation would be to get such fields as long number but we get them as strings. As we understand it might be necessary when date…

---

## [Setting up Elastic - Failed to allocate closure](https://discuss.elastic.co/t/setting-up-elastic-failed-to-allocate-closure/369379)

<div class="topic-metadata">

**Author:** [@greenmachine](https://discuss.elastic.co/u/greenmachine)\
**Replies:** 0\
**Last updated:** [October 24, 2024, 6:34pm UTC](https://discuss.elastic.co/t/setting-up-elastic-failed-to-allocate-closure/369379 "2024-10-24T18:34:28Z")

</div>

Getting the Failed to allocate closure error when trying to start elasticsearch. We've added Environment=ES\_TMPDIR=/usr/share/elasticsearch/tmp to the services file, but still getting the same error.

---

## [Elasticsearch service won't start on Ubuntu 22.04 after a reboot](https://discuss.elastic.co/t/elasticsearch-service-wont-start-on-ubuntu-22-04-after-a-reboot/369342)

<div class="topic-metadata">

**Author:** [@morgandally](https://discuss.elastic.co/u/morgandally)\
**Replies:** 1\
**Last updated:** [October 24, 2024, 6:11pm UTC](https://discuss.elastic.co/t/elasticsearch-service-wont-start-on-ubuntu-22-04-after-a-reboot/369342 "2024-10-24T18:11:54Z")

</div>

I installed Elasticsearch and Kibana yesterday and it worked fine, i rebooted the VM overnight and this morning it will not start the Elasticsearch service. When I go to the IP address I get the message that the Kibana S…

---

## [Agent log level sending info & debug, how to change level](https://discuss.elastic.co/t/agent-log-level-sending-info-debug-how-to-change-level/369370)

<div class="topic-metadata">

**Author:** [@rugenl](https://discuss.elastic.co/u/rugenl)\
**Replies:** 8\
**Last updated:** [October 24, 2024, 5:48pm UTC](https://discuss.elastic.co/t/agent-log-level-sending-info-debug-how-to-change-level/369370 "2024-10-24T17:48:22Z")

</div>

I found that my busiest index was a logs-elastic\_agent.filebeat-default index, so I looked into what was being sent. I found a simple custom logs (filebeat) agent that was sending at debug level. Over 8 million events …

---

## [How to resume Elasticsearch log retrieval after partial write in .NET](https://discuss.elastic.co/t/how-to-resume-elasticsearch-log-retrieval-after-partial-write-in-net/369368)

<div class="topic-metadata">

**Author:** [@Mahesh\_Kumar\_S](https://discuss.elastic.co/u/Mahesh_Kumar_S)\
**Replies:** 0\
**Last updated:** [October 24, 2024, 1:56pm UTC](https://discuss.elastic.co/t/how-to-resume-elasticsearch-log-retrieval-after-partial-write-in-net/369368 "2024-10-24T13:56:23Z")

</div>

Hello Elastic Community, I’m working on an application that fetches logs from Elasticsearch and writes them to an XML file. However, I’m running into an issue when managing large volumes of data, and I’m seeking advice …

---

## [Plan Failed during restart of deployment](https://discuss.elastic.co/t/plan-failed-during-restart-of-deployment/368805)

<div class="topic-metadata">

**Author:** [@Marcelo\_Mendes](https://discuss.elastic.co/u/Marcelo_Mendes)\
**Replies:** 1\
**Last updated:** [October 15, 2024, 1:09am UTC](https://discuss.elastic.co/t/plan-failed-during-restart-of-deployment/368805 "2024-10-15T01:09:41Z")

</div>

I'm trying to restart Elasticsearch located on Azure deployment, but its showing an error "Plan Failed", any one can help my with any suggestion of troubleshooting?

---

## [Performance search ES 7.17 vs 8.14](https://discuss.elastic.co/t/performance-search-es-7-17-vs-8-14/369358)

<div class="topic-metadata">

**Author:** [@INS](https://discuss.elastic.co/u/INS)\
**Replies:** 0\
**Last updated:** [October 24, 2024, 12:21pm UTC](https://discuss.elastic.co/t/performance-search-es-7-17-vs-8-14/369358 "2024-10-24T12:21:18Z")

</div>

Hi Can You describe in details {summary} what is the sensitive diff between ES 7.17 vs 8.14 in search engine perspective. Anyone from You have any experience?

---

## [Is semantic search on multiple fields possible with text\_similarity\_reranker retriever?](https://discuss.elastic.co/t/is-semantic-search-on-multiple-fields-possible-with-text-similarity-reranker-retriever/369352)

<div class="topic-metadata">

**Author:** [@JdKock](https://discuss.elastic.co/u/JdKock)\
**Replies:** 0\
**Last updated:** [October 24, 2024, 11:20am UTC](https://discuss.elastic.co/t/is-semantic-search-on-multiple-fields-possible-with-text-similarity-reranker-retriever/369352 "2024-10-24T11:20:52Z")

</div>

I have an index with document with the fields "title", "description" and "Content". With this index I did a pilot with semantic search on all 3 fields with the rff retriever. This works fine. Now I saw the new "text\_si…

---

## [Sync between multiple indices](https://discuss.elastic.co/t/sync-between-multiple-indices/369331)

<div class="topic-metadata">

**Author:** [@prempatell](https://discuss.elastic.co/u/prempatell)\
**Replies:** 1\
**Last updated:** [October 24, 2024, 8:36am UTC](https://discuss.elastic.co/t/sync-between-multiple-indices/369331 "2024-10-24T08:36:55Z")

</div>

Hi, I got a requirement of indexing a document in multiple indices each having their own ingestion pipeline. Constraint: the API call to add a document will only be done to primary index. Need to build a sync such tha…

---

## [Trouble using new .order() on datehistogram after upgrading](https://discuss.elastic.co/t/trouble-using-new-order-on-datehistogram-after-upgrading/369224)

<div class="topic-metadata">

**Author:** [@Krikkits](https://discuss.elastic.co/u/Krikkits)\
**Replies:** 1\
**Last updated:** [October 24, 2024, 8:26am UTC](https://discuss.elastic.co/t/trouble-using-new-order-on-datehistogram-after-upgrading/369224 "2024-10-24T08:26:04Z")

</div>

I recently upgraded to Spring 3 which means there were small adjustments needed for some of my queries/aggregations written in elasticsearch java. I cannot figure out how to get the .order(SortOrder.Asc) to work again in…

---

## ['no\_http\_response\_exception' Issue With Watcher](https://discuss.elastic.co/t/no-http-response-exception-issue-with-watcher/369289)

<div class="topic-metadata">

**Author:** [@ameindel](https://discuss.elastic.co/u/ameindel)\
**Replies:** 1\
**Last updated:** [October 23, 2024, 6:50pm UTC](https://discuss.elastic.co/t/no-http-response-exception-issue-with-watcher/369289 "2024-10-23T18:50:53Z")

</div>

Hello! I'm having an issue with a Watcher that I'm try to create that will call the ES /\_cluster/health API endpoint. I'm using the Watcher example from the documentation here pretty much verbatim and am getting a 'no\_…

---

## [What is the reason for not reading from the HDD storage disk?](https://discuss.elastic.co/t/what-is-the-reason-for-not-reading-from-the-hdd-storage-disk/369298)

<div class="topic-metadata">

**Author:** [@dsagent](https://discuss.elastic.co/u/dsagent)\
**Replies:** 0\
**Last updated:** [October 23, 2024, 5:32pm UTC](https://discuss.elastic.co/t/what-is-the-reason-for-not-reading-from-the-hdd-storage-disk/369298 "2024-10-23T17:32:17Z")

</div>

hi I have a Linux environment in which there are two disks to store data, one SSD and the other HDD, and I installed elasticsearch on the SSD disk and made a data storage path to the HDD disk, and it was normal and serv…

---

## [Alert Rule with DSL finding if most recent value has a true property](https://discuss.elastic.co/t/alert-rule-with-dsl-finding-if-most-recent-value-has-a-true-property/369168)

<div class="topic-metadata">

**Author:** [@jeffabar](https://discuss.elastic.co/u/jeffabar)\
**Replies:** 1\
**Last updated:** [October 23, 2024, 4:24pm UTC](https://discuss.elastic.co/t/alert-rule-with-dsl-finding-if-most-recent-value-has-a-true-property/369168 "2024-10-23T16:24:59Z")

</div>

I am looking to build an alert rule where if the latest record for a module has an unexpected\_state == true trigger the rule and if the most recent state is not unexpected\_state == true generate no record which will allo…

---

## [Too many smaller indices. shards is creating issue](https://discuss.elastic.co/t/too-many-smaller-indices-shards-is-creating-issue/369271)

<div class="topic-metadata">

**Author:** [@Jay\_Timbadia](https://discuss.elastic.co/u/Jay_Timbadia)\
**Replies:** 20\
**Last updated:** [October 23, 2024, 12:35pm UTC](https://discuss.elastic.co/t/too-many-smaller-indices-shards-is-creating-issue/369271 "2024-10-23T12:35:17Z")

</div>

Hello all, I have a requirement where we have 10s of thousands of smaller indices (~10-20mb). Now the issue is each index is creating a 2 shard(1 primary & 1 replica). So for 10s of thousands of indexes, it will be a …

[Previous page](https://discuss.elastic.co/c/elastic-stack/elasticsearch/6.md?page=66)

[Next page](https://discuss.elastic.co/c/elastic-stack/elasticsearch/6.md?page=68)
