# Elasticsearch

**URL:** https://discuss.elastic.co/c/elastic-stack/elasticsearch/6.md?page=87

[Latest](https://discuss.elastic.co/latest.md) · [Categories](https://discuss.elastic.co/categories.md) · [Tags](https://discuss.elastic.co/tags.md)

**Page:** 88

---

## [Unable to Apply Configuration Changes Due to Errors \[ Critical Issue\]](https://discuss.elastic.co/t/unable-to-apply-configuration-changes-due-to-errors-critical-issue/364626)

<div class="topic-metadata">

**Author:** [@Raghavendra\_Mendon](https://discuss.elastic.co/u/Raghavendra_Mendon)\
**Replies:** 0\
**Last updated:** [August 8, 2024, 7:13pm UTC](https://discuss.elastic.co/t/unable-to-apply-configuration-changes-due-to-errors-critical-issue/364626 "2024-08-08T19:13:43Z")

</div>

Due to a recent change in index ILM configuration, our hot storage, which is 2GB out of 60GB, has reached 100% capacity. As a result, the Elastic Cloud service is down, and the new configuration changes are not being app…

---

## [Hot Warm Cold - not going to cold?](https://discuss.elastic.co/t/hot-warm-cold-not-going-to-cold/364557)

<div class="topic-metadata">

**Author:** [@learningelastic](https://discuss.elastic.co/u/learningelastic)\
**Replies:** 4\
**Last updated:** [August 8, 2024, 5:20pm UTC](https://discuss.elastic.co/t/hot-warm-cold-not-going-to-cold/364557 "2024-08-08T17:20:38Z")

</div>

I'm learning about ILM and hot warm cold structure. For some reason, my indices aren't going to the cold node OR being deleted. I will show my experiment below and someone tell me what I did wrong? I have 3 nodes and t…

---

## [ILM Policy Error](https://discuss.elastic.co/t/ilm-policy-error/364556)

<div class="topic-metadata">

**Author:** [@linux\_admin](https://discuss.elastic.co/u/linux_admin)\
**Replies:** 8\
**Last updated:** [August 8, 2024, 3:41pm UTC](https://discuss.elastic.co/t/ilm-policy-error/364556 "2024-08-08T15:41:15Z")

</div>

I am using ELK version 8.12.0 for collecting kong logs using kong udp-logs. I am getting the below ILM error for one old index. How to solve it, please? \[2024-08-07T22:14:31,004\]\[WARN \]\[o.e.x.i.ExecuteStepsUpdateTask\] …

---

## [Data for the index is stored in only one shard](https://discuss.elastic.co/t/data-for-the-index-is-stored-in-only-one-shard/364613)

<div class="topic-metadata">

**Author:** [@abhadauria](https://discuss.elastic.co/u/abhadauria)\
**Replies:** 1\
**Last updated:** [August 8, 2024, 2:21pm UTC](https://discuss.elastic.co/t/data-for-the-index-is-stored-in-only-one-shard/364613 "2024-08-08T14:21:04Z")

</div>

I am using ES version 7.17, I have a doubt that my index is having settings that it is associated with 100 shards with replication of 2, however all the data for the index is getting stored in only 1 shard. Please let …

---

## [Requirements for precision tuning to work](https://discuss.elastic.co/t/requirements-for-precision-tuning-to-work/364607)

<div class="topic-metadata">

**Author:** [@tomekred](https://discuss.elastic.co/u/tomekred)\
**Replies:** 0\
**Last updated:** [August 8, 2024, 12:49pm UTC](https://discuss.elastic.co/t/requirements-for-precision-tuning-to-work/364607 "2024-08-08T12:49:49Z")

</div>

Hello All, Recently I've been trying to make App Search working on an existing index (and modifying the mapping accordingly) , but I am not sure if I understand the process correctly. I would be very pleased if you cou…

---

## [ElasticSearch services Failed because none of the ciphers......are supported by this JVM](https://discuss.elastic.co/t/elasticsearch-services-failed-because-none-of-the-ciphers-are-supported-by-this-jvm/364534)

<div class="topic-metadata">

**Author:** [@william13110](https://discuss.elastic.co/u/william13110)\
**Replies:** 7\
**Last updated:** [August 8, 2024, 11:47am UTC](https://discuss.elastic.co/t/elasticsearch-services-failed-because-none-of-the-ciphers-are-supported-by-this-jvm/364534 "2024-08-08T11:47:56Z")

</div>

\[2024-08-07T16:03:33,738\]\[ERROR\]\[o.e.b.Bootstrap \] \[idrive-AP-srv\] Exception java.lang.IllegalStateException: failed to load plugin class \[org.elasticsearch.xpack.core.XPackPlugin\] at org.elasticsearch.plugins.…

---

## [Update field meta of dynamic object in mappings using NEST](https://discuss.elastic.co/t/update-field-meta-of-dynamic-object-in-mappings-using-nest/364594)

<div class="topic-metadata">

**Author:** [@rdmzcn](https://discuss.elastic.co/u/rdmzcn)\
**Replies:** 0\
**Last updated:** [August 8, 2024, 10:26am UTC](https://discuss.elastic.co/t/update-field-meta-of-dynamic-object-in-mappings-using-nest/364594 "2024-08-08T10:26:35Z")

</div>

Hello everyone, I have a nested field with dynamic=true as below. I keep the tr/en localizations of the fields in meta. How can I change the meta when adding a new field due to dynamic mapping in a new insert request? {…

---

## [Natural language to Query DSL building](https://discuss.elastic.co/t/natural-language-to-query-dsl-building/364586)

<div class="topic-metadata">

**Author:** [@Souvik\_Das](https://discuss.elastic.co/u/Souvik_Das)\
**Replies:** 0\
**Last updated:** [August 8, 2024, 8:26am UTC](https://discuss.elastic.co/t/natural-language-to-query-dsl-building/364586 "2024-08-08T08:26:39Z")

</div>

Hi Folks, I want to build an app that converts natural language query to elasticsearch query DSL. I have gone through How to use Elasticsearch to prompt ChatGPT with natural language | Elastic Blog Are there any refere…

---

## [Elasticsearch - es rejected execution exception](https://discuss.elastic.co/t/elasticsearch-es-rejected-execution-exception/364577)

<div class="topic-metadata">

**Author:** [@Dylan\_Juan](https://discuss.elastic.co/u/Dylan_Juan)\
**Replies:** 0\
**Last updated:** [August 8, 2024, 6:49am UTC](https://discuss.elastic.co/t/elasticsearch-es-rejected-execution-exception/364577 "2024-08-08T06:49:17Z")

</div>

Hi everyone, currently i'm facing an issue with my elasticsearch cluster. The version is very old which is ES 5.6.2, the logs is coming from Oracle SOA cluster which is collected using GELF and then into rabbitmq queue, …

---

## [How to remove expired SSL certificate](https://discuss.elastic.co/t/how-to-remove-expired-ssl-certificate/364280)

<div class="topic-metadata">

**Author:** [@Chuck\_Reynolds](https://discuss.elastic.co/u/Chuck_Reynolds)\
**Replies:** 6\
**Last updated:** [August 8, 2024, 1:28am UTC](https://discuss.elastic.co/t/how-to-remove-expired-ssl-certificate/364280 "2024-08-08T01:28:00Z")

</div>

I have a ssl cert that our webops team created for me a year ago and now it has expired. I've added copied the new ssl cert to each server and pointed this line to in the elasticsearch.yml file xpack.security.http.ssl.…

---

## [How to convert hex value into decimal in painless language](https://discuss.elastic.co/t/how-to-convert-hex-value-into-decimal-in-painless-language/364554)

<div class="topic-metadata">

**Author:** [@nabeel1](https://discuss.elastic.co/u/nabeel1)\
**Replies:** 1\
**Last updated:** [August 7, 2024, 6:34pm UTC](https://discuss.elastic.co/t/how-to-convert-hex-value-into-decimal-in-painless-language/364554 "2024-08-07T18:34:17Z")

</div>

Can anyone inform the syntax to convert a value from hex to decimal for a bucket index .. e.g. i want to convert this substring which is the IP in hex to a IP in decimal .. so, from string need to convert to hex and t…

---

## [Autosuggestion service](https://discuss.elastic.co/t/autosuggestion-service/364547)

<div class="topic-metadata">

**Author:** [@kosyakla](https://discuss.elastic.co/u/kosyakla)\
**Replies:** 0\
**Last updated:** [August 7, 2024, 3:17pm UTC](https://discuss.elastic.co/t/autosuggestion-service/364547 "2024-08-07T15:17:46Z")

</div>

Hello everyone, I'm thinking of building a suggestion service, similar to what you can see in google for example, so trying to wrap my head around Elasticsearch. Let's say we have a steam of users data which we can tok…

---

## [Elastic Search( Store XML data as just a string)](https://discuss.elastic.co/t/elastic-search-store-xml-data-as-just-a-string/364386)

<div class="topic-metadata">

**Author:** [@apoorvleo](https://discuss.elastic.co/u/apoorvleo)\
**Replies:** 3\
**Last updated:** [August 7, 2024, 1:12pm UTC](https://discuss.elastic.co/t/elastic-search-store-xml-data-as-just-a-string/364386 "2024-08-07T13:12:27Z")

</div>

Hi Team, I am using kibana and ES versions 8.14. I am sending a json through Java Bulk call API {"uuid": string type instance: string type inputJson : JsonNode type xmlmxmessage: xmlbutinStringformat } this is th…

---

## [Suggest query issue](https://discuss.elastic.co/t/suggest-query-issue/364514)

<div class="topic-metadata">

**Author:** [@jahedi](https://discuss.elastic.co/u/jahedi)\
**Replies:** 2\
**Last updated:** [August 7, 2024, 1:05pm UTC](https://discuss.elastic.co/t/suggest-query-issue/364514 "2024-08-07T13:05:16Z")

</div>

Hi, I am using Suggest query for a Did-you-mean functionality based on this tutorial Create a simple “did you mean” — ElasticSearch but there is an issue. If a typo happens in the middle of a word, the suggest query r…

---

## [Continuos warning throwing up in fresh installation of a 3 node elk cluster's 1st node. Please help to sort out](https://discuss.elastic.co/t/continuos-warning-throwing-up-in-fresh-installation-of-a-3-node-elk-clusters-1st-node-please-help-to-sort-out/364481)

<div class="topic-metadata">

**Author:** [@martianzz](https://discuss.elastic.co/u/martianzz)\
**Replies:** 2\
**Last updated:** [August 7, 2024, 11:10am UTC](https://discuss.elastic.co/t/continuos-warning-throwing-up-in-fresh-installation-of-a-3-node-elk-clusters-1st-node-please-help-to-sort-out/364481 "2024-08-07T11:10:52Z")

</div>

Kindly tell me why this error is shown in a fresh 3 node cluster of elk stack \*2024-08-06T19:47:07,586\]\[WARN \]\[o.e.h.AbstractHttpServerTransport\] \[elk-stack-node1.kseb.in\] caught exception while handling client http tra…

---

## [Pdf Parsing Issues when using FS crawler](https://discuss.elastic.co/t/pdf-parsing-issues-when-using-fs-crawler/364488)

<div class="topic-metadata">

**Author:** [@saifstech26](https://discuss.elastic.co/u/saifstech26)\
**Replies:** 4\
**Last updated:** [August 7, 2024, 9:07am UTC](https://discuss.elastic.co/t/pdf-parsing-issues-when-using-fs-crawler/364488 "2024-08-07T09:07:28Z")

</div>

Hi @dadoonet, I have started using FS crawler recently. We have a requirement to crawl all files on the local file system, most of which are PDFs along with other doc formats. The thing with these PDFs is that all PDFs …

---

## [gce plugin with private access](https://discuss.elastic.co/t/gce-plugin-with-private-access/364492)

<div class="topic-metadata">

**Author:** [@vaboston](https://discuss.elastic.co/u/vaboston)\
**Replies:** 2\
**Last updated:** [August 7, 2024, 8:44am UTC](https://discuss.elastic.co/t/gce-plugin-with-private-access/364492 "2024-08-07T08:44:15Z")

</div>

Hello, I'm using GCE discovery plugin on GCP VM, and i don't have nat gateway to join metadata.google.internal. I activated private access on my subnet and now i can use private.googleapis.com to ask metadata. But gce-d…

---

## [More Index Latency with add\_id proc in Filebeat](https://discuss.elastic.co/t/more-index-latency-with-add-id-proc-in-filebeat/364518)

<div class="topic-metadata">

**Author:** [@demudrol](https://discuss.elastic.co/u/demudrol)\
**Replies:** 1\
**Last updated:** [August 7, 2024, 8:21am UTC](https://discuss.elastic.co/t/more-index-latency-with-add-id-proc-in-filebeat/364518 "2024-08-07T08:21:58Z")

</div>

Hi! We have logging structure like with: Application -\> docker json -\> Filebeat file harvester -\> Kafka Topic -\> Filebeat retranslator from Topic to Elasticsearch. Sometimes there is a lot of event deduplication in Ela…

---

## [Your connector has not connected to Search](https://discuss.elastic.co/t/your-connector-has-not-connected-to-search/364499)

<div class="topic-metadata">

**Author:** [@Dedicated\_Server](https://discuss.elastic.co/u/Dedicated_Server)\
**Replies:** 6\
**Last updated:** [August 7, 2024, 7:24am UTC](https://discuss.elastic.co/t/your-connector-has-not-connected-to-search/364499 "2024-08-07T07:24:13Z")

</div>

I am running mongo, elastic, kibana, and elastic-connectors in docker containers with docker-compose. I setup the connector and config, and it even connects in docker logs. \[FMWK\]\[21:01:02\]\[INFO\] Running connector serv…

---

## [Unable to get local issuer certificate (\_ssl.c:1007)))](https://discuss.elastic.co/t/unable-to-get-local-issuer-certificate-ssl-c-1007/364462)

<div class="topic-metadata">

**Author:** [@SaraS](https://discuss.elastic.co/u/SaraS)\
**Replies:** 2\
**Last updated:** [August 7, 2024, 6:46am UTC](https://discuss.elastic.co/t/unable-to-get-local-issuer-certificate-ssl-c-1007/364462 "2024-08-07T06:46:41Z")

</div>

Hello. I run my elasticsearch via docker compose and i set ssl security for it and now i want to connect Elasticsearch from remote server when i curl -X GET -u user:pass -k https://serverIP:9200/\_cat/indices i can see…

---

## [Remote reindex No route to host error despite remote cluster returning \_cluster/health info](https://discuss.elastic.co/t/remote-reindex-no-route-to-host-error-despite-remote-cluster-returning-cluster-health-info/364187)

<div class="topic-metadata">

**Author:** [@fidsamuraiCrelio](https://discuss.elastic.co/u/fidsamuraiCrelio)\
**Replies:** 7\
**Last updated:** [August 7, 2024, 4:11am UTC](https://discuss.elastic.co/t/remote-reindex-no-route-to-host-error-despite-remote-cluster-returning-cluster-health-info/364187 "2024-08-07T04:11:59Z")

</div>

Hi All! We use Elasticsearch 6.8.0 as a search engine for our application logs. Unfortunately our cluster crashed and some indices were unrecoverable. Since the cluster was in red state we spun up a new cluster so tha…

---

## [Elastic mapping flattened vs field wise](https://discuss.elastic.co/t/elastic-mapping-flattened-vs-field-wise/362151)

<div class="topic-metadata">

**Author:** [@Moni\_Hazarika](https://discuss.elastic.co/u/Moni_Hazarika)\
**Replies:** 9\
**Last updated:** [August 7, 2024, 3:20am UTC](https://discuss.elastic.co/t/elastic-mapping-flattened-vs-field-wise/362151 "2024-08-07T03:20:14Z")

</div>

In our MongoDB if we have a collection where we have multiple field types like array, multi-level object, strings, numbers, dates etc. sample of a nested field/object is like - "ValuesDocument ":{"field1":"Value1","fiel…

---

## [How to get match count in string field for one document?](https://discuss.elastic.co/t/how-to-get-match-count-in-string-field-for-one-document/364501)

<div class="topic-metadata">

**Author:** [@karaagacylmaz](https://discuss.elastic.co/u/karaagacylmaz)\
**Replies:** 0\
**Last updated:** [August 6, 2024, 9:47pm UTC](https://discuss.elastic.co/t/how-to-get-match-count-in-string-field-for-one-document/364501 "2024-08-06T21:47:44Z")

</div>

Here is my ex document: { "categoryId" : 8, "productId" : 12, "starLevel" : 4.2, "reviewList" : \[ "foo", "bar", "foo bar", "foo bar f…

---

## [Index \[.security-profile-8\] is unavailable","error":{"message":"unavailable\_shards\_exception](https://discuss.elastic.co/t/index-security-profile-8-is-unavailable-error-message-unavailable-shards-exception/364470)

<div class="topic-metadata">

**Author:** [@Raghav\_Gaur](https://discuss.elastic.co/u/Raghav_Gaur)\
**Replies:** 1\
**Last updated:** [August 6, 2024, 7:55pm UTC](https://discuss.elastic.co/t/index-security-profile-8-is-unavailable-error-message-unavailable-shards-exception/364470 "2024-08-06T19:55:45Z")

</div>

I am not able to login to kibana because of the error index \[.security-profile-8\] is unavailable","error":{"message":"unavailable\_shards\_exception. Primary and replica both shards are not available because the node havi…

---

## [Tier Preference is not using the secondary option for replica](https://discuss.elastic.co/t/tier-preference-is-not-using-the-secondary-option-for-replica/364008)

<div class="topic-metadata">

**Author:** [@jsheely](https://discuss.elastic.co/u/jsheely)\
**Replies:** 4\
**Last updated:** [August 6, 2024, 5:55pm UTC](https://discuss.elastic.co/t/tier-preference-is-not-using-the-secondary-option-for-replica/364008 "2024-08-06T17:55:13Z")

</div>

I am trying to utilize the \_tier\_preference setting of "data\_hot,data\_warm" so that all of my new indexes primary goes onto the HOT node and the replica for that index goes onto the WARM node. However it ups the data on…

---

## [Data stream index template is resetting](https://discuss.elastic.co/t/data-stream-index-template-is-resetting/363307)

<div class="topic-metadata">

**Author:** [@jsheely](https://discuss.elastic.co/u/jsheely)\
**Replies:** 1\
**Last updated:** [August 4, 2024, 11:28pm UTC](https://discuss.elastic.co/t/data-stream-index-template-is-resetting/363307 "2024-08-04T23:28:14Z")

</div>

One of my data stream index templates settings and mappings keeps resetting to the default values and I can't figure out why The primary setting I've changed is total\_fields limit from 2,000 to 10,000 but for some reaso…

---

## [Can I get refund by a mistake in the Elastic Cloud Platform?](https://discuss.elastic.co/t/can-i-get-refund-by-a-mistake-in-the-elastic-cloud-platform/364292)

<div class="topic-metadata">

**Author:** [@Luis\_Felipe\_Antunes](https://discuss.elastic.co/u/Luis_Felipe_Antunes)\
**Replies:** 4\
**Last updated:** [August 6, 2024, 4:25pm UTC](https://discuss.elastic.co/t/can-i-get-refund-by-a-mistake-in-the-elastic-cloud-platform/364292 "2024-08-06T16:25:35Z")

</div>

Hey everyone, I'm looking for some help with a billing issue on Elastic Cloud. I received an email notification that my credit card was charged $407.23, but I didn't mean to incur any costs. I was just exploring the pla…

---

## [Understanding operations\_behind in transform stats](https://discuss.elastic.co/t/understanding-operations-behind-in-transform-stats/363281)

<div class="topic-metadata">

**Author:** [@gueri](https://discuss.elastic.co/u/gueri)\
**Replies:** 2\
**Last updated:** [August 6, 2024, 2:10pm UTC](https://discuss.elastic.co/t/understanding-operations-behind-in-transform-stats/363281 "2024-08-06T14:10:55Z")

</div>

Hello, I have a question about the metric operations\_behind when I call the transform stats API. The elastic doc says the following about operations\_behind : The number of operations that have occurred on the source …

---

## [Check your network connection and try again. Code 413](https://discuss.elastic.co/t/check-your-network-connection-and-try-again-code-413/363568)

<div class="topic-metadata">

**Author:** [@Leomar.V](https://discuss.elastic.co/u/Leomar.V)\
**Replies:** 1\
**Last updated:** [August 6, 2024, 2:03pm UTC](https://discuss.elastic.co/t/check-your-network-connection-and-try-again-code-413/363568 "2024-08-06T14:03:29Z")

</div>

Good morning, All good? I wanted to know if you know the cause of this error? This error only happens when I create the dashbords, it gives this error, but if I change the field name it resolves it, but then it gives t…

---

## [Stackoverflow due to long request string](https://discuss.elastic.co/t/stackoverflow-due-to-long-request-string/364456)

<div class="topic-metadata">

**Author:** [@futonirou.sarami](https://discuss.elastic.co/u/futonirou.sarami)\
**Replies:** 2\
**Last updated:** [August 6, 2024, 12:44pm UTC](https://discuss.elastic.co/t/stackoverflow-due-to-long-request-string/364456 "2024-08-06T12:44:23Z")

</div>

Occurrence Throwing a 4000 character query against an Elasticsearch data node causes a Stackoverflow and stops the Elasticsearch service. Elasticsearch Version 8.6.2 Requests 1.Whether or not a similar problem occur…

[Previous page](https://discuss.elastic.co/c/elastic-stack/elasticsearch/6.md?page=86)

[Next page](https://discuss.elastic.co/c/elastic-stack/elasticsearch/6.md?page=88)
