# Kibana

**URL:** https://discuss.elastic.co/c/elastic-stack/kibana/7.md?page=122

[Latest](https://discuss.elastic.co/latest.md) · [Categories](https://discuss.elastic.co/categories.md) · [Tags](https://discuss.elastic.co/tags.md)

**Page:** 123

---

## [Kibana 8.7.1 plugin fails to launch](https://discuss.elastic.co/t/kibana-8-7-1-plugin-fails-to-launch/333506)

<div class="topic-metadata">

**Author:** [@kbujold\_wr](https://discuss.elastic.co/u/kbujold_wr)\
**Replies:** 1\
**Last updated:** [May 19, 2023, 1:15pm UTC](https://discuss.elastic.co/t/kibana-8-7-1-plugin-fails-to-launch/333506 "2023-05-19T13:15:12Z")

</div>

Hi, Our plugin which was working in ELK 8.6.2 is failing in 8.7.1 with this failure "\[FATAL\]\[root\] Error: Cannot find module '../../../../../../packages/kbn-config-schema'" This should still be supported? 'yarn kbn boo…

---

## [KIbana failover to a healthy ES node](https://discuss.elastic.co/t/kibana-failover-to-a-healthy-es-node/333574)

<div class="topic-metadata">

**Author:** [@zaeemmasood](https://discuss.elastic.co/u/zaeemmasood)\
**Replies:** 4\
**Last updated:** [May 18, 2023, 6:35pm UTC](https://discuss.elastic.co/t/kibana-failover-to-a-healthy-es-node/333574 "2023-05-18T18:35:15Z")

</div>

Hi All, We are facing an issue where Kibana does not failover to a healthy Elasticsearch node in case a node goes down. Login into Kibana console stops working unless the bad node is brought up. KIbana config is as fo…

---

## [Cannot remove or resolve metric alerts](https://discuss.elastic.co/t/cannot-remove-or-resolve-metric-alerts/333783)

<div class="topic-metadata">

**Author:** [@cfqnjohn](https://discuss.elastic.co/u/cfqnjohn)\
**Replies:** 0\
**Last updated:** [May 18, 2023, 3:44pm UTC](https://discuss.elastic.co/t/cannot-remove-or-resolve-metric-alerts/333783 "2023-05-18T15:44:22Z")

</div>

Hello, I have some alerts that were created for Disk Usage alerting. It seems that they triggered awhile back on April 19th, and have not updated since. The alert threshold was modified to 80% originally it was set to 7…

---

## [Referencing canvas variables with outputs of other variables](https://discuss.elastic.co/t/referencing-canvas-variables-with-outputs-of-other-variables/333775)

<div class="topic-metadata">

**Author:** [@dreynolds](https://discuss.elastic.co/u/dreynolds)\
**Replies:** 0\
**Last updated:** [May 18, 2023, 1:51pm UTC](https://discuss.elastic.co/t/referencing-canvas-variables-with-outputs-of-other-variables/333775 "2023-05-18T13:51:24Z")

</div>

I have multiple variables defined that have the number of hosts a department should have: hr\_hosts: 35, it\_hosts:45, acct\_hosts:5 I'm running a query to pull host scans, which includes the department names as a column …

---

## [Hiding non-indexed/ non-searchable fields in "Available fields" section in Kibana discover](https://discuss.elastic.co/t/hiding-non-indexed-non-searchable-fields-in-available-fields-section-in-kibana-discover/333723)

<div class="topic-metadata">

**Author:** [@Saindra\_K](https://discuss.elastic.co/u/Saindra_K)\
**Replies:** 1\
**Last updated:** [May 18, 2023, 10:50am UTC](https://discuss.elastic.co/t/hiding-non-indexed-non-searchable-fields-in-available-fields-section-in-kibana-discover/333723 "2023-05-18T10:50:45Z")

</div>

In Kibana discover is there a way to automatically hide the non indexed fields/ non searchable fields in "Available fields" ? I see in available fields setting, by filtering Searchable to Yes we can hide, but this is no…

---

## [Not Getting Kubernetes related filters in Kibana when exporting logs from Logstash](https://discuss.elastic.co/t/not-getting-kubernetes-related-filters-in-kibana-when-exporting-logs-from-logstash/333400)

<div class="topic-metadata">

**Author:** [@Akshay04](https://discuss.elastic.co/u/Akshay04)\
**Replies:** 1\
**Last updated:** [May 17, 2023, 11:44pm UTC](https://discuss.elastic.co/t/not-getting-kubernetes-related-filters-in-kibana-when-exporting-logs-from-logstash/333400 "2023-05-17T23:44:02Z")

</div>

Hello, I have configured Fluentbit in my k8s cluster to send logs to S3 and ELK stack to get logs from S3 and Visualise in Kibana. When I create Dataview in kibana for the Index, the kibana dashboard is not giving filte…

---

## [Is there a way to recover kibana\_x file?](https://discuss.elastic.co/t/is-there-a-way-to-recover-kibana-x-file/333319)

<div class="topic-metadata">

**Author:** [@ardit](https://discuss.elastic.co/u/ardit)\
**Replies:** 1\
**Last updated:** [May 17, 2023, 11:11pm UTC](https://discuss.elastic.co/t/is-there-a-way-to-recover-kibana-x-file/333319 "2023-05-17T23:11:43Z")

</div>

Is there any possibility to recover from lost kibana\_x index? \[opc@elasticsearch-2 ~\]$ curl -XGET http://localhost:9200/\_cat/shards/.kibana\_7.12.0\_001 .kibana\_7.12.0\_001 0 p UNASSIGNED .kibana\_7.12.0\_001 0 r UNASSIG…

---

## [Is it possible to have multiple SQL queries into the Expression Editor?](https://discuss.elastic.co/t/is-it-possible-to-have-multiple-sql-queries-into-the-expression-editor/333596)

<div class="topic-metadata">

**Author:** [@SamuelSMendes](https://discuss.elastic.co/u/SamuelSMendes)\
**Replies:** 1\
**Last updated:** [May 17, 2023, 3:15pm UTC](https://discuss.elastic.co/t/is-it-possible-to-have-multiple-sql-queries-into-the-expression-editor/333596 "2023-05-17T15:15:42Z")

</div>

For the context, I have a query that brings me data from the last 24hous. And would like to have a second column which will deal only with information from the last 6minutes. The thing is, if I do both like: @timestamp…

---

## [Working days - how to find](https://discuss.elastic.co/t/working-days-how-to-find/332404)

<div class="topic-metadata">

**Author:** [@TheyCallMeTrinity](https://discuss.elastic.co/u/TheyCallMeTrinity)\
**Replies:** 8\
**Last updated:** [May 17, 2023, 11:54am UTC](https://discuss.elastic.co/t/working-days-how-to-find/332404 "2023-05-17T11:54:04Z")

</div>

Hi, I have a problem. I'm getting data from the api which lists the rooms that users have booked. Each room has set working days and hours. I need to make a table where the Average real resource usage will be calculat…

---

## [How to show zero value in len](https://discuss.elastic.co/t/how-to-show-zero-value-in-len/333517)

<div class="topic-metadata">

**Author:** [@tonyaw](https://discuss.elastic.co/u/tonyaw)\
**Replies:** 4\
**Last updated:** [May 17, 2023, 9:21am UTC](https://discuss.elastic.co/t/how-to-show-zero-value-in-len/333517 "2023-05-17T09:21:33Z")

</div>

I had a search result which has non-zero per 2 hours. I want to use Lens to show a sawtooth graph per hour(contains both non-zero value and zero value). May I ask how to configure it? Currently, I got a straight line re…

---

## [Count filtering visualization](https://discuss.elastic.co/t/count-filtering-visualization/333527)

<div class="topic-metadata">

**Author:** [@clmtb](https://discuss.elastic.co/u/clmtb)\
**Replies:** 7\
**Last updated:** [May 17, 2023, 8:06am UTC](https://discuss.elastic.co/t/count-filtering-visualization/333527 "2023-05-17T08:06:51Z")

</div>

Hi all, I am trying to create a pretty simple visualization in Kibana in TSVB Table, with the count of different fields but with a filter applied. To be more precise, I want to get the count of every values higher than …

---

## [Mismatch between Elastic Query Aggretion and Kibana Visualize Function](https://discuss.elastic.co/t/mismatch-between-elastic-query-aggretion-and-kibana-visualize-function/333619)

<div class="topic-metadata">

**Author:** [@phong\_elastic](https://discuss.elastic.co/u/phong_elastic)\
**Replies:** 1\
**Last updated:** [May 17, 2023, 4:29am UTC](https://discuss.elastic.co/t/mismatch-between-elastic-query-aggretion-and-kibana-visualize-function/333619 "2023-05-17T04:29:42Z")

</div>

Hello everyone. I'm trying create a table that have the same data like the table in Lens Visualization by using the Elasticsearch Query. I'm confusing cause there's is a different between the data I get by the query an…

---

## [Kibana dashboard filters that recognize multiple views?](https://discuss.elastic.co/t/kibana-dashboard-filters-that-recognize-multiple-views/333507)

<div class="topic-metadata">

**Author:** [@learningelastic](https://discuss.elastic.co/u/learningelastic)\
**Replies:** 4\
**Last updated:** [May 16, 2023, 6:31pm UTC](https://discuss.elastic.co/t/kibana-dashboard-filters-that-recognize-multiple-views/333507 "2023-05-16T18:31:01Z")

</div>

I created a dashboard that shows visualizations . Each visualization references a different Kibana data view. And each kibana data view references a different index. For example, let's say I have two indices with the f…

---

## [Loadbalancing config in Kibana](https://discuss.elastic.co/t/loadbalancing-config-in-kibana/333464)

<div class="topic-metadata">

**Author:** [@zaeemmasood](https://discuss.elastic.co/u/zaeemmasood)\
**Replies:** 4\
**Last updated:** [May 16, 2023, 1:31pm UTC](https://discuss.elastic.co/t/loadbalancing-config-in-kibana/333464 "2023-05-16T13:31:36Z")

</div>

Hi All, Filebeat output has an ability to be configured with load balancing config as follows: output.logstash: hosts: \["hostA:5044","hostB:5044","hostC:5044"\] loadbalance: true Do we have a similar set up for K…

---

## [Add a quick range based on server time to Kibana Time filter quick ranges](https://discuss.elastic.co/t/add-a-quick-range-based-on-server-time-to-kibana-time-filter-quick-ranges/333564)

<div class="topic-metadata">

**Author:** [@gizem](https://discuss.elastic.co/u/gizem)\
**Replies:** 1\
**Last updated:** [May 16, 2023, 12:07pm UTC](https://discuss.elastic.co/t/add-a-quick-range-based-on-server-time-to-kibana-time-filter-quick-ranges/333564 "2023-05-16T12:07:14Z")

</div>

Hello, I want to add a quick range based on server time to Kibana. For example: \<{ "from": "now-15m", "to": "now", "display": "Last 15 minutes" }, /\> 'now' is set by client time. But if client time is wrong, filt…

---

## [Can Snapshots save index in a limited time](https://discuss.elastic.co/t/can-snapshots-save-index-in-a-limited-time/333553)

<div class="topic-metadata">

**Author:** [@Skairik](https://discuss.elastic.co/u/Skairik)\
**Replies:** 4\
**Last updated:** [May 16, 2023, 12:04pm UTC](https://discuss.elastic.co/t/can-snapshots-save-index-in-a-limited-time/333553 "2023-05-16T12:04:17Z")

</div>

Hello everyone, I would like to know if it is possible to set up a snapshot policy that retrieves for example indexes only from the last 7 days. For example, I save my logs from my active directory with this format: in…

---

## [Error restoring state from URL rison decoder error: missing ':'](https://discuss.elastic.co/t/error-restoring-state-from-url-rison-decoder-error-missing/330053)

<div class="topic-metadata">

**Author:** [@carollyl](https://discuss.elastic.co/u/carollyl)\
**Replies:** 10\
**Last updated:** [May 16, 2023, 5:06am UTC](https://discuss.elastic.co/t/error-restoring-state-from-url-rison-decoder-error-missing/330053 "2023-05-16T05:06:38Z")

</div>

Hi, since updated from 6.8.8 to 7.12.0, always get this message "Error restoring state from URL". I have used a scripted field as URL to link one dashboard to another. See below for the URL (sample.com). I've verified w…

---

## [Kibana service keeps failing after upgrade from 7.17 to 8.7](https://discuss.elastic.co/t/kibana-service-keeps-failing-after-upgrade-from-7-17-to-8-7/333099)

<div class="topic-metadata">

**Author:** [@A\_Abdellah](https://discuss.elastic.co/u/A_Abdellah)\
**Replies:** 2\
**Last updated:** [May 16, 2023, 12:17am UTC](https://discuss.elastic.co/t/kibana-service-keeps-failing-after-upgrade-from-7-17-to-8-7/333099 "2023-05-16T00:17:04Z")

</div>

Hi, I'm trying to upgrade my cluster from 7.17.7 to 8.7 and I'm testing the upgrade on a single node cluster. I treated all the errors found by the upgrade assistant and upgraded elasticsearch just fine and tried witho…

---

## [Kibana bootstrap fails 8.7.1](https://discuss.elastic.co/t/kibana-bootstrap-fails-8-7-1/333480)

<div class="topic-metadata">

**Author:** [@kbujold\_wr](https://discuss.elastic.co/u/kbujold_wr)\
**Replies:** 1\
**Last updated:** [May 15, 2023, 8:55pm UTC](https://discuss.elastic.co/t/kibana-bootstrap-fails-8-7-1/333480 "2023-05-15T20:55:59Z")

</div>

Trying to build kibana 8.7.1 and I am getting this error I was not getting when I build 8.6.2 yarn kbn bootstrap yarn run v1.22.19 $ node scripts/kbn bootstrap \[bazel\] INFO: Invocation ID: ff0c547e-d7a4-489e-a5ac-693642…

---

## [10 days log deletion policy using kibana tool](https://discuss.elastic.co/t/10-days-log-deletion-policy-using-kibana-tool/332462)

<div class="topic-metadata">

**Author:** [@kumar918](https://discuss.elastic.co/u/kumar918)\
**Replies:** 5\
**Last updated:** [May 15, 2023, 4:31pm UTC](https://discuss.elastic.co/t/10-days-log-deletion-policy-using-kibana-tool/332462 "2023-05-15T16:31:07Z")

</div>

Hi All, Could you please provide the step by step to configure the 90 days log retention automatically. tried the following steps, but it seems the logs are not deleting Stack management -\> created a new life cycle…

---

## [Index data level security](https://discuss.elastic.co/t/index-data-level-security/332843)

<div class="topic-metadata">

**Author:** [@Msacs](https://discuss.elastic.co/u/Msacs)\
**Replies:** 3\
**Last updated:** [May 15, 2023, 12:38pm UTC](https://discuss.elastic.co/t/index-data-level-security/332843 "2023-05-15T12:38:44Z")

</div>

Wanted some guidance on how to setup data level security . I have a index with a field plant\_id and I have user list that I intend to map users to the corresponding plant id and when users searches ES or access Kibana da…

---

## [Loading Coordinates in Elastic Maps](https://discuss.elastic.co/t/loading-coordinates-in-elastic-maps/333356)

<div class="topic-metadata">

**Author:** [@Denni](https://discuss.elastic.co/u/Denni)\
**Replies:** 4\
**Last updated:** [May 15, 2023, 12:25pm UTC](https://discuss.elastic.co/t/loading-coordinates-in-elastic-maps/333356 "2023-05-15T12:25:36Z")

</div>

Hi, I am very new to elasticsearch and kibana. I am trying to visualise some data I have collected, using the analytics, maps function. My file with Coordinates is read and loaded in. However it only shows the first data…

---

## [Kibana user reset password through email](https://discuss.elastic.co/t/kibana-user-reset-password-through-email/333424)

<div class="topic-metadata">

**Author:** [@Sandeepa\_Kariyawasam](https://discuss.elastic.co/u/Sandeepa_Kariyawasam)\
**Replies:** 1\
**Last updated:** [May 15, 2023, 8:34am UTC](https://discuss.elastic.co/t/kibana-user-reset-password-through-email/333424 "2023-05-15T08:34:15Z")

</div>

I'm not sure whether this is already available. We have multiple Kibana users, mostly with viewer and editor privileges. Currently we have to use a superuser and access server to reset user passwords. When we created u…

---

## [Elastic Machine learning, Datafeed has missed xxx documents due to ingest latency](https://discuss.elastic.co/t/elastic-machine-learning-datafeed-has-missed-xxx-documents-due-to-ingest-latency/332870)

<div class="topic-metadata">

**Author:** [@JasonREC](https://discuss.elastic.co/u/JasonREC)\
**Replies:** 1\
**Last updated:** [May 15, 2023, 8:25am UTC](https://discuss.elastic.co/t/elastic-machine-learning-datafeed-has-missed-xxx-documents-due-to-ingest-latency/332870 "2023-05-15T08:25:44Z")

</div>

Hi, I currenly have a APM server which running on cloud and receiving my php app transaction log. Basiclly, request will keep sending to my php api endpoint. And, I am using the APM generated index pattern log to fee…

---

## [Model Bound in periodic processes](https://discuss.elastic.co/t/model-bound-in-periodic-processes/333281)

<div class="topic-metadata">

**Author:** [@Kirtash](https://discuss.elastic.co/u/Kirtash)\
**Replies:** 1\
**Last updated:** [May 15, 2023, 8:20am UTC](https://discuss.elastic.co/t/model-bound-in-periodic-processes/333281 "2023-05-15T08:20:39Z")

</div>

Good morning, I have a doubt about the model bounds, I have a few services that only have request in periodic moments and although I think that is logic, when this service receive requests it show me that is critical. I…

---

## [Getting Could not find the data view error on kibana dashboard](https://discuss.elastic.co/t/getting-could-not-find-the-data-view-error-on-kibana-dashboard/332792)

<div class="topic-metadata">

**Author:** [@Sachchan](https://discuss.elastic.co/u/Sachchan)\
**Replies:** 26\
**Last updated:** [May 15, 2023, 7:59am UTC](https://discuss.elastic.co/t/getting-could-not-find-the-data-view-error-on-kibana-dashboard/332792 "2023-05-15T07:59:25Z")

</div>

Hi All, I am using kibana dashboards to visualize the data. but i am getting "Could not find the data view" error very frequently and when i refresh again, this error doesn't come. Please help in resolving this error. T…

---

## [Is there a way to plot trend on Opensource Dashobard 2.6](https://discuss.elastic.co/t/is-there-a-way-to-plot-trend-on-opensource-dashobard-2-6/333301)

<div class="topic-metadata">

**Author:** [@Priyanka\_Rajpal](https://discuss.elastic.co/u/Priyanka_Rajpal)\
**Replies:** 3\
**Last updated:** [May 15, 2023, 6:00am UTC](https://discuss.elastic.co/t/is-there-a-way-to-plot-trend-on-opensource-dashobard-2-6/333301 "2023-05-15T06:00:01Z")

</div>

I am using OpensearchDashboards which is a fork of kibana 7.10.2 opensource, is there a way to get a trend on that?

---

## [About configuring the ELK Stack in centos7 server](https://discuss.elastic.co/t/about-configuring-the-elk-stack-in-centos7-server/333208)

<div class="topic-metadata">

**Author:** [@Anil\_Sai\_Pinnelli](https://discuss.elastic.co/u/Anil_Sai_Pinnelli)\
**Replies:** 1\
**Last updated:** [May 14, 2023, 11:34pm UTC](https://discuss.elastic.co/t/about-configuring-the-elk-stack-in-centos7-server/333208 "2023-05-14T23:34:32Z")

</div>

We are trying to Install ELK Stack in Centos7 server in order to pull the MySql data from the same centos7 server. Could You pls give us in detail instructions how to configure the Elasticsearch, Kibana and Logstash and …

---

## [Virtuel Deshboard](https://discuss.elastic.co/t/virtuel-deshboard/333308)

<div class="topic-metadata">

**Author:** [@Ali\_Trache](https://discuss.elastic.co/u/Ali_Trache)\
**Replies:** 0\
**Last updated:** [May 12, 2023, 1:20pm UTC](https://discuss.elastic.co/t/virtuel-deshboard/333308 "2023-05-12T13:20:03Z")

</div>

hello community, I installed and configured elastic then I configured logstach and I shouted an index afterwards I configured a VMware virtual machine to send and analyzed ESXI logs with Kibana how can I shout a virtual …

---

## [How to construct geo\_point field from separate fields of latitude and longitude from Kafka?](https://discuss.elastic.co/t/how-to-construct-geo-point-field-from-separate-fields-of-latitude-and-longitude-from-kafka/333370)

<div class="topic-metadata">

**Author:** [@Jagath\_Prasanga](https://discuss.elastic.co/u/Jagath_Prasanga)\
**Replies:** 1\
**Last updated:** [May 14, 2023, 10:29am UTC](https://discuss.elastic.co/t/how-to-construct-geo-point-field-from-separate-fields-of-latitude-and-longitude-from-kafka/333370 "2023-05-14T10:29:17Z")

</div>

How to construct geo\_point field in logstash from Kafka input? This is my logstash config file. But Kibana not recognizing as a geo\_point field. input { kafka { bootstrap\_servers =\> "localhost:9095" top…

[Previous page](https://discuss.elastic.co/c/elastic-stack/kibana/7.md?page=121)

[Next page](https://discuss.elastic.co/c/elastic-stack/kibana/7.md?page=123)
