# Kibana

**URL:** https://discuss.elastic.co/c/elastic-stack/kibana/7.md?page=169

[Latest](https://discuss.elastic.co/latest.md) · [Categories](https://discuss.elastic.co/categories.md) · [Tags](https://discuss.elastic.co/tags.md)

**Page:** 170

---

## [Kibana : Not able to generate large reports](https://discuss.elastic.co/t/kibana-not-able-to-generate-large-reports/318145)

<div class="topic-metadata">

**Author:** [@shobhit](https://discuss.elastic.co/u/shobhit)\
**Replies:** 4\
**Last updated:** [November 21, 2022, 5:52am UTC](https://discuss.elastic.co/t/kibana-not-able-to-generate-large-reports/318145 "2022-11-21T05:52:16Z")

</div>

Hi, I am using ELK Version 7.17.2 . We are trying to generate reports for more then a million rows CSV. Getting below error. Error Error: Max attempts reached (3). Queue timeout reached. ###kibana.yml \*server.host…

---

## [Kibana - important size of sdtout file](https://discuss.elastic.co/t/kibana-important-size-of-sdtout-file/319166)

<div class="topic-metadata">

**Author:** [@Stef072](https://discuss.elastic.co/u/Stef072)\
**Replies:** 1\
**Last updated:** [November 21, 2022, 2:11am UTC](https://discuss.elastic.co/t/kibana-important-size-of-sdtout-file/319166 "2022-11-21T02:11:08Z")

</div>

Hi there, The stdout file we have in /var/log/kibana seems to increase without end reaching todayy 2.1Gb. Is there a strategy to manage this file to control hard disk occupation ? Thanks

---

## [{"statusCode":503,"error":"Service Unavailable","message":"License is not available."}](https://discuss.elastic.co/t/statuscode-503-error-service-unavailable-message-license-is-not-available/319150)

<div class="topic-metadata">

**Author:** [@auser](https://discuss.elastic.co/u/auser)\
**Replies:** 6\
**Last updated:** [November 21, 2022, 2:04am UTC](https://discuss.elastic.co/t/statuscode-503-error-service-unavailable-message-license-is-not-available/319150 "2022-11-21T02:04:09Z")

</div>

I recently configured https for kibana running in three different environments. One of them works fine while the other two have issue as mentioned below - 1 - {"statusCode":503,"error":"Service Unavailable","message":"L…

---

## [Transmitting Kibana data through watchers](https://discuss.elastic.co/t/transmitting-kibana-data-through-watchers/314199)

<div class="topic-metadata">

**Author:** [@Nalin](https://discuss.elastic.co/u/Nalin)\
**Replies:** 10\
**Last updated:** [October 25, 2022, 8:19am UTC](https://discuss.elastic.co/t/transmitting-kibana-data-through-watchers/314199 "2022-10-25T08:19:23Z")

</div>

Hi All, We are trying to run the API call for "GET /\_cat/indices" through a watcher , but we are not able to receive the data . Could anyone please help us with the correct script for running the above GET command thro…

---

## [iframeCode Single Metric Viewer](https://discuss.elastic.co/t/iframecode-single-metric-viewer/317354)

<div class="topic-metadata">

**Author:** [@Ismael\_Alvarez](https://discuss.elastic.co/u/Ismael_Alvarez)\
**Replies:** 0\
**Last updated:** [October 24, 2022, 11:21pm UTC](https://discuss.elastic.co/t/iframecode-single-metric-viewer/317354 "2022-10-24T23:21:14Z")

</div>

hey there! I need to share Single Metric Viewer as embed code Snapshot, attached example. Best regards

---

## [How can I increase number of values of visualize](https://discuss.elastic.co/t/how-can-i-increase-number-of-values-of-visualize/319289)

<div class="topic-metadata">

**Author:** [@yts85205107](https://discuss.elastic.co/u/yts85205107)\
**Replies:** 4\
**Last updated:** [November 20, 2022, 6:49am UTC](https://discuss.elastic.co/t/how-can-i-increase-number-of-values-of-visualize/319289 "2022-11-20T06:49:08Z")

</div>

Hi, I want to increase number of values of visualize, but I can't found the setting to increase. now, the number of values is 1000, I want to increase to 3000, how can I increase? Thanks.

---

## [Dashboard and visualization showing No results found, but Discover page shows data](https://discuss.elastic.co/t/dashboard-and-visualization-showing-no-results-found-but-discover-page-shows-data/319344)

<div class="topic-metadata">

**Author:** [@D3epDiv3r](https://discuss.elastic.co/u/D3epDiv3r)\
**Replies:** 2\
**Last updated:** [November 20, 2022, 3:04am UTC](https://discuss.elastic.co/t/dashboard-and-visualization-showing-no-results-found-but-discover-page-shows-data/319344 "2022-11-20T03:04:12Z")

</div>

Hello team, I am using Elastic Stack 5.2.2, I have been able to parse logs from Suricata to Logstash and Elasticsearch which displays in the Kibana Discover page as seen below: But whenever I go to the Dashboard tab…

---

## [Kibana installation error](https://discuss.elastic.co/t/kibana-installation-error/318913)

<div class="topic-metadata">

**Author:** [@Vivek\_Arumugam](https://discuss.elastic.co/u/Vivek_Arumugam)\
**Replies:** 16\
**Last updated:** [November 19, 2022, 4:28pm UTC](https://discuss.elastic.co/t/kibana-installation-error/318913 "2022-11-19T16:28:49Z")

</div>

Hi All, I have installed Elasticsearch "8.5.0". I keep getting the following problem when attempting to install Kibana.

---

## [.NET IIS Auto Profiler Instrumentation Stuck and Not showing in Kibana Windows](https://discuss.elastic.co/t/net-iis-auto-profiler-instrumentation-stuck-and-not-showing-in-kibana-windows/319193)

<div class="topic-metadata">

**Author:** [@giga](https://discuss.elastic.co/u/giga)\
**Replies:** 0\
**Last updated:** [November 17, 2022, 12:46pm UTC](https://discuss.elastic.co/t/net-iis-auto-profiler-instrumentation-stuck-and-not-showing-in-kibana-windows/319193 "2022-11-17T12:46:20Z")

</div>

Hi, I've installed elasticsearch, kibana and APM Server on windows environment. Then I have .Net application run on IIS in another windows computer (client side) in the same network. I've following this guide: But the …

---

## [Data dog+Kibana plugin](https://discuss.elastic.co/t/data-dog-kibana-plugin/317274)

<div class="topic-metadata">

**Author:** [@Racheli\_Vagenfeld](https://discuss.elastic.co/u/Racheli_Vagenfeld)\
**Replies:** 1\
**Last updated:** [October 23, 2022, 2:34pm UTC](https://discuss.elastic.co/t/data-dog-kibana-plugin/317274 "2022-10-23T14:34:53Z")

</div>

Hi, I want to use this: Datadog output plugin | Logstash Reference \[8.4\] | Elastic\](Datadog output plugin | Logstash Reference \[8.4\] | Elastic Is there anyway to make the integration based on specific filter of kibana …

---

## [Error while creating index pattern](https://discuss.elastic.co/t/error-while-creating-index-pattern/317593)

<div class="topic-metadata">

**Author:** [@Kartik101](https://discuss.elastic.co/u/Kartik101)\
**Replies:** 2\
**Last updated:** [November 18, 2022, 4:12am UTC](https://discuss.elastic.co/t/error-while-creating-index-pattern/317593 "2022-11-18T04:12:37Z")

</div>

I am using ES 7.10.2 and Kibana7.10.2, and getting below error in "nohup.out" file (running kibana in background) while creating index pattern: {"type":"error","@timestamp":"2022-08-23T13:53:37Z","tags":\["connection","c…

---

## [Kibana url not working. FATAL Error: \[config validation of \[elasticsearch\].username\]: value of "elastic" is forbidden. This is a superuser account that cannot write to system indices that Kibana needs to function. Use a service account token instead](https://discuss.elastic.co/t/kibana-url-not-working-fatal-error-config-validation-of-elasticsearch-username-value-of-elastic-is-forbidden-this-is-a-superuser-account-that-cannot-write-to-system-indices-that-kibana-needs-to-function-use-a-service-account-token-instead/317026)

<div class="topic-metadata">

**Author:** [@SUNA](https://discuss.elastic.co/u/SUNA)\
**Replies:** 13\
**Last updated:** [November 18, 2022, 12:28am UTC](https://discuss.elastic.co/t/kibana-url-not-working-fatal-error-config-validation-of-elasticsearch-username-value-of-elastic-is-forbidden-this-is-a-superuser-account-that-cannot-write-to-system-indices-that-kibana-needs-to-function-use-a-service-account-token-instead/317026 "2022-11-18T00:28:06Z")

</div>

Hi Team, Kindly help here how can i fix this. ? Previously, ELK failed due to an error "java.lang. IllegalStateException: A node cannot be upgraded directly from version \[7.10.2\] to version \[8.4.3\], it must first be…

---

## [Reporting SQL relational data (Oracle) in Kibana](https://discuss.elastic.co/t/reporting-sql-relational-data-oracle-in-kibana/319178)

<div class="topic-metadata">

**Author:** [@Gianluca\_De\_Pasquale](https://discuss.elastic.co/u/Gianluca_De_Pasquale)\
**Replies:** 0\
**Last updated:** [November 17, 2022, 11:14am UTC](https://discuss.elastic.co/t/reporting-sql-relational-data-oracle-in-kibana/319178 "2022-11-17T11:14:27Z")

</div>

Hi all, just a theoric question about Kibana reporting capabilities. We have a Oracle database where there are at least 10 tables we want to report data of. We started using Microsoft Power Bi and the results were ver…

---

## [Automate Kibana query](https://discuss.elastic.co/t/automate-kibana-query/316671)

<div class="topic-metadata">

**Author:** [@baseely](https://discuss.elastic.co/u/baseely)\
**Replies:** 3\
**Last updated:** [October 21, 2022, 1:41am UTC](https://discuss.elastic.co/t/automate-kibana-query/316671 "2022-10-21T01:41:02Z")

</div>

Hello Community, I want to use some REST API so that I will be able to automate long list of queries that should be created with the same pattern at the end. For example: \<WORD1\> AND message: \<SAME\_CONSTANT\_WORD\_THAT\_…

---

## [Removing xpack.maps.enabled as advised breaks Kibana](https://discuss.elastic.co/t/removing-xpack-maps-enabled-as-advised-breaks-kibana/319222)

<div class="topic-metadata">

**Author:** [@mikewillis](https://discuss.elastic.co/u/mikewillis)\
**Replies:** 2\
**Last updated:** [November 17, 2022, 5:18pm UTC](https://discuss.elastic.co/t/removing-xpack-maps-enabled-as-advised-breaks-kibana/319222 "2022-11-17T17:18:12Z")

</div>

Kibana 7.17 The Kibana Upgrade Assistant is showing me a Critical issue: Setting "xpack.maps.enabled" is deprecated Configuring "xpack.maps.enabled" is deprecated and will be removed in 8.0.0. How to fix Remove "xp…

---

## [Anomaly Detection doesn't recongise patterns](https://discuss.elastic.co/t/anomaly-detection-doesnt-recongise-patterns/319229)

<div class="topic-metadata">

**Author:** [@PeaDubYa](https://discuss.elastic.co/u/PeaDubYa)\
**Replies:** 0\
**Last updated:** [November 17, 2022, 5:16pm UTC](https://discuss.elastic.co/t/anomaly-detection-doesnt-recongise-patterns/319229 "2022-11-17T17:16:17Z")

</div>

I'm trying out the anomaly detection package for the first time, and there is a nice example in the tutorial, whereby elastic learns temporal oscillations. I've configured a very basic job, but the ML does not pick up t…

---

## [Kibana logs](https://discuss.elastic.co/t/kibana-logs/319115)

<div class="topic-metadata">

**Author:** [@mauroslucios](https://discuss.elastic.co/u/mauroslucios)\
**Replies:** 2\
**Last updated:** [November 17, 2022, 4:44pm UTC](https://discuss.elastic.co/t/kibana-logs/319115 "2022-11-17T16:44:27Z")

</div>

I have an ELK cluster that has a different time in the logs than the machine where it is installed. Does anyone have any idea how to resolve? Below is an image of my server.

---

## [Angular routing Kibana iframe](https://discuss.elastic.co/t/angular-routing-kibana-iframe/319160)

<div class="topic-metadata">

**Author:** [@PRASHANT\_MEHTA](https://discuss.elastic.co/u/PRASHANT_MEHTA)\
**Replies:** 0\
**Last updated:** [November 17, 2022, 9:56am UTC](https://discuss.elastic.co/t/angular-routing-kibana-iframe/319160 "2022-11-17T09:56:31Z")

</div>

Hello All, We've intregrated kibana pages into angular web application using iframe,Now the issue that we are facing is we need to redirect from our home page dashboard(monitoring) -conataining several url to designate…

---

## [Following example to update mappings gives exception](https://discuss.elastic.co/t/following-example-to-update-mappings-gives-exception/319155)

<div class="topic-metadata">

**Author:** [@tinrik](https://discuss.elastic.co/u/tinrik)\
**Replies:** 1\
**Last updated:** [November 17, 2022, 9:50am UTC](https://discuss.elastic.co/t/following-example-to-update-mappings-gives-exception/319155 "2022-11-17T09:50:48Z")

</div>

Hi, I'm following this example to bring down the storage usage of my index. However when I try it out: PUT /my\_index/\_mapping { "mappings": { "dynamic\_templates": \[ { "strings": { "match\_…

---

## [Kibana logs are not showing in DIscover page](https://discuss.elastic.co/t/kibana-logs-are-not-showing-in-discover-page/319054)

<div class="topic-metadata">

**Author:** [@yasar](https://discuss.elastic.co/u/yasar)\
**Replies:** 2\
**Last updated:** [November 17, 2022, 8:20am UTC](https://discuss.elastic.co/t/kibana-logs-are-not-showing-in-discover-page/319054 "2022-11-17T08:20:18Z")

</div>

Hi team, We are injected the logs by manually for few testing and we have done the filebeat, and logstash pipeline and Logstash config file as well as the same. But after configured and pushed the logs by manually, it …

---

## [Probleme with attachement file in watcher kibana](https://discuss.elastic.co/t/probleme-with-attachement-file-in-watcher-kibana/318959)

<div class="topic-metadata">

**Author:** [@Mouloud\_Addouche](https://discuss.elastic.co/u/Mouloud_Addouche)\
**Replies:** 0\
**Last updated:** [November 15, 2022, 1:16pm UTC](https://discuss.elastic.co/t/probleme-with-attachement-file-in-watcher-kibana/318959 "2022-11-15T13:16:22Z")

</div>

Hello, I have a problem with watcher in elasticsearch, in fact I created a watcher that allows to send a mail with a pdf file ( the pdf file is a dashboard on kibana ) "reporting": { "url": "http://kibana:5601/api/rep…

---

## [Can you set partition field and count by as the same field?](https://discuss.elastic.co/t/can-you-set-partition-field-and-count-by-as-the-same-field/316244)

<div class="topic-metadata">

**Author:** [@emi\_rose](https://discuss.elastic.co/u/emi_rose)\
**Replies:** 1\
**Last updated:** [October 20, 2022, 2:27am UTC](https://discuss.elastic.co/t/can-you-set-partition-field-and-count-by-as-the-same-field/316244 "2022-10-20T02:27:57Z")

</div>

I have been trying to create a machine learning job that detects that a certain job that has been running for an anomalous amount of time. Sometimes this job runs for much longer than expected and sometimes much shorter.…

---

## [Kibana Alerts Table Missing Columns](https://discuss.elastic.co/t/kibana-alerts-table-missing-columns/319122)

<div class="topic-metadata">

**Author:** [@codewriterguy](https://discuss.elastic.co/u/codewriterguy)\
**Replies:** 0\
**Last updated:** [November 16, 2022, 5:42pm UTC](https://discuss.elastic.co/t/kibana-alerts-table-missing-columns/319122 "2022-11-16T17:42:15Z")

</div>

Hi, The alerts dashboard is showing alerts but there are no columns/values populating for each alert. I am able to view details for an alert, investigate in the timeline, etc but I am not able to see any alert details i…

---

## [Use Kibana on my local machine to monitor Metricbeat on a remote VM?](https://discuss.elastic.co/t/use-kibana-on-my-local-machine-to-monitor-metricbeat-on-a-remote-vm/317054)

<div class="topic-metadata">

**Author:** [@nola](https://discuss.elastic.co/u/nola)\
**Replies:** 2\
**Last updated:** [October 19, 2022, 10:25pm UTC](https://discuss.elastic.co/t/use-kibana-on-my-local-machine-to-monitor-metricbeat-on-a-remote-vm/317054 "2022-10-19T22:25:14Z")

</div>

I have Metricbeat and Elasticsearch installed and running on an AWS EC2 instance. I have Kibana on my local machine. In kibana.yml, I have the server address for the elastic.hosts parameter, and am able to run queries …

---

## [Access to aggregation results using kibana alerting](https://discuss.elastic.co/t/access-to-aggregation-results-using-kibana-alerting/319112)

<div class="topic-metadata">

**Author:** [@Youssef\_Mouadden](https://discuss.elastic.co/u/Youssef_Mouadden)\
**Replies:** 1\
**Last updated:** [November 16, 2022, 4:45pm UTC](https://discuss.elastic.co/t/access-to-aggregation-results-using-kibana-alerting/319112 "2022-11-16T16:45:47Z")

</div>

Hello, I'm facing a problem with Kibana alerting: I defined my query DSL and defined an aggregation I want to access the result of the aggregation returned using the query. Kibana only suggest {{context.hits}} but I'm …

---

## [Searching logs by host name](https://discuss.elastic.co/t/searching-logs-by-host-name/316388)

<div class="topic-metadata">

**Author:** [@rsk0](https://discuss.elastic.co/u/rsk0)\
**Replies:** 7\
**Last updated:** [November 16, 2022, 4:33pm UTC](https://discuss.elastic.co/t/searching-logs-by-host-name/316388 "2022-11-16T16:33:31Z")

</div>

I have a little quandary. I'd like my customers to easily search for logs by host name. ECS has a field, host.name exactly for that information, but it's keyword, and that requires users know the exact capitalization a…

---

## [How to Create a Rule Based on Time Range](https://discuss.elastic.co/t/how-to-create-a-rule-based-on-time-range/318998)

<div class="topic-metadata">

**Author:** [@ElasticUser11](https://discuss.elastic.co/u/ElasticUser11)\
**Replies:** 0\
**Last updated:** [November 15, 2022, 8:06pm UTC](https://discuss.elastic.co/t/how-to-create-a-rule-based-on-time-range/318998 "2022-11-15T20:06:27Z")

</div>

I'm trying to create a rule that detects when users login outside business hours (7AM-6PM). I believe this can be done with machine Learning, but I don not have that type of subscription. So, I've tried several ways, alb…

---

## [Using conditions in watcher](https://discuss.elastic.co/t/using-conditions-in-watcher/318956)

<div class="topic-metadata">

**Author:** [@ErGeek](https://discuss.elastic.co/u/ErGeek)\
**Replies:** 5\
**Last updated:** [November 16, 2022, 12:55pm UTC](https://discuss.elastic.co/t/using-conditions-in-watcher/318956 "2022-11-16T12:55:41Z")

</div>

Hi All, I am trying to add conditions in a watcher. If the value of the ctx.payload.value is less than 100, it should print a particular message "Within the limit". And if not than it should print another message "Limi…

---

## [Kubernetes elastic search and kibana communication issue](https://discuss.elastic.co/t/kubernetes-elastic-search-and-kibana-communication-issue/317023)

<div class="topic-metadata">

**Author:** [@Siva\_Priya](https://discuss.elastic.co/u/Siva_Priya)\
**Replies:** 1\
**Last updated:** [October 19, 2022, 9:47pm UTC](https://discuss.elastic.co/t/kubernetes-elastic-search-and-kibana-communication-issue/317023 "2022-10-19T21:47:11Z")

</div>

Am trying to set up the Elasticsearch and kibana in Kubernetes cluster as per the instructions mentioned in How to run Elastic Cloud on Kubernetes from Azure Kubernetes Service | Elastic Blog. Everything is fine But I am…

---

## [Timezone issue](https://discuss.elastic.co/t/timezone-issue/318620)

<div class="topic-metadata">

**Author:** [@MahithaSarala](https://discuss.elastic.co/u/MahithaSarala)\
**Replies:** 10\
**Last updated:** [November 16, 2022, 12:12pm UTC](https://discuss.elastic.co/t/timezone-issue/318620 "2022-11-16T12:12:32Z")

</div>

In our current kibana setup , the timezone has been set to browser timezone. This dashboard is live for users in India as well as users in Ireland . The kibana setup is live and linked to spinnaker to monitor the pipelin…

[Previous page](https://discuss.elastic.co/c/elastic-stack/kibana/7.md?page=168)

[Next page](https://discuss.elastic.co/c/elastic-stack/kibana/7.md?page=170)
