# Kibana

**URL:** https://discuss.elastic.co/c/elastic-stack/kibana/7.md?page=186

[Latest](https://discuss.elastic.co/latest.md) · [Categories](https://discuss.elastic.co/categories.md) · [Tags](https://discuss.elastic.co/tags.md)

**Page:** 187

---

## [Kibana tables are showing very few rows(150) though there are around 4000 rows in the result](https://discuss.elastic.co/t/kibana-tables-are-showing-very-few-rows-150-though-there-are-around-4000-rows-in-the-result/312658)

<div class="topic-metadata">

**Author:** [@Vishwanatha.K](https://discuss.elastic.co/u/Vishwanatha.K)\
**Replies:** 5\
**Last updated:** [August 24, 2022, 9:28am UTC](https://discuss.elastic.co/t/kibana-tables-are-showing-very-few-rows-150-though-there-are-around-4000-rows-in-the-result/312658 "2022-08-24T09:28:00Z")

</div>

Hi, Kibana tables are showing very few rows(150) though there are around 4000 rows in the result. Is there anyway I can set the max rows to be displayed in tables data ? I tried to set the Stackmanagement-\>Advance sett…

---

## [How to fetch the data from elasticsearch in query](https://discuss.elastic.co/t/how-to-fetch-the-data-from-elasticsearch-in-query/312756)

<div class="topic-metadata">

**Author:** [@Rain\_Water](https://discuss.elastic.co/u/Rain_Water)\
**Replies:** 3\
**Last updated:** [August 24, 2022, 6:46am UTC](https://discuss.elastic.co/t/how-to-fetch-the-data-from-elasticsearch-in-query/312756 "2022-08-24T06:46:10Z")

</div>

Hi, i want to create a query to fetch the data from elasticsearch in csv can any one help me with the query. thanks.

---

## [The reporting job failed + Error: Max attempts (3) reached for job X. Failed with: Error: Unable to get index-pattern](https://discuss.elastic.co/t/the-reporting-job-failed-error-max-attempts-3-reached-for-job-x-failed-with-error-unable-to-get-index-pattern/310588)

<div class="topic-metadata">

**Author:** [@alexus](https://discuss.elastic.co/u/alexus)\
**Replies:** 7\
**Last updated:** [August 24, 2022, 3:21am UTC](https://discuss.elastic.co/t/the-reporting-job-failed-error-max-attempts-3-reached-for-job-x-failed-with-error-unable-to-get-index-pattern/310588 "2022-08-24T03:21:50Z")

</div>

Hello World! I'm trying to: yet while trying to run report (using "added\*" index-pattern), getting the following error: The reporting job failed Error: Max attempts (3) reached for job X. Failed with: Error: Unabl…

---

## [Native azure integration with Azure AD SSO failures](https://discuss.elastic.co/t/native-azure-integration-with-azure-ad-sso-failures/312660)

<div class="topic-metadata">

**Author:** [@samjpv](https://discuss.elastic.co/u/samjpv)\
**Replies:** 3\
**Last updated:** [August 23, 2022, 11:44pm UTC](https://discuss.elastic.co/t/native-azure-integration-with-azure-ad-sso-failures/312660 "2022-08-23T23:44:10Z")

</div>

I've been working to set up SSO with Azure AD on a native Azure integrated elasticsearch cluster following this guide: How to set up OpenID Connect on Elastic Cloud (with Azure, Google, Okta) | Elastic Blog. As far as I …

---

## [Kibana is now available (was degraded)"](https://discuss.elastic.co/t/kibana-is-now-available-was-degraded/312610)

<div class="topic-metadata">

**Author:** [@sanjay\_kumar\_chahar](https://discuss.elastic.co/u/sanjay_kumar_chahar)\
**Replies:** 2\
**Last updated:** [August 23, 2022, 2:00pm UTC](https://discuss.elastic.co/t/kibana-is-now-available-was-degraded/312610 "2022-08-23T14:00:57Z")

</div>

Hi All I have configured elasticsearch, kibana and fileebeat Kibana version number: "8.3.3" Elasticsearch version number : "8.3.3" Filebeat version number : "8.3.3" I am able to login in Kibana Web UI and not able…

---

## [Question About Field order in Discover](https://discuss.elastic.co/t/question-about-field-order-in-discover/312439)

<div class="topic-metadata">

**Author:** [@Paul\_Chen](https://discuss.elastic.co/u/Paul_Chen)\
**Replies:** 1\
**Last updated:** [August 23, 2022, 1:38pm UTC](https://discuss.elastic.co/t/question-about-field-order-in-discover/312439 "2022-08-23T13:38:25Z")

</div>

I use Logstash to output data to ES from database, and in the Kibana discover, the field always sort in a-z Is there any way to make the field order follow the database field order? note: My SQL statement already has t…

---

## [Kibana Email Alerting Connector](https://discuss.elastic.co/t/kibana-email-alerting-connector/312587)

<div class="topic-metadata">

**Author:** [@Ayushi\_bhardwaj](https://discuss.elastic.co/u/Ayushi_bhardwaj)\
**Replies:** 1\
**Last updated:** [August 23, 2022, 1:18pm UTC](https://discuss.elastic.co/t/kibana-email-alerting-connector/312587 "2022-08-23T13:18:17Z")

</div>

How to setup Email Connector once the rule is created in kibana Rules & Connectors? what Username and password inside email connector option we need to give.

---

## [Kibana Dashboard Refresh takes too long](https://discuss.elastic.co/t/kibana-dashboard-refresh-takes-too-long/312683)

<div class="topic-metadata">

**Author:** [@Scorpion21](https://discuss.elastic.co/u/Scorpion21)\
**Replies:** 1\
**Last updated:** [August 23, 2022, 11:56am UTC](https://discuss.elastic.co/t/kibana-dashboard-refresh-takes-too-long/312683 "2022-08-23T11:56:46Z")

</div>

I deploy an ELK platform using kubernetes. For a quick test, I just create a simple dashboard including one map and two bars, based on a small index including less than 4000 docs. However, it will take around 20 sec…

---

## [Monitoring Request Failed in Stack Monitoring in Kibana 8.3.3](https://discuss.elastic.co/t/monitoring-request-failed-in-stack-monitoring-in-kibana-8-3-3/312698)

<div class="topic-metadata">

**Author:** [@sumitpramanik](https://discuss.elastic.co/u/sumitpramanik)\
**Replies:** 0\
**Last updated:** [August 23, 2022, 11:27am UTC](https://discuss.elastic.co/t/monitoring-request-failed-in-stack-monitoring-in-kibana-8-3-3/312698 "2022-08-23T11:27:25Z")

</div>

Hi, I am facing below issue after updating kibana to 8.2 and in 8.3.3 its not fixed yet. How to solve this? {"ecs":{"version":"8.0.0"},"@timestamp":"2022-08-23T17:24:52.715+06:00","message":"Saved object \[task/e3353…

---

## [Set new value in controls-visualisation after pipeline execution/index creation](https://discuss.elastic.co/t/set-new-value-in-controls-visualisation-after-pipeline-execution-index-creation/312679)

<div class="topic-metadata">

**Author:** [@Jonas\_S](https://discuss.elastic.co/u/Jonas_S)\
**Replies:** 2\
**Last updated:** [August 23, 2022, 10:43am UTC](https://discuss.elastic.co/t/set-new-value-in-controls-visualisation-after-pipeline-execution-index-creation/312679 "2022-08-23T10:43:32Z")

</div>

Hello, i have a kibana dashboard with an index pattern where every month a new index is created by a logstash pipeline within the same index pattern. The data contains a field "month", which is selectable in a controls …

---

## [Download CSV file name with visualization Name](https://discuss.elastic.co/t/download-csv-file-name-with-visualization-name/312372)

<div class="topic-metadata">

**Author:** [@Sandeep\_Raju](https://discuss.elastic.co/u/Sandeep_Raju)\
**Replies:** 3\
**Last updated:** [August 23, 2022, 10:53am UTC](https://discuss.elastic.co/t/download-csv-file-name-with-visualization-name/312372 "2022-08-23T10:53:59Z")

</div>

Hi all, I'm using Kibana 7.4.1. I create a data table and include it in my dashboard. When i try to download CSV on formatted button I'm only able to download filename table.CSV. For all visualizations, name of file …

---

## [Cannot access stack monitoring](https://discuss.elastic.co/t/cannot-access-stack-monitoring/312589)

<div class="topic-metadata">

**Author:** [@asp](https://discuss.elastic.co/u/asp)\
**Replies:** 2\
**Last updated:** [August 23, 2022, 6:45am UTC](https://discuss.elastic.co/t/cannot-access-stack-monitoring/312589 "2022-08-23T06:45:57Z")

</div>

Hi, we are using the free license. I cannot access the stack monitoring. Getting following error message inside kibana: The issue occurs as superuser elastic and with a newly created user called monitoring: It d…

---

## [ILM policy is not followed correctly and index is not getting rollover as per doc size or max age](https://discuss.elastic.co/t/ilm-policy-is-not-followed-correctly-and-index-is-not-getting-rollover-as-per-doc-size-or-max-age/312306)

<div class="topic-metadata">

**Author:** [@PRASHANT\_MEHTA](https://discuss.elastic.co/u/PRASHANT_MEHTA)\
**Replies:** 6\
**Last updated:** [August 23, 2022, 5:18am UTC](https://discuss.elastic.co/t/ilm-policy-is-not-followed-correctly-and-index-is-not-getting-rollover-as-per-doc-size-or-max-age/312306 "2022-08-23T05:18:42Z")

</div>

Hello All, I'm facing major challenges with regards to ILM policy for all my indexes. In ILM policy I'm using two phase HOT and DELETE. Hot Phase- It should have max 2mb of data or data should be there for 3 min then …

---

## [Kibana terribly slow on /apm/traces](https://discuss.elastic.co/t/kibana-terribly-slow-on-apm-traces/312665)

<div class="topic-metadata">

**Author:** [@user2022](https://discuss.elastic.co/u/user2022)\
**Replies:** 1\
**Last updated:** [August 23, 2022, 2:39am UTC](https://discuss.elastic.co/t/kibana-terribly-slow-on-apm-traces/312665 "2022-08-23T02:39:03Z")

</div>

can any one look at the issue i posted at apm category? links: Kibana terribly slow on /apm/traces - Elastic Observability / APM - Discuss the Elastic Stack

---

## [Request latency](https://discuss.elastic.co/t/request-latency/312636)

<div class="topic-metadata">

**Author:** [@Tomas\_Rabazo](https://discuss.elastic.co/u/Tomas_Rabazo)\
**Replies:** 1\
**Last updated:** [August 23, 2022, 1:22am UTC](https://discuss.elastic.co/t/request-latency/312636 "2022-08-23T01:22:21Z")

</div>

Hello, I am trying to display latency related with a request to a backend (endpoint). For instance, I search the endpoint (backend) and I want to display average latency for that endpoint. How can I do it?

---

## [ILM policies conditions are getting exceeded to rollover the indices](https://discuss.elastic.co/t/ilm-policies-conditions-are-getting-exceeded-to-rollover-the-indices/312308)

<div class="topic-metadata">

**Author:** [@Mangesh\_Mathe](https://discuss.elastic.co/u/Mangesh_Mathe)\
**Replies:** 4\
**Last updated:** [August 22, 2022, 9:20pm UTC](https://discuss.elastic.co/t/ilm-policies-conditions-are-getting-exceeded-to-rollover-the-indices/312308 "2022-08-22T21:20:24Z")

</div>

Hello Elastic Team, I have applied ILM policy(test) to my Index(timeseries) where I have defined ONLY hot phase with conditions max\_age(15m) & max\_docs(5). My index is getting rollover but not following/matching above …

---

## [How to replicate Heartbeat menu on dashboard](https://discuss.elastic.co/t/how-to-replicate-heartbeat-menu-on-dashboard/312652)

<div class="topic-metadata">

**Author:** [@SamuelSMendes](https://discuss.elastic.co/u/SamuelSMendes)\
**Replies:** 0\
**Last updated:** [August 22, 2022, 7:32pm UTC](https://discuss.elastic.co/t/how-to-replicate-heartbeat-menu-on-dashboard/312652 "2022-08-22T19:32:26Z")

</div>

So we have this menu on heartbeat where we can select between ALL, UP and DOWN. And what I've been trying to do is replicate this little menu by Markdown. I did the "ALL" part since it was simply sending the link bac…

---

## [Unable to login to Kibana using API\_KEY with restrictions](https://discuss.elastic.co/t/unable-to-login-to-kibana-using-api-key-with-restrictions/312258)

<div class="topic-metadata">

**Author:** [@Bikram\_Kundu](https://discuss.elastic.co/u/Bikram_Kundu)\
**Replies:** 12\
**Last updated:** [August 22, 2022, 12:37pm UTC](https://discuss.elastic.co/t/unable-to-login-to-kibana-using-api-key-with-restrictions/312258 "2022-08-22T12:37:58Z")

</div>

Use case: I am implementing Attribute Based Access Control as mentioned on the official blog. How can I create an API\_Key that has access to the Kibana dashboard with restricted attribute-based access control? Steps f…

---

## [How to update user profile using API without \`manage\_security\` privilege](https://discuss.elastic.co/t/how-to-update-user-profile-using-api-without-manage-security-privilege/312545)

<div class="topic-metadata">

**Author:** [@Azhar\_Uddin1](https://discuss.elastic.co/u/Azhar_Uddin1)\
**Replies:** 3\
**Last updated:** [August 22, 2022, 2:39pm UTC](https://discuss.elastic.co/t/how-to-update-user-profile-using-api-without-manage-security-privilege/312545 "2022-08-22T14:39:58Z")

</div>

I am trying to update the user profile using Flask API if user is logged in then he/she can update his profile fields full name, email only when I trying to update user using put\_user #es=Elasticsearch instance sscl…

---

## [Kibana to Elastic Search Communication Not Working with Wildcard Certificate](https://discuss.elastic.co/t/kibana-to-elastic-search-communication-not-working-with-wildcard-certificate/312037)

<div class="topic-metadata">

**Author:** [@hoover63](https://discuss.elastic.co/u/hoover63)\
**Replies:** 3\
**Last updated:** [August 22, 2022, 1:52pm UTC](https://discuss.elastic.co/t/kibana-to-elastic-search-communication-not-working-with-wildcard-certificate/312037 "2022-08-22T13:52:44Z")

</div>

For the last couple of days I have been trying to add a wildcard certificate to a new ELK server (one server running ES+Kibana). I have gotten the cert to work with ES, however, Kibana is unable to communicate with ES us…

---

## [Unable to find ip releted filed in rollups](https://discuss.elastic.co/t/unable-to-find-ip-releted-filed-in-rollups/312342)

<div class="topic-metadata">

**Author:** [@Surendra\_Hire](https://discuss.elastic.co/u/Surendra_Hire)\
**Replies:** 1\
**Last updated:** [August 22, 2022, 12:35am UTC](https://discuss.elastic.co/t/unable-to-find-ip-releted-filed-in-rollups/312342 "2022-08-22T00:35:46Z")

</div>

Hello i am applying rollups function on my data. there are mutiple filed in ES. but when i applyed rollup job i cound found ip releted fileds. first image i have apply rollup and second image i can not found ip rel…

---

## [Kibana 8.2.3 heat map was not ok](https://discuss.elastic.co/t/kibana-8-2-3-heat-map-was-not-ok/312243)

<div class="topic-metadata">

**Author:** [@Marco1221](https://discuss.elastic.co/u/Marco1221)\
**Replies:** 2\
**Last updated:** [August 22, 2022, 1:15pm UTC](https://discuss.elastic.co/t/kibana-8-2-3-heat-map-was-not-ok/312243 "2022-08-22T13:15:52Z")

</div>

I‘m chinese，so my english just soso I found Kibana 8.2.3 heat map was not ok， The heat map is displayed only once！ that 2 pictures in one video who can help me！ thanks！

---

## [Impossible to find index template path](https://discuss.elastic.co/t/impossible-to-find-index-template-path/312541)

<div class="topic-metadata">

**Author:** [@Samuele\_Lolli](https://discuss.elastic.co/u/Samuele_Lolli)\
**Replies:** 4\
**Last updated:** [August 22, 2022, 9:38am UTC](https://discuss.elastic.co/t/impossible-to-find-index-template-path/312541 "2022-08-22T09:38:43Z")

</div>

I created a index template from the Kibana UI but i can't configure properly the index inside my logstash pipeline because i can't find the path of the index template.

---

## [Kibana Scripted Field HourOfDay](https://discuss.elastic.co/t/kibana-scripted-field-hourofday/311447)

<div class="topic-metadata">

**Author:** [@fim01](https://discuss.elastic.co/u/fim01)\
**Replies:** 3\
**Last updated:** [August 22, 2022, 8:14am UTC](https://discuss.elastic.co/t/kibana-scripted-field-hourofday/311447 "2022-08-22T08:14:14Z")

</div>

I followed documentation to create a simple scripted field to calculate HourOfDay doc\['@timestamp'\].date.hourOfDay error: { "took": 5, "timed\_out": false, "\_shards": { "total": 9, "successful": 8, …

---

## [Kibana LDAP authentication via apache proxy](https://discuss.elastic.co/t/kibana-ldap-authentication-via-apache-proxy/312385)

<div class="topic-metadata">

**Author:** [@thirty2](https://discuss.elastic.co/u/thirty2)\
**Replies:** 4\
**Last updated:** [August 22, 2022, 7:27am UTC](https://discuss.elastic.co/t/kibana-ldap-authentication-via-apache-proxy/312385 "2022-08-22T07:27:57Z")

</div>

Hi, with xpack and TLS for elasticserach + kibana disable i can use ldap authentication via apache. I can login to kibana with my ldap account. Kibana config: server.port: 5601 server.host: "myhost" elasticsearch.hos…

---

## [Version history](https://discuss.elastic.co/t/version-history/312463)

<div class="topic-metadata">

**Author:** [@afuente](https://discuss.elastic.co/u/afuente)\
**Replies:** 1\
**Last updated:** [August 22, 2022, 12:27am UTC](https://discuss.elastic.co/t/version-history/312463 "2022-08-22T00:27:32Z")

</div>

Hello, guys!! Is it possible to see the version history of a saved query, dashboard, visualization, etc.? I mean, I created a saved query, but another user has changed it without telling me, is it possible to know who c…

---

## [Registry Proxy Authentication](https://discuss.elastic.co/t/registry-proxy-authentication/312460)

<div class="topic-metadata">

**Author:** [@zirota](https://discuss.elastic.co/u/zirota)\
**Replies:** 0\
**Last updated:** [August 19, 2022, 11:22am UTC](https://discuss.elastic.co/t/registry-proxy-authentication/312460 "2022-08-19T11:22:25Z")

</div>

Hello, Any idea how I can provide credentials to the proxy specified xpack.fleet.registryProxyUrl? Usually when working with proxies, we make use of the username:password basic authentication in the URL such as "https:…

---

## [Vega Pie doesn't show slices with scripted\_metric, only the values in the middle of the chart without a Pie](https://discuss.elastic.co/t/vega-pie-doesnt-show-slices-with-scripted-metric-only-the-values-in-the-middle-of-the-chart-without-a-pie/312265)

<div class="topic-metadata">

**Author:** [@DMinovski](https://discuss.elastic.co/u/DMinovski)\
**Replies:** 1\
**Last updated:** [August 21, 2022, 3:52am UTC](https://discuss.elastic.co/t/vega-pie-doesnt-show-slices-with-scripted-metric-only-the-values-in-the-middle-of-the-chart-without-a-pie/312265 "2022-08-21T03:52:55Z")

</div>

I'm using Vega to create a Pie visualization that gets its data from an Elasticsearch index. I used the code for the Radial Plot pie example: Radial Plot Example | Vega, but I changed it to use an index and scripted\_metr…

---

## [Options to Create/Add a New Field](https://discuss.elastic.co/t/options-to-create-add-a-new-field/312507)

<div class="topic-metadata">

**Author:** [@Yolanda.darricarrere](https://discuss.elastic.co/u/Yolanda.darricarrere)\
**Replies:** 1\
**Last updated:** [August 21, 2022, 1:53am UTC](https://discuss.elastic.co/t/options-to-create-add-a-new-field/312507 "2022-08-21T01:53:14Z")

</div>

Using the ecommerce data, I want to create a new field that is the total of products.taxful\_price minus products.discount\_amount (make it a double), then add the new field to a line graph using data from the past 7-days.…

---

## [KIbana Status is Yellow and I the pods become unavailable](https://discuss.elastic.co/t/kibana-status-is-yellow-and-i-the-pods-become-unavailable/312512)

<div class="topic-metadata">

**Author:** [@Francisco\_Yanez](https://discuss.elastic.co/u/Francisco_Yanez)\
**Replies:** 0\
**Last updated:** [August 20, 2022, 5:03am UTC](https://discuss.elastic.co/t/kibana-status-is-yellow-and-i-the-pods-become-unavailable/312512 "2022-08-20T05:03:13Z")

</div>

Hello Everyone, I am running the Elastic stack on Kubernetes. Recently I starting having timeouts on my kibana pods, getting alerts and in the kibana dashboard a few of the instances become yellow. I have 4 pods (instan…

[Previous page](https://discuss.elastic.co/c/elastic-stack/kibana/7.md?page=185)

[Next page](https://discuss.elastic.co/c/elastic-stack/kibana/7.md?page=187)
