# Kibana

**URL:** https://discuss.elastic.co/c/elastic-stack/kibana/7.md?page=197

[Latest](https://discuss.elastic.co/latest.md) · [Categories](https://discuss.elastic.co/categories.md) · [Tags](https://discuss.elastic.co/tags.md)

**Page:** 198

---

## [Is it possible to create custom visualization (without Vega)?](https://discuss.elastic.co/t/is-it-possible-to-create-custom-visualization-without-vega/308644)

<div class="topic-metadata">

**Author:** [@Kushal\_Roy](https://discuss.elastic.co/u/Kushal_Roy)\
**Replies:** 2\
**Last updated:** [July 13, 2022, 11:45am UTC](https://discuss.elastic.co/t/is-it-possible-to-create-custom-visualization-without-vega/308644 "2022-07-13T11:45:23Z")

</div>

I want to create a visualization, like a plugin and add it to the dashboard. Is it possible to do so??

---

## [Mass Custom SVG Icons for Map](https://discuss.elastic.co/t/mass-custom-svg-icons-for-map/309455)

<div class="topic-metadata">

**Author:** [@WMask](https://discuss.elastic.co/u/WMask)\
**Replies:** 1\
**Last updated:** [July 13, 2022, 9:05am UTC](https://discuss.elastic.co/t/mass-custom-svg-icons-for-map/309455 "2022-07-13T09:05:30Z")

</div>

My company is trying to add a very large number of SVG Icons (10,000+ individual icons) to our world map visualized on Kibana and link it to data keywords we have in one of our data streams. Does anyone know an easy way…

---

## [Logstash monitoring with metricbeat](https://discuss.elastic.co/t/logstash-monitoring-with-metricbeat/308474)

<div class="topic-metadata">

**Author:** [@Alain\_Bod](https://discuss.elastic.co/u/Alain_Bod)\
**Replies:** 5\
**Last updated:** [July 13, 2022, 7:53am UTC](https://discuss.elastic.co/t/logstash-monitoring-with-metricbeat/308474 "2022-07-13T07:53:51Z")

</div>

Hi, I have an Elastic Cloud cluster running (7.17.3). I'm plugging in a local logstash monitoring with metricbeat (7.17.4). I can see an index .monitoring-logstash-7-mb-2022.06.29 filling in over time. But I can't fin…

---

## [Filebeat cannt connect to kibana](https://discuss.elastic.co/t/filebeat-cannt-connect-to-kibana/309433)

<div class="topic-metadata">

**Author:** [@matin44](https://discuss.elastic.co/u/matin44)\
**Replies:** 2\
**Last updated:** [July 13, 2022, 7:29am UTC](https://discuss.elastic.co/t/filebeat-cannt-connect-to-kibana/309433 "2022-07-13T07:29:39Z")

</div>

i try to setup filebeat on redhat when i run the command "filebeat setup -e" i get error message "Exiting: error connecting to Kibana: fail to get the Kibana version ....." i changed the kibana host name at filebeat.y…

---

## [Dashboard / Pb with global filter](https://discuss.elastic.co/t/dashboard-pb-with-global-filter/307578)

<div class="topic-metadata">

**Author:** [@Phildefer](https://discuss.elastic.co/u/Phildefer)\
**Replies:** 3\
**Last updated:** [July 12, 2022, 7:54pm UTC](https://discuss.elastic.co/t/dashboard-pb-with-global-filter/307578 "2022-07-12T19:54:14Z")

</div>

Hi i have several questions about the filters and the controls in the dashboard : I would like to know if it is possible to disable some filters. I have a map and a table.The map and the table are linked to different i…

---

## [Kibana : communication with cluster elasticsearch](https://discuss.elastic.co/t/kibana-communication-with-cluster-elasticsearch/308754)

<div class="topic-metadata">

**Author:** [@emmanuel\_stevens\_LED](https://discuss.elastic.co/u/emmanuel_stevens_LED)\
**Replies:** 2\
**Last updated:** [July 12, 2022, 5:17pm UTC](https://discuss.elastic.co/t/kibana-communication-with-cluster-elasticsearch/308754 "2022-07-12T17:17:33Z")

</div>

Hello, I am brand new to ELK, i try to make a test environnement at home. I just set up a elastic cluster, it works fine. All my three noeuds connetcts to each other. I installed a kibana server, and i follow the guid…

---

## [ES 7.15.1 APM reporting 302 as failure](https://discuss.elastic.co/t/es-7-15-1-apm-reporting-302-as-failure/309425)

<div class="topic-metadata">

**Author:** [@Roger\_Clark](https://discuss.elastic.co/u/Roger_Clark)\
**Replies:** 0\
**Last updated:** [July 12, 2022, 1:37pm UTC](https://discuss.elastic.co/t/es-7-15-1-apm-reporting-302-as-failure/309425 "2022-07-12T13:37:28Z")

</div>

We're using a C# APM agent (Elastic.Apm 1.14.0, 1.16.1 current) in some of our code to report into an APM server on Elastic Stack, but we're seeing all of our API call responses that return a 302 (Found) as event.outcome…

---

## [Error: Cannot read properties of undefined (reading 'includes')](https://discuss.elastic.co/t/error-cannot-read-properties-of-undefined-reading-includes/303696)

<div class="topic-metadata">

**Author:** [@Amitesh\_Gupta](https://discuss.elastic.co/u/Amitesh_Gupta)\
**Replies:** 10\
**Last updated:** [July 12, 2022, 8:29am UTC](https://discuss.elastic.co/t/error-cannot-read-properties-of-undefined-reading-includes/303696 "2022-07-12T08:29:43Z")

</div>

When I am trying to access security from kibana dashboard I'm getting this error. Error Error: Cannot read properties of undefined (reading 'includes') at c (http://10.9.1.8:5601/50723/bundles/plugin/securitySoluti…

---

## [Recorded Future v1.0.1 Not Populating Intel Properly](https://discuss.elastic.co/t/recorded-future-v1-0-1-not-populating-intel-properly/309231)

<div class="topic-metadata">

**Author:** [@codewriterguy](https://discuss.elastic.co/u/codewriterguy)\
**Replies:** 1\
**Last updated:** [July 11, 2022, 9:21pm UTC](https://discuss.elastic.co/t/recorded-future-v1-0-1-not-populating-intel-properly/309231 "2022-07-11T21:21:42Z")

</div>

Hi, The Recorded Future integration package v1.0.1 appears not to be properly pulling risklists from Recorded Future. Intel is streaming into the instance (screenshot at 22:15UTC): Elastic agent is healthy: I'v…

---

## [Logging configuration Kibana](https://discuss.elastic.co/t/logging-configuration-kibana/308580)

<div class="topic-metadata">

**Author:** [@Lily\_si](https://discuss.elastic.co/u/Lily_si)\
**Replies:** 3\
**Last updated:** [July 11, 2022, 1:40pm UTC](https://discuss.elastic.co/t/logging-configuration-kibana/308580 "2022-07-11T13:40:21Z")

</div>

Hello Everyone, I'm trying to set logging parameters in the file kibana.yml by using the "rolling-file" function, here is my configuration : logging: appenders: rolling-file: type: rolling-file fileNa…

---

## [Kibana map function](https://discuss.elastic.co/t/kibana-map-function/309259)

<div class="topic-metadata">

**Author:** [@Jathurshan\_Sumandira](https://discuss.elastic.co/u/Jathurshan_Sumandira)\
**Replies:** 1\
**Last updated:** [July 10, 2022, 3:47pm UTC](https://discuss.elastic.co/t/kibana-map-function/309259 "2022-07-10T15:47:52Z")

</div>

I am using the kibana map visualization for visualizing my elastic data. I have data on shopping mall locations. So I use the latitude and the longitude of those locations as geo-points and I created a layer on the map a…

---

## [Kibana\] Action failed with 'Request timed out' while CREATE\_NEW\_TARGET -\> CREATE\_NEW\_TARGET in docker swarm environment](https://discuss.elastic.co/t/kibana-action-failed-with-request-timed-out-while-create-new-target-create-new-target-in-docker-swarm-environment/307106)

<div class="topic-metadata">

**Author:** [@itsraj](https://discuss.elastic.co/u/itsraj)\
**Replies:** 3\
**Last updated:** [July 11, 2022, 4:12am UTC](https://discuss.elastic.co/t/kibana-action-failed-with-request-timed-out-while-create-new-target-create-new-target-in-docker-swarm-environment/307106 "2022-07-11T04:12:52Z")

</div>

Hi Community, I am trying to deploy Elastic Cluster with 3 nodes on a docker swarm environment with Kibana. All 4 services (3 elastic and 1 kibana) are running fine. Below image for reference. But Kibana is failing …

---

## [Issue with Embed Kibana Dashboard](https://discuss.elastic.co/t/issue-with-embed-kibana-dashboard/309275)

<div class="topic-metadata">

**Author:** [@soumilshah1995](https://discuss.elastic.co/u/soumilshah1995)\
**Replies:** 0\
**Last updated:** [July 10, 2022, 9:00pm UTC](https://discuss.elastic.co/t/issue-with-embed-kibana-dashboard/309275 "2022-07-10T21:00:10Z")

</div>

Hello all i have spent almost more than 4 hours reading and resolving this issue I have a dashboard which I am trying top embed on the website I went and created a role and assigned the role to the user and added chan…

---

## [Looking for way to search for wildcard with space characters. Does KQL have character escaping?](https://discuss.elastic.co/t/looking-for-way-to-search-for-wildcard-with-space-characters-does-kql-have-character-escaping/309250)

<div class="topic-metadata">

**Author:** [@megaksa](https://discuss.elastic.co/u/megaksa)\
**Replies:** 0\
**Last updated:** [July 9, 2022, 1:57pm UTC](https://discuss.elastic.co/t/looking-for-way-to-search-for-wildcard-with-space-characters-does-kql-have-character-escaping/309250 "2022-07-09T13:57:50Z")

</div>

Basically, I have log strings that I wanted to keep as a wildcard type to be able to search for exact substrings with either wildcard query \*abc\* or with regex /.\*abc.\*/. The problem is that Observability → Logs doesn't…

---

## [Username or password is incorrect. Please try again. / HTTP/1.1 401 Unauthorized](https://discuss.elastic.co/t/username-or-password-is-incorrect-please-try-again-http-1-1-401-unauthorized/309145)

<div class="topic-metadata">

**Author:** [@alexus](https://discuss.elastic.co/u/alexus)\
**Replies:** 3\
**Last updated:** [July 9, 2022, 4:41am UTC](https://discuss.elastic.co/t/username-or-password-is-incorrect-please-try-again-http-1-1-401-unauthorized/309145 "2022-07-09T04:41:33Z")

</div>

Hello World! I'm trying to follow Install Kibana with Docker | Kibana Guide \[7.17\] | Elastic and even though it looks like Kibana started fine: % docker compose logs --tail 1 kibana | {"type":"log","@timestamp":"2022-…

---

## [Ingress Nginx Integration](https://discuss.elastic.co/t/ingress-nginx-integration/309230)

<div class="topic-metadata">

**Author:** [@AlexandreCoelho](https://discuss.elastic.co/u/AlexandreCoelho)\
**Replies:** 0\
**Last updated:** [July 8, 2022, 8:49pm UTC](https://discuss.elastic.co/t/ingress-nginx-integration/309230 "2022-07-08T20:49:49Z")

</div>

Hey, today i have elasticsearch implemented with fluentbit and Kibana, we are using nginx as ingress of my cluster. And I have notice that exist that integration with integrations. I have managed to implement agent …

---

## [Using Custom Elastic Charts Fork in Kibana](https://discuss.elastic.co/t/using-custom-elastic-charts-fork-in-kibana/302780)

<div class="topic-metadata">

**Author:** [@Jacob\_Williams](https://discuss.elastic.co/u/Jacob_Williams)\
**Replies:** 2\
**Last updated:** [July 8, 2022, 4:47pm UTC](https://discuss.elastic.co/t/using-custom-elastic-charts-fork-in-kibana/302780 "2022-07-08T16:47:31Z")

</div>

Like the title suggests I am trying to use a custom fork of elastic-charts in Kibana so I can do some custom themeing, mostly small things like adjusting font size on bar chart to client request. I was able to prepare a…

---

## [Calculate Apdex value in elasticsearch](https://discuss.elastic.co/t/calculate-apdex-value-in-elasticsearch/305955)

<div class="topic-metadata">

**Author:** [@mmartinez](https://discuss.elastic.co/u/mmartinez)\
**Replies:** 6\
**Last updated:** [July 8, 2022, 4:21pm UTC](https://discuss.elastic.co/t/calculate-apdex-value-in-elasticsearch/305955 "2022-07-08T16:21:00Z")

</div>

Hello, Recently, we migrated our New Relic APM stack to escloud but we realised there is no official way to calculate the Apdex value. There is this new User Experience App but some people from our company are still req…

---

## [Add runtime field to system index template](https://discuss.elastic.co/t/add-runtime-field-to-system-index-template/307749)

<div class="topic-metadata">

**Author:** [@mmartinez](https://discuss.elastic.co/u/mmartinez)\
**Replies:** 2\
**Last updated:** [July 8, 2022, 4:08pm UTC](https://discuss.elastic.co/t/add-runtime-field-to-system-index-template/307749 "2022-07-08T16:08:14Z")

</div>

Hello, We have a Data View created based on the .ds-.monitoring-es\* indices. We created a scripted field in that Data View that is working but as elastic says, it is deprecated. We tried to move that scripted field int…

---

## [Flattening JSON string level with other fields](https://discuss.elastic.co/t/flattening-json-string-level-with-other-fields/309182)

<div class="topic-metadata">

**Author:** [@Mostafa\_Talebi](https://discuss.elastic.co/u/Mostafa_Talebi)\
**Replies:** 1\
**Last updated:** [July 8, 2022, 4:03pm UTC](https://discuss.elastic.co/t/flattening-json-string-level-with-other-fields/309182 "2022-07-08T16:03:43Z")

</div>

I have set up my kibana and Elastic. I am getting my logs from Fluentbit. My main app log, which is JSON, is sent by Fluent with other meta fields like this: { "containerId": "foo", "clusterId" : "bar", "s…

---

## [Can't export Data table visualization into CSV](https://discuss.elastic.co/t/cant-export-data-table-visualization-into-csv/307890)

<div class="topic-metadata">

**Author:** [@mmartinez](https://discuss.elastic.co/u/mmartinez)\
**Replies:** 2\
**Last updated:** [July 8, 2022, 3:46pm UTC](https://discuss.elastic.co/t/cant-export-data-table-visualization-into-csv/307890 "2022-07-08T15:46:05Z")

</div>

Hello, We would like to export one of our Data table visualizations into a CSV file but we just have the option to generate PDF and PNG reports. I have seen some examples in different webpages that exported in CSV but w…

---

## [Kibana TSVB Markdown styling](https://discuss.elastic.co/t/kibana-tsvb-markdown-styling/309208)

<div class="topic-metadata">

**Author:** [@Adriann](https://discuss.elastic.co/u/Adriann)\
**Replies:** 1\
**Last updated:** [July 8, 2022, 3:26pm UTC](https://discuss.elastic.co/t/kibana-tsvb-markdown-styling/309208 "2022-07-08T15:26:34Z")

</div>

Hello, I want to create a pretty and highly functional dashboard containing all important information and metrics regarding the whole network. Right now I am working on displaying information on failover status for ASA …

---

## [Kiban show wrong time](https://discuss.elastic.co/t/kiban-show-wrong-time/309193)

<div class="topic-metadata">

**Author:** [@anton.potekhin](https://discuss.elastic.co/u/anton.potekhin)\
**Replies:** 4\
**Last updated:** [July 8, 2022, 3:01pm UTC](https://discuss.elastic.co/t/kiban-show-wrong-time/309193 "2022-07-08T15:01:16Z")

</div>

i have log messages in the following format: {"@timestamp":"2022-07-08T10:01:43.181Z","log.level":"info","message":"verifyReceipt: found receipt","ecs":{"version":"1.6.0"}} @timestamp in UTC. When i check logs in Kiban…

---

## [Log UI doesn't show log.level](https://discuss.elastic.co/t/log-ui-doesnt-show-log-level/309191)

<div class="topic-metadata">

**Author:** [@anton.potekhin](https://discuss.elastic.co/u/anton.potekhin)\
**Replies:** 0\
**Last updated:** [July 8, 2022, 10:26am UTC](https://discuss.elastic.co/t/log-ui-doesnt-show-log-level/309191 "2022-07-08T10:26:52Z")

</div>

I have filebeat that process my logs. Logs in the following format: {"@timestamp":"2022-07-08T10:01:43.181Z","log.level":"info","message":"verifyReceipt: found receipt","ecs":{"version":"1.6.0"}} When i use discover s…

---

## [Dashboard - field Host.hostname not found error](https://discuss.elastic.co/t/dashboard-field-host-hostname-not-found-error/309173)

<div class="topic-metadata">

**Author:** [@Darshana](https://discuss.elastic.co/u/Darshana)\
**Replies:** 3\
**Last updated:** [July 8, 2022, 7:55am UTC](https://discuss.elastic.co/t/dashboard-field-host-hostname-not-found-error/309173 "2022-07-08T07:55:36Z")

</div>

Hi, I'm getting error for Kibana Dashboard : "Field host.hostname was not found Edit in Lens editor to see more errors"

---

## [Anomaly detection](https://discuss.elastic.co/t/anomaly-detection/309098)

<div class="topic-metadata">

**Author:** [@Amit\_Thombre](https://discuss.elastic.co/u/Amit_Thombre)\
**Replies:** 1\
**Last updated:** [July 8, 2022, 2:14am UTC](https://discuss.elastic.co/t/anomaly-detection/309098 "2022-07-08T02:14:23Z")

</div>

We are trying to use anomaly detection from Machine Learning. But very little information is available on the internet regarding it. Can you please help us with the following? Details of anomaly detection algorithm, whi…

---

## [Delegate Authorization from Saml](https://discuss.elastic.co/t/delegate-authorization-from-saml/309013)

<div class="topic-metadata">

**Author:** [@Keemtaker](https://discuss.elastic.co/u/Keemtaker)\
**Replies:** 3\
**Last updated:** [July 8, 2022, 12:35am UTC](https://discuss.elastic.co/t/delegate-authorization-from-saml/309013 "2022-07-08T00:35:46Z")

</div>

I have setup single sign-on via saml and also completed a basic role map. I will like to switch from using role mapping to delegated authorization. So users authenticate via saml but authorization is handled by different…

---

## [No recovery message generated when using Elasticsearch query Kibana Alert type](https://discuss.elastic.co/t/no-recovery-message-generated-when-using-elasticsearch-query-kibana-alert-type/309126)

<div class="topic-metadata">

**Author:** [@Adriann](https://discuss.elastic.co/u/Adriann)\
**Replies:** 4\
**Last updated:** [July 7, 2022, 8:24pm UTC](https://discuss.elastic.co/t/no-recovery-message-generated-when-using-elasticsearch-query-kibana-alert-type/309126 "2022-07-07T20:24:11Z")

</div>

Hello, I want to deploy notification based on custom query. For this scenario, I use logstash to fetch data from devices I want to catch all new documents where i.e. the field "failover.status.message" has a different…

---

## [More complicated calculation/visualisaton - is it possible?](https://discuss.elastic.co/t/more-complicated-calculation-visualisaton-is-it-possible/309136)

<div class="topic-metadata">

**Author:** [@Frantisek\_Sitler](https://discuss.elastic.co/u/Frantisek_Sitler)\
**Replies:** 1\
**Last updated:** [July 7, 2022, 7:52pm UTC](https://discuss.elastic.co/t/more-complicated-calculation-visualisaton-is-it-possible/309136 "2022-07-07T19:52:52Z")

</div>

Hello, I have an issue to create a bit more complex calculation and visualization. It should take data from multiple indices, always an record will be connected via one field - IN number. There is always multiple recor…

---

## [Kibana logs is full](https://discuss.elastic.co/t/kibana-logs-is-full/307903)

<div class="topic-metadata">

**Author:** [@ptang](https://discuss.elastic.co/u/ptang)\
**Replies:** 3\
**Last updated:** [July 7, 2022, 2:55pm UTC](https://discuss.elastic.co/t/kibana-logs-is-full/307903 "2022-07-07T14:55:47Z")

</div>

can anyone help me how to cleanup the kibana.log files under /var/log/kibana directory. kibana.log filled my diskspace and no space to write the logs. Thanks, pradeep

[Previous page](https://discuss.elastic.co/c/elastic-stack/kibana/7.md?page=196)

[Next page](https://discuss.elastic.co/c/elastic-stack/kibana/7.md?page=198)
