# Kibana

**URL:** https://discuss.elastic.co/c/elastic-stack/kibana/7.md?page=2

[Latest](https://discuss.elastic.co/latest.md) · [Categories](https://discuss.elastic.co/categories.md) · [Tags](https://discuss.elastic.co/tags.md)

**Page:** 3

---

## [Kibana shows 500-Internal Server Error after upgrade from 9.3.1 to 9.4.1 when security is turend off](https://discuss.elastic.co/t/kibana-shows-500-internal-server-error-after-upgrade-from-9-3-1-to-9-4-1-when-security-is-turend-off/386504)

<div class="topic-metadata">

**Author:** [@Dheeraj\_Gupta](https://discuss.elastic.co/u/Dheeraj_Gupta)\
**Replies:** 1\
**Last updated:** [May 26, 2026, 2:53pm UTC](https://discuss.elastic.co/t/kibana-shows-500-internal-server-error-after-upgrade-from-9-3-1-to-9-4-1-when-security-is-turend-off/386504 "2026-05-26T14:53:46Z")

</div>

We have deployed Elasticsearch and Kibana on an internal network. The elasticsearch cluster has security and ML disabled xpack.security.enabled: false xpack.security.transport.ssl.enabled: false xpack.security.http.ssl.…

---

## [Problem Updating kibana 8.19 -\> 9.4.1](https://discuss.elastic.co/t/problem-updating-kibana-8-19-9-4-1/386468)

<div class="topic-metadata">

**Author:** [@Shahar\_Argov](https://discuss.elastic.co/u/Shahar_Argov)\
**Replies:** 1\
**Last updated:** [May 24, 2026, 12:24pm UTC](https://discuss.elastic.co/t/problem-updating-kibana-8-19-9-4-1/386468 "2026-05-24T12:24:30Z")

</div>

We have been updating our cluster from 8.19 to 9.4.1, we finished all the nodes except the kibana. when updating we saw the service stuck on \[plugins.screenshotting.chromium\] Browser executable: /usr/share/kibana/node\_mo…

---

## [Elasticsearch Kibana 9.4.0 Basic authentication returns 401 Unauthorized](https://discuss.elastic.co/t/elasticsearch-kibana-9-4-0-basic-authentication-returns-401-unauthorized/386318)

<div class="topic-metadata">

**Author:** [@GeertVerbeurgt](https://discuss.elastic.co/u/GeertVerbeurgt)\
**Replies:** 37\
**Last updated:** [May 22, 2026, 11:05am UTC](https://discuss.elastic.co/t/elasticsearch-kibana-9-4-0-basic-authentication-returns-401-unauthorized/386318 "2026-05-22T11:05:15Z")

</div>

After upgrading from elasticsearch/kibana version 9.3.0 to elasticsearch/kibana 9.4.0 I'm no longer able to login with basic authentication via the Authorization Header. This returns the error 401 Unauthorized. { "ser…

---

## [Where the detection rules store? in which index?](https://discuss.elastic.co/t/where-the-detection-rules-store-in-which-index/386144)

<div class="topic-metadata">

**Author:** [@neshat1485](https://discuss.elastic.co/u/neshat1485)\
**Replies:** 4\
**Last updated:** [May 21, 2026, 9:01am UTC](https://discuss.elastic.co/t/where-the-detection-rules-store-in-which-index/386144 "2026-05-21T09:01:25Z")

</div>

i see that we have an index with the name .kibana\_security\_solution\* that the prebuilt and default detection rules are in this index but i couldn't find the index that store the data of the custom detection rules that w…

---

## [Kibana FATAL log](https://discuss.elastic.co/t/kibana-fatal-log/386352)

<div class="topic-metadata">

**Author:** [@blacknight1019](https://discuss.elastic.co/u/blacknight1019)\
**Replies:** 0\
**Last updated:** [May 15, 2026, 2:09am UTC](https://discuss.elastic.co/t/kibana-fatal-log/386352 "2026-05-15T02:09:22Z")

</div>

I am currently upgrading my ELK stack from version 8.19.14 to version 9.3.3. After setting up Windows Task Scheduler to start the services automatically, I found that Kibana reports the following error in kibana.log. Ho…

---

## [Question on the Default Kibana NodeJS Setting --max-old-space-size=2048](https://discuss.elastic.co/t/question-on-the-default-kibana-nodejs-setting-max-old-space-size-2048/386310)

<div class="topic-metadata">

**Author:** [@metalshanked](https://discuss.elastic.co/u/metalshanked)\
**Replies:** 2\
**Last updated:** [May 15, 2026, 1:57am UTC](https://discuss.elastic.co/t/question-on-the-default-kibana-nodejs-setting-max-old-space-size-2048/386310 "2026-05-15T01:57:21Z")

</div>

The below note for ECK seems to imply that setting the container mem limits should suffice instead of overriding the pod spec template for kibana. https://www.elastic.co/docs/deploy-manage/production-guidance/kibana-con…

---

## [Best practices for dashboards and rules](https://discuss.elastic.co/t/best-practices-for-dashboards-and-rules/386316)

<div class="topic-metadata">

**Author:** [@PatreKerier](https://discuss.elastic.co/u/PatreKerier)\
**Replies:** 0\
**Last updated:** [May 13, 2026, 6:42am UTC](https://discuss.elastic.co/t/best-practices-for-dashboards-and-rules/386316 "2026-05-13T06:42:46Z")

</div>

Good afternoon, colleagues! If it's not too much trouble, could you please share your ready-made correlation rules and dashboards that are really useful to you in practice. According to Best Practice. I will be very gra…

---

## [Kibana does not load in brower](https://discuss.elastic.co/t/kibana-does-not-load-in-brower/385546)

<div class="topic-metadata">

**Author:** [@riahc3](https://discuss.elastic.co/u/riahc3)\
**Replies:** 9\
**Last updated:** [May 12, 2026, 2:00pm UTC](https://discuss.elastic.co/t/kibana-does-not-load-in-brower/385546 "2026-05-12T14:00:17Z")

</div>

Hello I upgraded Kibana 8 to 9 (obviously everything else) but it does not load in my browser. I see this in the logs: tail -f /data/kibana/logs/kibana.log | jq { "service": { "node": { "roles": \[ "background\_tasks…

---

## [Elasticsearch And Kibana Dashboard Ideas for a Hotel Booking and Guest Analytics System](https://discuss.elastic.co/t/elasticsearch-and-kibana-dashboard-ideas-for-a-hotel-booking-and-guest-analytics-system/386301)

<div class="topic-metadata">

**Author:** [@Jixcy001](https://discuss.elastic.co/u/Jixcy001)\
**Replies:** 0\
**Last updated:** [May 12, 2026, 9:21am UTC](https://discuss.elastic.co/t/elasticsearch-and-kibana-dashboard-ideas-for-a-hotel-booking-and-guest-analytics-system/386301 "2026-05-12T09:21:32Z")

</div>

Hello Elastic Community, I’m exploring how Elasticsearch and Kibana can be used for a hospitality/travel project related to a luxury budget hotel in Varanasi called Hotel KB Palace. The idea is to build a small hotel an…

---

## [Kibana Error Reporting](https://discuss.elastic.co/t/kibana-error-reporting/385720)

<div class="topic-metadata">

**Author:** [@geoffrey](https://discuss.elastic.co/u/geoffrey)\
**Replies:** 1\
**Last updated:** [May 12, 2026, 12:43am UTC](https://discuss.elastic.co/t/kibana-error-reporting/385720 "2026-05-12T00:43:13Z")

</div>

I’m interested in other people’s view of the Kibana error reporting, and this is in particular reference to using the DEV TOOLS. With some recent reorganization of indexes I was presented with an error 502. To cut a …

---

## [Averaging last values of multiple beats](https://discuss.elastic.co/t/averaging-last-values-of-multiple-beats/386182)

<div class="topic-metadata">

**Author:** [@Benjamin\_Klein](https://discuss.elastic.co/u/Benjamin_Klein)\
**Replies:** 4\
**Last updated:** [May 7, 2026, 6:28pm UTC](https://discuss.elastic.co/t/averaging-last-values-of-multiple-beats/386182 "2026-05-07T18:28:51Z")

</div>

I have a collection of Heartbeat monitors pinging several different hosts. Each host has multiple services being pinged (by different beats). Is there a way to display, for each host, either the number of beats that came…

---

## [Workflows/fields actions](https://discuss.elastic.co/t/workflows-fields-actions/386190)

<div class="topic-metadata">

**Author:** [@proclick](https://discuss.elastic.co/u/proclick)\
**Replies:** 0\
**Last updated:** [May 6, 2026, 1:52pm UTC](https://discuss.elastic.co/t/workflows-fields-actions/386190 "2026-05-06T13:52:36Z")

</div>

Hey team, The workflows are pretty useful, but you still need to do a lot of extra steps to, for example, check the hash from the alert (without using Trigger Alert and On Alert). Is it planned to add an option to run t…

---

## [We are trying to configure Kibana with Entra ID(Azure Active directory) and it is not working properly](https://discuss.elastic.co/t/we-are-trying-to-configure-kibana-with-entra-id-azure-active-directory-and-it-is-not-working-properly/386130)

<div class="topic-metadata">

**Author:** [@AKAM14](https://discuss.elastic.co/u/AKAM14)\
**Replies:** 4\
**Last updated:** [May 2, 2026, 5:30pm UTC](https://discuss.elastic.co/t/we-are-trying-to-configure-kibana-with-entra-id-azure-active-directory-and-it-is-not-working-properly/386130 "2026-05-02T17:30:13Z")

</div>

Hello Everyone, We are having a onprem cluster 8.17.x where we are trying to configure entra id for kibana login. unable to successfully do it. unfortunately we are not getting any logs in kibana or elk after the config…

---

## [Need help indexing high-frequency manufacturing data from stamping processes in Elasticsearch](https://discuss.elastic.co/t/need-help-indexing-high-frequency-manufacturing-data-from-stamping-processes-in-elasticsearch/386107)

<div class="topic-metadata">

**Author:** [@jixcy](https://discuss.elastic.co/u/jixcy)\
**Replies:** 1\
**Last updated:** [May 2, 2026, 5:40am UTC](https://discuss.elastic.co/t/need-help-indexing-high-frequency-manufacturing-data-from-stamping-processes-in-elasticsearch/386107 "2026-05-02T05:40:01Z")

</div>

Hello everyone, I’m currently working on a real-time industrial data pipeline where we are capturing continuous machine-level outputs from stamping processes in a manufacturing environment. In our setup, we are dealing…

---

## [Custom user guide - Link](https://discuss.elastic.co/t/custom-user-guide-link/386104)

<div class="topic-metadata">

**Author:** [@Vignesh2](https://discuss.elastic.co/u/Vignesh2)\
**Replies:** 1\
**Last updated:** [April 30, 2026, 9:37am UTC](https://discuss.elastic.co/t/custom-user-guide-link/386104 "2026-04-30T09:37:53Z")

</div>

Hi, I have a custom user guide (PDF) that explains how to use our dashboards, alerts, and other features. I’d like to know if there’s a way to integrate or attach this guide directly within the Kibana UI—something like…

---

## [Freeze one or more columns in Lens Table visualisation](https://discuss.elastic.co/t/freeze-one-or-more-columns-in-lens-table-visualisation/378300)

<div class="topic-metadata">

**Author:** [@tallakh](https://discuss.elastic.co/u/tallakh)\
**Replies:** 4\
**Last updated:** [April 29, 2026, 1:15pm UTC](https://discuss.elastic.co/t/freeze-one-or-more-columns-in-lens-table-visualisation/378300 "2026-04-29T13:15:42Z")

</div>

I have a Lens Table that contains quite many columns which leads to a lot of horisontal scrolling. Is it possible to pin/freeze columns? That would make it a lot easier to keep track when scrolling? It would also be rea…

---

## [Alert re-triggering & limited context (recovery actions)](https://discuss.elastic.co/t/alert-re-triggering-limited-context-recovery-actions/386049)

<div class="topic-metadata">

**Author:** [@Actor01](https://discuss.elastic.co/u/Actor01)\
**Replies:** 1\
**Last updated:** [April 29, 2026, 7:42am UTC](https://discuss.elastic.co/t/alert-re-triggering-limited-context-recovery-actions/386049 "2026-04-29T07:42:31Z")

</div>

Hello, we are currently working with Kibana alerting in a production environment and ran into a couple of challenges. We would like to ask if there are recommended approaches or built-in solutions for the following scen…

---

## [How to filter an ESQL dashboard on a field in the index being looked up on](https://discuss.elastic.co/t/how-to-filter-an-esql-dashboard-on-a-field-in-the-index-being-looked-up-on/386052)

<div class="topic-metadata">

**Author:** [@TSlump](https://discuss.elastic.co/u/TSlump)\
**Replies:** 3\
**Last updated:** [April 28, 2026, 10:07am UTC](https://discuss.elastic.co/t/how-to-filter-an-esql-dashboard-on-a-field-in-the-index-being-looked-up-on/386052 "2026-04-28T10:07:39Z")

</div>

Hi, I'm having trouble finding a nice intuitive way to filter an ESQL dashboard. Any ideas would be greatly appreciated ! I have two indices: buildings and rooms, where each room has a building Id. On the dashboard I ha…

---

## [Kibana Workflows and secrets](https://discuss.elastic.co/t/kibana-workflows-and-secrets/386028)

<div class="topic-metadata">

**Author:** [@willemdh](https://discuss.elastic.co/u/willemdh)\
**Replies:** 3\
**Last updated:** [April 25, 2026, 8:27am UTC](https://discuss.elastic.co/t/kibana-workflows-and-secrets/386028 "2026-04-25T08:27:41Z")

</div>

Hello, I’ve been experimenting with Kibana Workflows and really like the direction. It’s a powerful addition for automation and enrichment use cases. One thing I’m currently struggling with is securely handling secrets…

---

## [Kibana 8.19.9 bootstrap reports "Integrity check failed for @elastic/eui"](https://discuss.elastic.co/t/kibana-8-19-9-bootstrap-reports-integrity-check-failed-for-elastic-eui/384414)

<div class="topic-metadata">

**Author:** [@kbujold\_wr](https://discuss.elastic.co/u/kbujold_wr)\
**Replies:** 1\
**Last updated:** [April 23, 2026, 3:35pm UTC](https://discuss.elastic.co/t/kibana-8-19-9-bootstrap-reports-integrity-check-failed-for-elastic-eui/384414 "2026-04-23T15:35:45Z")

</div>

Hi, We have moved from ELK 8.18.3 to ELK 8.19.9. There appears to have been changes with bootstrap. I am getting this error BUILD\_TS\_REFS\_DISABLE=true yarn kbn bootstrap yarn run v1.22.22 $ node --no-experimental-requi…

---

## [Elastic - ESET AV integration](https://discuss.elastic.co/t/elastic-eset-av-integration/385971)

<div class="topic-metadata">

**Author:** [@PatreKerier](https://discuss.elastic.co/u/PatreKerier)\
**Replies:** 2\
**Last updated:** [April 22, 2026, 12:25pm UTC](https://discuss.elastic.co/t/elastic-eset-av-integration/385971 "2026-04-22T12:25:04Z")

</div>

Good afternoon! Please tell me if anyone has configured the integration of ESET AntiVirus with ELASTIC. I deployed a Linux-based syslog server, specified the address and port 514 or 6514 in ESET, but there are no logs, …

---

## [Palo alto (pan Metrics) integration tips](https://discuss.elastic.co/t/palo-alto-pan-metrics-integration-tips/385943)

<div class="topic-metadata">

**Author:** [@a.elbacha](https://discuss.elastic.co/u/a.elbacha)\
**Replies:** 0\
**Last updated:** [April 19, 2026, 7:04pm UTC](https://discuss.elastic.co/t/palo-alto-pan-metrics-integration-tips/385943 "2026-04-19T19:04:27Z")

</div>

I am trying to integrate PAN with ELK to fetch metrics and later on enable anomaly detection to proactively detect any connections failure or packet drops. Moreover, is it supported in service Maps to visualize the traf…

---

## [Kibana 9.3.1 Disabling message "New! Connect AutoOps to this self-managed cluster"](https://discuss.elastic.co/t/kibana-9-3-1-disabling-message-new-connect-autoops-to-this-self-managed-cluster/385736)

<div class="topic-metadata">

**Author:** [@kbujold\_wr](https://discuss.elastic.co/u/kbujold_wr)\
**Replies:** 14\
**Last updated:** [April 16, 2026, 10:10am UTC](https://discuss.elastic.co/t/kibana-9-3-1-disabling-message-new-connect-autoops-to-this-self-managed-cluster/385736 "2026-04-16T10:10:01Z")

</div>

We would like to not present this message to our users. Is there a way this disable this?

---

## [Embedding Kibana Dashboards with multiple anon accounts](https://discuss.elastic.co/t/embedding-kibana-dashboards-with-multiple-anon-accounts/385905)

<div class="topic-metadata">

**Author:** [@HermanDev](https://discuss.elastic.co/u/HermanDev)\
**Replies:** 1\
**Last updated:** [April 16, 2026, 7:27am UTC](https://discuss.elastic.co/t/embedding-kibana-dashboards-with-multiple-anon-accounts/385905 "2026-04-16T07:27:59Z")

</div>

Here is my use case: We built 4 analytics dashboards, and would like to have those 4 dashboards embedded into our site. I have managed to get this working using anonymous accounts. The problem we are facing is that ou…

---

## [Kibana visualizations dont load upon opening from a formed URL via python and posted in slack](https://discuss.elastic.co/t/kibana-visualizations-dont-load-upon-opening-from-a-formed-url-via-python-and-posted-in-slack/385890)

<div class="topic-metadata">

**Author:** [@shinysap](https://discuss.elastic.co/u/shinysap)\
**Replies:** 3\
**Last updated:** [April 15, 2026, 11:17am UTC](https://discuss.elastic.co/t/kibana-visualizations-dont-load-upon-opening-from-a-formed-url-via-python-and-posted-in-slack/385890 "2026-04-15T11:17:37Z")

</div>

Kibana visualizations dont load upon opening from a formed URL via python and posted in slack Its a line chart visulization. But when i open the dashboard direct from the dashboards page and paste the KQL it works.

---

## [ELK Kibana 9.3.1 How do we disable the AI Assistant?](https://discuss.elastic.co/t/elk-kibana-9-3-1-how-do-we-disable-the-ai-assistant/385822)

<div class="topic-metadata">

**Author:** [@kbujold\_wr](https://discuss.elastic.co/u/kbujold_wr)\
**Replies:** 7\
**Last updated:** [April 12, 2026, 6:02am UTC](https://discuss.elastic.co/t/elk-kibana-9-3-1-how-do-we-disable-the-ai-assistant/385822 "2026-04-12T06:02:46Z")

</div>

How can we disable the AI Assistant button on the top bar?

---

## [Unable to view rule detail. (Unable to load rule)](https://discuss.elastic.co/t/unable-to-view-rule-detail-unable-to-load-rule/385837)

<div class="topic-metadata">

**Author:** [@Whoami1980](https://discuss.elastic.co/u/Whoami1980)\
**Replies:** 2\
**Last updated:** [April 10, 2026, 6:19am UTC](https://discuss.elastic.co/t/unable-to-view-rule-detail-unable-to-load-rule/385837 "2026-04-10T06:19:53Z")

</div>

Alerts trigger. However unable to view rule detail. (Unable to load rule)

---

## [Delete saved object of type url via Kibana 7 API](https://discuss.elastic.co/t/delete-saved-object-of-type-url-via-kibana-7-api/385805)

<div class="topic-metadata">

**Author:** [@mikewillis](https://discuss.elastic.co/u/mikewillis)\
**Replies:** 5\
**Last updated:** [April 9, 2026, 1:53pm UTC](https://discuss.elastic.co/t/delete-saved-object-of-type-url-via-kibana-7-api/385805 "2026-04-09T13:53:34Z")

</div>

Ahead of upgrading Kibana from 7 (yes I know) to 8, I'm looking at ~1500 short URLs which it has been decided are no longer needed. (N.B. Some short URLs are still wanted.) Deleting them using the Kibana GUI would be exc…

---

## [Disable auto create data view](https://discuss.elastic.co/t/disable-auto-create-data-view/385795)

<div class="topic-metadata">

**Author:** [@tmp13](https://discuss.elastic.co/u/tmp13)\
**Replies:** 7\
**Last updated:** [April 8, 2026, 7:37am UTC](https://discuss.elastic.co/t/disable-auto-create-data-view/385795 "2026-04-08T07:37:44Z")

</div>

Hi. I use Kibana 9.3 I cant find how to disable auto create dataview like: logs-\* metrics-\* All logs Thnx.

---

## [Search url Saved Objects by Title](https://discuss.elastic.co/t/search-url-saved-objects-by-title/385701)

<div class="topic-metadata">

**Author:** [@mikewillis](https://discuss.elastic.co/u/mikewillis)\
**Replies:** 4\
**Last updated:** [April 7, 2026, 3:35pm UTC](https://discuss.elastic.co/t/search-url-saved-objects-by-title/385701 "2026-04-07T15:35:43Z")

</div>

Kibana 7.17.28 (yes, I know.) In the Stack Management \> Saved Objects section there is a Search field. I want to search for objects of type url with a given Title, or even a given id attribute which I've extracted from …

[Previous page](https://discuss.elastic.co/c/elastic-stack/kibana/7.md?page=1)

[Next page](https://discuss.elastic.co/c/elastic-stack/kibana/7.md?page=3)
