# Kibana

**URL:** https://discuss.elastic.co/c/elastic-stack/kibana/7.md?page=231

[Latest](https://discuss.elastic.co/latest.md) · [Categories](https://discuss.elastic.co/categories.md) · [Tags](https://discuss.elastic.co/tags.md)

**Page:** 232

---

## [Kibana error after upgrade to version 8.0 \[config validation of \[logging\].dest\]: definition for this key is missing\]](https://discuss.elastic.co/t/kibana-error-after-upgrade-to-version-8-0-config-validation-of-logging-dest-definition-for-this-key-is-missing/297948)

<div class="topic-metadata">

**Author:** [@Shreesh\_Narayanan](https://discuss.elastic.co/u/Shreesh_Narayanan)\
**Replies:** 3\
**Last updated:** [March 11, 2022, 11:03pm UTC](https://discuss.elastic.co/t/kibana-error-after-upgrade-to-version-8-0-config-validation-of-logging-dest-definition-for-this-key-is-missing/297948 "2022-03-11T23:03:26Z")

</div>

Hi, I had successfully upgraded to version 8.0 on ELK , while the rest of the stack works , kibana has failed to start citing dev-elk-app01 kibana\[19018\]: FATAL Error: \[config validation of \[logging\].dest\]: definitio…

---

## [Not able to create role mapping in kibana](https://discuss.elastic.co/t/not-able-to-create-role-mapping-in-kibana/299472)

<div class="topic-metadata">

**Author:** [@Amisha\_Thakkar1](https://discuss.elastic.co/u/Amisha_Thakkar1)\
**Replies:** 3\
**Last updated:** [March 11, 2022, 8:44pm UTC](https://discuss.elastic.co/t/not-able-to-create-role-mapping-in-kibana/299472 "2022-03-11T20:44:37Z")

</div>

I have assigned one user as superuser and I am trying to search for role mapping under stack management in Kibana. But I am not able to see that. Even I tried to assign role using role mapping api. Still not able to log…

---

## [Turn off sending time range filter when using drilldown](https://discuss.elastic.co/t/turn-off-sending-time-range-filter-when-using-drilldown/298632)

<div class="topic-metadata">

**Author:** [@Rick\_V](https://discuss.elastic.co/u/Rick_V)\
**Replies:** 2\
**Last updated:** [March 11, 2022, 3:58pm UTC](https://discuss.elastic.co/t/turn-off-sending-time-range-filter-when-using-drilldown/298632 "2022-03-11T15:58:27Z")

</div>

Hi, I'm using drilldowns in dashboards to give a deeper detail into the visualization. I use several visualizations like line and area graph to give an insight over time like the derivative. However when i click on a do…

---

## [How to get and create users using the Kibana API](https://discuss.elastic.co/t/how-to-get-and-create-users-using-the-kibana-api/299408)

<div class="topic-metadata">

**Author:** [@Amphagory](https://discuss.elastic.co/u/Amphagory)\
**Replies:** 2\
**Last updated:** [March 11, 2022, 2:25pm UTC](https://discuss.elastic.co/t/how-to-get-and-create-users-using-the-kibana-api/299408 "2022-03-11T14:25:20Z")

</div>

Hello, I'm using the Elastic cloud service and the version I'm using is 7.16.2 I'm trying to get and create users from the following documentation using Postman and a Python script, GET user: Get users API | Elasti…

---

## [Missing privileges - Stack rules not showing as rule type on creating new alert](https://discuss.elastic.co/t/missing-privileges-stack-rules-not-showing-as-rule-type-on-creating-new-alert/299437)

<div class="topic-metadata">

**Author:** [@Mark\_Veenstra](https://discuss.elastic.co/u/Mark_Veenstra)\
**Replies:** 0\
**Last updated:** [March 11, 2022, 11:10am UTC](https://discuss.elastic.co/t/missing-privileges-stack-rules-not-showing-as-rule-type-on-creating-new-alert/299437 "2022-03-11T11:10:33Z")

</div>

Within Kibana we would like to configure alert rules. When I navigate to the alerts and want to create a new rule. Some users do not have the option for Elasticsearch query based rules and/or index threshold rules. It s…

---

## [Keycloak with ELK stack](https://discuss.elastic.co/t/keycloak-with-elk-stack/299311)

<div class="topic-metadata">

**Author:** [@shivendra95](https://discuss.elastic.co/u/shivendra95)\
**Replies:** 3\
**Last updated:** [March 11, 2022, 6:23am UTC](https://discuss.elastic.co/t/keycloak-with-elk-stack/299311 "2022-03-11T06:23:17Z")

</div>

I'm trying to use Keycloak to login into kibana dashboard. Can anyone help me on this as some of the solutions I found on the forum were not working out for me.

---

## [Kibana server is not ready yet](https://discuss.elastic.co/t/kibana-server-is-not-ready-yet/299385)

<div class="topic-metadata">

**Author:** [@AlexIch](https://discuss.elastic.co/u/AlexIch)\
**Replies:** 7\
**Last updated:** [March 11, 2022, 1:56am UTC](https://discuss.elastic.co/t/kibana-server-is-not-ready-yet/299385 "2022-03-11T01:56:36Z")

</div>

HI guys Im getting Kibana server is not ready yet error when Opening Kibana dashboard Elasticsearch.yml: cluster.name: xiake-els-server node.name: node-1 path.data: /data/Elasticsearch/data path.logs: /data/Elastic…

---

## [How do I logout of Kibana](https://discuss.elastic.co/t/how-do-i-logout-of-kibana/299015)

<div class="topic-metadata">

**Author:** [@codewriterguy](https://discuss.elastic.co/u/codewriterguy)\
**Replies:** 8\
**Last updated:** [March 10, 2022, 11:18pm UTC](https://discuss.elastic.co/t/how-do-i-logout-of-kibana/299015 "2022-03-10T23:18:39Z")

</div>

I know this is incredibly basic and I'm not trolling, I can't find a logout button

---

## [Unable to create kibana readonly dashboard after upgrade](https://discuss.elastic.co/t/unable-to-create-kibana-readonly-dashboard-after-upgrade/299362)

<div class="topic-metadata">

**Author:** [@ksk\_droid](https://discuss.elastic.co/u/ksk_droid)\
**Replies:** 0\
**Last updated:** [March 10, 2022, 7:05pm UTC](https://discuss.elastic.co/t/unable-to-create-kibana-readonly-dashboard-after-upgrade/299362 "2022-03-10T19:05:27Z")

</div>

Currently my Kibana/Elasticsearch version is 7.17.1 community edition. I installed it on Ubuntu. Earlier I was able to create on readonly dahsboard. Now when I want to add the newly created dashboard in admin role to …

---

## [Table Chart showing incorrect doc "Count percentage"](https://discuss.elastic.co/t/table-chart-showing-incorrect-doc-count-percentage/298762)

<div class="topic-metadata">

**Author:** [@Divyank\_Mahalle](https://discuss.elastic.co/u/Divyank_Mahalle)\
**Replies:** 2\
**Last updated:** [March 10, 2022, 5:33pm UTC](https://discuss.elastic.co/t/table-chart-showing-incorrect-doc-count-percentage/298762 "2022-03-10T17:33:05Z")

</div>

Hi, I created a table in kibana viz with elastic version 7.6.1. It's showing the incorrect "Count Percentage" tab in the table. I checked the config of Table viz,but still unable to solve this. Snap-Incorrect percent…

---

## [Canvas Issue - math](https://discuss.elastic.co/t/canvas-issue-math/299090)

<div class="topic-metadata">

**Author:** [@PaulaCM](https://discuss.elastic.co/u/PaulaCM)\
**Replies:** 2\
**Last updated:** [March 10, 2022, 4:07pm UTC](https://discuss.elastic.co/t/canvas-issue-math/299090 "2022-03-10T16:07:24Z")

</div>

Hey! I don't know if someone got this issue or knows how to help: I am doing a SQL query which is working fine: // SELECT COUNT(DISTINCT "idVisit") FROM "test" but when displaying an error appears "Whoops! Expressi…

---

## [Logstash Log Stream](https://discuss.elastic.co/t/logstash-log-stream/299262)

<div class="topic-metadata">

**Author:** [@laolao](https://discuss.elastic.co/u/laolao)\
**Replies:** 3\
**Last updated:** [March 10, 2022, 3:55pm UTC](https://discuss.elastic.co/t/logstash-log-stream/299262 "2022-03-10T15:55:34Z")

</div>

I have a basic configuration of logstash sending syslogs to Elasticsearch. I created my index pattern and can make visualizations, etc. However, I want to view the logs in real time on my dashboard. My dashboard has 4 d…

---

## [Is it possible to monitor 2 different infrastructures?](https://discuss.elastic.co/t/is-it-possible-to-monitor-2-different-infrastructures/298590)

<div class="topic-metadata">

**Author:** [@Teckinfor](https://discuss.elastic.co/u/Teckinfor)\
**Replies:** 1\
**Last updated:** [March 10, 2022, 3:39pm UTC](https://discuss.elastic.co/t/is-it-possible-to-monitor-2-different-infrastructures/298590 "2022-03-10T15:39:52Z")

</div>

Hello, I would like to be able to monitor 2 infrastructures at the same time, I have created a space for each infrastructure as well as 2 agent policies linked to the agents of their own infrastructure. I was wondering…

---

## [Elasticsearch SQL - How to query data only from yesterday](https://discuss.elastic.co/t/elasticsearch-sql-how-to-query-data-only-from-yesterday/299151)

<div class="topic-metadata">

**Author:** [@ezra](https://discuss.elastic.co/u/ezra)\
**Replies:** 1\
**Last updated:** [March 10, 2022, 3:38pm UTC](https://discuss.elastic.co/t/elasticsearch-sql-how-to-query-data-only-from-yesterday/299151 "2022-03-10T15:38:44Z")

</div>

Hello everyone. I am looking to query data from yesterday, excluding the data from today. I have figured out how to do this when inputting a specific date and subtracting 1 day. However, I need it to be from today's dat…

---

## [Kibana error opening transforms page](https://discuss.elastic.co/t/kibana-error-opening-transforms-page/297780)

<div class="topic-metadata">

**Author:** [@gentle\_ghost](https://discuss.elastic.co/u/gentle_ghost)\
**Replies:** 3\
**Last updated:** [March 10, 2022, 1:56pm UTC](https://discuss.elastic.co/t/kibana-error-opening-transforms-page/297780 "2022-03-10T13:56:00Z")

</div>

Hello, I've been working on transforms today without much of an issue. I went to create another transform in the Kibana UI but as soon as I click "create transform" the page loads with the following error: \> Error: Fa…

---

## [How to do wildcard query search for "scenario-d3". I get no hits when '-' is added in my query. Any help is appreciated](https://discuss.elastic.co/t/how-to-do-wildcard-query-search-for-scenario-d3-i-get-no-hits-when-is-added-in-my-query-any-help-is-appreciated/299218)

<div class="topic-metadata">

**Author:** [@soumyas](https://discuss.elastic.co/u/soumyas)\
**Replies:** 0\
**Last updated:** [March 9, 2022, 12:59pm UTC](https://discuss.elastic.co/t/how-to-do-wildcard-query-search-for-scenario-d3-i-get-no-hits-when-is-added-in-my-query-any-help-is-appreciated/299218 "2022-03-09T12:59:45Z")

</div>

{ "bool": { "filter": \[ { "wildcard": { "test.value": { "wildcard": "scenario-", "boost": 1 } } } \], Can you please help dadoonet

---

## [Variable-value is displaying as an array for nested field in kibana](https://discuss.elastic.co/t/variable-value-is-displaying-as-an-array-for-nested-field-in-kibana/298256)

<div class="topic-metadata">

**Author:** [@Onkel\_Bob](https://discuss.elastic.co/u/Onkel_Bob)\
**Replies:** 4\
**Last updated:** [March 10, 2022, 12:28pm UTC](https://discuss.elastic.co/t/variable-value-is-displaying-as-an-array-for-nested-field-in-kibana/298256 "2022-03-10T12:28:04Z")

</div>

kibana 7.17.0 Ubuntu 20.04 The json looks like "attempt": \[ { "responsecode": 250, "responsendr": "2.0.0", "transportid": "relay", "duration": 0.50850701, "jobid": ""…

---

## [From Elasticsearch aggregations to Kibana dashboard](https://discuss.elastic.co/t/from-elasticsearch-aggregations-to-kibana-dashboard/299241)

<div class="topic-metadata">

**Author:** [@bianca6](https://discuss.elastic.co/u/bianca6)\
**Replies:** 1\
**Last updated:** [March 10, 2022, 12:25pm UTC](https://discuss.elastic.co/t/from-elasticsearch-aggregations-to-kibana-dashboard/299241 "2022-03-10T12:25:38Z")

</div>

Hi, IN A FEW WORDS: I would like to display on a Kibana dashboard some duration calculated from my logs with the help of Elasticsearch aggregation. PRECISELY: I have some logs like this (simplified): timestamp = 10,…

---

## [Alert results are showing incorrect](https://discuss.elastic.co/t/alert-results-are-showing-incorrect/298647)

<div class="topic-metadata">

**Author:** [@vishal\_bisa](https://discuss.elastic.co/u/vishal_bisa)\
**Replies:** 5\
**Last updated:** [March 10, 2022, 11:03am UTC](https://discuss.elastic.co/t/alert-results-are-showing-incorrect/298647 "2022-03-10T11:03:38Z")

</div>

Hi Team, I have created a watcher to detect for failed status in a particular index, attached the screenshot for reference. the watcher seems to be working fine, but when i have observed care fully the results are quit…

---

## [Using port 443 to access kibanan (solution)](https://discuss.elastic.co/t/using-port-443-to-access-kibanan-solution/299317)

<div class="topic-metadata">

**Author:** [@shharukh](https://discuss.elastic.co/u/shharukh)\
**Replies:** 0\
**Last updated:** [March 10, 2022, 10:11am UTC](https://discuss.elastic.co/t/using-port-443-to-access-kibanan-solution/299317 "2022-03-10T10:11:53Z")

</div>

Continuing the discussion from How to use port 443 to access Kibana. legacy-multitenancy error: sorry for the delay in my answer. solution setcap 'CAP\_NET\_BIND\_SERVICE=+eip' /usr/share/kibana/node/bin/node then ch…

---

## [Kibana error after upgrade to version 8.0 from 7.17.0 \[No validation schema has been defined for \[xpack.canvas\]](https://discuss.elastic.co/t/kibana-error-after-upgrade-to-version-8-0-from-7-17-0-no-validation-schema-has-been-defined-for-xpack-canvas/298352)

<div class="topic-metadata">

**Author:** [@sumitpramanik](https://discuss.elastic.co/u/sumitpramanik)\
**Replies:** 5\
**Last updated:** [March 10, 2022, 9:37am UTC](https://discuss.elastic.co/t/kibana-error-after-upgrade-to-version-8-0-from-7-17-0-no-validation-schema-has-been-defined-for-xpack-canvas/298352 "2022-03-10T09:37:07Z")

</div>

Hi, I have updated my elasticstack from version 7.17 to 8.0 recenly. All of my 3 Elasticsearch nodes and 2 logstash nodes are working fine. But whenever I am trying to upgrade to Kibana version 8.0 it is thowing below e…

---

## [Unable to filter on data\_stream.namespace via Log Stream in Dashboard](https://discuss.elastic.co/t/unable-to-filter-on-data-stream-namespace-via-log-stream-in-dashboard/298736)

<div class="topic-metadata">

**Author:** [@Josh\_G](https://discuss.elastic.co/u/Josh_G)\
**Replies:** 4\
**Last updated:** [March 10, 2022, 9:11am UTC](https://discuss.elastic.co/t/unable-to-filter-on-data-stream-namespace-via-log-stream-in-dashboard/298736 "2022-03-10T09:11:49Z")

</div>

When selecting Log Stream when creating a Dashboard there are no available data stream or namespace fields to filter on only event.dataset and we'd rather not have to use unique datasets (due to the additional indicies t…

---

## [Kibana - Unable to retrieve version information from Elasticsearch nodes. self signed certificate in certificate chain](https://discuss.elastic.co/t/kibana-unable-to-retrieve-version-information-from-elasticsearch-nodes-self-signed-certificate-in-certificate-chain/299159)

<div class="topic-metadata">

**Author:** [@elasticScrub](https://discuss.elastic.co/u/elasticScrub)\
**Replies:** 6\
**Last updated:** [March 10, 2022, 5:01am UTC](https://discuss.elastic.co/t/kibana-unable-to-retrieve-version-information-from-elasticsearch-nodes-self-signed-certificate-in-certificate-chain/299159 "2022-03-10T05:01:55Z")

</div>

When starting Kibana, I'm getting the following message: \[ERROR\]\[elasticsearch-service\] Unable to retrieve version information from Elasticsearch nodes. self signed certificate in certificate chain root@ubuntu:~# syste…

---

## [Can't establish a secure connection](https://discuss.elastic.co/t/cant-establish-a-secure-connection/299224)

<div class="topic-metadata">

**Author:** [@bibilena](https://discuss.elastic.co/u/bibilena)\
**Replies:** 1\
**Last updated:** [March 9, 2022, 9:50pm UTC](https://discuss.elastic.co/t/cant-establish-a-secure-connection/299224 "2022-03-09T21:50:45Z")

</div>

Hello, I have some problem: I have a docker-compose with Elasticsearch, Kibana and Enterprise Search. all work locally but I need https to use connector with a custom domain name. When I try, I have an error: "Safari ca…

---

## [The overall view of the logs on the screen is very small. We are able to see only 3 to 4 logs in the page even if we hide the chart and using the tiny scroll bar is difficult](https://discuss.elastic.co/t/the-overall-view-of-the-logs-on-the-screen-is-very-small-we-are-able-to-see-only-3-to-4-logs-in-the-page-even-if-we-hide-the-chart-and-using-the-tiny-scroll-bar-is-difficult/299219)

<div class="topic-metadata">

**Author:** [@anushyaadam](https://discuss.elastic.co/u/anushyaadam)\
**Replies:** 1\
**Last updated:** [March 9, 2022, 9:49pm UTC](https://discuss.elastic.co/t/the-overall-view-of-the-logs-on-the-screen-is-very-small-we-are-able-to-see-only-3-to-4-logs-in-the-page-even-if-we-hide-the-chart-and-using-the-tiny-scroll-bar-is-difficult/299219 "2022-03-09T21:49:54Z")

</div>

---

## [Need to change Kibana defaultRoute/path/uri from /app/kibana to /app/kibana76](https://discuss.elastic.co/t/need-to-change-kibana-defaultroute-path-uri-from-app-kibana-to-app-kibana76/299216)

<div class="topic-metadata">

**Author:** [@kumar716](https://discuss.elastic.co/u/kumar716)\
**Replies:** 2\
**Last updated:** [March 9, 2022, 9:47pm UTC](https://discuss.elastic.co/t/need-to-change-kibana-defaultroute-path-uri-from-app-kibana-to-app-kibana76/299216 "2022-03-09T21:47:48Z")

</div>

Hi, Requirement: we have 2 kibana servers (different versions) running on same vm. Old kibana is running on version 6 (port 5601), new kibana is running on version 7.6.2 (port 5611 with ssl enabled). The default UI ur…

---

## [Need to bypass authentication in iframe](https://discuss.elastic.co/t/need-to-bypass-authentication-in-iframe/299175)

<div class="topic-metadata">

**Author:** [@shivendra95](https://discuss.elastic.co/u/shivendra95)\
**Replies:** 1\
**Last updated:** [March 9, 2022, 5:39pm UTC](https://discuss.elastic.co/t/need-to-bypass-authentication-in-iframe/299175 "2022-03-09T17:39:04Z")

</div>

I have an iframe which I need to embed in our application, but whenever I tried to access the iframe a login page comes. I need to bypass this authentication as this page will be accessed by client. I have found same que…

---

## [Top 50 Fields based on per second average count](https://discuss.elastic.co/t/top-50-fields-based-on-per-second-average-count/298734)

<div class="topic-metadata">

**Author:** [@jaysolanki](https://discuss.elastic.co/u/jaysolanki)\
**Replies:** 3\
**Last updated:** [March 9, 2022, 2:59pm UTC](https://discuss.elastic.co/t/top-50-fields-based-on-per-second-average-count/298734 "2022-03-09T14:59:37Z")

</div>

Hi All, I'm trying to create a visualization on kibana for top 50 entries of a certain field based on it's average count per second, but not able to achieve the same yet. Have tried it to shocase as table

---

## [Kibana 8.0.0 - Unknown configuration key(s): "kibana.index"](https://discuss.elastic.co/t/kibana-8-0-0-unknown-configuration-key-s-kibana-index/299228)

<div class="topic-metadata">

**Author:** [@Harish619](https://discuss.elastic.co/u/Harish619)\
**Replies:** 1\
**Last updated:** [March 9, 2022, 2:48pm UTC](https://discuss.elastic.co/t/kibana-8-0-0-unknown-configuration-key-s-kibana-index/299228 "2022-03-09T14:48:43Z")

</div>

Hi Team - After i upgraded to 8.0.0 from 7.17.0 . Im getting below error. What is the alternative syntax for "kibana.index" in 8.0.0 FATAL Error: Unknown configuration key(s): "kibana.index". Check for spelling erro…

---

## [How config "Allow for cookie's SameSite" in YAML type CDRS?](https://discuss.elastic.co/t/how-config-allow-for-cookies-samesite-in-yaml-type-cdrs/299209)

<div class="topic-metadata">

**Author:** [@Pablo\_Andrei](https://discuss.elastic.co/u/Pablo_Andrei)\
**Replies:** 0\
**Last updated:** [March 9, 2022, 12:05pm UTC](https://discuss.elastic.co/t/how-config-allow-for-cookies-samesite-in-yaml-type-cdrs/299209 "2022-03-09T12:05:50Z")

</div>

I need to use EMBED CODE for displaying dashboards, but I need the parameters to: xpack.security.secureCookies: true xpack.security.sameSiteCookies: None or XPACK\_SECURITY\_SECURECOOKIES=true XPACK\_SECURITY\_SAMESICOO…

[Previous page](https://discuss.elastic.co/c/elastic-stack/kibana/7.md?page=230)

[Next page](https://discuss.elastic.co/c/elastic-stack/kibana/7.md?page=232)
