# Kibana

**URL:** https://discuss.elastic.co/c/elastic-stack/kibana/7.md?page=4

[Latest](https://discuss.elastic.co/latest.md) · [Categories](https://discuss.elastic.co/categories.md) · [Tags](https://discuss.elastic.co/tags.md)

**Page:** 5

---

## ["Explore in Discover" produces very long URLs](https://discuss.elastic.co/t/explore-in-discover-produces-very-long-urls/385236)

<div class="topic-metadata">

**Author:** [@xcq1](https://discuss.elastic.co/u/xcq1)\
**Replies:** 2\
**Last updated:** [February 27, 2026, 1:15pm UTC](https://discuss.elastic.co/t/explore-in-discover-produces-very-long-urls/385236 "2026-02-27T13:15:54Z")

</div>

Hello there, I have a Lens Visualization using a table where I now want to look at the matching records in Discover in detail. So I try to click “Explore in Discover”, but that forwards me to a link with 11,000+ charact…

---

## [Cluster overview not working](https://discuss.elastic.co/t/cluster-overview-not-working/385180)

<div class="topic-metadata">

**Author:** [@juancamiloll](https://discuss.elastic.co/u/juancamiloll)\
**Replies:** 1\
**Last updated:** [February 24, 2026, 8:25pm UTC](https://discuss.elastic.co/t/cluster-overview-not-working/385180 "2026-02-24T20:25:46Z")

</div>

Hello, I am currently on version 8.19.8 and am preparing to first upgrade to the latest version of 8.x and then to 9.x. In “Upgrade Assistant,” I set out to remove the warnings I had, and when I got to the last one rel…

---

## [Kibana Options List Controls](https://discuss.elastic.co/t/kibana-options-list-controls/385080)

<div class="topic-metadata">

**Author:** [@Vignesh2](https://discuss.elastic.co/u/Vignesh2)\
**Replies:** 3\
**Last updated:** [February 22, 2026, 6:17am UTC](https://discuss.elastic.co/t/kibana-options-list-controls/385080 "2026-02-22T06:17:09Z")

</div>

Hi Team, I’m facing an issue with Options List Controls in Kibana dashboards. When the field used in the control has less than 100 unique values, the behavior works as expected. If I type a value in the control search …

---

## [Kibana permissions - different behavior between read and custom privileges](https://discuss.elastic.co/t/kibana-permissions-different-behavior-between-read-and-custom-privileges/385112)

<div class="topic-metadata">

**Author:** [@Ror](https://discuss.elastic.co/u/Ror)\
**Replies:** 1\
**Last updated:** [February 19, 2026, 1:50pm UTC](https://discuss.elastic.co/t/kibana-permissions-different-behavior-between-read-and-custom-privileges/385112 "2026-02-19T13:50:58Z")

</div>

I recently migrated from elastic cloud to elastic cloud on kubernetes. In order to migrate, I restored a snapshot with all the users and roles. I wanted to make a change to a custom role I created to allow a user to crea…

---

## [mTLS configuration confusion between Elasticsearch & Kibana](https://discuss.elastic.co/t/mtls-configuration-confusion-between-elasticsearch-kibana/385105)

<div class="topic-metadata">

**Author:** [@Reviving9721](https://discuss.elastic.co/u/Reviving9721)\
**Replies:** 2\
**Last updated:** [February 19, 2026, 2:38am UTC](https://discuss.elastic.co/t/mtls-configuration-confusion-between-elasticsearch-kibana/385105 "2026-02-19T02:38:32Z")

</div>

Currently attempting to configure mTLS between Elasticsearch & Kibana, but I am getting this error… (stack 9.3.0) \[2026-02-18T15:25:30,182\]\[WARN \]\[o.e.h.AbstractHttpServerTransport\] \[testelastic.internal\] caught excepti…

---

## [Lens Table is always sorted on "oldest" / leftmost column - need to sort on "newest" / rightmost column](https://discuss.elastic.co/t/lens-table-is-always-sorted-on-oldest-leftmost-column-need-to-sort-on-newest-rightmost-column/385015)

<div class="topic-metadata">

**Author:** [@Erik\_Reuter](https://discuss.elastic.co/u/Erik_Reuter)\
**Replies:** 1\
**Last updated:** [February 15, 2026, 11:16am UTC](https://discuss.elastic.co/t/lens-table-is-always-sorted-on-oldest-leftmost-column-need-to-sort-on-newest-rightmost-column/385015 "2026-02-15T11:16:41Z")

</div>

I have created a Table, where I would like for it to automatically sort records on the column having the newest date, but it defaults to sorting on the oldest date… we use this on a overhead screen showing general status…

---

## [Kibana Cross-Site Scripting Vulnerability - Unencoded Character in JSON Response](https://discuss.elastic.co/t/kibana-cross-site-scripting-vulnerability-unencoded-character-in-json-response/385041)

<div class="topic-metadata">

**Author:** [@Rakesh\_Bhalani](https://discuss.elastic.co/u/Rakesh_Bhalani)\
**Replies:** 1\
**Last updated:** [February 13, 2026, 1:42pm UTC](https://discuss.elastic.co/t/kibana-cross-site-scripting-vulnerability-unencoded-character-in-json-response/385041 "2026-02-13T13:42:59Z")

</div>

We have on-prime installation of kibana-8.14.0, It is being analyzed by the vulnerability detection tool Qualys, tool is reporting JSON response of following API as vulnerable to Cross-Site-Scripting Kibana API call ma…

---

## [I need a docker image with enrollment token disabled](https://discuss.elastic.co/t/i-need-a-docker-image-with-enrollment-token-disabled/385027)

<div class="topic-metadata">

**Author:** [@Shivu007](https://discuss.elastic.co/u/Shivu007)\
**Replies:** 1\
**Last updated:** [February 12, 2026, 9:02pm UTC](https://discuss.elastic.co/t/i-need-a-docker-image-with-enrollment-token-disabled/385027 "2026-02-12T21:02:57Z")

</div>

Hi team, I’m currently working on the elasticsearch and kibana Docker image for the snowflake SPCS container. However, I’m unable to generate the enrollment token and the logs also do not display the token or password w…

---

## [Kibana Instance Crashing During PDF/CSV Export on Elastic Cloud](https://discuss.elastic.co/t/kibana-instance-crashing-during-pdf-csv-export-on-elastic-cloud/384990)

<div class="topic-metadata">

**Author:** [@Hichem\_Blagui](https://discuss.elastic.co/u/Hichem_Blagui)\
**Replies:** 4\
**Last updated:** [February 12, 2026, 2:07pm UTC](https://discuss.elastic.co/t/kibana-instance-crashing-during-pdf-csv-export-on-elastic-cloud/384990 "2026-02-12T14:07:28Z")

</div>

Hi, I am experiencing frequent instance crashes when attempting to export default dashboards (PDF/PNG/CSV) from Kibana. I am currently using Elastic Cloud and do not have access to the underlying terminal or the physica…

---

## [Can't disable Kibana calls to 169.254.169.254](https://discuss.elastic.co/t/cant-disable-kibana-calls-to-169-254-169-254/385018)

<div class="topic-metadata">

**Author:** [@fentom](https://discuss.elastic.co/u/fentom)\
**Replies:** 0\
**Last updated:** [February 12, 2026, 10:01am UTC](https://discuss.elastic.co/t/cant-disable-kibana-calls-to-169-254-169-254/385018 "2026-02-12T10:01:40Z")

</div>

I’m running Kibana and Elasticsearch using ECK Operator on an air gapped K8s cluster which also uses Cilium to configure network policies. In the Hubble UI provided by Cilium I can see that requests from Elasticsearch a…

---

## [📢 Announcing: Kibana MCP Server - Control Kibana using Claude AI](https://discuss.elastic.co/t/announcing-kibana-mcp-server-control-kibana-using-claude-ai/377757)

<div class="topic-metadata">

**Author:** [@azmatjan139](https://discuss.elastic.co/u/azmatjan139)\
**Replies:** 4\
**Last updated:** [February 12, 2026, 12:16am UTC](https://discuss.elastic.co/t/announcing-kibana-mcp-server-control-kibana-using-claude-ai/377757 "2026-02-12T00:16:33Z")

</div>

Project Introduction I'm excited to announce Kibana MCP Server, a new open-source implementation based on the Model Context Protocol (MCP) that allows any MCP-compatible AI client (such as Claude Desktop) to access and m…

---

## [Failed to check if maintenance windows are active](https://discuss.elastic.co/t/failed-to-check-if-maintenance-windows-are-active/384984)

<div class="topic-metadata">

**Author:** [@GiorgioS13](https://discuss.elastic.co/u/GiorgioS13)\
**Replies:** 6\
**Last updated:** [February 11, 2026, 12:15pm UTC](https://discuss.elastic.co/t/failed-to-check-if-maintenance-windows-are-active/384984 "2026-02-11T12:15:26Z")

</div>

After the update of the on-premises deployment, this error appears. What could be the root cause?

---

## [Failed to decrypt report job data. Please ensure that xpack.reporting.encryptionKey is set and re-generate this report](https://discuss.elastic.co/t/failed-to-decrypt-report-job-data-please-ensure-that-xpack-reporting-encryptionkey-is-set-and-re-generate-this-report/384933)

<div class="topic-metadata">

**Author:** [@francescoa](https://discuss.elastic.co/u/francescoa)\
**Replies:** 2\
**Last updated:** [February 9, 2026, 9:10am UTC](https://discuss.elastic.co/t/failed-to-decrypt-report-job-data-please-ensure-that-xpack-reporting-encryptionkey-is-set-and-re-generate-this-report/384933 "2026-02-09T09:10:10Z")

</div>

Hi everyone :slight\_smile: I’m new here, I signed up because we’re having some issues with Kibana and I’m hoping someone can help :heart: We have Kibana v8.13.4 exposed on an AWS EC2 instance. It’s the only one Kibana …

---

## [The preprocessing for selecting values does not work in discover](https://discuss.elastic.co/t/the-preprocessing-for-selecting-values-does-not-work-in-discover/384951)

<div class="topic-metadata">

**Author:** [@Ruslan\_Hafizov](https://discuss.elastic.co/u/Ruslan_Hafizov)\
**Replies:** 2\
**Last updated:** [February 7, 2026, 8:00am UTC](https://discuss.elastic.co/t/the-preprocessing-for-selecting-values-does-not-work-in-discover/384951 "2026-02-07T08:00:02Z")

</div>

When selecting a field in the left menu, no selection is displayed by field. Despite the fact that the value itself is in the index. I couldn't find information in the documentation on how this function works to check wh…

---

## [Kibana needs more memory to generate this report. Check RAM requirements](https://discuss.elastic.co/t/kibana-needs-more-memory-to-generate-this-report-check-ram-requirements/384934)

<div class="topic-metadata">

**Author:** [@francescoa](https://discuss.elastic.co/u/francescoa)\
**Replies:** 0\
**Last updated:** [February 5, 2026, 5:15pm UTC](https://discuss.elastic.co/t/kibana-needs-more-memory-to-generate-this-report-check-ram-requirements/384934 "2026-02-05T17:15:29Z")

</div>

Hi everyone :slight\_smile: We have Kibana v8.13.4 exposed on an AWS EC2 instance. It’s the only one Kibana instance we have. When I try to create a report, the section Management \> Alerts and Insights \> Reporting somet…

---

## [Kibana visulaisatiion](https://discuss.elastic.co/t/kibana-visulaisatiion/384876)

<div class="topic-metadata">

**Author:** [@akmoharana](https://discuss.elastic.co/u/akmoharana)\
**Replies:** 1\
**Last updated:** [February 3, 2026, 11:23am UTC](https://discuss.elastic.co/t/kibana-visulaisatiion/384876 "2026-02-03T11:23:29Z")

</div>

Hi Everyone I want to create a Paid-to-Billed ratio visualization expressed as a percentage. Could someone please explain how to create this and what fields are required in the dataview? Thanks

---

## [Is there a workaround for view context which is not working post ugrade to 8.19.3](https://discuss.elastic.co/t/is-there-a-workaround-for-view-context-which-is-not-working-post-ugrade-to-8-19-3/383946)

<div class="topic-metadata">

**Author:** [@shinysap](https://discuss.elastic.co/u/shinysap)\
**Replies:** 2\
**Last updated:** [February 3, 2026, 9:13am UTC](https://discuss.elastic.co/t/is-there-a-workaround-for-view-context-which-is-not-working-post-ugrade-to-8-19-3/383946 "2026-02-03T09:13:41Z")

</div>

Is there a workaround for view context which is not working post ugrade to 8.19.3

---

## [Cannot Edit Monitor](https://discuss.elastic.co/t/cannot-edit-monitor/384846)

<div class="topic-metadata">

**Author:** [@lomar](https://discuss.elastic.co/u/lomar)\
**Replies:** 4\
**Last updated:** [February 2, 2026, 11:51am UTC](https://discuss.elastic.co/t/cannot-edit-monitor/384846 "2026-02-02T11:51:06Z")

</div>

When I try to delete via the Elasticsearch API, I get the same error code. I would appreciate your help. ELK Stack version: 9.2.4 Cluster status: green

---

## [Share discovery session time picker issue](https://discuss.elastic.co/t/share-discovery-session-time-picker-issue/384809)

<div class="topic-metadata">

**Author:** [@mcdaidh](https://discuss.elastic.co/u/mcdaidh)\
**Replies:** 4\
**Last updated:** [January 30, 2026, 5:19pm UTC](https://discuss.elastic.co/t/share-discovery-session-time-picker-issue/384809 "2026-01-30T17:19:13Z")

</div>

I have a discover session that I am trying share, I have the time picker set to a relative option (1 hour), yet when I try and share the view, it’s saying it will share it using the current time (it’s specifying the star…

---

## [Kibana embedded dashboard in iframe returns 401 Unauthorized loop - anonymous auth works directly but not in iframe](https://discuss.elastic.co/t/kibana-embedded-dashboard-in-iframe-returns-401-unauthorized-loop-anonymous-auth-works-directly-but-not-in-iframe/384815)

<div class="topic-metadata">

**Author:** [@Oscar\_NT](https://discuss.elastic.co/u/Oscar_NT)\
**Replies:** 1\
**Last updated:** [January 30, 2026, 7:58am UTC](https://discuss.elastic.co/t/kibana-embedded-dashboard-in-iframe-returns-401-unauthorized-loop-anonymous-auth-works-directly-but-not-in-iframe/384815 "2026-01-30T07:58:17Z")

</div>

Environment: Elastic Cloud (Hosted) Kibana version: 8.x (Cloud managed) Browser: Chrome / Safari Frontend: Next.js app running on https://localhost:3000 (HTTPS with mkcert) Problem: I'm trying to embed a Kibana dash…

---

## [Removing alias fields from index but making sure dashboards are not broken](https://discuss.elastic.co/t/removing-alias-fields-from-index-but-making-sure-dashboards-are-not-broken/384797)

<div class="topic-metadata">

**Author:** [@MH2026](https://discuss.elastic.co/u/MH2026)\
**Replies:** 1\
**Last updated:** [January 30, 2026, 3:45am UTC](https://discuss.elastic.co/t/removing-alias-fields-from-index-but-making-sure-dashboards-are-not-broken/384797 "2026-01-30T03:45:12Z")

</div>

I have to remove alias fields from Index but those are being used in different dashboards, so how would I ensure that the dashboards don't break with my plan of removing alias fields

---

## [How to make horizontal bar graph?](https://discuss.elastic.co/t/how-to-make-horizontal-bar-graph/384723)

<div class="topic-metadata">

**Author:** [@Miksos](https://discuss.elastic.co/u/Miksos)\
**Replies:** 5\
**Last updated:** [January 24, 2026, 10:11am UTC](https://discuss.elastic.co/t/how-to-make-horizontal-bar-graph/384723 "2026-01-24T10:11:00Z")

</div>

I can’t create horizontal bar graphs, I find mentions in old post about them, and videos but in my version of Elastic I am unable to create one ? I will be grateful for some info. Thanks !

---

## [Reporting job is still pending despite having killed previous job](https://discuss.elastic.co/t/reporting-job-is-still-pending-despite-having-killed-previous-job/384714)

<div class="topic-metadata">

**Author:** [@RRecio](https://discuss.elastic.co/u/RRecio)\
**Replies:** 0\
**Last updated:** [January 23, 2026, 12:09pm UTC](https://discuss.elastic.co/t/reporting-job-is-still-pending-despite-having-killed-previous-job/384714 "2026-01-23T12:09:25Z")

</div>

Hi. I’m experiencing the same issue as this Closed ticket, which seemingly didn’t have a resolution: Need to stop all Pending jobs in reporting I accidentally hit “Download CSV” in a report that was far too big to be do…

---

## [Restrict fleet view to only specific namespace](https://discuss.elastic.co/t/restrict-fleet-view-to-only-specific-namespace/384579)

<div class="topic-metadata">

**Author:** [@TheJ](https://discuss.elastic.co/u/TheJ)\
**Replies:** 3\
**Last updated:** [January 21, 2026, 2:12pm UTC](https://discuss.elastic.co/t/restrict-fleet-view-to-only-specific-namespace/384579 "2026-01-21T14:12:21Z")

</div>

Hi, I have installed 10 elastic agents in 2 different agent policies: admins personel Also i created role for our helpdesk team (the name of role is helpdesk). Now I want that helpdesk role can see only agents …

---

## [Elasticsearch automatic dashboard access](https://discuss.elastic.co/t/elasticsearch-automatic-dashboard-access/384632)

<div class="topic-metadata">

**Author:** [@Robin\_Gorry](https://discuss.elastic.co/u/Robin_Gorry)\
**Replies:** 2\
**Last updated:** [January 21, 2026, 12:27pm UTC](https://discuss.elastic.co/t/elasticsearch-automatic-dashboard-access/384632 "2026-01-21T12:27:39Z")

</div>

Elasticsearch Cloud Hosted, 8. We’ll create separate spaces with a dashboard per space. We’ll provide users (that we create) access to a specific Kibana dashboard on Elastic and an embedded iframe of their application. …

---

## [Is it possible to make a template that aggregates by one field and sorts by another?](https://discuss.elastic.co/t/is-it-possible-to-make-a-template-that-aggregates-by-one-field-and-sorts-by-another/384526)

<div class="topic-metadata">

**Author:** [@Phil\_McLachlan](https://discuss.elastic.co/u/Phil_McLachlan)\
**Replies:** 4\
**Last updated:** [January 20, 2026, 8:12pm UTC](https://discuss.elastic.co/t/is-it-possible-to-make-a-template-that-aggregates-by-one-field-and-sorts-by-another/384526 "2026-01-20T20:12:46Z")

</div>

Hi, We have a elasticsearch index with a lot of data in it. For this question, I am interested in two fields primarily: brand.brands\_pk and brand.name\_loc.content\_default. I want to create a template to return a uniqu…

---

## [Installation - receive this message:](https://discuss.elastic.co/t/installation-receive-this-message/384603)

<div class="topic-metadata">

**Author:** [@jwelby](https://discuss.elastic.co/u/jwelby)\
**Replies:** 3\
**Last updated:** [January 19, 2026, 8:45pm UTC](https://discuss.elastic.co/t/installation-receive-this-message/384603 "2026-01-19T20:45:47Z")

</div>

error root\_cause 0 type "status\_exception" reason "Cluster state has not been recovered yet, cannot write to the \[null\] index" type "authentication\_processing\_error" reason "failed to promote the aut…

---

## [Ingest Pipeline - Why Isn’t My Failure Processor Redirecting Failed Docs to a New Index?](https://discuss.elastic.co/t/ingest-pipeline-why-isn-t-my-failure-processor-redirecting-failed-docs-to-a-new-index/384619)

<div class="topic-metadata">

**Author:** [@nilsen](https://discuss.elastic.co/u/nilsen)\
**Replies:** 3\
**Last updated:** [January 19, 2026, 3:23pm UTC](https://discuss.elastic.co/t/ingest-pipeline-why-isn-t-my-failure-processor-redirecting-failed-docs-to-a-new-index/384619 "2026-01-19T15:23:15Z")

</div>

Following the Elastic documentation for Handling pipeline failures I have added a failure processor which is supposed to change the \_index, but it does not seem to work as I thought. ▶ Failure Processors (.json) My Pi…

---

## [Kibana TSVB shows keyword string "/" as "(empty)"](https://discuss.elastic.co/t/kibana-tsvb-shows-keyword-string-as-empty/384577)

<div class="topic-metadata">

**Author:** [@hylowaker](https://discuss.elastic.co/u/hylowaker)\
**Replies:** 2\
**Last updated:** [January 19, 2026, 8:34am UTC](https://discuss.elastic.co/t/kibana-tsvb-shows-keyword-string-as-empty/384577 "2026-01-19T08:34:24Z")

</div>

I loaded Metricbeat dashboards into Kibana. The Disk Usage \[Metricbeat System\] ECS library shows Top 10 mount points with high disk usages. I see an (empty) mount point, but the actual value of system.filesystem.mount\_…

---

## [Kibana login broken after trying to enable reporting. "You do not have permission to access the requested page" message - Need help to fix it](https://discuss.elastic.co/t/kibana-login-broken-after-trying-to-enable-reporting-you-do-not-have-permission-to-access-the-requested-page-message-need-help-to-fix-it/384554)

<div class="topic-metadata">

**Author:** [@eparreiras](https://discuss.elastic.co/u/eparreiras)\
**Replies:** 24\
**Last updated:** [January 18, 2026, 8:34pm UTC](https://discuss.elastic.co/t/kibana-login-broken-after-trying-to-enable-reporting-you-do-not-have-permission-to-access-the-requested-page-message-need-help-to-fix-it/384554 "2026-01-18T20:34:05Z")

</div>

Hi there, After trying to enable reporting in Kibana following the document below: I am not able to login into Kibana anymore. I am using a Kibana 8.10.4 container version. The Elasticsearch is a IBM Cloud managed…

[Previous page](https://discuss.elastic.co/c/elastic-stack/kibana/7.md?page=3)

[Next page](https://discuss.elastic.co/c/elastic-stack/kibana/7.md?page=5)
