# Kibana

**URL:** https://discuss.elastic.co/c/elastic-stack/kibana/7.md?page=460

[Latest](https://discuss.elastic.co/latest.md) · [Categories](https://discuss.elastic.co/categories.md) · [Tags](https://discuss.elastic.co/tags.md)

**Page:** 461

---

## [MetricBeat sample dashboards/visualizations, and cross cluster search](https://discuss.elastic.co/t/metricbeat-sample-dashboards-visualizations-and-cross-cluster-search/240222)

<div class="topic-metadata">

**Author:** [@Alex\_Howle](https://discuss.elastic.co/u/Alex_Howle)\
**Replies:** 1\
**Last updated:** [July 7, 2020, 9:12pm UTC](https://discuss.elastic.co/t/metricbeat-sample-dashboards-visualizations-and-cross-cluster-search/240222 "2020-07-07T21:12:03Z")

</div>

I have 2 ELK clusters. They have been setup correctly as Remote Clusters to each other, and I have the correct Cross Cluster Search Index Pattern of \*:metricbeat-\* I can successfully query the data against this Index Pa…

---

## [Send Logstash logs to Kibana remote server](https://discuss.elastic.co/t/send-logstash-logs-to-kibana-remote-server/240060)

<div class="topic-metadata">

**Author:** [@Sai\_Avinash\_Duddupud](https://discuss.elastic.co/u/Sai_Avinash_Duddupud)\
**Replies:** 5\
**Last updated:** [July 7, 2020, 8:19pm UTC](https://discuss.elastic.co/t/send-logstash-logs-to-kibana-remote-server/240060 "2020-07-07T20:19:01Z")

</div>

I am new to ELK Stack and trying to view logs on kibana which is hosted on different server. Following are my configurations for Filebeat and logstash in my localhost pc and logstash is succesfully recieving logs …

---

## [Kibana map metrics for heat map](https://discuss.elastic.co/t/kibana-map-metrics-for-heat-map/239407)

<div class="topic-metadata">

**Author:** [@john9570](https://discuss.elastic.co/u/john9570)\
**Replies:** 3\
**Last updated:** [July 7, 2020, 8:16pm UTC](https://discuss.elastic.co/t/kibana-map-metrics-for-heat-map/239407 "2020-07-07T20:16:54Z")

</div>

Hi, I currently have kibana 7.8 and am trying to add Metrics to the Heat Map in Kibana's mapping visualization. However, unlike other map layers the Heat Map 'Metrics' section has no button to add a metric. How do I cor…

---

## [Setup Stack Monitoring with Metricbeat and Docker-compose](https://discuss.elastic.co/t/setup-stack-monitoring-with-metricbeat-and-docker-compose/240193)

<div class="topic-metadata">

**Author:** [@damasu](https://discuss.elastic.co/u/damasu)\
**Replies:** 0\
**Last updated:** [July 7, 2020, 4:17pm UTC](https://discuss.elastic.co/t/setup-stack-monitoring-with-metricbeat-and-docker-compose/240193 "2020-07-07T16:17:13Z")

</div>

I am wondering how to correctly configure stack monitoring in kibana when used with an elastic stack based on docker-compose. For instance, on the same host machine as docker-compose i have installed metricbeat to monit…

---

## [Powerpoint to Canvas theme conversion](https://discuss.elastic.co/t/powerpoint-to-canvas-theme-conversion/238510)

<div class="topic-metadata">

**Author:** [@Ryan\_Downey](https://discuss.elastic.co/u/Ryan_Downey)\
**Replies:** 1\
**Last updated:** [July 7, 2020, 4:20pm UTC](https://discuss.elastic.co/t/powerpoint-to-canvas-theme-conversion/238510 "2020-07-07T16:20:50Z")

</div>

Is there a way to import a theme for Powerpoint into Canvas? If I understand the "Import workpad JSON file" function correctly I need to convert the Powerpoint slides into JSON in order to use it. Any guidance would be…

---

## [Kibana 7.8.0. Empty csv report](https://discuss.elastic.co/t/kibana-7-8-0-empty-csv-report/239500)

<div class="topic-metadata">

**Author:** [@dsv](https://discuss.elastic.co/u/dsv)\
**Replies:** 3\
**Last updated:** [July 7, 2020, 4:16pm UTC](https://discuss.elastic.co/t/kibana-7-8-0-empty-csv-report/239500 "2020-07-07T16:16:08Z")

</div>

After upgrading to 7.8.0 about 90 % of cvs reports empty (the corresponding saved search is not!). Can't find any corresponding error messages in the kibana log. The only one suspect is absence of .reporting-%date% ind…

---

## [After upgrade to 7.8 kibana is suddenly showing a lot of non-existing fields in the table view](https://discuss.elastic.co/t/after-upgrade-to-7-8-kibana-is-suddenly-showing-a-lot-of-non-existing-fields-in-the-table-view/240066)

<div class="topic-metadata">

**Author:** [@corbosman](https://discuss.elastic.co/u/corbosman)\
**Replies:** 4\
**Last updated:** [July 7, 2020, 3:49pm UTC](https://discuss.elastic.co/t/after-upgrade-to-7-8-kibana-is-suddenly-showing-a-lot-of-non-existing-fields-in-the-table-view/240066 "2020-07-07T15:49:05Z")

</div>

We upgraded elasticsearch/kibana to 7.8 from 7.7. All went well, except for one weird thing. If I go into discover and look at documents (all server logs) in one of our indices (using the table view), kibana is not only …

---

## [Plugin install error:"This plugin is using \`link:\` dependencies for non-Kibana packages"](https://discuss.elastic.co/t/plugin-install-error-this-plugin-is-using-link-dependencies-for-non-kibana-packages/240074)

<div class="topic-metadata">

**Author:** [@Fent](https://discuss.elastic.co/u/Fent)\
**Replies:** 1\
**Last updated:** [July 7, 2020, 3:43pm UTC](https://discuss.elastic.co/t/plugin-install-error-this-plugin-is-using-link-dependencies-for-non-kibana-packages/240074 "2020-07-07T15:43:50Z")

</div>

HI ,I create my plugin,and run "yarn build" to package this plugin to a zip file, and install to kibana ,it show error info like this my demo plugin create like this , and i don't modify any file ,it work well in w…

---

## [elasticsearch.requestTimeout value is not reflecting in kibana UI](https://discuss.elastic.co/t/elasticsearch-requesttimeout-value-is-not-reflecting-in-kibana-ui/240079)

<div class="topic-metadata">

**Author:** [@GopiV](https://discuss.elastic.co/u/GopiV)\
**Replies:** 1\
**Last updated:** [July 7, 2020, 3:40pm UTC](https://discuss.elastic.co/t/elasticsearch-requesttimeout-value-is-not-reflecting-in-kibana-ui/240079 "2020-07-07T15:40:38Z")

</div>

Kabana: v 7.2.1 I've change the value of elasticsearch.requestTimeout from 30secs (30000) to 60secs (60000) in /etc/kibana/kibana.yml and restart Kibana due to the timeout I'm getting for few searches in UI after 30secs…

---

## [Bar and Lines Visualization](https://discuss.elastic.co/t/bar-and-lines-visualization/240184)

<div class="topic-metadata">

**Author:** [@BrunoSdeMenezes](https://discuss.elastic.co/u/BrunoSdeMenezes)\
**Replies:** 0\
**Last updated:** [July 7, 2020, 3:19pm UTC](https://discuss.elastic.co/t/bar-and-lines-visualization/240184 "2020-07-07T15:19:24Z")

</div>

Hello There, I'm trying to build a chart with a bar and a line. The bar must show the actual year and the line must show last year. The x-axis must be the months. Something like that: I've built a chart with two coun…

---

## [Kibana graph now showing on a selected Index](https://discuss.elastic.co/t/kibana-graph-now-showing-on-a-selected-index/240155)

<div class="topic-metadata">

**Author:** [@Kevin\_f](https://discuss.elastic.co/u/Kevin_f)\
**Replies:** 12\
**Last updated:** [July 7, 2020, 2:49pm UTC](https://discuss.elastic.co/t/kibana-graph-now-showing-on-a-selected-index/240155 "2020-07-07T14:49:37Z")

</div>

Hi All, I have got an issue where a particular index is not showing the graph like other indexes do within discovery. This index I am referring to is for the ingestion of Cloudtrail logs not showing the bar graph as it …

---

## [Minimum interval on "Date Histogram" aggregation](https://discuss.elastic.co/t/minimum-interval-on-date-histogram-aggregation/238973)

<div class="topic-metadata">

**Author:** [@laurentml](https://discuss.elastic.co/u/laurentml)\
**Replies:** 14\
**Last updated:** [July 7, 2020, 2:40pm UTC](https://discuss.elastic.co/t/minimum-interval-on-date-histogram-aggregation/238973 "2020-07-07T14:40:25Z")

</div>

Hi folks, I'm using ELK stack (v7.8.0, same on v7.7.1) for an application used by historians, where each entry is an archive which can be like from year 1687 for example. Rendering options of Kibana are generally very …

---

## [Getting error when try to install kibana plugin](https://discuss.elastic.co/t/getting-error-when-try-to-install-kibana-plugin/240110)

<div class="topic-metadata">

**Author:** [@Mahathir\_Mohammad](https://discuss.elastic.co/u/Mahathir_Mohammad)\
**Replies:** 9\
**Last updated:** [July 7, 2020, 8:44am UTC](https://discuss.elastic.co/t/getting-error-when-try-to-install-kibana-plugin/240110 "2020-07-07T08:44:15Z")

</div>

I'm trying to install "opendistro\_security\_kibana\_plugin-1.8.0.0.zip" package for kibana. I tried to install with sudo : sudo bin/kibana-plugin install https://d3g5vo6xdbdb9a.cloudfront.net/downloads/kibana-plugins/ope…

---

## [Custom kibana home](https://discuss.elastic.co/t/custom-kibana-home/238427)

<div class="topic-metadata">

**Author:** [@Shikhar\_Dixit](https://discuss.elastic.co/u/Shikhar_Dixit)\
**Replies:** 9\
**Last updated:** [July 7, 2020, 8:19am UTC](https://discuss.elastic.co/t/custom-kibana-home/238427 "2020-07-07T08:19:38Z")

</div>

Hi, can anyone help in the customization of the homepage of kibana ui I want to remove all the cards and add a pic in the background

---

## [Get saved object id through Search API of Kibana](https://discuss.elastic.co/t/get-saved-object-id-through-search-api-of-kibana/239424)

<div class="topic-metadata">

**Author:** [@Voula\_Mikr](https://discuss.elastic.co/u/Voula_Mikr)\
**Replies:** 1\
**Last updated:** [July 7, 2020, 8:17am UTC](https://discuss.elastic.co/t/get-saved-object-id-through-search-api-of-kibana/239424 "2020-07-07T08:17:44Z")

</div>

Hi! Is there any query I can make in console of Kibana that I can get the id of a specific Dashboard, visualization, index-pattern and search? For example with : GET .kibana/\_search { "\_source": \["dashboard.title"\], …

---

## [TVSB visualization filter parameter does not take effect](https://discuss.elastic.co/t/tvsb-visualization-filter-parameter-does-not-take-effect/240101)

<div class="topic-metadata">

**Author:** [@wajika](https://discuss.elastic.co/u/wajika)\
**Replies:** 0\
**Last updated:** [July 7, 2020, 6:59am UTC](https://discuss.elastic.co/t/tvsb-visualization-filter-parameter-does-not-take-effect/240101 "2020-07-07T06:59:10Z")

</div>

Condition k8s\_container\_name: osc-ali-prd filters out all information, leaving only the information containing osc.xxxx.cn is correct, but the filter is not successful.

---

## [Ilm-history system index does not start with a dot](https://discuss.elastic.co/t/ilm-history-system-index-does-not-start-with-a-dot/239335)

<div class="topic-metadata">

**Author:** [@ypid-geberit](https://discuss.elastic.co/u/ypid-geberit)\
**Replies:** 1\
**Last updated:** [July 7, 2020, 6:30am UTC](https://discuss.elastic.co/t/ilm-history-system-index-does-not-start-with-a-dot/239335 "2020-07-07T06:30:16Z")

</div>

Hi Here are the typical system indices found when using the Elastic Stack 7.6 (ES and Kibana are relevant here): GET \_cat/indices?h=i&s=i .apm-agent-configuration .kibana\_1 .kibana\_task\_manager\_1 .monitoring-alerts-7 .…

---

## [It's not working in "mark / force / links"](https://discuss.elastic.co/t/its-not-working-in-mark-force-links/236957)

<div class="topic-metadata">

**Author:** [@thegyoo](https://discuss.elastic.co/u/thegyoo)\
**Replies:** 2\
**Last updated:** [July 7, 2020, 4:03am UTC](https://discuss.elastic.co/t/its-not-working-in-mark-force-links/236957 "2020-07-07T04:03:24Z")

</div>

i try the above example in kibana with 2 indices.(node index, link index) but it's not working in "mark / force / links". i found the case in google, "https://github.com/vega/vega-force/issues/2". the update.json…

---

## [Error: Port 5601 is already in use. Another instance of Kibana may be running!](https://discuss.elastic.co/t/error-port-5601-is-already-in-use-another-instance-of-kibana-may-be-running/240070)

<div class="topic-metadata">

**Author:** [@Splunk](https://discuss.elastic.co/u/Splunk)\
**Replies:** 5\
**Last updated:** [July 7, 2020, 1:44am UTC](https://discuss.elastic.co/t/error-port-5601-is-already-in-use-another-instance-of-kibana-may-be-running/240070 "2020-07-07T01:44:06Z")

</div>

bin kibana log \[22:25:12.491\] \[warning\]\[plugins-discovery\] Expect plugin "id" in camelCase, but found: apm\_oss log \[22:25:12.504\] \[warning\]\[plugins-discovery\] Expect plugin "id" in camelCase, but found: triggers\_a…

---

## [Alerting Webhook](https://discuss.elastic.co/t/alerting-webhook/240023)

<div class="topic-metadata">

**Author:** [@Rushabh\_Doshi](https://discuss.elastic.co/u/Rushabh_Doshi)\
**Replies:** 1\
**Last updated:** [July 7, 2020, 12:48am UTC](https://discuss.elastic.co/t/alerting-webhook/240023 "2020-07-07T00:48:26Z")

</div>

Need to send alert email to my gmail account , what should i set in the host, port, path and key/value Would like to know what values can i enter in these fields, so that an alert email is sent to my gmail account pl…

---

## [Kibana: How to get raw data and aggregate in KQL in a serial fashion?](https://discuss.elastic.co/t/kibana-how-to-get-raw-data-and-aggregate-in-kql-in-a-serial-fashion/239930)

<div class="topic-metadata">

**Author:** [@kelk](https://discuss.elastic.co/u/kelk)\
**Replies:** 3\
**Last updated:** [July 7, 2020, 12:23am UTC](https://discuss.elastic.co/t/kibana-how-to-get-raw-data-and-aggregate-in-kql-in-a-serial-fashion/239930 "2020-07-07T00:23:12Z")

</div>

I was looking for equivalent of splunk query (i.e. get raw data , then do aggregation on top of that) index=some\_data | stats count by hostname The above will aggregate all the data by hostname and shows the data in n…

---

## [Unable to connect to Elasticsearch. Error: Request Timeout after 30000ms another client :)](https://discuss.elastic.co/t/unable-to-connect-to-elasticsearch-error-request-timeout-after-30000ms-another-client/240022)

<div class="topic-metadata">

**Author:** [@sd99](https://discuss.elastic.co/u/sd99)\
**Replies:** 3\
**Last updated:** [July 6, 2020, 11:58pm UTC](https://discuss.elastic.co/t/unable-to-connect-to-elasticsearch-error-request-timeout-after-30000ms-another-client/240022 "2020-07-06T23:58:00Z")

</div>

Hi, I have installed Elasticsearch in my server and now I am installing Kibana, and there is an error appear with me. ( Unable to connect to Elasticsearch. Error: Request Timeout after 30000ms) I'm also trying to alte…

---

## [Error in Kibana :(](https://discuss.elastic.co/t/error-in-kibana/240033)

<div class="topic-metadata">

**Author:** [@sd99](https://discuss.elastic.co/u/sd99)\
**Replies:** 1\
**Last updated:** [July 6, 2020, 7:34pm UTC](https://discuss.elastic.co/t/error-in-kibana/240033 "2020-07-06T19:34:13Z")

</div>

I have a problem with Kibana, can anyone help me here :frowning:

---

## [Access denied while opening Stack-Monitoring on Kibana 7.8](https://discuss.elastic.co/t/access-denied-while-opening-stack-monitoring-on-kibana-7-8/239947)

<div class="topic-metadata">

**Author:** [@vishakh](https://discuss.elastic.co/u/vishakh)\
**Replies:** 7\
**Last updated:** [July 6, 2020, 5:37pm UTC](https://discuss.elastic.co/t/access-denied-while-opening-stack-monitoring-on-kibana-7-8/239947 "2020-07-06T17:37:55Z")

</div>

Stack Intro: I'm running ELK-Stack 7.8 with 3 Cluster-Nodes Enabled XPack security in elasticsearch yml "xpack.security.enabled: true" and also enabled SSL/TLS on Transport and HTTP with below conf: xpack.security.tran…

---

## [Can some one explain how the transform runs it in this scenario](https://discuss.elastic.co/t/can-some-one-explain-how-the-transform-runs-it-in-this-scenario/238888)

<div class="topic-metadata">

**Author:** [@anjilinga](https://discuss.elastic.co/u/anjilinga)\
**Replies:** 4\
**Last updated:** [July 6, 2020, 5:26pm UTC](https://discuss.elastic.co/t/can-some-one-explain-how-the-transform-runs-it-in-this-scenario/238888 "2020-07-06T17:26:11Z")

</div>

Hi, I am using transform index, and i am grouping the records by day wise to find out max. but the frequency of the transform can be set maximum as 1hour. if the transform runs at next hour will it consider the record…

---

## [Render errors in generated PDF reports (Canvas)](https://discuss.elastic.co/t/render-errors-in-generated-pdf-reports-canvas/239353)

<div class="topic-metadata">

**Author:** [@sandbender](https://discuss.elastic.co/u/sandbender)\
**Replies:** 2\
**Last updated:** [July 6, 2020, 4:39pm UTC](https://discuss.elastic.co/t/render-errors-in-generated-pdf-reports-canvas/239353 "2020-07-06T16:39:44Z")

</div>

Hi, When generating a PDF reports from Canvas, I came across two unpleasant render errors: It appears that font choices are not being considered, which in the following case renders a customised chart unreadable. (Tri…

---

## [Directly Connecting MySQL DB to Kibana for visualization](https://discuss.elastic.co/t/directly-connecting-mysql-db-to-kibana-for-visualization/239982)

<div class="topic-metadata">

**Author:** [@Karan\_Gupta10](https://discuss.elastic.co/u/Karan_Gupta10)\
**Replies:** 4\
**Last updated:** [July 6, 2020, 2:34pm UTC](https://discuss.elastic.co/t/directly-connecting-mysql-db-to-kibana-for-visualization/239982 "2020-07-06T14:34:30Z")

</div>

Hi My current problem statement involves connecting to MySQL DB to fetch the data and produce Datavisualization in Kibana. Is there a way to directly connect with MySQL DB from Kibana. If not, then what are the other …

---

## [Set server.basePath and server.host in docker file](https://discuss.elastic.co/t/set-server-basepath-and-server-host-in-docker-file/239979)

<div class="topic-metadata">

**Author:** [@AsfK](https://discuss.elastic.co/u/AsfK)\
**Replies:** 1\
**Last updated:** [July 6, 2020, 1:54pm UTC](https://discuss.elastic.co/t/set-server-basepath-and-server-host-in-docker-file/239979 "2020-07-06T13:54:14Z")

</div>

Hello I have this (working) docker-compose.yml file (before server. tries): version: '3' services: elasticsearch: image: docker.elastic.co/elasticsearch/elasticsearch:7.6.2 environment: - node.name=es01 - cluste…

---

## [Adding iframe code in wordpress website](https://discuss.elastic.co/t/adding-iframe-code-in-wordpress-website/239984)

<div class="topic-metadata">

**Author:** [@Mayank\_Ruhella](https://discuss.elastic.co/u/Mayank_Ruhella)\
**Replies:** 1\
**Last updated:** [July 6, 2020, 1:48pm UTC](https://discuss.elastic.co/t/adding-iframe-code-in-wordpress-website/239984 "2020-07-06T13:48:28Z")

</div>

I know how to create, share and embed iframe code of the visualisation and dashboard but the problem is, it is asking for kibana credentials to load on website. Is it possible to skip login into kibana.

---

## [TSVB table : Group by multiple fields](https://discuss.elastic.co/t/tsvb-table-group-by-multiple-fields/240007)

<div class="topic-metadata">

**Author:** [@elisavet](https://discuss.elastic.co/u/elisavet)\
**Replies:** 2\
**Last updated:** [July 6, 2020, 1:44pm UTC](https://discuss.elastic.co/t/tsvb-table-group-by-multiple-fields/240007 "2020-07-06T13:44:03Z")

</div>

Hello! I would like to use TSVB to make a data table that sums a value for multiple groups as in the picture? Is it possible? Thank you, elisavet

[Previous page](https://discuss.elastic.co/c/elastic-stack/kibana/7.md?page=459)

[Next page](https://discuss.elastic.co/c/elastic-stack/kibana/7.md?page=461)
