# Kibana

**URL:** https://discuss.elastic.co/c/elastic-stack/kibana/7.md?page=76

[Latest](https://discuss.elastic.co/latest.md) · [Categories](https://discuss.elastic.co/categories.md) · [Tags](https://discuss.elastic.co/tags.md)

**Page:** 77

---

## [Error Unable to retrieve version information from Elasticsearch nodes. unable to get issuer certificate](https://discuss.elastic.co/t/error-unable-to-retrieve-version-information-from-elasticsearch-nodes-unable-to-get-issuer-certificate/350389)

<div class="topic-metadata">

**Author:** [@kray](https://discuss.elastic.co/u/kray)\
**Replies:** 4\
**Last updated:** [January 5, 2024, 4:32am UTC](https://discuss.elastic.co/t/error-unable-to-retrieve-version-information-from-elasticsearch-nodes-unable-to-get-issuer-certificate/350389 "2024-01-05T04:32:47Z")

</div>

please help, when I open the wazuh web the following error and I checked the kibana log, there is the following error {"type":"log","@timestamp":"2024-01-04T20:11:27+07:00","tags":\["error","elasticsearch-service"\],"p…

---

## [Parse Kibana Query to sql object](https://discuss.elastic.co/t/parse-kibana-query-to-sql-object/350335)

<div class="topic-metadata">

**Author:** [@Ofir\_Safin](https://discuss.elastic.co/u/Ofir_Safin)\
**Replies:** 1\
**Last updated:** [January 4, 2024, 10:35pm UTC](https://discuss.elastic.co/t/parse-kibana-query-to-sql-object/350335 "2024-01-04T22:35:27Z")

</div>

Hi everyone, I'm trying to monitor logs from Elasticsearch in python My problem is that each log has a different structure. For example: "error" and applicationName :"test" "query" will be like this: { "bool": { …

---

## [Changing the log-in text](https://discuss.elastic.co/t/changing-the-log-in-text/350363)

<div class="topic-metadata">

**Author:** [@Karan\_Lobo](https://discuss.elastic.co/u/Karan_Lobo)\
**Replies:** 1\
**Last updated:** [January 4, 2024, 6:27pm UTC](https://discuss.elastic.co/t/changing-the-log-in-text/350363 "2024-01-04T18:27:49Z")

</div>

Hey there, I am trying to change the login text to "Welcome to Elastic." I tried changing the source code in the \\kibana-7.17.0-windowsx86\_64\\xpack\\plugins\\security\\target\\public\\security.chunk.5.js file, but it won't wo…

---

## [Can't log in other than from the local host](https://discuss.elastic.co/t/cant-log-in-other-than-from-the-local-host/349883)

<div class="topic-metadata">

**Author:** [@rcfa](https://discuss.elastic.co/u/rcfa)\
**Replies:** 3\
**Last updated:** [January 4, 2024, 7:51pm UTC](https://discuss.elastic.co/t/cant-log-in-other-than-from-the-local-host/349883 "2024-01-04T19:51:08Z")

</div>

I'm a newby, so excuse if I ask a dummy question, but I got to start somewhere, and being able to log in is, well, prerequisite... So on my server, let's call it 10.0.0.1 I have installed the Elasticsearch and kibana pa…

---

## [savedVisualization / embeddable in canvas broken after upgrading to version 8.9.2 due to saved Objects Id](https://discuss.elastic.co/t/savedvisualization-embeddable-in-canvas-broken-after-upgrading-to-version-8-9-2-due-to-saved-objects-id/349652)

<div class="topic-metadata">

**Author:** [@preetish\_P](https://discuss.elastic.co/u/preetish_P)\
**Replies:** 4\
**Last updated:** [January 4, 2024, 6:32pm UTC](https://discuss.elastic.co/t/savedvisualization-embeddable-in-canvas-broken-after-upgrading-to-version-8-9-2-due-to-saved-objects-id/349652 "2024-01-04T18:32:53Z")

</div>

Hi folks, We are looking to upgrade elk stack from 7.17.2 to 8.9.2. One of the first observations we made in Canvas is that savedVisualization is broken. We have Canvas dashboards having upto 9 kibana visualisation impo…

---

## [Using location data to show a route taken](https://discuss.elastic.co/t/using-location-data-to-show-a-route-taken/350263)

<div class="topic-metadata">

**Author:** [@RainTown](https://discuss.elastic.co/u/RainTown)\
**Replies:** 2\
**Last updated:** [January 4, 2024, 1:38pm UTC](https://discuss.elastic.co/t/using-location-data-to-show-a-route-taken/350263 "2024-01-04T13:38:40Z")

</div>

Hi I have time based data for the location of an item, that I'd like to visualise as a sort of "route map", i.e. a sequnece of lines joining the various location points as traversed in time series order. Maybe I'm miss…

---

## [Kibana: Cold indices not showing when using filter in index management](https://discuss.elastic.co/t/kibana-cold-indices-not-showing-when-using-filter-in-index-management/350200)

<div class="topic-metadata">

**Author:** [@basiltitus](https://discuss.elastic.co/u/basiltitus)\
**Replies:** 8\
**Last updated:** [January 4, 2024, 12:40pm UTC](https://discuss.elastic.co/t/kibana-cold-indices-not-showing-when-using-filter-in-index-management/350200 "2024-01-04T12:40:47Z")

</div>

I have a two node cluster with a master/hot and a single data node defined in cold tier. I have created few indices for testing data tier. But when I apply "lifecycle phase" filter the indices supposed to be in cold tie…

---

## [Multiple Kibanas on 1 cluster](https://discuss.elastic.co/t/multiple-kibanas-on-1-cluster/350372)

<div class="topic-metadata">

**Author:** [@avnere](https://discuss.elastic.co/u/avnere)\
**Replies:** 1\
**Last updated:** [January 4, 2024, 10:32am UTC](https://discuss.elastic.co/t/multiple-kibanas-on-1-cluster/350372 "2024-01-04T10:32:47Z")

</div>

Hi, Is it possible\\alowed to run multiple Kibana instances connected to same cluster? Will it create internal index (.monitoring, etc) per instance? Thanks...

---

## [Alternatives to kibana](https://discuss.elastic.co/t/alternatives-to-kibana/350360)

<div class="topic-metadata">

**Author:** [@Karan\_Lobo](https://discuss.elastic.co/u/Karan_Lobo)\
**Replies:** 2\
**Last updated:** [January 4, 2024, 9:53am UTC](https://discuss.elastic.co/t/alternatives-to-kibana/350360 "2024-01-04T09:53:18Z")

</div>

Hey i was wondering if i could connect my elasticsearch and logstash with some other vizualisation tool like powerbi or tablue for free . I tried to do so but it seems i have to buy the platinum version to download the e…

---

## [Embedding kibana using iframe](https://discuss.elastic.co/t/embedding-kibana-using-iframe/350042)

<div class="topic-metadata">

**Author:** [@Atul87](https://discuss.elastic.co/u/Atul87)\
**Replies:** 3\
**Last updated:** [January 4, 2024, 8:28am UTC](https://discuss.elastic.co/t/embedding-kibana-using-iframe/350042 "2024-01-04T08:28:10Z")

</div>

Hi team, I am trying to embed kibana url using iframe, but its not working for me. I am using kibana version 7.17.13, I want to embed overall kibana, with all its functionality not just any one dashbord of it. Authenti…

---

## [Stack Monitoring Access Denied](https://discuss.elastic.co/t/stack-monitoring-access-denied/350313)

<div class="topic-metadata">

**Author:** [@sourcreamnormanbates](https://discuss.elastic.co/u/sourcreamnormanbates)\
**Replies:** 3\
**Last updated:** [January 3, 2024, 9:32pm UTC](https://discuss.elastic.co/t/stack-monitoring-access-denied/350313 "2024-01-03T21:32:48Z")

</div>

When I try to view Stack Monitoring, I receive an error message. I get the same message with the default elastic admin user as well as my provisioned unique admin user account I use. I only have one cluster, so I'm not…

---

## [Share a dashboard in read-only mode](https://discuss.elastic.co/t/share-a-dashboard-in-read-only-mode/350326)

<div class="topic-metadata">

**Author:** [@gnatola](https://discuss.elastic.co/u/gnatola)\
**Replies:** 3\
**Last updated:** [January 3, 2024, 7:58pm UTC](https://discuss.elastic.co/t/share-a-dashboard-in-read-only-mode/350326 "2024-01-03T19:58:40Z")

</div>

Hello, using Kibana 8.11. Created a dashboard that I would like to share in read-only mode. I would like to be the only person who can edit the dashboard. What is the best way to accomplish this? Thanks.

---

## [Audit logging in Elastic Cloud](https://discuss.elastic.co/t/audit-logging-in-elastic-cloud/348688)

<div class="topic-metadata">

**Author:** [@lreger](https://discuss.elastic.co/u/lreger)\
**Replies:** 2\
**Last updated:** [January 3, 2024, 5:08pm UTC](https://discuss.elastic.co/t/audit-logging-in-elastic-cloud/348688 "2024-01-03T17:08:34Z")

</div>

I have two questions I was hoping someone could answer. Question 1: I am using an elastic cloud deployment running ES 7.17.5. I know how to enable audit logging and ship those logs to my monitoring deployment. I noticed…

---

## [Error running Elastic Maps behind proxy](https://discuss.elastic.co/t/error-running-elastic-maps-behind-proxy/350082)

<div class="topic-metadata">

**Author:** [@m.hanna](https://discuss.elastic.co/u/m.hanna)\
**Replies:** 7\
**Last updated:** [January 3, 2024, 4:52pm UTC](https://discuss.elastic.co/t/error-running-elastic-maps-behind-proxy/350082 "2024-01-03T16:52:38Z")

</div>

I am trying to run an EMS server on a disconnected network behind an Nginx reverse-proxy in a docker swarm. I am able to start EMS up and it looks to connect to elasticsearch without the basePath setting. As soon as I a…

---

## [Plugin installation was unsuccessful due to error Plugin kibanaPrometheusExporter \[7.17.0\] is incompatible with Kibana \[7.17.15\]](https://discuss.elastic.co/t/plugin-installation-was-unsuccessful-due-to-error-plugin-kibanaprometheusexporter-7-17-0-is-incompatible-with-kibana-7-17-15/350231)

<div class="topic-metadata">

**Author:** [@Domnic\_Raj\_D](https://discuss.elastic.co/u/Domnic_Raj_D)\
**Replies:** 6\
**Last updated:** [January 3, 2024, 12:44pm UTC](https://discuss.elastic.co/t/plugin-installation-was-unsuccessful-due-to-error-plugin-kibanaprometheusexporter-7-17-0-is-incompatible-with-kibana-7-17-15/350231 "2024-01-03T12:44:55Z")

</div>

I have upgraded Kibana to version 7.17.15 in our environment, but I cannot find the Kibana Prometheus Exporter version 7.17.15 on the GitHub page. I attempted versions 7.17.0 and the latest patch version, but encountered…

---

## [Kibana server is not ready yet](https://discuss.elastic.co/t/kibana-server-is-not-ready-yet/350280)

<div class="topic-metadata">

**Author:** [@MD\_Rezaul\_Karim](https://discuss.elastic.co/u/MD_Rezaul_Karim)\
**Replies:** 10\
**Last updated:** [January 3, 2024, 11:11am UTC](https://discuss.elastic.co/t/kibana-server-is-not-ready-yet/350280 "2024-01-03T11:11:08Z")

</div>

Hi, I am getting following error. anyone pls. help me .. Jan 03 13:21:50 siem kibana\[10792\]: FATAL Error: Unable to complete saved object migrations for the \[.kibana\_task\_manager\] index. Please check the health of you…

---

## [I want restore my details in the managed repository like client, bucket , base path how to get old details](https://discuss.elastic.co/t/i-want-restore-my-details-in-the-managed-repository-like-client-bucket-base-path-how-to-get-old-details/350281)

<div class="topic-metadata">

**Author:** [@Gopi\_Tellakula](https://discuss.elastic.co/u/Gopi_Tellakula)\
**Replies:** 0\
**Last updated:** [January 3, 2024, 7:53am UTC](https://discuss.elastic.co/t/i-want-restore-my-details-in-the-managed-repository-like-client-bucket-base-path-how-to-get-old-details/350281 "2024-01-03T07:53:15Z")

</div>

i want restore my details in managed repository like client, bucket , base path how to get old details, i ran some code in dev tools to create another repository it changed this managed repository details also. i need t…

---

## [Kibana Vega visualizations don't honor courier:ignoreFilterIfFieldNotInIndex settings](https://discuss.elastic.co/t/kibana-vega-visualizations-dont-honor-courier-ignorefilteriffieldnotinindex-settings/348962)

<div class="topic-metadata">

**Author:** [@Prakash\_Gupta](https://discuss.elastic.co/u/Prakash_Gupta)\
**Replies:** 2\
**Last updated:** [January 2, 2024, 4:13pm UTC](https://discuss.elastic.co/t/kibana-vega-visualizations-dont-honor-courier-ignorefilteriffieldnotinindex-settings/348962 "2024-01-02T16:13:34Z")

</div>

I have a dashboard where I have multiple metrics visualizations from different indices including lenses and vega. If I apply a filter on the dashboard, I just wanted the visualizations which are having the field should o…

---

## [Kibana not accessible via Kubernetes Ingress](https://discuss.elastic.co/t/kibana-not-accessible-via-kubernetes-ingress/349162)

<div class="topic-metadata">

**Author:** [@patrick-94](https://discuss.elastic.co/u/patrick-94)\
**Replies:** 4\
**Last updated:** [January 2, 2024, 3:18pm UTC](https://discuss.elastic.co/t/kibana-not-accessible-via-kubernetes-ingress/349162 "2024-01-02T15:18:04Z")

</div>

Hey, i have the following Problem which I copy and paste it from Github, anyone here who can help me out with this? This is the Original Post to Github: Kibana not accessible via Ingress · Issue #172630 · elastic/kiban…

---

## [Visualization Lens bar display limit](https://discuss.elastic.co/t/visualization-lens-bar-display-limit/350212)

<div class="topic-metadata">

**Author:** [@Liam619](https://discuss.elastic.co/u/Liam619)\
**Replies:** 1\
**Last updated:** [January 2, 2024, 3:17pm UTC](https://discuss.elastic.co/t/visualization-lens-bar-display-limit/350212 "2024-01-02T15:17:52Z")

</div>

Hi everyone and happy new year. I have a question regarding Visual Lens -\> Bar Chart. I'm trying to display more bars in my chart, during my testing stage, it found that the number of bar charts that can display with a…

---

## [Kibana 审计功能](https://discuss.elastic.co/t/kibana/350219)

<div class="topic-metadata">

**Author:** [@wq1357226](https://discuss.elastic.co/u/wq1357226)\
**Replies:** 0\
**Last updated:** [January 2, 2024, 10:04am UTC](https://discuss.elastic.co/t/kibana/350219 "2024-01-02T10:04:37Z")

</div>

kibana7.11.2咋样开启审计日志功能，记录在目标日志中或者展示到控制台上，根据官网文档添加配置重启，无报错，也无日志输出

---

## [Kibana v8(beat)和V7主题版本的区别](https://discuss.elastic.co/t/kibana-v8-beat-v7/350217)

<div class="topic-metadata">

**Author:** [@wq1357226](https://discuss.elastic.co/u/wq1357226)\
**Replies:** 0\
**Last updated:** [January 2, 2024, 10:01am UTC](https://discuss.elastic.co/t/kibana-v8-beat-v7/350217 "2024-01-02T10:01:19Z")

</div>

kibana7.11.2提供V8（beat）和V7两种版本选择，有什么区别呢

---

## [Kibana\_error](https://discuss.elastic.co/t/kibana-error/349585)

<div class="topic-metadata">

**Author:** [@sossoulokoariel](https://discuss.elastic.co/u/sossoulokoariel)\
**Replies:** 3\
**Last updated:** [January 2, 2024, 8:30am UTC](https://discuss.elastic.co/t/kibana-error/349585 "2024-01-02T08:30:48Z")

</div>

Hi community, hope you're well. I'm in the process of implementing the ELK stack as part of my dissertation project. For a few weeks I haven't logged in, but today I logged in, but the web interface puts Kibana is not re…

---

## [Kibana8.4.3 & nginx，nginx returns 502 bad gateway](https://discuss.elastic.co/t/kibana8-4-3-nginx-nginx-returns-502-bad-gateway/350197)

<div class="topic-metadata">

**Author:** [@gaygayGuys](https://discuss.elastic.co/u/gaygayGuys)\
**Replies:** 0\
**Last updated:** [January 2, 2024, 7:29am UTC](https://discuss.elastic.co/t/kibana8-4-3-nginx-nginx-returns-502-bad-gateway/350197 "2024-01-02T07:29:19Z")

</div>

hello everyone ! i need help !!!! when i use nginx to proxy kibana ,i find a tricky problem. at the beginning ,everything is ok. but several minutes later, 502 bad gateway is starting to appear! i hava no idea to solve…

---

## [Attempt to create Lens visualization produces an error "Cannot read properties of undefined (reading 'localeCompare')"](https://discuss.elastic.co/t/attempt-to-create-lens-visualization-produces-an-error-cannot-read-properties-of-undefined-reading-localecompare/350010)

<div class="topic-metadata">

**Author:** [@Nicole\_Hirshler](https://discuss.elastic.co/u/Nicole_Hirshler)\
**Replies:** 4\
**Last updated:** [January 1, 2024, 12:29pm UTC](https://discuss.elastic.co/t/attempt-to-create-lens-visualization-produces-an-error-cannot-read-properties-of-undefined-reading-localecompare/350010 "2024-01-01T12:29:42Z")

</div>

Since the upgrade to 7.17.12 ELK, I cannot create Lens visualization. I searched the internet and found some post saying that it can be related to the security. ELK is configured in my setup with two users: elastic and s…

---

## [Conditional formatting for data and colors according to input field available for dashboard users](https://discuss.elastic.co/t/conditional-formatting-for-data-and-colors-according-to-input-field-available-for-dashboard-users/350177)

<div class="topic-metadata">

**Author:** [@Magdy](https://discuss.elastic.co/u/Magdy)\
**Replies:** 0\
**Last updated:** [January 1, 2024, 7:17am UTC](https://discuss.elastic.co/t/conditional-formatting-for-data-and-colors-according-to-input-field-available-for-dashboard-users/350177 "2024-01-01T07:17:38Z")

</div>

Create text input on the screen and compare it with the value in the tree map to change the background of cells accordingly.

---

## [How to compare the value of field with the input value from the screen to take an action?](https://discuss.elastic.co/t/how-to-compare-the-value-of-field-with-the-input-value-from-the-screen-to-take-an-action/350168)

<div class="topic-metadata">

**Author:** [@adnan-ali](https://discuss.elastic.co/u/adnan-ali)\
**Replies:** 0\
**Last updated:** [January 1, 2024, 5:37am UTC](https://discuss.elastic.co/t/how-to-compare-the-value-of-field-with-the-input-value-from-the-screen-to-take-an-action/350168 "2024-01-01T05:37:32Z")

</div>

in the tree map value ,we need to change the background color of tree map cell depend on the input value from the screen to comparing with value on tree map EX: tree map value is 1000 . input value from screen is 1200…

---

## [Vega Force Directed Graph and Kibana: Use data from index not from a json](https://discuss.elastic.co/t/vega-force-directed-graph-and-kibana-use-data-from-index-not-from-a-json/349405)

<div class="topic-metadata">

**Author:** [@Ranger\_Rick](https://discuss.elastic.co/u/Ranger_Rick)\
**Replies:** 2\
**Last updated:** [December 30, 2023, 12:51pm UTC](https://discuss.elastic.co/t/vega-force-directed-graph-and-kibana-use-data-from-index-not-from-a-json/349405 "2023-12-30T12:51:41Z")

</div>

Good afternoon! I have two indexes with data in my instances and am trying to make a force directed graph to visualize relationships. There is an excellent example available Vega's github (Vega Github's Force Directed La…

---

## [I need help](https://discuss.elastic.co/t/i-need-help/349630)

<div class="topic-metadata">

**Author:** [@omlett](https://discuss.elastic.co/u/omlett)\
**Replies:** 2\
**Last updated:** [December 29, 2023, 4:07pm UTC](https://discuss.elastic.co/t/i-need-help/349630 "2023-12-29T16:07:40Z")

</div>

i am trying to make a parsedmarc elasticsearch and Kibana docker container, everything is running fine except i dont see any data on Kibana and i dont know what im doing wrong, because with the same configs they were run…

---

## [Create visualization on kibana for one filed if the other filed is present in document](https://discuss.elastic.co/t/create-visualization-on-kibana-for-one-filed-if-the-other-filed-is-present-in-document/350116)

<div class="topic-metadata">

**Author:** [@RameshNagargoje](https://discuss.elastic.co/u/RameshNagargoje)\
**Replies:** 1\
**Last updated:** [December 29, 2023, 3:21pm UTC](https://discuss.elastic.co/t/create-visualization-on-kibana-for-one-filed-if-the-other-filed-is-present-in-document/350116 "2023-12-29T15:21:23Z")

</div>

I have use case is to create the pie chart for "name" present in documents when documents has a "status" field available. We have several documents in an index; for all documents, we have "name" available, but the "sta…

[Previous page](https://discuss.elastic.co/c/elastic-stack/kibana/7.md?page=75)

[Next page](https://discuss.elastic.co/c/elastic-stack/kibana/7.md?page=77)
