# Kibana

**URL:** https://discuss.elastic.co/c/elastic-stack/kibana/7.md?page=89

[Latest](https://discuss.elastic.co/latest.md) · [Categories](https://discuss.elastic.co/categories.md) · [Tags](https://discuss.elastic.co/tags.md)

**Page:** 90

---

## [Kibana rule - raise alert when CPU is over 90% for the last 5 min](https://discuss.elastic.co/t/kibana-rule-raise-alert-when-cpu-is-over-90-for-the-last-5-min/344404)

<div class="topic-metadata">

**Author:** [@catalin.bulancea](https://discuss.elastic.co/u/catalin.bulancea)\
**Replies:** 6\
**Last updated:** [October 16, 2023, 5:02pm UTC](https://discuss.elastic.co/t/kibana-rule-raise-alert-when-cpu-is-over-90-for-the-last-5-min/344404 "2023-10-16T17:02:22Z")

</div>

Hi gurus, I'm new to Rules in Kibana so I need your help. I need to raise an email alert when the CPU is constantly exceeding 90% for the past 5 minutes. The way I configured the rule is the following: The alert i…

---

## [No Data streams](https://discuss.elastic.co/t/no-data-streams/344985)

<div class="topic-metadata">

**Author:** [@Jean-Claude](https://discuss.elastic.co/u/Jean-Claude)\
**Replies:** 4\
**Last updated:** [October 16, 2023, 2:10pm UTC](https://discuss.elastic.co/t/no-data-streams/344985 "2023-10-16T14:10:30Z")

</div>

Hello, i hope you are doing well This my infra ELASTIC v-elkmaster01.sys.u-bordeaux.fr v-elkmaster02.sys.u-bordeaux.fr v-elkmaster03.sys.u-bordeaux.fr p-elkhot01.sys.u-bordeaux.fr p-elkhot02.sys.u-bordeaux.fr p-elkwar…

---

## [Enabling Native Multi-Factor Authentication in On-Premises versions](https://discuss.elastic.co/t/enabling-native-multi-factor-authentication-in-on-premises-versions/345108)

<div class="topic-metadata">

**Author:** [@yago82](https://discuss.elastic.co/u/yago82)\
**Replies:** 1\
**Last updated:** [October 16, 2023, 1:18pm UTC](https://discuss.elastic.co/t/enabling-native-multi-factor-authentication-in-on-premises-versions/345108 "2023-10-16T13:18:32Z")

</div>

Hello everyone, I'm currently using Elasticsearch in an on-premises environment and I'm exploring options to enhance the security of my cluster. I was wondering if enabling a native multi-factor authentication is possib…

---

## [Unable to Display Visualization in custom plugin](https://discuss.elastic.co/t/unable-to-display-visualization-in-custom-plugin/345106)

<div class="topic-metadata">

**Author:** [@Amit\_Dhiman](https://discuss.elastic.co/u/Amit_Dhiman)\
**Replies:** 0\
**Last updated:** [October 16, 2023, 12:52pm UTC](https://discuss.elastic.co/t/unable-to-display-visualization-in-custom-plugin/345106 "2023-10-16T12:52:41Z")

</div>

I am successful to create and display Dashbaords and Lens in my custom plugin. I have some visualizations created in Kibana Admin. I want these visualizations to be rendered into my custom plugin screen. I tried many s…

---

## [Clean filter when going back from a drilldown](https://discuss.elastic.co/t/clean-filter-when-going-back-from-a-drilldown/345068)

<div class="topic-metadata">

**Author:** [@jaimika\_kosambia](https://discuss.elastic.co/u/jaimika_kosambia)\
**Replies:** 0\
**Last updated:** [October 16, 2023, 7:02am UTC](https://discuss.elastic.co/t/clean-filter-when-going-back-from-a-drilldown/345068 "2023-10-16T07:02:28Z")

</div>

How can we clean filter when going back from a drilldown?

---

## [Dashboards are not picking right fields](https://discuss.elastic.co/t/dashboards-are-not-picking-right-fields/345032)

<div class="topic-metadata">

**Author:** [@huzaifa224](https://discuss.elastic.co/u/huzaifa224)\
**Replies:** 1\
**Last updated:** [October 15, 2023, 2:07am UTC](https://discuss.elastic.co/t/dashboards-are-not-picking-right-fields/345032 "2023-10-15T02:07:45Z")

</div>

I am sending data from multiple Linux servers to Logstash using Filebeat, which then forwards the data to Elasticsearch after applying parsing rules for SSH logs. The problem is that when I open the default SSH dashboard…

---

## [Testing kibana 8.5](https://discuss.elastic.co/t/testing-kibana-8-5/344727)

<div class="topic-metadata">

**Author:** [@mzm1370](https://discuss.elastic.co/u/mzm1370)\
**Replies:** 3\
**Last updated:** [October 14, 2023, 11:11am UTC](https://discuss.elastic.co/t/testing-kibana-8-5/344727 "2023-10-14T11:11:17Z")

</div>

Hello, I want to put the success and failure logs of Kibana automatic test into the file, please help me

---

## [Mounting disk at home/kafka\_data which has 20Gb already and data as well](https://discuss.elastic.co/t/mounting-disk-at-home-kafka-data-which-has-20gb-already-and-data-as-well/344991)

<div class="topic-metadata">

**Author:** [@kriti\_dabas](https://discuss.elastic.co/u/kriti_dabas)\
**Replies:** 5\
**Last updated:** [October 13, 2023, 5:33pm UTC](https://discuss.elastic.co/t/mounting-disk-at-home-kafka-data-which-has-20gb-already-and-data-as-well/344991 "2023-10-13T17:33:57Z")

</div>

typ\*\* command lsblk for checking the space added NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT sda 8:0 0 40G 0 disk ├─sda1 8:1 0 …

---

## ["Web Server Misconfiguration: Insecure Content-Type Setting" vulnerability detected after version upgrade](https://discuss.elastic.co/t/web-server-misconfiguration-insecure-content-type-setting-vulnerability-detected-after-version-upgrade/344625)

<div class="topic-metadata">

**Author:** [@Septianingrum.17](https://discuss.elastic.co/u/Septianingrum.17)\
**Replies:** 1\
**Last updated:** [October 13, 2023, 2:27pm UTC](https://discuss.elastic.co/t/web-server-misconfiguration-insecure-content-type-setting-vulnerability-detected-after-version-upgrade/344625 "2023-10-13T14:27:36Z")

</div>

After I upgraded the elastic stack to 8.6.0 and carried out a vulnerability scan on Kibana using the microfocus tool, there were vulnerabilities as follows: I have made changes to the Kibana configuration, namely cha…

---

## [Kibana Alerts - Alert Details URL](https://discuss.elastic.co/t/kibana-alerts-alert-details-url/343398)

<div class="topic-metadata">

**Author:** [@Gelinski](https://discuss.elastic.co/u/Gelinski)\
**Replies:** 1\
**Last updated:** [October 13, 2023, 2:12pm UTC](https://discuss.elastic.co/t/kibana-alerts-alert-details-url/343398 "2023-10-13T14:12:24Z")

</div>

Hello folks, I have an alert rule configured with a ServiceNow ITOM Connector where I am setting the following content to the description field: =RULE= {{rule.name}} =REASON= {{context.reason}} =DETAILS= CRITERIA: {{…

---

## [Filter data into kibana dashboard using post method](https://discuss.elastic.co/t/filter-data-into-kibana-dashboard-using-post-method/345001)

<div class="topic-metadata">

**Author:** [@Sujith\_Nair](https://discuss.elastic.co/u/Sujith_Nair)\
**Replies:** 0\
**Last updated:** [October 13, 2023, 12:33pm UTC](https://discuss.elastic.co/t/filter-data-into-kibana-dashboard-using-post-method/345001 "2023-10-13T12:33:17Z")

</div>

Hi Team, I would like to filter out data dynamically using javascript with the help of post method. I have used the a script but getting error in the post method. Attaching the script for your reference. const kibanaDa…

---

## [“Cache Management: Insecure Policy” vulnerability detected after version upgrade](https://discuss.elastic.co/t/cache-management-insecure-policy-vulnerability-detected-after-version-upgrade/344627)

<div class="topic-metadata">

**Author:** [@Septianingrum.17](https://discuss.elastic.co/u/Septianingrum.17)\
**Replies:** 2\
**Last updated:** [October 13, 2023, 9:08am UTC](https://discuss.elastic.co/t/cache-management-insecure-policy-vulnerability-detected-after-version-upgrade/344627 "2023-10-13T09:08:16Z")

</div>

After I upgraded the elastic stack to 8.6.0 and carried out a vulnerability scan on Kibana using the microfocus tool, there were vulnerabilities as follows: I have made changes to the Kibana configuration, namely cha…

---

## [Search error and escaping characters](https://discuss.elastic.co/t/search-error-and-escaping-characters/344935)

<div class="topic-metadata">

**Author:** [@Lewis030](https://discuss.elastic.co/u/Lewis030)\
**Replies:** 1\
**Last updated:** [October 13, 2023, 5:59am UTC](https://discuss.elastic.co/t/search-error-and-escaping-characters/344935 "2023-10-13T05:59:07Z")

</div>

Hello there, i'm trying to play around with a rule to search for instances of the Sticky Key being abused in Windows. The output below has been created from converting a SIGMA rule: process where (event.category : "pro…

---

## [Visualizing certain elements in an Array field](https://discuss.elastic.co/t/visualizing-certain-elements-in-an-array-field/344849)

<div class="topic-metadata">

**Author:** [@hs121](https://discuss.elastic.co/u/hs121)\
**Replies:** 2\
**Last updated:** [October 12, 2023, 3:21pm UTC](https://discuss.elastic.co/t/visualizing-certain-elements-in-an-array-field/344849 "2023-10-12T15:21:18Z")

</div>

Hi there, This is a naive question but I have a field called "tools\_usage" that holds some Array data: e.g tools\_record = \[ "toolname:banana", "toolcategory:fruit", "success:true", \] self.es.index(index="my\_i…

---

## [Bar chart comparison of count for today and yesterday](https://discuss.elastic.co/t/bar-chart-comparison-of-count-for-today-and-yesterday/344687)

<div class="topic-metadata">

**Author:** [@Jason\_Paralta](https://discuss.elastic.co/u/Jason_Paralta)\
**Replies:** 6\
**Last updated:** [October 12, 2023, 2:25pm UTC](https://discuss.elastic.co/t/bar-chart-comparison-of-count-for-today-and-yesterday/344687 "2023-10-12T14:25:28Z")

</div>

Hello, I have 3 different regions namely US,APAC and EMEA based licennse. Now I have index with below field: us.region.license.inuse, apac.region.license.inuse and emea.region.license.inuse and now I want to make bar c…

---

## [How to block drilldown except for a specific field in the table in kibana?](https://discuss.elastic.co/t/how-to-block-drilldown-except-for-a-specific-field-in-the-table-in-kibana/344871)

<div class="topic-metadata">

**Author:** [@Aromal\_Thulazi](https://discuss.elastic.co/u/Aromal_Thulazi)\
**Replies:** 2\
**Last updated:** [October 12, 2023, 10:10am UTC](https://discuss.elastic.co/t/how-to-block-drilldown-except-for-a-specific-field-in-the-table-in-kibana/344871 "2023-10-12T10:10:15Z")

</div>

I have two dashboards & it is connected using drilldown .In my first dashboard I have an aggregation based table & have many columns on that table . I want to block the option to go to other dashboard from all other col…

---

## [Kibana Transform\_Vis plugin for 8.x](https://discuss.elastic.co/t/kibana-transform-vis-plugin-for-8-x/344626)

<div class="topic-metadata">

**Author:** [@pchanas](https://discuss.elastic.co/u/pchanas)\
**Replies:** 3\
**Last updated:** [October 12, 2023, 8:56am UTC](https://discuss.elastic.co/t/kibana-transform-vis-plugin-for-8-x/344626 "2023-10-12T08:56:12Z")

</div>

Hi everybody, We have an extensive usage of the transform\_viz plugin firstly released by PhaedrusTheGreek and then maintained by \[gwintzer\] (GitHub - gwintzer/transform\_vis: Transform Visualization for Kibana). Has any…

---

## [Nginx 502 bad gateway, and kibana restarting](https://discuss.elastic.co/t/nginx-502-bad-gateway-and-kibana-restarting/344858)

<div class="topic-metadata">

**Author:** [@Mohammad\_Ramadan\_Abd](https://discuss.elastic.co/u/Mohammad_Ramadan_Abd)\
**Replies:** 1\
**Last updated:** [October 12, 2023, 2:45am UTC](https://discuss.elastic.co/t/nginx-502-bad-gateway-and-kibana-restarting/344858 "2023-10-12T02:45:27Z")

</div>

My stack is not working and when I login I receive this message nginx "502 Bad gateway". I have checked the kibana service and I found it continously restarting. tailing logs for kibana I found " di@dar-elk-7:~$ tail …

---

## [Update to stopwords not reflected in Tag Cloud](https://discuss.elastic.co/t/update-to-stopwords-not-reflected-in-tag-cloud/343353)

<div class="topic-metadata">

**Author:** [@ADarkDividedGem](https://discuss.elastic.co/u/ADarkDividedGem)\
**Replies:** 1\
**Last updated:** [October 11, 2023, 6:22pm UTC](https://discuss.elastic.co/t/update-to-stopwords-not-reflected-in-tag-cloud/343353 "2023-10-11T18:22:43Z")

</div>

My index uses a stop words file as part of its analyzer: "analysis": { "filter": { "stopwords\_filter": { "ignore\_case": "true", "type": "stop", "stopwords\_path": "en\_complete.txt" } }, "analyzer": { "c…

---

## [Vertical Scroll bar not visible in Kibana](https://discuss.elastic.co/t/vertical-scroll-bar-not-visible-in-kibana/343792)

<div class="topic-metadata">

**Author:** [@Kibana\_User](https://discuss.elastic.co/u/Kibana_User)\
**Replies:** 1\
**Last updated:** [October 11, 2023, 6:00pm UTC](https://discuss.elastic.co/t/vertical-scroll-bar-not-visible-in-kibana/343792 "2023-10-11T18:00:39Z")

</div>

I am using a 7.15.1 version and I am not seeing the page vertical scroll bar in kibana. Can some one help on this.

---

## [Kibana giving application not found error](https://discuss.elastic.co/t/kibana-giving-application-not-found-error/344805)

<div class="topic-metadata">

**Author:** [@swapnilsadkar](https://discuss.elastic.co/u/swapnilsadkar)\
**Replies:** 1\
**Last updated:** [October 11, 2023, 5:34pm UTC](https://discuss.elastic.co/t/kibana-giving-application-not-found-error/344805 "2023-10-11T17:34:03Z")

</div>

Hi Team, Kibana shows all log counts but when we click dataset DNS or any other tab it shows application not found and No application was found this URL error. Could you please help me to resolve this error? Thanks

---

## [Without the write permission of the kibana directory, how to launch kibana properly](https://discuss.elastic.co/t/without-the-write-permission-of-the-kibana-directory-how-to-launch-kibana-properly/344543)

<div class="topic-metadata">

**Author:** [@Lingran\_Xiao](https://discuss.elastic.co/u/Lingran_Xiao)\
**Replies:** 1\
**Last updated:** [October 11, 2023, 3:17pm UTC](https://discuss.elastic.co/t/without-the-write-permission-of-the-kibana-directory-how-to-launch-kibana-properly/344543 "2023-10-11T15:17:25Z")

</div>

Hi, I don't have the write permission of the kibana-8.7.1 directory, but my group want me to finish the deployment of kibana. I specify the config directory by using the environment variable KBN\_PATH\_CONF. And when I tr…

---

## [Visualization In Kibana after Merging/Mapping](https://discuss.elastic.co/t/visualization-in-kibana-after-merging-mapping/344801)

<div class="topic-metadata">

**Author:** [@Priyaansh\_Dwivedi](https://discuss.elastic.co/u/Priyaansh_Dwivedi)\
**Replies:** 1\
**Last updated:** [October 11, 2023, 11:29am UTC](https://discuss.elastic.co/t/visualization-in-kibana-after-merging-mapping/344801 "2023-10-11T11:29:32Z")

</div>

"Hello Community, I've always found great support here, and I'm hoping for the same assistance again. In my application, I'm dealing with three different types of logs. These logs are sent to Logstash via Filebeat, wher…

---

## [Connector in KIbana not showing "Define Time field for each document"](https://discuss.elastic.co/t/connector-in-kibana-not-showing-define-time-field-for-each-document/344796)

<div class="topic-metadata">

**Author:** [@Ashish\_Kumar4](https://discuss.elastic.co/u/Ashish_Kumar4)\
**Replies:** 1\
**Last updated:** [October 11, 2023, 8:08am UTC](https://discuss.elastic.co/t/connector-in-kibana-not-showing-define-time-field-for-each-document/344796 "2023-10-11T08:08:09Z")

</div>

I have self hosted the ELK stack and in that while adding a connector i can see that there is no option coming for "Define Time field for each document" as shown in kibana documentation. Version : 8.7 Link for document…

---

## [Define Runtime Field as Clickable URL](https://discuss.elastic.co/t/define-runtime-field-as-clickable-url/344784)

<div class="topic-metadata">

**Author:** [@carollyl](https://discuss.elastic.co/u/carollyl)\
**Replies:** 1\
**Last updated:** [October 11, 2023, 6:07am UTC](https://discuss.elastic.co/t/define-runtime-field-as-clickable-url/344784 "2023-10-11T06:07:59Z")

</div>

Referring to the attached screenshot of Scripted Field, it was working using Kibana 7.17.0. Expected to see the label shows up on Kibana as 1234567 (es\_id) and the clickable URL being resolved using URL template, e.g. ht…

---

## [How to add a map by pointing to an external map server but not elastic map server?](https://discuss.elastic.co/t/how-to-add-a-map-by-pointing-to-an-external-map-server-but-not-elastic-map-server/344416)

<div class="topic-metadata">

**Author:** [@FredMir](https://discuss.elastic.co/u/FredMir)\
**Replies:** 5\
**Last updated:** [October 10, 2023, 8:55pm UTC](https://discuss.elastic.co/t/how-to-add-a-map-by-pointing-to-an-external-map-server-but-not-elastic-map-server/344416 "2023-10-10T20:55:20Z")

</div>

I want to add a map for data visualization by pointing to a map server already available by my company. I don't have access to internet and I don't want to download docker image for Elastic map server. How can I change t…

---

## [Issue with ingest pipeline](https://discuss.elastic.co/t/issue-with-ingest-pipeline/344535)

<div class="topic-metadata">

**Author:** [@rafaelrangel](https://discuss.elastic.co/u/rafaelrangel)\
**Replies:** 18\
**Last updated:** [October 10, 2023, 4:45pm UTC](https://discuss.elastic.co/t/issue-with-ingest-pipeline/344535 "2023-10-10T16:45:16Z")

</div>

I have a data entry through Logstash (8.9.1) that does not have a field (hostname) only ip. I created a pipeline using the Elastic API (8.9.1) like this: PUT \_ingest/pipeline/name\_device\_ping { "processors": \[ { …

---

## [Does Kibana have a way to use a scroll option in dashboard/graphs(lens)?](https://discuss.elastic.co/t/does-kibana-have-a-way-to-use-a-scroll-option-in-dashboard-graphs-lens/344554)

<div class="topic-metadata">

**Author:** [@erikg](https://discuss.elastic.co/u/erikg)\
**Replies:** 4\
**Last updated:** [October 10, 2023, 2:17pm UTC](https://discuss.elastic.co/t/does-kibana-have-a-way-to-use-a-scroll-option-in-dashboard-graphs-lens/344554 "2023-10-10T14:17:51Z")

</div>

Hello, I was wondering how I can display a graph(lens) with time series data where I can drill down without distorting the wide view. A good example of what I want is this from Elastic ML: Not sure if that's availa…

---

## [Pre-built Dashboards Not Loading for Users Except Superuser](https://discuss.elastic.co/t/pre-built-dashboards-not-loading-for-users-except-superuser/344642)

<div class="topic-metadata">

**Author:** [@Ankur\_Mahajan](https://discuss.elastic.co/u/Ankur_Mahajan)\
**Replies:** 10\
**Last updated:** [October 10, 2023, 1:26pm UTC](https://discuss.elastic.co/t/pre-built-dashboards-not-loading-for-users-except-superuser/344642 "2023-10-10T13:26:50Z")

</div>

I have encountered an issue with certain pre-built dashboards in our system. These dashboards are failing to load for any users except the superuser. I have verified that all the required permissions are correctly assign…

---

## [Grok parser question (Invalid json string)](https://discuss.elastic.co/t/grok-parser-question-invalid-json-string/344730)

<div class="topic-metadata">

**Author:** [@superm0](https://discuss.elastic.co/u/superm0)\
**Replies:** 0\
**Last updated:** [October 10, 2023, 11:46am UTC](https://discuss.elastic.co/t/grok-parser-question-invalid-json-string/344730 "2023-10-10T11:46:22Z")

</div>

Hi,please assit me with creating custom grok pattern . I've created custom pattern, it works perfectly in Grok Debugger. But i cant add this expression for parsing data: Error: Invalid Json string. %{SYSLOGTIMESTAMP:…

[Previous page](https://discuss.elastic.co/c/elastic-stack/kibana/7.md?page=88)

[Next page](https://discuss.elastic.co/c/elastic-stack/kibana/7.md?page=90)
