# Elastic Observability

**URL:** https://discuss.elastic.co/c/observability/82.md?page=1

[Latest](https://discuss.elastic.co/latest.md) · [Categories](https://discuss.elastic.co/categories.md) · [Tags](https://discuss.elastic.co/tags.md)

**Page:** 2

---

## [EDOT pushing to elastic fails with HTTP status message: Bad Request](https://discuss.elastic.co/t/edot-pushing-to-elastic-fails-with-http-status-message-bad-request/375661)

<div class="topic-metadata">

**Author:** [@yev](https://discuss.elastic.co/u/yev)\
**Replies:** 12\
**Last updated:** [March 26, 2026, 2:32pm UTC](https://discuss.elastic.co/t/edot-pushing-to-elastic-fails-with-http-status-message-bad-request/375661 "2026-03-26T14:32:46Z")

</div>

Hi there, I'm exploring the capabilities of EDOT and I have an issue: Logs from my spring-boot app \[otel.javaagent 2025-03-10 16:31:10:565 +0100\] \[OkHttp http://localhost:9200/...\] WARN io.opentelemetry.exporter.inter…

---

## [Wrapping Elastic OTEL Java Agent for internal standardization — best practices & legal considerations](https://discuss.elastic.co/t/wrapping-elastic-otel-java-agent-for-internal-standardization-best-practices-legal-considerations/385586)

<div class="topic-metadata">

**Author:** [@rajbdilip](https://discuss.elastic.co/u/rajbdilip)\
**Replies:** 6\
**Last updated:** [March 26, 2026, 7:49am UTC](https://discuss.elastic.co/t/wrapping-elastic-otel-java-agent-for-internal-standardization-best-practices-legal-considerations/385586 "2026-03-26T07:49:08Z")

</div>

Hi all, We are integrating the Elastic OpenTelemetry Java agent across multiple services in our organization and are exploring creating a small internal wrapper around the agent (elastic-otel-java) to standardize config…

---

## [Docker logs integration with Fleet to a datastream - my experience](https://discuss.elastic.co/t/docker-logs-integration-with-fleet-to-a-datastream-my-experience/385549)

<div class="topic-metadata">

**Author:** [@dot-mike](https://discuss.elastic.co/u/dot-mike)\
**Replies:** 0\
**Last updated:** [March 20, 2026, 4:43pm UTC](https://discuss.elastic.co/t/docker-logs-integration-with-fleet-to-a-datastream-my-experience/385549 "2026-03-20T16:43:07Z")

</div>

Hi community, I'm sharing my experience here for ingesting docker logs with fleet agent-setup. My goal is to ingest docker logs for a specific application running on on-premises on a specific system to a custom datastre…

---

## [Synthetic agents ICMP monitors are all of sudden failing](https://discuss.elastic.co/t/synthetic-agents-icmp-monitors-are-all-of-sudden-failing/385541)

<div class="topic-metadata">

**Author:** [@Whoami1980](https://discuss.elastic.co/u/Whoami1980)\
**Replies:** 0\
**Last updated:** [March 20, 2026, 7:17am UTC](https://discuss.elastic.co/t/synthetic-agents-icmp-monitors-are-all-of-sudden-failing/385541 "2026-03-20T07:17:27Z")

</div>

Our Synthetic agents ICMP monitors are all of sudden failing. While looking through the agent logs. These are the message we see. #message Possible transient error during checkin with fleet-server, retrying #error.me…

---

## [APM some time dont show trace.id by link/to/trace](https://discuss.elastic.co/t/apm-some-time-dont-show-trace-id-by-link-to-trace/385491)

<div class="topic-metadata">

**Author:** [@tmp13](https://discuss.elastic.co/u/tmp13)\
**Replies:** 1\
**Last updated:** [March 18, 2026, 6:13am UTC](https://discuss.elastic.co/t/apm-some-time-dont-show-trace-id-by-link-to-trace/385491 "2026-03-18T06:13:02Z")

</div>

Kibana version: 9.3.0 Elasticsearch version: 9.3.0 APM Server version: 9.3.0 Browser version: Firefox/Safari Original install method (e.g. download page, yum, deb, from source, etc.) and version: tar.gz Fresh instal…

---

## [Paraya 7 JAX-RS invalid transaction name + no span captured with @WithSpan](https://discuss.elastic.co/t/paraya-7-jax-rs-invalid-transaction-name-no-span-captured-with-withspan/384995)

<div class="topic-metadata">

**Author:** [@ciment](https://discuss.elastic.co/u/ciment)\
**Replies:** 3\
**Last updated:** [March 17, 2026, 12:42pm UTC](https://discuss.elastic.co/t/paraya-7-jax-rs-invalid-transaction-name-no-span-captured-with-withspan/384995 "2026-03-17T12:42:03Z")

</div>

Hi, @Sylvain\_Juge Based on previous discussion ( Problem with distributing tracing for Jakarta 10 and payara 6 ) I have already prepared project to test EDOT java agent with payara7. I have problem with payara 7.2026.…

---

## [Certification support team is unresponsive](https://discuss.elastic.co/t/certification-support-team-is-unresponsive/385461)

<div class="topic-metadata">

**Author:** [@riyaz3az](https://discuss.elastic.co/u/riyaz3az)\
**Replies:** 2\
**Last updated:** [March 17, 2026, 6:05am UTC](https://discuss.elastic.co/t/certification-support-team-is-unresponsive/385461 "2026-03-17T06:05:23Z")

</div>

I have purchased the Elastic Observability Engineer exam with my official email account and our email security team is blocking the emails from TrueAbility, in order to change the email address, I’m trying to reach certi…

---

## [TOP N processes (System process metrics)](https://discuss.elastic.co/t/top-n-processes-system-process-metrics/385034)

<div class="topic-metadata">

**Author:** [@fsch](https://discuss.elastic.co/u/fsch)\
**Replies:** 1\
**Last updated:** [March 9, 2026, 1:02am UTC](https://discuss.elastic.co/t/top-n-processes-system-process-metrics/385034 "2026-03-09T01:02:38Z")

</div>

Hi, I have a question concerning the system metrics field system.process.cpu.total.norm.pct described as "The percentage of CPU time spent by the process since the last event. This value is normalized by the number of C…

---

## [How to Bulk update Synthesis ICMP monitor frequency?](https://discuss.elastic.co/t/how-to-bulk-update-synthesis-icmp-monitor-frequency/385291)

<div class="topic-metadata">

**Author:** [@Whoami1980](https://discuss.elastic.co/u/Whoami1980)\
**Replies:** 6\
**Last updated:** [March 4, 2026, 9:29am UTC](https://discuss.elastic.co/t/how-to-bulk-update-synthesis-icmp-monitor-frequency/385291 "2026-03-04T09:29:44Z")

</div>

Our ELK is 8.19 We are using Synthetics monitoring. We have about 5000 ICMP monitors. The current ICMP Ping frequency is currently 3 minutes. Our customer have a request to update all to 1 minute. What’s our best opt…

---

## [Node name APM](https://discuss.elastic.co/t/node-name-apm/384851)

<div class="topic-metadata">

**Author:** [@Karol\_Niema](https://discuss.elastic.co/u/Karol_Niema)\
**Replies:** 4\
**Last updated:** [February 25, 2026, 1:30pm UTC](https://discuss.elastic.co/t/node-name-apm/384851 "2026-02-25T13:30:25Z")

</div>

Hi, I have problem with empty node name in services APM Kibana version: 9.0.3 Elasticsearch version: 9.0.3 My stack TIBCO BW send otel data to local EDOT collector, collector directly send data to elasticsearch Is…

---

## [Problem with distributing tracing for Jakarta 10 and payara 6](https://discuss.elastic.co/t/problem-with-distributing-tracing-for-jakarta-10-and-payara-6/372920)

<div class="topic-metadata">

**Author:** [@ciment](https://discuss.elastic.co/u/ciment)\
**Replies:** 10\
**Last updated:** [February 5, 2026, 9:52am UTC](https://discuss.elastic.co/t/problem-with-distributing-tracing-for-jakarta-10-and-payara-6/372920 "2026-02-05T09:52:54Z")

</div>

Hi, I have a problem with distributing tracing after migration of my application (few microservices) from Payara 5.201 to 6.2024.12. During migration we have already updated application to Jakarta 10 (previous Java EE 8…

---

## [Transactions Not Properly Labeled Since .NET 10 Upgrade](https://discuss.elastic.co/t/transactions-not-properly-labeled-since-net-10-upgrade/384458)

<div class="topic-metadata">

**Author:** [@Brandon\_Liles](https://discuss.elastic.co/u/Brandon_Liles)\
**Replies:** 1\
**Last updated:** [February 2, 2026, 1:39pm UTC](https://discuss.elastic.co/t/transactions-not-properly-labeled-since-net-10-upgrade/384458 "2026-02-02T13:39:20Z")

</div>

Kibana version: 8.18.2 Elasticsearch version: 8.18.2 APM Server version: 8.18.2 APM Agent language and version: Elastic.Apm.NetCoreAll 1.34.1 running on .NET 10 Browser version: n/a Original install method (e.g. dow…

---

## [Kibana lost services in apm after timerange extend](https://discuss.elastic.co/t/kibana-lost-services-in-apm-after-timerange-extend/383582)

<div class="topic-metadata">

**Author:** [@Karol\_Niema](https://discuss.elastic.co/u/Karol_Niema)\
**Replies:** 3\
**Last updated:** [February 2, 2026, 8:37am UTC](https://discuss.elastic.co/t/kibana-lost-services-in-apm-after-timerange-extend/383582 "2026-02-02T08:37:30Z")

</div>

kibana 9.03 elasticserach 9.0.3 Hello I am facing problem with disappeared services in Observability -\> services problem occurs when time range extend, after changing to last 15 min it also happens when exten…

---

## [Kibana Log Threshold Alert Rule Trigger Problem when using multiple conditions](https://discuss.elastic.co/t/kibana-log-threshold-alert-rule-trigger-problem-when-using-multiple-conditions/384795)

<div class="topic-metadata">

**Author:** [@manzer](https://discuss.elastic.co/u/manzer)\
**Replies:** 8\
**Last updated:** [February 1, 2026, 5:54pm UTC](https://discuss.elastic.co/t/kibana-log-threshold-alert-rule-trigger-problem-when-using-multiple-conditions/384795 "2026-02-01T17:54:57Z")

</div>

Hi, I have created many alert rules in Kibana, however currently I am facing a strange issue, when I create Log Threshold Rule with single condition it is working file and Triggering the alert, but if I add multiple con…

---

## [DLL hell; the elastic apm profiler vs OutSystems edition…](https://discuss.elastic.co/t/dll-hell-the-elastic-apm-profiler-vs-outsystems-edition/384737)

<div class="topic-metadata">

**Author:** [@avanlieshout](https://discuss.elastic.co/u/avanlieshout)\
**Replies:** 2\
**Last updated:** [January 26, 2026, 2:26pm UTC](https://discuss.elastic.co/t/dll-hell-the-elastic-apm-profiler-vs-outsystems-edition/384737 "2026-01-26T14:26:06Z")

</div>

DLL hell; the elastic apm profiler vs OutSystems edition… l.s. We are running our applications on an OutSystems platform (v11.32.0 (Build 44177)) which is a lowcode platform hosted on a windows server 2022 IIS. For app…

---

## [Best practice for enriching logs with environment names](https://discuss.elastic.co/t/best-practice-for-enriching-logs-with-environment-names/384655)

<div class="topic-metadata">

**Author:** [@curiousdba](https://discuss.elastic.co/u/curiousdba)\
**Replies:** 4\
**Last updated:** [January 22, 2026, 3:46pm UTC](https://discuss.elastic.co/t/best-practice-for-enriching-logs-with-environment-names/384655 "2026-01-22T15:46:54Z")

</div>

I want to enrich logs by adding service information (Environment specifically). Add a service name to logs seems like what I want. But none of the options seem ideal. Ideally I would have an agent policy for (say) the …

---

## [Choppy graphs with APM 8.x](https://discuss.elastic.co/t/choppy-graphs-with-apm-8-x/384590)

<div class="topic-metadata">

**Author:** [@Alex-T](https://discuss.elastic.co/u/Alex-T)\
**Replies:** 1\
**Last updated:** [January 19, 2026, 4:23pm UTC](https://discuss.elastic.co/t/choppy-graphs-with-apm-8-x/384590 "2026-01-19T16:23:56Z")

</div>

Not sure if this is just a very delayed duplicate of Dropped unsampled transactions in \>= 8.x poses a problem - but I’ve only just upgraded to version 8 of the various stack components. The thoughput/latency graphs show…

---

## [APM Server 7.17.25 crashes: fatal error: concurrent map iteration and map write](https://discuss.elastic.co/t/apm-server-7-17-25-crashes-fatal-error-concurrent-map-iteration-and-map-write/384544)

<div class="topic-metadata">

**Author:** [@jpescalona](https://discuss.elastic.co/u/jpescalona)\
**Replies:** 3\
**Last updated:** [January 19, 2026, 4:02pm UTC](https://discuss.elastic.co/t/apm-server-7-17-25-crashes-fatal-error-concurrent-map-iteration-and-map-write/384544 "2026-01-19T16:02:55Z")

</div>

Kibana version: 8.16.2 Elasticsearch version: 8.16.2 APM Server version: 7.17.25 APM Agent language and version: Java - 1.50.0, 1.43.0 and 1.41.0 Original install method (e.g. download page, yum, deb, from source, et…

---

## [Check if Observability Case was viewed](https://discuss.elastic.co/t/check-if-observability-case-was-viewed/384488)

<div class="topic-metadata">

**Author:** [@GlebCA](https://discuss.elastic.co/u/GlebCA)\
**Replies:** 0\
**Last updated:** [January 12, 2026, 4:44pm UTC](https://discuss.elastic.co/t/check-if-observability-case-was-viewed/384488 "2026-01-12T16:44:42Z")

</div>

Hi, Is there any way to check that an Observability case was at least opened by User / viewed? Like to to notify Assignee if Case was not at least reviewed and provide stat how often Observability Cases are really open…

---

## [How to make EDOT not extract traceparentid from external requests?](https://discuss.elastic.co/t/how-to-make-edot-not-extract-traceparentid-from-external-requests/384457)

<div class="topic-metadata">

**Author:** [@nilsen](https://discuss.elastic.co/u/nilsen)\
**Replies:** 5\
**Last updated:** [January 12, 2026, 2:58pm UTC](https://discuss.elastic.co/t/how-to-make-edot-not-extract-traceparentid-from-external-requests/384457 "2026-01-12T14:58:51Z")

</div>

I'm using the EDOT for Java (elastic-otel-javaagent-1.6.0.jar) which automatically extracts traceparentid from incoming HTTP requests for distributed tracing. This works as expected, however, when our external users also…

---

## [Missing PDF report generator](https://discuss.elastic.co/t/missing-pdf-report-generator/384434)

<div class="topic-metadata">

**Author:** [@maxxer](https://discuss.elastic.co/u/maxxer)\
**Replies:** 1\
**Last updated:** [January 12, 2026, 8:01am UTC](https://discuss.elastic.co/t/missing-pdf-report-generator/384434 "2026-01-12T08:01:21Z")

</div>

We enabled PDF report generation on our Kibana instance a few months back. We use Google login, and we map Google Workspace groups to Kibana Roles. This has been working fine for the members of this group, but out of a …

---

## [How can I create an alert for one-time events?](https://discuss.elastic.co/t/how-can-i-create-an-alert-for-one-time-events/383781)

<div class="topic-metadata">

**Author:** [@nilsen](https://discuss.elastic.co/u/nilsen)\
**Replies:** 2\
**Last updated:** [January 9, 2026, 8:48am UTC](https://discuss.elastic.co/t/how-can-i-create-an-alert-for-one-time-events/383781 "2026-01-09T08:48:41Z")

</div>

I want to set up an alert that triggers whenever one of my APIs returns a 500 error. This doesn’t really fit into the usual active/recovered/flapping model since it’s more of a single event rather than something that sta…

---

## [Does Elastic APM/RUM allow us to save sessions?](https://discuss.elastic.co/t/does-elastic-apm-rum-allow-us-to-save-sessions/328187)

<div class="topic-metadata">

**Author:** [@bigdamhero](https://discuss.elastic.co/u/bigdamhero)\
**Replies:** 7\
**Last updated:** [January 6, 2026, 3:12pm UTC](https://discuss.elastic.co/t/does-elastic-apm-rum-allow-us-to-save-sessions/328187 "2026-01-06T15:12:34Z")

</div>

I'm trying to spec out APM to replace Dynatrace RUM. Are we able to have session playback?

---

## [APM Errors showing as "N/A" when using Java agent log\_sending=true (errors coming from logs)](https://discuss.elastic.co/t/apm-errors-showing-as-n-a-when-using-java-agent-log-sending-true-errors-coming-from-logs/384232)

<div class="topic-metadata">

**Author:** [@nicolasbalao](https://discuss.elastic.co/u/nicolasbalao)\
**Replies:** 1\
**Last updated:** [January 5, 2026, 12:07pm UTC](https://discuss.elastic.co/t/apm-errors-showing-as-n-a-when-using-java-agent-log-sending-true-errors-coming-from-logs/384232 "2026-01-05T12:07:16Z")

</div>

Versions Kibana version: 9.2.2 Elasticsearch version: 9.2.2 APM Server version: 9.2.2 (via Fleet integration) APM Agent language and version: Java agent 1.55.2 Browser version: Chrome (latest) Installation Original i…

---

## [Spring Boot 4.0 / Spring Framework 7.0 Incompatibility with Elastic APM Java Agent](https://discuss.elastic.co/t/spring-boot-4-0-spring-framework-7-0-incompatibility-with-elastic-apm-java-agent/384087)

<div class="topic-metadata">

**Author:** [@cthurston-clgx](https://discuss.elastic.co/u/cthurston-clgx)\
**Replies:** 4\
**Last updated:** [January 5, 2026, 9:26am UTC](https://discuss.elastic.co/t/spring-boot-4-0-spring-framework-7-0-incompatibility-with-elastic-apm-java-agent/384087 "2026-01-05T09:26:42Z")

</div>

\*\*Kibana version:\*\* N/A (issue occurs during instrumentation) \*\*Elasticsearch version:\*\* N/A (issue occurs during instrumentation) \*\*APM Server version:\*\* N/A (issue occurs during instrumentation) \*\*APM Agent language…

---

## [Any Reason traces-apm@template is using Standard Index mode instead of timeseries or logsdb](https://discuss.elastic.co/t/any-reason-traces-apm-template-is-using-standard-index-mode-instead-of-timeseries-or-logsdb/383301)

<div class="topic-metadata">

**Author:** [@Serak\_Shiferaw](https://discuss.elastic.co/u/Serak_Shiferaw)\
**Replies:** 10\
**Last updated:** [December 22, 2025, 8:51am UTC](https://discuss.elastic.co/t/any-reason-traces-apm-template-is-using-standard-index-mode-instead-of-timeseries-or-logsdb/383301 "2025-12-22T08:51:09Z")

</div>

we are capturing enterprise java traces, and the trace is filling up all the spaces on my cluster, its generating 1.4TB daily and i cant keep up, then upon checking there is no compression on the created index and its ju…

---

## [Issue on Dependency Operations Beta Page](https://discuss.elastic.co/t/issue-on-dependency-operations-beta-page/384202)

<div class="topic-metadata">

**Author:** [@Serak\_Shiferaw](https://discuss.elastic.co/u/Serak_Shiferaw)\
**Replies:** 0\
**Last updated:** [December 19, 2025, 2:46pm UTC](https://discuss.elastic.co/t/issue-on-dependency-operations-beta-page/384202 "2025-12-19T14:46:00Z")

</div>

Observability \> APM \> Dependencies \> db2/FEPRODDB \> Operations i have observed the below things 1st from java monitoring agent or the display its not good with multiline format sql statments , it just shows SELECT 2nd…

---

## [ILM policy for indices from APM server](https://discuss.elastic.co/t/ilm-policy-for-indices-from-apm-server/384133)

<div class="topic-metadata">

**Author:** [@Narek\_Martirosyan](https://discuss.elastic.co/u/Narek_Martirosyan)\
**Replies:** 2\
**Last updated:** [December 19, 2025, 7:48am UTC](https://discuss.elastic.co/t/ilm-policy-for-indices-from-apm-server/384133 "2025-12-19T07:48:45Z")

</div>

Hi, I’m running Elasticsearch 9.0.3 managed by ECK on AKS, and I’m seeing persistent high JVM heap usage on my warm nodes. Cluster topology 3 × master nodes 2 × hot data nodes 2 × warm data nodes Persistent…

---

## [Mulesoft integration with elastic search](https://discuss.elastic.co/t/mulesoft-integration-with-elastic-search/384155)

<div class="topic-metadata">

**Author:** [@nkknkk](https://discuss.elastic.co/u/nkknkk)\
**Replies:** 2\
**Last updated:** [December 18, 2025, 1:18pm UTC](https://discuss.elastic.co/t/mulesoft-integration-with-elastic-search/384155 "2025-12-18T13:18:19Z")

</div>

Can someone please point me to the documentation on how to ingest MuleSoft logs into Elasticsearch? My environment has only Elasticsearch and Kibana installed.

---

## [Help troubleshooting Elastic APM Integration: Installation Error - Input Not Supported](https://discuss.elastic.co/t/help-troubleshooting-elastic-apm-integration-installation-error-input-not-supported/383931)

<div class="topic-metadata">

**Author:** [@nilsen](https://discuss.elastic.co/u/nilsen)\
**Replies:** 8\
**Last updated:** [December 17, 2025, 10:12pm UTC](https://discuss.elastic.co/t/help-troubleshooting-elastic-apm-integration-installation-error-input-not-supported/383931 "2025-12-17T22:12:20Z")

</div>

Kibana version: v 9.1.5 Elasticsearch version: 9.1.5 Elastic APM: 9.1.5 I'm having problems installing the Elastic APM integration on around half of my Fleet Agents. Getting the error: input not supported, have tried …

[Previous page](https://discuss.elastic.co/c/observability/82.md)

[Next page](https://discuss.elastic.co/c/observability/82.md?page=2)
