# Elastic Observability

**URL:** https://discuss.elastic.co/c/observability/82.md?page=24

[Latest](https://discuss.elastic.co/latest.md) · [Categories](https://discuss.elastic.co/categories.md) · [Tags](https://discuss.elastic.co/tags.md)

**Page:** 25

---

## [Please Help me~ APM Exclude Option Sample](https://discuss.elastic.co/t/please-help-me-apm-exclude-option-sample/360059)

<div class="topic-metadata">

**Author:** [@eagles40cnuh](https://discuss.elastic.co/u/eagles40cnuh)\
**Replies:** 2\
**Last updated:** [May 24, 2024, 2:27am UTC](https://discuss.elastic.co/t/please-help-me-apm-exclude-option-sample/360059 "2024-05-24T02:27:30Z")

</div>

Kibana version: 8.13.2 Elasticsearch version: 8.13.2 APM Server version: 8.13.2 APM Agent language and version: elastic\_apm\_profiler\_1.27.1 I am running a .NET CORE web service in IIS. (Version 10) I wonder if m…

---

## [Elastic Synthetics Alerts in the same workspace to different teams](https://discuss.elastic.co/t/elastic-synthetics-alerts-in-the-same-workspace-to-different-teams/359477)

<div class="topic-metadata">

**Author:** [@DougR](https://discuss.elastic.co/u/DougR)\
**Replies:** 4\
**Last updated:** [May 23, 2024, 2:10pm UTC](https://discuss.elastic.co/t/elastic-synthetics-alerts-in-the-same-workspace-to-different-teams/359477 "2024-05-23T14:10:26Z")

</div>

I'm using Elastic Synthetics with Elastic Cloud v8.13.4. I am in the process of setting up in tests for some applications where alerts for tests which need to be in the same workspace need to be routed to different teams…

---

## [Custom Alert Rules for Sythetics](https://discuss.elastic.co/t/custom-alert-rules-for-sythetics/359728)

<div class="topic-metadata">

**Author:** [@RichiCoder](https://discuss.elastic.co/u/RichiCoder)\
**Replies:** 4\
**Last updated:** [May 23, 2024, 2:08pm UTC](https://discuss.elastic.co/t/custom-alert-rules-for-sythetics/359728 "2024-05-23T14:08:41Z")

</div>

We've been using the new Synthetics capability in Elastic Observability to much success, however we've run into a distinct issue that it's not clear how to send specific synthetic alerts to specific channels. For Uptime…

---

## [Synthetic Monitoring : Multi-Level Monitoring](https://discuss.elastic.co/t/synthetic-monitoring-multi-level-monitoring/359684)

<div class="topic-metadata">

**Author:** [@aisyaharifin](https://discuss.elastic.co/u/aisyaharifin)\
**Replies:** 1\
**Last updated:** [May 23, 2024, 1:57pm UTC](https://discuss.elastic.co/t/synthetic-monitoring-multi-level-monitoring/359684 "2024-05-23T13:57:32Z")

</div>

Hello Elastic, I have a use case where I am monitoring specific application. For example, the application have a technology stack on it which is Azure AD Login. The one that is failing is the AAD Login and the website…

---

## [Analyzing log files in a static directory](https://discuss.elastic.co/t/analyzing-log-files-in-a-static-directory/360071)

<div class="topic-metadata">

**Author:** [@Muhammad\_Adil\_Talay](https://discuss.elastic.co/u/Muhammad_Adil_Talay)\
**Replies:** 1\
**Last updated:** [May 23, 2024, 11:42am UTC](https://discuss.elastic.co/t/analyzing-log-files-in-a-static-directory/360071 "2024-05-23T11:42:50Z")

</div>

Introduction Hi, I'm a newbie to Elastic stack, training in the area of Observability. Background I have log files of an application saved in a folder or directory of my computer, not connected to the app. Goal I wo…

---

## [Java APM agent for java 6](https://discuss.elastic.co/t/java-apm-agent-for-java-6/360015)

<div class="topic-metadata">

**Author:** [@heba](https://discuss.elastic.co/u/heba)\
**Replies:** 1\
**Last updated:** [May 22, 2024, 6:15pm UTC](https://discuss.elastic.co/t/java-apm-agent-for-java-6/360015 "2024-05-22T18:15:19Z")

</div>

I am using latest ELK version 8.13 and I want to use elastic apm java agent to monitor Java application using jdk 6 as this app can't upgraded Which agent version can be used or event refactored to be able to work

---

## [Adjust internal queue size](https://discuss.elastic.co/t/adjust-internal-queue-size/359833)

<div class="topic-metadata">

**Author:** [@iamp3](https://discuss.elastic.co/u/iamp3)\
**Replies:** 4\
**Last updated:** [May 22, 2024, 12:37pm UTC](https://discuss.elastic.co/t/adjust-internal-queue-size/359833 "2024-05-22T12:37:37Z")

</div>

We faced an issue with queue full. How I could configure queue.mem.events on Elasti Cloud Deployment setup?

---

## [Alerting based on Geographic region](https://discuss.elastic.co/t/alerting-based-on-geographic-region/359879)

<div class="topic-metadata">

**Author:** [@Arpan\_Mondal](https://discuss.elastic.co/u/Arpan_Mondal)\
**Replies:** 3\
**Last updated:** [May 22, 2024, 9:30am UTC](https://discuss.elastic.co/t/alerting-based-on-geographic-region/359879 "2024-05-22T09:30:20Z")

</div>

Hi Team, Can you please help out if its possible to group alerts for a service based on the Geographic region. As we are getting metrics based on Geographic regions, due to business use cases we would like to set alerts…

---

## [Fleet UI Custom Dashboard](https://discuss.elastic.co/t/fleet-ui-custom-dashboard/357245)

<div class="topic-metadata">

**Author:** [@erikg](https://discuss.elastic.co/u/erikg)\
**Replies:** 3\
**Last updated:** [May 21, 2024, 1:05pm UTC](https://discuss.elastic.co/t/fleet-ui-custom-dashboard/357245 "2024-05-21T13:05:46Z")

</div>

Hello, Is there a way to create a custom dashboard to monitor hosts that have Elastic Agents and their status? I know this is already part of Fleet UI, but the UI isn't the best to use. I can't really find much value …

---

## [App agent blocking application startup with activation leak error](https://discuss.elastic.co/t/app-agent-blocking-application-startup-with-activation-leak-error/359708)

<div class="topic-metadata">

**Author:** [@tarund](https://discuss.elastic.co/u/tarund)\
**Replies:** 3\
**Last updated:** [May 21, 2024, 8:47am UTC](https://discuss.elastic.co/t/app-agent-blocking-application-startup-with-activation-leak-error/359708 "2024-05-21T08:47:06Z")

</div>

Elasticsearch version: 7.17.1 APM Server version: 7.15.0 APM Agent language and version: Java / 1.47.1 Description of the problem including expected versus actual behavior. Please include screenshots (if relevant): A…

---

## [Visualise rabbimq queue name on service map](https://discuss.elastic.co/t/visualise-rabbimq-queue-name-on-service-map/359795)

<div class="topic-metadata">

**Author:** [@paulmander](https://discuss.elastic.co/u/paulmander)\
**Replies:** 0\
**Last updated:** [May 20, 2024, 7:59am UTC](https://discuss.elastic.co/t/visualise-rabbimq-queue-name-on-service-map/359795 "2024-05-20T07:59:31Z")

</div>

Using otel java agent to instrument spring boot microservices and I see that in the service map rabbitmq is seen as a single consumer/producer regardless of the exchange or queue being used. Is there a way to have indivi…

---

## [Elastic APM PHP Tracer. Sending events to APM Server failed. Exiting...; resultCode: resultFailure (6);](https://discuss.elastic.co/t/elastic-apm-php-tracer-sending-events-to-apm-server-failed-exiting-resultcode-resultfailure-6/359685)

<div class="topic-metadata">

**Author:** [@Julian\_Fazri](https://discuss.elastic.co/u/Julian_Fazri)\
**Replies:** 5\
**Last updated:** [May 20, 2024, 7:38am UTC](https://discuss.elastic.co/t/elastic-apm-php-tracer-sending-events-to-apm-server-failed-exiting-resultcode-resultfailure-6/359685 "2024-05-20T07:38:13Z")

</div>

Hi All, got error when I install APM agent for PHP. I have follow the documentation from APM PHP Agent Reference \[1.x\] | Elastic But I still got no clues what is the problem. Kibana version: 8.12 Elasticsearch version:…

---

## [Can host.name in Entra ID Entity Analytics be lowercased and domain appended?](https://discuss.elastic.co/t/can-host-name-in-entra-id-entity-analytics-be-lowercased-and-domain-appended/358437)

<div class="topic-metadata">

**Author:** [@willemdh](https://discuss.elastic.co/u/willemdh)\
**Replies:** 1\
**Last updated:** [May 18, 2024, 7:51pm UTC](https://discuss.elastic.co/t/can-host-name-in-entra-id-entity-analytics-be-lowercased-and-domain-appended/358437 "2024-05-18T19:51:23Z")

</div>

Hello, I've activated Entra ID Entity Analytics integration. Very nice data sets, but I'm having the same issues I've been having for year in different datasets (of which most of them have been solved or mitigated). The…

---

## [Isolation of specific Synthetics monitors](https://discuss.elastic.co/t/isolation-of-specific-synthetics-monitors/359257)

<div class="topic-metadata">

**Author:** [@s.buksa](https://discuss.elastic.co/u/s.buksa)\
**Replies:** 1\
**Last updated:** [May 17, 2024, 10:32am UTC](https://discuss.elastic.co/t/isolation-of-specific-synthetics-monitors/359257 "2024-05-17T10:32:28Z")

</div>

Hi, Is it possible to hide specific Synthetics Monitors from appearing? For example, I have one Kibana Namspace where two HTTP type monitors-1 and HTTP type monitor-2 are available. At the same time I have User-1 and U…

---

## [How to remove no-data alert for removed host?](https://discuss.elastic.co/t/how-to-remove-no-data-alert-for-removed-host/359642)

<div class="topic-metadata">

**Author:** [@herrdommel](https://discuss.elastic.co/u/herrdommel)\
**Replies:** 4\
**Last updated:** [May 17, 2024, 9:07am UTC](https://discuss.elastic.co/t/how-to-remove-no-data-alert-for-removed-host/359642 "2024-05-17T09:07:12Z")

</div>

Hi all, I have a metric threshold alert rule configured in Kibana that alerts me on high disk usage. This is grouped by host name. One host was removed and a no data alert was created. How can I get rid of this alert? I…

---

## [Span duration of an HTTP GET calculated wrongly?](https://discuss.elastic.co/t/span-duration-of-an-http-get-calculated-wrongly/359629)

<div class="topic-metadata">

**Author:** [@IngoStrauch2020](https://discuss.elastic.co/u/IngoStrauch2020)\
**Replies:** 2\
**Last updated:** [May 17, 2024, 7:28am UTC](https://discuss.elastic.co/t/span-duration-of-an-http-get-calculated-wrongly/359629 "2024-05-17T07:28:52Z")

</div>

APM Server version: 8.9.1 APM Agent language and version: Java 1.49.0 Description of the problem including expected versus actual behavior. Please include screenshots (if relevant): While debugging a long running tran…

---

## [No such index \[observability-annotations\]](https://discuss.elastic.co/t/no-such-index-observability-annotations/359660)

<div class="topic-metadata">

**Author:** [@erikg](https://discuss.elastic.co/u/erikg)\
**Replies:** 0\
**Last updated:** [May 16, 2024, 6:44pm UTC](https://discuss.elastic.co/t/no-such-index-observability-annotations/359660 "2024-05-16T18:44:32Z")

</div>

I am getting errors from Kibana service in APM. APM/Elastic/Kibana Verision: 8.13.4

---

## [APM to monitor Elastic itself](https://discuss.elastic.co/t/apm-to-monitor-elastic-itself/358770)

<div class="topic-metadata">

**Author:** [@erikg](https://discuss.elastic.co/u/erikg)\
**Replies:** 1\
**Last updated:** [May 16, 2024, 5:18pm UTC](https://discuss.elastic.co/t/apm-to-monitor-elastic-itself/358770 "2024-05-16T17:18:04Z")

</div>

Hello, I don't have an issue but I am wondering if its possible to monitor Elastic using APM? I feel like this might be possible but not sure if it would be monitoring Elasticsearch or Kibana and if so what APM agents a…

---

## [Attaching apm-agent-attach-cli.jar to a running process that already has javaagents](https://discuss.elastic.co/t/attaching-apm-agent-attach-cli-jar-to-a-running-process-that-already-has-javaagents/321595)

<div class="topic-metadata">

**Author:** [@Yuri\_Bernstein](https://discuss.elastic.co/u/Yuri_Bernstein)\
**Replies:** 1\
**Last updated:** [May 16, 2024, 1:41pm UTC](https://discuss.elastic.co/t/attaching-apm-agent-attach-cli-jar-to-a-running-process-that-already-has-javaagents/321595 "2024-05-16T13:41:37Z")

</div>

Hi, I am trying to attach an agent to a running process that has another agent attached at startup time using -javaagent option. The agent throws the following: {"@timestamp":"2022-12-19T19:50:48.574Z","log.level": "IN…

---

## [Inventory Rule - Disk Usage](https://discuss.elastic.co/t/inventory-rule-disk-usage/359195)

<div class="topic-metadata">

**Author:** [@erikg](https://discuss.elastic.co/u/erikg)\
**Replies:** 2\
**Last updated:** [May 16, 2024, 1:21pm UTC](https://discuss.elastic.co/t/inventory-rule-disk-usage/359195 "2024-05-16T13:21:42Z")

</div>

Hello, how do you monitor disk usage when there are different mount points per device? Using the inventory rule, I can do the average of disk usage but it seems to calculate the average of all the mount points. Is there…

---

## [Any github repo to start Spring Boot and OTEL using els](https://discuss.elastic.co/t/any-github-repo-to-start-spring-boot-and-otel-using-els/359535)

<div class="topic-metadata">

**Author:** [@nagkumar](https://discuss.elastic.co/u/nagkumar)\
**Replies:** 1\
**Last updated:** [May 15, 2024, 8:41pm UTC](https://discuss.elastic.co/t/any-github-repo-to-start-spring-boot-and-otel-using-els/359535 "2024-05-15T20:41:07Z")

</div>

Are there any github repo that is latest and works well to showcase spring-boot application Observability for Metrics, Traces and Logs using Docker running ELS components.. Google for 2 days is not helping here..

---

## [How to config prometheus integration to scrape metrics from k8s pod](https://discuss.elastic.co/t/how-to-config-prometheus-integration-to-scrape-metrics-from-k8s-pod/359468)

<div class="topic-metadata">

**Author:** [@Terran\_Yiu](https://discuss.elastic.co/u/Terran_Yiu)\
**Replies:** 4\
**Last updated:** [May 15, 2024, 2:43pm UTC](https://discuss.elastic.co/t/how-to-config-prometheus-integration-to-scrape-metrics-from-k8s-pod/359468 "2024-05-15T14:43:31Z")

</div>

I'm using fleet-managed elastic agents installed in k8s. I want to scrape pod metrics by HTTP API. My current config is in the following picture: But it does not work, any suggestions?

---

## [Elastic APM Java for async Spring events](https://discuss.elastic.co/t/elastic-apm-java-for-async-spring-events/359528)

<div class="topic-metadata">

**Author:** [@Wolfram\_Haussig](https://discuss.elastic.co/u/Wolfram_Haussig)\
**Replies:** 2\
**Last updated:** [May 15, 2024, 12:22pm UTC](https://discuss.elastic.co/t/elastic-apm-java-for-async-spring-events/359528 "2024-05-15T12:22:27Z")

</div>

Hi all, I hope someone can point me in the right direction here. I am using Spring Boot 3 in combination with Spring Modulith in my application. I get APM data in Kibana, so the configuration is fine. But, when I use an…

---

## [Unable to generate log file for Elastic Java agent](https://discuss.elastic.co/t/unable-to-generate-log-file-for-elastic-java-agent/359428)

<div class="topic-metadata">

**Author:** [@Namita\_Jaokar](https://discuss.elastic.co/u/Namita_Jaokar)\
**Replies:** 5\
**Last updated:** [May 15, 2024, 10:35am UTC](https://discuss.elastic.co/t/unable-to-generate-log-file-for-elastic-java-agent/359428 "2024-05-15T10:35:44Z")

</div>

Hi, I am using elastic java agent 1.49 for tracing a containerized application with docker. I have some spans being dropped out and to debug the same, Enabled the logs to trace mode for the agent. However , I am unabl…

---

## [Circular loading of installed providers detected for: Spring Boot \>= 3.2.2](https://discuss.elastic.co/t/circular-loading-of-installed-providers-detected-for-spring-boot-3-2-2/359445)

<div class="topic-metadata">

**Author:** [@raissi-oa](https://discuss.elastic.co/u/raissi-oa)\
**Replies:** 0\
**Last updated:** [May 14, 2024, 9:12am UTC](https://discuss.elastic.co/t/circular-loading-of-installed-providers-detected-for-spring-boot-3-2-2/359445 "2024-05-14T09:12:42Z")

</div>

Kibana version: Elasticsearch version: APM Server version: APM Agent language and version: Java agent: 1.48.1 & 1.49.0 Browser version: Original install method (e.g. download page, yum, deb, from source, etc.) and …

---

## [\[Q\] How do I run the same test on multiple endpoints in multiple environments](https://discuss.elastic.co/t/q-how-do-i-run-the-same-test-on-multiple-endpoints-in-multiple-environments/359422)

<div class="topic-metadata">

**Author:** [@cjessing](https://discuss.elastic.co/u/cjessing)\
**Replies:** 1\
**Last updated:** [May 14, 2024, 6:29am UTC](https://discuss.elastic.co/t/q-how-do-i-run-the-same-test-on-multiple-endpoints-in-multiple-environments/359422 "2024-05-14T06:29:53Z")

</div>

Sorry if this is a n00b question but I'm quite new to both Playwright and Synthetics. I'm writing this test that'll create a case (url #1), send it to a recipient that'll perform additional steps (url #2) and return the…

---

## [Flask Integration issues with Self Signed Certificate via Fleet](https://discuss.elastic.co/t/flask-integration-issues-with-self-signed-certificate-via-fleet/359342)

<div class="topic-metadata">

**Author:** [@Yogesh\_AS](https://discuss.elastic.co/u/Yogesh_AS)\
**Replies:** 2\
**Last updated:** [May 14, 2024, 5:34am UTC](https://discuss.elastic.co/t/flask-integration-issues-with-self-signed-certificate-via-fleet/359342 "2024-05-14T05:34:14Z")

</div>

Hi Team , Advance thanks for helping me out andI am trying to monitor the flask application metrices I am getting an error like given below Failed to submit message: "Unable to reach APM Server: HTTPSConnectionPool(ho…

---

## [APM Server Error Error](https://discuss.elastic.co/t/apm-server-error-error/359421)

<div class="topic-metadata">

**Author:** [@Chandu.Tatapudi](https://discuss.elastic.co/u/Chandu.Tatapudi)\
**Replies:** 0\
**Last updated:** [May 14, 2024, 4:18am UTC](https://discuss.elastic.co/t/apm-server-error-error/359421 "2024-05-14T04:18:37Z")

</div>

If you are asking about a problem you are experiencing, please use the following template, as it will help us help you. If you have a different problem, please delete all of this text :slight\_smile: TIP 1: select at lea…

---

## [Setting APM trace lifecycle policy per type (transaction v span) using custom policy](https://discuss.elastic.co/t/setting-apm-trace-lifecycle-policy-per-type-transaction-v-span-using-custom-policy/358992)

<div class="topic-metadata">

**Author:** [@cozog](https://discuss.elastic.co/u/cozog)\
**Replies:** 4\
**Last updated:** [May 14, 2024, 2:54am UTC](https://discuss.elastic.co/t/setting-apm-trace-lifecycle-policy-per-type-transaction-v-span-using-custom-policy/358992 "2024-05-14T02:54:27Z")

</div>

When using the legacy APM server approach for managing the lifecycle of APM traces one is able to set a separate policy for both spans and transactions via event type mapping; However, for the new recommended approach …

---

## [Is there an option to set a different name (alias) other than the one on service\_name](https://discuss.elastic.co/t/is-there-an-option-to-set-a-different-name-alias-other-than-the-one-on-service-name/359213)

<div class="topic-metadata">

**Author:** [@minilik](https://discuss.elastic.co/u/minilik)\
**Replies:** 1\
**Last updated:** [May 10, 2024, 12:58pm UTC](https://discuss.elastic.co/t/is-there-an-option-to-set-a-different-name-alias-other-than-the-one-on-service-name/359213 "2024-05-10T12:58:05Z")

</div>

Greetings! I'm trying to create some APM services from my java based servlets but I don't want to show the actual names on Kibana portal. Is there a way to create an alias for the Kibana portal different form the name s…

[Previous page](https://discuss.elastic.co/c/observability/82.md?page=23)

[Next page](https://discuss.elastic.co/c/observability/82.md?page=25)
