# Elastic Observability

**URL:** https://discuss.elastic.co/c/observability/82.md?page=29

[Latest](https://discuss.elastic.co/latest.md) · [Categories](https://discuss.elastic.co/categories.md) · [Tags](https://discuss.elastic.co/tags.md)

**Page:** 30

---

## [APM version 1.26.0 - "the selected trace cannot be found "](https://discuss.elastic.co/t/apm-version-1-26-0-the-selected-trace-cannot-be-found/354111)

<div class="topic-metadata">

**Author:** [@Premysl\_Capek](https://discuss.elastic.co/u/Premysl_Capek)\
**Replies:** 1\
**Last updated:** [February 26, 2024, 10:29am UTC](https://discuss.elastic.co/t/apm-version-1-26-0-the-selected-trace-cannot-be-found/354111 "2024-02-26T10:29:22Z")

</div>

If I use Elastic.Apm.NetCoreAll version 1.26.0 I see this message instead of transactions: Works with version 1.25.3 Server version is 8.12.1 for all components.

---

## [Choosing ECK for Openshift Cluster](https://discuss.elastic.co/t/choosing-eck-for-openshift-cluster/354074)

<div class="topic-metadata">

**Author:** [@rhowin](https://discuss.elastic.co/u/rhowin)\
**Replies:** 0\
**Last updated:** [February 26, 2024, 3:25am UTC](https://discuss.elastic.co/t/choosing-eck-for-openshift-cluster/354074 "2024-02-26T03:25:09Z")

</div>

Hello Team, Need your advice to have a better monitoring method unlike we have it for our current OpenShift cluster, which is running on the version 4.12.40. We are looking out for features which also includes the appli…

---

## [C# - Auto instrumentation of Confluent Kafka](https://discuss.elastic.co/t/c-auto-instrumentation-of-confluent-kafka/353979)

<div class="topic-metadata">

**Author:** [@Premysl\_Capek](https://discuss.elastic.co/u/Premysl_Capek)\
**Replies:** 2\
**Last updated:** [February 23, 2024, 12:00pm UTC](https://discuss.elastic.co/t/c-auto-instrumentation-of-confluent-kafka/353979 "2024-02-23T12:00:29Z")

</div>

Hello, is possible enable auto instrumentation of Confluent Kafka for versions 2.x. Actual version is 2.3.0.

---

## [APM- server not connecting to the elasticsearch which is running on the same server](https://discuss.elastic.co/t/apm-server-not-connecting-to-the-elasticsearch-which-is-running-on-the-same-server/353971)

<div class="topic-metadata">

**Author:** [@vijjay](https://discuss.elastic.co/u/vijjay)\
**Replies:** 0\
**Last updated:** [February 23, 2024, 10:15am UTC](https://discuss.elastic.co/t/apm-server-not-connecting-to-the-elasticsearch-which-is-running-on-the-same-server/353971 "2024-02-23T10:15:23Z")

</div>

\*\*Kibana version\*\*: 8.12.2 \*\*Elasticsearch version\*\*: 8.12.2 \*\*APM Server version\*\*:8.12.2 \*\*APM Agent language and version\*\*: \*\*Browser version\*\*: \*\*Original install method - download page \*\*Description of the problem i…

---

## [C# Integration Testing with WebApplicationFactory fail due to missing CurrentTransaction](https://discuss.elastic.co/t/c-integration-testing-with-webapplicationfactory-fail-due-to-missing-currenttransaction/353951)

<div class="topic-metadata">

**Author:** [@PeterLech](https://discuss.elastic.co/u/PeterLech)\
**Replies:** 0\
**Last updated:** [February 23, 2024, 7:13am UTC](https://discuss.elastic.co/t/c-integration-testing-with-webapplicationfactory-fail-due-to-missing-currenttransaction/353951 "2024-02-23T07:13:05Z")

</div>

Hi @ all, did somebody faced issues in dotnet Integration Testing that the Agent.Tracer.CurrentTransaction was null for the second test? I'm using dotnet 8 and the Elastic.Apm.NetCoreAll Version=1.26.0 nuget package. …

---

## [Indexing Application Trace Data into Separate Indices Based on Application Names](https://discuss.elastic.co/t/indexing-application-trace-data-into-separate-indices-based-on-application-names/353437)

<div class="topic-metadata">

**Author:** [@Sayyad\_Seyidli](https://discuss.elastic.co/u/Sayyad_Seyidli)\
**Replies:** 1\
**Last updated:** [February 22, 2024, 4:11pm UTC](https://discuss.elastic.co/t/indexing-application-trace-data-into-separate-indices-based-on-application-names/353437 "2024-02-22T16:11:26Z")

</div>

I'm currently working with an Elasticsearch cluster to store and manage trace and metric data from various applications running in a Kubernetes environment. We use OpenTelemetry for instrumentation, collecting metrics an…

---

## [Unable to get transaction on APM server](https://discuss.elastic.co/t/unable-to-get-transaction-on-apm-server/353775)

<div class="topic-metadata">

**Author:** [@Zain\_Ul\_Abideen](https://discuss.elastic.co/u/Zain_Ul_Abideen)\
**Replies:** 2\
**Last updated:** [February 22, 2024, 1:19pm UTC](https://discuss.elastic.co/t/unable-to-get-transaction-on-apm-server/353775 "2024-02-22T13:19:07Z")

</div>

I am using running service on local on docker container, Also my APM is running on docker. Locally it is working fine and population transactions entry for every API in the service but when I am deploying my service on t…

---

## [How can I delete a Kibana dashboard through API?](https://discuss.elastic.co/t/how-can-i-delete-a-kibana-dashboard-through-api/353867)

<div class="topic-metadata">

**Author:** [@Lide\_Ding](https://discuss.elastic.co/u/Lide_Ding)\
**Replies:** 2\
**Last updated:** [February 22, 2024, 10:34am UTC](https://discuss.elastic.co/t/how-can-i-delete-a-kibana-dashboard-through-api/353867 "2024-02-22T10:34:03Z")

</div>

I found that APIs to delete Kibana dashboard have been deprecated, is there an API can delete dashboard?

---

## [Failed to deserialize APM server response and HTTP 502](https://discuss.elastic.co/t/failed-to-deserialize-apm-server-response-and-http-502/353776)

<div class="topic-metadata">

**Author:** [@andysjoholm](https://discuss.elastic.co/u/andysjoholm)\
**Replies:** 0\
**Last updated:** [February 21, 2024, 10:27am UTC](https://discuss.elastic.co/t/failed-to-deserialize-apm-server-response-and-http-502/353776 "2024-02-21T10:27:45Z")

</div>

I have a Java APM Agent running in my Openshift container application. My application/apm agent prints the following exception when trying to send metrics to APM Server. What is going on and where/what to fix? tjavax.ne…

---

## [Java APM agent does override default method, causing no-op tracing](https://discuss.elastic.co/t/java-apm-agent-does-override-default-method-causing-no-op-tracing/352637)

<div class="topic-metadata">

**Author:** [@bebeDobreRano](https://discuss.elastic.co/u/bebeDobreRano)\
**Replies:** 5\
**Last updated:** [February 20, 2024, 2:38pm UTC](https://discuss.elastic.co/t/java-apm-agent-does-override-default-method-causing-no-op-tracing/352637 "2024-02-20T14:38:09Z")

</div>

Elasticsearch Java client version 8.11.1 Kibana version: 8.9.1 APM Elasticsearch version: 8.9.1 APM Server version: 8.9.1 APM Agent language and version: Java, 1.46.0 Hello, I originally wanted to create githu…

---

## [APM latency statistics not showing any data](https://discuss.elastic.co/t/apm-latency-statistics-not-showing-any-data/353517)

<div class="topic-metadata">

**Author:** [@bassem\_abdalftah](https://discuss.elastic.co/u/bassem_abdalftah)\
**Replies:** 0\
**Last updated:** [February 18, 2024, 12:34pm UTC](https://discuss.elastic.co/t/apm-latency-statistics-not-showing-any-data/353517 "2024-02-18T12:34:02Z")

</div>

Kibana version: 8.3.3 Elasticsearch version:8.3.3 APM Server version:8.3.3 APM Agent language and version: java Fresh install or upgraded from other version? Fresh install APM latency statistics showing no data, how…

---

## [Log\_ecs\_reformatting not reformatting](https://discuss.elastic.co/t/log-ecs-reformatting-not-reformatting/353119)

<div class="topic-metadata">

**Author:** [@Dileesha](https://discuss.elastic.co/u/Dileesha)\
**Replies:** 1\
**Last updated:** [February 20, 2024, 11:41am UTC](https://discuss.elastic.co/t/log-ecs-reformatting-not-reformatting/353119 "2024-02-20T11:41:41Z")

</div>

Kibana version:8.11.1 Elasticsearch version:8.11.1 APM Server version:8.11.1 APM Agent language and version:Java - 1.34.0 I'm trying to monitor my Spring Boot logs with Elasticsearch, and currently, the logs are succ…

---

## [Kibana Observability Infrastructure Inventory Docker Containers have error (400): Error while fetching resource](https://discuss.elastic.co/t/kibana-observability-infrastructure-inventory-docker-containers-have-error-400-error-while-fetching-resource/353652)

<div class="topic-metadata">

**Author:** [@wruiwr](https://discuss.elastic.co/u/wruiwr)\
**Replies:** 0\
**Last updated:** [February 20, 2024, 7:41am UTC](https://discuss.elastic.co/t/kibana-observability-infrastructure-inventory-docker-containers-have-error-400-error-while-fetching-resource/353652 "2024-02-20T07:41:21Z")

</div>

After upgrading Elastic Stack from 8.11.4 to 8.12.0, there is an error when seeing the Docker Containers in the Inventory of Observability Infrastructure of Kibana: See the screenshot: I'm unsure if it is a bug or s…

---

## [Kibana APM metrics view din't show Opentelemetry JVM metrics](https://discuss.elastic.co/t/kibana-apm-metrics-view-dint-show-opentelemetry-jvm-metrics/353524)

<div class="topic-metadata">

**Author:** [@XuQing\_Tan](https://discuss.elastic.co/u/XuQing_Tan)\
**Replies:** 10\
**Last updated:** [February 19, 2024, 2:49pm UTC](https://discuss.elastic.co/t/kibana-apm-metrics-view-dint-show-opentelemetry-jvm-metrics/353524 "2024-02-19T14:49:29Z")

</div>

Versions: ES v8.11.2 opentelemtry agent 2.1.0 jre 17.0.10 I'm setting up the APM dashboard of Keycloak which uses Quarkus, so per the thread Does Elastic APM support Quarkus? - #2 by cyrilleleclerc I used opentelemetr…

---

## [The otelp exception.message will be used for the ecs message instead of the body field](https://discuss.elastic.co/t/the-otelp-exception-message-will-be-used-for-the-ecs-message-instead-of-the-body-field/353555)

<div class="topic-metadata">

**Author:** [@HHobeck](https://discuss.elastic.co/u/HHobeck)\
**Replies:** 1\
**Last updated:** [February 19, 2024, 11:28am UTC](https://discuss.elastic.co/t/the-otelp-exception-message-will-be-used-for-the-ecs-message-instead-of-the-body-field/353555 "2024-02-19T11:28:09Z")

</div>

Kibana version: 8.10.2 Elasticsearch version: 8.10.2 APM Server version: 8.10.2 APM Agent language and version: No idea where I can find this. Original install method (e.g. download page, yum, deb, from source, e…

---

## [How do I add my registered domain in Uptime Monitoring using heartbeat?](https://discuss.elastic.co/t/how-do-i-add-my-registered-domain-in-uptime-monitoring-using-heartbeat/353421)

<div class="topic-metadata">

**Author:** [@Cruz](https://discuss.elastic.co/u/Cruz)\
**Replies:** 0\
**Last updated:** [February 16, 2024, 12:45am UTC](https://discuss.elastic.co/t/how-do-i-add-my-registered-domain-in-uptime-monitoring-using-heartbeat/353421 "2024-02-16T00:45:35Z")

</div>

Hello everyone, is it possible to add my registered domain names in a heartbeat? what I want to happen is that I can monitor my domain to see when it expires

---

## [ResposeError: illegal\_argument\_exception when create SLO](https://discuss.elastic.co/t/resposeerror-illegal-argument-exception-when-create-slo/353135)

<div class="topic-metadata">

**Author:** [@01052346103a](https://discuss.elastic.co/u/01052346103a)\
**Replies:** 2\
**Last updated:** [February 15, 2024, 10:16am UTC](https://discuss.elastic.co/t/resposeerror-illegal-argument-exception-when-create-slo/353135 "2024-02-15T10:16:01Z")

</div>

Hi i got error when i create SLO with Kibana UI I have no idea what to do solve this problem ES v8.11.4 Kibana v8.11.4 \[2024-02-13T16:08:55.366+09:00\]\[ERROR\]\[plugins.observability\] Cannot preview SLO transform \[slo-b…

---

## [Couldn't connect to server](https://discuss.elastic.co/t/couldnt-connect-to-server/353058)

<div class="topic-metadata">

**Author:** [@Jean-Claude](https://discuss.elastic.co/u/Jean-Claude)\
**Replies:** 4\
**Last updated:** [February 14, 2024, 3:07pm UTC](https://discuss.elastic.co/t/couldnt-connect-to-server/353058 "2024-02-14T15:07:42Z")

</div>

Hello Kibana version: 8.12 Elasticsearch version: 8.12 APM Server version: 8.12 APM Agent language and version: php v1.13.0 Browser version: firefox 122.0.1 (64 bits) Original install method (e.g. download page, y…

---

## [Apm agent can't read the configuration from appsettings.Release.json](https://discuss.elastic.co/t/apm-agent-cant-read-the-configuration-from-appsettings-release-json/353174)

<div class="topic-metadata">

**Author:** [@bassem\_abdalftah](https://discuss.elastic.co/u/bassem_abdalftah)\
**Replies:** 2\
**Last updated:** [February 14, 2024, 11:25am UTC](https://discuss.elastic.co/t/apm-agent-cant-read-the-configuration-from-appsettings-release-json/353174 "2024-02-14T11:25:50Z")

</div>

Kibana version: 8.3.3 Elasticsearch version:8.3.3 APM Server version:8.3.3 APM Agent language and version:dotnet core 1.25.3 Fresh install or upgraded from other version? Fresh install The APM dotnet core agent does…

---

## [Logstash upgrade issue](https://discuss.elastic.co/t/logstash-upgrade-issue/353154)

<div class="topic-metadata">

**Author:** [@mansoorpn](https://discuss.elastic.co/u/mansoorpn)\
**Replies:** 6\
**Last updated:** [February 14, 2024, 8:33am UTC](https://discuss.elastic.co/t/logstash-upgrade-issue/353154 "2024-02-14T08:33:00Z")

</div>

Hello Team, We have an IOT device and the logs generated from this device are received by a logstash instance as input and sent the same logs to the cloudamqp queue as output. Working condition -- \> Logstash version 6.…

---

## [Trouble configuring APM Server on K8 with ECK](https://discuss.elastic.co/t/trouble-configuring-apm-server-on-k8-with-eck/352965)

<div class="topic-metadata">

**Author:** [@anavarro10](https://discuss.elastic.co/u/anavarro10)\
**Replies:** 0\
**Last updated:** [February 9, 2024, 6:16pm UTC](https://discuss.elastic.co/t/trouble-configuring-apm-server-on-k8-with-eck/352965 "2024-02-09T18:16:07Z")

</div>

Kibana version: 8.11.1 Elasticsearch version: 8.11.1 APM Server version: 8.11.1 APM Agent language and version: Python Browser version: Version 121.0.6167.140 (Official Build) (64-bit) Original install method (…

---

## [Ansible Tower Integration (AWX) with APM ](https://discuss.elastic.co/t/ansible-tower-integration-awx-with-apm/352890)

<div class="topic-metadata">

**Author:** [@danyseve](https://discuss.elastic.co/u/danyseve)\
**Replies:** 1\
**Last updated:** [February 12, 2024, 10:10am UTC](https://discuss.elastic.co/t/ansible-tower-integration-awx-with-apm/352890 "2024-02-12T10:10:27Z")

</div>

Good afternoon. I wanted to know if anyone has been able to implement AWX ansible monitoring using elasticsearch APM. I am currently running Elastic 8.12 with APM-server, on the other hand AWX 23.5.1 needs to be monito…

---

## [Permission denied when reading /proc/$pid/io](https://discuss.elastic.co/t/permission-denied-when-reading-proc-pid-io/353026)

<div class="topic-metadata">

**Author:** [@i.raisr](https://discuss.elastic.co/u/i.raisr)\
**Replies:** 0\
**Last updated:** [February 11, 2024, 6:49pm UTC](https://discuss.elastic.co/t/permission-denied-when-reading-proc-pid-io/353026 "2024-02-11T18:49:25Z")

</div>

Dear all, Please could you comment what is the reason behind specifying required capabilities NET\_ADMIN and SETUID in the following document which describes how to setup a private location for synthetics monitoring: M…

---

## [Why Opentelemetry spans with same trace ids could have different transaction ids?](https://discuss.elastic.co/t/why-opentelemetry-spans-with-same-trace-ids-could-have-different-transaction-ids/352916)

<div class="topic-metadata">

**Author:** [@toporovvv](https://discuss.elastic.co/u/toporovvv)\
**Replies:** 0\
**Last updated:** [February 9, 2024, 9:38am UTC](https://discuss.elastic.co/t/why-opentelemetry-spans-with-same-trace-ids-could-have-different-transaction-ids/352916 "2024-02-09T09:38:04Z")

</div>

I see a strange behavior for Opentelemetry integration. We have applications in PHP and Go which are linked with GRPC. I've made a manual Opentelemetry integration for PHP (with GRPC transport). However there is a strang…

---

## [Change mapping from text to match\_only\_text](https://discuss.elastic.co/t/change-mapping-from-text-to-match-only-text/352857)

<div class="topic-metadata">

**Author:** [@Vijayakumar\_Kannan](https://discuss.elastic.co/u/Vijayakumar_Kannan)\
**Replies:** 1\
**Last updated:** [February 9, 2024, 8:25am UTC](https://discuss.elastic.co/t/change-mapping-from-text-to-match-only-text/352857 "2024-02-09T08:25:25Z")

</div>

Existing indices having field app.message in text field type. now it has to be changed from "text" to "match\_only\_text" for new records. Will it impact any of the searches?

---

## [Table Dashboard color code](https://discuss.elastic.co/t/table-dashboard-color-code/352892)

<div class="topic-metadata">

**Author:** [@erlaarun](https://discuss.elastic.co/u/erlaarun)\
**Replies:** 0\
**Last updated:** [February 8, 2024, 8:47pm UTC](https://discuss.elastic.co/t/table-dashboard-color-code/352892 "2024-02-08T20:47:27Z")

</div>

Hi, I have created the Tabular Dashboard on elastic. Table data having fields called certificate name , valid from date ,valid To Date. we want to change the color code of Valid To Date ,if the certificate expiring wit…

---

## [Error executing alerts](https://discuss.elastic.co/t/error-executing-alerts/352883)

<div class="topic-metadata">

**Author:** [@Deividi\_Cavarzan](https://discuss.elastic.co/u/Deividi_Cavarzan)\
**Replies:** 0\
**Last updated:** [February 8, 2024, 5:25pm UTC](https://discuss.elastic.co/t/error-executing-alerts/352883 "2024-02-08T17:25:55Z")

</div>

Hi, Some alerts stop working due to the error above, I wans't able to find how to set this index as write.

---

## [Confusion about winlog.process.pid and xcopy](https://discuss.elastic.co/t/confusion-about-winlog-process-pid-and-xcopy/352520)

<div class="topic-metadata">

**Author:** [@nerio](https://discuss.elastic.co/u/nerio)\
**Replies:** 0\
**Last updated:** [February 5, 2024, 10:29am UTC](https://discuss.elastic.co/t/confusion-about-winlog-process-pid-and-xcopy/352520 "2024-02-05T10:29:26Z")

</div>

Hello I would have 2 questions : In an event id 1 (pcoess creation), what is the difference between the field winlog.process.pid (eg 2360) and the field process.pid (eg 6392) ? Why did not the command "C:\\Windows\\S…

---

## [Cannot Edit the configuration of Logs Stream on Kibana UI](https://discuss.elastic.co/t/cannot-edit-the-configuration-of-logs-stream-on-kibana-ui/339981)

<div class="topic-metadata">

**Author:** [@Cruz](https://discuss.elastic.co/u/Cruz)\
**Replies:** 7\
**Last updated:** [February 8, 2024, 11:45am UTC](https://discuss.elastic.co/t/cannot-edit-the-configuration-of-logs-stream-on-kibana-ui/339981 "2024-02-08T11:45:02Z")

</div>

Does anyone know how to solve this? It seems I can't change the settings of Logs Stream. The input field not clickable. I just want to change the Log indices. I tried to restart my elastic and kibana but it's still…

---

## [I am getting the error while setting on Runcloud Based Setup on Normal setup its working like a charm but on Runcloud I am have this issue](https://discuss.elastic.co/t/i-am-getting-the-error-while-setting-on-runcloud-based-setup-on-normal-setup-its-working-like-a-charm-but-on-runcloud-i-am-have-this-issue/352834)

<div class="topic-metadata">

**Author:** [@Arya\_Aniket](https://discuss.elastic.co/u/Arya_Aniket)\
**Replies:** 0\
**Last updated:** [February 8, 2024, 8:59am UTC](https://discuss.elastic.co/t/i-am-getting-the-error-while-setting-on-runcloud-based-setup-on-normal-setup-its-working-like-a-charm-but-on-runcloud-i-am-have-this-issue/352834 "2024-02-08T08:59:20Z")

</div>

I am using LEMP setup and we are using Runcloud service for deploying the wordpress apps and Laravel apps. On raw LEMP setup its working fine but on runcloud I am getting this issue. This issue is regarding open\_basedir. …

[Previous page](https://discuss.elastic.co/c/observability/82.md?page=28)

[Next page](https://discuss.elastic.co/c/observability/82.md?page=30)
