# Elastic Observability

**URL:** https://discuss.elastic.co/c/observability/82.md?page=30

[Latest](https://discuss.elastic.co/latest.md) · [Categories](https://discuss.elastic.co/categories.md) · [Tags](https://discuss.elastic.co/tags.md)

**Page:** 31

---

## [How to structure observability data about the wellness of my (custom) app](https://discuss.elastic.co/t/how-to-structure-observability-data-about-the-wellness-of-my-custom-app/352779)

<div class="topic-metadata">

**Author:** [@nouknouk](https://discuss.elastic.co/u/nouknouk)\
**Replies:** 0\
**Last updated:** [February 7, 2024, 3:56pm UTC](https://discuss.elastic.co/t/how-to-structure-observability-data-about-the-wellness-of-my-custom-app/352779 "2024-02-07T15:56:41Z")

</div>

Hi, I have a (big, old) application which is monitored on production, to detect when something is mis-behaving and pro-actively notify operators. The current monitoring is composed of a big script which executes a batc…

---

## [Exclude hosts from metric threshold rule](https://discuss.elastic.co/t/exclude-hosts-from-metric-threshold-rule/352536)

<div class="topic-metadata">

**Author:** [@Adindan](https://discuss.elastic.co/u/Adindan)\
**Replies:** 3\
**Last updated:** [February 6, 2024, 1:59pm UTC](https://discuss.elastic.co/t/exclude-hosts-from-metric-threshold-rule/352536 "2024-02-06T13:59:57Z")

</div>

Hi, I'm wondering if it's possible to stop a rule from running on certain hosts in an inventory. I'm looking for something that would either stop the rule from running at a certain time, or ignore any alerts that occur …

---

## [Supervise the execution of our SSIS packages via APM](https://discuss.elastic.co/t/supervise-the-execution-of-our-ssis-packages-via-apm/352607)

<div class="topic-metadata">

**Author:** [@hrescourio](https://discuss.elastic.co/u/hrescourio)\
**Replies:** 0\
**Last updated:** [February 6, 2024, 8:33am UTC](https://discuss.elastic.co/t/supervise-the-execution-of-our-ssis-packages-via-apm/352607 "2024-02-06T08:33:52Z")

</div>

Hello We want to monitor the execution of our SSIS packages via APM. Logs are stored in the SSISDB database. Is there an agent to collect them in Elastic Thanks in advance Best regards

---

## [Uptime alert when Elastic/kibana service is down](https://discuss.elastic.co/t/uptime-alert-when-elastic-kibana-service-is-down/351971)

<div class="topic-metadata">

**Author:** [@theacodes](https://discuss.elastic.co/u/theacodes)\
**Replies:** 4\
**Last updated:** [February 6, 2024, 5:27am UTC](https://discuss.elastic.co/t/uptime-alert-when-elastic-kibana-service-is-down/351971 "2024-02-06T05:27:18Z")

</div>

I've added Elastic and Kibana's URLs to monitors and enabled uptime alerts on Slack. I want to know if I will get an alert or not if the kibana service is down and not loading on web?

---

## [Elasticsearch cluster goes down with 1 node capacity reached, resolutions](https://discuss.elastic.co/t/elasticsearch-cluster-goes-down-with-1-node-capacity-reached-resolutions/352550)

<div class="topic-metadata">

**Author:** [@charvi23](https://discuss.elastic.co/u/charvi23)\
**Replies:** 4\
**Last updated:** [February 5, 2024, 4:27pm UTC](https://discuss.elastic.co/t/elasticsearch-cluster-goes-down-with-1-node-capacity-reached-resolutions/352550 "2024-02-05T16:27:12Z")

</div>

I have a 2 node cluster, out of which 1 node has reached max capacity (96%). Both nodes have different capacity. It gives the following error: TOO\_MANY\_REQUESTS/12/disk usage exceeded flood-stage watermark, index has re…

---

## [Why the kibana action so slow?](https://discuss.elastic.co/t/why-the-kibana-action-so-slow/350702)

<div class="topic-metadata">

**Author:** [@jevonsnotes](https://discuss.elastic.co/u/jevonsnotes)\
**Replies:** 9\
**Last updated:** [February 4, 2024, 8:43am UTC](https://discuss.elastic.co/t/why-the-kibana-action-so-slow/350702 "2024-02-04T08:43:01Z")

</div>

version 8.11.3 such as the Synthetics func ,it take a few minutes to action when i change the switch

---

## [Unable to create component template updating component template results in invalid composable template after templates are merged](https://discuss.elastic.co/t/unable-to-create-component-template-updating-component-template-results-in-invalid-composable-template-after-templates-are-merged/352271)

<div class="topic-metadata">

**Author:** [@florinsfetea](https://discuss.elastic.co/u/florinsfetea)\
**Replies:** 2\
**Last updated:** [February 2, 2024, 8:32am UTC](https://discuss.elastic.co/t/unable-to-create-component-template-updating-component-template-results-in-invalid-composable-template-after-templates-are-merged/352271 "2024-02-02T08:32:58Z")

</div>

On 8.12.0 I am hitting this again \` Unable to create component template updating component template \[metrics-mysql.performance@custom\] results in invalid composable template \[metrics-mysql.performance\] after templates…

---

## [Use Field in Alert Email Action](https://discuss.elastic.co/t/use-field-in-alert-email-action/352344)

<div class="topic-metadata">

**Author:** [@Ray3](https://discuss.elastic.co/u/Ray3)\
**Replies:** 0\
**Last updated:** [February 1, 2024, 11:31pm UTC](https://discuss.elastic.co/t/use-field-in-alert-email-action/352344 "2024-02-01T23:31:26Z")

</div>

I think I saw this somewhere but have been unable to find it again. Can I set a rule and alert to send to an email address stored in document field. Our field is alertdistlist and it has a formatted email address. I …

---

## [Monitoring openshift with elastic 8.12](https://discuss.elastic.co/t/monitoring-openshift-with-elastic-8-12/352321)

<div class="topic-metadata">

**Author:** [@gbeltramelli](https://discuss.elastic.co/u/gbeltramelli)\
**Replies:** 0\
**Last updated:** [February 1, 2024, 3:47pm UTC](https://discuss.elastic.co/t/monitoring-openshift-with-elastic-8-12/352321 "2024-02-01T15:47:10Z")

</div>

Hello!! i was looking for any documentation about the procedures for monitoring our openshift with elastic (metrics packets filebeat apm everything) but i was not able to find any up to date info about it, does anyone ha…

---

## [Filter out APM service.name from ML Job](https://discuss.elastic.co/t/filter-out-apm-service-name-from-ml-job/352215)

<div class="topic-metadata">

**Author:** [@ethranes](https://discuss.elastic.co/u/ethranes)\
**Replies:** 1\
**Last updated:** [January 31, 2024, 5:35pm UTC](https://discuss.elastic.co/t/filter-out-apm-service-name-from-ml-job/352215 "2024-01-31T17:35:27Z")

</div>

Hi. From my APM page, I have setup a high transaction duration ML job. I am only able to base it from the service.environment. The issue with this is that one service, in the environment is red a lot, and we don't really…

---

## [How To Install Bundled APM Plugin](https://discuss.elastic.co/t/how-to-install-bundled-apm-plugin/352095)

<div class="topic-metadata">

**Author:** [@Evesy](https://discuss.elastic.co/u/Evesy)\
**Replies:** 0\
**Last updated:** [January 30, 2024, 2:07pm UTC](https://discuss.elastic.co/t/how-to-install-bundled-apm-plugin/352095 "2024-01-30T14:07:03Z")

</div>

Kibana 8.12.0 introduced a new bundled X-Pack plugin (x-pack/plugin/apm: introduce x-pack-apm plugin · axw/elasticsearch@2aebfcc · GitHub) that allows installing APM related index templates etc. without the need for conf…

---

## [PHP APM Agent is not picking up the routes](https://discuss.elastic.co/t/php-apm-agent-is-not-picking-up-the-routes/352080)

<div class="topic-metadata">

**Author:** [@Ali\_Mehdi](https://discuss.elastic.co/u/Ali_Mehdi)\
**Replies:** 6\
**Last updated:** [January 31, 2024, 11:01am UTC](https://discuss.elastic.co/t/php-apm-agent-is-not-picking-up-the-routes/352080 "2024-01-31T11:01:56Z")

</div>

Kibana version: 8.11 Elasticsearch version:8.11 APM Server version:fleet managed apm 8.11 APM Agent language and version:apm-agent-php v1.12.0 Browser version: Version 121.0.6167.85 Original install method (e.g. do…

---

## [Elastic Observability Engineer 7.9 (On-Demand) - Labs - Trial Expired](https://discuss.elastic.co/t/elastic-observability-engineer-7-9-on-demand-labs-trial-expired/337667)

<div class="topic-metadata">

**Author:** [@AmitKakkad](https://discuss.elastic.co/u/AmitKakkad)\
**Replies:** 1\
**Last updated:** [January 30, 2024, 11:17pm UTC](https://discuss.elastic.co/t/elastic-observability-engineer-7-9-on-demand-labs-trial-expired/337667 "2024-01-30T23:17:32Z")

</div>

Hello All. I am getting "Trial Expired" errors in the Labs. Any ideas on a fix. I have contacted support. Thanks. Amit

---

## [Understanding Metrics Displayed on Dashboard](https://discuss.elastic.co/t/understanding-metrics-displayed-on-dashboard/351620)

<div class="topic-metadata">

**Author:** [@vinaykoul4](https://discuss.elastic.co/u/vinaykoul4)\
**Replies:** 1\
**Last updated:** [January 30, 2024, 7:07pm UTC](https://discuss.elastic.co/t/understanding-metrics-displayed-on-dashboard/351620 "2024-01-30T19:07:12Z")

</div>

I am unable to figure out the data provided by below graph. Is it the memory/CPU consumption by single server or average of all servers under which service has been running? Is it at Process level , if yes which proces…

---

## [Java service not recovering from APM circuit breaker after CPU stress subsides in kubernetes](https://discuss.elastic.co/t/java-service-not-recovering-from-apm-circuit-breaker-after-cpu-stress-subsides-in-kubernetes/352082)

<div class="topic-metadata">

**Author:** [@HemdeepSaini](https://discuss.elastic.co/u/HemdeepSaini)\
**Replies:** 1\
**Last updated:** [January 30, 2024, 1:01pm UTC](https://discuss.elastic.co/t/java-service-not-recovering-from-apm-circuit-breaker-after-cpu-stress-subsides-in-kubernetes/352082 "2024-01-30T13:01:09Z")

</div>

Description: I'm using Elastic APM to monitor a Java application deployed on a Kubernetes pod. When the service initially experiences CPU stress, the APM TRACER correctly switches to the PAUSED state due to the circuit …

---

## [How can I get the wkB/s reported by iostat](https://discuss.elastic.co/t/how-can-i-get-the-wkb-s-reported-by-iostat/352043)

<div class="topic-metadata">

**Author:** [@aorona](https://discuss.elastic.co/u/aorona)\
**Replies:** 0\
**Last updated:** [January 30, 2024, 1:02am UTC](https://discuss.elastic.co/t/how-can-i-get-the-wkb-s-reported-by-iostat/352043 "2024-01-30T01:02:52Z")

</div>

I am using elastic integrations to collect disk statistics https://docs.elastic.co/en/integrations/system#disk-io I would like to plot amount of data read and written (rkB/s , wkB/s ) but I am running into some issues…

---

## [Dotnet 8 \> Serilog \> OTEL \> APM](https://discuss.elastic.co/t/dotnet-8-serilog-otel-apm/351957)

<div class="topic-metadata">

**Author:** [@Sunny84](https://discuss.elastic.co/u/Sunny84)\
**Replies:** 0\
**Last updated:** [January 29, 2024, 5:56am UTC](https://discuss.elastic.co/t/dotnet-8-serilog-otel-apm/351957 "2024-01-29T05:56:17Z")

</div>

I am trying to create a demo on my local to prove that I can setup auto instrumentation of dotnet 8 web api using Serilog sink to send data to OTEL collector which in turn is forwarding Trace, Metrics and Logs data to el…

---

## [Not able to use profiling on fargate enviroment](https://discuss.elastic.co/t/not-able-to-use-profiling-on-fargate-enviroment/350688)

<div class="topic-metadata">

**Author:** [@julianep](https://discuss.elastic.co/u/julianep)\
**Replies:** 3\
**Last updated:** [January 26, 2024, 6:40am UTC](https://discuss.elastic.co/t/not-able-to-use-profiling-on-fargate-enviroment/350688 "2024-01-26T06:40:00Z")

</div>

I'm using the elastic agent to implement the Universal Profiling feature in our AWS ECS Fargate clusters, but I'm facing strange errors and we got stuck trying to get this working properly, i know this is related to ebpf…

---

## [Loading profiler failed during CoCreateInstance](https://discuss.elastic.co/t/loading-profiler-failed-during-cocreateinstance/351775)

<div class="topic-metadata">

**Author:** [@Melyanets\_Pavel](https://discuss.elastic.co/u/Melyanets_Pavel)\
**Replies:** 0\
**Last updated:** [January 25, 2024, 6:47am UTC](https://discuss.elastic.co/t/loading-profiler-failed-during-cocreateinstance/351775 "2024-01-25T06:47:51Z")

</div>

APM Agent language and version: apm-agent-dotnet v1.25.3 Kibana version: 7.17.13 Elasticsearch version: 7.17.13 APM Server version: 7.17.13 Browser version: is not applicable Original install method (e.g. download p…

---

## [Is there a way to disable source mapping in fleet-managed APM?](https://discuss.elastic.co/t/is-there-a-way-to-disable-source-mapping-in-fleet-managed-apm/351531)

<div class="topic-metadata">

**Author:** [@Overl0rd](https://discuss.elastic.co/u/Overl0rd)\
**Replies:** 1\
**Last updated:** [January 24, 2024, 2:53am UTC](https://discuss.elastic.co/t/is-there-a-way-to-disable-source-mapping-in-fleet-managed-apm/351531 "2024-01-24T02:53:47Z")

</div>

Hi, I'm looking to disable to source.mapping in fleet-managed APM. Our APM is currently trying to read source maps of logs which do not have a source map, causing stack traces to be filled with ""error": unable to find …

---

## [Not able to view log afer creating the indices in 8.11](https://discuss.elastic.co/t/not-able-to-view-log-afer-creating-the-indices-in-8-11/351523)

<div class="topic-metadata">

**Author:** [@Neha\_Tiwari](https://discuss.elastic.co/u/Neha_Tiwari)\
**Replies:** 2\
**Last updated:** [January 23, 2024, 10:09am UTC](https://discuss.elastic.co/t/not-able-to-view-log-afer-creating-the-indices-in-8-11/351523 "2024-01-23T10:09:11Z")

</div>

i have installed 8.11 and after that i have created indices and i am not able view the log

---

## [Kibana upgrade error - \[2023-12-27T14:22:46.832+00:00\]\[ERROR\]\[plugins.observability\] Failed to install SLO common resources and summary transforms](https://discuss.elastic.co/t/kibana-upgrade-error-2023-12-27t1446-832-00-00-error-plugins-observability-failed-to-install-slo-common-resources-and-summary-transforms/350028)

<div class="topic-metadata">

**Author:** [@Shaiju\_Sam](https://discuss.elastic.co/u/Shaiju_Sam)\
**Replies:** 2\
**Last updated:** [January 1, 2024, 12:40am UTC](https://discuss.elastic.co/t/kibana-upgrade-error-2023-12-27t1446-832-00-00-error-plugins-observability-failed-to-install-slo-common-resources-and-summary-transforms/350028 "2024-01-01T00:40:54Z")

</div>

Hi Team, We are trying to upgrade the cluster from 8.9.2 to 8.11.3. The Elasticsearch upgrade is succesfull however when trying to upgrade kibana, we are getting error as below \[2023-12-27T14:22:46.832+00:00\]\[ERROR\]\[pl…

---

## [Healt indicator not showing on all services](https://discuss.elastic.co/t/healt-indicator-not-showing-on-all-services/351265)

<div class="topic-metadata">

**Author:** [@flalar](https://discuss.elastic.co/u/flalar)\
**Replies:** 2\
**Last updated:** [January 19, 2024, 1:55pm UTC](https://discuss.elastic.co/t/healt-indicator-not-showing-on-all-services/351265 "2024-01-19T13:55:37Z")

</div>

Hi, We have a few .net services instrumented with elastic apm. However, it seems the APM server is not able to detect if a service is healty or not for anything other than web requests. See screenshot below. Is ther…

---

## [SQL Bulk copy operation not captured by Apm Agent](https://discuss.elastic.co/t/sql-bulk-copy-operation-not-captured-by-apm-agent/350908)

<div class="topic-metadata">

**Author:** [@vinaykoul4](https://discuss.elastic.co/u/vinaykoul4)\
**Replies:** 5\
**Last updated:** [January 19, 2024, 9:17am UTC](https://discuss.elastic.co/t/sql-bulk-copy-operation-not-captured-by-apm-agent/350908 "2024-01-19T09:17:33Z")

</div>

We are using SQLBulkCopy.Write ToServerAsync method to write data to tables but these operations are not captured by APM agent. Agent is subscribed to SqlClientDiagnosticSubscriber Tried with adding package Elastic.Apm…

---

## [Grouping hosts in infrastructure by custom key or tags](https://discuss.elastic.co/t/grouping-hosts-in-infrastructure-by-custom-key-or-tags/336707)

<div class="topic-metadata">

**Author:** [@rubal033](https://discuss.elastic.co/u/rubal033)\
**Replies:** 1\
**Last updated:** [January 18, 2024, 7:41pm UTC](https://discuss.elastic.co/t/grouping-hosts-in-infrastructure-by-custom-key-or-tags/336707 "2024-01-18T19:41:18Z")

</div>

Hi Is there any way to group host with name while monitoring infrastructure with elastic-agent? Currently agent name is same as hostname under fleet and if we keep hostname same for more than 1 host to group them under …

---

## [Response to preflight request doesn’t pass access control check: No ‘Access-Control-Allow-Origin’](https://discuss.elastic.co/t/response-to-preflight-request-doesn-t-pass-access-control-check-no-access-control-allow-origin/348244)

<div class="topic-metadata">

**Author:** [@alexander3](https://discuss.elastic.co/u/alexander3)\
**Replies:** 1\
**Last updated:** [January 18, 2024, 11:25am UTC](https://discuss.elastic.co/t/response-to-preflight-request-doesn-t-pass-access-control-check-no-access-control-allow-origin/348244 "2024-01-18T11:25:34Z")

</div>

Hi, I am in a process of learning how to use Elastic, Kibana and a simple create-react-app project with OpenTelemetry to monitor a react application. After setting up Elastic, Kibana and instrumenting OpenTelemetry I am …

---

## [Set number of replicas to 0 for all indices and index templates](https://discuss.elastic.co/t/set-number-of-replicas-to-0-for-all-indices-and-index-templates/351078)

<div class="topic-metadata">

**Author:** [@georgms](https://discuss.elastic.co/u/georgms)\
**Replies:** 3\
**Last updated:** [January 18, 2024, 9:53am UTC](https://discuss.elastic.co/t/set-number-of-replicas-to-0-for-all-indices-and-index-templates/351078 "2024-01-18T09:53:46Z")

</div>

We're running an Elastic Cloud APM setup for a small application. As this is not critical data we're deliberately using only a single zone across all tier. We are aware of the potential consequences of downtime or data l…

---

## [Profiler Auto instrumentation not working after update c# agent to version 1.25.3](https://discuss.elastic.co/t/profiler-auto-instrumentation-not-working-after-update-c-agent-to-version-1-25-3/351106)

<div class="topic-metadata">

**Author:** [@vahe](https://discuss.elastic.co/u/vahe)\
**Replies:** 8\
**Last updated:** [January 17, 2024, 1:04pm UTC](https://discuss.elastic.co/t/profiler-auto-instrumentation-not-working-after-update-c-agent-to-version-1-25-3/351106 "2024-01-17T13:04:21Z")

</div>

Hello. Please help me. Profiler Auto instrumentation stopped working after update agent to version 1.25.3. Agent version 1.22.0 working fine. Elastic version 8.11.4 Fleet 8.11.4 APM Server 8.11.4 Linux CentOS Linux…

---

## [ES Query Rule : Ability to show previous value?](https://discuss.elastic.co/t/es-query-rule-ability-to-show-previous-value/351215)

<div class="topic-metadata">

**Author:** [@erikg](https://discuss.elastic.co/u/erikg)\
**Replies:** 0\
**Last updated:** [January 17, 2024, 12:04am UTC](https://discuss.elastic.co/t/es-query-rule-ability-to-show-previous-value/351215 "2024-01-17T00:04:42Z")

</div>

Hello, It's me again. I have a interesting use case for ES Query rule but was wondering if its even possible. I was asked to create an alert and be able to show the a field like {{\_source.status}}. This is possible. N…

---

## [Java APM Agent, System CPU reporting with Java 21](https://discuss.elastic.co/t/java-apm-agent-system-cpu-reporting-with-java-21/351149)

<div class="topic-metadata">

**Author:** [@GreenEyed](https://discuss.elastic.co/u/GreenEyed)\
**Replies:** 4\
**Last updated:** [January 16, 2024, 5:41pm UTC](https://discuss.elastic.co/t/java-apm-agent-system-cpu-reporting-with-java-21/351149 "2024-01-16T17:41:00Z")

</div>

Kibana version: 7.17.10 Elasticsearch version: 7.17.10 APM Server version: 7.17.10 APM Agent language and version: Java agent, 1.45.0 Java version: Java 21 Original install method (e.g. download page, yum, deb, from…

[Previous page](https://discuss.elastic.co/c/observability/82.md?page=29)

[Next page](https://discuss.elastic.co/c/observability/82.md?page=31)
