# Elastic Observability

**URL:** https://discuss.elastic.co/c/observability/82.md?page=33

[Latest](https://discuss.elastic.co/latest.md) · [Categories](https://discuss.elastic.co/categories.md) · [Tags](https://discuss.elastic.co/tags.md)

**Page:** 34

---

## [Elastic APM co.elastic.apm.agent.report.AbstractIntakeApiHandler ERROR](https://discuss.elastic.co/t/elastic-apm-co-elastic-apm-agent-report-abstractintakeapihandler-error/348814)

<div class="topic-metadata">

**Author:** [@Jasonespo](https://discuss.elastic.co/u/Jasonespo)\
**Replies:** 0\
**Last updated:** [December 7, 2023, 12:49pm UTC](https://discuss.elastic.co/t/elastic-apm-co-elastic-apm-agent-report-abstractintakeapihandler-error/348814 "2023-12-07T12:49:26Z")

</div>

Hi we are using the APM Java agent to send some transaction monitoring data to APM. Recently we've started getting the below errors every 30s 2023-12-07 11:53:19,638 \[elastic-apm-server-reporter\] ERROR co.elastic.apm.ag…

---

## [Passing context to another thread](https://discuss.elastic.co/t/passing-context-to-another-thread/349055)

<div class="topic-metadata">

**Author:** [@johngregg](https://discuss.elastic.co/u/johngregg)\
**Replies:** 3\
**Last updated:** [December 11, 2023, 3:52pm UTC](https://discuss.elastic.co/t/passing-context-to-another-thread/349055 "2023-12-11T15:52:09Z")

</div>

I am using the 1.42.0 java agent. I am working on an app that uses an unsupported threading library. Based on reading some posts here, we decided to use the OTel library like this: import io.opentelemetry.api.trace.Sp…

---

## [How to shift to elastic-apm-agent-java8](https://discuss.elastic.co/t/how-to-shift-to-elastic-apm-agent-java8/349003)

<div class="topic-metadata">

**Author:** [@Vijeya\_Nidhi](https://discuss.elastic.co/u/Vijeya_Nidhi)\
**Replies:** 1\
**Last updated:** [December 11, 2023, 1:34pm UTC](https://discuss.elastic.co/t/how-to-shift-to-elastic-apm-agent-java8/349003 "2023-12-11T13:34:32Z")

</div>

elastic-apm-agent is supporting java 7, so it is compiled with log4j 2.12.4 But I am also seeing elastic-apm-agent-java8 which has the higher log4j version. Can I know where to find the jar file for the same for downlo…

---

## [Java 7 support drop dates](https://discuss.elastic.co/t/java-7-support-drop-dates/349004)

<div class="topic-metadata">

**Author:** [@Vijeya\_Nidhi](https://discuss.elastic.co/u/Vijeya_Nidhi)\
**Replies:** 1\
**Last updated:** [December 11, 2023, 1:26pm UTC](https://discuss.elastic.co/t/java-7-support-drop-dates/349004 "2023-12-11T13:26:58Z")

</div>

Hi, apm-agent-java is still supporting Java 7. Can I know if there is a plan in the future to drop the support and make the lowest supported version to be Java 8?

---

## [Elastic APM not instrumenting nested routes in separate files on Express server](https://discuss.elastic.co/t/elastic-apm-not-instrumenting-nested-routes-in-separate-files-on-express-server/348813)

<div class="topic-metadata">

**Author:** [@HemdeepSaini](https://discuss.elastic.co/u/HemdeepSaini)\
**Replies:** 2\
**Last updated:** [December 11, 2023, 10:51am UTC](https://discuss.elastic.co/t/elastic-apm-not-instrumenting-nested-routes-in-separate-files-on-express-server/348813 "2023-12-11T10:51:03Z")

</div>

Problem: I am using Elastic APM to monitor Express application. However, APM is not able to instrument any HTTP requests when nested routing is implemented across multiple files. It only works when all routes are define…

---

## [Watcher with different thresholds](https://discuss.elastic.co/t/watcher-with-different-thresholds/347276)

<div class="topic-metadata">

**Author:** [@shayn](https://discuss.elastic.co/u/shayn)\
**Replies:** 2\
**Last updated:** [December 11, 2023, 6:15am UTC](https://discuss.elastic.co/t/watcher-with-different-thresholds/347276 "2023-12-11T06:15:49Z")

</div>

hi im trying to figure up if I've the ability to alert different thresholds in same watcher task . i have index that's contains some different devices with numer of events i want to create watcher that will have diffe…

---

## [Logstash 8.11 Geoip filter plugin does not enhancing the apache access data](https://discuss.elastic.co/t/logstash-8-11-geoip-filter-plugin-does-not-enhancing-the-apache-access-data/348893)

<div class="topic-metadata">

**Author:** [@husoelasticbe](https://discuss.elastic.co/u/husoelasticbe)\
**Replies:** 13\
**Last updated:** [December 8, 2023, 9:32pm UTC](https://discuss.elastic.co/t/logstash-8-11-geoip-filter-plugin-does-not-enhancing-the-apache-access-data/348893 "2023-12-08T21:32:07Z")

</div>

Dear elastic community, I am having issues with enhancing my access log data with Geoip filter plugin. I have very simple pipeline conf file like follow: input { file { path =\> "/etc/logstash/event-data/a…

---

## [VueJS RUM distributed tracing](https://discuss.elastic.co/t/vuejs-rum-distributed-tracing/348937)

<div class="topic-metadata">

**Author:** [@senyam08](https://discuss.elastic.co/u/senyam08)\
**Replies:** 1\
**Last updated:** [December 8, 2023, 8:45pm UTC](https://discuss.elastic.co/t/vuejs-rum-distributed-tracing/348937 "2023-12-08T20:45:51Z")

</div>

We have instrumented our application(Vuejs) with RUM javascript agent We have used the following js file inserted via GTM tag https://unpkg.com/@elastic/apm-rum@5.15.0/dist/bundles/elastic-apm-rum.umd.min.js We are ge…

---

## [Observability Alerting - Throttling/Acknowledge - Based](https://discuss.elastic.co/t/observability-alerting-throttling-acknowledge-based/348837)

<div class="topic-metadata">

**Author:** [@erikg](https://discuss.elastic.co/u/erikg)\
**Replies:** 2\
**Last updated:** [December 7, 2023, 10:46pm UTC](https://discuss.elastic.co/t/observability-alerting-throttling-acknowledge-based/348837 "2023-12-07T22:46:55Z")

</div>

Hello, I been creating some alerts using Inventory/Metrics to be able to alert like on CPU usage. I can't seem to find in the documentation how we can implement throttling in this alerts (in order to avoid spam). Also …

---

## [Observability - Tiered Alerting](https://discuss.elastic.co/t/observability-tiered-alerting/348838)

<div class="topic-metadata">

**Author:** [@erikg](https://discuss.elastic.co/u/erikg)\
**Replies:** 1\
**Last updated:** [December 7, 2023, 7:24pm UTC](https://discuss.elastic.co/t/observability-tiered-alerting/348838 "2023-12-07T19:24:55Z")

</div>

Hello, It would be cool if we are be to create like a action sequence in alerting. An example, if an alert is triggered it will send an email to User1, if User1 doesn't acknowledge it or after a certain time has exceede…

---

## [House Keeping the dedicated monitoring deployment](https://discuss.elastic.co/t/house-keeping-the-dedicated-monitoring-deployment/348588)

<div class="topic-metadata">

**Author:** [@Nww\_Pot\_Fung\_Nng](https://discuss.elastic.co/u/Nww_Pot_Fung_Nng)\
**Replies:** 2\
**Last updated:** [December 7, 2023, 7:49pm UTC](https://discuss.elastic.co/t/house-keeping-the-dedicated-monitoring-deployment/348588 "2023-12-07T19:49:10Z")

</div>

Hi, just want to know how we housekeep the dedicated monitoring deployment. I would imagine we will need to remove indexes that reach a certain age such as 30d. Cheers, Martin

---

## [Embedding Certificate in configuration file fails with environment variable](https://discuss.elastic.co/t/embedding-certificate-in-configuration-file-fails-with-environment-variable/347554)

<div class="topic-metadata">

**Author:** [@asnyameeteen](https://discuss.elastic.co/u/asnyameeteen)\
**Replies:** 3\
**Last updated:** [December 6, 2023, 11:32pm UTC](https://discuss.elastic.co/t/embedding-certificate-in-configuration-file-fails-with-environment-variable/347554 "2023-12-06T23:32:49Z")

</div>

Running versions 8.10.2 of Kibana, Filebeat, Elasticsearch and APM Server. They are currently running on AWS ECS as Docker containers. I am attempting to configure the output.elasticsearch portion of the apm-server.yml …

---

## [Adding APM as integration facing Kibana security must be enabled to use Fleet](https://discuss.elastic.co/t/adding-apm-as-integration-facing-kibana-security-must-be-enabled-to-use-fleet/348292)

<div class="topic-metadata">

**Author:** [@Yasir\_Zafar](https://discuss.elastic.co/u/Yasir_Zafar)\
**Replies:** 1\
**Last updated:** [December 5, 2023, 8:10pm UTC](https://discuss.elastic.co/t/adding-apm-as-integration-facing-kibana-security-must-be-enabled-to-use-fleet/348292 "2023-12-05T20:10:07Z")

</div>

When i am trying to add APM as integration point facing. Error loading integration details Kibana security must be enabled to use Fleet.

---

## [Elastic APM index name requirement?](https://discuss.elastic.co/t/elastic-apm-index-name-requirement/348639)

<div class="topic-metadata">

**Author:** [@Jasonespo](https://discuss.elastic.co/u/Jasonespo)\
**Replies:** 2\
**Last updated:** [December 5, 2023, 3:39pm UTC](https://discuss.elastic.co/t/elastic-apm-index-name-requirement/348639 "2023-12-05T15:39:20Z")

</div>

Hi, I was wondering if there is a requirement on the index name for the logs to appear in the logs section of an Elastic APM transaction? I moved to using Elastic Serverless Forwarder to send applications logs to a cus…

---

## [Collect logs from AWS Fargate application to Elastic Cloud](https://discuss.elastic.co/t/collect-logs-from-aws-fargate-application-to-elastic-cloud/344223)

<div class="topic-metadata">

**Author:** [@georgms](https://discuss.elastic.co/u/georgms)\
**Replies:** 5\
**Last updated:** [December 4, 2023, 7:52pm UTC](https://discuss.elastic.co/t/collect-logs-from-aws-fargate-application-to-elastic-cloud/344223 "2023-12-04T19:52:10Z")

</div>

I have an application running on AWS Fargate. I have already added the Elastic APM agent to the application so I get metrics, transactions etc. but no log yet. So how do I collect logs from an AWS Fargate application to…

---

## [Monitor.use({ options](https://discuss.elastic.co/t/monitor-use-options/348415)

<div class="topic-metadata">

**Author:** [@linuschewpet](https://discuss.elastic.co/u/linuschewpet)\
**Replies:** 2\
**Last updated:** [December 3, 2023, 10:30am UTC](https://discuss.elastic.co/t/monitor-use-options/348415 "2023-12-03T10:30:08Z")

</div>

const { journey, step, expect, monitor } = require('@elastic/synthetics'); journey('App1', async ({ page, context }) =\> { monitor.use({ id: 'App1', schedule: 30, tags: \['App1'\], //service: \['App1'\], }…

---

## [Do not send alert if Synthetic fails certain step](https://discuss.elastic.co/t/do-not-send-alert-if-synthetic-fails-certain-step/348418)

<div class="topic-metadata">

**Author:** [@linuschewpet](https://discuss.elastic.co/u/linuschewpet)\
**Replies:** 3\
**Last updated:** [December 3, 2023, 10:27am UTC](https://discuss.elastic.co/t/do-not-send-alert-if-synthetic-fails-certain-step/348418 "2023-12-03T10:27:47Z")

</div>

Given a scenario, say if synthetic fails on the login step before it could run the other steps fun and sad time. By normal behaviour it would send an alert as long as any steps failed, however the requirement would be. …

---

## [Agent configuration infrastructure is not ready](https://discuss.elastic.co/t/agent-configuration-infrastructure-is-not-ready/348364)

<div class="topic-metadata">

**Author:** [@joe\_recra](https://discuss.elastic.co/u/joe_recra)\
**Replies:** 7\
**Last updated:** [December 1, 2023, 7:05pm UTC](https://discuss.elastic.co/t/agent-configuration-infrastructure-is-not-ready/348364 "2023-12-01T19:05:50Z")

</div>

Kibana version: 8.11.1 Elasticsearch version: 8.11.1 APM Server version: 8.11.1 APM Agent language and version: Nodejs v17.9.1 && elastic-apm-node 4.2.0 Browser version: Original install method (e.g. download pa…

---

## [How dependencies are listed under Observability \> APM \> Dependencies](https://discuss.elastic.co/t/how-dependencies-are-listed-under-observability-apm-dependencies/348410)

<div class="topic-metadata">

**Author:** [@dev19](https://discuss.elastic.co/u/dev19)\
**Replies:** 1\
**Last updated:** [December 1, 2023, 12:10pm UTC](https://discuss.elastic.co/t/how-dependencies-are-listed-under-observability-apm-dependencies/348410 "2023-12-01T12:10:12Z")

</div>

Kibana version: 8.7.1 Elasticsearch version: 8.7.1 APM Server version: 8.7.1 APM Agent language and version: Java, 1.42.0 Fresh install or upgraded from other version? Fresh Install In APM\>Services, I have bunch of …

---

## [How to add custom trace id generator in elastic APM java agent code base](https://discuss.elastic.co/t/how-to-add-custom-trace-id-generator-in-elastic-apm-java-agent-code-base/348360)

<div class="topic-metadata">

**Author:** [@MadhusudanN](https://discuss.elastic.co/u/MadhusudanN)\
**Replies:** 1\
**Last updated:** [December 1, 2023, 11:52am UTC](https://discuss.elastic.co/t/how-to-add-custom-trace-id-generator-in-elastic-apm-java-agent-code-base/348360 "2023-12-01T11:52:14Z")

</div>

Can someone please let me know if there is a way to plug custom trace id generator in the elastic APM java agent code base.

---

## [Traces are not correctly ccorrelated when using an API Gateway](https://discuss.elastic.co/t/traces-are-not-correctly-ccorrelated-when-using-an-api-gateway/348400)

<div class="topic-metadata">

**Author:** [@MaxMeijer](https://discuss.elastic.co/u/MaxMeijer)\
**Replies:** 0\
**Last updated:** [December 1, 2023, 6:48am UTC](https://discuss.elastic.co/t/traces-are-not-correctly-ccorrelated-when-using-an-api-gateway/348400 "2023-12-01T06:48:21Z")

</div>

Kibana version: 8.11.1 Elasticsearch version: 8.11.1 APM Server version: Unknown/ most likely 8.11.1 APM Agent language and version: No APM Agent. .NET OpenTelemetry sending data directly to the APm server using …

---

## [ERROR: java.lang.NoClassDefFoundError: co/elastic/apm/api/ElasticApm](https://discuss.elastic.co/t/error-java-lang-noclassdeffounderror-co-elastic-apm-api-elasticapm/348263)

<div class="topic-metadata">

**Author:** [@miguel.longo](https://discuss.elastic.co/u/miguel.longo)\
**Replies:** 1\
**Last updated:** [November 30, 2023, 8:37am UTC](https://discuss.elastic.co/t/error-java-lang-noclassdeffounderror-co-elastic-apm-api-elasticapm/348263 "2023-11-30T08:37:38Z")

</div>

Kibana version: 8.6.2 Elasticsearch version: 8.6.2 APM Server version: 8.6.2 APM Agent language and version: 1.43.0 Original install method (e.g. download page, yum, deb, from source, etc.) and version: Docker stack …

---

## [.Net APM Traces Incomplete When Deployed](https://discuss.elastic.co/t/net-apm-traces-incomplete-when-deployed/348185)

<div class="topic-metadata">

**Author:** [@skaaks](https://discuss.elastic.co/u/skaaks)\
**Replies:** 3\
**Last updated:** [November 29, 2023, 6:47pm UTC](https://discuss.elastic.co/t/net-apm-traces-incomplete-when-deployed/348185 "2023-11-29T18:47:56Z")

</div>

Kibana version: 7.17..0 Elasticsearch version: 7.17.0 APM Server version: 7.17.15 APM Agent language and version: .Net Core 6.0 Browser version: Chrome 119.0.6045.160 Original install method (e.g. download page, yum…

---

## [Active Alerts Showing for Unenrolled Agents](https://discuss.elastic.co/t/active-alerts-showing-for-unenrolled-agents/347060)

<div class="topic-metadata">

**Author:** [@DougR](https://discuss.elastic.co/u/DougR)\
**Replies:** 4\
**Last updated:** [November 29, 2023, 5:20pm UTC](https://discuss.elastic.co/t/active-alerts-showing-for-unenrolled-agents/347060 "2023-11-29T17:20:52Z")

</div>

We are using Elastic Cloud 8.11.0. I have active alerts showing for agents which have been unenrolled from Fleet and are showing in Fleet as unenrolled. How can I remove these alerts?

---

## [Is Apache HttpClient 5.x supported?](https://discuss.elastic.co/t/is-apache-httpclient-5-x-supported/348235)

<div class="topic-metadata">

**Author:** [@johngregg](https://discuss.elastic.co/u/johngregg)\
**Replies:** 1\
**Last updated:** [November 29, 2023, 1:47pm UTC](https://discuss.elastic.co/t/is-apache-httpclient-5-x-supported/348235 "2023-11-29T13:47:59Z")

</div>

I'm using java agent 1.42.0. Is Apache HttpClient 5.x supported? The docs say 4.3+. With debug enabled, I see messages like: 2023-11-29 07:29:20,399 \[main\] DEBUG co.elastic.apm.agent.bci.ElasticApmAgent - Applying i…

---

## [ERROR co.elastic.apm.agent.bci.IndyBootstrap - Advice threw an exception, this should never happen! java.lang.NoSuchMethodError](https://discuss.elastic.co/t/error-co-elastic-apm-agent-bci-indybootstrap-advice-threw-an-exception-this-should-never-happen-java-lang-nosuchmethoderror/348150)

<div class="topic-metadata">

**Author:** [@miguel.longo](https://discuss.elastic.co/u/miguel.longo)\
**Replies:** 4\
**Last updated:** [November 29, 2023, 11:28am UTC](https://discuss.elastic.co/t/error-co-elastic-apm-agent-bci-indybootstrap-advice-threw-an-exception-this-should-never-happen-java-lang-nosuchmethoderror/348150 "2023-11-29T11:28:09Z")

</div>

Kibana version: 8.6.2 Elasticsearch version: 8.6.2 APM Server version: 8.6.2 APM Agent language and version: java/1.43.0 Original install method (e.g. download page, yum, deb, from source, etc.) and version: Docker s…

---

## [Upgrade Elasticsearch 8.6.0 into new environment](https://discuss.elastic.co/t/upgrade-elasticsearch-8-6-0-into-new-environment/348002)

<div class="topic-metadata">

**Author:** [@Septianingrum.17](https://discuss.elastic.co/u/Septianingrum.17)\
**Replies:** 3\
**Last updated:** [November 29, 2023, 9:26am UTC](https://discuss.elastic.co/t/upgrade-elasticsearch-8-6-0-into-new-environment/348002 "2023-11-29T09:26:18Z")

</div>

Hi All, currently I have elasticsearch version 8.6.0 with 2 elasticsearch nodes, 1 kibana node, 1 fleet server and 1 logstash node with each installed on RHEL 7.9 OS. I want to upgrade ELK to version 8.10 but in the new…

---

## [APM agent suddenly stopped sending data to APM server](https://discuss.elastic.co/t/apm-agent-suddenly-stopped-sending-data-to-apm-server/345544)

<div class="topic-metadata">

**Author:** [@surya\_dadi\_dhamarake](https://discuss.elastic.co/u/surya_dadi_dhamarake)\
**Replies:** 12\
**Last updated:** [November 29, 2023, 4:53am UTC](https://discuss.elastic.co/t/apm-agent-suddenly-stopped-sending-data-to-apm-server/345544 "2023-11-29T04:53:54Z")

</div>

Hi Team, I have deployed elastic cloud deployment along with APM server and integrations server. My Deployment version : 8.9.0 Kibana and integration servers with: 1GB RAM, up to 8.4vCPU I have integrated APM agent w…

---

## [Synthetics - Separate Alerts for Monitors](https://discuss.elastic.co/t/synthetics-separate-alerts-for-monitors/348096)

<div class="topic-metadata">

**Author:** [@erikg](https://discuss.elastic.co/u/erikg)\
**Replies:** 5\
**Last updated:** [November 28, 2023, 7:37pm UTC](https://discuss.elastic.co/t/synthetics-separate-alerts-for-monitors/348096 "2023-11-28T19:37:18Z")

</div>

Hello, This might be obvious, but I can't seem to find the answer. We are considering using Synthetics instead of Uptime in Observability. I have set up the Elastic Agent Integration for Synthetics, and we have it up a…

---

## [GUI of APM not showing values in the label. version 8.9.2](https://discuss.elastic.co/t/gui-of-apm-not-showing-values-in-the-label-version-8-9-2/348163)

<div class="topic-metadata">

**Author:** [@ElasticLiver](https://discuss.elastic.co/u/ElasticLiver)\
**Replies:** 0\
**Last updated:** [November 28, 2023, 3:57pm UTC](https://discuss.elastic.co/t/gui-of-apm-not-showing-values-in-the-label-version-8-9-2/348163 "2023-11-28T15:57:17Z")

</div>

Hi, a customer is asking why the values in the labes are not showing anymore, in some visualization of the APM section in observability: where in previous version the visualization show the values: Is this a bug? …

[Previous page](https://discuss.elastic.co/c/observability/82.md?page=32)

[Next page](https://discuss.elastic.co/c/observability/82.md?page=34)
