# Elastic Observability

**URL:** https://discuss.elastic.co/c/observability/82.md?page=4

[Latest](https://discuss.elastic.co/latest.md) · [Categories](https://discuss.elastic.co/categories.md) · [Tags](https://discuss.elastic.co/tags.md)

**Page:** 5

---

## [ERROR: Could not resolve "chromium-bidi"](https://discuss.elastic.co/t/error-could-not-resolve-chromium-bidi/381826)

<div class="topic-metadata">

**Author:** [@xyngfei](https://discuss.elastic.co/u/xyngfei)\
**Replies:** 1\
**Last updated:** [September 10, 2025, 8:49am UTC](https://discuss.elastic.co/t/error-could-not-resolve-chromium-bidi/381826 "2025-09-10T08:49:06Z")

</div>

SYNTHETICS\_API\_KEY=xxx DEBUG=synthetics NODE\_ENV=production npx @elastic/synthetics push --yes any idea why i cant push the code into my own elastic server? Error: Build failed with 2 errors: node\_modules/playwright-co…

---

## [Traces using opentelemetry SDK to EDOT collector does not show the url path](https://discuss.elastic.co/t/traces-using-opentelemetry-sdk-to-edot-collector-does-not-show-the-url-path/381541)

<div class="topic-metadata">

**Author:** [@mikhatanu](https://discuss.elastic.co/u/mikhatanu)\
**Replies:** 1\
**Last updated:** [September 9, 2025, 10:03pm UTC](https://discuss.elastic.co/t/traces-using-opentelemetry-sdk-to-edot-collector-does-not-show-the-url-path/381541 "2025-09-09T22:03:18Z")

</div>

I’m trying opentelemetry in elasticstack, currently i’m using this: OpenTelemetry node js SDK → EDOT collector → Elasticsearch For sdk, i use autoinstrumentation using opentelemetry operator. For EDOT collector, I used …

---

## [PDF Screenshot Issue: Different Behavior Local vs Elastic Synthetics Server](https://discuss.elastic.co/t/pdf-screenshot-issue-different-behavior-local-vs-elastic-synthetics-server/381629)

<div class="topic-metadata">

**Author:** [@jens\_strumper](https://discuss.elastic.co/u/jens_strumper)\
**Replies:** 0\
**Last updated:** [September 5, 2025, 8:55am UTC](https://discuss.elastic.co/t/pdf-screenshot-issue-different-behavior-local-vs-elastic-synthetics-server/381629 "2025-09-05T08:55:39Z")

</div>

Problem I have a journey that needs to take a screenshot of a PDF document. The same code works perfectly locally but fails on the Elastic Synthetics server due to different tab/navigation behavior. Environment Elast…

---

## [Agent status datastream](https://discuss.elastic.co/t/agent-status-datastream/381019)

<div class="topic-metadata">

**Author:** [@juancamiloll](https://discuss.elastic.co/u/juancamiloll)\
**Replies:** 5\
**Last updated:** [September 4, 2025, 12:50pm UTC](https://discuss.elastic.co/t/agent-status-datastream/381019 "2025-09-04T12:50:26Z")

</div>

It is clear to me that there is already a “Fleet” section where you can see all the agents and their status. However, I need to do this in a table so that I can export them, which is why I am here today to ask you under…

---

## [APM - Stack trace Is not registering for captured exceptions](https://discuss.elastic.co/t/apm-stack-trace-is-not-registering-for-captured-exceptions/381593)

<div class="topic-metadata">

**Author:** [@oliverkuchies](https://discuss.elastic.co/u/oliverkuchies)\
**Replies:** 2\
**Last updated:** [September 4, 2025, 1:59am UTC](https://discuss.elastic.co/t/apm-stack-trace-is-not-registering-for-captured-exceptions/381593 "2025-09-04T01:59:49Z")

</div>

APM Server version: v 8.17.0 APM Agent language and version: apm-agent-php\_1.15.0\_amd64.deb Browser version: Arc 139.0.7258.128 (Official Build) (arm64) Original install method (e.g. download page, yum, deb, from sour…

---

## [APM-Server logs are not wrriten in respective directory](https://discuss.elastic.co/t/apm-server-logs-are-not-wrriten-in-respective-directory/379140)

<div class="topic-metadata">

**Author:** [@Ekta](https://discuss.elastic.co/u/Ekta)\
**Replies:** 8\
**Last updated:** [September 3, 2025, 11:44am UTC](https://discuss.elastic.co/t/apm-server-logs-are-not-wrriten-in-respective-directory/379140 "2025-09-03T11:44:39Z")

</div>

If you are asking about a problem you are experiencing, please use the following template, as it will help us help you. If you have a different problem, please delete all of this text :slight\_smile: TIP 1: select at lea…

---

## [APM FileSystemAlreadyExistsException](https://discuss.elastic.co/t/apm-filesystemalreadyexistsexception/381337)

<div class="topic-metadata">

**Author:** [@jrf](https://discuss.elastic.co/u/jrf)\
**Replies:** 9\
**Last updated:** [September 3, 2025, 9:09am UTC](https://discuss.elastic.co/t/apm-filesystemalreadyexistsexception/381337 "2025-09-03T09:09:50Z")

</div>

APM Server version: 8.18.2 APM Agent language and version: Java 1.55.0 Is there anything special in your setup? This is a Scala application running on Kubernetes with embedded Jetty server. Entrypoint for the container…

---

## [Idea for Elastic Observability Blogs or Documentation](https://discuss.elastic.co/t/idea-for-elastic-observability-blogs-or-documentation/381319)

<div class="topic-metadata">

**Author:** [@erikg](https://discuss.elastic.co/u/erikg)\
**Replies:** 5\
**Last updated:** [September 2, 2025, 4:12pm UTC](https://discuss.elastic.co/t/idea-for-elastic-observability-blogs-or-documentation/381319 "2025-09-02T16:12:57Z")

</div>

Hello, I wanted to share an idea about how elastic can improve their “monitoring” use cases. I am not sure where to share my ideas. So, currently Elastic Agent with integrations is one of the quickest ways to get data …

---

## [Logs not sent when elastic-apm-node is enabled, even with ECSformat](https://discuss.elastic.co/t/logs-not-sent-when-elastic-apm-node-is-enabled-even-with-ecsformat/381500)

<div class="topic-metadata">

**Author:** [@Axel\_Couty1](https://discuss.elastic.co/u/Axel_Couty1)\
**Replies:** 0\
**Last updated:** [September 2, 2025, 12:16am UTC](https://discuss.elastic.co/t/logs-not-sent-when-elastic-apm-node-is-enabled-even-with-ecsformat/381500 "2025-09-02T00:16:03Z")

</div>

Hey everyone, First, thanks for your work ! I am trying to build a NestJS application and I would like to push logs to elasticsearch. The app's deployment does not allow me to use filebeat so I need to push logs direct…

---

## [Apm-server set-up for version 9.1.2](https://discuss.elastic.co/t/apm-server-set-up-for-version-9-1-2/381437)

<div class="topic-metadata">

**Author:** [@Namita\_Jaokar](https://discuss.elastic.co/u/Namita_Jaokar)\
**Replies:** 6\
**Last updated:** [September 1, 2025, 6:29am UTC](https://discuss.elastic.co/t/apm-server-set-up-for-version-9-1-2/381437 "2025-09-01T06:29:10Z")

</div>

Hi Team, Our team for a brief time had elasticsearch , kibana and standalone apm-server all having version 8.6 for observability and visualizing traces in kibana. Recently we migrated to the latest version i.e. 9.1.2 v…

---

## [Problems using ecs](https://discuss.elastic.co/t/problems-using-ecs/381340)

<div class="topic-metadata">

**Author:** [@Ruslan\_Hafizov](https://discuss.elastic.co/u/Ruslan_Hafizov)\
**Replies:** 1\
**Last updated:** [August 29, 2025, 6:35pm UTC](https://discuss.elastic.co/t/problems-using-ecs/381340 "2025-08-29T18:35:48Z")

</div>

I try to use ecs to standardize various logs from different applications. I don't always manage to find a field that suits the situation, especially when it comes to user authorization/authentication. I would like to pro…

---

## [Ingest Pipeline for otel logs](https://discuss.elastic.co/t/ingest-pipeline-for-otel-logs/376033)

<div class="topic-metadata">

**Author:** [@Steve\_Foster](https://discuss.elastic.co/u/Steve_Foster)\
**Replies:** 6\
**Last updated:** [August 29, 2025, 2:28pm UTC](https://discuss.elastic.co/t/ingest-pipeline-for-otel-logs/376033 "2025-08-29T14:28:48Z")

</div>

I've recently migrated our deployments for EDOT to use the Open-Telemetry operator to bring them in line with the guidelines from Elastic. Something that seems to be missing from this is parsing of structured logs (in t…

---

## [Issue: EDOT-Dotnet in elastic dashboard showing random-id even though we are setting the service.node.name](https://discuss.elastic.co/t/issue-edot-dotnet-in-elastic-dashboard-showing-random-id-even-though-we-are-setting-the-service-node-name/381420)

<div class="topic-metadata">

**Author:** [@ullasa-sindhur](https://discuss.elastic.co/u/ullasa-sindhur)\
**Replies:** 1\
**Last updated:** [August 28, 2025, 11:55am UTC](https://discuss.elastic.co/t/issue-edot-dotnet-in-elastic-dashboard-showing-random-id-even-though-we-are-setting-the-service-node-name/381420 "2025-08-28T11:55:29Z")

</div>

Kibana version: 9.0.4 APM Server version: 9.0.4 APM Agent language and version: elastic otel dotnet - 1.1.0 Fresh install or upgraded from other version? migrating from apm-agent to elastic otel dotnet (EDOT) Is the…

---

## [APM-server docker image does not support curl, preventing proper health test](https://discuss.elastic.co/t/apm-server-docker-image-does-not-support-curl-preventing-proper-health-test/359274)

<div class="topic-metadata">

**Author:** [@Gil\_Zigelman](https://discuss.elastic.co/u/Gil_Zigelman)\
**Replies:** 2\
**Last updated:** [August 27, 2025, 7:46am UTC](https://discuss.elastic.co/t/apm-server-docker-image-does-not-support-curl-preventing-proper-health-test/359274 "2025-08-27T07:46:27Z")

</div>

APM Server version docker image: 8.13.4 The docker image does not support curl command. I would like to use curl to detect whether apm-server is healthy for dependent services. Steps to reproduce\*\*: docker run -it…

---

## [Issue with ICMP Monitor](https://discuss.elastic.co/t/issue-with-icmp-monitor/381262)

<div class="topic-metadata">

**Author:** [@erikg](https://discuss.elastic.co/u/erikg)\
**Replies:** 1\
**Last updated:** [August 22, 2025, 3:52pm UTC](https://discuss.elastic.co/t/issue-with-icmp-monitor/381262 "2025-08-22T15:52:32Z")

</div>

Hello, I was wondering why I am getting an error with a specific icmp monitor. I am on self managed and running on private location. Elasticsearch and kibana version 8.18.0. For example: I only have the IP address and …

---

## [Limit es monitored data in metricbeat](https://discuss.elastic.co/t/limit-es-monitored-data-in-metricbeat/381160)

<div class="topic-metadata">

**Author:** [@SamehSaeed](https://discuss.elastic.co/u/SamehSaeed)\
**Replies:** 2\
**Last updated:** [August 21, 2025, 6:47am UTC](https://discuss.elastic.co/t/limit-es-monitored-data-in-metricbeat/381160 "2025-08-21T06:47:36Z")

</div>

Hello, I’m currently monitoring ELK stack through metricbeat (Elasticsearch, Kibana & Logstash) but the monitoring index for Elasticsearch “.ds-.monitoring-es…….” is around 15GB per day so I switched the period to 60 …

---

## [Distributed tracing implementation with self hosted .net services](https://discuss.elastic.co/t/distributed-tracing-implementation-with-self-hosted-net-services/381125)

<div class="topic-metadata">

**Author:** [@amit37](https://discuss.elastic.co/u/amit37)\
**Replies:** 0\
**Last updated:** [August 19, 2025, 6:47am UTC](https://discuss.elastic.co/t/distributed-tracing-implementation-with-self-hosted-net-services/381125 "2025-08-19T06:47:49Z")

</div>

Hello Team, I need your support with distributed tracing implementation for my self hosted services running using .NET8 and Elastic.APM.AspNetCore version 1.30.0. There are 3 self hosted services and a client (develope…

---

## [Log Explorer Removal?](https://discuss.elastic.co/t/log-explorer-removal/380945)

<div class="topic-metadata">

**Author:** [@erikg](https://discuss.elastic.co/u/erikg)\
**Replies:** 1\
**Last updated:** [August 12, 2025, 6:57am UTC](https://discuss.elastic.co/t/log-explorer-removal/380945 "2025-08-12T06:57:17Z")

</div>

Hello, I was wondering how come log explorer got removed or is deperecated? I previously like that this was like quick way to see the data coming from integrations without having to deal with data views. Also the l…

---

## [Rum is not working](https://discuss.elastic.co/t/rum-is-not-working/380870)

<div class="topic-metadata">

**Author:** [@kavya\_agarwal](https://discuss.elastic.co/u/kavya_agarwal)\
**Replies:** 1\
**Last updated:** [August 7, 2025, 1:48pm UTC](https://discuss.elastic.co/t/rum-is-not-working/380870 "2025-08-07T13:48:03Z")

</div>

I created one Rum Test page for nginx with RUM script. curl command is working and giving output 202 command curl -v -X POST htt://10.xx.xx.xx:8200/intake/v2/rum/events -H "Origin: htt://corporateoperation.xx.co.in" …

---

## [Rum is not working](https://discuss.elastic.co/t/rum-is-not-working/380871)

<div class="topic-metadata">

**Author:** [@elastic\_user\_agarwal](https://discuss.elastic.co/u/elastic_user_agarwal)\
**Replies:** 1\
**Last updated:** [August 7, 2025, 1:33pm UTC](https://discuss.elastic.co/t/rum-is-not-working/380871 "2025-08-07T13:33:46Z")

</div>

I created one Rum Test page with RUM script. It is running fineOn app server curl command is also working and giving output 202 command curl -v -X POST http://10.xx.xx.xx:8200/intake/v2/rum/events -H "Origin: http://…

---

## [Metricbeat Openshift - Monitoring only one namespace](https://discuss.elastic.co/t/metricbeat-openshift-monitoring-only-one-namespace/380843)

<div class="topic-metadata">

**Author:** [@LukaszPawlak](https://discuss.elastic.co/u/LukaszPawlak)\
**Replies:** 0\
**Last updated:** [August 6, 2025, 7:58pm UTC](https://discuss.elastic.co/t/metricbeat-openshift-monitoring-only-one-namespace/380843 "2025-08-06T19:58:08Z")

</div>

Hi, I would like to ask you about Metricbeat on Openshift. My case: I would like to implement metricbeat like deployment only on my one namespace. I have possibility to create service account with right permission, …

---

## [Elastic AI Assistant - Function Calls not working from separately hosted Ollama instance running in Docker](https://discuss.elastic.co/t/elastic-ai-assistant-function-calls-not-working-from-separately-hosted-ollama-instance-running-in-docker/380734)

<div class="topic-metadata">

**Author:** [@BBQigniter](https://discuss.elastic.co/u/BBQigniter)\
**Replies:** 1\
**Last updated:** [August 4, 2025, 6:20pm UTC](https://discuss.elastic.co/t/elastic-ai-assistant-function-calls-not-working-from-separately-hosted-ollama-instance-running-in-docker/380734 "2025-08-04T18:20:54Z")

</div>

Hello, for testing purposes I've set up an ECK on a home-server. On the same server there also runs an Ollama instance serving the model hf.co/unsloth/Mistral-Small-3.2-24B-Instruct-2506-GGUF:Q4\_K\_XL. Because I have no …

---

## [Query regarding Synthetics Monitor in Kibana](https://discuss.elastic.co/t/query-regarding-synthetics-monitor-in-kibana/380565)

<div class="topic-metadata">

**Author:** [@Tortoise](https://discuss.elastic.co/u/Tortoise)\
**Replies:** 3\
**Last updated:** [August 4, 2025, 3:21pm UTC](https://discuss.elastic.co/t/query-regarding-synthetics-monitor-in-kibana/380565 "2025-08-04T15:21:08Z")

</div>

Hello Team : Say we create Synthetics monitoring using "HTTP Ping" with below parameters URL Monitor name Locations Frequency Now the Synthetic monitoring is working for Monitor name : ABC If I drill down to monitor …

---

## [APM Data flush API instead of waiting for Flush interval](https://discuss.elastic.co/t/apm-data-flush-api-instead-of-waiting-for-flush-interval/380698)

<div class="topic-metadata">

**Author:** [@Isaack](https://discuss.elastic.co/u/Isaack)\
**Replies:** 0\
**Last updated:** [August 3, 2025, 6:17pm UTC](https://discuss.elastic.co/t/apm-data-flush-api-instead-of-waiting-for-flush-interval/380698 "2025-08-03T18:17:46Z")

</div>

What is the status for adding the APM Data Flush API to .NET? It I see it has been added to some of the other languages.

---

## [Currently experiencing an issue when navigating to APM → Services → Transactions — the page is throwing an error and fails to load properly](https://discuss.elastic.co/t/currently-experiencing-an-issue-when-navigating-to-apm-services-transactions-the-page-is-throwing-an-error-and-fails-to-load-properly/380049)

<div class="topic-metadata">

**Author:** [@Pankaj\_kumar3](https://discuss.elastic.co/u/Pankaj_kumar3)\
**Replies:** 2\
**Last updated:** [August 1, 2025, 10:41am UTC](https://discuss.elastic.co/t/currently-experiencing-an-issue-when-navigating-to-apm-services-transactions-the-page-is-throwing-an-error-and-fails-to-load-properly/380049 "2025-08-01T10:41:24Z")

</div>

Error while fetching resource Error search\_phase\_execution\_exception: \[illegal\_argument\_exception\] Reason: Fielddata is disabled on \[span.type\] in \[traces-apm-default\]. Text fields are not optimised for operations that …

---

## [Invalid Token error from Elastic APM .Net agent](https://discuss.elastic.co/t/invalid-token-error-from-elastic-apm-net-agent/380206)

<div class="topic-metadata">

**Author:** [@kinjalgranicus](https://discuss.elastic.co/u/kinjalgranicus)\
**Replies:** 6\
**Last updated:** [July 24, 2025, 4:11pm UTC](https://discuss.elastic.co/t/invalid-token-error-from-elastic-apm-net-agent/380206 "2025-07-24T16:11:23Z")

</div>

Hello, We have integrated .Net Elastic APM agent version 1.31 with IIS and our applications running on .Net framework 4.8 are throwing Invalid\_Token error. Error 1: Message:Could not load type 'Invalid\_Token.0x010002C…

---

## [Monitor uptime for multiple URL through heartbeat](https://discuss.elastic.co/t/monitor-uptime-for-multiple-url-through-heartbeat/380415)

<div class="topic-metadata">

**Author:** [@Eshwar\_K](https://discuss.elastic.co/u/Eshwar_K)\
**Replies:** 2\
**Last updated:** [July 24, 2025, 9:40am UTC](https://discuss.elastic.co/t/monitor-uptime-for-multiple-url-through-heartbeat/380415 "2025-07-24T09:40:39Z")

</div>

Hi Community, My goal is to monitor uptime for each service. so, we are trying to configure heartbeat to monitor multiple URL to get uptime for each service however heartbeat is considering last http input rather all ht…

---

## [Request for Review – False Positive Flag on MyCleanPC by Elastic (VirusTotal)](https://discuss.elastic.co/t/request-for-review-false-positive-flag-on-mycleanpc-by-elastic-virustotal/380120)

<div class="topic-metadata">

**Author:** [@Reputation](https://discuss.elastic.co/u/Reputation)\
**Replies:** 3\
**Last updated:** [July 21, 2025, 7:43pm UTC](https://discuss.elastic.co/t/request-for-review-false-positive-flag-on-mycleanpc-by-elastic-virustotal/380120 "2025-07-21T19:43:34Z")

</div>

Hello Elastic team, I’m the Reputation Manager at RealDefense, the company behind MyCleanPC, a legitimate PC optimization tool. I’m reaching out regarding a persistent false positive detection by Elastic’s engine on Vir…

---

## [Module 6 Actionable Observability Data Lab 6.3 Alerting](https://discuss.elastic.co/t/module-6-actionable-observability-data-lab-6-3-alerting/379966)

<div class="topic-metadata">

**Author:** [@topebiggs](https://discuss.elastic.co/u/topebiggs)\
**Replies:** 1\
**Last updated:** [July 21, 2025, 1:28pm UTC](https://discuss.elastic.co/t/module-6-actionable-observability-data-lab-6-3-alerting/379966 "2025-07-21T13:28:46Z")

</div>

I am completing a course on Elastic Observability Engineer on Demand, Module 6: Actionable Observability Data, and running Lab 6.3 on Alerting, which requires creating an alert on Step 9. While doing this, I am getting a…

---

## [APM server status not detected](https://discuss.elastic.co/t/apm-server-status-not-detected/377564)

<div class="topic-metadata">

**Author:** [@SamehSaeed](https://discuss.elastic.co/u/SamehSaeed)\
**Replies:** 2\
**Last updated:** [July 21, 2025, 8:54am UTC](https://discuss.elastic.co/t/apm-server-status-not-detected/377564 "2025-07-21T08:54:40Z")

</div>

APM server status is "No APM Server detected" although Elasticsearch is receiving APM logs from multiple servers : Kibana version: 8.17.0 Elasticsearch version: 8.17.0 APM Server version: 8.17.0 APM Agent language…

[Previous page](https://discuss.elastic.co/c/observability/82.md?page=3)

[Next page](https://discuss.elastic.co/c/observability/82.md?page=5)
