# Latest

**URL:** https://discuss.elastic.co/latest.md?page=395

[Latest](https://discuss.elastic.co/latest.md) · [Categories](https://discuss.elastic.co/categories.md) · [Tags](https://discuss.elastic.co/tags.md)

**Page:** 396

---

## [Timeline Error - a.reduce is not a function](https://discuss.elastic.co/t/timeline-error-a-reduce-is-not-a-function/353704)

<div class="topic-metadata">

**Author:** [@cristianhb](https://discuss.elastic.co/u/cristianhb)\
**Replies:** 3\
**Last updated:** [February 20, 2024, 4:52pm UTC](https://discuss.elastic.co/t/timeline-error-a-reduce-is-not-a-function/353704 "2024-02-20T16:52:53Z")

</div>

Hello, We have a fairly simple cluster which has everything in working order. However, the Timeline part does not work for some alerts. There is no correlation we can see between the alerts that this works for and the …

---

## [How to track the count of visitors to a particular dashboard in Kibana](https://discuss.elastic.co/t/how-to-track-the-count-of-visitors-to-a-particular-dashboard-in-kibana/353370)

<div class="topic-metadata">

**Author:** [@ArpithaS](https://discuss.elastic.co/u/ArpithaS)\
**Replies:** 2\
**Last updated:** [February 20, 2024, 4:47pm UTC](https://discuss.elastic.co/t/how-to-track-the-count-of-visitors-to-a-particular-dashboard-in-kibana/353370 "2024-02-20T16:47:21Z")

</div>

How to get the count of visitors to a particular dashboard when anonymous user login(continue as guest without any credentials) is configured?

---

## [Web\_Traffic index not available in engineer course](https://discuss.elastic.co/t/web-traffic-index-not-available-in-engineer-course/353716)

<div class="topic-metadata">

**Author:** [@stan777](https://discuss.elastic.co/u/stan777)\
**Replies:** 1\
**Last updated:** [February 20, 2024, 4:25pm UTC](https://discuss.elastic.co/t/web-traffic-index-not-available-in-engineer-course/353716 "2024-02-20T16:25:17Z")

</div>

Course: Elastic engineer I am on module 5 of the Elastic Engineer on demand course. The lab references an index called web\_traffic, however the index does not exist on the lab environment. I would just skip the module,…

---

## [How can i restrict only http post api requests to logstash](https://discuss.elastic.co/t/how-can-i-restrict-only-http-post-api-requests-to-logstash/353685)

<div class="topic-metadata">

**Author:** [@kashyap\_kapadia](https://discuss.elastic.co/u/kashyap_kapadia)\
**Replies:** 3\
**Last updated:** [February 20, 2024, 3:28pm UTC](https://discuss.elastic.co/t/how-can-i-restrict-only-http-post-api-requests-to-logstash/353685 "2024-02-20T15:28:14Z")

</div>

Hi All, i want to restrict only https POST call to be accepted by logstash for which i did multiple options in http input section as shown below: input { http { port =\> 5400 ssl\_enabled =\> true s…

---

## [Create Multiple Rows and Columns with Data Table](https://discuss.elastic.co/t/create-multiple-rows-and-columns-with-data-table/353619)

<div class="topic-metadata">

**Author:** [@Sujit\_Kumbhar](https://discuss.elastic.co/u/Sujit_Kumbhar)\
**Replies:** 7\
**Last updated:** [February 20, 2024, 2:56pm UTC](https://discuss.elastic.co/t/create-multiple-rows-and-columns-with-data-table/353619 "2024-02-20T14:56:29Z")

</div>

Hi, I want to display the Data in Table Format as per below structure. So, My question is it Possible to create the Kibana dashboard with above image format

---

## [Java APM agent does override default method, causing no-op tracing](https://discuss.elastic.co/t/java-apm-agent-does-override-default-method-causing-no-op-tracing/352637)

<div class="topic-metadata">

**Author:** [@bebeDobreRano](https://discuss.elastic.co/u/bebeDobreRano)\
**Replies:** 5\
**Last updated:** [February 20, 2024, 2:38pm UTC](https://discuss.elastic.co/t/java-apm-agent-does-override-default-method-causing-no-op-tracing/352637 "2024-02-20T14:38:09Z")

</div>

Elasticsearch Java client version 8.11.1 Kibana version: 8.9.1 APM Elasticsearch version: 8.9.1 APM Server version: 8.9.1 APM Agent language and version: Java, 1.46.0 Hello, I originally wanted to create githu…

---

## [Scale testing logstash beat input](https://discuss.elastic.co/t/scale-testing-logstash-beat-input/353705)

<div class="topic-metadata">

**Author:** [@Vivek\_Shinde](https://discuss.elastic.co/u/Vivek_Shinde)\
**Replies:** 0\
**Last updated:** [February 20, 2024, 2:35pm UTC](https://discuss.elastic.co/t/scale-testing-logstash-beat-input/353705 "2024-02-20T14:35:43Z")

</div>

Hi - Any suggestions to test the logstash beat input under load, e.g like simulating metricbeat data for thousands of the machines.

---

## [Terms aggregation on a nested field using Java SDK?](https://discuss.elastic.co/t/terms-aggregation-on-a-nested-field-using-java-sdk/353634)

<div class="topic-metadata">

**Author:** [@ndtreviv](https://discuss.elastic.co/u/ndtreviv)\
**Replies:** 6\
**Last updated:** [February 20, 2024, 2:28pm UTC](https://discuss.elastic.co/t/terms-aggregation-on-a-nested-field-using-java-sdk/353634 "2024-02-20T14:28:23Z")

</div>

I have a document mapping that looks like this: "domain": { "type": "nested", "properties": { "name": { "type": "keyword", "store": true }, "tl…

---

## [Failed to parse date field \[-386391600\] with format \[epoch\_millis\]](https://discuss.elastic.co/t/failed-to-parse-date-field-386391600-with-format-epoch-millis/353444)

<div class="topic-metadata">

**Author:** [@persik665](https://discuss.elastic.co/u/persik665)\
**Replies:** 6\
**Last updated:** [February 20, 2024, 2:23pm UTC](https://discuss.elastic.co/t/failed-to-parse-date-field-386391600-with-format-epoch-millis/353444 "2024-02-20T14:23:35Z")

</div>

Hi all, we have a problem with bulk requests: \[ElasticsearchException\[Elasticsearch exception \[type=mapper\_parsing\_exception, reason=failed to parse field \[clientBirthday\] of type \[date\] in document with id 'lBWSpo0B8q…

---

## [Could not locate that index-pattern (id:b76afda0-cf11....)](https://discuss.elastic.co/t/could-not-locate-that-index-pattern-id-b76afda0-cf11/353701)

<div class="topic-metadata">

**Author:** [@edgarmat1964](https://discuss.elastic.co/u/edgarmat1964)\
**Replies:** 0\
**Last updated:** [February 20, 2024, 1:59pm UTC](https://discuss.elastic.co/t/could-not-locate-that-index-pattern-id-b76afda0-cf11/353701 "2024-02-20T13:59:33Z")

</div>

LS, I'm using elastic/kibana 7.17 on RHEL 8. I've deleted some indices named appl-platform- and corresponding index patterns (appl-platform-), uploaded new data into elasticsearch and created a new index-pattern with th…

---

## [Specific Kibana filter in iframe URL and filter bar](https://discuss.elastic.co/t/specific-kibana-filter-in-iframe-url-and-filter-bar/353672)

<div class="topic-metadata">

**Author:** [@skouf](https://discuss.elastic.co/u/skouf)\
**Replies:** 2\
**Last updated:** [February 20, 2024, 1:45pm UTC](https://discuss.elastic.co/t/specific-kibana-filter-in-iframe-url-and-filter-bar/353672 "2024-02-20T13:45:56Z")

</div>

Hello I saw many topic regarding this subject. But I need to add mine because maybe there are some solutions that exists since. I am using Elastic and Kibana 7 I need to pass some specific filters to my iframe from my…

---

## [On restarting filebeat, every filestream paths input is deemed to be truncated](https://discuss.elastic.co/t/on-restarting-filebeat-every-filestream-paths-input-is-deemed-to-be-truncated/353337)

<div class="topic-metadata">

**Author:** [@Dheeraj\_Gupta](https://discuss.elastic.co/u/Dheeraj_Gupta)\
**Replies:** 6\
**Last updated:** [February 20, 2024, 1:32pm UTC](https://discuss.elastic.co/t/on-restarting-filebeat-every-filestream-paths-input-is-deemed-to-be-truncated/353337 "2024-02-20T13:32:05Z")

</div>

Hi, We are using filebeat to ship Zeek logs to logstash. We do this by defining a different filestream input for each type of log and in the input we define the path filebeat.yml path.home: /usr/share/filebeat path.da…

---

## [Logstash - The default timestamp field does not match my log field](https://discuss.elastic.co/t/logstash-the-default-timestamp-field-does-not-match-my-log-field/353622)

<div class="topic-metadata">

**Author:** [@ozonshak](https://discuss.elastic.co/u/ozonshak)\
**Replies:** 5\
**Last updated:** [February 20, 2024, 1:16pm UTC](https://discuss.elastic.co/t/logstash-the-default-timestamp-field-does-not-match-my-log-field/353622 "2024-02-20T13:16:36Z")

</div>

Hello. I have an existing Elastic stack that is pulling in app and web server logs. For the web site, I have 2 software stacks - 1 is using an older apache format (comma separated values) and 1 is using a newer JSON form…

---

## [ElasticSearch failed to apply default image tag in OpenShift deployment](https://discuss.elastic.co/t/elasticsearch-failed-to-apply-default-image-tag-in-openshift-deployment/353630)

<div class="topic-metadata">

**Author:** [@Mike\_Kirby](https://discuss.elastic.co/u/Mike_Kirby)\
**Replies:** 2\
**Last updated:** [February 20, 2024, 12:54pm UTC](https://discuss.elastic.co/t/elasticsearch-failed-to-apply-default-image-tag-in-openshift-deployment/353630 "2024-02-20T12:54:20Z")

</div>

Good Afternoon my Elastic Guru's. I am in the process of using the Docker image of 8.11.4 to deploy Elasticsearch in an OpenShift envirorment. I am using the OpenShift User interface and it should be a simple enough ta…

---

## [Year to date visualization](https://discuss.elastic.co/t/year-to-date-visualization/353539)

<div class="topic-metadata">

**Author:** [@Senol\_Kurt](https://discuss.elastic.co/u/Senol_Kurt)\
**Replies:** 3\
**Last updated:** [February 20, 2024, 12:41pm UTC](https://discuss.elastic.co/t/year-to-date-visualization/353539 "2024-02-20T12:41:15Z")

</div>

i have an index that holds monthly aggregated sales data. i want to visualize year to date sales for each month. can i do it without creating a new field and what is the best way to do it?

---

## [ECK on GKE with local SSDs](https://discuss.elastic.co/t/eck-on-gke-with-local-ssds/353689)

<div class="topic-metadata">

**Author:** [@rh\_at](https://discuss.elastic.co/u/rh_at)\
**Replies:** 0\
**Last updated:** [February 20, 2024, 12:39pm UTC](https://discuss.elastic.co/t/eck-on-gke-with-local-ssds/353689 "2024-02-20T12:39:00Z")

</div>

Hi all, We've set a new elasticsearch cluster to store skywalking data. Settings are as following: 6 data nodes, each 16GB RAM (around 50% heap size), 16 cores, 4\*375G local SSDs disks (thats about 1.5TB each) 3 maste…

---

## [Block results for search terms](https://discuss.elastic.co/t/block-results-for-search-terms/353615)

<div class="topic-metadata">

**Author:** [@syrupman](https://discuss.elastic.co/u/syrupman)\
**Replies:** 1\
**Last updated:** [February 20, 2024, 12:37pm UTC](https://discuss.elastic.co/t/block-results-for-search-terms/353615 "2024-02-20T12:37:50Z")

</div>

We are using elastic.co to search images in our ecommerce with ELSER. Knowing that AI/ML will eventually commit a faux-paus, we need to be able to add negative words to each item so they won't show up on searches with t…

---

## [Kibana returns 404](https://discuss.elastic.co/t/kibana-returns-404/352342)

<div class="topic-metadata">

**Author:** [@Reclocco](https://discuss.elastic.co/u/Reclocco)\
**Replies:** 9\
**Last updated:** [February 20, 2024, 11:49am UTC](https://discuss.elastic.co/t/kibana-returns-404/352342 "2024-02-20T11:49:05Z")

</div>

Hi everyone i have a problem where kibana stopped working at some point without any tinkering with config. I checked the nginx routing etc and that seems to be fine 'security' is not enabled elasticsearch is green \[r…

---

## [APM latency statistics not showing any data](https://discuss.elastic.co/t/apm-latency-statistics-not-showing-any-data/353517)

<div class="topic-metadata">

**Author:** [@bassem\_abdalftah](https://discuss.elastic.co/u/bassem_abdalftah)\
**Replies:** 0\
**Last updated:** [February 18, 2024, 12:34pm UTC](https://discuss.elastic.co/t/apm-latency-statistics-not-showing-any-data/353517 "2024-02-18T12:34:02Z")

</div>

Kibana version: 8.3.3 Elasticsearch version:8.3.3 APM Server version:8.3.3 APM Agent language and version: java Fresh install or upgraded from other version? Fresh install APM latency statistics showing no data, how…

---

## [Logstash.service unable to access Keystore](https://discuss.elastic.co/t/logstash-service-unable-to-access-keystore/353628)

<div class="topic-metadata">

**Author:** [@marmai16](https://discuss.elastic.co/u/marmai16)\
**Replies:** 7\
**Last updated:** [February 20, 2024, 11:48am UTC](https://discuss.elastic.co/t/logstash-service-unable-to-access-keystore/353628 "2024-02-20T11:48:06Z")

</div>

Hello everyone, while trying to setup a test Logstash instance, i struggle to get it running. The following error appears, viewable via journalctl: ERROR: Failed to load settings file from "path.settings". Aborting...…

---

## [Failed to restore an incremental snapshot](https://discuss.elastic.co/t/failed-to-restore-an-incremental-snapshot/353657)

<div class="topic-metadata">

**Author:** [@praval\_singhal](https://discuss.elastic.co/u/praval_singhal)\
**Replies:** 6\
**Last updated:** [February 20, 2024, 11:42am UTC](https://discuss.elastic.co/t/failed-to-restore-an-incremental-snapshot/353657 "2024-02-20T11:42:38Z")

</div>

I have been trying to restore an incremental snapshot for my ES cluster stored in azure storage account. I am getting this error {"error":{"root\_cause":\[{"type":"snapshot\_restore\_exception","reason":"\[elasticsearch\_sna…

---

## [Log\_ecs\_reformatting not reformatting](https://discuss.elastic.co/t/log-ecs-reformatting-not-reformatting/353119)

<div class="topic-metadata">

**Author:** [@Dileesha](https://discuss.elastic.co/u/Dileesha)\
**Replies:** 1\
**Last updated:** [February 20, 2024, 11:41am UTC](https://discuss.elastic.co/t/log-ecs-reformatting-not-reformatting/353119 "2024-02-20T11:41:41Z")

</div>

Kibana version:8.11.1 Elasticsearch version:8.11.1 APM Server version:8.11.1 APM Agent language and version:Java - 1.34.0 I'm trying to monitor my Spring Boot logs with Elasticsearch, and currently, the logs are succ…

---

## [Get only one fileld that is common accoss different indices, like SQL join on tables](https://discuss.elastic.co/t/get-only-one-fileld-that-is-common-accoss-different-indices-like-sql-join-on-tables/353677)

<div class="topic-metadata">

**Author:** [@PRASHANT\_MEHTA](https://discuss.elastic.co/u/PRASHANT_MEHTA)\
**Replies:** 0\
**Last updated:** [February 20, 2024, 11:08am UTC](https://discuss.elastic.co/t/get-only-one-fileld-that-is-common-accoss-different-indices-like-sql-join-on-tables/353677 "2024-02-20T11:08:14Z")

</div>

Hello All, Can someone please let me know I have a requirement to make dashboard which shows which usecases/ index are critical to be shown with status Heathy in green color and Red Critical. Below is image I have achi…

---

## [Sort by Relevance Logic](https://discuss.elastic.co/t/sort-by-relevance-logic/353643)

<div class="topic-metadata">

**Author:** [@aisyaharifin](https://discuss.elastic.co/u/aisyaharifin)\
**Replies:** 1\
**Last updated:** [February 20, 2024, 11:04am UTC](https://discuss.elastic.co/t/sort-by-relevance-logic/353643 "2024-02-20T11:04:31Z")

</div>

Hi I want to get confirmation on the Search UI for SORT Relevance right, I want to understand the logic behind this sort, is the relevance sort will sort according to the search score? Thanks.

---

## [Not able to get all RDS metrics to Elasticsearch](https://discuss.elastic.co/t/not-able-to-get-all-rds-metrics-to-elasticsearch/353676)

<div class="topic-metadata">

**Author:** [@arvind297](https://discuss.elastic.co/u/arvind297)\
**Replies:** 0\
**Last updated:** [February 20, 2024, 11:04am UTC](https://discuss.elastic.co/t/not-able-to-get-all-rds-metrics-to-elasticsearch/353676 "2024-02-20T11:04:12Z")

</div>

Hi, We are trying to configure elasticagent to send RDS metrics to Elasticsearch. Able to configure using AWS RDS integration and we are getting the metrics. But not getting all the metrics.From the documentation i unde…

---

## [Elasticsaerch Query with exact match with stemmer apply](https://discuss.elastic.co/t/elasticsaerch-query-with-exact-match-with-stemmer-apply/353675)

<div class="topic-metadata">

**Author:** [@Mohan\_T](https://discuss.elastic.co/u/Mohan_T)\
**Replies:** 0\
**Last updated:** [February 20, 2024, 11:03am UTC](https://discuss.elastic.co/t/elasticsaerch-query-with-exact-match-with-stemmer-apply/353675 "2024-02-20T11:03:40Z")

</div>

To fetch the exact match I have applied Ex: keywords.keyword\_values.keyword mappings: "keywords": { "type": "object", "enabled": True, "properties": { "keyword\_values": { "type": "text"…

---

## [How to refer doc\_count in MovingFunctions.ewma aggregation bucket path?](https://discuss.elastic.co/t/how-to-refer-doc-count-in-movingfunctions-ewma-aggregation-bucket-path/353602)

<div class="topic-metadata">

**Author:** [@Abinash\_Raja](https://discuss.elastic.co/u/Abinash_Raja)\
**Replies:** 1\
**Last updated:** [February 20, 2024, 10:47am UTC](https://discuss.elastic.co/t/how-to-refer-doc-count-in-movingfunctions-ewma-aggregation-bucket-path/353602 "2024-02-20T10:47:32Z")

</div>

Hi, Is there a way to directly refer the doc\_count of date histogram(over time\_millis field) bucket(s) in MovingFunctions.ewma bucket path, instead of creating a separate value\_count aggregation (for the same field time…

---

## [Illegal\_state\_exception: no rollover info found for \[logstash-2024.02.16\] with rollover target \[logstash-\], the index has not yet rolled over with that target](https://discuss.elastic.co/t/illegal-state-exception-no-rollover-info-found-for-logstash-2024-02-16-with-rollover-target-logstash-the-index-has-not-yet-rolled-over-with-that-target/353667)

<div class="topic-metadata">

**Author:** [@martianzz](https://discuss.elastic.co/u/martianzz)\
**Replies:** 0\
**Last updated:** [February 20, 2024, 9:46am UTC](https://discuss.elastic.co/t/illegal-state-exception-no-rollover-info-found-for-logstash-2024-02-16-with-rollover-target-logstash-the-index-has-not-yet-rolled-over-with-that-target/353667 "2024-02-20T09:46:00Z")

</div>

illegal\_state\_exception: no rollover info found for \[logstash-2024.02.16\] with rollover target \[logstash-\], the index has not yet rolled over with that target. Why is this error always coming. How to solve it

---

## [Hardware profiles for Hot/Warm tiers](https://discuss.elastic.co/t/hardware-profiles-for-hot-warm-tiers/353582)

<div class="topic-metadata">

**Author:** [@intrepid1](https://discuss.elastic.co/u/intrepid1)\
**Replies:** 2\
**Last updated:** [February 20, 2024, 9:01am UTC](https://discuss.elastic.co/t/hardware-profiles-for-hot-warm-tiers/353582 "2024-02-20T09:01:40Z")

</div>

Hi there, We are in the process of moving our on-premise logging cluster to AWS on EC2 and would like to use a hot/warm architecture. The aim is to place the data on the hardware that is most suited to, allowing multipl…

---

## [Elastic Search Deployment](https://discuss.elastic.co/t/elastic-search-deployment/351967)

<div class="topic-metadata">

**Author:** [@Karthikeyan\_K](https://discuss.elastic.co/u/Karthikeyan_K)\
**Replies:** 22\
**Last updated:** [February 20, 2024, 8:43am UTC](https://discuss.elastic.co/t/elastic-search-deployment/351967 "2024-02-20T08:43:50Z")

</div>

Hi, I am trying to install Elastic Stack in my local machine. I downloaded elasticsearch-8.11.3-windows-x86\_64. When I try to run the batch file I get the following error message. " fatal exception while booting Elastic…

[Previous page](https://discuss.elastic.co/latest.md?page=394)

[Next page](https://discuss.elastic.co/latest.md?page=396)
