# Latest

**URL:** https://discuss.elastic.co/latest.md?page=403

[Latest](https://discuss.elastic.co/latest.md) · [Categories](https://discuss.elastic.co/categories.md) · [Tags](https://discuss.elastic.co/tags.md)

**Page:** 404

---

## [Evaluate the quality of ranked search results in Enterprise App Search](https://discuss.elastic.co/t/evaluate-the-quality-of-ranked-search-results-in-enterprise-app-search/353182)

<div class="topic-metadata">

**Author:** [@jeferson-telia](https://discuss.elastic.co/u/jeferson-telia)\
**Replies:** 2\
**Last updated:** [February 13, 2024, 3:30pm UTC](https://discuss.elastic.co/t/evaluate-the-quality-of-ranked-search-results-in-enterprise-app-search/353182 "2024-02-13T15:30:23Z")

</div>

Hello, I’m trying to find a way to validate search results for different queries. I found search-rank-eval API (Ranking evaluation API | Elasticsearch Guide \[8.12\] | Elastic), which seems to do what I need. The issue is…

---

## [Elastic query when executed from dev tools gives top 1 record, when same through logstash gives many record in Index](https://discuss.elastic.co/t/elastic-query-when-executed-from-dev-tools-gives-top-1-record-when-same-through-logstash-gives-many-record-in-index/353067)

<div class="topic-metadata">

**Author:** [@PRASHANT\_MEHTA](https://discuss.elastic.co/u/PRASHANT_MEHTA)\
**Replies:** 1\
**Last updated:** [February 13, 2024, 7:12am UTC](https://discuss.elastic.co/t/elastic-query-when-executed-from-dev-tools-gives-top-1-record-when-same-through-logstash-gives-many-record-in-index/353067 "2024-02-13T07:12:38Z")

</div>

Hello All, I am trying to send two fields from mis-monitoring-webserver to new index mis-monitoring-webui. Issue faced: This webserver index gets data every 10 seconds and from this my expectation is- I have written sp…

---

## [Timeout errors Elastic GitHub Workflow Runner](https://discuss.elastic.co/t/timeout-errors-elastic-github-workflow-runner/353064)

<div class="topic-metadata">

**Author:** [@christos-P](https://discuss.elastic.co/u/christos-P)\
**Replies:** 2\
**Last updated:** [February 13, 2024, 2:18pm UTC](https://discuss.elastic.co/t/timeout-errors-elastic-github-workflow-runner/353064 "2024-02-13T14:18:58Z")

</div>

Hi all, We have our code hosted in GitHub, and we utilize GitHub workflows for our CI/CD pipeline. On each push in a feature branch, based on a docker compose file , in which we describe two services, two services are s…

---

## [System Integration dashboard somehow broken](https://discuss.elastic.co/t/system-integration-dashboard-somehow-broken/353177)

<div class="topic-metadata">

**Author:** [@Alphayeeeet](https://discuss.elastic.co/u/Alphayeeeet)\
**Replies:** 1\
**Last updated:** [February 13, 2024, 2:15pm UTC](https://discuss.elastic.co/t/system-integration-dashboard-somehow-broken/353177 "2024-02-13T14:15:03Z")

</div>

I completely uninstalled and reinstalled the integration and it didnt help (as it is caused by the aggregation in the dashboard). My Dashbaord visualization is like this: There are some missing values (I do use the …

---

## [Logstash as a Statefulset in Kubernetes - File Input and duplicated logs](https://discuss.elastic.co/t/logstash-as-a-statefulset-in-kubernetes-file-input-and-duplicated-logs/353162)

<div class="topic-metadata">

**Author:** [@veramendi](https://discuss.elastic.co/u/veramendi)\
**Replies:** 6\
**Last updated:** [February 13, 2024, 1:52pm UTC](https://discuss.elastic.co/t/logstash-as-a-statefulset-in-kubernetes-file-input-and-duplicated-logs/353162 "2024-02-13T13:52:06Z")

</div>

Hello, I am trying to deploy a multiple pod logstash Statefulset on a kubernetes cluster using the Input File type. It looks like each pod is reading the same logs from the logfile placed on a PVC, and therefore we are…

---

## [Elasticsearch tuning](https://discuss.elastic.co/t/elasticsearch-tuning/353163)

<div class="topic-metadata">

**Author:** [@Mathews\_Ignatius](https://discuss.elastic.co/u/Mathews_Ignatius)\
**Replies:** 3\
**Last updated:** [February 13, 2024, 1:47pm UTC](https://discuss.elastic.co/t/elasticsearch-tuning/353163 "2024-02-13T13:47:59Z")

</div>

Hi, I am trying to reduce storage size of index. I tried customising the mapping, shrinking shards, compression algorithms and all but nothing seems to work the size is not getting reduced. Is there anything else that c…

---

## [Kibana deprecated settings](https://discuss.elastic.co/t/kibana-deprecated-settings/352747)

<div class="topic-metadata">

**Author:** [@miiroslavkardos](https://discuss.elastic.co/u/miiroslavkardos)\
**Replies:** 10\
**Last updated:** [February 13, 2024, 1:31pm UTC](https://discuss.elastic.co/t/kibana-deprecated-settings/352747 "2024-02-13T13:31:19Z")

</div>

Hello, Can you help me, how to get of rid of this deprecated setting in KIbana GUI under Upgrade asistant? I Already removed these settings in my kibana.yml but it is still shwoing. How to fix Remove the "xpack.repor…

---

## [ECK Enterprise Search: Pre-flight check with Kibana connection refused](https://discuss.elastic.co/t/eck-enterprise-search-pre-flight-check-with-kibana-connection-refused/352208)

<div class="topic-metadata">

**Author:** [@johnmcav](https://discuss.elastic.co/u/johnmcav)\
**Replies:** 1\
**Last updated:** [February 13, 2024, 1:05pm UTC](https://discuss.elastic.co/t/eck-enterprise-search-pre-flight-check-with-kibana-connection-refused/352208 "2024-02-13T13:05:59Z")

</div>

We have a requirement to use the web crawler to ingest pages from our organisation's own websites. We currently connect to Elasticsearch v7.17 hosted on IBM Cloud with Enterprise Search version 7.17 and Kibana version 7…

---

## [Data fs grows forever after full snapshot is taken](https://discuss.elastic.co/t/data-fs-grows-forever-after-full-snapshot-is-taken/353139)

<div class="topic-metadata">

**Author:** [@TinaMartiello](https://discuss.elastic.co/u/TinaMartiello)\
**Replies:** 4\
**Last updated:** [February 13, 2024, 1:10pm UTC](https://discuss.elastic.co/t/data-fs-grows-forever-after-full-snapshot-is-taken/353139 "2024-02-13T13:10:42Z")

</div>

Hi, we have 3 elasticsearch nodes, elasticsearch-8.11.1-1.x86\_64 and CentOS Linux release 7.3.1611 (Core) o.s. are installed on premis. We have very busy read/write systems. We are taking a full snapshot once a day, o…

---

## [Export/Import ES 7 to ES 8](https://discuss.elastic.co/t/export-import-es-7-to-es-8/353159)

<div class="topic-metadata">

**Author:** [@omegaziv](https://discuss.elastic.co/u/omegaziv)\
**Replies:** 1\
**Last updated:** [February 13, 2024, 1:03pm UTC](https://discuss.elastic.co/t/export-import-es-7-to-es-8/353159 "2024-02-13T13:03:12Z")

</div>

Hello. we have ES 7 with 3 GB of data. We will migrate to ES 8. and we are looking for the best way. is there an upgrade procedure without moving the data? we tried to export the data for later import - but it took o…

---

## [Downsampling policy](https://discuss.elastic.co/t/downsampling-policy/353106)

<div class="topic-metadata">

**Author:** [@noambe991](https://discuss.elastic.co/u/noambe991)\
**Replies:** 0\
**Last updated:** [February 12, 2024, 8:08pm UTC](https://discuss.elastic.co/t/downsampling-policy/353106 "2024-02-12T20:08:34Z")

</div>

Hello, I'm trying to define a policy for my time-series data stream as follows: "policy": { "phases": { "warm": { "min\_age": "0d", "actions": { "readonly": {}, …

---

## [Integration Oracle Cloud Kafka + Elastic-agent doesn't work](https://discuss.elastic.co/t/integration-oracle-cloud-kafka-elastic-agent-doesnt-work/353155)

<div class="topic-metadata">

**Author:** [@Death](https://discuss.elastic.co/u/Death)\
**Replies:** 0\
**Last updated:** [February 13, 2024, 10:57am UTC](https://discuss.elastic.co/t/integration-oracle-cloud-kafka-elastic-agent-doesnt-work/353155 "2024-02-13T10:57:20Z")

</div>

Good afternoon. At the moment, there was an attempt to connect to collect logs from Oracle cloud Audit logs via Kafka, and everything worked through logstash. Now when I try to use Custom Kafka Integration in elasticsear…

---

## [Script.painless.regex.enabled: true Is not enough to disable limits](https://discuss.elastic.co/t/script-painless-regex-enabled-true-is-not-enough-to-disable-limits/353153)

<div class="topic-metadata">

**Author:** [@Saief](https://discuss.elastic.co/u/Saief)\
**Replies:** 0\
**Last updated:** [February 13, 2024, 10:49am UTC](https://discuss.elastic.co/t/script-painless-regex-enabled-true-is-not-enough-to-disable-limits/353153 "2024-02-13T10:49:42Z")

</div>

Hello, ES vesion : 8.12.0 I want to use scripting when search documents. I activated "script.painless.regex.enabled: true" in purpose to avoid limiting chars, But in my cluster settings, I still see : "painless":{"re…

---

## [ELK configuration for OpenShift](https://discuss.elastic.co/t/elk-configuration-for-openshift/353149)

<div class="topic-metadata">

**Author:** [@ayoub\_souihel](https://discuss.elastic.co/u/ayoub_souihel)\
**Replies:** 0\
**Last updated:** [February 13, 2024, 10:27am UTC](https://discuss.elastic.co/t/elk-configuration-for-openshift/353149 "2024-02-13T10:27:00Z")

</div>

Hello , i am a very new to ELK , i have set up a single node cluster ( Elasticsearch , kibana , logstash ) , i have configured the logforwarder on openshift correctly ( i see elasticsearch logs showing logs recieved fro…

---

## [elastic connectors has error : cannot import name 'coroutine' from 'asyncio'](https://discuss.elastic.co/t/elastic-connectors-has-error-cannot-import-name-coroutine-from-asyncio/353019)

<div class="topic-metadata">

**Author:** [@trunglh88](https://discuss.elastic.co/u/trunglh88)\
**Replies:** 4\
**Last updated:** [February 13, 2024, 9:33am UTC](https://discuss.elastic.co/t/elastic-connectors-has-error-cannot-import-name-coroutine-from-asyncio/353019 "2024-02-13T09:33:28Z")

</div>

i using elastic connectors to mongodb with docker, when i run then elastic connectors show error like this this is config.yml connectors: - connector\_id: "id\_here" service\_type: "mongodb" api\_key: "key\_in\_here…

---

## [Performance problem because of read IOPS increase](https://discuss.elastic.co/t/performance-problem-because-of-read-iops-increase/353074)

<div class="topic-metadata">

**Author:** [@jnegredo](https://discuss.elastic.co/u/jnegredo)\
**Replies:** 4\
**Last updated:** [February 13, 2024, 9:28am UTC](https://discuss.elastic.co/t/performance-problem-because-of-read-iops-increase/353074 "2024-02-13T09:28:55Z")

</div>

Hi, I've a elasticsearch cluster with 3 nodes (version 6.8.0). It's deployed on 3 virtual machines with 16GB RAM and 4 cores, in Google Cloud. Usually we have a lot more wirting IOPS than reading (40-50 vs 0-5) without …

---

## [Will the Workplace Search interface remain as it is merged with Elasticsearch?](https://discuss.elastic.co/t/will-the-workplace-search-interface-remain-as-it-is-merged-with-elasticsearch/353109)

<div class="topic-metadata">

**Author:** [@catmanjan](https://discuss.elastic.co/u/catmanjan)\
**Replies:** 1\
**Last updated:** [February 13, 2024, 8:59am UTC](https://discuss.elastic.co/t/will-the-workplace-search-interface-remain-as-it-is-merged-with-elasticsearch/353109 "2024-02-13T08:59:50Z")

</div>

I refer to this blog post Evolution of Workplace Search: Search your private data with Elasticsearch | Elastic Blog So it seems the Workplace Search concept is being removed/replaced - but it isn't clear to me whether t…

---

## [Useruuid,tracingId and correlationId field is not comming in logstash](https://discuss.elastic.co/t/useruuid-tracingid-and-correlationid-field-is-not-comming-in-logstash/351537)

<div class="topic-metadata">

**Author:** [@vikascateina](https://discuss.elastic.co/u/vikascateina)\
**Replies:** 4\
**Last updated:** [February 13, 2024, 5:32am UTC](https://discuss.elastic.co/t/useruuid-tracingid-and-correlationid-field-is-not-comming-in-logstash/351537 "2024-02-13T05:32:15Z")

</div>

Not able to see Useruuid,tracingId and correlationId field in logs in logstash which is comming from mule but it is comming in message field in logstash.Below is my logstash.conf file and I have attached the screenshot a…

---

## [Trouble configuring APM Server on K8 with ECK](https://discuss.elastic.co/t/trouble-configuring-apm-server-on-k8-with-eck/352965)

<div class="topic-metadata">

**Author:** [@anavarro10](https://discuss.elastic.co/u/anavarro10)\
**Replies:** 0\
**Last updated:** [February 9, 2024, 6:16pm UTC](https://discuss.elastic.co/t/trouble-configuring-apm-server-on-k8-with-eck/352965 "2024-02-09T18:16:07Z")

</div>

Kibana version: 8.11.1 Elasticsearch version: 8.11.1 APM Server version: 8.11.1 APM Agent language and version: Python Browser version: Version 121.0.6167.140 (Official Build) (64-bit) Original install method (…

---

## [Failed to obtain node locks, tried \[/usr/share/elasticsearch/data\]](https://discuss.elastic.co/t/failed-to-obtain-node-locks-tried-usr-share-elasticsearch-data/353107)

<div class="topic-metadata">

**Author:** [@ebonybubbles](https://discuss.elastic.co/u/ebonybubbles)\
**Replies:** 0\
**Last updated:** [February 12, 2024, 9:01pm UTC](https://discuss.elastic.co/t/failed-to-obtain-node-locks-tried-usr-share-elasticsearch-data/353107 "2024-02-12T21:01:54Z")

</div>

Hello Team, I have installed ECK Operator(v2.11.1). Installation of the operator is successful. If I am creating Elasticsearch cluster via an operator, pods are getting crashed with following error: {"@timestamp":"2024…

---

## [Filebeat: How to create multiple instances/pipelines on same VM](https://discuss.elastic.co/t/filebeat-how-to-create-multiple-instances-pipelines-on-same-vm/352999)

<div class="topic-metadata">

**Author:** [@albus](https://discuss.elastic.co/u/albus)\
**Replies:** 5\
**Last updated:** [February 12, 2024, 7:51pm UTC](https://discuss.elastic.co/t/filebeat-how-to-create-multiple-instances-pipelines-on-same-vm/352999 "2024-02-12T19:51:38Z")

</div>

Hello Elastic Community, I hope everybody is doing great. I am facing a problem and I cannot find any documentation or blog related to it. Problem statement is: Is there a possibility to run multiple instances of Fileb…

---

## [Primary shard not available](https://discuss.elastic.co/t/primary-shard-not-available/352938)

<div class="topic-metadata">

**Author:** [@Manal\_A](https://discuss.elastic.co/u/Manal_A)\
**Replies:** 3\
**Last updated:** [February 12, 2024, 7:41pm UTC](https://discuss.elastic.co/t/primary-shard-not-available/352938 "2024-02-12T19:41:34Z")

</div>

Hi after i've receive disk full i try to remove some indices from this path: elasticsearch/indices/ after the status of the cluster become red and give below errors: is there any way to fix it please?

---

## [Sorting of classes while getting top 10 classes by each category using aggregation](https://discuss.elastic.co/t/sorting-of-classes-while-getting-top-10-classes-by-each-category-using-aggregation/352620)

<div class="topic-metadata">

**Author:** [@Vaibhav\_Vidhate](https://discuss.elastic.co/u/Vaibhav_Vidhate)\
**Replies:** 1\
**Last updated:** [February 12, 2024, 7:10pm UTC](https://discuss.elastic.co/t/sorting-of-classes-while-getting-top-10-classes-by-each-category-using-aggregation/352620 "2024-02-12T19:10:50Z")

</div>

We are using Elasticsearch for searching classes and showing a list of featured classes. Each class can have many categories assigned. For each class, sort order is defined within each category assigned. We need to ret…

---

## [.net client (8.12) converts params data properties to camelCase but i use PascalCase](https://discuss.elastic.co/t/net-client-8-12-converts-params-data-properties-to-camelcase-but-i-use-pascalcase/353101)

<div class="topic-metadata">

**Author:** [@Nazim\_Kirma](https://discuss.elastic.co/u/Nazim_Kirma)\
**Replies:** 0\
**Last updated:** [February 12, 2024, 7:05pm UTC](https://discuss.elastic.co/t/net-client-8-12-converts-params-data-properties-to-camelcase-but-i-use-pascalcase/353101 "2024-02-12T19:05:13Z")

</div>

Hi all, I use .net client to index my documents. I use nested field to update arrays and add new objects. I use the PascalCase configuration for Properties. This is my configuration : var node = new SingleNodePool(new…

---

## [Platinum License - Restore from Elastic 6.X to Elastic 8.X](https://discuss.elastic.co/t/platinum-license-restore-from-elastic-6-x-to-elastic-8-x/353098)

<div class="topic-metadata">

**Author:** [@Joao\_Barreto](https://discuss.elastic.co/u/Joao_Barreto)\
**Replies:** 4\
**Last updated:** [February 12, 2024, 6:55pm UTC](https://discuss.elastic.co/t/platinum-license-restore-from-elastic-6-x-to-elastic-8-x/353098 "2024-02-12T18:55:57Z")

</div>

Dear friends, I've made a snapshot on our customer Elastic Search 6.X, and I'm trying to restore it in a new infrastructure with Elastic Search 8.X. I'm using Kibana (Dev Tools/Console) to manage the execution of the c…

---

## [Moving shapshot between computers (again)](https://discuss.elastic.co/t/moving-shapshot-between-computers-again/352963)

<div class="topic-metadata">

**Author:** [@kwalcock](https://discuss.elastic.co/u/kwalcock)\
**Replies:** 7\
**Last updated:** [February 12, 2024, 6:43pm UTC](https://discuss.elastic.co/t/moving-shapshot-between-computers-again/352963 "2024-02-12T18:43:11Z")

</div>

I know things like this have been discussed here, but I do not find any complete answer that matches the situation or what I observe on the screen, so I have to ask again. If I make a snapshot of an index on one compute…

---

## [Massive index compression](https://discuss.elastic.co/t/massive-index-compression/352926)

<div class="topic-metadata">

**Author:** [@revelc33](https://discuss.elastic.co/u/revelc33)\
**Replies:** 10\
**Last updated:** [February 12, 2024, 5:47pm UTC](https://discuss.elastic.co/t/massive-index-compression/352926 "2024-02-12T17:47:29Z")

</div>

How can I easily compress 140 indices (some of which are up to 100 GB)? I have tried closing the indices, changing the codec to 'best\_compression,' and then executing a forcemerge on the index. The forcemerge task fi…

---

## [Get available fields in index](https://discuss.elastic.co/t/get-available-fields-in-index/353091)

<div class="topic-metadata">

**Author:** [@kaismax](https://discuss.elastic.co/u/kaismax)\
**Replies:** 0\
**Last updated:** [February 12, 2024, 5:08pm UTC](https://discuss.elastic.co/t/get-available-fields-in-index/353091 "2024-02-12T17:08:29Z")

</div>

Hello, community, I want to get the available fields from an index, like taking the last 500 documents and returning a list of non-null fields. thanks.

---

## [Elastic Defend integration failed to upgrade](https://discuss.elastic.co/t/elastic-defend-integration-failed-to-upgrade/352583)

<div class="topic-metadata">

**Author:** [@Krishna\_Teja](https://discuss.elastic.co/u/Krishna_Teja)\
**Replies:** 4\
**Last updated:** [February 12, 2024, 5:05pm UTC](https://discuss.elastic.co/t/elastic-defend-integration-failed-to-upgrade/352583 "2024-02-12T17:05:33Z")

</div>

I upgraded elastic version to 8.12.0 recently. Today, when I tried to upgrade my agents, they are stuck in "unhealthy" state with a few errors stating Download failure and "No action taken" (screenshot attached). What c…

---

## [Oracle Data to ES using Logstash](https://discuss.elastic.co/t/oracle-data-to-es-using-logstash/352900)

<div class="topic-metadata">

**Author:** [@elkeng](https://discuss.elastic.co/u/elkeng)\
**Replies:** 4\
**Last updated:** [February 12, 2024, 2:19pm UTC](https://discuss.elastic.co/t/oracle-data-to-es-using-logstash/352900 "2024-02-12T14:19:25Z")

</div>

Hello everyone, I am trying to ingest Oracle data to ES using Logstash. But I got some errors in different conditions. Is there a procedure or best practice to do this? Thanks

[Previous page](https://discuss.elastic.co/latest.md?page=402)

[Next page](https://discuss.elastic.co/latest.md?page=404)
