# Latest

**URL:** https://discuss.elastic.co/latest.md?page=418

[Latest](https://discuss.elastic.co/latest.md) · [Categories](https://discuss.elastic.co/categories.md) · [Tags](https://discuss.elastic.co/tags.md)

**Page:** 419

---

## [Filebeat fails connection to Logstash on Kubernetes](https://discuss.elastic.co/t/filebeat-fails-connection-to-logstash-on-kubernetes/351822)

<div class="topic-metadata">

**Author:** [@Ziggiyzoo](https://discuss.elastic.co/u/Ziggiyzoo)\
**Replies:** 5\
**Last updated:** [January 29, 2024, 2:14pm UTC](https://discuss.elastic.co/t/filebeat-fails-connection-to-logstash-on-kubernetes/351822 "2024-01-29T14:14:19Z")

</div>

Hi, I'm trying to connect a Filebeats deployment to Logstash but I am having error getting Filebeat to connect. A connection attempt failed because the connected party did not properly respond after a period of time, o…

---

## [ELSER hybrid search. Error: '\[sub\_searches\] query malformed, no start\_object after query name')](https://discuss.elastic.co/t/elser-hybrid-search-error-sub-searches-query-malformed-no-start-object-after-query-name/351802)

<div class="topic-metadata">

**Author:** [@SanthoshKMurugadass](https://discuss.elastic.co/u/SanthoshKMurugadass)\
**Replies:** 12\
**Last updated:** [January 29, 2024, 1:44pm UTC](https://discuss.elastic.co/t/elser-hybrid-search-error-sub-searches-query-malformed-no-start-object-after-query-name/351802 "2024-01-29T13:44:06Z")

</div>

I am trying a develop a hybrid search query by combing ELSER Semantic and Full Text searches using Python client. Below is my sample code. I am getting a error '\[sub\_searches\] query malformed, no start\_object after quer…

---

## [How to add new config file to logstash which is created by docker compose?](https://discuss.elastic.co/t/how-to-add-new-config-file-to-logstash-which-is-created-by-docker-compose/351655)

<div class="topic-metadata">

**Author:** [@shrm](https://discuss.elastic.co/u/shrm)\
**Replies:** 3\
**Last updated:** [January 29, 2024, 1:43pm UTC](https://discuss.elastic.co/t/how-to-add-new-config-file-to-logstash-which-is-created-by-docker-compose/351655 "2024-01-29T13:43:48Z")

</div>

How to add a new config file to logstash which is created by docker-compose? I created my service with docker-compose and log stash is connected to kibana and elasticsearch. Now I created a new config file for logstash…

---

## [Performance Problems](https://discuss.elastic.co/t/performance-problems/348035)

<div class="topic-metadata">

**Author:** [@fgonzalez](https://discuss.elastic.co/u/fgonzalez)\
**Replies:** 27\
**Last updated:** [January 29, 2024, 1:34pm UTC](https://discuss.elastic.co/t/performance-problems/348035 "2024-01-29T13:34:47Z")

</div>

Good morning, I have several Elasticsearch clusters and they are giving me performance problems. I have located (I think) the problems but I need you to confirm if I am on the right track. Basic configuration normally …

---

## [Performing Search across multiple Elasticsearch Indices](https://discuss.elastic.co/t/performing-search-across-multiple-elasticsearch-indices/351980)

<div class="topic-metadata">

**Author:** [@muhammad\_qassem](https://discuss.elastic.co/u/muhammad_qassem)\
**Replies:** 3\
**Last updated:** [January 29, 2024, 1:33pm UTC](https://discuss.elastic.co/t/performing-search-across-multiple-elasticsearch-indices/351980 "2024-01-29T13:33:29Z")

</div>

hello , If i have about 120 indices in my elastic cluster and want to get the data from each index through REST API does that mean that i need 120 API one for each index or could i get all of them through one api

---

## [Elastic-agent fleet upgrade windows - DNS lookup failure](https://discuss.elastic.co/t/elastic-agent-fleet-upgrade-windows-dns-lookup-failure/351992)

<div class="topic-metadata">

**Author:** [@beno](https://discuss.elastic.co/u/beno)\
**Replies:** 0\
**Last updated:** [January 29, 2024, 1:17pm UTC](https://discuss.elastic.co/t/elastic-agent-fleet-upgrade-windows-dns-lookup-failure/351992 "2024-01-29T13:17:26Z")

</div>

Hello, I would like to upgrade my fleet server running on a windows server from Elastic 8.10.2 to Elastic 8.11.3. I run the upgrade through the UI from Fleet-\>Agents page. When I do this, I get the following 2 errors: …

---

## [Failed to determine the health of the cluster. , with exit code 69](https://discuss.elastic.co/t/failed-to-determine-the-health-of-the-cluster-with-exit-code-69/351919)

<div class="topic-metadata">

**Author:** [@coolin\_dady](https://discuss.elastic.co/u/coolin_dady)\
**Replies:** 1\
**Last updated:** [January 29, 2024, 1:16pm UTC](https://discuss.elastic.co/t/failed-to-determine-the-health-of-the-cluster-with-exit-code-69/351919 "2024-01-29T13:16:44Z")

</div>

\`\`i got that error when tried to create enrollment tocken for the first time .i installed elk version 8.12.0

---

## [Delete dictionary from array if one key is empty](https://discuss.elastic.co/t/delete-dictionary-from-array-if-one-key-is-empty/351863)

<div class="topic-metadata">

**Author:** [@ITIC](https://discuss.elastic.co/u/ITIC)\
**Replies:** 2\
**Last updated:** [January 29, 2024, 1:08pm UTC](https://discuss.elastic.co/t/delete-dictionary-from-array-if-one-key-is-empty/351863 "2024-01-29T13:08:00Z")

</div>

Hi! It's been a while since I last wrestled with logstash, and I can feel the rust! I'm trying to delete an array element with delete\_if, and I have trouble with it. The element itself is a dictionary, and the conditi…

---

## [Dense\_vector type changes to “float” after loading the data](https://discuss.elastic.co/t/dense-vector-type-changes-to-float-after-loading-the-data/350309)

<div class="topic-metadata">

**Author:** [@Rakesh\_Kalange](https://discuss.elastic.co/u/Rakesh_Kalange)\
**Replies:** 5\
**Last updated:** [January 29, 2024, 12:40pm UTC](https://discuss.elastic.co/t/dense-vector-type-changes-to-float-after-loading-the-data/350309 "2024-01-29T12:40:53Z")

</div>

Hi, I'm trying to load vector\_value into Elasticsearch, index creation and data loading finished without any error. But the result of mapping shows type "float", not "dense\_vector". The version of Elasticsearch is 7.…

---

## [Mutate and gsub usage](https://discuss.elastic.co/t/mutate-and-gsub-usage/351769)

<div class="topic-metadata">

**Author:** [@Sara93](https://discuss.elastic.co/u/Sara93)\
**Replies:** 3\
**Last updated:** [January 29, 2024, 12:32pm UTC](https://discuss.elastic.co/t/mutate-and-gsub-usage/351769 "2024-01-29T12:32:11Z")

</div>

Hi, I was trying to fetch below fileds from the log 2024-01-10 04:21:52.018 -06:00 \[INF\] \[2696100223720240110042151-10\] {"Message":"Device\_Response\_2696100223720240110042151-10","ApiEndPoint":"ws://10.136.41.18:50000/"…

---

## [Log Configuration](https://discuss.elastic.co/t/log-configuration/351974)

<div class="topic-metadata">

**Author:** [@tejas.d](https://discuss.elastic.co/u/tejas.d)\
**Replies:** 3\
**Last updated:** [January 29, 2024, 12:18pm UTC](https://discuss.elastic.co/t/log-configuration/351974 "2024-01-29T12:18:52Z")

</div>

How can i define Application log files when i have a suffix as system date after .log in filebeat.yml folder Examle: C:/path/folder/\*.log29012024

---

## [Update\_by\_query?routing=orgid performance veryslow](https://discuss.elastic.co/t/update-by-query-routing-orgid-performance-veryslow/351940)

<div class="topic-metadata">

**Author:** [@Sankar\_S](https://discuss.elastic.co/u/Sankar_S)\
**Replies:** 6\
**Last updated:** [January 29, 2024, 12:16pm UTC](https://discuss.elastic.co/t/update-by-query-routing-orgid-performance-veryslow/351940 "2024-01-29T12:16:51Z")

</div>

Hello All, /\_update\_by\_query { "query": { "bool": { "filter": \[ { "term": { "my\_key": "myapikey" } } \] } }, "script": { "source": """ …

---

## [Deleting array fields logstash](https://discuss.elastic.co/t/deleting-array-fields-logstash/351790)

<div class="topic-metadata">

**Author:** [@andrejcoliveira](https://discuss.elastic.co/u/andrejcoliveira)\
**Replies:** 6\
**Last updated:** [January 29, 2024, 11:37am UTC](https://discuss.elastic.co/t/deleting-array-fields-logstash/351790 "2024-01-29T11:37:43Z")

</div>

Hi, In my company we're trying to process a json array sent by filiebeat to logstash. The json that logstash receives is: { "logFile": \[ { "line": 2, "elements": \[ { "line": 4, "name": "", "description": "", "type": ""…

---

## [RestHighLevelClient, warning "Deprecated field \[type\] used"](https://discuss.elastic.co/t/resthighlevelclient-warning-deprecated-field-type-used/351870)

<div class="topic-metadata">

**Author:** [@antoinelefloch](https://discuss.elastic.co/u/antoinelefloch)\
**Replies:** 4\
**Last updated:** [January 29, 2024, 10:47am UTC](https://discuss.elastic.co/t/resthighlevelclient-warning-deprecated-field-type-used/351870 "2024-01-29T10:47:59Z")

</div>

Hello, I am using RestHighLevelClient (elasticsearch-rest-high-level-client-7.17.16.jar) and I get a warning from our 7.17.13 server Warning: 299 Elasticsearch-7.17.13-2b211dbb8bfdecaf7f5b44d356bdfe54b1050c13 "Depre…

---

## [Term aggregation ordering within a pivot transform](https://discuss.elastic.co/t/term-aggregation-ordering-within-a-pivot-transform/351754)

<div class="topic-metadata">

**Author:** [@nicole.oresme](https://discuss.elastic.co/u/nicole.oresme)\
**Replies:** 4\
**Last updated:** [January 29, 2024, 9:12am UTC](https://discuss.elastic.co/t/term-aggregation-ordering-within-a-pivot-transform/351754 "2024-01-29T09:12:38Z")

</div>

I'm running a pivot transform in which I have a terms aggregation that I'm trying to order, roughly: "items": { "terms": { "field": "item\_id", "order": { "value": "desc" } }, …

---

## [No output shown in Metric Explorer or Inventory but Metricbeat is running](https://discuss.elastic.co/t/no-output-shown-in-metric-explorer-or-inventory-but-metricbeat-is-running/351871)

<div class="topic-metadata">

**Author:** [@Swathi12](https://discuss.elastic.co/u/Swathi12)\
**Replies:** 2\
**Last updated:** [January 29, 2024, 9:10am UTC](https://discuss.elastic.co/t/no-output-shown-in-metric-explorer-or-inventory-but-metricbeat-is-running/351871 "2024-01-29T09:10:21Z")

</div>

Hi, i deployed metricbeat on Kubernetes Cluster but when i want to see metrics in Metric Explorer or Inventory it's showing nothing But metricbeat is still running without error

---

## [How to deploy and update metricbeat on several k8s cluster?](https://discuss.elastic.co/t/how-to-deploy-and-update-metricbeat-on-several-k8s-cluster/351970)

<div class="topic-metadata">

**Author:** [@Swathi12](https://discuss.elastic.co/u/Swathi12)\
**Replies:** 0\
**Last updated:** [January 29, 2024, 9:00am UTC](https://discuss.elastic.co/t/how-to-deploy-and-update-metricbeat-on-several-k8s-cluster/351970 "2024-01-29T09:00:35Z")

</div>

Hi, we have one Elasticsearch Cluster. There is running our ECK and Kibana. Now i try to deploy metricbeat on multiple cluster ( around 15-20 clusters) My question Do i have to run yaml file individually for cluster …

---

## [Elastic App Search Crawler](https://discuss.elastic.co/t/elastic-app-search-crawler/351699)

<div class="topic-metadata">

**Author:** [@\_Pontes](https://discuss.elastic.co/u/_Pontes)\
**Replies:** 2\
**Last updated:** [January 29, 2024, 8:37am UTC](https://discuss.elastic.co/t/elastic-app-search-crawler/351699 "2024-01-29T08:37:12Z")

</div>

Hi there, Is there a way to make the Elasticsearch crawler from indexing the content of and HTML tags and their content? Specifically, we'd like to remove them from the headings and main\_content (extracted by default…

---

## [Kibana server is not ready](https://discuss.elastic.co/t/kibana-server-is-not-ready/351652)

<div class="topic-metadata">

**Author:** [@prajeet](https://discuss.elastic.co/u/prajeet)\
**Replies:** 1\
**Last updated:** [January 29, 2024, 8:31am UTC](https://discuss.elastic.co/t/kibana-server-is-not-ready/351652 "2024-01-29T08:31:02Z")

</div>

Hi, I have created a new elastic, Kibana and logstash instances on RHEL. They are not clustered and elastic responds to curl. I have used server host name for elastic server.hostname with port 9200. But when it comes to …

---

## [Output to more than one Kafka topics](https://discuss.elastic.co/t/output-to-more-than-one-kafka-topics/351929)

<div class="topic-metadata">

**Author:** [@ErGeek](https://discuss.elastic.co/u/ErGeek)\
**Replies:** 1\
**Last updated:** [January 29, 2024, 8:23am UTC](https://discuss.elastic.co/t/output-to-more-than-one-kafka-topics/351929 "2024-01-29T08:23:43Z")

</div>

Hi, We are trying to send output to more than one Kafka topics using filebeat. It is not working as expected. Output section: output.kafka: enabled: true hosts: \[ "---" \] topic: "%{\[fields.topic\_name\]}" to…

---

## [ODBC Driver for elasticsearch](https://discuss.elastic.co/t/odbc-driver-for-elasticsearch/351783)

<div class="topic-metadata">

**Author:** [@muhammad\_qassem](https://discuss.elastic.co/u/muhammad_qassem)\
**Replies:** 8\
**Last updated:** [January 29, 2024, 8:11am UTC](https://discuss.elastic.co/t/odbc-driver-for-elasticsearch/351783 "2024-01-29T08:11:57Z")

</div>

Hi, I am trying to configure the elastic odbc driver for Elasticsearch to then get data to power bi but when i test the connection for that it gives me error i dont know this error is related to what certificate or autho…

---

## [Default search timeout doesn't work](https://discuss.elastic.co/t/default-search-timeout-doesnt-work/350726)

<div class="topic-metadata">

**Author:** [@anon90868141](https://discuss.elastic.co/u/anon90868141)\
**Replies:** 3\
**Last updated:** [January 29, 2024, 7:44am UTC](https://discuss.elastic.co/t/default-search-timeout-doesnt-work/350726 "2024-01-29T07:44:39Z")

</div>

Hello, it seems like the following settings do not work for elasticsearch 7.17.10: PUT \_cluster/settings { "persistent": { "search.default\_search\_timeout": "300s", "search.low\_level\_cancellation": "true" } …

---

## [Dotnet 8 \> Serilog \> OTEL \> APM](https://discuss.elastic.co/t/dotnet-8-serilog-otel-apm/351957)

<div class="topic-metadata">

**Author:** [@Sunny84](https://discuss.elastic.co/u/Sunny84)\
**Replies:** 0\
**Last updated:** [January 29, 2024, 5:56am UTC](https://discuss.elastic.co/t/dotnet-8-serilog-otel-apm/351957 "2024-01-29T05:56:17Z")

</div>

I am trying to create a demo on my local to prove that I can setup auto instrumentation of dotnet 8 web api using Serilog sink to send data to OTEL collector which in turn is forwarding Trace, Metrics and Logs data to el…

---

## [Kibanaへの接続が出来なくなりました](https://discuss.elastic.co/t/kibana/351955)

<div class="topic-metadata">

**Author:** [@JunJun\_San](https://discuss.elastic.co/u/JunJun_San)\
**Replies:** 0\
**Last updated:** [January 29, 2024, 5:23am UTC](https://discuss.elastic.co/t/kibana/351955 "2024-01-29T05:23:29Z")

</div>

KIBANAを表示しようとすると 応答時間が長すぎるとのエラーメッセージが表示されKIBANAを使用する事が出来なくなっています。 ログを見ると「Error sending telemetry usage data. 」とのメッセージが 数日前から出る様になっていて、これが原因なのかと思いましたが 対処方法が解りません。 何方かご教示いただけますか？

---

## [The latest version of logstash 8.12.0. Reports vulnerable](https://discuss.elastic.co/t/the-latest-version-of-logstash-8-12-0-reports-vulnerable/351952)

<div class="topic-metadata">

**Author:** [@ranjini](https://discuss.elastic.co/u/ranjini)\
**Replies:** 2\
**Last updated:** [January 29, 2024, 4:54am UTC](https://discuss.elastic.co/t/the-latest-version-of-logstash-8-12-0-reports-vulnerable/351952 "2024-01-29T04:54:10Z")

</div>

How to fix vulnerabilities in the maven-core-3.3.9.jar, maven-compat-3.3.9.jar and derby-10.14.1.0.jar. This is reported vulnerable in the latest Logstash package? DetailedName org.apache.maven:maven-core 3.3.9 …

---

## [Sort terms aggregation by totla sum of 2 nested sum aggregations](https://discuss.elastic.co/t/sort-terms-aggregation-by-totla-sum-of-2-nested-sum-aggregations/351915)

<div class="topic-metadata">

**Author:** [@Assaf\_Cohen](https://discuss.elastic.co/u/Assaf_Cohen)\
**Replies:** 2\
**Last updated:** [January 28, 2024, 7:12pm UTC](https://discuss.elastic.co/t/sort-terms-aggregation-by-totla-sum-of-2-nested-sum-aggregations/351915 "2024-01-28T19:12:04Z")

</div>

I have an index which stores all the books and articles read by users. The books and articles are of nested type. I am trying to get the top x users who read the highest number of books and articles which match the speci…

---

## [Contains query in elastic search](https://discuss.elastic.co/t/contains-query-in-elastic-search/351932)

<div class="topic-metadata">

**Author:** [@post90](https://discuss.elastic.co/u/post90)\
**Replies:** 3\
**Last updated:** [January 28, 2024, 12:28pm UTC](https://discuss.elastic.co/t/contains-query-in-elastic-search/351932 "2024-01-28T12:28:43Z")

</div>

How do we do a contains string search in elasticsearch in more than 1 field efficiently e.g text "denis tomas" should be searchable by query "tom". I stumbled upon query\_string query but usage of wildcards make it ineffi…

---

## [Filebeat read logs stored in rook cephfs persistent volume](https://discuss.elastic.co/t/filebeat-read-logs-stored-in-rook-cephfs-persistent-volume/351942)

<div class="topic-metadata">

**Author:** [@alex\_petrov](https://discuss.elastic.co/u/alex_petrov)\
**Replies:** 0\
**Last updated:** [January 28, 2024, 12:15pm UTC](https://discuss.elastic.co/t/filebeat-read-logs-stored-in-rook-cephfs-persistent-volume/351942 "2024-01-28T12:15:21Z")

</div>

I setup kubernetes cluster on bare metal and setup rook cephfs as default storage class.I deployed a pod that store logs in a drirectory inside pod that mapped to a pv(using cephfs pv).so my questions are : is filebeat…

---

## [Logstash JDBC Output to Postgres case-sensitive issue](https://discuss.elastic.co/t/logstash-jdbc-output-to-postgres-case-sensitive-issue/351881)

<div class="topic-metadata">

**Author:** [@h\_ng\_d\_ng](https://discuss.elastic.co/u/h_ng_d_ng)\
**Replies:** 9\
**Last updated:** [January 28, 2024, 9:53am UTC](https://discuss.elastic.co/t/logstash-jdbc-output-to-postgres-case-sensitive-issue/351881 "2024-01-28T09:53:03Z")

</div>

Hi, i got issue with logstash when trying to import data to postgres table. here are my output config: and it always show error that :\[ERROR\] 2024-01-26 20:22:38.348 \[\[main\]\>worker0\] jdbc - JDBC - Exception. Not retr…

---

## [401 Unauthorized](https://discuss.elastic.co/t/401-unauthorized/351806)

<div class="topic-metadata">

**Author:** [@Lukasz\_Skrzat](https://discuss.elastic.co/u/Lukasz_Skrzat)\
**Replies:** 1\
**Last updated:** [January 27, 2024, 2:50pm UTC](https://discuss.elastic.co/t/401-unauthorized/351806 "2024-01-27T14:50:49Z")

</div>

Hi i trying connect my kubernetes agent to elastic-stack using fleet token but after deployment have error "Failed to connect to backoff(elasticsearch(https://elasticsearch.logging-stack.svc.cluster.local:9200)): 401 U…

[Previous page](https://discuss.elastic.co/latest.md?page=417)

[Next page](https://discuss.elastic.co/latest.md?page=419)
