# Latest

**URL:** https://discuss.elastic.co/latest.md?page=439

[Latest](https://discuss.elastic.co/latest.md) · [Categories](https://discuss.elastic.co/categories.md) · [Tags](https://discuss.elastic.co/tags.md)

**Page:** 440

---

## [Watermark sonarqube](https://discuss.elastic.co/t/watermark-sonarqube/350406)

<div class="topic-metadata">

**Author:** [@walterh91](https://discuss.elastic.co/u/walterh91)\
**Replies:** 3\
**Last updated:** [January 5, 2024, 7:17am UTC](https://discuss.elastic.co/t/watermark-sonarqube/350406 "2024-01-05T07:17:18Z")

</div>

Hello how are you? Currently, I am using two versions of SonarQube: Development environment: Community Edition Version 9.1 (build 47736) Production environment: Developer Edition Version 9.9.1 (build 69595) In both c…

---

## [Error-Failed version compatibility check with elasticsearch: tls: failed to verify certificate: x509: certificate signed by unknown authority](https://discuss.elastic.co/t/error-failed-version-compatibility-check-with-elasticsearch-tls-failed-to-verify-certificate-x509-certificate-signed-by-unknown-authority/349711)

<div class="topic-metadata">

**Author:** [@Austin1](https://discuss.elastic.co/u/Austin1)\
**Replies:** 6\
**Last updated:** [January 5, 2024, 5:26am UTC](https://discuss.elastic.co/t/error-failed-version-compatibility-check-with-elasticsearch-tls-failed-to-verify-certificate-x509-certificate-signed-by-unknown-authority/349711 "2024-01-05T05:26:41Z")

</div>

Hi all , Please help me with setting up elastic agent container! I got below error when I used podman run command followed: Error-Failed version compatibility check with elasticsearch: tls: failed to verify certificat…

---

## [Error Unable to retrieve version information from Elasticsearch nodes. unable to get issuer certificate](https://discuss.elastic.co/t/error-unable-to-retrieve-version-information-from-elasticsearch-nodes-unable-to-get-issuer-certificate/350389)

<div class="topic-metadata">

**Author:** [@kray](https://discuss.elastic.co/u/kray)\
**Replies:** 4\
**Last updated:** [January 5, 2024, 4:32am UTC](https://discuss.elastic.co/t/error-unable-to-retrieve-version-information-from-elasticsearch-nodes-unable-to-get-issuer-certificate/350389 "2024-01-05T04:32:47Z")

</div>

please help, when I open the wazuh web the following error and I checked the kibana log, there is the following error {"type":"log","@timestamp":"2024-01-04T20:11:27+07:00","tags":\["error","elasticsearch-service"\],"p…

---

## [Distributed traces not working for RUM js and java backend with VueJs/Springboot](https://discuss.elastic.co/t/distributed-traces-not-working-for-rum-js-and-java-backend-with-vuejs-springboot/350417)

<div class="topic-metadata">

**Author:** [@senyam08](https://discuss.elastic.co/u/senyam08)\
**Replies:** 1\
**Last updated:** [January 5, 2024, 1:08am UTC](https://discuss.elastic.co/t/distributed-traces-not-working-for-rum-js-and-java-backend-with-vuejs-springboot/350417 "2024-01-05T01:08:53Z")

</div>

We have instrumented our VueJs front end with RUM js agent via GTM. Added following code RUM data capturing works fine. But we dont see correlation between RUM data and java agent APM data. Sprint boot application …

---

## [Are there any plans to increase the 800kb push limit?](https://discuss.elastic.co/t/are-there-any-plans-to-increase-the-800kb-push-limit/350314)

<div class="topic-metadata">

**Author:** [@joel.parker](https://discuss.elastic.co/u/joel.parker)\
**Replies:** 6\
**Last updated:** [January 5, 2024, 1:04am UTC](https://discuss.elastic.co/t/are-there-any-plans-to-increase-the-800kb-push-limit/350314 "2024-01-05T01:04:41Z")

</div>

I want to run a set of tests that will check the contents of PDF files using the pdf-parse node module. However, when I import it to use in my monitors I can't push it up to elastic as I get the following error: Error: …

---

## [Parse Kibana Query to sql object](https://discuss.elastic.co/t/parse-kibana-query-to-sql-object/350335)

<div class="topic-metadata">

**Author:** [@Ofir\_Safin](https://discuss.elastic.co/u/Ofir_Safin)\
**Replies:** 1\
**Last updated:** [January 4, 2024, 10:35pm UTC](https://discuss.elastic.co/t/parse-kibana-query-to-sql-object/350335 "2024-01-04T22:35:27Z")

</div>

Hi everyone, I'm trying to monitor logs from Elasticsearch in python My problem is that each log has a different structure. For example: "error" and applicationName :"test" "query" will be like this: { "bool": { …

---

## [Changing the log-in text](https://discuss.elastic.co/t/changing-the-log-in-text/350363)

<div class="topic-metadata">

**Author:** [@Karan\_Lobo](https://discuss.elastic.co/u/Karan_Lobo)\
**Replies:** 1\
**Last updated:** [January 4, 2024, 6:27pm UTC](https://discuss.elastic.co/t/changing-the-log-in-text/350363 "2024-01-04T18:27:49Z")

</div>

Hey there, I am trying to change the login text to "Welcome to Elastic." I tried changing the source code in the \\kibana-7.17.0-windowsx86\_64\\xpack\\plugins\\security\\target\\public\\security.chunk.5.js file, but it won't wo…

---

## [Backup/Restore Indexes](https://discuss.elastic.co/t/backup-restore-indexes/350411)

<div class="topic-metadata">

**Author:** [@marcowiskhy](https://discuss.elastic.co/u/marcowiskhy)\
**Replies:** 1\
**Last updated:** [January 4, 2024, 8:31pm UTC](https://discuss.elastic.co/t/backup-restore-indexes/350411 "2024-01-04T20:31:25Z")

</div>

Hey guys, I have an Elasticsearch node in production and am experiencing issues regarding disk storage. At the moment I cannot increase computational resources or add other nodes because I depend on collaboration with a…

---

## [What should be specified in the filebeats config to connect to Elastic search cloud?](https://discuss.elastic.co/t/what-should-be-specified-in-the-filebeats-config-to-connect-to-elastic-search-cloud/350401)

<div class="topic-metadata">

**Author:** [@jcc2186](https://discuss.elastic.co/u/jcc2186)\
**Replies:** 4\
**Last updated:** [January 4, 2024, 7:52pm UTC](https://discuss.elastic.co/t/what-should-be-specified-in-the-filebeats-config-to-connect-to-elastic-search-cloud/350401 "2024-01-04T19:52:40Z")

</div>

I am trying to setup filebeats to connect to elasticsearch cloud to send my custom application .json log file. What configuration setting do I need to add to the filebeat.yml config to send logs to the correct elasticse…

---

## [Can't log in other than from the local host](https://discuss.elastic.co/t/cant-log-in-other-than-from-the-local-host/349883)

<div class="topic-metadata">

**Author:** [@rcfa](https://discuss.elastic.co/u/rcfa)\
**Replies:** 3\
**Last updated:** [January 4, 2024, 7:51pm UTC](https://discuss.elastic.co/t/cant-log-in-other-than-from-the-local-host/349883 "2024-01-04T19:51:08Z")

</div>

I'm a newby, so excuse if I ask a dummy question, but I got to start somewhere, and being able to log in is, well, prerequisite... So on my server, let's call it 10.0.0.1 I have installed the Elasticsearch and kibana pa…

---

## [savedVisualization / embeddable in canvas broken after upgrading to version 8.9.2 due to saved Objects Id](https://discuss.elastic.co/t/savedvisualization-embeddable-in-canvas-broken-after-upgrading-to-version-8-9-2-due-to-saved-objects-id/349652)

<div class="topic-metadata">

**Author:** [@preetish\_P](https://discuss.elastic.co/u/preetish_P)\
**Replies:** 4\
**Last updated:** [January 4, 2024, 6:32pm UTC](https://discuss.elastic.co/t/savedvisualization-embeddable-in-canvas-broken-after-upgrading-to-version-8-9-2-due-to-saved-objects-id/349652 "2024-01-04T18:32:53Z")

</div>

Hi folks, We are looking to upgrade elk stack from 7.17.2 to 8.9.2. One of the first observations we made in Canvas is that savedVisualization is broken. We have Canvas dashboards having upto 9 kibana visualisation impo…

---

## [Is it possible to run beats agent as a container](https://discuss.elastic.co/t/is-it-possible-to-run-beats-agent-as-a-container/350393)

<div class="topic-metadata">

**Author:** [@ACodingfreak](https://discuss.elastic.co/u/ACodingfreak)\
**Replies:** 1\
**Last updated:** [January 4, 2024, 4:05pm UTC](https://discuss.elastic.co/t/is-it-possible-to-run-beats-agent-as-a-container/350393 "2024-01-04T16:05:20Z")

</div>

Hi All, I am quite new to Elastic and have a very basic doubt. I understand that beats is used as an agent running on edge node shipping the data to Elasticsearch. It is installed as an RPM or DEB package but can it be…

---

## [\[Elasticsearch user settings and extensions\] Increase http.max\_initial\_line\_length](https://discuss.elastic.co/t/elasticsearch-user-settings-and-extensions-increase-http-max-initial-line-length/350387)

<div class="topic-metadata">

**Author:** [@Xavier\_Huberdeau](https://discuss.elastic.co/u/Xavier_Huberdeau)\
**Replies:** 1\
**Last updated:** [January 4, 2024, 4:53pm UTC](https://discuss.elastic.co/t/elasticsearch-user-settings-and-extensions-increase-http-max-initial-line-length/350387 "2024-01-04T16:53:46Z")

</div>

Hello, I'm trying to change the elasticsearch settings yml configuration from elastic.co When I put http.max\_initial\_line\_length: 32kb, it says: Your changes cannot be applied Elasticsearch - 'http.max\_initial\_li…

---

## [Kindly suggest hardware sizing](https://discuss.elastic.co/t/kindly-suggest-hardware-sizing/350348)

<div class="topic-metadata">

**Author:** [@sakda.pk](https://discuss.elastic.co/u/sakda.pk)\
**Replies:** 0\
**Last updated:** [January 4, 2024, 4:12am UTC](https://discuss.elastic.co/t/kindly-suggest-hardware-sizing/350348 "2024-01-04T04:12:28Z")

</div>

I have size of data is 850 GB per day and must keep data in 91 days. Total size about 77 TB. pleased help to suggest. - quantity node - quantity shade of index per day Additional Question - how maximum space of n…

---

## [How to modify total memory of existing nodes?](https://discuss.elastic.co/t/how-to-modify-total-memory-of-existing-nodes/349958)

<div class="topic-metadata">

**Author:** [@SanthoshKMurugadass](https://discuss.elastic.co/u/SanthoshKMurugadass)\
**Replies:** 8\
**Last updated:** [January 4, 2024, 3:51pm UTC](https://discuss.elastic.co/t/how-to-modify-total-memory-of-existing-nodes/349958 "2024-01-04T15:51:32Z")

</div>

Hi, I am new to elasticresearch. I have set up 3 node cluster following docker setup procedure explained as per section: Section Start a multi-node cluster with Docker Compose in below help link Here is my cluster nod…

---

## [No transaction/traces with elastic-apm-agent with quarkus](https://discuss.elastic.co/t/no-transaction-traces-with-elastic-apm-agent-with-quarkus/350232)

<div class="topic-metadata">

**Author:** [@hzdb5betrieb](https://discuss.elastic.co/u/hzdb5betrieb)\
**Replies:** 1\
**Last updated:** [January 4, 2024, 3:47pm UTC](https://discuss.elastic.co/t/no-transaction-traces-with-elastic-apm-agent-with-quarkus/350232 "2024-01-04T15:47:42Z")

</div>

Kibana version: 7.17.0 Elasticsearch version: 7.17.0 APM Server version: 7.17.0 APM Agent language and version: java: elastic-apm-agent-1.45.0.jar Browser version: firefox latest Original install method (e.g. d…

---

## [Apm-agent-java 1.45.0 Java 7 issue](https://discuss.elastic.co/t/apm-agent-java-1-45-0-java-7-issue/350027)

<div class="topic-metadata">

**Author:** [@Eric\_Gitau](https://discuss.elastic.co/u/Eric_Gitau)\
**Replies:** 1\
**Last updated:** [January 4, 2024, 3:22pm UTC](https://discuss.elastic.co/t/apm-agent-java-1-45-0-java-7-issue/350027 "2024-01-04T15:22:00Z")

</div>

Hi. It looks like version 1.45.0 of the java agent is unable to start with Java 7. The issue seems to be coming from JCC tools. 1.44.0 works ok. 17:41:53,342 ERROR \[stderr\] (elastic-apm-agent-initialization) \[elastic-…

---

## [How to integrate Ironscales to Elastic Cloud?](https://discuss.elastic.co/t/how-to-integrate-ironscales-to-elastic-cloud/350161)

<div class="topic-metadata">

**Author:** [@Anilkumar](https://discuss.elastic.co/u/Anilkumar)\
**Replies:** 1\
**Last updated:** [January 4, 2024, 3:01pm UTC](https://discuss.elastic.co/t/how-to-integrate-ironscales-to-elastic-cloud/350161 "2024-01-04T15:01:31Z")

</div>

Hi All, I am looking to integrate Ironscales audit logs into Elastic cloud& can't find the Integration for it. How to ingest this logs, can anyone help?

---

## [Missing packetbeat.yml file /etc/packetbeat](https://discuss.elastic.co/t/missing-packetbeat-yml-file-etc-packetbeat/350340)

<div class="topic-metadata">

**Author:** [@ACodingfreak](https://discuss.elastic.co/u/ACodingfreak)\
**Replies:** 1\
**Last updated:** [January 4, 2024, 2:38pm UTC](https://discuss.elastic.co/t/missing-packetbeat-yml-file-etc-packetbeat/350340 "2024-01-04T14:38:52Z")

</div>

Hi All, I am trying to install packetbeat in my ubuntu 22.04 machine following the instructions shared in As shown in below logs, /etc/packetbeat is empty and I dont see the default template of packetbeat.yml file. A…

---

## [Using location data to show a route taken](https://discuss.elastic.co/t/using-location-data-to-show-a-route-taken/350263)

<div class="topic-metadata">

**Author:** [@RainTown](https://discuss.elastic.co/u/RainTown)\
**Replies:** 2\
**Last updated:** [January 4, 2024, 1:38pm UTC](https://discuss.elastic.co/t/using-location-data-to-show-a-route-taken/350263 "2024-01-04T13:38:40Z")

</div>

Hi I have time based data for the location of an item, that I'd like to visualise as a sort of "route map", i.e. a sequnece of lines joining the various location points as traversed in time series order. Maybe I'm miss…

---

## [Kibana: Cold indices not showing when using filter in index management](https://discuss.elastic.co/t/kibana-cold-indices-not-showing-when-using-filter-in-index-management/350200)

<div class="topic-metadata">

**Author:** [@basiltitus](https://discuss.elastic.co/u/basiltitus)\
**Replies:** 8\
**Last updated:** [January 4, 2024, 12:40pm UTC](https://discuss.elastic.co/t/kibana-cold-indices-not-showing-when-using-filter-in-index-management/350200 "2024-01-04T12:40:47Z")

</div>

I have a two node cluster with a master/hot and a single data node defined in cold tier. I have created few indices for testing data tier. But when I apply "lifecycle phase" filter the indices supposed to be in cold tie…

---

## [Maximum timeout reached while retrying request. Call: Status code unknown from](https://discuss.elastic.co/t/maximum-timeout-reached-while-retrying-request-call-status-code-unknown-from/350378)

<div class="topic-metadata">

**Author:** [@ali\_haider](https://discuss.elastic.co/u/ali_haider)\
**Replies:** 0\
**Last updated:** [January 4, 2024, 12:14pm UTC](https://discuss.elastic.co/t/maximum-timeout-reached-while-retrying-request-call-status-code-unknown-from/350378 "2024-01-04T12:14:31Z")

</div>

Hi, I have installed Elasticsearch 7.17.7 version on Windows Server 2022 I am facing the following error and exception Index goes to red zone after this exception. In Elasticsearch logs it's says that that indices fi…

---

## [Geo.location as object and not as geo\_point](https://discuss.elastic.co/t/geo-location-as-object-and-not-as-geo-point/349230)

<div class="topic-metadata">

**Author:** [@helldunkel](https://discuss.elastic.co/u/helldunkel)\
**Replies:** 3\
**Last updated:** [January 4, 2024, 11:48am UTC](https://discuss.elastic.co/t/geo-location-as-object-and-not-as-geo-point/349230 "2024-01-04T11:48:44Z")

</div>

Hi, I created a component template for a custon sensor. everything works, has the right datatypes. Only destination.geo.location is set to object and not to geo\_point: "destination": { "type": "object", …

---

## [Multiple Kibanas on 1 cluster](https://discuss.elastic.co/t/multiple-kibanas-on-1-cluster/350372)

<div class="topic-metadata">

**Author:** [@avnere](https://discuss.elastic.co/u/avnere)\
**Replies:** 1\
**Last updated:** [January 4, 2024, 10:32am UTC](https://discuss.elastic.co/t/multiple-kibanas-on-1-cluster/350372 "2024-01-04T10:32:47Z")

</div>

Hi, Is it possible\\alowed to run multiple Kibana instances connected to same cluster? Will it create internal index (.monitoring, etc) per instance? Thanks...

---

## [I facing error while setup elasticsearch cluster in docker using 2 host server those servers from azure ERROR i am getting like this Peer{transportAddress=10.33.8.79:9300, discoveryNode=null, peersRequestInFlight=false} connection failed org.elasticsearc](https://discuss.elastic.co/t/i-facing-error-while-setup-elasticsearch-cluster-in-docker-using-2-host-server-those-servers-from-azure-error-i-am-getting-like-this-peer-transportaddress-10-33-8-79-9300-discoverynode-null-peersrequestinflight-false-connection-failed-org-elasticsearc/350369)

<div class="topic-metadata">

**Author:** [@Pasupuleti\_siva](https://discuss.elastic.co/u/Pasupuleti_siva)\
**Replies:** 4\
**Last updated:** [January 4, 2024, 10:08am UTC](https://discuss.elastic.co/t/i-facing-error-while-setup-elasticsearch-cluster-in-docker-using-2-host-server-those-servers-from-azure-error-i-am-getting-like-this-peer-transportaddress-10-33-8-79-9300-discoverynode-null-peersrequestinflight-false-connection-failed-org-elasticsearc/350369 "2024-01-04T10:08:37Z")

</div>

ERROR: \[2024-01-04T09:04:24,575\]\[DEBUG\]\[o.e.d.PeerFinder \] \[odfe-node2\] Peer{transportAddress=10.33.8.79:9300, discoveryNode=null, peersRequestInFlight=false} connection failed org.elasticsearch.transport.Connect…

---

## [Alternatives to kibana](https://discuss.elastic.co/t/alternatives-to-kibana/350360)

<div class="topic-metadata">

**Author:** [@Karan\_Lobo](https://discuss.elastic.co/u/Karan_Lobo)\
**Replies:** 2\
**Last updated:** [January 4, 2024, 9:53am UTC](https://discuss.elastic.co/t/alternatives-to-kibana/350360 "2024-01-04T09:53:18Z")

</div>

Hey i was wondering if i could connect my elasticsearch and logstash with some other vizualisation tool like powerbi or tablue for free . I tried to do so but it seems i have to buy the platinum version to download the e…

---

## [Use runtime field in App Search](https://discuss.elastic.co/t/use-runtime-field-in-app-search/350334)

<div class="topic-metadata">

**Author:** [@gael-ian](https://discuss.elastic.co/u/gael-ian)\
**Replies:** 2\
**Last updated:** [January 4, 2024, 9:37am UTC](https://discuss.elastic.co/t/use-runtime-field-in-app-search/350334 "2024-01-04T09:37:11Z")

</div>

Hi, I have a rather complex use case for App Search with engines based on Elasticsearch indexes. I managed to build ES indexes and AP engines that match almost all of my criteria but I stumble on one of the last things …

---

## [Logstash output adding ES cluster exception](https://discuss.elastic.co/t/logstash-output-adding-es-cluster-exception/350345)

<div class="topic-metadata">

**Author:** [@kinho](https://discuss.elastic.co/u/kinho)\
**Replies:** 2\
**Last updated:** [January 4, 2024, 9:30am UTC](https://discuss.elastic.co/t/logstash-output-adding-es-cluster-exception/350345 "2024-01-04T09:30:52Z")

</div>

Logstash docker I plan to use Docker Compose to deploy ELK in Docker, where ES is a cluster The version is 8.11.3 .env: ELASTIC\_PASSWORD=123456 KIBANA\_PASSWORD=123456 STACK\_VERSION=8.11.3 CLUSTER\_NAME=docker-clu…

---

## [I want to know details about how we reduced the heap usage per shard](https://discuss.elastic.co/t/i-want-to-know-details-about-how-we-reduced-the-heap-usage-per-shard/350346)

<div class="topic-metadata">

**Author:** [@emmning](https://discuss.elastic.co/u/emmning)\
**Replies:** 1\
**Last updated:** [January 4, 2024, 9:28am UTC](https://discuss.elastic.co/t/i-want-to-know-details-about-how-we-reduced-the-heap-usage-per-shard/350346 "2024-01-04T09:28:15Z")

</div>

Through this blog I see that starting from 8.3, we have significantly reduced Usage of each shard of the heap. I would like to know more details about how we can reduce the heap usage per shard. Anyone knows a PR or blog…

---

## [Siem integrated ml jobs and multi tenancy](https://discuss.elastic.co/t/siem-integrated-ml-jobs-and-multi-tenancy/350315)

<div class="topic-metadata">

**Author:** [@Crazyworlds](https://discuss.elastic.co/u/Crazyworlds)\
**Replies:** 2\
**Last updated:** [January 4, 2024, 8:31am UTC](https://discuss.elastic.co/t/siem-integrated-ml-jobs-and-multi-tenancy/350315 "2024-01-04T08:31:48Z")

</div>

Hi to everyone, We use the ECS field 'organization.name" and "data\_stream.namespace" to distinguish the organization name, and it work well with SIEM alert rules excluding those based on machine learning. On this king…

[Previous page](https://discuss.elastic.co/latest.md?page=438)

[Next page](https://discuss.elastic.co/latest.md?page=440)
