# Latest

**URL:** https://discuss.elastic.co/latest.md?page=596

[Latest](https://discuss.elastic.co/latest.md) · [Categories](https://discuss.elastic.co/categories.md) · [Tags](https://discuss.elastic.co/tags.md)

**Page:** 597

---

## [Masters not joining the cluster](https://discuss.elastic.co/t/masters-not-joining-the-cluster/339158)

<div class="topic-metadata">

**Author:** [@ORIAN\_MENASHE](https://discuss.elastic.co/u/ORIAN_MENASHE)\
**Replies:** 1\
**Last updated:** [July 25, 2023, 9:11am UTC](https://discuss.elastic.co/t/masters-not-joining-the-cluster/339158 "2023-07-25T09:11:32Z")

</div>

Hi I have 3 masters that not joining my cluster One of the is up but don’t have cluster uuid Can you help me?

---

## [Merge records into one table](https://discuss.elastic.co/t/merge-records-into-one-table/339067)

<div class="topic-metadata">

**Author:** [@akeelow](https://discuss.elastic.co/u/akeelow)\
**Replies:** 3\
**Last updated:** [July 25, 2023, 8:50am UTC](https://discuss.elastic.co/t/merge-records-into-one-table/339067 "2023-07-25T08:50:41Z")

</div>

Hello! cisco gateway sends 4 log entries for one voip call. All four records have a common id. Is it possible to create such a query in the Kibana interface to create a table where each row will contain the following fie…

---

## [Getting the error after upgrading from v6 to v7](https://discuss.elastic.co/t/getting-the-error-after-upgrading-from-v6-to-v7/339034)

<div class="topic-metadata">

**Author:** [@sonujatav35](https://discuss.elastic.co/u/sonujatav35)\
**Replies:** 3\
**Last updated:** [July 25, 2023, 8:44am UTC](https://discuss.elastic.co/t/getting-the-error-after-upgrading-from-v6-to-v7/339034 "2023-07-25T08:44:31Z")

</div>

Hi ES community, I have one question recently i have done reindexing then ES up-gradation from v6.8.23 to v7.17.9. After this operation i noticed some error in elastic-search. Text fields are not optimised for operatio…

---

## [Get Unique Values for Elastic UI Donut Charts](https://discuss.elastic.co/t/get-unique-values-for-elastic-ui-donut-charts/339087)

<div class="topic-metadata">

**Author:** [@cyrildaniel](https://discuss.elastic.co/u/cyrildaniel)\
**Replies:** 1\
**Last updated:** [July 25, 2023, 7:44am UTC](https://discuss.elastic.co/t/get-unique-values-for-elastic-ui-donut-charts/339087 "2023-07-25T07:44:36Z")

</div>

I would like to show the total unique count of vendors in the middle of the donut chart, but by default the total count comes. Is there a way to show the unique number of vendors? In the below image instead of 98 it sho…

---

## [Syntax is overwriting when using .NET Elastic.Clients.ElasticSearch package](https://discuss.elastic.co/t/syntax-is-overwriting-when-using-net-elastic-clients-elasticsearch-package/339050)

<div class="topic-metadata">

**Author:** [@Rottonscope](https://discuss.elastic.co/u/Rottonscope)\
**Replies:** 1\
**Last updated:** [July 25, 2023, 7:34am UTC](https://discuss.elastic.co/t/syntax-is-overwriting-when-using-net-elastic-clients-elasticsearch-package/339050 "2023-07-25T07:34:52Z")

</div>

Hello! I'm new to using Elasticsearch and trying to get my head around the Query DSL for the .NET package: Elastic.Clients.Elasticsearch. I have a basic query set-up as such: Ids excludeIds = new Ids(new List\<I…

---

## [Number of concurrent search requests on ElasticSearch cluster](https://discuss.elastic.co/t/number-of-concurrent-search-requests-on-elasticsearch-cluster/339144)

<div class="topic-metadata">

**Author:** [@Mohit\_Munjal](https://discuss.elastic.co/u/Mohit_Munjal)\
**Replies:** 3\
**Last updated:** [July 25, 2023, 6:22am UTC](https://discuss.elastic.co/t/number-of-concurrent-search-requests-on-elasticsearch-cluster/339144 "2023-07-25T06:22:35Z")

</div>

My objective is to calculate 2 things Q1: how many search requests can a elasticsearch cluster can work on at once Q2: how many search requests can a elasticsearch cluster hold in it's queue before starting rejecting i…

---

## [Stuck in preparing for race](https://discuss.elastic.co/t/stuck-in-preparing-for-race/339143)

<div class="topic-metadata">

**Author:** [@maximiliano\_carrasco](https://discuss.elastic.co/u/maximiliano_carrasco)\
**Replies:** 1\
**Last updated:** [July 25, 2023, 6:09am UTC](https://discuss.elastic.co/t/stuck-in-preparing-for-race/339143 "2023-07-25T06:09:21Z")

</div>

I am trying to use esrally but it keeps stuck in "preparing for race..." I create a track with: esrally create-track --track=test --target-hosts=host --client-options="use\_ssl:true,verify\_certs:true,basic\_auth\_user:…

---

## [LDAP Integration Not Working](https://discuss.elastic.co/t/ldap-integration-not-working/338865)

<div class="topic-metadata">

**Author:** [@forabraham1](https://discuss.elastic.co/u/forabraham1)\
**Replies:** 6\
**Last updated:** [July 25, 2023, 4:53am UTC](https://discuss.elastic.co/t/ldap-integration-not-working/338865 "2023-07-25T04:53:31Z")

</div>

We're running inhouse platinum version of ELK stack 7.16. We've tried to use AD for user authentication, but it is not working and ends throwing invalid credential error. We're 100% sure that it is valid password. This …

---

## [How to configure multi-pipeline configuration in logstash 8.6.1?](https://discuss.elastic.co/t/how-to-configure-multi-pipeline-configuration-in-logstash-8-6-1/339071)

<div class="topic-metadata">

**Author:** [@Koele](https://discuss.elastic.co/u/Koele)\
**Replies:** 4\
**Last updated:** [July 25, 2023, 3:26am UTC](https://discuss.elastic.co/t/how-to-configure-multi-pipeline-configuration-in-logstash-8-6-1/339071 "2023-07-25T03:26:59Z")

</div>

Basic Information logstash version: 8.6.1 Logstash installation method: tar.gz logstash installation directory: /opt OS: CentOS 7 ogstash.yml configuration file node.name: logstash01 path.data: /data/logstash01 pipe…

---

## [Metricbeat missing dashboards](https://discuss.elastic.co/t/metricbeat-missing-dashboards/339139)

<div class="topic-metadata">

**Author:** [@Ryaninsolencee](https://discuss.elastic.co/u/Ryaninsolencee)\
**Replies:** 0\
**Last updated:** [July 25, 2023, 3:17am UTC](https://discuss.elastic.co/t/metricbeat-missing-dashboards/339139 "2023-07-25T03:17:16Z")

</div>

As i configured my elasticsearch to https, i changed all the necessary .yml files to include the https for elastic. but now my metricbeat doesnt work anymore and im also missing the dashboard fields elasticsearch and ki…

---

## [Unable to start elasticsearch when configuring SSL](https://discuss.elastic.co/t/unable-to-start-elasticsearch-when-configuring-ssl/339030)

<div class="topic-metadata">

**Author:** [@Ryaninsolencee](https://discuss.elastic.co/u/Ryaninsolencee)\
**Replies:** 6\
**Last updated:** [July 25, 2023, 2:07am UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-when-configuring-ssl/339030 "2023-07-25T02:07:48Z")

</div>

Very new to ELK stack and ive been trying to tinker and figure out security configs , i already have kibana running on ssl and now im trying to configure elasticsearch. ive followed the guide and now it just refuses to s…

---

## [Problem to access Elastic portal https://local.host:12443/deployments](https://discuss.elastic.co/t/problem-to-access-elastic-portal-https-local-host-12443-deployments/339137)

<div class="topic-metadata">

**Author:** [@Cleber\_Carvalho](https://discuss.elastic.co/u/Cleber_Carvalho)\
**Replies:** 0\
**Last updated:** [July 25, 2023, 1:09am UTC](https://discuss.elastic.co/t/problem-to-access-elastic-portal-https-local-host-12443-deployments/339137 "2023-07-25T01:09:02Z")

</div>

When I try access the link to my ECE installation I receive the following error: 'Error: Service Unavailable' 'at y (https://local.host:12443/app.ac60c57da441fe117e33.js:2:252916)' 'at m (https://local.host:12443/app.…

---

## [Not able to download all rows of data in CSV](https://discuss.elastic.co/t/not-able-to-download-all-rows-of-data-in-csv/338638)

<div class="topic-metadata">

**Author:** [@hjazz6](https://discuss.elastic.co/u/hjazz6)\
**Replies:** 13\
**Last updated:** [July 24, 2023, 10:53pm UTC](https://discuss.elastic.co/t/not-able-to-download-all-rows-of-data-in-csv/338638 "2023-07-24T22:53:12Z")

</div>

Hi, I have a query that generated 25 hits, and I have selected a few columns to display in the tabular format. When I tried to export the results by generating a CSV report, I'm only able to export 15 rows, not all 25 r…

---

## [Kibana can't sign in](https://discuss.elastic.co/t/kibana-cant-sign-in/339131)

<div class="topic-metadata">

**Author:** [@dro](https://discuss.elastic.co/u/dro)\
**Replies:** 2\
**Last updated:** [July 24, 2023, 10:35pm UTC](https://discuss.elastic.co/t/kibana-cant-sign-in/339131 "2023-07-24T22:35:39Z")

</div>

Kibana is not accepting the default elasticsearch-master-credentials The following ELK stack configuration is all version 8.5.1 running in a single node cluster: pod/elasticsearch-master-0 1/1 Running 0 …

---

## [Find all numbers in a text with](https://discuss.elastic.co/t/find-all-numbers-in-a-text-with/339020)

<div class="topic-metadata">

**Author:** [@kbfifi](https://discuss.elastic.co/u/kbfifi)\
**Replies:** 2\
**Last updated:** [July 24, 2023, 8:39pm UTC](https://discuss.elastic.co/t/find-all-numbers-in-a-text-with/339020 "2023-07-24T20:39:33Z")

</div>

I'm a newbe and trying to find all numbers in text with GROK. I'm using GROK debugger. My sample text: "Sample content with date 11 22 2022 and entity California and another date 1 1 1999 2-3-2024" I hope to get an ar…

---

## [No autorizated for monitoring error](https://discuss.elastic.co/t/no-autorizated-for-monitoring-error/338968)

<div class="topic-metadata">

**Author:** [@hlcxpl](https://discuss.elastic.co/u/hlcxpl)\
**Replies:** 2\
**Last updated:** [July 24, 2023, 7:30pm UTC](https://discuss.elastic.co/t/no-autorizated-for-monitoring-error/338968 "2023-07-24T19:30:34Z")

</div>

You are not authorized to access Monitoring. To use Monitoring, you need the privileges granted by both the \`kibana\_admin\` and \`monitoring\_user \` roles. If you are attempting to access a dedicated monitoring cluster, th…

---

## [Kibana Data Path / Chromium Files](https://discuss.elastic.co/t/kibana-data-path-chromium-files/338908)

<div class="topic-metadata">

**Author:** [@jokulicz](https://discuss.elastic.co/u/jokulicz)\
**Replies:** 4\
**Last updated:** [July 24, 2023, 7:16pm UTC](https://discuss.elastic.co/t/kibana-data-path-chromium-files/338908 "2023-07-24T19:16:47Z")

</div>

Hi! I am running the latest version of Kibana on Windows. I set the data.path variable in the config to change the location of the data and this works for the uuid file, but not for the chromium folders that are create…

---

## [Issues Running ElasticSearch on Kibana](https://discuss.elastic.co/t/issues-running-elasticsearch-on-kibana/339123)

<div class="topic-metadata">

**Author:** [@Emily\_Miller](https://discuss.elastic.co/u/Emily_Miller)\
**Replies:** 2\
**Last updated:** [July 24, 2023, 6:50pm UTC](https://discuss.elastic.co/t/issues-running-elasticsearch-on-kibana/339123 "2023-07-24T18:50:47Z")

</div>

Hey all. I'm brand new to running Kibana, and I'm using a software called GrimoireLab that runs off of it and docker. I used to not have any issues setting it up, but every time I try to open my localhost now it says ERR…

---

## [How to secure the Elasticsearch API?](https://discuss.elastic.co/t/how-to-secure-the-elasticsearch-api/339092)

<div class="topic-metadata">

**Author:** [@subash](https://discuss.elastic.co/u/subash)\
**Replies:** 1\
**Last updated:** [July 24, 2023, 5:50pm UTC](https://discuss.elastic.co/t/how-to-secure-the-elasticsearch-api/339092 "2023-07-24T17:50:57Z")

</div>

Hello, I want to share the Elastic curl API to the application team so that they can consume the API to get the data from Elastic search. How do I provide the authorization to the application team to consume that API? …

---

## [Standard training subscription, which courses should I start with? Some courses are starting off very difficult](https://discuss.elastic.co/t/standard-training-subscription-which-courses-should-i-start-with-some-courses-are-starting-off-very-difficult/338916)

<div class="topic-metadata">

**Author:** [@pezhed](https://discuss.elastic.co/u/pezhed)\
**Replies:** 2\
**Last updated:** [July 24, 2023, 5:40pm UTC](https://discuss.elastic.co/t/standard-training-subscription-which-courses-should-i-start-with-some-courses-are-starting-off-very-difficult/338916 "2023-07-24T17:40:42Z")

</div>

I was provided the elasticsearch on-demand standard training subscription through work. I am aiming to become elasticsearch certified. I don't have too much elasticsearch background (but I do have CS and programming back…

---

## [Match query not returning results](https://discuss.elastic.co/t/match-query-not-returning-results/337815)

<div class="topic-metadata">

**Author:** [@senadk](https://discuss.elastic.co/u/senadk)\
**Replies:** 6\
**Last updated:** [July 24, 2023, 5:14pm UTC](https://discuss.elastic.co/t/match-query-not-returning-results/337815 "2023-07-24T17:14:06Z")

</div>

Hi everyone, I started today with Elastic Search and have been working on some endpoints to get and post data. I do get a problem when trying to get results back on a match query. This is my document: { exception: \[…

---

## [Demo Dashboards](https://discuss.elastic.co/t/demo-dashboards/338999)

<div class="topic-metadata">

**Author:** [@Aamir1](https://discuss.elastic.co/u/Aamir1)\
**Replies:** 2\
**Last updated:** [July 24, 2023, 4:59pm UTC](https://discuss.elastic.co/t/demo-dashboards/338999 "2023-07-24T16:59:32Z")

</div>

Hello Everyone, I found this dashboard at 'demo.elastic.co' and I really impressed with this dashboard. Anyone can please tell me that where I can download its json object so I can test this with my data?

---

## [Logstash Create pipeline API: \[pipeline\] failed to parse object / json\_parse\_exception](https://discuss.elastic.co/t/logstash-create-pipeline-api-pipeline-failed-to-parse-object-json-parse-exception/339055)

<div class="topic-metadata">

**Author:** [@alexus](https://discuss.elastic.co/u/alexus)\
**Replies:** 1\
**Last updated:** [July 24, 2023, 4:46pm UTC](https://discuss.elastic.co/t/logstash-create-pipeline-api-pipeline-failed-to-parse-object-json-parse-exception/339055 "2023-07-24T16:46:21Z")

</div>

Hello World! I'm trying to follow this: to duplicate an existing Logstash pipeline, however I'm running into following error: % export PIPELINE=$(curl --silent --request GET --insecure "https://elastic:$es\_password@…

---

## [Will KSPM and CSPM be compatible with Alibaba Cloud in the future?](https://discuss.elastic.co/t/will-kspm-and-cspm-be-compatible-with-alibaba-cloud-in-the-future/337499)

<div class="topic-metadata">

**Author:** [@L1NG](https://discuss.elastic.co/u/L1NG)\
**Replies:** 1\
**Last updated:** [July 24, 2023, 4:04pm UTC](https://discuss.elastic.co/t/will-kspm-and-cspm-be-compatible-with-alibaba-cloud-in-the-future/337499 "2023-07-24T16:04:46Z")

</div>

Will KSPM and CSPM be compatible with Alibaba Cloud in the future?

---

## [Alert Suppression on Event Correlation Rule (duplicate alerts)](https://discuss.elastic.co/t/alert-suppression-on-event-correlation-rule-duplicate-alerts/338837)

<div class="topic-metadata">

**Author:** [@adub08](https://discuss.elastic.co/u/adub08)\
**Replies:** 1\
**Last updated:** [July 24, 2023, 3:30pm UTC](https://discuss.elastic.co/t/alert-suppression-on-event-correlation-rule-duplicate-alerts/338837 "2023-07-24T15:30:27Z")

</div>

Has anyone found a good way of modifying the prebuilt in event coloration rules Elastic Security to not produce too many alerts repeated alerts within a short time span? Similar to how Alert suppression works with custom…

---

## [Two apm server URLs](https://discuss.elastic.co/t/two-apm-server-urls/339094)

<div class="topic-metadata">

**Author:** [@Rick\_V](https://discuss.elastic.co/u/Rick_V)\
**Replies:** 2\
**Last updated:** [July 24, 2023, 2:41pm UTC](https://discuss.elastic.co/t/two-apm-server-urls/339094 "2023-07-24T14:41:29Z")

</div>

Hi, We run Elastic in the cloud, and we recently switched to using apm using the integration. If I log into Elastic cloud, i can copy the apm endpoint from there using copy endpoint. I get a certain URL with .apm. in it…

---

## [Fleet Server not deploying in ECK operator](https://discuss.elastic.co/t/fleet-server-not-deploying-in-eck-operator/337110)

<div class="topic-metadata">

**Author:** [@conuoha1](https://discuss.elastic.co/u/conuoha1)\
**Replies:** 1\
**Last updated:** [July 24, 2023, 2:14pm UTC](https://discuss.elastic.co/t/fleet-server-not-deploying-in-eck-operator/337110 "2023-07-24T14:14:45Z")

</div>

This is my fleet.yaml file , i cant seem to understand why im getting this error apiVersion: agent.k8s.elastic.co/v1alpha1 kind: Agent metadata: annotations: association.k8s.elastic.co/es-conf-3796208044: \>- …

---

## [RFE: SQL - Add listagg aggregate function](https://discuss.elastic.co/t/rfe-sql-add-listagg-aggregate-function/339111)

<div class="topic-metadata">

**Author:** [@t603](https://discuss.elastic.co/u/t603)\
**Replies:** 0\
**Last updated:** [July 24, 2023, 2:14pm UTC](https://discuss.elastic.co/t/rfe-sql-add-listagg-aggregate-function/339111 "2023-07-24T14:14:12Z")

</div>

Hello, may I ask You in SQL language module to add "listagg" function into the aggregate (group by...having) SQL queries? This would help me to identify unique type of logs using this style of aggregation of string col…

---

## [Shards are in ALLOCATION\_FAILED or CLUSTER\_RECOVERED](https://discuss.elastic.co/t/shards-are-in-allocation-failed-or-cluster-recovered/339100)

<div class="topic-metadata">

**Author:** [@Sathish22](https://discuss.elastic.co/u/Sathish22)\
**Replies:** 3\
**Last updated:** [July 24, 2023, 2:05pm UTC](https://discuss.elastic.co/t/shards-are-in-allocation-failed-or-cluster-recovered/339100 "2023-07-24T14:05:30Z")

</div>

Hi All, we have a 5 master and 41 node cluster, due to some storage hardware issue, Elasticsearch cluster was affected and after resolving hardware issue, some of the shards are showing as ALLOCATION\_FAILED or CLUSTER\_R…

---

## [Change log level for beats deployed by fleet managed elastic-agent](https://discuss.elastic.co/t/change-log-level-for-beats-deployed-by-fleet-managed-elastic-agent/338473)

<div class="topic-metadata">

**Author:** [@GibbsGreatly](https://discuss.elastic.co/u/GibbsGreatly)\
**Replies:** 2\
**Last updated:** [July 24, 2023, 2:04pm UTC](https://discuss.elastic.co/t/change-log-level-for-beats-deployed-by-fleet-managed-elastic-agent/338473 "2023-07-24T14:04:51Z")

</div>

I've set up Elasticsearch and Kibana on a couple of test VM's. These will be running on Raspberry Pi's once I have it all figured out. Hence, it's pretty important that I limit logging. I am trying really hard to find…

[Previous page](https://discuss.elastic.co/latest.md?page=595)

[Next page](https://discuss.elastic.co/latest.md?page=597)
