# Latest

**URL:** https://discuss.elastic.co/latest.md?page=920

[Latest](https://discuss.elastic.co/latest.md) · [Categories](https://discuss.elastic.co/categories.md) · [Tags](https://discuss.elastic.co/tags.md)

**Page:** 921

---

## [Elastic score decay if field tokens are in another field](https://discuss.elastic.co/t/elastic-score-decay-if-field-tokens-are-in-another-field/316037)

<div class="topic-metadata">

**Author:** [@Sergey\_V](https://discuss.elastic.co/u/Sergey_V)\
**Replies:** 4\
**Last updated:** [October 25, 2022, 7:38am UTC](https://discuss.elastic.co/t/elastic-score-decay-if-field-tokens-are-in-another-field/316037 "2022-10-25T07:38:12Z")

</div>

Hi! Me need decrease score of document if in "field1" has tokens of "field2". Tell me how can this be done?

---

## [Split Document into multiple document based on condition](https://discuss.elastic.co/t/split-document-into-multiple-document-based-on-condition/316737)

<div class="topic-metadata">

**Author:** [@yuswanul](https://discuss.elastic.co/u/yuswanul)\
**Replies:** 19\
**Last updated:** [October 25, 2022, 6:54am UTC](https://discuss.elastic.co/t/split-document-into-multiple-document-based-on-condition/316737 "2022-10-25T06:54:47Z")

</div>

Hi there, i plan to split field into multiple document based on OID. So, i have configured snmp pipeline for my network device. I managed to monitor the cpu and memory usage but i'm facing problem when i want to monitor…

---

## [Fortinet integration not parsing all data](https://discuss.elastic.co/t/fortinet-integration-not-parsing-all-data/317369)

<div class="topic-metadata">

**Author:** [@sirineb](https://discuss.elastic.co/u/sirineb)\
**Replies:** 0\
**Last updated:** [October 25, 2022, 6:44am UTC](https://discuss.elastic.co/t/fortinet-integration-not-parsing-all-data/317369 "2022-10-25T06:44:37Z")

</div>

Hi, I posted a topic in the category Elastic Stack Beats as it was advised to do with issues regarding the Elastic Agent. But I am struggling having an answer, so I paste here, in the category Elastic Stack Elastic Agen…

---

## [Visio stencils](https://discuss.elastic.co/t/visio-stencils/317368)

<div class="topic-metadata">

**Author:** [@bering](https://discuss.elastic.co/u/bering)\
**Replies:** 0\
**Last updated:** [October 25, 2022, 6:20am UTC](https://discuss.elastic.co/t/visio-stencils/317368 "2022-10-25T06:20:09Z")

</div>

Some time ago I was able to download logos and other Elasic figures that could be imported into Visio from this link Trademarks found on Elastic.co | Elastic but that now links to some trademark page. Does anyone know w…

---

## [Question 2 / 6 - Exam Practice](https://discuss.elastic.co/t/question-2-6-exam-practice/317361)

<div class="topic-metadata">

**Author:** [@linhz](https://discuss.elastic.co/u/linhz)\
**Replies:** 0\
**Last updated:** [October 25, 2022, 3:11am UTC](https://discuss.elastic.co/t/question-2-6-exam-practice/317361 "2022-10-25T03:11:28Z")

</div>

Hi, Question 2 I could not found "average of bytes last formatted" under the name whereby i follow the solution. Anyone happen to know the reason? Question 6 How do we know we need to select "Terms" aggregation? A…

---

## [How to get nested field value equal to keyword field value](https://discuss.elastic.co/t/how-to-get-nested-field-value-equal-to-keyword-field-value/317360)

<div class="topic-metadata">

**Author:** [@casterQ](https://discuss.elastic.co/u/casterQ)\
**Replies:** 0\
**Last updated:** [October 25, 2022, 2:58am UTC](https://discuss.elastic.co/t/how-to-get-nested-field-value-equal-to-keyword-field-value/317360 "2022-10-25T02:58:31Z")

</div>

can i get b value in nested script query? PUT test { "mappings": { "properties": { "b": { "type": "keyword" }, "nested": { "type": "nested", "properties": { "a":…

---

## [Using Prometheus remote\_write to send metrics to Elastic cloud](https://discuss.elastic.co/t/using-prometheus-remote-write-to-send-metrics-to-elastic-cloud/317014)

<div class="topic-metadata">

**Author:** [@Maduranga](https://discuss.elastic.co/u/Maduranga)\
**Replies:** 6\
**Last updated:** [October 25, 2022, 1:48am UTC](https://discuss.elastic.co/t/using-prometheus-remote-write-to-send-metrics-to-elastic-cloud/317014 "2022-10-25T01:48:41Z")

</div>

Hello, I have a Prometheus server which is sending currently sending metrics to Grafana using remote\_write. I would like to use our Elastic cloud Kibana to get the Prometheus metrics. Would like advice on how to authe…

---

## [Java agent make Micronaut to hang](https://discuss.elastic.co/t/java-agent-make-micronaut-to-hang/317270)

<div class="topic-metadata">

**Author:** [@dniel](https://discuss.elastic.co/u/dniel)\
**Replies:** 5\
**Last updated:** [October 25, 2022, 1:36am UTC](https://discuss.elastic.co/t/java-agent-make-micronaut-to-hang/317270 "2022-10-25T01:36:57Z")

</div>

Versions: Micronaut 3.7 running in a Docker container. JDK 17 Temurin Java Agent 1.34.0 Description of the problem including expected versus actual behavior. Please include screenshots (if relevant): During initiali…

---

## [How to display custom calculated machine learning metrics on Kibana dashboard?](https://discuss.elastic.co/t/how-to-display-custom-calculated-machine-learning-metrics-on-kibana-dashboard/317330)

<div class="topic-metadata">

**Author:** [@Suraj\_Manjunatha](https://discuss.elastic.co/u/Suraj_Manjunatha)\
**Replies:** 0\
**Last updated:** [October 24, 2022, 3:13pm UTC](https://discuss.elastic.co/t/how-to-display-custom-calculated-machine-learning-metrics-on-kibana-dashboard/317330 "2022-10-24T15:13:52Z")

</div>

Hello, I have a ML model for image classification problem running on Azure Kubernetes instance on python. I would like to visualize some model metrics like precision, accuracy, recall etc. on a kibana dashboard. With ev…

---

## [Solving version\_conflict\_engine\_exception on update](https://discuss.elastic.co/t/solving-version-conflict-engine-exception-on-update/317337)

<div class="topic-metadata">

**Author:** [@OranShuster](https://discuss.elastic.co/u/OranShuster)\
**Replies:** 9\
**Last updated:** [October 24, 2022, 8:31pm UTC](https://discuss.elastic.co/t/solving-version-conflict-engine-exception-on-update/317337 "2022-10-24T20:31:46Z")

</div>

Preface - Cluster is running version 6.8 and we are doing a mix of search/create/update using the NodeJS Operations can access the same document in quick succession/concurrently since its based off events coming from k…

---

## [Can I use discovery-ec2 plugin for finding data node?](https://discuss.elastic.co/t/can-i-use-discovery-ec2-plugin-for-finding-data-node/317331)

<div class="topic-metadata">

**Author:** [@qksjdhi1212](https://discuss.elastic.co/u/qksjdhi1212)\
**Replies:** 1\
**Last updated:** [October 24, 2022, 8:24pm UTC](https://discuss.elastic.co/t/can-i-use-discovery-ec2-plugin-for-finding-data-node/317331 "2022-10-24T20:24:15Z")

</div>

First I wanted to use discovery-ec2 plugin to find nodes(including non-master-eligible nodes) easily in cluster but I've just noticed that discovery-ec2 plugin is only for finding master-eligible nodes on ES docs The d…

---

## [Filebeat on local laptop does not talk to the Elasticsearch (also on local laptop) - dial tcp \[::1\]:9200: connect: cannot assign requested address](https://discuss.elastic.co/t/filebeat-on-local-laptop-does-not-talk-to-the-elasticsearch-also-on-local-laptop-dial-tcp-1-connect-cannot-assign-requested-address/317145)

<div class="topic-metadata">

**Author:** [@ppine7](https://discuss.elastic.co/u/ppine7)\
**Replies:** 6\
**Last updated:** [October 24, 2022, 8:13pm UTC](https://discuss.elastic.co/t/filebeat-on-local-laptop-does-not-talk-to-the-elasticsearch-also-on-local-laptop-dial-tcp-1-connect-cannot-assign-requested-address/317145 "2022-10-24T20:13:24Z")

</div>

Hi, I am trying to setup Elsticsearch 8, Kibana and Filebeat 8 all on my local laptop, using this guide: I've got ES and Kibana running in Docker containers and communicating just fine. Next, I want to send events fr…

---

## [Can we delay output to Elasticsearch in batch?](https://discuss.elastic.co/t/can-we-delay-output-to-elasticsearch-in-batch/317137)

<div class="topic-metadata">

**Author:** [@quentin.legraverend](https://discuss.elastic.co/u/quentin.legraverend)\
**Replies:** 3\
**Last updated:** [October 24, 2022, 7:46pm UTC](https://discuss.elastic.co/t/can-we-delay-output-to-elasticsearch-in-batch/317137 "2022-10-24T19:46:20Z")

</div>

Hello, I have an Elastic stack self-managed in the cloud with a Fleet Server on it. I have a second environment on-premise with a really limited bandwidth and I want to have some Elastic Agents here also. My first ide…

---

## [Service account token elastic/kibana problemKibana not accessible from browser](https://discuss.elastic.co/t/service-account-token-elastic-kibana-problemkibana-not-accessible-from-browser/317333)

<div class="topic-metadata">

**Author:** [@EExisT](https://discuss.elastic.co/u/EExisT)\
**Replies:** 4\
**Last updated:** [October 24, 2022, 6:19pm UTC](https://discuss.elastic.co/t/service-account-token-elastic-kibana-problemkibana-not-accessible-from-browser/317333 "2022-10-24T18:19:52Z")

</div>

Hello, I was trying to start Kibana as a service, but I noticed that after a few seconds from the start Kibana goes down. In the /var/log/syslog file I saw this error: Oct 24 17:24:18 ubuntu-linux-22-04-desktop kibana…

---

## [Kibana visualize using unique count by latest records](https://discuss.elastic.co/t/kibana-visualize-using-unique-count-by-latest-records/316236)

<div class="topic-metadata">

**Author:** [@Ibrahim\_Z\_HIDIR](https://discuss.elastic.co/u/Ibrahim_Z_HIDIR)\
**Replies:** 2\
**Last updated:** [October 24, 2022, 5:29pm UTC](https://discuss.elastic.co/t/kibana-visualize-using-unique-count-by-latest-records/316236 "2022-10-24T17:29:55Z")

</div>

Hi all After some search and try, I could't find a way to solve my problem. I just want to display the counts of records depending of latest records of some repeating columns. For Example, the latest status of "A" i…

---

## [Is there an easy way to change the Lifecycle Policy of a Fleet managed data stream?](https://discuss.elastic.co/t/is-there-an-easy-way-to-change-the-lifecycle-policy-of-a-fleet-managed-data-stream/316941)

<div class="topic-metadata">

**Author:** [@leandrojmp](https://discuss.elastic.co/u/leandrojmp)\
**Replies:** 2\
**Last updated:** [October 24, 2022, 4:09pm UTC](https://discuss.elastic.co/t/is-there-an-easy-way-to-change-the-lifecycle-policy-of-a-fleet-managed-data-stream/316941 "2022-10-24T16:09:18Z")

</div>

Hello, I'm starting to use the Fleet Server and the Elastic Agent to be able to use some integrations and because of that I'm also using data streams for the first time. I have a fleet server and one agent running wher…

---

## [How to use EXISTING multi-domain SSL cert to secure Kibana](https://discuss.elastic.co/t/how-to-use-existing-multi-domain-ssl-cert-to-secure-kibana/316934)

<div class="topic-metadata">

**Author:** [@Bitdoctor](https://discuss.elastic.co/u/Bitdoctor)\
**Replies:** 9\
**Last updated:** [October 24, 2022, 4:03pm UTC](https://discuss.elastic.co/t/how-to-use-existing-multi-domain-ssl-cert-to-secure-kibana/316934 "2022-10-24T16:03:00Z")

</div>

Simple case - the kibana guide to securing kibana with SSL assumes generating CSR 'from' Kibana server and submitting to SSL provider. I need instructions how to use my existing multi-domain certificate to secure Browser…

---

## [Observability Engineer Lab 3.3 I am getting a unhealthy status for my Ubuntu\_petclinic-client](https://discuss.elastic.co/t/observability-engineer-lab-3-3-i-am-getting-a-unhealthy-status-for-my-ubuntu-petclinic-client/317043)

<div class="topic-metadata">

**Author:** [@Jsarath](https://discuss.elastic.co/u/Jsarath)\
**Replies:** 3\
**Last updated:** [October 24, 2022, 3:56pm UTC](https://discuss.elastic.co/t/observability-engineer-lab-3-3-i-am-getting-a-unhealthy-status-for-my-ubuntu-petclinic-client/317043 "2022-10-24T15:56:08Z")

</div>

I am having trouble viewing an APM app after following the directions of the lab for Node.js agent it is not showing up in my APM services. My configurations are the following in the docker petclinic-client: bin/www: …

---

## [Failed to start Elasticsearch](https://discuss.elastic.co/t/failed-to-start-elasticsearch/317304)

<div class="topic-metadata">

**Author:** [@nicolas2603](https://discuss.elastic.co/u/nicolas2603)\
**Replies:** 9\
**Last updated:** [October 24, 2022, 3:12pm UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch/317304 "2022-10-24T15:12:52Z")

</div>

Hello. I'm having a problem with Elasticsearch, and I don't know much about Linux. It doesn't help! To run a mapping application (GeoNetwork), I need an instance of Elasticsearch. So I downloaded version 8.4.3 in tar.g…

---

## [I paid 2400 USD for a PDF training. The lab opened once and It does not work any more](https://discuss.elastic.co/t/i-paid-2400-usd-for-a-pdf-training-the-lab-opened-once-and-it-does-not-work-any-more/317253)

<div class="topic-metadata">

**Author:** [@Alexandre\_Giordanell](https://discuss.elastic.co/u/Alexandre_Giordanell)\
**Replies:** 2\
**Last updated:** [October 24, 2022, 3:16pm UTC](https://discuss.elastic.co/t/i-paid-2400-usd-for-a-pdf-training-the-lab-opened-once-and-it-does-not-work-any-more/317253 "2022-10-24T15:16:46Z")

</div>

I don't recommend any On Demand courses from ElasticTraining.

---

## [Need help on syslog logstash input plugin](https://discuss.elastic.co/t/need-help-on-syslog-logstash-input-plugin/317181)

<div class="topic-metadata">

**Author:** [@niveditakathal](https://discuss.elastic.co/u/niveditakathal)\
**Replies:** 17\
**Last updated:** [October 24, 2022, 2:58pm UTC](https://discuss.elastic.co/t/need-help-on-syslog-logstash-input-plugin/317181 "2022-10-24T14:58:10Z")

</div>

Hi All, I have created a logstash pipeline to read the network syslog (RFC5424) data as mentioned below, However I don't see any output while running the pipeline. Can someone please assist me what I am missing. Note …

---

## [EQL correlation rule is timing out...sometimes](https://discuss.elastic.co/t/eql-correlation-rule-is-timing-out-sometimes/316641)

<div class="topic-metadata">

**Author:** [@gweiss76](https://discuss.elastic.co/u/gweiss76)\
**Replies:** 0\
**Last updated:** [October 14, 2022, 1:21pm UTC](https://discuss.elastic.co/t/eql-correlation-rule-is-timing-out-sometimes/316641 "2022-10-14T13:21:54Z")

</div>

Hi fellow log analysts We have a simple EQL correlation rule which we use to identify password changes on critical accounts (eventlog based). It looks like this: \[ any where event.code == "4624" \] by winlog.event\_data.…

---

## [Will PCRE regular expressions be supported in the future?](https://discuss.elastic.co/t/will-pcre-regular-expressions-be-supported-in-the-future/317322)

<div class="topic-metadata">

**Author:** [@shengwei.xu](https://discuss.elastic.co/u/shengwei.xu)\
**Replies:** 0\
**Last updated:** [October 24, 2022, 2:06pm UTC](https://discuss.elastic.co/t/will-pcre-regular-expressions-be-supported-in-the-future/317322 "2022-10-24T14:06:50Z")

</div>

Will PCRE regular expressions be supported in the future? I ran into a scenario that non-tech users only use PCRE regular expressions that most languages use, it's time-consuming for non-tech users to learn how to use el…

---

## [How to find the percentage for any query success?](https://discuss.elastic.co/t/how-to-find-the-percentage-for-any-query-success/317194)

<div class="topic-metadata">

**Author:** [@HemabhRavee](https://discuss.elastic.co/u/HemabhRavee)\
**Replies:** 1\
**Last updated:** [October 24, 2022, 12:38pm UTC](https://discuss.elastic.co/t/how-to-find-the-percentage-for-any-query-success/317194 "2022-10-24T12:38:21Z")

</div>

I want to write an aggregation which returns the percentage of hits for any query Let say I have a query Q which returns me 20 docs out of the 100 present in the target index. Then that aggregation should return me 20%…

---

## [Filter vs query](https://discuss.elastic.co/t/filter-vs-query/317297)

<div class="topic-metadata">

**Author:** [@Ismet](https://discuss.elastic.co/u/Ismet)\
**Replies:** 1\
**Last updated:** [October 24, 2022, 12:20pm UTC](https://discuss.elastic.co/t/filter-vs-query/317297 "2022-10-24T12:20:52Z")

</div>

Hi, can we use only filter without query and can we use query string with wildcard in filter. What are benefits of using only filter and using query string + filter? There is example of using only filter. Is this code o…

---

## [Grab everything upto a specific word](https://discuss.elastic.co/t/grab-everything-upto-a-specific-word/317280)

<div class="topic-metadata">

**Author:** [@Rajeev\_Shrestha](https://discuss.elastic.co/u/Rajeev_Shrestha)\
**Replies:** 5\
**Last updated:** [October 24, 2022, 12:19pm UTC](https://discuss.elastic.co/t/grab-everything-upto-a-specific-word/317280 "2022-10-24T12:19:02Z")

</div>

Hi Guys, I am new to GROK and appreciate your help. The goal is to put everything leading up to the word 'user-agent' to a fieldname "details" and everything after "user-agent" to a fieldname "user-agent". The excerpt…

---

## [Signed API keys](https://discuss.elastic.co/t/signed-api-keys/317302)

<div class="topic-metadata">

**Author:** [@Gerardo\_Zenobi](https://discuss.elastic.co/u/Gerardo_Zenobi)\
**Replies:** 0\
**Last updated:** [October 24, 2022, 9:18am UTC](https://discuss.elastic.co/t/signed-api-keys/317302 "2022-10-24T09:18:49Z")

</div>

Hi there :wave: I was testing the mechanism for generating and using Search Signed API keys. The documentation says the following: Signed search keys are created using one of our clients. They require an existing Pri…

---

## [Add index\_options option to all text fields with dynamic templates](https://discuss.elastic.co/t/add-index-options-option-to-all-text-fields-with-dynamic-templates/317303)

<div class="topic-metadata">

**Author:** [@frank\_esg](https://discuss.elastic.co/u/frank_esg)\
**Replies:** 0\
**Last updated:** [October 24, 2022, 9:21am UTC](https://discuss.elastic.co/t/add-index-options-option-to-all-text-fields-with-dynamic-templates/317303 "2022-10-24T09:21:55Z")

</div>

Hello, we´re using component templates to define field mappings based on ECS for all of our indices. In the past we had some issues with search highlighting in Kibana , when text fields are very big. Now i would like t…

---

## [Kibana 8.4.2 new Control does not show options for runtime field](https://discuss.elastic.co/t/kibana-8-4-2-new-control-does-not-show-options-for-runtime-field/315015)

<div class="topic-metadata">

**Author:** [@Jonas\_S](https://discuss.elastic.co/u/Jonas_S)\
**Replies:** 7\
**Last updated:** [October 24, 2022, 8:18am UTC](https://discuss.elastic.co/t/kibana-8-4-2-new-control-does-not-show-options-for-runtime-field/315015 "2022-10-24T08:18:44Z")

</div>

Hello, i upgraded to the newest Kibana version to use the new Controls. I have a runtime field in my Data View that gets a value from the indexname: It can be used in all visualizations without problems. I tried to …

---

## [Indexes created automatically by the system](https://discuss.elastic.co/t/indexes-created-automatically-by-the-system/317125)

<div class="topic-metadata">

**Author:** [@dpelaezb](https://discuss.elastic.co/u/dpelaezb)\
**Replies:** 4\
**Last updated:** [October 24, 2022, 7:47am UTC](https://discuss.elastic.co/t/indexes-created-automatically-by-the-system/317125 "2022-10-24T07:47:40Z")

</div>

Hello everyone, We have an infrastructure that consists of several Filebeats that send the traces to a Logstash located on another machine where there is also a Metricbeat to plot Logstash. We have detected that a seri…

[Previous page](https://discuss.elastic.co/latest.md?page=919)

[Next page](https://discuss.elastic.co/latest.md?page=921)
