# \_bulk API change in 0.12.0 release?

**URL:** <https://discuss.elastic.co/t/-bulk-api-change-in-0-12-0-release/3454>\
**Category:** Elasticsearch\
**Created:** [October 19, 2010, 1:23pm UTC](https://discuss.elastic.co/t/-bulk-api-change-in-0-12-0-release/3454 "2010-10-19T13:23:21Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![ruflin\_2](https://avatars.discourse-cdn.com/v4/letter/r/a8b319/32.png) [@ruflin\_2](https://discuss.elastic.co/u/ruflin_2)\
**Post date:** [October 19, 2010, 1:23pm UTC](https://discuss.elastic.co/t/-bulk-api-change-in-0-12-0-release/3454/1 "2010-10-19T13:23:21Z")

</div>

Hi kimchy

First, thanks for the 0.12.0 release. Has something change in the  
\_bulk API? The  
same code that works in 0.11.0 throws now some errors with 0.12.0

ActionRequestValidationException[Validation Failed: 1: index is  
missing2:  
type is missing3: index is missing4: type is missing5: ...

Type and index are defined as written here:  
[http://www.elasticsearch.com/docs/elasticsearch/rest\_api/bulk/](http://www.elasticsearch.com/docs/elasticsearch/rest_api/bulk/)

Nicolas

---

<div class="post-metadata">

**Author:** ![kimchy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kimchy/32/44952_2.png) [@kimchy](https://discuss.elastic.co/u/kimchy)\
**Post date:** [October 19, 2010, 1:24pm UTC](https://discuss.elastic.co/t/-bulk-api-change-in-0-12-0-release/3454/2 "2010-10-19T13:24:39Z")

</div>

Yes, the bulk API changed, here are the details:  
[Issues · elastic/elasticsearch · GitHub](http://github.com/elasticsearch/elasticsearch/issues/closed#issue/421).

On Tue, Oct 19, 2010 at 3:23 PM, ruflin [ruflin@gmail.com](mailto:ruflin@gmail.com) wrote:

> Hi kimchy
> 
> First, thanks for the 0.12.0 release. Has something change in the  
> \_bulk API? The  
> same code that works in 0.11.0 throws now some errors with 0.12.0
> 
> ActionRequestValidationException[Validation Failed: 1: index is  
> missing2:  
> type is missing3: index is missing4: type is missing5: ...
> 
> Type and index are defined as written here:  
> [http://www.elasticsearch.com/docs/elasticsearch/rest\_api/bulk/](http://www.elasticsearch.com/docs/elasticsearch/rest_api/bulk/)
> 
> Nicolas

---

<div class="post-metadata">

**Author:** ![ruflin\_2](https://avatars.discourse-cdn.com/v4/letter/r/a8b319/32.png) [@ruflin\_2](https://discuss.elastic.co/u/ruflin_2)\
**Post date:** [October 19, 2010, 2:29pm UTC](https://discuss.elastic.co/t/-bulk-api-change-in-0-12-0-release/3454/3 "2010-10-19T14:29:20Z")

</div>

This solved the problem. Thanks.

On Oct 19, 3:24 pm, Shay Banon [shay.ba...@elasticsearch.com](mailto:shay.ba...@elasticsearch.com) wrote:

> Yes, the bulk API changed, here are the details:[Issues · elastic/elasticsearch · GitHub](http://github.com/elasticsearch/elasticsearch/issues/closed#issue/421).
> 
> On Tue, Oct 19, 2010 at 3:23 PM, ruflin [ruf...@gmail.com](mailto:ruf...@gmail.com) wrote:
> 
> > Hi kimchy
> 
> > First, thanks for the 0.12.0 release. Has something change in the  
> > \_bulk API? The  
> > same code that works in 0.11.0 throws now some errors with 0.12.0
> 
> > ActionRequestValidationException[Validation Failed: 1: index is  
> > missing2:  
> > type is missing3: index is missing4: type is missing5: ...
> 
> > Type and index are defined as written here:  
> > [http://www.elasticsearch.com/docs/elasticsearch/rest\_api/bulk/](http://www.elasticsearch.com/docs/elasticsearch/rest_api/bulk/)
> 
> > Nicolas

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 4:17am UTC](https://discuss.elastic.co/t/-bulk-api-change-in-0-12-0-release/3454/4 "2017-07-06T04:17:50Z")

</div>


