# 2016/02/25 17:37:08.496727 transport.go:125: ERR SSL client failed to connect with: dial tcp 172.31.31.169:5044: getsockopt: no route to host

**URL:** <https://discuss.elastic.co/t/2016-02-25-17-37-08-496727-transport-go-125-err-ssl-client-failed-to-connect-with-dial-tcp-172-31-31-169-5044-getsockopt-no-route-to-host/42757>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [February 25, 2016, 5:44pm UTC](https://discuss.elastic.co/t/2016-02-25-17-37-08-496727-transport-go-125-err-ssl-client-failed-to-connect-with-dial-tcp-172-31-31-169-5044-getsockopt-no-route-to-host/42757 "2016-02-25T17:44:39Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![Mayur\_Patel](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mayur_patel/32/8071_2.png) [@Mayur\_Patel](https://discuss.elastic.co/u/Mayur_Patel)\
**Post date:** [February 25, 2016, 5:44pm UTC](https://discuss.elastic.co/t/2016-02-25-17-37-08-496727-transport-go-125-err-ssl-client-failed-to-connect-with-dial-tcp-172-31-31-169-5044-getsockopt-no-route-to-host/42757/1 "2016-02-25T17:44:39Z")

</div>

Hey I am using Amazon EC2 server for my app. I have follow this tutorial for setting ELK stack: [https://www.digitalocean.com/community/tutorials/how-to-install-elasticsearch-logstash-and-kibana-elk-stack-on-ubuntu-14-04](https://www.digitalocean.com/community/tutorials/how-to-install-elasticsearch-logstash-and-kibana-elk-stack-on-ubuntu-14-04)

When I run `sudo service filebeat restart` command I got this error:

`2016/02/25 17:37:08.496727 transport.go:125: ERR SSL client failed to connect with: dial tcp ec2_private_ip:5044: getsockopt: no route to host`

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [February 25, 2016, 8:28pm UTC](https://discuss.elastic.co/t/2016-02-25-17-37-08-496727-transport-go-125-err-ssl-client-failed-to-connect-with-dial-tcp-172-31-31-169-5044-getsockopt-no-route-to-host/42757/2 "2016-02-25T20:28:32Z")

</div>

That's a networking issue, it means your filebeat host cannot connect to the end point.

Providing your configs may help.

---

<div class="post-metadata">

**Author:** ![Mayur\_Patel](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mayur_patel/32/8071_2.png) [@Mayur\_Patel](https://discuss.elastic.co/u/Mayur_Patel)\
**Post date:** [February 26, 2016, 7:39pm UTC](https://discuss.elastic.co/t/2016-02-25-17-37-08-496727-transport-go-125-err-ssl-client-failed-to-connect-with-dial-tcp-172-31-31-169-5044-getsockopt-no-route-to-host/42757/3 "2016-02-26T19:39:26Z")

</div>

`/etc/logstash/conf.d/logstash.conf`

```auto
input {
  beats {
    port => 5044
    ssl => true
    ssl_certificate => "/etc/pki/tls/certs/logstash-forwarder.crt"
    ssl_key => "/etc/pki/tls/private/logstash-forwarder.key"
  }
}

filter {
  if [type] == "syslog" {
    grok {
      match => { "message" => "%{SYSLOGTIMESTAMP:syslog_timestamp} %{SYSLOGHOST:syslog_hostname} %{DATA:syslog_program}(?:\[%{POSINT:syslog_pid}\])?: %{GREEDYDATA:syslog_message}" }
      add_field => ["received_at", "%{@timestamp}"]
      add_field => ["received_from", "%{host}"]
    }
    syslog_pri { }
    date {
      match => ["syslog_timestamp", "MMM d HH:mm:ss", "MMM dd HH:mm:ss"]
    }
  }
}

output {
  stdout { codec => "rubydebug" }
  elasticsearch {
    hosts => ["localhost:9200"]
    sniffing => true
    manage_template => false
    index => "%{[@metadata][beat]}-%{+YYYY.MM.dd}"
    document_type => "%{[@metadata][type]}"
  }
}

```

`/etc/filebeat/filebeat.yml`

```auto
filebeat:
  prospectors:
    -
      paths:
        - /var/log/auth.log
        - /var/log/syslog
      # - /var/log/*.log
      input_type: log
      document_type: syslog
  registry_file: /var/lib/filebeat/registry

output:
  logstash:
    enabled: true
    hosts: ["elk_server_private_ip:5044"]
    bulk_max_size: 1024
    tls:
      certificate_authorities: ["/etc/pki/tls/certs/logstash-forwarder.crt"]

shipper:

logging:
  files:
    rotateeverybytes: 10485760 # = 10MB

```

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [February 26, 2016, 7:48pm UTC](https://discuss.elastic.co/t/2016-02-25-17-37-08-496727-transport-go-125-err-ssl-client-failed-to-connect-with-dial-tcp-172-31-31-169-5044-getsockopt-no-route-to-host/42757/4 "2016-02-26T19:48:01Z")

</div>

Can you ping `elk_server_private_ip` from the host running filebeat? Can you `telnet elk_server_private_ip 5044` from the same host?

---

<div class="post-metadata">

**Author:** ![Mayur\_Patel](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mayur_patel/32/8071_2.png) [@Mayur\_Patel](https://discuss.elastic.co/u/Mayur_Patel)\
**Post date:** [February 26, 2016, 7:51pm UTC](https://discuss.elastic.co/t/2016-02-25-17-37-08-496727-transport-go-125-err-ssl-client-failed-to-connect-with-dial-tcp-172-31-31-169-5044-getsockopt-no-route-to-host/42757/5 "2016-02-26T19:51:03Z")

</div>

```auto
telnet 172.31.32.169 5044
Trying 172.31.32.169...
telnet: Unable to connect to remote host: No route to host

```

it's on aws ec2  
and thanks for quick reply

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [February 26, 2016, 9:34pm UTC](https://discuss.elastic.co/t/2016-02-25-17-37-08-496727-transport-go-125-err-ssl-client-failed-to-connect-with-dial-tcp-172-31-31-169-5044-getsockopt-no-route-to-host/42757/6 "2016-02-26T21:34:10Z")

</div>

So there's your problem, it could be a security group thing, so start there.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 5, 2017, 9:55pm UTC](https://discuss.elastic.co/t/2016-02-25-17-37-08-496727-transport-go-125-err-ssl-client-failed-to-connect-with-dial-tcp-172-31-31-169-5044-getsockopt-no-route-to-host/42757/7 "2017-07-05T21:55:20Z")

</div>


