# 3-Node cluster setup

**URL:** https://discuss.elastic.co/t/3-node-cluster-setup/322420
**Category:** Elasticsearch
**Tags:** elastic-stack-security
**Created:** [January 4, 2023, 4:41am UTC](https://discuss.elastic.co/t/3-node-cluster-setup/322420 "2023-01-04T04:41:28Z")
**Posts on this page:** 6
**Page:** 1

<div class="post-metadata">

### Author: ![Sandeepa\_Kariyawasam](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sandeepa_kariyawasam/32/115517_2.png) [@Sandeepa\_Kariyawasam](https://discuss.elastic.co/u/Sandeepa_Kariyawasam)
#### Post date: [January 4, 2023, 4:41am UTC](https://discuss.elastic.co/t/3-node-cluster-setup/322420/1 "2023-01-04T04:41:28Z")

</div>

I have created a Elasticsearch node with enrolment token configured. Now I'm trying to attach two other nodes to the running node as a cluster. It gave this error,

```auto
This node will be reconfigured to join an existing cluster, using the enrollment token that you provided.
This operation will overwrite the existing configuration. Specifically: 
  - Security auto configuration will be removed from elasticsearch.yml
  - The [certs] config directory will be removed
  - Security auto configuration related secure settings will be removed from the elasticsearch.keystore
Do you want to continue with the reconfiguration process [y/N] y
Unable to communicate with the node on https://ip:9200/_security/enroll/node. Error was No route to host
ERROR: Aborting enrolling to cluster. Could not communicate with the node on any of the addresses from the enrollment token. All of [ip:9200] were attempted.

```

After this, all attempts to connect this node to cluster ends in failure, with this error

```auto
ERROR: Aborting enrolling to cluster. This node doesn't appear to be auto-configured for security. Expected configuration is missing from elasticsearch.yml.

```

Is there any way I can connect this node without reinstalling elasticsearch ?

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [January 4, 2023, 7:06am UTC](https://discuss.elastic.co/t/3-node-cluster-setup/322420/2 "2023-01-04T07:06:11Z")

</div>

Welcome to our community! 😃

> [@Sandeepa\_Kariyawasam](#):
>
> `No route to host`

This suggests that you may have networking issues. Can you curl the existing cluster from the new node?

---

<div class="post-metadata">

### Author: ![Sandeepa\_Kariyawasam](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sandeepa_kariyawasam/32/115517_2.png) [@Sandeepa\_Kariyawasam](https://discuss.elastic.co/u/Sandeepa_Kariyawasam)
#### Post date: [January 4, 2023, 1:26pm UTC](https://discuss.elastic.co/t/3-node-cluster-setup/322420/3 "2023-01-04T13:26:33Z")

</div>

network issues resolved. Now the error says I don't have security configured. Do I need to reinstall elasticsearch ?

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [January 4, 2023, 7:56pm UTC](https://discuss.elastic.co/t/3-node-cluster-setup/322420/4 "2023-01-04T19:56:14Z")

</div>

Please share the error.

---

<div class="post-metadata">

### Author: ![TimV](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/timv/32/13162_2.png) [@TimV](https://discuss.elastic.co/u/TimV)
#### Post date: [January 5, 2023, 5:06am UTC](https://discuss.elastic.co/t/3-node-cluster-setup/322420/5 "2023-01-05T05:06:15Z")

</div>

> [@Sandeepa\_Kariyawasam](#):
>
> After this, all attempts to connect this node to cluster ends in failure, with this error

What is the exact command you are running here?

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [February 2, 2023, 5:06am UTC](https://discuss.elastic.co/t/3-node-cluster-setup/322420/6 "2023-02-02T05:06:57Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
