# 5.0.0-rc1 Setting network.host \<NIC IP\> fails

**URL:** <https://discuss.elastic.co/t/5-0-0-rc1-setting-network-host-nic-ip-fails/62833>\
**Category:** Elasticsearch\
**Created:** [October 12, 2016, 4:06pm UTC](https://discuss.elastic.co/t/5-0-0-rc1-setting-network-host-nic-ip-fails/62833 "2016-10-12T16:06:50Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![red888](https://avatars.discourse-cdn.com/v4/letter/r/ecae2f/32.png) [@red888](https://discuss.elastic.co/u/red888)\
**Post date:** [October 12, 2016, 4:06pm UTC](https://discuss.elastic.co/t/5-0-0-rc1-setting-network-host-nic-ip-fails/62833/1 "2016-10-12T16:06:50Z")

</div>

If I go into /etc/elasticsearch/elasticsearch.yml, set network.host to IP of the nic on the server, and restart the service it will not start:

```
[root@centos-7 ~]# systemctl status elasticsearch -l
● elasticsearch.service - Elasticsearch
   Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; disabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Wed 2016-10-12 12:00:30 EDT; 5min ago
     Docs: http://www.elastic.co
  Process: 4388 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -p ${PID_DIR}/elasticsearch.pid --quiet -Edefault.path.logs=${LOG_DIR} -Edefault.path.data=${DATA_DIR} -Edefault.path.conf=${CONF_DIR} (code=exited, status=78)
  Process: 4386 ExecStartPre=/usr/share/elasticsearch/bin/elasticsearch-systemd-pre-exec (code=exited, status=0/SUCCESS)
 Main PID: 4388 (code=exited, status=78)

Oct 12 12:00:18 centos-7.lab.local systemd[1]: Starting Elasticsearch...
Oct 12 12:00:18 centos-7.lab.local systemd[1]: Started Elasticsearch.
Oct 12 12:00:30 centos-7.lab.local systemd[1]: elasticsearch.service: main process exited, code=exited, status=78/n/a
Oct 12 12:00:30 centos-7.lab.local systemd[1]: Unit elasticsearch.service entered failed state.
Oct 12 12:00:30 centos-7.lab.local systemd[1]: elasticsearch.service failed.
```

---

<div class="post-metadata">

**Author:** ![Anantha\_Ravi](https://avatars.discourse-cdn.com/v4/letter/a/eb8c5e/32.png) [@Anantha\_Ravi](https://discuss.elastic.co/u/Anantha_Ravi)\
**Post date:** [November 3, 2016, 7:45pm UTC](https://discuss.elastic.co/t/5-0-0-rc1-setting-network-host-nic-ip-fails/62833/2 "2016-11-03T19:45:42Z")

</div>

I am also running into s ame issue . this is with elasticsearch 5.x on Centos 7 .

please share if you were able to make it work .

---

<div class="post-metadata">

**Author:** ![red888](https://avatars.discourse-cdn.com/v4/letter/r/ecae2f/32.png) [@red888](https://discuss.elastic.co/u/red888)\
**Post date:** [November 3, 2016, 7:58pm UTC](https://discuss.elastic.co/t/5-0-0-rc1-setting-network-host-nic-ip-fails/62833/3 "2016-11-03T19:58:37Z")

</div>

I gave up and used an older version, but now I want to try the 5.x GA release, will see if I run into this issue again.

Surprised nobody responded to this.

---

<div class="post-metadata">

**Author:** ![az-es](https://avatars.discourse-cdn.com/v4/letter/a/35a633/32.png) [@az-es](https://discuss.elastic.co/u/az-es)\
**Post date:** [December 14, 2016, 7:50pm UTC](https://discuss.elastic.co/t/5-0-0-rc1-setting-network-host-nic-ip-fails/62833/4 "2016-12-14T19:50:42Z")

</div>

Check you /var/log/elasticsearch/elasticsearch.log  
for something like  
"  
bootstrap checks failed  
initial heap size [XXXXXXX] not equal to maximum heap size [YYYYYY]; this can cause resize pauses and prevents mlockall from locking the entire heap  
"  
It seems strange at first look how external net iface relate with mem heaps , but I found explanation here

> <https://github.com/elastic/elasticsearch/issues/18462>

Hope it will be useful...

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 5, 2017, 10:04pm UTC](https://discuss.elastic.co/t/5-0-0-rc1-setting-network-host-nic-ip-fails/62833/5 "2017-07-05T22:04:57Z")

</div>


